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内容提要 

Altium Designer 6是 Ahium公司推出的最新的板级电路设计系统，它完美地综合了原理

图绘制、电路仿真、PCB设计、设计规则检查、FPGA及逻辑器件设计等功能，为用户提供

了全面的设计解决方案。 

本书共十章，深入浅出地介绍了在 Altium Designer 6平台下进行原理图设计以及 PCB

板设计的具体方法。本书适合于 Altium Designer 6的初学者、有一定 Protel早期版本使用经

验的用户、从事电子线路设计的科技人员，同时也是理工科各专业学习电路设计的本科生、

研究生必不可少的参考书。 

 本书的相关代码可在 http://www.kylinx.com/books/ad6/index.htm免费下载。 
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前 言 

2006年初，原 Protel软件的开发商 Altium 公司推出了 Protel系列的更新版本 Altium 

Designer 6.0，目前其最新版本为 6.7。Altium Designer 6.x是一个一体化的电子产品开发系统，

作为 Protel系列软件的更新换代产品，Altium Designer 6是目前唯一一款能实现所有电路板

级设计功能的软件。Altium Designer 6将设计流程、集成化 PCB 设计、可编程器件（如 FPGA）

设计和基于处理器设计的嵌入式软件开发功能整合在一起，具备同时进行 PCB和 FPGA设

计以及嵌入式设计的能力，能实现将设计方案从概念转变为最终成品所需的全部功能。 

在国内 Protel系列软件已经拥有大量的用户群，Protel软件已成为国内电子设计人员必

须掌握的基础工具之一。作为 Protel系列软件的最新版本，Altium Designer 6能为用户提供

了全线的设计解决方案。 

本书以大量实例为主线，介绍在 Altium Designer 6平台下，进行原理图设计以及 PCB

板设计的具体方法，全书共 10章，其中： 

第 1 章为 Altium Designer 6的基础知识，介绍 Protel 系列软件的发展历史，Altium 

Designer 6软件的安装步骤，界面简介以及系统环境的设置步骤，读完该章后，读者对 Altium 

Designer 6平台有一定的直观了解，消除新手对于 Altium Designer 6平台使用的陌生感； 

第 2章至第 6章介绍了电路原理图设计系统，包括原理图图纸的设置，各图元对象的布

置，各种报表的生成和原理图的输出、原理图元件库的创建和管理以及原理图仿真等。介绍

方式以实例为主，针对任务介绍详细步骤，在阅读的同时如果能同时完成实例中的步骤，读

者将会掌握在 Altium Designer 6平台完成电路原理图设计的方法，具有独立设计电路原理图

并按照要求输出文档能力。 

第 7章至第 10章详细介绍了 PCB（印制电路板）的设计方法，内容包括印制电路板的

设计基础、印制电路板的设计制作方法步骤、PCB 图生成各种报表文件、PCB 图的输出、

PCB图的设计规则 PCB元器件封装库的创建与管理等。介绍方式以实例为主，针对任务介

绍详细步骤，在阅读的同时如果能同时完成实例中的步骤，将能很快掌握 PCB板图设计的

方法，成为一个能独立完成电路设计、PCB板设计任务的电路设计工程人员。 

本书作者均为长期从事 EDA 技术教学的高校教师，由李珩主编，参加编写的人员有张

家祥、宋文峰、邢克飞、韩超、王志勇、阮坚、王鹏、邓波、高宏伟、刘东、张雄明、潘海

龙\史明宇、严虎等。在编写过程中，编者参阅了许多同行专家的编著文献，在此一并真诚

致谢。限于编者水平，疏误之处敬请批评指正。 

 

编者     

二〇〇七年  九月 
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第 1章  Altium Designer 6软件简介 

本章将简要介绍 Altium Designer 6的基础知识，包括其前身 Protel 系列软件的发展历

史、Altium Designer 6的安装步骤、Altium Designer 6的系统界面及环境的设置方法。 

1.1  Altium Designer 6简介 

随着电子制造技术的飞速发展，各大电子器件不断推陈出新，电子器件日益大规模化、

高密度化和小型化。电子产品对于速度、容量、体积和重量等技术指标的要求不断提高，传

统的手工设计越来越难以适应市场发展的需要。因此，越来越多的设计人员使用一些快速、

高效的 CAD 设计软件来进行辅助电路原理图、PCB图的设计，打印各种报表，控制电路板

的生产，电路设计在方法和手段上发生了革命性的变化。为提高设计效率，人们进而提出了

智能型 EDA（Electronics Design Automation）即电子设计自动化的概念，并开发了相应的

EDA 工具软件。这种工具软件可以根据系统的行为和功能要求，自动地逐层完成电子产品

设计的全过程，包括原理图和语言输入、检查错误和仿真验证、PCB 设计、信号分析和规

则检查以及生成 CAM 文件等。 

2006年初，原Protel软件的开发商 Altium 公司推出了Protel系列的最新高端版本 Altium 

Designer 6.0，目前其最新版本为 6.7。Altium Designer 6.x是一个一体化的电子产品开发系统，

是目前唯一一款能实现所有电路板级设计功能的软件。Altium Designer 6 将设计流程、集成

化 PCB 设计、可编程器件（如 FPGA）设计和基于处理器设计的嵌入式软件开发功能整合

在一起，具备同时进行 PCB和 FPGA设计以及嵌入式设计的能力，能实现将设计方案从概

念转变为最终成品所需的全部功能。 

Altium Designer 6除了全面继承包括 99SE，Protel DXP在内的先前一系列版本的功能和

优点以外，还增加了许多改进和很多高端功能。该平台拓宽了板级设计的传统界限，全面集

成了 FPGA设计功能和 SOPC设计实现功能，从而允许工程师能将系统设计中的 FPGA与

PCB设计以及嵌入式设计集成在一起。 

Altium Designer 6以强大的设计输入功能为特点，在 FPGA和板级设计中，同时支持原

理图输入和 HDL 硬件描述输入模式；同时支持基于 VHDL 的设计仿真，混合信号电路仿真、

布局前/后信号完整性分析。Altium Designer 6的布局布线采用完全规则驱动模式，并且在

PCB布线中采用了无网格的 SitusTM拓扑逻辑自动布线功能，将完整的 CAM 输出功能的编

辑结合在一起。 

1.2  Altium Designer 6的系统需求与安装 

1.2.1系统需求 

由于综合了 FPGA设计和嵌入式系统软件设计（包含使用基于 FPGA技术的处理器的

嵌入式系统软件）功能，Altium Designer 6的系统需求较以往的版本更高。 

Altium 公司推荐的系统配置为： 
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● WindowsXP（专业版或家庭版）、Windows2000专业版。 

● 至少 1.8G Hz处理器。 

● 至少 1GB内存。 

● 至少 2GB硬盘空间。 

● 显示器至少 1024×768屏幕分辨率，32位真彩色，32MB 显存。 

1.2.2系统安装 

Altium Designer 6的安装过程与其它软件类似，其具体步骤如下。 

（1）打开安装盘，双击“setup”目录下的“setup.exe”文件，弹出如图 1.1 所示的安

装向导欢迎窗口。 

 

图 1.1  安装向导欢迎窗口 

（2）单击安装向导欢迎窗口的“Next”按钮，显示如图 1.2所示的“License Agreement”

视图。 

 

图 1.2  “License Agreement”视图 

（3）选择“License Agreement”视图中的“I accept the license agreement”单选项，同

意该协议，单击“Next”按钮，显示如图 1.3所示的“User Information”视图。 
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图 1.3  “User Information”视图 

（4）在“User Information”视图中的“Full Name”编辑框内输入用户名称，在

“Organization”编辑框内输入单位名称，在使用权限选项中选择使用权限的范围：“Anyone 

who uses this computer”单选项，表示这台计算机上的所有用户都能使用 Altium Designer 6，

“Only for me”单选项则表示只有在当前安装 Altium Designer 6的用户帐号下才能使用

Altium Designer 6软件。单击“Next”按钮，显示如图 1.4所示的“Destination Folder”视图。 

 

图 1.4  “Destination Folder”视图 

（5）在“Destination Folder”视图“Destination Folder”区域显示了即将安装 Altium 

Designer 6 的安装路径，若想更改安装路径，单击“Browse”按钮，打开如图 1.5所示的安

装路径选择对话框。 

 

图 1.5  安装路径选择对话框 

（6）在安装路径选择对话框中选择安装路径，单击“OK”按钮，确定安装路径，单击

“Destination Folder”视图中的“Next”按钮，打开如图 1.6 所示的“Ready to Install the 
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Application”视图。 

 

图 1.6  “Ready to Install the Application”视图 

（7）确定以上安装信息设定无误后，单击“Ready to Install the Application”视图中的

“Next”按钮开始安装，过程中，文件复制窗口内将显示操作过程和文件复制进度，以及安

装剩余时间等信息，如图 1.7所示。 

 

图 1.7  显示安装进度 

（8）文件复制完毕后，系统弹出安装完毕窗口，单击“Finish”按钮，结束安装。 

至此，Altium Designer 6的文件安装工作基本结束，但此时软件仍不能正常运行，需要

使用软件许可证文件或网络许可证将其激活，才能正常使用该软件。 

1.2.3 软件激活 

Altium Designer 6只有在启动后才能激活，Altium Designer 6的启动方式有如下两种。 

（1）单击计算机桌面下方的“开始”按钮，在弹出的启动菜单中选择“Altium Designer 

6”选项，即可启动 Altium Designer 6。或者在计算机桌面上选择“开始”->“程序（P）”

->“Altium Designer 6”->“Altium Designer 6”命令项，也可启动 Altium Designer 6，如图

1.8所示。 
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图 1.8  “开始”菜单中的“Altium Designer 6”启动选项 

激活前的 Altium Designer 6启动画面如图 1.9所示，其中的右上角显示“unlicensed”字

样，表示该软件尚未被激活。 

 

图 1.9  激活前的 Altium Designer 6启动画面 

启动后，Altium Designer 6将自动新建一个名为“Workspace1.DsnWrk”的工作台，此

时工具栏中的快捷按钮都处于不可用状态，系统自动打开如图 1.10 所示的“DXP Licenses 

management”页面，以红色显示“There are no active lincenses. Use the options to add or choose 

a license”，提示未找到激活许可证，要求用户设置或添加许可证以激活 Altium Designer 6。

添加许可证文件步骤如下。 
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图 1.10  未激活的 Altium Designer 6界面 

（1）在“DXP Licensing”栏内的“Licensing Mode”选项栏中选择软件许可证类型，

“Standalone”表示单机版软件许可证，“Network”表示网络版软件许可证。选择“Standalone”

选项，然后单击“Available License”区域内的“Add license file”超链接，打开如图 1.11所

示的“打开”对话框。 

 

图 1.11  “打开”对话框 

（2）在“打开”对话框中选择许可证文件“*.alf”文件，单击“打开”按钮，将许可

证文件添加到 Altium Designer 6系统中。 

添加许可证后，“DXP Licenses management”页面中“Licenses Mode”区域内的红色

提示消失了，“Available Licenses”区域内的 licenses列表中添加了一行许可证文件状态，

如图 1.12所示。工具栏中的快捷工具按钮被激活，处于可用状态。 
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图 1.12  “Available Licenses”区域 

（3）选择“Help”->“about”命令，打开如图 1.13所示的版本信息窗口。 

 

图 1.13  版本信息窗口 

版本信息窗口中显示了蓝色的“licensed to XXX”字样，表示该软件已被激活。 

1.3  初识 Altium Designer 6 

Altium Designer 6是 Altium 公司 Protel系列软件基于 Windows平台的最新产品, 是

Altium 公司总结了多年的技术研发成果，对 Protel99SE以及 Protel DXP不断修改、扩充新

设计模块和多次升级完善后的产物。Altium Designer 6是完全一体化电子产品开发系统的下

一个版本。Altium Designer 是将设计流程、集成化 PCB 设计、可编程器件（如 FPGA）设

计和基于处理器设计的嵌入式软件开发功能整合在一起的电子设计系统。  

1.3.1  Altium Designer 6软件界面简介 

Altium Designer 6软件默认启动后的工作界面如图1.14所示，该操作界面由系统主菜单、

浏览器工具栏、系统工具栏、工作区和工作区面板五大部分组成。 
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图 1.14  Altium Designer 6软件默认界面 

（1）系统主菜单 

系统主菜单位于 Altium Designer 6界面的上方左侧，启动 Altium Designer 6后，系统显

示 “DXP”、“File”、“View”、“Favorites”、“Project”、“Window”和“Help”

等基本操作菜单项，用户使用这些菜单项内的命令选项可以设置 Altium Designer 6中的系统

参数，新建各类项目文件，启动对应的设计模块。当设计模块被启动后，主菜单将会自动更

新，以匹配设计模块。 

（2）浏览器工具栏 

浏览器工具栏位于 Altium Designer 6界面的上方右侧，由浏览器地址编辑框、后退快捷

按钮 、前进快捷按钮 、回主页快捷按钮 和个人喜好快捷按钮 组成。其中，浏览

器地址编辑框用于显示当前工作区文件的地址；单击后退或前进快捷按钮可以根据浏览的次

序后退或前进，且通过单击按钮右侧的下拉列表按钮 ，打开浏览次序列表，用户还可以选

择重新打开用户在此之前或之后浏览过的页面；单击回主页快捷按钮 ，将系统默认主页；

单击个人喜好快捷按钮 ，可以将当前页面设置为个人喜好页面。 

（3）系统工具栏 

系统工具栏位于系统主菜单下方，由快捷工具按钮组成，单击该按钮等同于选择相应菜

单命令。 

（4）工作区 

工作区位于 Altium Designer 6界面的中间，是用户编辑各种文档的区域。在无编辑对象

打开的情况下，工作区将自动显示为系统默认主页，主页内列出了常用的任务命令，单击即

可快速启动相应工具模块。 

（5）工作区面板 

Protel DXP为用户提供了大量的工作区面板，如文件管理面板、项目管理面板、器件库

工作区 

工作面板 

工作区面

板标签 

系统主菜单 

工作区面

板标签 

系统工具栏 

浏览器

工具栏 
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面板等，分别位于 Altium Designer 6界面的左右两侧和下部。用户可以使用工作区面板右上

部分的小按钮移动、修改或修剪面板，单击相应的面板标签还可以显示、隐藏或切换工作面

板。 

1.3.3  Altium Designer 6的文件类型和服务组件 

Altium Designer 6中共有 PCB项目、FPGA项目、嵌入式系统项目和集成元件库 4种项

目类型。 

它们的图标和文件格式分别如下。 

PCB项目文件的后缀为.PrjPCB，该类文件的图标为  

FPGA项目文件的后缀为.PrjFpg，该类文件的图标为  

嵌入式系统项目文件的后缀为.PrjEmb，该类文件的图标为  

集成元件库文件的后缀为.LibPkg，该类文件的图标为  

在每种项目里都可以添加文件，除了集成元件库有一点特殊以外，其他 3个项目文件都

是存储项目中文件的相对路径，因此文件都比较小。在项目文件中可以任意添加各种类型的

设计文件，例如原理图文件、PCB文件，对于 FPGA项目还可以添加 VHDL 文件等。 

Projects面板中打开的项目文件可以生成一个项目组，因此也就有了项目组文件。它们

不必保存在同一路径下，可以方便打开、一次调用前次工作环境和工作文档。项目组的文件

格式为“*.PrjGap”。 

还有一些其他的文件类型可用于各种不同需要的设计任务中，它们的扩展名及文件类型

如下所示。 

原理图文件的扩展名为：*.SchDoc  

PCB文件的扩展名为：*.PcbDoc  

原理图元件库文件的扩展名为：*.SchLib  

PCB元件封装库文件的扩展名为：*.PcbLib  

VHDL 语言文件的扩展名为：*.Vhd  

VHDL TestBench文件的扩展名为：*.VHDTST  

VHDL 库文件的扩展名为：*.VHDLIB  

VHDL 模型文件的扩展名为：*.VHDMDL  

CUPL PLD文件的扩展名为：*.PLD  

C 语言源文件的扩展名为：*.C  

C++语言文件的扩展名为：*.CPP  

Delphi语言宏文件的扩展名为：*.pas或*.bas  

数据库链接文件的扩展名为：*.DBLink  

项目输出文件的扩展名为：*.OUTJOB  

CAM 文件的扩展名为：*.CAM  

电路仿真模型文件的扩展名为：*.MDL  

电路仿真网络表文件的扩展名为：*.Nsx  

电路仿真子电路模型文件的扩展名为：*.ckt  

EDIF文件（有 PCB和 VHDL 两种格式） 的扩展名为：*.EDIF  

EDIF库文件的扩展名为：*.EDIFLIB  

Protel的网络表文件的扩展名为：*.NET  

文本文件的扩展名为：*.Txt  

元件的信号完整性模型库文件的扩展名为：*.1ib  
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仿真的波形文件的扩展名为：*.sdf  

此外，Altium Designer 6还支持许多种第三方软件的文件格式，设计者可以利用菜单 File

下的 Import 命令来进行外部文件的交换。对于系统运行过程中产生的一些报告文件，则可

以使用通用的报表软件打开。 

Altium Designer 6为用户提供了许多服务组件，在启动 Altium Designer 6后，选择“DXP”

->“System info…”命令，打开了如图 1.15所示的“EDA Servers”对话框，显示系统支持

的服务组件。 

 

图 1.15  “EDA Servers”对话框 

Altium Designer 6内的服务组件名称及功能如下。 

ArngeCmp服务组件，该服务组件的功能是按照元件的封装形式排列板上的元件。 

AutoPlacer服务组件，该服务组件的功能是自动交互元件布局。 

CAMtastic服务组件，该服务组件的功能是对电路板的自动加工 CAM 文件进行

浏览、编辑。 

CompMake服务组件，该服务组件的功能是新建元件向导 

CoreBuilder服务组件，该服务组件的功能是进行 FPGA内核编译 

EditConstraints服务组件，该服务组件的功能是对设计规则和约束进行设置和修

改。 

EditEDIF服务组件，该服务组件的功能是对 EDIF文件进行编辑和修改。 

EditEmbedded服务组件，该服务组件的功能是编辑嵌入式系统的程序代码。 

EditScript服务组件，该服务组件的功能是编辑 Altium Designer 6的脚本文件。 
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EditSim服务组件，该服务组件的功能是对已由电路进行混合仿真。 

EditVHDL 服务组件，该服务组件的功能是编辑 VHDL 语言文件。 

FpgaFlow服务组件，该服务组件的功能是进行 LiveDesign管理。 

HelpAdvisor服务组件，该服务组件的功能是提供系统帮助功能。 

HSEdit服务组件，该服务组件的功能是编辑 PCB图中的过孔尺寸。 

IntegratedLibrary服务组件，该服务组件的功能是编辑管理集成元件库。 

LayerStackupAnalyzer服务组件，该服务组件的功能是分析多层板的 PCB板层堆

栈 

LoadPCADPCB服务组件，该服务组件的功能是导入 PCAD的原理图文件。 

 LogicAnalyser服务组件，该服务组件的功能是在仿真或调试时，进行信号逻辑

分析。 

MakeLib服务组件，该服务组件的功能是利用已有的设计提取元件库文件。 

PCB服务组件，该服务组件的功能是进行 PCB板设计。 

PCB3D服务组件，该服务组件的功能是 PCB三维视图的生成、浏览。 

PCBMaker服务组件，该服务组件提供 PCB板生成向导服务。 

Pdiflmporter服务组件，该服务组件提供 PDIF PCB文件的导入服务。 

Pin Swapper服务组件，该服务组件的功能是在进行 FPGA设计时，自动交换元

件引脚定义功能。 

Placer服务组件，该服务组件的功能是 PCB元件自动布局。 

PLD 服务组件，该服务组件的功能是 PLD 编译和仿真。 

 ReportGenerator服务组件，该服务组件的功能是自动生成设计报告。 

RouteCCT服务组件，该服务组件的功能是提供布线界面 

SavePCADPCB服务组件，该服务组件的功能是导出 PCAD2000格式的 PCB文

件。 
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Sch服务组件，该服务组件的功能是原理图编辑。 

SchDwgUtility服务组件，该服务组件的功能是导入/导出 AutoCAD 格式的 DWG

文件。 

ScriptingSystem服务组件，该服务组件的功能是脚本编辑。 

SignalIntegrity服务组件，该服务组件的功能是进行信号完整性分析。 

SIM 服务组件，该服务组件的功能是电路模型仿真。 

SimView服务组件，该服务组件的功能是显示仿真的结果波形。 

SpecctraIF服务组件，该服务组件的功能是 Specctra文件格式交互界面。 

Targets服务组件，该服务组件的功能是显示目标页面。 

TextEdit服务组件，该服务组件的功能是编辑文本文件。 

 Wave服务组件，该服务组件的功能是编辑和显示波形。 

WaveSim服务组件，该服务组件的功能是进行波形仿真 

 WorkSpaceManager服务组件，该服务组件的功能是项目管理 

以上的服务组件构成了 Altium Designer 6的系统，所有的系统功能均由这些服务组件完

成。 

1.4  Altium Designer 6的系统设置 

完成 Altium Designer 6安装，了解了系统的基本功能后，用户可对 Altium Designer 6的

系统环境参数进行设置，以适应自己的操作习惯。 

1.4.1  Altium Designer 6系统参数设置 

启动 Altium Designer 6后，在主菜单中选择 “DXP”->“Preferences”命令，打开如图

1.16所示的“Preferences”对话框。 
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图 1.16  “Preferences”对话框 

“Preferences”对话框由左右两部分组成，左侧是树型列表，显示所有的选项卡标题，

右侧是选项卡，显示左侧的树型列表中选中的选项设置页面内容。Altium Designer 6将绝大

部分的参数设置整合到一个“Preferences”对话框中，共包含 “System”（系统）、“Schematic”

（原理图编辑）、“FPGA”（FPGA设计）、“Version Control”（版本控制）、“Embedded 

System”（嵌入式系统设计）、“PCB Editor”（印刷电路板编辑器）、“Text Editor”（文

本编辑器）、“CAM Editor”（CAM 编辑器）和“Wave”（波形编辑器）共 9个选项组，

分别针对系统和 8个功能模块的设置。本节仅介绍有关系统设置的页面内容。 

在“System”选项组中共有 12个选项卡，分别是“General”通用选项页、“View”视

图选项页、“Altium Web Update”网络升级选项页、“Transparency”透明度选项页、“Navigation”

导航选项页、“Backup”备份选项页、“Project Panel”项目面板选项页、“File Types”文

件类型选项页、“New Document Default”新文档选项页、“File Locking”文件锁定选项页、

“Installed Libraries”已安装的库选项页和“Scripting System”描述系统选项页。这些选项

卡内的选项功能分别介绍如下。 

1.“General”选项卡 

“General”选项卡如图 1.17所示，该选项卡包含系统的常规功能选项，其具体意义如

下。 
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图 1.17  “General”选项卡 

1）“Startup”选项区域对系统启动过程进行设置，其中包含有三个复选项，介绍如下。 

“Reopen last Workspace”选项表示在下次启动 Altium Designer 6的时候，自动打开上

一次退出系统前的工作空间，加载关闭前的项目组，而对于以非项目状态打开的 Free 

Documents则不会自动加载。如果不选中此项，那么下次 Altium Designer 6启动时就不会加

载以前的项目组。 

“Open Home Page if no documents open”选项表示在启动 Altium Designer 6后，如果没

有文档打开，系统自动打开如图 1.18所示的 Altium Designer 6的系统主页。 

 

图 1.18  Altium Designer 6的系统主页 

“Show startup Screen”用于设置启动过程中显示如图 1.19所示的 DXP 的启动画面。 
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图 1.19  Altium Designer 6启动画面 

2）“Default Locations”区域用来设置系统默认的文件路径，包含两个编辑框，这些编

辑框的功能介绍如下。 

 “Document Path”编辑框用于设置系统打开或保存 Altium Designer 6相关的文档、项

目和项目组时的默认路径。系统默认的是保存有安装示例的目录，用户可以直接在编辑框中

输入需要设置的目录的路径，或者单击右侧的 按钮，打开“浏览文件夹”对话框，在该

对话框内指定一个已存在的文件夹，然后单击“确定”按钮即完成默认路径设置。一旦设定

好默认的文档路径，在使用 Altium Designer 6时，单击新建、打开或保存文件按钮后，系统

会直接打开设定的默认目录，为操作带来极大方便。 

“Library Path” 编辑框用于设置系统的元件库目录的路径，系统默认的是系统安装时

集成的元件库目录的路径，用户可对该路径进行修改。 

3）“System font”区域用于设定 Altium Designer 6系统内部的各种对话框的交互式文

本所使用的字体、字形及字号。只有 “System font”复选项被选中后，“Change”按钮才

被激活。单击“Change”按钮，在弹出的如图 1.20所示的“字体”对话框中设置字体、字

形和大小，最后单击“确定”按钮，更新系统字体。通常不建议用户更改系统字体，只有当

出现对话框的交互式文本显示不正常时才有必要更改。系统默认字体为常规 8号“MS Sans 

Serif”字体。 

 

图 1.20 “字体”对话框 

4）“General”选项区域用于设置较通用的选项，其中只有一个 “Monitor clipboard content 

within this application only”复选项，该选项用于设置 Altium Designer 6的剪贴板仅显示
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Altium Designer 6中的内容。 

5）“Localization”选项区域用于设置本地化选项，其中各选项的意义介绍如下。 

“Use Localization”复选项用于设置使用本地化功能。选用该选项后，该区域的其他三

个复选项将被激活，允许用户进行选择设置。 

单选项“Display localized dialogs”和“Display localized hints”用于设置使用本地对话

框或者使用本地化的提示，默认选择“Display localized dialogs”项。 

“Display localized menus”复选项用于设置显示本地化菜单。 

2.“View”选项卡 

“View”选项卡如图 1.21所示，该页面由设置系统视图显示的选项组成。 

 

图 1.21 “View”选项卡 

一、“Desktop”选项区域用于设置有关系统界面的选项，其中的选项的功能和意义如

下。 

“Autosave desktop”复选项用于设置自动保存桌面。 

“Restore open documents”复选项用于设置保存打开的文档，这些文档类型由

“Exclusions”编辑框指定。 

“Exclusions”编辑框用于指定自动保存的文档的类型，单击编辑框右侧的“…”按钮，

打开如图 1.22所示的“Select Document kinds”对话框。 
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图 1.22  “Select Document kinds”对话框 

在“Select Document kinds”对话框左侧的“Not selected”列表中选择文件类型，然后

单击 键，将所选择的文件类型传递到“Selected”列表中，使用 按钮可以将所有文件类

型全部转换到“Selected”列表中，同样可以通过 按钮或 按钮将已选择的文件类型从

“Selected”列表转移到“Not selected”列表中。当确认选择的文件类型后，单击“OK”按

钮即可。 

二、“Popup Panels”区域中选项用于设置工作面板的弹出情况，其中的选项功能和意

义介绍如下。 

“Popup delay”滑块用于设置工作面板的弹出延迟时间，即当从鼠标指针移动到工作面

板标签上开始，到工作面板弹出为止的时间，滑块越向右则设置的值越大。 

“Hide delay”滑块用于设置工作面板的隐藏延迟时间，即从鼠标指针移出工作面板范

围开始，到工作面板隐藏为止的时间，滑块越向右则设置的值越大。 

“Use animation”复选项用于设置面板弹出或隐藏的过程使用动画效果，选中该项后，

“Animation speed”滑块将被激活，该滑块用来调节动画的速度，若不想在面板显现或隐退

时显示动画，则应当取消该复选项。另外，当电脑硬件配置较低时，建议关闭“Use animation”

复选项。 

三、“Show Navigation Bar As”选项区域用于设置浏览导航栏的显示设置，其中“Build-in 

panel”和“Toolbar”单选项用于设置浏览导航栏的显示形式，“Build-in panel”项表示采用

如图 1.23所示的方式显示浏览导航栏。“Toolbar”项表示采用工具栏的形式显示浏览导航

栏，默认情况下选用“Toolbar”项。在选中“Toolbar”项后，复选项“Always Show Navigation 

Panel in Task View”被激活，选中该项后，导航面板将在任务视图中显示。 

 

图 1.23  “Build-in panel”方式显示的浏览导航栏 

四、“Favorites Panel”区域用于设置收藏夹面板的显示状态，其中“Keep 4x3 Aspect Ratio”

复选项表示保持收藏夹面板的长宽比为 4比 3，“Thumbnail X Size”编辑框用于设置收藏夹
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内的单个项目显示的 X 方向尺寸，“Thumbnail Y Size”编辑框用于设置收藏夹内的项目显

示的 Y 方向尺寸。 

五、“General”区域用于设定设计窗口的样式。其中的选项意义如下。 

“Show full path in title bar”复选项用于确定是否在窗口标题栏上显示当前正在编辑的

设计文档的完整路径，选中该项则显示文档的完整路径，否则只显示文档名。 

“Display shadows around menus，toolbars and panels”复选项用于设置在菜单、工具栏

以及面板的周围显示阴影，增加立体效果，选中将呈现阴影效果。若电脑硬件配置较低时，

建议取消阴影效果。 

“Emulate XP look under Windows 2000” 复选项用于设置在 Windows2000的操作系统

环境下，模拟显示在 Windows XP操作系统下的外观。 

“Hide floating panels on focus change” 复选项用于设置操作焦点转移时，自动隐藏浮

动面板。 

“Remember window for each document kind”复选项用于记忆每种文件类型的显示窗口。 

“Auto show symbol and model previews”复选项用于设置自动显示标志和模型预览。 

六、“Documents Bar”选项区域的选项用于设置工作区上方的文档栏的显示状态，各

选项的功能和意义介绍如下。 

“Group documents if need”复选项用于设置当空间不足时，分组显示文件名，以节约

文档栏的空间。选中该复选项后，其下方的单选项被激活，“By document kind”和“By project”

单选项用于设置文件分组的依据，“By document kind”项表示按照文件的类型分组，“By 

project”项表示按照文件所属的项目分组。 

“Use equal-width buttons”复选项用于设置使用同等的宽度来显示文件名，未选中该项

时，文档栏将根据文件名的长度决定其名称标签宽度。 

“Auto-hide the documents bar”复选项用于设置自动隐藏文档栏。 

“Multline documents bar”复选项用于设置显示多行文档栏。 

“Ctrl+Tab switches to the last active document”复选项用于设置使用“Ctrl+Tab”快捷键

切换到上一个活动的文档。 

“Close switches to the last active document”复选项用于设置当关闭当前文档时，系统自

动切换到上一个活动的文档。 

“Middle click closes document tab”复选项用于设置在文档栏的标签上单击鼠标中键关

闭文档。 

3.“Altium Web Update”选项卡 

“Altium Web Update”选项卡如图 1.24所示。该选项卡由设定自动网络升级的选项组

成。 
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图 1.24  “Altium Web Update”选项卡 

一、“Select source for updates”选项区域内的选项用于设置网络升级的文件来源，该选

项区域中有两个单选项，介绍如下。 

“URL”项表示从 Internet网上下载升级文件，用户可在选项下方的编辑框内输入网络

地址，默认为 Altium 公司的官方升级网址 http://www.altium.com/webupdate/； 

“Network path”项表示从本地网络下载升级文件，以实现局域网内的软件升级，用户

可以在该项下方的编辑框内输入局域网内的升级文件地址。 

“Explore”按钮用于设置下载的升级文件在本地电脑硬盘内保存的路径。 

二、“Automatic checking”区域用于设置自动查找新的升级文件的频率，用户可在“Check 

frequency”下拉列表中设置查询频率。 

4.“Transparency”选项卡 

“Transparency”选项卡如图 1.25所示。该选项卡内的选项主要设置浮动工具栏及对话

框的透明效果，其中选项的具体意义如下。 

 

图 1.25  “Transparency”选项卡 

一、“Transparent floating windows”复选项用于设定在调用一个交互式过程时，编辑器

工作区上的浮动工具栏及其他对话框是否以透明效果显示。 

二、“Dynamic transparency”复选项用于启用动态透明效果。“Highest transparency”

滑块和“Lowest transparency”滑块分别用于设定最高透明度和最低透明度，滑块越靠右值
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越大。“Distance factor”滑块用来设定透明度与光标距离浮动对象距离之间的参数关系，这

里的浮动对象可以是浮动工具栏、浮动对话框或浮动面板。 

5.“Navigation”选项卡 

“Transparency”选项卡如图 1.26所示。该选项卡内的选项主要用于设置导航面板，其

中的选项具体介绍如下。 

 

图 1.26 “Navigation”选项卡 

一、“Highlight Methods”选项区域用于设置通过导航面板选择图元对象后，工作区显

示图元对象强调显示的状态，“Zooming”复选项用于自动调整显示的比例，使选择的图元

对象最大化显示，“Selecting”复选项用于使导航面板中选择的图元对象处于已选中状态，

“Masking”复选项用于设置自动蒙板，将未选中的图元对象遮蔽起来，“Connective Graph”

复选项用于设置同时强调显示选中的图元对象的网络连接情况，选择该项后将激活“Include 

Power Parts”复选项，该项表示强调显示选中的图元对象的网络连接情况中包括电源元件。 

二、“Zoom Precision”选项区域用于设置自动缩放导航面板内选中的图元对象的程度，

通过拖动滑动条可以调整所放的比例，当向“Far”方向拖动时，图元显示比例减小，向“Close”

方向拖动时，图元显示比例增大。 

三、“Objects To Display”选项区域用于设置导航面板显示的图元对象内容，其中包括

七个选项，功能介绍如下。 

“Pins”复选项表示导航面板中显示器件引脚。 

“Net Labels”复选项表示导航面板中显示网络标签。 

“Ports”复选项表示导航面板中显示网络端口。 

“Sheet Entries”复选项表示在多图纸设计中，导航面板内显示页面端口。 

“Sheet Connectors” 复选项表示在多图纸设计中，导航面板内显示页面接口。 

“Sheet Symbols”复选项表示在多图纸设计中，导航面板内显示页面标志。 

“Graphical Lines”复选项表示导航面板内显示不具有电气意义的图线。 

6.“Backup”选项卡 

“Backup”选项卡如图 1.27所示，由文档备份设置选项组成。 
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图 1.27  “Backup”选项卡 

“Auto save every：”复选项用于设置自动保存文档的时间间隔，用户选中此项后，可

在其右侧的编辑框内输入间隔时间，单位是分钟。 

“Number of versions to keep”编辑框用于设置自动保存的文件的版本数，但自动保存

的次数高于版本数时，将自动覆盖最早的版本，当用户需要察看修改过程中的文件时，可以

打开较早的版本。 

“Path”编辑框用于设置自动保存文件的路径。 

7.“Project Panel”选项卡 

“Project Panel”选项卡如图 1.28所示，其中的选项用于设置“Project”面板的属性，

该属性页面由两部分组成，用户在“Categories”区域内选择项目面板的类别，在右侧的对

应类别区域内设定选中类别的状态信息。其中选项的功能和意义如下。 

 

图 1.28   “Project Panel”选项卡 

一、“General”区域用于设置“Projects”面板中的通用属性，其中选项的具体意义如

下。 

 “Show open/modified status”复选项用于设定在项目管理面板上显示设计文档被编辑、

保存或打开的状态。选中时将显示上述信息，默认值为启用状态。 

“Show VCS status”复选项用于设定是否在项目管理面板上显示设计文档版本控制系统

状态。 

“Show document position in project”复选项用于设定是否在项目管理面板上显示文档在

项目中的位置，用序号表示。 

“Show full path information in hint”复选项用于设定当光标指向项目管理面板的文档

时，是否在提示信息内显示文档的完整路径。 

“Show Grid”复选项用于设定在项目管理器面板上是否显示栅格。 

二、“File View”选项区域如图 1.29所示，该选项区域用于设置“Projects”面板中的

文件视图属性，其中选项的具体意义如下。 
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图 1.29  “File View”区域 

“Show Project Structure”复选项用于设置是否在项目管理器面板中显示项目结构。 

“Show Document Structure”复选项用于设置是否在文件面板中显示文件结构。 

三、“Structure View”选项区域如图 1.30所示，该选项区域用于设置“Projects”面板

中的结构视图属性，其中选项的具体意义如下。 

 

图 1.30  “Structure View”区域 

“Show Documents”复选项用于设置是否在项目管理器面板中显示文档名。 

“Show Sheet Symbol”复选项用于设置是否在项目管理器面板中显示页面标志。 

“Show Nexus Components”复选项用于设置是否在项目管理器面板中显示联结组件。 

四、“Sorting”选项区域如图 1.31所示，该选项区域用于设置“Projects”面板中的排

序属性，其中选项的具体意义如下。 

 

 

图 1.31  “Sorting”区域 

“Proiect order”单选项用于设置是否按照添加的先后顺序排列项目中文档。 

“Alphabetically”单选项用于设置是否按字母顺序排列项目中的文档。 

“Open／modified status”单选项用于设置是否按照已打开、正在编辑以及未打开等方

式排列项目中的文档， 

“VCS Status” 单选项用于设置是否按版本控制状态排列项目中的文档。 

当选中上述四个选项之一后，若再选中“Ascending”复选项，则项目中的文档将按升

序排列，否则，将按降序排列。 

五、“Grouping”选项区域如图 1.32所示，该区域内的选项用来设定项目中各文档分组
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形式，其中选项的具体意义如下。 

 

图 1.32  “Grouping”区域 

“Do not group”单选项用于取消项目中的文档分类管理功能。 

“By class”单选项表示按照类别进行管理项目中的文档，即各种设计文档及输出文档

算作一类，库文件算作另一类。 

“By document type”单选项表示按照文件类别进行文档分类管理，即所有的原理图文

档归为一类，所有的 PCB文档归为一类。 

六、“Default Expansion”区域如图 1.33所示，该区域用于定义项目管理器面板的默认

扩展状态。其中选项的具体意义如下。 

 

图 1.33  “Default Expansion”区域 

“Full contracted”选项表示项目管理器面板中的所有子面板都收缩。 

“Expanded one level”选项表示扩展项目管理器面板中的第一级子面板。 

“Source file expanded”选项表示仅扩展源文件面板。 

“Fully expanded”选项表示扩展所有的面板。 

七、“Single Click”选项区域如图 1.34所示，该区域用于定义在“Projects”面板内鼠

标单击的功能，其中选项的具体意义如下。 

 

图 1.34  “Single Click”区域 

“Does nothing”单选项用于设定屏蔽鼠标的单击动作，选中该选项后，用鼠标左键单

击项目管理面板上的某个文档图标，将不会引起任何动作。 

“Activates open documents” 单选项用于设置鼠标单击激活已打开文档的功能，选中该
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选项后，用鼠标左键单击项目管理面板上已处于打开状态的文档图标，就能够将该文档激活

（即显示在工作区的最前面）。 

“Opens and shows documents”选项用于设置鼠标单击打开文档的功能，选中该选项后，

用鼠标左键单击项目管理面板上未打开的文档图标时，该文档将被打开。 

8.“File Types”选项卡 

“File Types”选项卡如图 1.35所示，该选项卡主要用于设置默认使用 Altium Designer 6

打开的文件类型，一旦用户在文件类型列表中勾选某一扩展名的文件类型前的复选项，在计

算机中的同类型文件都将使用 Altium Designer 6进行浏览。 

 

图 1.35 “File Types”选项卡 

9.“New Document Default”选项卡 

“New Document Default”选项卡如图 1.36所示，该选项卡主要用于设置使用 Altium 

Designer 6新建的文件的初始状态和内容，如果用户将某一特定文件设置为该类型文件的新

建默认文件，之后使用 Altium Designer 6新建的所有该类型的文件的初始内容和初始设置都

与该文件相同。用户可在“New documents default”栏中设置各种类型的文件的新建默认文

件。 

 

tyw藏书



第 1 章  Altium Designer 6.x 软件简介 

 ·25·   

图 1.36  “New Document Default”选项卡 

10.“File Locking”选项卡 

“File Locking”选项卡如图 1.37所示，该选项卡主要用于设置文件锁定选项，具体介

绍如下。 

 

图 1.37  “File Locking”选项卡 

“Enable File Locking”复选项用于设置文件锁定，当选中“Enable File Locking”复选

项后，系统将在当前文件中添加文件所有者信息，这样可以限制对文件更改的权限，非文件

所有者将无法保存对文件的修改。当打开的文件是被锁定的文件时，在“Project”面板中对

应文件名称旁边将显示锁定标记，如果该文件属于当前用户所有，则该锁定标记为绿色，否

则为红色。 

“Enable File locking in File Output Directory”复选项用于设定文件输出目录下的文件或

子目录内的文件的锁定，该复选项只有在“Enable File locking”复选项选中后才被激活，当

选中该项后，文件输出目录下的文件或子目录内的文件也会被锁定。 

“Warning level for locked files during Open”下拉列表用于设定打开锁定文件时的警告

级别，“Warning level for locked files during Save”下拉列表用于设定保存锁定文件时的警告

级别，下拉列表中共有两个选项，其中“Warning in Dialog box”项表示使用对话框的方式

显示警告，“Warning in Message Panel”项表示在消息面板中显示警告。 

11.“Installed Libraries”选项卡 

“Installed Libraries”选项卡如图 1.38所示，该选项卡主要用于显示和设置系统加载的

各种元件库，该选项卡的使用将在接下来的章节中进行详细介绍。 
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图 1.38  “Installed Libraries”选项卡 

12“Scripting System”选项卡 

“Scripting System”选项卡如图 1.39所示，用于设置 Altium Designer 6当前的“Script”

项目，用户可以通过“Script”项目调用 Altium Designer 6的系统 API，在编辑的文件中实

现更多的功能。具体“Script”项目的编制技巧请参考相应的帮助文件。 

 

图 1.39  “Scripting System”选项卡 

为方便用户对设置进行管理，“Preference”提供了保存设置的功能，当完成设置后，

单击“Save”按钮，即可打开“Save”对话框，用户可将设置的内容保存到后缀名“.DXPprf”

的文件中，当需要更改设置时，只需要单击“Load”加载对应的设置文件即可。另外，通过

“Set to Defaults”按钮，用户可自动加载默认的设置。 

1.5  Altium Designer 6的界面自定义 

Altium Designer 6支持用户自定义设计界面，用户可以根据自己的操作习惯定制编辑器
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菜单条、工具栏和快捷操作面板等。所有的资源均由设计管理器管理，默认的资源设定存储

在一个名为“DXP.rcs”的文件中，本节将通过添加菜单命令实例介绍自定义界面的方法。 

（1）启动 Altium Designer 6，在主菜单中选择“DXP”->“Customize…”命令，打开

如图 1.40所示的“Customizing PickATask Editor”对话框。 

 

图 1.40  “Customizing PickATask Editor”对话框 

“Customizing PickATask Editor”对话框包含“Commands”和“Toolbars”两个选项卡，

其中“Commands”选项卡用于对菜单内的命令进行调整，“Toolbar”选项卡用于在界面中

添加完整菜单或工具栏。 

（2）在“Customizing PickATask Editor”对话框中单击“Commands”选项卡中的“New”

按钮，打开如图 1.41所示的“Edit Command”对话框。 

 

图 1.41  “Edit Command”对话框 

（3）单击“Edit Command”对话框的“Action”选项区域内的“Process”编辑框右侧

的“Browse”按钮，打开如图 1.42所示的“Process Browser”对话框。 
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图 1.42  “Process Browser”对话框 

（4）在“Process Browser”对话框中选择“Client：FullScreen”命令，单击“OK”按

钮，将该动作添加到“Edit Command”对话框的“Progress”编辑框中。 

（5）在“Edit Command”对话框的“Caption”区域内的“Caption”编辑框中输入新建

的命令项的名称“Full Screen”。在“Description”编辑框内输入对该命令的描述语言“全

屏”。 

（6）在“Edit Command”对话框的“Shortcut”区域内单击“Primary”下拉列表，在

弹出的列表中选择“Ctrl+F”作为新建命令的快捷键，然后单击“Edit Command”对话框中

的“OK”按钮，新建一个命令。 

（8）在“Customizing PickATask Editor”对话框的“Commands”列表中选择“Custom”

项，移动鼠标到右侧的“Commands”列表中新建的命令“Full Screen”上方，按下鼠标左

键，将其拖到主菜单“File”菜单栏中，如图 1.43所示。 

 

图 1.43  添加命令到菜单中 

至此，用户就在选中的菜单中添加了一个自定义的命令“Full Screen”，当选择该命令

时，Altium Designer 6将转换为全屏显示状态。
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第 2章  原理图设计基础 

原理图设计，顾名思义，就是在计算机辅助设计平台上使用原理图来表达电子电路的设

计者设计意图的过程。从电子设计辅助软件的角度来看，设计电路原理图的主要目的是通过

电路原理图这种形式，将设计者构想中的电路的结构模型输入辅助设计系统，使系统能了解

设计者设计的的电路连接关系，以便辅助设计者实现设计意图，生成能指导电路板生产的文

档。从表面上看，电路原理图设计的方法与传统的 CAD 绘图过程相似，都是将电路要素（元

件、连线等）的图形符号放到图纸上，使之变为设计记录。但是，使用 Altium Designer辅

助设计系统后，用户可以通过输入电路原理图将变成电路器件网络列表，通过网络列表，

Altium Designer将辅助用户完成检测电路性能以及生成 PCB版图的任务。 

本章将首先介绍 Altium Designer的原理图输入模块的操作界面，然后介绍常见的原理

图设计过程、项目管理以及图纸设定方法，最后介绍一个简单原理图设计实例。  

2.1 Altium Designer原理图编辑的操作界面介绍 

启动 Altium Designer后，系统并不会进入原理图编辑的操作界面，只有当用户新建或

打开一个 PCB项目中的原理图文件后，系统会进入原理图编辑的操作界面，其界面如图 2.1

所示。 

 

图 2.1  DXP Schematic Editor操作界面 

如图 2.1所示的 DXP Schematic Editor操作界面由工作区、主菜单、快捷工具栏、悬浮

窗口、活动面板等构成，具体介绍如下。 
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1.主菜单 

主菜单位于操作界面的上方。Altium Designer中的绝大部分操作均可通过在主菜单中选

择相应的命令实现。当用户对不同类型的文档进行操作时，主菜单的内容会自动更新，以适

应操作的需要。 

2.工具栏 

Altium Designer 为用户提供了多种快捷工具栏，这些工具栏中包含大量的快捷工具按

钮，用户可以自定义工具栏的显示或隐藏状态，使操作界面更适合操作的习惯，提高工作效

率。根据工具栏内工具按钮的功能，Altium Designer的工具栏分为“Schematic Standard”工

具栏、“Utility”工具栏、“Navigation”工具栏、“Formatting”工具栏和“Mixed Sim”工

具栏，具体介绍如下： 

一、“Schematic Standard”工具栏 

“Schematic Standard”工具栏如图 2.2所示，该工具栏为用户提供 23个最通用的操作

快捷命令按钮。在主菜单中选择“View”->“Toolbars”->“Schematic Standard”命令或在

当前工具栏上单击右键，然后在弹出的右键菜单中选择“Schematic Standard”都可以显示或

隐藏标准工具栏。 

 

图 2.2  “Schematic Standard”工具栏 

“Schematic Standard”工具栏中的快捷工具按钮功能如下： 

新建文件工具按钮 ：该快捷工具按钮用于新建新文件。 

打开文件工具按钮 ：该快捷工具按钮用于打开已有的文件。 

保存文件工具按钮 ：该快捷工具按钮用于保存当前工作区的文件。 

打印工具按钮 ：该快捷工具按钮用于打印当前工作区的文件。 

打印预览工具按钮 ：该快捷工具按钮用于对将打印文件进行预览。 

设备视图工具按钮 ：该快捷工具按钮用于开启设备视图，用户可以在该视图中操作连

接到计算机上的 FPGA配置设备。 

全景视图缩放工具按钮 ：该快捷工具按钮用于缩放当前工作区中的视图，使所有的

图元对象能在当前工作区中完整显示。 

区域缩放工具按钮 ：该快捷工具按钮用于放大用户选择区域的视图至整个工作区。 

选择缩放工具按钮 ：该快捷工具按钮用于放大或缩小用户选择的图元对象，使其占满

整个工作区。 

下划线缩放工具按钮 ：该快捷工具按钮用于放大或缩小用户用户标注了下划线的图元

对象，使其占满整个工作区。单击该工具按钮后，用户可在弹出的菜单中选择下划线的颜色。 

剪切工具按钮 ：该快捷工具按钮用于剪切选择的图元对象，将其保存到剪贴板中。 

复制工具按钮 ：该快捷工具按钮用于复制选择的图元对象，将其保存到剪贴板中。 

粘贴工具按钮 ：该快捷工具按钮用于将剪贴板中的当前内容粘贴到工作区。Altium 

Designer为用户提供了 24块剪贴板空间，单击粘贴工具按钮后，将粘贴最新的剪贴板内容。 

橡皮图章工具按钮 ：该快捷工具按钮用于橡皮图章操作，可将选中的图元对象多次复

制到用户指定的工作区位置。 

框选工具按钮 ：该快捷工具按钮用于进行连续框选操作。 
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移动工具按钮 ：该快捷工具按钮用于移动已选择的图元对象。 

取消选择工具按钮 ：该快捷工具按钮用于取消当前的所有图元对象的选择状态。 

清除滤镜工具按钮 ：该快捷工具按钮用于清除当前的滤镜状态，所有的图元对象将

被正常显示出来。 

撤销上步操作工具按钮 ：该快捷工具按钮用于撤销上一步的操作。 

恢复撤销的操作工具按钮 ：该快捷工具按钮用于恢复上一步撤销的操作。 

层次切换工具按钮 ：该快捷工具按钮用于在层次设计中切换设计层次。 

交叉探查工具按钮 ：该快捷工具按钮用于探查原理图中的元件对应的 PCB图。 

元件库浏览工具按钮 ：该快捷工具按钮用于浏览元件库。 

二、“Utility”工具栏 

“utilities”工具栏如图 2.3所示，该工具栏为用户提供了常用的的原理图绘制工具，该

工具栏由六个组合工具栏组成，这些工具栏具体介绍如下。 

 

图 2.3  “Utility”工具栏 

● 绘图工具  

单击绘图工具组按钮 ，打开如图 2.4所示的绘图工具栏，该工具栏主要用于在原理图

上绘制各种不具有电气意义的图形和文字，该工具栏中的工具按钮功能介绍如下。 

 

图 2.4  绘图工具栏 

直线工具按钮 ：该快捷工具按钮用于绘制直线。 

多变形工具按钮 ：该快捷工具按钮用于绘制内部填充的多变形。 

椭圆弧工具按钮 ：该快捷工具按钮用于绘制椭圆弧。 

贝赛尔曲线工具按钮 ：该快捷工具按钮用于绘制贝赛尔曲线。 

文本串工具按钮 ：该快捷工具按钮用于在工作取插入字符串。 

文本框工具按钮 ：该快捷工具按钮用于在工作取插入文本框。 

矩形工具按钮 ：该快捷工具按钮用于绘制填充矩形。 

圆角矩形工具按钮 ：该快捷工具按钮用于绘制填充的圆角矩形。 

椭圆工具按钮 ：该快捷工具按钮用于绘制填充的椭圆。 

扇形工具按钮 ：该快捷工具按钮用于绘制填充的扇形。 

插入图片工具按钮 ：该快捷工具按钮用于在工作区插入图片。 

● 对齐工具  

单击对齐工具按钮 ，打开如图 2.5所示的对齐工具栏，该工具栏主要用于自动对齐原

理图中所选择的元件，该工具栏中的工具按钮功能介绍如下。 
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图 2.5  对齐工具栏 

左对齐工具按钮 ：该快捷工具按钮用于使所选择的图元对象左侧边缘对齐。 

右对齐工具按钮 ：该快捷工具按钮用于使所选择的图元对象右侧边缘对齐。 

水平中心线对齐工具按钮 ：该快捷工具按钮用于使所选择的图元对象的水平中心线对

齐 

水平等间距工具按钮 ：该快捷工具按钮用于使所选择的图元对象的垂直中心线在水

平方向上的距离相等。 

顶部对齐工具按钮 ：该快捷工具按钮用于使所选择的图元对象的顶部边缘对齐。 

底部对齐工具按钮 ：该快捷工具按钮用于使所选择的图元对象的底部边缘对齐。 

垂直中心线对齐工具按钮 ：该快捷工具按钮用于使所选择的图元对象的垂直中心线对

齐。 

垂直等间距工具按钮 ：该快捷工具按钮用于使所选择的图元对象的水平中心线在垂

直方向上的距离相等。 

对齐网格工具按钮 ：该快捷工具按钮用于使所选择的图元对象对齐最近的网格。 

● 电源工具  

单击电源工具按钮 ，打开如图 2.6所示的电源工具栏，该工具栏主要用于在原理图中

放置各类电源标志，具体介绍如下。 

 

图 2.6 电源工具栏 

电源地工具按钮 ：该快捷工具按钮用于在工作区布置电源地标志。 

电源工具按钮 ：该快捷工具按钮用于在工作区布置电源标志。 

+12V电源工具按钮 ：该快捷工具按钮用于在工作区布置+12V电源标志。 

+5V 电源工具按钮 ：该快捷工具按钮用于在工作区布置+5V 电源标志。 

-5V 电源工具按钮 ：该快捷工具按钮用于在工作区布置-5V 电源标志。 

箭头式电源工具按钮 ：该快捷工具按钮用于在工作区布置箭头式电源标志。 

波式电源工具按钮 ：该快捷工具按钮用于在工作区布置波式电源标志。 

台式电源工具按钮 ：该快捷工具按钮用于在工作区布置台式电源标志。 

环形电源工具按钮 ：该快捷工具按钮用于在工作区布置环形电源标志。 

信号地工具按钮 ：该快捷工具按钮用于在工作区布置信号地标志。 
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地线工具按钮 ：该快捷工具按钮用于在工作区布置地线标志。 

● 数字电路器件工具  

单击数字电路器件工具按钮 ，弹出如图 2.7所示的数字电路工具栏，该工具栏用于在

原理图中放置各类常用的数字电路器件标志，具体介绍如下。 

 

图 2.7  数字电路器件工具栏 

电阻工具按钮 ：该快捷工具按钮用于在工作区布置电阻，阻值由工具按钮

右侧的数字决定，单位为Ω。 

电容工具按钮 ：该快捷工具按钮用于在工作区布置电容，电容的容量值由

工具按钮右侧的数字决定，单位为 uF。 

与非门工具按钮 ：该快捷工具按钮用于在工作区布置与非门器件 SN74F00D。 

或非门工具按钮 ：该快捷工具按钮用于在工作区布置与或门器件 SN74F02D。 

非门工具按钮 ：该快捷工具按钮用于在工作区布置非门器件 SN74F04D。 

与门工具按钮 ：该快捷工具按钮用于在工作区布置与门器件 SN74F08D。 

或门工具按钮 ：该快捷工具按钮用于在工作区布置或门器件 SN74F32D。 

三态门工具按钮 ：该快捷工具按钮用于在工作区布置三态门器件 SN74F126D。 

D 触发器工具按钮 ：该快捷工具按钮用于在工作区布置 D 触发器器件 SN74F74D。 

异或门工具按钮 ：该快捷工具按钮用于在工作区布置异或门器件 SN74F86D。 

3-8译码器工具按钮 ：该快捷工具按钮用于在工作区布置 3-8译码器器件SN74F126D。 

8 位三态总线工具按钮 ：该快捷工具按钮用于在工作区布置 8 位三态总线控制器件

SN74F245DW。 

● 仿真信号源工具  

单击仿真信号源工具按钮 ，弹出如图 2.8所示的仿真信号源工具栏，该工具栏用于在

原理图中布置各类信号源标志，便于用户对设计进行仿真测试，具体介绍如下。 

 

图 2.8  仿真资源工具栏 

直流电压源工具按钮 ：该快捷工具按钮用于在工作区布置直流电压源，其电

压由工具按钮上部的数值决定，单位为“V”。 

正弦信号源工具按钮 ：该快捷工具按钮用于在工作区布置正弦波信号源，其

频率由工具按钮下方的数值决定，单位为“Hz”。 

脉冲信号源工具按钮 ：该快捷工具按钮用于在工作区布置脉冲信号源，其频

率由工具按钮下方的数值决定，单位为“Hz”。 

● 网格设置工具  

单击网格工具按钮 ，弹出如图 2.9所示的网格设置菜单，该菜单用于设置原理图中的
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对齐网格属性。各命令的功能介绍如下。 

 

图 2.9  网格设置菜单 

“Cycle Snap Grid”命令用于使鼠标指针对齐设定的限制网格，这样鼠标指针移动图元

对象时的移动位置就只能在设定的网格交叉点上。 

“Cycle Snap Grid（Reverse）”命令用于是鼠标对齐反向设定的限制网格，这样鼠标指

针移动图元对象时，位置就只能在设定的网格交叉点上。 

“Toggle Visible Grid”命令用于使工作区显示网格或隐藏网格。 

“Toggle Electrical Grid”命令用于使用或取消电气网格，使用电气网格可以使原理图布

线更加方便。 

“Set Snap Grid”命令用于设置对齐网格。 

3）Wiring 工具栏 

“Wiring”工具栏如图 2.10所示。该工具栏内的快捷按钮用于在原理图中放置元件和布

置导线。该工具栏中的快捷工具按钮的功能介绍如下。 

 

图 2.10  “Wiring”工具栏 

导线工具按钮 ：该快捷工具按钮用于在工作区布置导线，将两个电气引脚连接起来。 

总线工具按钮 ：该快捷工具按钮用于在工作区布置总线。 

总线引入线工具按钮 ：该快捷工具按钮用于在工作区布置 

网络节点标志工具按钮 ：该快捷工具按钮用于在工作区布置网络节点标志，在 Altium 

Designer中，具有相同的网络节点标志的两个或多个引脚被视为导通的引脚。 

电源地工具按钮 ：该快捷工具按钮用于在工作区布置电源地标志。 

电源工具按钮 ：该快捷工具按钮用于在工作区布置电源标志。 

元件工具按钮 ：该快捷工具按钮用于在工作区布置电子元件。 

图纸标志工具按钮 ：该快捷工具按钮用于在多图纸的层次化设计中，在工作区布置

底层设计图纸标志。 

图纸接口工具按钮 ：该快捷工具按钮用于在多图纸的层次化设计中，在图纸标志上布

置图纸的接口。 

电气端口工具按钮 ：该快捷工具按钮用于在工作区布置全局电气端口。 

免检工具按钮 ：该快捷工具按钮用于在工作区布置免检标志，在编译时，将不会检查

该端口是否有错误。 

4）“Formatting”工具栏 

“Format”工具栏如图 2.11所示，用于设置工作区的文字的颜色、大小和字体等格式，

选中文字后，该工具栏中的工具会自动被激活。 

 

tyw藏书



第 2 章  原理图设计基础 

 ·35·   

图 2.11  “Formatting”工具栏 

5）“Navigation”工具栏 

“Navigation”工具栏如图 2.12所示，用于进行网络资源浏览，Altium Designer是按照

浏览器的方式进行工作区管理的，浏览器工具栏中的地址编辑框可显示当前工作区的文件或

网页地址，用户可以通过在地址编辑框内输入地址浏览网页或文件。 

按照资源浏览顺序后退或前进，单击打开主页按钮 还能打开如图 2.13所示的主页资

源。 

 

图 2.12  “Navigation”工具栏 

 

图 2.13  Altium Designer的主页 

6）“Mixed Sim”工具栏 

“Mixed Sim”工具栏如图 2.14所示，该工具栏用于设置混合信号仿真。 

 

图 2.14  “Mixed Sim”工具栏 

开始仿真工具按钮 ：该快捷工具按钮用于启动仿真过程。 

仿真设置工具按钮 ：该快捷工具按钮用于设置仿真对象及参数。 

建立 XSPICE网表工具按钮 ：该快捷工具按钮用于创建 XSPICE仿真网表文件。 

3.悬浮窗口 

悬浮窗口工作区上方，显示原理图的全局信息，方便用户进行原理图视图调整、图元对

象编辑等操作。通过选择悬浮窗口下方的标签，悬浮窗口可显示于“Sheet”窗口、“SCH List”
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窗口和“SCH Inspector”窗口 

“Sheet”窗口如图 2.15所示，改窗口悬浮于工作区上方，用于调整工作区的文件视图

显示比例和位置，通过调整窗口中红色方框的大小和位置，用户可以在当前工作区显示原理

图中的任何局部范围。 

 

图 2.15  “Sheet”窗口 

“SCH List”窗口如图 2.16所示，用于显示和修改文件中用户设置的图元对象及其属性，

在该窗口上部有一个操作描述语句，用户可对该描述语句进行设置，可以从而在“SCH List”

窗口描述希望进行的操作。 

 

图 2.16  “SCH List”窗口 

“SCH Inspector”窗口如图 2.17所示，用于显示和修改文件中用户选择的图元对象的

属性。在该窗口上部有一个操作描述语句，用户可对该描述语句进行设置，选择特定的图元

对象进行修改。 
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图 2.17  “SCH Inspector”窗口 

4.弹出式面板 

默认状况下，弹出式面板位于 Altium Designer的工作界面左右端及下端，在未被激活

时，仅显示该面板标签，当单击面板标签后，工作面板将会弹出，如图 2.18 所示就是弹出

后的“File”工作面板，用户可在弹出的工作面板中选择需要进行的操作，操作完成后，一

旦操作焦点转移，面板又会自动隐藏。 

 

图 2.18  弹出的“File”工作面板 
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2.2  原理图设计流程 

电路原理图设计是 EDA 设计的基础，原理图设计的大致流程如图 2.19所示。 

 

图 2.19  原理图设计流程 

在 Altium Designer中进行原理图设计的具体步骤如下。 

一、新建 PCB项目及原理图文件 

Altium Designer中的设计是以项目为单位的，通常一个 PCB设计项目中包含原理图文

件和 PCB文件，在进行原理图设计前，需要创建一个 PCB设计项目，然后再在新建的 PCB

项目中添加空白原理图文档，当打开新建的原理图文档时，系统会自动进入原理图编辑界面。 

二、设置原理图编辑界面的系统参数和工作环境 

为适应不同用户的操作习惯，以及不同的项目的原理图格式需求，Altium Designer允许

用户设置原理图编辑界面的工作环境，例如设置网格的大小和类型以及鼠标指针类型等，其

中大多数参数都可以用系统默认值，但根据用户个人习惯来适当调整环境设置，将会给设计

者带来方便，显著提高设计效率。在对原理图编辑界面进行调整后，用户还需要对原理图的

图纸尺寸及版面进行设置，以满足图纸使用者的要求，图纸的格式、规格要根据实际情况进

行选择，良好的图纸格式会使图纸管理工作变得更加轻松。尤其是在一个项目中包含多张原

理图的时候。 

新建 PCB项目及原理图文件 

设置原理图环境参数 

放置元件 

设置元件连接关系 

编译 

项目 
修改原理图 

仿真 

验证 
修改原理图 

出现 
错误 

出现 
错误 

正确 

正确 

输出原理图报告 

保存文件，打印输出 
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三、布置元件并调整元件属性和布局 

这一步是原理图设计的关键，用户根据实际电路的需要，选择合适的电子元件，然后载

入包含所需元件的集成元件库，从元件库中提取元件放置到原理图的图纸上，同时还须设定

零件的标识、封装等属性。对于当前元件库中没有的元件，则可以自行定义。在布置元件时，

元件之间的位置要尽量合理，这样能减少原理图布线过程的工作量，提高原理图的可读性。 

四、原理图布线 

原理图布线就是利用“Wiring”工具栏中的连线工具将图纸上的独立元件用具有电气意

义的导线、符号连接起来，构成一个完整的原理图。 

五、检查、仿真、校对及线路调整 

当原理图绘制完成以后，用户还需要利用系统所提供的各种工具对项目进行编译，找出

原理图中的错误，进行修改，如有需要，也可以在绘制好的电路图中添加信号进行软件模拟

仿真，检验原理图的功能。 

六、输出报表，保存文件 

原理图校对结束后，用户可利用系统提供的各种报表生成服务模块创建各种报表，例如

网络列表、元件列表等。为后续的 PCB板设计做准备。获得报表输出后，保存原理图文档

或打印输出原理图，设计工作结束。 

2.3  项目管理 

在进行电路应用设计时，一个电子应用将涉及大量不同类型的文件，例如原理图文件、

PCB图文件、各种报表文件等等，如何有效的管理这些文件将是一件比较复杂的事情，Altium 

Designer提供了项目管理功能对文件进行管理，在 Altium Designer中一个应用设计有关的多

个文件被包含在一个项目中，而多个具有相似特征的项目被包含在一个工作空间中，用户的

设计是以项目为单元的，在进行原理图设计前需要新建项目、设置项目选项等操作，好的项

目设置会使设计的结构清晰明确，便于项目参与者理解，本节将介绍 Altium Designer中的

项目管理操作。 

2.3.1创建项目文档 

Altium Designer启动后会自动新建一个默认名为“Workspace1.DsnWrk”的设计空间，

用户可直接在该默认设计空间下创建项目，也可以自己新建设计空间。本节将一一介绍这些

操作的具体步骤。 

一、新建设计空间 

（1）双击桌面上的 Altium Designer图标，启动 Altium Designer。 

（2）在主菜单中选择“File”->“New”->“Design Workspace”命令，创建默认名称

为“Workspace1.DsnWrk”的设计空间。 

（3）选择“File”->“Save Design Workspace As…”命令，或者单击“Projects”工作

面板中的“Workspace”按钮，在如图 2.20所示的弹出菜单中，选择“Save Design Workspace 

As…”命令，打开如图 2.21所示的“Save[Workspace1.DsnWrk]As…”对话框。。 
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图 2.20  弹出菜单 

 

图 2.21“Save[Workspace1.DsnWrk]As…”对话框 

（4）在“Save[Workspace1.DsnWrk]As…”对话框的“文件名”编辑框内，输入设计空

间名称，本例中输入“ExampleWorkspace”，然后设置设计空间文件的保存路径，本例中使

用 系 统 的 默 认 路 径 ， 单 击 “ 保 存 ” 按 钮 ， 将 新 建 的 的 工 作 空 间 更 名 为

“ExampleWorkspace.DSNWRK”，并且保存了该设计空间文件。 

至此，设计空间已经自定义成功了。 

二、新建 PCB项目 

上一个例子中新建的设计空间下还没有任何项目，接下来的操作是在该设计空间内，添

加 PCB项目，其步骤如下。 

（1）启动“Altium Designer”在“Projects”工作面板中的设计空间下拉列表中选择新

建的名为“ExampleWorkspace.DSNWRK”的设计空间。 

（2）在主菜单中选择“File”->“New”->“Project”->“PCB Project”命令或者单击

“Project”工作面板上的“Project”按钮，在弹出的菜单中选择“Add New Project”->“PCB 

Project”命令，打开如图 2.22所示的“Select PCB Type”对话框。 
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图 2.22  “Select PCB Type”对话框 

（3）在“Select PCB Type”对话框中选择“Protel Pcb”项，单击“OK”按钮，新建一

个默认名称为“PCB_Project1.PrjPcb”的空白 PCB项目，如图 2.23所示。 

 

图 2.23  新建的空白 PCB项目 

（4）在主菜单中选择“File”->“Save Project As…”命令，或者单击“Projects”工作

面板中的“Project”按钮，然后在如图 2.24所示的弹出菜单中选择“Save Project As…”命

令，或打开“Save [PCB_Project1.PrjPcb]As”对话框。 

 

图 2.24  弹出菜单 

（5）在“Save [PCB_Project1.PrjPcb]As…”对话框的“文件名”编辑框中输入用户自

定义的项目文件名“ExamplePCB_Project”，单击“保存”按钮，将新建的 PCB 项目更名

为 “ExamplePCB_Project.PrjPcb”。 

（6）在主菜单中选择“File”->“Save Workspace”命令，保存对当前工作空间的修改。 

至此，在设计空间“ExampleWorkspace”下，新建了一个名为“ExamplePCB_Project”

的空白项目。 

三、添加已有项目 

Altium Designer允许用户在设计空间下，添加已存在的项目文件，步骤如下。 

（ 1 ） 启 动 “ Altium Designer” 在 “ Projects” 工 作 面 板 中 选 择 名 为
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“ExampleWorkspace.DSNWRK”的设计空间。 

（2）单击“Workspace”按钮，在弹出的菜单中选择“Add Existing Project…”命令，

打开“Choose Project to Open”对话框。 

（3）在“Choose Project to Open”对话框中选择需要添加到设计空间中的项目文件名，

然后单击“打开”按钮，即可将所选择的项目添加到设计空间中。 

（4）在主菜单中选择“File”->“Save Workspace”命令，保存对当前工作空间的修改。 

四、在项目中新建设计文件。 

（1）启动“Altium Designer”在“Projects”工作面板中的设计空间下拉列表中选择名

为“ExampleWorkspace.DSNWRK”的设计空间，然后在项目下拉列表中选择名为

“ExampPCB_Project.PrjPcb”的项目。 

（2）选择“File”->“New”->“Schematic”命令，或者单击“Project”按钮，在新建

的项目文件上单击右键，在弹出的菜单中选择“Add New to Project”->“Schematic”命令，

新建一个默认名为“Sheet1.SchDoc”的原理图文件，自动进入原理图编辑界面。 

（3）在主菜单中选择“File”->“Save As…”命令或者在“Projects”工作面板中的原

理图文件名称上单击右键，在如图 2.25所示的弹出菜单中，选择“Save As…”命令，打开

“Save [Sheet1.SchDoc]As…”对话框，在“Save [Sheet1.SchDoc]As…”对话框的“文件名”

编辑框中输入需要更改的文件名“ExampleSheet”，单击“保存”按钮。将文件更名为

“ExampleSheet.SchDoc”。 

 

图 2.25  弹出的菜单 

（4）在主菜单中选择“File”->“Save All”命令或者单击“Project”工作面板上的

“WorkSpace”按钮，在弹出的菜单中选择“Save All”命令，即可自动保存当前设计空间

下所有的更改。 

至此，在新建的“ExamplePCB_Project”的项目下新建了一个名为“Examplesheet.SchDoc”

的空白原理图文件，用户还可以在该项目下继续添加其它类型的文件，如 PCB文件、元件

库文件等等。 

在 Altium Designer中，用户的项目操作均在内存中进行，即新建的文件或者项目，在

被用户保存前，都储存在内存中，Altium Designer不会将这些文件自动写到磁盘上。因此，

如果设计者在新建项目文件后关闭该项目时未保存文件，那么这个文件将会自动从内存中释

放。 

为防止出现误操作，AltiumDesigner6.0提供了文件更改提醒功能，如果用户对设计空间、

项目或者文件进行了修改，在“Project”工作面板上的对应的“WorkSpace”编辑框和“Project”

编辑框中的当前设计空间名称和当前项目名称后都会出现一个“*”，表示该设计空间和项

目都已更改，但是未被保存，以此提醒用户保存。 

当用户在未保存对项目文件的更改的情况下，单击 AltiumDesigner6.0程序窗口右上角

的关闭按钮 时，会打开如图 2.26所示的“Confirm Save for（2） Modified Documents”对
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话框，提醒用户选择应该保存的对项目文件的更改，该对话框名称中的“（2）”表示有 2

个文档已被更改，需要保存。 

 

图 2.26  “Confirm Save for（2） Modified Documents”对话框 

在“Confirm Save for（2）Modified Documents”对话框中，“Save All”按钮用于设置

保存对话框中列出的所有文件，“Save None”按钮用于设置不保存对话框中列出的所有文

件，“Save Selectes”用于设置保存用户选择的文件，通过设置文件名称右侧的“Decision”

栏，用户可以设置该文件是否需要被保存， 表示保存对应文件， 表示

不保存对应文件。单击“OK”按钮，系统即会自动保存选中的文件，并关掉 Altium Designer。 

2.3.2  项目选项设置 

建立一个项目文件后，根据实际情况需要对项目的设置进行调整，本小节将介绍项目设

置的具体步骤，及部分常用项目设置选项的含义。 

（1）在主菜单中选择“Project”->“Project Options…”命令，打开如图 2.27所示的“Options 

for PCB Project ExamplePCB_Project.PrjPcb”对话框。 

 

图 2.27 “Options for PCB Project MyPCB_Prj1.PrjPcb”对话框 

（2）单击“Options for PCB Project ExamplePCB_Project.PrjPcb”对话框上部的“Options”

标签，打开如图 2.28所示的“Options”选项卡。 
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图 2.28  “Options”选项卡 

“Option”选项卡由五部分组成，分别介绍如下。 

1）“Output Path”编辑框内设置当前设计项目产生的输出文件的默认输出路径。 

2）“Output Options”选项区域包含文件输出选项，其中： 

“Open outputs after compile”表示系统在项目编译完成后会自动打开生成的文件。 

“Time stamp folder”复选项表示在生成的项目文件夹上注明日期和时间。 

“Use separate folder for each output type”复选项表示使用不同的文件夹保存生成的不同

类型的文件。 

“Archive project document”复选框表示自动存档打开的设计项目。 

3）“Netlist Options”选项区域包含网络列表选项，其中： 

“Allow Ports to Name Nets”复选项表示，与“Port”相连的电气网络中将使用“Port”

名称命名，而不是系统产生的网络名。 

“Allow Sheet Entries to Name Nets”复选项表示，与“SheetEntry”相连的电气网络将

使用“Sheet Entry”名称命名，而不是系统产生的网络名。 

“Append Sheet Numbers to Local Nets”复选项表示，电气网络名称将后缀该网络所在

的图纸的图纸编号。 

“Higher Level Names Take Priority”复选项表示，使用电气网络中最高级别的图元对象

名称命名网络。 

“Power Port Names Take Priority” 复选项表示，如果电气网络中含有电源标志，这一

电源标志名称命名网络。 

4）“Net ldentifier Scope”区域用于设置电气网络标志符的使用范围，其中的下拉列表

框内包含四个选项，“Automatic（Based On project contents）”项表示网络基于项目内容的

自动定义，“Flat”（Only Ports Global）项表示采用单层标志符，仅仅在全局端口定义，

“Hierarchy”（Sheet entry <->port connection）项表示使用分级标志符，“Global（Netlabels 

and ports global）”项表示使用全局网络标志符。  

5）“Allow Pin-Swapping Using These Methods”区域用于设置引脚替换的方法，其中： 

“Adding/Removing Net-Labels”项表示增减网络标签符号，以适应引脚替换。 

“Changing Schematic Pins”项表示更改原理图的引脚方式，以适应引脚替换。 

（4）在“Options”选项卡中选择需要的各项目选项，建议在“Output Option”选项区

域选中“Open outputs after compile”项、“Time stamp folder”项和“Use separate folder for each 
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output type”复选项；在“Netlist Options”选项区域选中“Allow Ports to Name Nets”项、

“Allow Sheet Entries to Name Nets”项和“Power Port Names Take Priority”项；在“Net 

ldentifier Scope”区域选择“Automatic（Based On project contents）”项；在“Allow Pin-Swapping 

Using These Methods”区域选择“Adding/Removing Net-Labels”项和“Changing Schematic 

Pins”项。 

（5）单击“OK”按钮，完成项目基本选项的设置。 

2.4  原理图工作环境设置 

Altium Designer的原理图绘制模块为用户提供了灵活的工作环境设置选项，这些选项和

参数主要集中在“Preferences”对话框内的“Schematic”选项组内，通过对这些选项和参数

的合理设置，可以使原理图绘制模块更能满足用户的操作习惯，有效提高绘图效率。具体设

置的方法如下。 

（1）启动 Altium Designer，打开上一节中创建的工作空间，系统自动打开工作空间中

的项目，进入原理图编辑界面，打开名称为“ExampleSheet.SchDoc”的空白原理图。 

（2）选择“Tools”->“Schematic Preferences”命令，打开如图 2.29所示的“Preferences”

对话框。 

 

图 2.29  “Preferences”对话框 

“Preferences”对话框中“Schematic”选项组中共有 11 个选项卡，分别用于设置原理

图绘制过程中的各类功能选项，下面分别介绍如下。 

2.4.1  “General”选项卡 

“General”选项卡如图 2.30所示，该选项卡主要用于原理图编辑过程中的通用项的设

置，按照选项功能细分，共分为 9个选项区域，其中各选项的介绍功能如下。 
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图 2.30  “General”选项卡 

一、“Options”区域 

“Options”区域用来设置原理图绘制过程中导线连接属性，包含 11个复选项，具体介

绍如下。 

“Drag Orthogonal”复选项用于设置当用户在保持元件原有电气连接的情况下，移动元

件位置时，系统自动调整导线保持直角；若未选中该选项，则导线之间将不再保持直角关系。 

“Optimize Wires&Buses”复选项用于设置自动优化连线，系统将自动删掉多余的或重

复连线。 

“Components Cut Wires”复选项用于设置元件自动断开导线功能，该选项只有在

“OptimizeWires&Buses”复选项已被选中的情况下才被激活。在选中此复选项后，将一个

元件布置到一根连续导线上，使这个元件的两个引脚同时与导线相连，则该元件两个引脚间

的导线段将被切除。如果未选中该复选项，系统不会自动切除连线夹在元件引脚中间的部分。

图 2.31所示为将一个电阻符号移动到一条导线上时，在选中“Components Cut Wires”复选

项前后的结果对比。 

                                 

            移动电阻前     未选中“Components Cut Wires”     选中“Components Cut Wires” 

图 2.31  选中“Components Cut Wires”复选项前后的区别 

“Enableln-PlaceEditing”复选项用于设置在原理图中直接编辑文本，选中该项后，用户

可通过在原理图中的文本上单击鼠标左键或使用快捷键 F2，直接进入文本编辑框，修改文

本内容，若未选中该复选项，则必须在文本所在图元对象的“Component Properties”对话框
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中修改文本内容。建议选中该复选项。 

“Ctrl+Double Click Opens Sheet”复选项用于设置在层次化的设计中打开文档的方式。

选中该复选项后，通过“Ctrl”键+双击对应文档符号的操作才能打开对应的原理图图纸。 

“Convert Cross Junction”复选项用于设置在所有的连线交叉处添加连接点符号，使交

叉的连线导通。 

“Displace Cross Over”复选项。选中该选项后，系统会采用横跨符号表示交叉而不导

通的连线。图 2.32所示为两条交叉而不导通的导线的不同表示图。 

         

未选中“Displace Cross Over”复选项   选中“Displace Cross Over”复选项 

图 2.32  选中“Displace Cross Over”复选项前后的区别 

“Pin Direction”复选项用于显示引脚上的信号流向。选中该选项后，原理图中定义了

信号流向的引脚将会通过三角肩头的方式显示该信号的流向。这样能避免原理图中元件引脚

间信号流向矛盾的错误出现。 

“Sheet Entry Direction”复选项用于在层次化的设计中，显示图纸连接端口的信号流向，

选中该选项后，原理图中的图纸连接端口将通过箭头的方式显示该端口的信号流向。这样能

避免原理图中电路模块间信号流向矛盾的错误出现。 

“Port Direction”复选项用于显示连接端口的信号流向，选中该选项后，电路端口将通

过箭头的方式显示该端口的信号流向。这样能避免原理图中信号流向矛盾的错误出现。 

“Unconnected Left to Right”复选项用于设置为连接的端口方向设置，该复选项只有在

“Port Direction”复选项选中后才有效，选中该复选项后，系统将自动把未连接的端口方向

设置为从左指向右。 

二、“Include with Clipboard and Prints”区域 

“Include with Clipboard and Prints”区域主要用来设置使用剪切板或打印时的属性。 

“No-ERCMarkers”复选项用于设置使用剪切板进行拷贝操作或打印时是否包含

“No-ERC”标记。选中该选项后，用户使用剪切板进行拷贝操作或打印时，将包含所选对

象的“No-ERC”标记；若未选中此项，复制或打印的操作，将不包含“No-ERC”标记。 

“ParameterSets”复选项用于设置使用剪切板进行拷贝操作或打印时是否包含对象的参

数设置。选中该复选项后，用户使用剪切板进行复制操作或打印时，对象的参数设置将随对

象被复制或打印；若未选中此项，复制或打印对象时，将不包括对象的参数。 

三、“Alpha Numeric Suffix”区域 

“Alpha Numeric Suffix”区域由两个单选项组成，主要用来设置集成的多单元器件的通

道标识后缀的类型。所谓多单元器件是指一个器件内集成多个功能单元，例如运放 LM358

就集成了两个独立的运算放大器单元，是一个两单元运放器件，或者一些大规模芯片，由于

引脚众多，通常也将其引脚分类，用多个单元来表示，以降低原理图的复杂程度。绘制电路

原理图时，常常将这些芯片内部的独立单元分开使用，为便于区别各单元，通常用“元件标

识号+后缀”的形式来标注其中某个部分。 

“Alpha”单选项用于设置英文字母组为各单元的后缀。 

“Numeric”单选项用于设置采用数字作为各单元的后缀。 
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“Alpha Numeric Suffix”区域中的选项是全局选项，一旦设定选项后，该选项将立即应

用到当前所有打开的原理图文档。 

四、“PinMargin”区域 

“PinMargin”区域用于设置元件符号标注的引脚名称、引脚号与元件符号边缘之间的

距离尺寸。该区域包含两个编辑框，分别介绍如下。 

“Name”编辑框用来设置元件标志中，引脚名称与元件符号边缘之间的距离，系统默

认该间距为 5mil。 

“Number”编辑框用来设置元件标志中，引脚的编号与元件边缘之间的距离，系统默

认该间距为 8mil。  

五、“Default Power Object Names”区域 

“Default Power Object Names”区域用于设置原理图中电源标志的默认网络标签。若该

区域块输入框为空，则原理图中电源的网络标签为空，用户需要手工在电源属性对话框内设

定。 

“PowerGround”编辑框用于设置电源地的默认网络名称，系统默认值为“GND”。 

“SignalGround”编辑框用于设置信号地的默认网络名称，系统默认值为“SGND”。 

“Earth”编辑框用于设置接地端标志的默认网络名称，系统默认值为“EARTH”。 

六、“Auto-Increment During Placement”区域 

“Auto-Increment During Placement”区域用来设置元件及引脚号自动标识过程中的序号

递增量。 

“Primary”编辑框用于设置在原理图上元件标识的自动递增量。默认为“1”，即用户

在连续放置同一种元件，例如电阻时，如果设置第一个电阻的标号是“R1”，则系统会自

动接下来布置的电阻标上“R2”、“R3”、…的元件标号。 

“Secondary”选项用来设定在创建原理图符号时，添加引脚过程中，引脚序号的递增

量，默认为“1”。 

七、“Default Template Name”区域 

“Default Template Name”区域用于设定默认的模板文件。用户可在“Template”编辑

框内输入原理图模版文件的路径，或单击“Browse”按钮，打开“打开”对话框，选择模版

文件。设定完成后，新建的原理图文件将自动套用设定的文件模板。该选项的默认值为“No 

Default Template File"，表示没有设定默认模板文件。如果需要取消缺省模板文档，可单击

“Clear”按钮，使编辑框内的值变为“No Default Template File”即可。 

八、“Document scope for filtering and selection”区域 

“Document scope for filtering and selection”区域用于设置选择图元对象、过滤图元对象

操作的应用范围，该区域中的下拉列表共有两个选项，“Current Document”项表示只在当

前文档范围内进行操作，“Open Documents”项表示在所有已打开的文档范围内进行操作。 

九、“Default Blank Sheet Size”区域 

“Default Blank Sheet Size”区域内的下拉列表用来设置默认空白文档的尺寸大小，默认

为“A4”，用户可在下拉列表中选择其他的标准尺寸。 

2.4.2  “Graphical Editing”选项卡 

“GraphicalEditing”选项卡如图 2.33 所示，该选项卡主要对原理图编辑中的图像编辑

属性进行设置，如鼠标指针类型、栅格、后退或重复操作次数等，具体介绍如下。 
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图 2.33  “GraphicalEditing”选项卡 

一、“Options”区域 

“Options”区域用于设定原理图文档的操作属性。 

“Clipboard Reference”复选项用于设置在剪贴板中使用的参考点，选中该项后，当用

户在进行复制和剪切操作时，系统会要求用户设制所选择图元对象复制到剪贴板时的参考

点。当把剪切板中的图元粘贴到电路图上时，将以参考点为基准。如果没有选择此项，进行

Copy和 Cut时系统不会要求指定参考点。 

“Add Template to Clipboard”复选项用于设置剪贴板中是否包含模版内容。选中该项后，

用户对图元进行复制或剪切操作，会将当前文档所使用的模板的相关内容一起复制到剪切

板。若未选中该复选项，用户可以直接将原理图复制到 Word文档。 

“Convert Special String”复选项。选中此项后，系统会将电路图中的特殊字符串转换

成它所代表的内容；若未选中，电路图中的特殊字符串将不进行转换。 

“Center of Object”复选项用于设置图元对象的中心点为操作的基准点，选中该项后，

当使用鼠标调整元件位置时，将以图元对象的中心点为操作的基准点。此时鼠标指针将自动

移到元件的中心点。 

“Object's Electrical Hotspot”复选项用于设置元件的电气热点作为操作的基准点，当选

中该项后，使用鼠标调整元件位置时，以元件离鼠标指针位置最近的热点，一般是元件的引

脚末端为基准点。 

“AutoZoom”复选项。选中该复选项后，当选中某元件时，系统会自动调整视图显示

比例，以最佳比例显示所选择的图元对象。 

“Single‘\’Negation”复选项用于设置，在原理图符号编辑时，以‘\’字符作为引脚

名取反的符号，选中该复选项后，在引脚“Name”前添加‘\’符号后，引脚名上方就显示

代表反值信号有效的短横杠，如图 2.34所示为一个“Name”项设置为“\RESET”的引脚在

选择“Single‘\’Negation”复选项前后的显示情况。 
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未选择“Single‘\’Negation”复选项      选择“Single‘\’Negation”复选项 

图 2.34  选择“Single‘\’Negation”复选项的显示效果 

“Double Click Runs Inspector”复选项用于设置在图元对象上双击后，打开“Inspector”

对话框。如未选中该复选项，则双击对象后将打开该对象的“Component Properties”对话框。 

“Confirm Selection Memory Clear”复选项用于设置在清除选择存储器时，显示确认消

息框。若选中该项，当用户单击存储器选择对话框的“Clear”按钮，欲清除选择存储器时，

将显示如图 2.35所示的“Confirm”消息框，请求确认。若未选中该项，在清除选择存储器

的内容时，将不会出现确认对话框，直接进行清除。建议选中该项，这样可以防止由于疏忽

而删掉己选存储器。 

 

图 2.35  “Confirm”消息框 

“Click Clears Selection”复选项用于设置通过单击原理图编辑窗口内的任意位置来清除

其他对象的选中状态。若未选中该复选项，单击原理图编辑窗口内已选中对象以外的任意位

置，只会增加已选取的对象，无法清除其他对象的选中状态。 

“Shift Click To Select”复选项用于指定需要在按住键盘“Shift”键，然后单击鼠标左

键才能选中的图元对象，选中该项后，该项右侧的“Primitives”按钮被激活，单击“Primitives”

按钮，打开如图 2.36所示的“Must Hold Shift To Select”对话框。在该对话框内的列表中勾

选图元对象类型对应的“Use Shift”栏，所有在“Must Hold Shift To Select”对话框中勾选

的图元对象类型都需要按住“Shift”键，然后单击鼠标才能被选中。 
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图 2.36 “Must Hold Shift To Select”对话框 

“Always Drag”复选项用于设置在移动具有电气意义的图元对象位置时，将保持图元

对象的电气连接状态，系统会自动调整导线的长度和形状。 

二、“Auto Pan Options”区域 

“Auto Pan Options”区域主要用于设置系统的视图自动移动功能。视图自动移动是指

在工作区无法完全显示当前的整幅图纸时，通过调整鼠标位置，调整视图显示的图纸区域，

以便用户能在显示比例不变的情况下对图纸的其它部分进行编辑。“Auto pan Options”区

域内各选项的功能和意义介绍如下。 

“Style”下拉列表用于设置视图自动移动的模式，该下拉列表中共有三个选项。 

“Auto Pan Off”项表示取消视图自动移动功能。 

“Auto Pan Fixed Jump”项表示按照“StepSize”编辑框和“ShiftSize”编辑框内的设置

值进行视图的自动移动。 

“Auto Pan ReCenter”项表示每次都将鼠标指针的位置设置为下一视图的中心位置，使

鼠标指针永远保持在视图的中心。 

“Speed”滑块用于设定自动摇景的移动的速度。滑块位置越靠右，自动摇景速度越快，

速度设置一定要适中。速度设置得过大，视图的移动速度太快，视图位置难以准确确定，速

度设置得过小，视图调整花费时间增加，降低了操作效率。 

“StepSize”编辑框用于设置视图每帧移动的步距。系统默认值为 30，即每帧移动 30

个像素点数。该项数值越大，图纸移动速度越快，但移动过程的跳动也越大，视图位置调整

的精确的程度越低。 

“ShiftStep”编辑框用于设置当按下“Shift”键时，每帧视图移动的距离。系统默认值

为 100，即按下“Shift”键，每次移动 100个像素点数。建议“Shift Step Size”选项所设数

值应与“Step Size”选项所设数值有较大的差别，以便用两种操作方式实现精确移动与快速

移动。 

三、“Undo/Redo”区域 

“Undo/Redo”区域用于设置可撤销或重复操作的次数。 

“StackSize”输入框内的数字用来设定操作存储堆栈的大小，即设定原理图编辑过程中

可以撤销或重复操作的次数。可撤销或重复的操作次数仅受系统内存容量的限制，设定的次

数越多，系统所需要的内存开销就越大，这样将会影响到编辑操作的速度。系统默认的堆栈
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深度为 50，即最多可以进行 50步操作的撤销或重复。 

“Group Undo”复选项用于设置将撤销的操作进行分组，可以以组为单位进行撤销操作。 

四、“Color Options”区域 

“Color Options”区域用于设定有关对象的颜色属性。 

“Selections”彩色条用来设定被选中对象边框的高亮显示颜色。鼠标单击“Selections”

彩色条，打开如图 2.37所示的颜色选择对话框。用户可以从该颜色选择款中选择合适颜色，

然后单击“OK”按钮确定。建议选择比较鲜艳的色彩，以便与普通对象有明显区别。系统

默认的色彩为亮绿色。 

 

图 2.37  “Choose Color”对话框 

五、“Cursor Grid Options”区域 

“Cursor Grid Options”区域用于定义鼠标指针的显示类型及可视栅格的类型。 

“CursorType”下拉列表用于设置对对象操作时的鼠标指针类型，其中共有四个选项。 

“LargeCursor 90”项将鼠标指针设置为由水平线和垂直线组成的 90°大鼠标指针，其

中的水平线和垂直线延伸到整个原理图文档。 

“SmallCursor90”项将鼠标指针设置为由水平线和垂直线组成的 90°小鼠标指针。 

“SmallCursor45”项将鼠标指针设置为由 45°线组成的小鼠标指针。 

“Tiny Cursor45” 项将鼠标指设置为由 45°线组成的更短更小的鼠标指针。 

这四种鼠标指针视图如图 2.38 所示。鼠标指针类型可根据个人习惯进行选择，系统默

认 “SmallCursor90”型的鼠标指针。这些鼠标指针只有在进行编辑活动（如放置或拖动图

元等）时才会显示，其他状态下鼠标指针为箭头类型 。 

       

      “LargeCursor 90”        “SmallCursor90”  “SmallCursor45”  “Tiny Custor45” 

图 2.38 四种不同的鼠标指针视图 
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2.4.3  “Mouse Wheel Configuration”选项卡 

“Mouse Wheel Configuration”选项卡如图 2.39所示，该选项卡用于设置鼠标滚轮的功

能，选项卡中的列表中共有两栏分别是实现的操作功能和使用的操作对应的按键设置，列表

中共列举了三种鼠标滚轮参与的操作，分别介绍如下。 

 

图 2.39  “Mouse Wheel Configuration”选项卡 

“Zoom Main Window”表示调整工作区的视图显示比例，默认是由“Ctrl”键与鼠标滚

轮共同实现，即按住键盘的“Ctrl”键，滚动鼠标滚轮即可调整工作区的视图显示比例。 

“Vertical Scroll”表示竖直方向移动视图，默认是通过滚动鼠标滚轮实现。 

“Horizontal Scroll”表示水平方向移动视图，默认是由“Shift”键与鼠标滚轮共同实现，

即按住键盘的“Shift”键，滚动鼠标滚轮即可水平移动视图。 

2.4.4  “Compiler”选项卡 

“Compiler”选项卡如图 2.40所示，该选项卡用于设置原理图编译属性，其中的选项介

绍如下。 

 

图 2.40  “Compiler”选项卡 
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一、“Errors & Warnings”列表 

“Errors & Warnings”列表用于设置编译错误或警告信息的显示属性，系统提供三种错

误或警告的级别，分别是“Fatal Error”致命错误、“Error”错误和“Warning”警告，用户

可在“Display”列中设置是否显示对应级别的错误或警告信息，在“Color”列中设置对应

级别的错误或警告信息的文本颜色。 

二、“Hints Display”选项区域 

“Hints Display”选项区域用于设置是否在鼠标移动到错误和警告发生区域的时候显示

错误或警告的提示信息。 

三、“Auto Junction”选项区域 

“Auto Junction”选项区域用于设置原理图中自动生成的电气连接点的属性，其中的选

项介绍如下。 

“Display On Wires”复选项用于设置显示导线上自动生成的电气连接点，选中该选项

后，电路原理图中显示导线上自动生成的电气连接点，同时该选项下方的“Size”和“Color”

选项将被激活，用于设置总线上电气连接点的尺寸和颜色。 

“Display On Buses” 复选项用于设置显示总线上自动生成的电气连接点，选中该选项

后，电路原理图中显示总线上自动生成的电气连接点，同时该选项下方的“Size”和“Color”

选项将被激活，用于设置总线上电气连接点的尺寸和颜色。 

四、“Manual Junctions Connection Status”选项区域 

“Manual Junctions Connection Status”选项区域用于设置原理图中手工布置的电气连接

点的属性，其中“Display”复选项用于设置显示手工布置的电气连接点，选中该选项后，

电路原理图中显示手工布置的电气连接点，同时该选项区域的“Size”和“Color”选项将被

激活，用于设置手工设置的连接点的尺寸和颜色。 

五、“Physical Name Expansion”选项区域 

“Physical Name Expansion”选项区域用于设置显示物理扩展名称的显示对象，通过选

择“Physical Name Expansion”选项区域的各类图元对象，使其显示对应的物理扩展名称。 

2.4.5  “Auto Focus”选项卡 

“Auto Focus”选项卡如图 2.41所示，该选项卡用于设定自动强调对象的属性，其中的

选项功能介绍如下。 

 

图 2.41  “Auto Focus”选项卡 

一、“Dim Unconnected Object”选项区域 
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“Dim Unconnected Object”选项区域设置与需要强调的图元对象没有连接关系的图元

对象的消隐选项，区域中的复选项用于设置触发消隐的动作，即当选中的对象执行选中的复

选项所表示的动作时，与其没有连接关系的其它图元对象会被消隐，以突出选中的对象。这

些复选项的意义介绍如下。 

“On Place”复选项表示当在布置图元对象时，系统自动消隐其他未与当前操作对象连

接的图元对象。 

“On Move”复选项表示当移动图元对象时，系统自动消隐其他未与当前操作对象连接

的图元对象。 

“On Edit Graphically”复选项表示当对图像进行编辑时，系统自动消隐其他未与当前

操作对象连接的图元对象。 

“On Edit In Place”复选项表示当对图元对象进行原地编辑时，系统自动消隐其他未与

当前操作对象连接的图元对象。 

“Dim Level”滑动条用于设置消隐的程度，滑块的位置越靠右，消隐程度越大，滑块

滑到最右侧，需要消隐的图元对象将完全隐藏。 

二、“Thicken Connected Object”选项区域 

“Thicken Connected Object”选项区域用于设置与当前操作的图元对象连接的图元对象

的加粗选项，区域中的复选项用于设置触发加粗的动作，即当选中的对象执行选中的复选项

所表示的动作时，与其有连接关系的其它图元对象会被加粗，以突出当前操作对象的连接关

系。复选项所代表的动作与“Dim Unconnected Object”选项区域中的复选项相同。 

“Delay”滑动条用于设置加粗状态持续的时间，滑块的位置越靠右，加粗状态持续时

间越长。 

三、“Zoom Connected Object”选项区域 

“Zoom Connected Object”选项区域用于设置与当前操作的图元对象连接的图元对象的

缩放选项，区域中的复选项用于设置触发加粗的动作，即当选中的对象执行选中的复选项所

表示的动作时，与其有连接关系的其它图元对象会被系统自动缩放到占满整个工作区，以突

出当前操作对象的连接关系。复选项所代表的动作与“Dim Unconnected Object”选项区域

中对应的同名复选项相同，当选择“On Edit In Place”复选项后将激活“Restrict to Non-net 

Objects Only”复选项，该复选项表示仅限于对没有网络属性的图元对象进行原地编辑时会

进行自动缩放。 

2.4.6  “Library AutoZoom”选项卡 

“Library AutoZoom”选项卡如图 2.42所示，该选项卡用于设置元件库中的元件显示的

自动缩放选项，该选项卡值有一个选项区域，该选项区域的选项功能介绍如下。 

 

图 2.42  “Library AutoZoom”选项卡 

“Do Not Change Zoom Between Components”单选项用于设置在进行元件库编辑时，各
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元件的显示比例相同，较大的元件将无法在工作区显示完全。 

“Remember Last Zoom For Each Component”单选项用于设置记忆每个元件在工作区的

上一次缩放状态。 

“Center Each Component In Editor”单选项用于设置将元件调整到工作区的中间位置，

并自动缩放至占满整个工作区的最佳比例，选中该选项后，“Zoom Precision”滑动条被激

活，该滑动条用于设置自动缩放的程度，滑块移动到最右侧，自动缩放的比例最大，元件将

被缩放到工作区能完全显示的最大程度，滑块越往左移动，元件显示的比例越小。 

2.4.7  “Grid”选项卡 

“Grid”选项卡如图 2.43所示，该选项卡用于设置原理图绘制界面中的网格选项，在进

行原理图绘制时，为了使元件的布置更加整齐，连线更加方便，Altium Designer提供了三种

网格，分别是“Snap Grid”、“Electrical Grid”和“Visible Grid”这三种网格的功能介绍如

下。 

 

图 2.43  “Grid”选项卡 

“Snap Grid”限置了鼠标在进行操作时的位置，使用“Snap Grid”网格功能后，在布

置或移动图元对象时，鼠标指针的位置将被限制在由“Snap Grid”定义的点阵上，这样能保

证对象位置整齐，给鼠标定位也带来了方便。 

“Electrical Grid”用于方便进行电气连接，使用“Electrical Grid”网格功能后，在进行

布置或调整导线连接过程中，鼠标指针不必准确的移到电气连接点处，只需要将鼠标移到该

电气接点所在的电气网格的范围内，系统会自动将鼠标指针定位到该电气连接点上。 

“Visible Grid”用于在工作区显示网格背景，方便用户定位、对齐元件。 

“Grid”选项卡中共有三个选项区域，其中选项的功能介绍如下。 

一、“Grid Options”选项区域 

“Grid Options”选项区域用于设置工作区显示的网格背景“Visible Grid”的属性，包

括网格显示的类型，网格的颜色。 

“Visible Grid”下拉列表用于设置工作区显示的网格背景“Visible Grid”的类型，Altium 

Designer提供两种网格类型，分别是“Line Grid”和“Dot Grid”。“Line Grid”由纵横交

叉的直线组成，“Dot Grid”由等间距排列的点阵组成，如图 2.44所示。 
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“Line Grid”   “Dot Grid” 

图 2.44  两种网格 

“Grid Color”颜色块用于设置网格的颜色，单击“Grid Color”颜色条，打开“Choose 

Color”对话框，选择需要显示的网格的颜色，建议网格的颜色不要设置得过于深，以免影

响原理图的绘制。 

二、“Imperial Grid Presets”区域用于设置当系统采用英制长度单位时，三种网格的预

置尺寸。单击该区域左侧的“Preset”按钮，选择网格的预置参数项。 

三、“Metric Grid Presets”区域用于设置当系统采用英制长度单位时，三种网格的预置

尺寸。单击该区域左侧的“Preset”按钮，选择网格的预置参数项。 

2.4.8  “Break Wire”选项卡 

“Break Wire”选项卡如图 2.45所示，该选项卡用于设置使用“Break Wire”命令后，

导线断开的状态，以及操作时的显示状态。其中包含三个选项区域，分别介绍如下。 

 

图 2.45  “Break Wire”选项卡 

一、“Cutting Length”选项区域 

“Cutting Length”选项区域用于设置导线断开的长度选项，包含三个单选项，“Snap To 

Segment”项表示将切除从剪切处向两侧扩展的完整的一段导线。“Snap Grid Size Multiple”

项表示将切除 N 个单位的“Snap Grid”网格长度，当选择该项后，其右侧的编辑框将被激

活，在该编辑框内输入 N 的数值。“Fixed Length”项表示将切除一定长度的导线，当选择

该项后，其右侧的编辑框将被激活，在该编辑框内输入导线长度的值，单位为当前的单位。 

二、“Show Cutter Box”选项区域 

“Show Cutter Box”选项区域用于设置在切除操作中是否显示如图 2.46所示的虚线切

除框，该切除框可方便确定切除的导线部位和长度。在该选项区域中共有三个单选项，其中

“Never”表示不显示切除框，“Always”表示一直显示切除框，“On Wire”表示仅在导线

上显示切除框。系统默认选择“Always”项 
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2.46  切除框 

三、“Show Extremity Marker”选项区域 

用于设置在切除操作中是否显示切除部位的两端标记，该标记可显示切除的导线的两

端。在该选项区域中共有三个单选项，其中“Never”表示不显示两端标记，“Always”表

示一直显示两端标记，“On Wire”表示仅在导线上显示两端标记。系统默认选择“Always”

项。 

2.4.9  “Default Units”选项卡 

“Default Units”选项卡如图 2.47所示，该选项卡用于设置系统默认的长度单位，该选

项卡包含三个区域，分别介绍如下。 

 

图 2.47  “Default Units”选项卡 

一、“Imperial Unit System”选项区域 

“Imperial Unit System”选项区域用于设置英制单位作为系统默认单位，勾选“Use 

Imperial Unit System”表示将使用英制单位作为默认单位，“Imperial unit used”下拉列表用

于设置具体的英制长度单位名称，该下拉列表中有“Mils”、“Inchs”、“Dxp Defaults”

和“Auto-imperial”四个选项，系统默认选择“Dxp Defaults”项。 

二、“Metric Unit System”选项区域 

“Metric Unit System”选项区域用于设置公制单位作为系统默认单位，勾选“Use Metric 

Unit System”表示将使用公制单位作为默认单位，“Metric unit used”下拉列表用于选择具

体的公制长度单位名称，该下拉列表中有“Millimeter”、“Centimeter”、“Meters”和

“Auto-Metric”四个选项。 

三、“Unit System”区域 

“Unit System”区域用于显示当前使用的单位提示信息。 

2.4.10  “Default Primitives”选项卡 

“Default Primitives”选项卡如图 2.48所示，该选项卡用于设置各图元对象的默认初始
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参数，用户可在“Primitives List”中的下拉列表中选择需要修改默认初始参数的图元对象所

属的类型，系统提供了“All”、“Wiring Objects”、“Drawing Objects”、“Sheet Symbol 

Objects”、“Library Objects”和“Others”6个选项，然后从“Primitives”列表中选择具体

的图元对象种类，然后在“Primitives”列表下方的选项卡中选择当前的长度单位选项卡，

然后单击“Edit Values”按钮，打开所选择的图元对象的属性对话框，在该属性对话框中设

置图元对象的对应属性即可。 

 

图 2.48  “Default Primitives”选项卡 

所有的默认初始参数设置军保存在“ADVSCH.DFT”和“ADCSCH.MMDFT”文件中，

用户也可以将自定义的图元对象的默认初始参数设置保存在其他文件中，只需要在完成自定

义设置后，单击“Save As”按钮，在打开的“Save default primitive file as”对话框中设置保

存自定义设置的文件名，然后单击“保存”按钮，就可以将当前的设置保存到 DFT 文件中。

当需要调用 DFT 文件时，只需要单击“Load”按钮，在打开的“Open default primitive file”

对话框中选择 DFT 文件，然后单击“打开”即可。 

2.4.11  “OrCAD（tm）”选项卡 

“OrCAD（tm）”选项卡如图 2.49所示，该选项卡用于设置导入 OrCAD 文件时的选

项，该选项卡包含两个选项区域，具体介绍如下。 
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图 2.49  “OrCAD（tm）”选项卡 

一、“Copy Footprint From/To”选项区域 

“Copy Footprint From/To”选项区域用于设置引脚封装对应的 OrCAD 文件中的“Part 

Field”，用户可从该区域的下拉列表中选择 OrCAD文件中的“Part Field”，在导入或导出

OrCAD文件时，系统会将 OrCAD文件设定的“Part Field”中的引脚封装信息导入或导出。 

二、“Orcad Ports”选项区域 

“Orcad Ports”选项区域用于设置导入或导出 OrCAD文件时的端口属性，其中的“Mimic 

Orcad Ports”复选项用于启动 OrCAD 端口模拟功能，在 OrCAD 中，端口标志的长度会随端

口名称字符的长短而自动调整，启动 OrCAD 端口模拟功能后，在 Altium Designer中导入或

导出 OrCAD原理图文件时，会自动根据字符长度调整原理图中的端口标志长度。 

2.5  原理图文档设置 

对操作环境的设置将应用于，接下来需要设定当前文档的选项，调整原理图文档的网格

系统和页面规格。这些设置将只应用于当前文档中，设置的步骤如下。 

（1）启动 Altium Designer，选择打开 2.3.1节创建的“MyWork.DSNERK”设计空间，

系统自动调入设计空间中的 PCB 项目“ExamplePCB_Prj1.PrjPcb”，双击该项目下的

“ExampleSheet.SchDoc”文件，进入原理图编辑界面。 

（2）在原理图编辑窗口的工作区中单击鼠标右键，然后在弹出的快捷菜单中选择

“Document Options…”命令，或直接选择“Design”->“Document Options…”命令，打开

如图 2.50所示的“Document Options”对话框。 
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图 2.50  “Document Options”对话框 

如图 2.50所示的“Document Options”对话框内有两个选项卡，即“Sheet Options”选

项卡和“Parameters”选项卡，分别用来设置文档选项和文档中的参数，其具体功能介绍如

下。 

2.5.1“Sheet Options”选项设置 

“Sheet Options”选项卡包括“Template” 区域、“Standard Style”区域、“Custom Style”

区域、“Options”区域、“Grids”区域、“Electrical Grid”区域和“Change System Font”

按钮共六个区域和一个按钮，具体功能如下： 

一、“Template”区域 

“Template”区域用于设定文档模板，在该区域的“File Name”编辑框内输入模板文件

的路径即可。 

二、“Standard Style”区域 

用于选择标准图纸的标准类型，在如图 2.51所示的“Standard Style”下拉列表内选择

标准图纸模板的类型即可。DXP Schematic能提供多种标准图纸类型，具体如下。 

公制：A0、A1、A2、A3、A4 

英制：A、B、C、D、E 

OrCAD标准：OrCADA、OrCADB、OrCADC、OrCADD、OrCADE 

其他：Letter、Legal、Tabloid 

 

图 2.51  “Standard Style”下拉列表 

三、“Options”区域 

“Options”区域用于设置图纸的方向、标题栏及边框等部分。 
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“Orientation”下拉列表用来设定图纸的放置方向。可供选择的有“Landscape”项和

“Portrait”项，其中“Landscape”项表示横向放置图纸，“Portrait”项表示纵向放置图纸。 

“TitleBlock”复选项用来设置图纸标题栏的显示。选中该复选项后，图纸上将显示标

题栏，并且通过“Title Block”下拉列表，用户可选择标题栏的类型，系统提供两种格式的

标题栏，分别是“Standard”（标准格式）和“ANSI”（美国国家标准协会支持格式），如

图 2.52所示。系统默认为“Standard”格式。若未选中该复选项，则不显示标题栏。 

 

“Standard”格式标题栏                   “ANSI”格式标题栏 

图 2.52  两种格式标题栏 

“Show Reference Zones”复选项用来设置图纸上索引区的显示。选中该复选项后，图

纸上将显示索引区。所谓索引区是指为方便描述一个对象在原理图文档中所处的位置，在图

纸的四个边上分配索引栅格，用不同的字母或数字来表示这些栅格，用字母和数字的组合来

代表由对应的垂直和水平栅格所确定的图纸中的区域。 

“Show Border”复选项用来设置图纸边框线的显示。选中该复选项后，图纸中将显示

边框线。若未选中该项，将不会显示边框线，同时索引栅格也将无法显示。 

“Show Template Graphics”复选项用来设置模板图形的显示。选中该复选项后，将显

示模板图形；若未选中，则不会显示模板图形。 

“Border Color”色彩选择框用来设定边框线的颜色。系统默认为黑色。 

“Sheet Color” 色彩选择框用来设定图纸的颜色。系统默认为浅黄色。如果用户需要

更改以上色彩选择框的颜色，可单击对应的色彩块，打开“Choose Color”对话框，用户可

在该对话框中选择所需要的颜色，然后单击“OK”键即可。 

四、“CustomStyle”区域 

“CustomStyle”区域用于自定义图纸类型。当标准图纸格式无法满足设计要求时，用

户可以自定义图纸格式。要想使用自定义图纸格式的功能，必须选中“UseCustomStyle”右

边的复选框，才能激活“CustomStyle”区域内的其它控件，进行参数设置。 

“Custom Width”选项用于设定自定义图纸的宽度，单位为 mil。DXP Schematic Editor

支持的最大自定义图纸宽度为 65英寸。当图纸方向为横向放置，即“Orientation”项设置为

“Landscape”时，这里的宽度指的是左右边缘间的尺寸；当“Orientation”项设置为 “Portrait”

即图纸方向选择为纵向放置时，这里的宽度指的是图纸上下边缘间的尺寸。 

“Custom Height”编辑框用于设定自定义图纸的高度，也用 mil 表示。系统支持的最大

自定义图纸高度为 65英寸。当图纸方向为横向放置，即“Orientation”项设置为“Landscape”

时，这里的高度指的是上下边缘间的尺寸；当“Orientation”项设置为 “Portrait”即图纸方

向选择为纵向放置时，这里的高度指的是左右边缘间的尺寸。 

“X region Count”编辑框用于设定自定义图纸水平方向上索引栅格的个数。 

“Y region Count”编辑框用于设定自定义图纸垂直方向上索引栅格的个数。 

“Margin Width”编辑框用于设定自定义图纸边框的宽度，单位为 mil。如果要显示索

引栅格，建议设定足够的边框宽度，否则，索引栅格将无法正常显示。 

“Update From Standard”按钮用于将“Standard Styles”输入框中设置的标准图纸格式

的尺寸信息添加到自定义图纸类型的宽及高输入框中，作为用户参考尺寸。该按钮在未选中
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“Use Custom style”复选项之前有效，选中“Use Custom style”复选项后，单击该按钮，

将不会发生任何变化。 

五、“Grids”区域 

“Grids”区域用于设定捕捉栅格及可视栅格的尺寸，其中的具体选项功能如下。 

“Snap”复选项。选中该复选项后，放置或拖动对象时，鼠标指针将以可捕捉栅格为单

位进行移动，便于对象的对齐定位，复选项右侧的编辑框用来设定捕捉栅格的宽度，单位是

mil。若未选中该项，鼠标指针的移动将是连续的。在调整网络标签、文字标注等文字对象

时建议不要选中此复选项。 

“Visible”复选项。选中该复选项后，工作区将显示栅格，其右侧的编辑框用来设置可

视化栅格的尺寸。建议在该编辑框中设置与“Snap”编辑框中相同的值，使显示的栅格与捕

捉栅格一致。若未选中该复选项则不显示栅格。 

六、“Electrical Grid”区域 

“Electrical Grid”区域用于设置是否采用电气栅格，以及电气栅格的作用范围。 

为方便用户在进行原理图绘制时定位元件的引脚，DXP Schematic Editor提供了电气栅

格功能。“Enable”复选框被选中后，若鼠标指针与元器件引脚的距离小于“Grid range”编

辑框内的设定值，则系统会自动将鼠标指针移动到该引脚上，并显示一个热点或亮点。此项

功能为摆放原理图组件、连接导线等带来极大的方便。建议将“Grid range”内的值设置为

略小于捕捉栅格。 

七、“Change System Font”按钮 

“Change System Font”按钮用于打开“字体”对话框，设置文档中的字体，系统默认

字体为“Times New Roman”常规 10号字。这里所指的系统字体，主要用在边框文本、系

统标题栏、元件引脚名、元件引脚号、端口、电源端子以及子图说明等位置，用户可调整字

体大小使图纸标注更加清晰，设置完毕后，单击“字体”对话框中的“确定”按钮即可。 

2.5.2  “Parameters”选项设置 

 单击“Document Option”对话框中的“Parameters”标签，将打开如图 2.53 所示的

“Parameters”选项卡，在该选项卡中可设置文档内图元的变量。 

 

图 2.53  “Parameters”选项卡 

“Parameters”选项卡为原理图文档提供 20多个文档参数，供用户在图纸模板（固定在

模板中）和图纸中放置。当用户为参数赋了值，并选中转换特殊字符串选项后，图纸上显示

所赋参数值。 
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对参数赋值时，先在列表中选择该参数的名称，然后单击“Edit”按钮，或者直接双击列

表中该参数的名称，打开如图 2.54 所示的“Parameter Properties”对话框，在该对话框的

“Value”文本框内输入参数值。如果是系统提供的参数，其参数名是不可更改的（灰色）。

确定后单击“OK”按钮，即完成参数赋值的操作。 

 

图 2.54  “Parameter Properties”对话框 

完成赋值操作后，“Parameters”选项卡内的列表中对应的参数行就会显示用户所设置

的参数的数值，单击“OK”按钮，即可结束设置。 

2.6  文档模板设置 

Altium Designer提供了大量的原理图的图纸模板供用户调用，这些模板存放在 Altium 

Designer 安装目录下的“Templates”子目录里，用户可根据实际情况调用。但是针对特定

的用户，这些通用的模版常常无法满足图纸需求，Altium Designer提供了自定义模板的功能，

本节将介绍文档模板的创建和调用方式。 

2.6.1  创建文档模板 

本节将通过创建一个纸型为“B5”的文档模板的实例，介绍如何自定义文档模板，以

及如何调用文档参数。 

（1）单击工具栏中的新建按钮 ，在弹出的 Files面板中选择“New”->“Schematic Sheet”

命令，新建一个空白原理图文件。 

新建的原理图上显示默认的标题栏和图纸边框，如图 2.55所示。 

 

图 2.55  默认的标题栏 

（2）在原理图上任意位置单击鼠标右键，在弹出的菜单中选择“Options”->“Document 

Options”命令，打开如图 2.56所示的“Document Options”对话框。 
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图 2.56  “Document Options”对话框 

（3）在“Document Options”对话框中的“Options”选项区域中取消选择“Title Block”

复选框，然后单击“Units”选项卡标题，在“Document Options”对话框中打开如图 2.57

所示的“Units”选项卡。 

 

图 2.57  “Units”选项卡 

（4）在“Unit”选项卡中的“Metric Unit System”选择区域中勾选“Use Metric Unit System”

选项，在激活的“Metric unit used”下拉列表中选择“Milimeters”，将文档中使用的长度单

位设置为毫米单位。 

（5）单击“Sheet Options”选项卡标题，打开该选项卡，勾选“Custom Style”选项区

域中的“Use Custom Style”选项，然后在激活的“Custom Width”编辑框中输入 257，在“Custom 

Height”编辑框中输入 182，在“X Region Count”编辑框中输入 4，在“Y Region Count”

编辑框中输入 3，单击“OK”按钮。 

通过以上操作，创建了如图 2.58所示的 B5规格的无标题栏的空白图纸。 
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图 2.58  创建的空白图纸 

（6）单击工具栏中的绘图工具按钮 ，在弹出的工具面板中选择绘制直线工具按钮 ，

按键盘上的“Tab”键，打开直线属性编辑对话框，然后设置直线的颜色为黑色。 

（7）在图纸的右下角绘制如图 2.59所示的标题栏边框。 

 

图 2.59  绘制的标题栏边框 

（8）单击工具栏中的绘图工具按钮 ，在弹出的工具面板中选择添加标注工具按钮 ，

按键盘上的“Tab”键，打开“Annotation”对话框，然后设置文字的颜色为黑色，字体为“小

二”，文字内容为“标题：”，单击“OK”按钮。然后将文字移动到如图 2.60所示的位置。 

 

图 2.60  输入标题 

（9）再次按键盘上的“Tab”键，打开“Annotation”对话框，然后设置字体为“四号”，

按照如图 2.61所示的标题栏，添加其他的文字。 

 

图 2.61  添加标题文字后的标题栏 

（10）选择“Design”->“Document Options”命令，打开“Document Options”对话框，

单击“Parameters”选项卡标题，打开如图 2.62所示的“Parameters”选项卡。 
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图 2.62  “Parameters”选项卡 

（11）单击“Parameters”选项卡中的“Add”按钮，打开如图 2.63所示的“Parameter 

Properties”对话框。 

 

图 2.63  “Parameter Properties”对话框 

（12）在“Parameter Properties”对话框中的“Name”编辑框中输入“Department”，

在“Properties”选项区域的“Type”下拉列表中选择“STRING”项，单击“OK”按钮，

创建一个参数名为“Department”的字符串类型参数。 

（13）重复步骤（12）添加一个名为“SheetTotal”的字符串类型参数。 

（14）单击工具栏中的绘图工具按钮 ，在弹出的工具面板中选择添加标注工具按钮

，按键盘上的“Tab”键，打开“Annotation”对话框，然后设置文字的颜色为蓝色，设置

字体为“小二”，在“Properties”选项区域中的“Text”下拉列表框中选择“=Title”，在

标题栏中“标题：”栏后添加参数“=Title”。 

（15）按照步骤（13）的方法，为标题栏添加如图 2.64所示的参数 
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图 2.64  添加参数后的标题栏 

其中“图号”一栏后添加的参数是“=SheetNumber”，“共  页”中间添加的参数是

“=SheetTotal”。 

（15）选择“Tools”->“Schematic Perferences”命令，打开“Preferences”对话框，在

对话框左边的树形列表中选择“Schematic”->“Graphical Editing”项，打开如图 2.65所示

的“Schematic-Graphical Editing”选项页。 

 

图 2.65  “Schematic-Graphical Editing”选项页 

（16）在“Schematic-Graphical Editing”选项页中的“Options”选项区域勾选“Convert 

Special Strings”复选框，然后单击“OK”按钮。 

此时，标题栏上的参数均显示为其默认的值“*”，如图 2.66所示。在使用该模板时，

只需更新“Parameters”选项卡中的对应参数的内容，即可更改标题栏中显示的内容。 

 

图 2.66  标题栏 

（17）在原理图上单击鼠标右键，在弹出的菜单中选择“Options”->“Document 

Parameters”命令，打开“Document Options”对话框，显示“Parameters”选项卡。 

（18）在“Parameters”选项卡中的列表内选择“CompanyName”项，单击“Edit”按
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钮，打开如图 2.67所示的“Parameter Properties”对话框。 

 

图 2.67  “Parameter Properties”对话框 

（19）在“Parameter Properties”对话框中的“Value”编辑框中输入公司名称，本例中

输入的是虚构的“承丰电子有限公司”，然后单击“OK”按钮，将参数“CompanyName”

的内容设置为“承丰电子有限公司”。 

用户也可直接在“Parameters”选项卡中的列表内直接修改参数的内容。 

（20）选择“Parameters”选项卡中的“Department”项，在该行对应的“Value”栏中

输入“工控部”，即可将参数“Department”的内容改为“工控部”。 

（21）将参数 Address1的内容设置为“湖南长沙五一大道 xxx 号”，单击“OK”按钮，

结束参数修改。 

此时的标题栏如图 2.68所示，公司和部门两栏已经更新为“承丰电子有限公司”和“工

控部”，当调用该文档模板时，用户就可不用修改这两个参数了。 

 

图 2.68  修改参数内容后的标题栏 

（22）单击保存按钮 ，在弹出的保存对话框中设置文件名为“B5_Template.SchDot”，

单击“OK”按钮，保存该文件为原理图模板文件“.SchDot”。 

保存文件后，该模板的标题栏中的文件名一栏将自动更新为“B5_Template.SchDot”，

如图 2.69所示。 

 

图 2.69  文件名自动更新 
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2.6.2  模板文件的调用 

本小节将通过一个调用 2.6.1小节创建的文档模板的实例，介绍模板文件的调用方法。 

（1）在主菜单中选择“File”->“New”->“Schematic”命令，新建一个空白原理图文

件。 

在调用新的文档模板之前，首先要删除旧的文档模板。 

（2）在主菜单中选择“Design”->“Template”->“Remove Current Template”命令，

打开如图 2.70所示的“Remove Template Graphics”对话框。 

 

图 2.70  “Remove Template Graphics”对话框 

该对话框中的“Choose Document Scope”有三个选项，用来设置操作的对象范围，其

中： 

“Just this document”表示仅仅对当前原理图文件进行操作，即移除当前原理图文件调

用的文档模板。 

“All schematic documents in the current project”表示将对当前原理图文件所在的项目中

的所有原理图文件进行操作，即将移除当前原理图文件所在的项目中所有的原理图文件调用

的的文档模板。 

“All open schematic documents”表示将对当前所有已打开的原理图文件进行操作，即

移除当前打开的所有原理图文件调用的文档模板。。 

（3）选择“Just this document”项，单击“OK”按钮，弹出如图 2.71所示的“Information”

消息框，要求用户确认移除文档模板的操作。 

 

图 2.71 “Information”消息框 

（4）单击在“Information”消息框中的“OK”按钮，确认操作。 

（5）选择主菜单中的“Design”->“Template”->“Set Template File Name”命令，打

开“打开”对话框，选择 2.6.1 小节中创建的文档模板文件“B5_Template.SchDot”，单击

“打开”按钮，打开如图 2.72所示的“Update Template”对话框。 
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图 2.72  “Update Template”对话框 

“Update Template”对话框中的“Choose Document Scope”选项区域中的三个选项与

“Remove Template Graphics”对话框中的相同，表示更新文档模板的对象。“Choose Parameter 

Actions”选项区域内的三个选项用于设置对于参数的操作，其意义如下： 

“Do not update any parameters”表示不更新任何的参数。 

“Add new parameters that exist in the template only”表示将文档模板中的新定义的参数

添加到调用文档模板的文件中。 

“Replace all matching parameters”表示用文档模板中的参数替换当前文件的对应参数。 

如果用户对文档模板文件进行了编辑，可通过选择“Design”->“Template”->“Update”

命令，打开“Update Template”对话框，对文档模板进行更新。 

（6）在“Choose Document Scope”选项区域中选择“Just this document”项，在“Choose 

Parameter Actions”选项区域内选择“Replace all matching parameters”项，单击“OK”按钮，

弹出如图 2.73所示的“Information”消息框，提示有一个文件调用了文档模板，单击“OK”

按钮确认。 

 

图 2.73  “Information”消息框 

调用后的文档标题栏与 2.6.1节中新建的文档模板的标题栏完全相同，只是文件名一栏

内容不同。 

（7）在原理图上单击鼠标右键，在弹出的菜单中选择“Options”->“Document Parameters”

命令，打开“Document Options”对话框，显示“Parameters”选项卡。 

（8）修改“Parameters”选项卡内的参数列表的内容，将参数“Title”的内容改为原理

图的名称，将参数“DesignBy”的内容改为设计者的姓名，将参数“Data”的内容改为设计

日期，将参数“Revision”的内容改为原理图的版本号，将参数“SheetNumber”的内容改为

原理图的图号，将参数“Sheet Total”的内容改为图纸的总数，然后单击“OK”按钮。 

更新后的标题栏如图 2.74所示。 

tyw藏书



第 2 章  原理图设计基础 

 ·72·   

 

图 2.74  更新后的标题栏 

（9）单击保存按钮 ，在弹出的保存对话框中设置文件名为“power.schdoc”，单击

“OK”按钮，保存该文件。 

2.7  布置图元对象 

典型的电路原理图是由各种电路符号和连接这些电路元件符号的导线以及标注符号组

成，用户设计原理图的过程，主要就是在原理图的图纸上布置各种原理图图元对象，然后通

过电路连线或网络标号等标志各图元对象之间联结关系的过程。这些图元既包括具有电气属

性的图元，例如电子元件符号、导线、网络标号、电源端口等电气对象，也包括不具有电气

属性的图元，如线段、圆形、矩形、多边形等非电气对象，还包括一些标记符号。本节将介

绍向原理图中添加图元对象的基本方法。 

2.7.1  添加电子元件方法 

电子元件是原理图中最重要的图元对象，通常的原理图由一个或多个核心器件和多个附

属器件构成，选择合适的电子元件是进行原理图设计的重要的步骤，在选好电子元件后，用

户需要在 Altium Designer提供的元件库文件中找出所需要的文件符号，布置到原理图图纸

上。Altium Designer使用的元件库为集成元件库，即元件库中任何的一型元件下既有该元件

的原理图符号还包括该元件的仿真模型、PCB封装模型和 3D 模型，这种结构方便了用户的

管理和调用。 

为了节约系统资源，Altium Designer在启动时并没有加载所有电子元件库，大多数情况

下，用户需手动加载相应的集成元件库，然后在元件库中选择所需要的元件，添加到原理图

中。本节将依次介绍加载元件库、添加元件的具体步骤。 

1.加载元件库 

Altium Designer安装时自带的元件库内元器件均采用国际标准命名方式命名，系统安装

后的集成元件库的默认路径是“（Altium Designer 安装目录） \Altium\Library\”，

AltiumDesigner6.0提供当前的大多数主流电子器件供应商的集成元件库文件，在“Library”

目录下包含多个以器件厂商名称命名的目录，各个目录下存放了该器件供应商按不同的元器

件类型建立的集成元件库。在“Library”目录下还有一些独立的器件库，比如 PCB引脚封

装库、做 FPGA设计用到 VHDL 库等。在 Altium Designer提供的集成元件库可以找到设计

所需的大部分器件，本节将通过一个加载“ST”公司的稳压器集成元件库的实例，介绍加

载集成元件库的步骤。 

（1）启动 Altium Designer，在“Workspace”列表中选择之前创建的设计空间

“ ExampleWorkspace.DSNWRK” ， 系 统 自 动 调 入 设 计 空 间 中 的 PCB 项 目

“ExamplePCB_Project.PrjPcb”，启动原理图编辑模块，打开“ExampleSheet.SchDoc”文件。 

（2）单击主窗口右侧的“Library”工作面板标签，打开如图 2.75所示的“Liberaries”
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工作面板。 

 

图 2.75  “Libraries”工作面板 

（3）单击 “Libraries”工作面板上方的“Libraries”按钮，打开如图 2.76所示的“Available 

Libraries”对话框。 

 

图 2.76  “Available Libraries”对话框 

在系统第一次启动时将自动加载两个通用集成元件库“Miscellaneous Devices.Intlib”和

“Miscellaneous Connector.Intlib”，这两个元件库包含了最常用的简单分立元件和接头元件。

在“Available Libraries”对话框内的“Installed”选项页中列出了当前加载的所有元件库的

名称、元件库的路径和类型，由于没有加载其它元件库，所以列表中仅列出了默认加载的两

个元件库。 

（4）单击“Install”按钮，打开如图 2.77所示的“打开”对话框。 
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图 2.77  “打开”对话框 

（5）在“打开”对话框中选择需添加的元件库文件，本例中选择“Altium\Library\ST 

Microelectronics\”目录下的“ST Power Mgt Voltage Regulator.INTLIB”文件，单击“打开”

按钮，将该元件库添加到“Available Liberies”对话框的列表中。 

加载新元件库后，“Available Libraries”对话框内的“Installed”选项页中增加了新的

元件库的信息，如图 2.78所示。 

 

图 2.78  “Installed”选项页 

（6）单击“Available Liberies”对话框中的“Close”按钮，即完成元件库的加载。 

加载元件库后，“Libraries”元件面板将自动列出最新加载的元件库中的元件列表，如

图 2.79所示。 
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图 2.79  “Libraries”面板 

2.添加元件到原理图中 

当元件库加载完毕后，用户就可以从元件库中选择元件，添加到原理图中去。添加元件

到原理图中的步骤如下。 

（1）在主菜单中选择 “Place”->“Part”命令，或单击添加元件按钮 ，打开如图 2.80

所示的“Place Part”对话框。 

 

图 2.80  “Place Part”对话框 

“Place Part”对话框中将默认显示最近一次添加的元件。 

（2）在“Place Part”对话框中的“Placement Type”选项区域内选择“From Standard 

Libraries”项，表示使用标准元件库。 

（3）单击“Place Part”对话框中“Part Details”选项区域内的 “...”浏览按钮，打开

如图 2.81所示的“Browse Libraries”对话框。 
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图 2.81  “Browse Libraries”对话框 

（3）单击“Browse Libraries”对话框中的“Libraries”下拉列表，在弹出的列表中选择

“ST Power Mgt Voltage Regulator.IntLib”。 

（4）在“Browse Libraries”对话框的元件列表中选择需要添加的元件名称“L78M05CV”，

然后单击“Browse Libraries”对话框右下角的浅黄色区域，该区域将显示所选元件的 PCB

图，如图 2.82所示。 

 

图 2.82  “Browse Libraries”对话框 

（5）单击“Browse Libraries”对话框“OK”按钮，关闭该对话框，然后单击“Place Part”

对话框中的“OK”按钮。 

此时鼠标指针将变成设置的十字形，并且鼠标指针上还吸附一个选中的元件符号，如图

2.83所示。 
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图 2.83  鼠标指针及其吸附的元件符号 

（6）单击键盘的“Tab”键，打开如图 2.84所示的“Component Properties”对话框。 

 

图 2.84  “Component Properties”对话框 

（7）在“Component Properties”对话框的“Properties”区域内的“Designator”编辑框

内输入元件的编号“U1”，单击“OK”按钮，关闭“Component Properties”对话框。 

在“Component Properties”对话框中还显示了元件的其它信息，一般情况下不需要对其

进行更改。 

（8）移动鼠标指针至原理图中的合适位置，单击鼠标即可在鼠标指针所在位置添加一

个所选元件。 

添加了一个元件后，鼠标指针上吸附的元件标志并不会消失，用户可以继续在其他的地

方添加该元件，在添加元件的过程中无需再次设置元件编号，系统会自动设置递增元件编号。

这样做便于连续添加一种元件。 

（9）重复步骤（8）在原理图其他地方添加元件，所有元件添加完毕后，单击鼠标右键，

或键盘“ESC”键，重新打开“Place Part”对话框，选择布置其它元件，或单击“Place Part”

对话框中的“Cancel”按钮，结束本次元件添加操作。 

用户还可以从元件库面板中直接添加元件到原理图中，通常这样操作更加方便快捷，步

骤如下。 

（1）单击“Libraries”标签，打开“Libraries”面板。 

（2）在“Libraries”面板的元件库下拉列表中选择欲添加的元件所在的元件库“ST Power 

Mgt Voltage Regulator.IntLib”。 
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（3）在元件列表中双击欲添加的元件名称“L7805CV”，或者选中“L78M05CV”后，

单击“Libraries”面板右上部的“Place L78M05CV”按钮，鼠标指针将变成十字形，并且吸

附一个“L78M05CV”元件的原理图符号。 

（4）单击键盘的“Tab”键，打开“Component Properties”对话框，在“Component Properties”

对话框中设置元件的编号，单击“OK”按钮。 

（5）移动鼠标指针至合适位置，单击鼠标即可在鼠标指针所在位置添加一个所选元件。 

添加了一个元件后，鼠标指针上悬浮的元件标志并不会消失，如果在原理图上其它位置

单击鼠标，会在单击处又添加一个元件，这样做便于连续添加统一元件。 

（6）单击鼠标右键或“Esc”键结束元件的添加。 

2.7.2 布置导线 

导线用于连接具有电气连通关系的各个原理图管脚，表示其两端连接的两个电气接点处

于同一个电气网路中。原理图中任何一根导线的两端必须分别连接引脚或其他电气符号。在

原理图中添加导线的步骤如下。 

（1）在主菜单中选择的“Place”->“Wire”命令，或者单击“Wiring”工具栏中的布

置导线工具按钮 。 

此时鼠标指针自动变成“十”字形，表示系统处于放置导线状态。 

（2）单击键盘“Tab”键，打开如图 2.85所示的“Wire”对话框。 

 

图 2.85  “Wire”对话框 

（3）单击“Wire”对话框中的“Color”色彩条，打开如图 2.86所示的“Choose Color”

对话框。 

 

图 2.86  “Choose Color”对话框 
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（4）在“Choose Color”对话框中设置导线的颜色，选好色彩后，单击“OK”按钮确

定。 

 

将鼠标指针移动到欲放置导线的起点位置（一般是元件的引脚），若设置了电气栅格后，

当鼠标指针移动到原理图中某一个电气结点，例如元件的引脚附近时，如果鼠标指针处于该

引脚的电气栅格范围之内，系统会自动定位鼠标指针到该引脚上，并显示一个红色的 X 形

连接标记，这表示鼠标指针此时在元件的该电气连接点上，如图 2.87所示。  

 

图 2.87  定位鼠标指针 

（3）单击鼠标左键或单击键盘回车键确定导线的起点。移动鼠标指针后，会出现一条

细线从所确定的第一个端点处延伸出来，直至鼠标指针当前所指位置。 

（4）将鼠标指针移到导线的下一个折点，单击鼠标左键或单击回车键在导线上添加一

个布线点，系统自动布置从端点到该布线点之间的导线。 

（5）继续移动鼠标指针确定导线上的其它布线点，直至导线的终点。 

（6）单击鼠标右键或单击“Esc”键，完成这一条导线的布置，整个过程如图 2.88 所

示。 

 

图 2.88  布置导线的过程 

（5）移动鼠标指针，在图纸上布置其它导线，如果导线布置完毕，单击鼠标右键，或

者单击“Esc”键，结束导线的布置。 

AltiumDesigner6.0提供了多种导线走线的模式，分别介绍如下。 

一、“90degree”，该模式下，导线按照水平和垂直方向走线，导间的夹角均为 90度，

如果用户设置的两个布线点不处于同一个水平，或竖直坐标上时，系统会自动添加一个 90

度的拐点，通过键盘“空格键”可以在顺时针方向和逆时针方向布线之间切换。 

二、“45degree”（45度），该模式下导线按照 45度的方向走线，导线之间的夹角为

45 度或者 135 度，如果用户设置的两个布线点不处于同一个水平，或竖直坐标上时，系统

会自动添加一个 135度的拐点，通过键盘“空格键”可以在顺时针方向和逆时针方向布线之

间切换。 

三、“Any Angle”（自由角度），该模式下导线按照直线连接其两端的电气结点。 

四“Auto Wire”（自动布线）模式，该模式下用户只需要指定导线的两端的电气结点，

系统自动生成连接所选择的接点的导线，生成的导线能自动避开布线路径上的其它图元对

象。在布线过程中，单击“Tab”键，可打开如图 2.89所示的“Point to Point Router Op…”
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对话框。 

 

图 2.89  “Point to Point Router Op…”对话框 

该对话框用以设置自动布线的规则，其中“Time Out After（s）”编辑框用来设置自动

布线的时间限制，这个时间设置得越长，系统的自动布线效果会越好，但花费的时间也就越

长。系统默认值为“3秒”。“Avoid cutting wires” 滑块用于设定自动布线过程中避免与

其他线交叉的要求程度，越向右则要求越高，相应布线质量也就越好，但布线速度会减慢，

花费时间也增加了。 

这四种布线方式所生成的导线如图 2.90所示。 

 

“90degree”模式 45degree模式 “Any Angle”模式  “Auto wire”模式 

图 2.90  四种布线模式比较 

  2.7.3  布置总线和总线引入线 

在数字电路原理图中常会出现多条平行布置的导线，由一个器件相邻的管脚连接到另一

个器件的对应相邻管脚。为降低原理图的复杂度，提高原理图的可读性，设计者可在原理图

中使用总线（Bus），总线是若干条性质相同的信号线的组合，它类似电气柜上的线束。在

Altium Designer的原理图编辑器中总线和总线引入线实际上都没有实质的电气意义，仅仅是

为了方便看原理图而采取的一种示意形式。电路上依靠总线形式连接的相应点的电气关系不

是由总线和总线引入线确定的，而是由在对应电气连接点上布置的网络标签“NetLab”确定

的，只有网络标签相同的各个点之间才真正具备电气连接关系。 

通常情况下，为与普通导线相区别，总线比一般导线粗，而且在两端有多个总线引入线

和网络标记。布置总线的布置过程与导线基本相同，其具体步骤如下。 

（1）单击“Wiring”工具栏上的布置总线工具按钮 ，或者选择主菜单中的“Place”
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->“Bus”命令，如图 2.91所示，熟练的用户可使用快捷键“P”，“B”。 

 

图 2.91  选择主菜单中的“Place”->“Bus”命令 

此时鼠标指针自动变成“十”字形，表示系统处于放置导线状态。鼠标指针的具体形状

与“Document Options”中的设置有关。 

（2）单击键盘上的“Tab”键，打开如图 2.92所示的“Bus”对话框。 

 

图 2.92  “Bus”对话框 

（3）在“Bus”对话框中单击“Color”色彩条，打开“Choose Color”对话框。用户可

在“Choose Color”对话框中设置总线的颜色，选好色彩后，单击“OK”按钮即可。 

（4）在“Bus”对话框的“Bus Width”下拉列表中选择总线的宽度。 

与导线宽度的设置相同，Altium Designer为用户提供了四种宽度的线型供选择，分别是

“Smallest”、“Small”、“Medium”和“Large”，默认的线宽为“Small”。总线的宽度

与导线宽度相匹配，即选择同样的宽度选项的总线和导线的宽度比例相同。建议总线的宽度

设置与导线的宽度相匹配，即两者都采用同一设置，如果导线宽度设置比总线宽度大的话，

容易引起混淆。画总线时一般常采用 45°模式绘制，并且总线的末端最好不要超出总线引

入线。 

（5）所有与总线相关的选项都设置完毕后，单击“OK”按钮，关闭“Bus”对话框。 

（6）将鼠标指针移动到欲放置总线的起点位置，单击鼠标左键或单击回车键确定总线

的起点。移动鼠标指针后，会出现一条细线从所确定的端点处延伸出来，直至鼠标指针所指

位置。 

（7）将鼠标指针移到总线的下一个转折点或终点处，单击鼠标左键或单击回车键添加

导线上的第二个固定点。此时在端点和固定点之间的导线就绘制好了。继续移动鼠标指针，

确定总线上的其它固定点，最后到达总线的终点后，先单击鼠标左键或单击键盘回车键，确

定终点，然后单击鼠标右键或单击“Esc”键，完成这一条总线的布置。 

与导线布置方式相同，DXP SchematicEditor也为用户提供了四种布置总线模式，分别

是“90degree”（90度）、“45degree”（45度）、“Any Angle”（自由角度）及“Auto Wire”

（自动布线）模式。通过按快捷键“Shift”+“空格键”可以在各种模式间循环切换。 

仅仅绘制完总线在原理图中并不代表任何意思，总线无法直接连接器件，还需要为其添
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加总线引入线和网络标记，步骤如下。 

（1）单击“Wiring”工具栏中的布置总线引入线工具按钮 ，或者在主菜单选择“Place”

->“Bus Entry”命令，如图 2.93所示，熟悉 Altium Designer的用户可以使用快捷键“P”，

“U”。 

 

图 2.93  选择“Place”->“Bus Entry”命令 

启动布置总线引入线命令后，鼠标指针变成“十”字状，并且自动悬浮一段与灰色水平

方向夹角为 45°或 135°的导线，如图 2.94所示，表示系统处于布置总线引入线状态。 

 

图 2.94  布置总线引入线时的鼠标指针 

（2）单击键盘上的“Tab”键，打开如图 2.95所示的“Bus Entry”对话框。 

 

图 2.95  “Bus Entry”对话框 

（3）在“Bus Entry”对话框中单击“Color”色彩条，打开“Choose Color”对话框。

在“Choose Color”对话框中选择总线引入线的颜色，选好色彩后，单击“OK”按钮即可。 

（4）在“Bus”对话框中单击“Bus Width”下拉列表右侧的 按钮，在弹出的列表中

选择总线引入线的宽度规格。 

与总线宽度一样，总线引入线也有四种宽度线型可选择，分别是“Smallest”、“Small”、

“Medium”和“Large”，默认的线宽为“Small”，建议选择与总线相同的线型。 

（5）单击“OK”按钮，完成对总线引入线属性的修改。 

（6）将鼠标指针移到将要放置总线引入线的器件管脚处，鼠标指针上出现一个红色的

星形标记，单击鼠标即可完成一个总线引入线的放置，如果总线引入线的角度不符合布线的
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要求，可以单击键盘的“空格键”调整总线引入线的方向。 

（7）重复步骤（6）的操作，在其他管脚放置总线引入线，当所有的总线引入线全部放

置完毕，单击鼠标右键或按“Esc”键，退出布置总线引入线的状态，此时鼠标指针恢复为

箭头状态 。 

（8）单击选中总线，按住鼠标，调整总线的位置，使其与一排总线引入线相连，绘制

好的总线引入线如图 2.96所示。 

 

图 2.96  绘制好的总线引入线 

用户也可以直接使用导线“Wire”将总线与元件管脚连接起来，这样操作会显得相对比

较麻烦，布置的引入线也不如使用总线引入线整齐美观。 

2.7.4  布置网络标签 

添加了总线引入线后，实际上并未在电路图上建立正确的引脚连接关系，此时还需要添

加网络标签“Net Label”，网络标签是用来为电气对象分配网络名称的一种符号。在没有实

际连线的情况下，也可以用来将多个信号线连接起来。网络标签可以在图纸中连接相距较远

的元件管脚，使图纸清晰整齐，避免长距离连线造成的识图不便。网络标签可以水平或者垂

直放置。在原理图中，采用相同名称的网络标签标识的多个电气结点，被视为同一条电气网

络上的点，等同于有一条导线将这些点都连接起来了。因此，在绘制复杂电路时，合理地使

用网络标签可以使原理图看起来更加简洁明了。放置网络标签的步骤如下。 

（1）在主菜单中选择“Place”->“Net Label”命令，如图 2.97所示，或者单击“Wiring”

工具栏上的放置网络标签工具按钮 ，。熟悉 Altium Designer的用户可按快捷键“P”，“N”。 

 

图 2.97  选择“Place”->“Net Label”命令 
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启动放置网络标签命令后，鼠标指针将变成十字鼠标指针，并在鼠标指针上悬浮着一个

默认名为“Net Label”的标签。 

（2）单击“Tab”键，打开如图 2.98所示的“Net Label”对话框。 

 

图 2.98  “Net Label”对话框 

（3）单击“Color”色彩块，打开“Choose Color”对话框，在该对话框中选择网络标

签的文字色彩，然后单击“OK”按钮，关闭“Choose Color”对话框。 

（4）单击“Orientation”右侧的文字，在弹出的列表中选择网络标签的的旋转角度。 

（5）在“Properties”区域的“Net”编辑框内设置网络标签的名称。 

（6）单击“Properties”区域内的“Change”按钮，打开“字体”对话框，在“字体”

对话框中设置网络标签的字体，然后单击“字体”对话框中的“确定”按钮，关闭“字体”

对话框。 

Altium Designer系统中，网络标签的字母不区分大小写。若用户在“Preferences”对话

框的“Graphical Editing”选项卡中选中 Single\Negation选项，可以在网络标签名称的后面

输入反斜杠“\”表示信号输入低、电平有效或下降有效，在第一个字母前加单反斜杠表示

该网络为低态信号。在放置过程中，如果网络标签的最后一个字符为数字，则该数字会按照

在“Preferences”对话框的“Graphical Editing”选项卡中对“Auto-Increment During Placement”

项的设置，自动按指定的数字递增。 

（7）将鼠标指针移到需要放置网络标签的导线上，当鼠标指针上显示出红色的星形标

记时，表示鼠标指针已捕捉到该导线，单击鼠标左键即可放置一个网络标签。 

如果需要调整网络标签的方向，单击键盘的“空格键”，网络标号会逆时针方向旋转

90度。 

（8）将鼠标指针移到其他需要放置网络标签的位置，继续放置网络标签。单击鼠标右

键或按“Esc”键，即可结束布置网络标签状态。 

如图 2.99所示为一个已布置好网络标签的总线的一端。 
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图 2.99  布置网络标签后的总线 

2.7.5  电源端口的布置 

电源端口是一种表示电源和地的专用符号，每个电源端口包含一个特定的网络标签，它

允许在原理图上的任何位置表示电源和地网络。电源端口的网络标签名称可以相同也可以不

同，相同则表示同一个电源或地，不同则表示不同的电源或地。布置电源端口的步骤如下。 

（1）在主菜单中选择“Place”->“Power Port”命令，或者单击“Wiring”工具栏上的

布置电源端口工具按钮 或布置接地端口工具按钮 ，熟悉 Altium Designer的用户使用快

捷键“P”，“O”。 

启动放置电源端口命令后，鼠标指针将变成十字鼠标指针，并在鼠标指针上悬浮一个电

源或接地标志。 

（2）单击“Tab”键，打开如图 2.100所示的“Power Port”对话框。 

 

图 2.100  “Power Port”对话框 

（3）单击“Color”色彩块，打开“Choose Color”对话框，在“Choose Color”对话框

中选择电源端口的颜色，然后单击“OK”按钮，关闭“Choose Color”对话框。 

（4）单击“Orientation”右侧的文字，在弹出的下拉列表中选择电源端口的旋转角度选

项。 

（5）单击“Style”右侧的文字，在弹出的下拉列表中选择电源端口标志的样式。Altium 

Designer为用户提供了多种电源端口图标，如图 2.101所示。 
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图 2.101  电源端口图标 

（6）在“Properties”区域的“Net”编辑框内输入电源端口的网络标签名称。 

（7）电源端口的属性项设置完成后，单击“OK”按钮，关闭“Power Port”对话框。 

（8）将鼠标指针移到需要放置电源端口处，单击鼠标即可完成一个电源端口的放置。  

在布置电源端口的过程中，单击键盘“空格键”即可将电源端口符号的按照逆时针方向

旋转 90度，单击“x”键左右翻转，单击“Y”键上下翻转。 

（9）重复步骤（8）放置其他电源端口，布置完所有电源端口后，单击鼠标右键或按“Esc”

键，即可结束电源端口的布置。 

2.7.6  放置电气连节点 

电气连节点是一个小的实心圆点，在原理图上用于表示交叉导线的电气连接关系，在默

认状态下，系统会在“T”形的连线交叉处自动放置电气节点，但在“十”字形交叉处就需

要手工添加电气节点，添加电气节点的步骤如下。 

（1）在主菜单中选择“Place”->“Manual Junction”命令，熟悉 Altium Designer的用

户可以使用“P”，“J”快捷键。 

启动放置电气节点命令后，鼠标指针将变成十字鼠标指针，并在鼠标指针上悬浮一个电

气节点标志。 

（2）单击键盘上的“Tab”键，打开如图 2.102所示的“Junction”对话框。 

 

图 2.102  “Junction”对话框 
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（3）单击“Color”色彩块，打开“Choose Color”对话框。在“Choose Color”对话框

中选择总线引入线的颜色，选好色彩后，单击“OK”按钮即完成对电气节点颜色的调整。 

（4）单击“Junction”对话框“Properties”区域的“Size”下拉列表右侧的 按钮，在

弹出的列表中选择电气节点的规格。 

为了与导线的规格相匹配，电气节点也有四种规格，分别是“Smallest”、“Small”、

“Medium”和“Large”。默认大小为“Small”。 

（5）单击“OK”按钮，关闭“Junction”对话框，结束对电气节点的调整。 

（6）移动鼠标指针至连线交叉处，此时鼠标指针上显示红色星形标志，表示该处有电

气连接点，单击鼠标，在该交叉点放置一个电气节点。 

（7）重复步骤（5）放置其他电气节点，布置完毕后，单击鼠标右键，结束电气节点的

布置。 

2.7.7  布置端口 

在原理图中除了使用导线、网络标签表示电气连接关系外，布置端口也是一种表示电气

连接关系的方法，端口通常用于在一张电路原理图上设置外部对于图纸的输入端或整个原理

图的信号输出端。布置端口的步骤如下。 

（1）在主菜单中选择“Place”->“Port”命令，或者单击“Wiring”工具栏中的布置端

口工具按钮 ，熟悉 Altium Designer的用户可以使用快捷键“P”或“R”。 

启动放置端口命令后，鼠标指针变成“十”字形，并在鼠标指针上悬浮一个端口标志，

如图 2.103所示。 

 

图 2.103  放置端口时的鼠标指针 

（2）单击“Tab”键，打开如图 2.104所示的“Port”对话框。 

 

图 2.104  “Port”对话框 
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（3）在“Port”对话框的“Graphical”选项卡的“Properities”区域的“I/O Type”下拉

列表框中选择端口的类型。 

根据端口标签上的信号流向，共有四种端口类型可供选择，分别是“Unspecified”、

“Input”、“Output”和“Bidirectional”，其标志分别如图 2.105所示。 

 

“Unspecified”      “Input”            “Output”       “Bidirectional” 

图 2.105  四种端口类型 

（4）在如图 2.91所示的“Port”对话框的“Graphic”选项卡的“Properities”区域内的

“Name”编辑框中输入端口名称，单击“OK”按钮。 

（5）移动鼠标指针到原理图上需要放置端口的地方，单击鼠标，将端口一端固定到原

理图上，移动鼠标，调整端口符号的长度，再次单击鼠标，即完成一个端口的布置。 

（6）重复步骤（5）布置其他端口，全部布置完毕后，单击鼠标右键，结束端口的布置。 

2.7.8  布置“No ERC”标志 

布置“No ERC”标志的主要目的是使系统在执行 ERC（电气规则）检查时，跳过对布

置有“No ERC”标志的节点的检查，避免在编译的报告中产生不必要的警告或错误信息。

例如，系统默认输入型引脚必须要连接，但实际上某些输入型引脚不连接也是允许的，如果

不放置“No ERC”标志，原理图在编译时就会被认为存在引脚使用错误，导致编译失败。

布置“No ERC”标志的步骤如下所示。 

（1）单击“Wiring”工具栏中的布置“No ERC”标志工具按钮 ，或者在主菜单中选

择“Place”->“Directives”->“No ERC”命令，如图 2.106所示，熟悉 Altium Designer的

用户可以使用快捷键“P”，“I”，“N”。 

 

图 2.106  选择“Place”->“Directives”->“No ERC”命令 

（2）单击键盘的“Tab”键，打开如图 2.107所示的“No ERC”对话框. 
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图 2.107  “No ERC”对话框 

（3）单击“Color”色彩块，打开“Choose Color”对话框，选择一种颜色作为“No ERC”

标志的颜色，单击“OK”按钮，关闭“Choose Color”对话框。 

（4）单击“No ERC”对话框中的“OK”按钮，关闭“No ERC”对话框，然后在电路

图中需要布置“No ERC”标志的引脚上单击鼠标，即可添加一个“No ERC”标志。 

在原理图中器件的一些引脚在被空置的时候，系统进行实时原理图规则检查时会在该引

脚下添加一个红色波浪线，表示该引脚存在错误。在该引脚上布置“No ERC”标志后，警

告错误的红色波浪线就消失了，如图 2.108所示。 

    

布置“No ERC”标志前            布置“No ERC”标志后 

图 2.108  布置“No ERC”标志前后的引脚 

（3）重复步骤（2），在其他的引脚上添加“No ERC”标志，完成后，单击鼠标右键

或者“Esc”键，结束“No ERC”标志的布置。 

2.7.9  非电气图元对象的绘制 

完整的电路原理图不仅包括具有电气意义的电器元件、导线以及其他符号外，还应该有

不具有电气意义的非电气图元对象，例如字符、直线、多边形、曲线等，用于注释原理图提

供参考信息，本节将介绍这些非电气图元的布置方法. 

1.折线绘制 

原理图中直线与导线代表完全不同的含义。折线不具备电气意义，主要用于设置各类注

释，编译过程中，系统将不会处理直线，折线的绘制步骤如下。 

（1）在主菜单中选择“Place”->“Drawing Tools”->“Line”命令，或者单击“Utilities”

工具栏中的绘图工具按钮 ，在弹出的如图 2.109 所示的绘图工具栏中选择直线工具按钮

。  
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图 2.109  绘图工具栏 

鼠标指针将显示“十”字标记，表示进入绘制直线状态。 

（2）单击“Tab”键，打开如图 2.110所示的“PolyLine”对话框。 

 

图 2.110  “PolyLine”对话框 

（3）单击“PolyLine”对话框中的“Line Width”右侧的文字，在弹出的列表中选择直

线的宽度规格。 

与导线的设置相同，直线宽度也有四种可供用户选择，分别是“Smallest”、“Small”、

“Medium”和“Large”，默认值为“Small”。 

（4）单击“PolyLine”对话框的“Line Style”右侧的文字，在弹出的列表中选择直线

的线型。 

在“Line Style”下拉列表中共有三种直线线型可供选择，分别是“Solid”（实线）、

“Dashed”（虚线）和“Dotted”（点线），默认值为“Solid”（实线）。 

（5）单击“PolyLine”对话框的“Color”色彩条，在弹出的“Choose Color”对话框中

选择直线色彩，单击“Choose Color”对话框中的“OK”按钮，即可设置直线颜色。 

（6）采用与绘制导线相同的方法，即可绘制直线。绘制结束后，单击鼠标右键或“Esc”

键结束直线绘制。 

系统提供了五种绘制直线的模式，即“以 90°线开始的直线”、“以 90°线结束的直

线”、“以 45°线开始的直线”、“以 45°线结束的直线”和“任意角度直线”，分别如

图 2.111所示。 
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图 2.111  五种绘制直线模式 

2.箭头绘制 

与之前的 Protel版本不同，Altium Designer提供了绘制箭头的功能，更方便用户对电路

图进行标注，绘制箭头的步骤如下。 

（1）在主菜单中选择“Place”->“Drawing Tools”->“Line”命令，或者单击“Utilities”

工具栏中的绘图工具按钮 ，在弹出的绘图工具栏中选择直线工具按钮 。 

（2）单击“Tab”键，打开 “PolyLine”对话框。 

（3）单击“PolyLine”对话框中的“Start Line Shape”右侧的文字，弹出如图 2.112所

示的下拉列表。 

 

图 2.112 “Start Line Shape”下拉列表 

“Start Line Shape”下拉列表中显示了六种导线端子的样式选项，并在选项右侧有图例

供用户选择。 

（4）在下拉列表中选择“SolidTail”项，然后单击“End Line Shape”右侧的文字，在

弹出的下拉列表中选择“SolidArrow”项。设置完直线两端的类型后，“PolyLine”对话框

中的图例中也将显示设置的带箭头的直线效果，如图 2.113所示。 

 

图 2.113  “PolyLine”对话框中的图例 

（5）单击“Line Shape Size”右侧的文字，在弹出的下拉列表中选择“Medium”项，

将箭头的尺寸设置为中号。 

（6）采用与绘制折线相同的方法，绘制折线。绘制结束后，单击鼠标右键或“Esc”键

结束直线绘制。绘制好的折线的两端将出现箭头。 

3.多边形绘制 

原理图中的多边形常用于注释图，其不具任何电气意义，在编译过程中将会被忽略，绘

制多边形的步骤如下所示。 

（1）在主菜单中选择“Place”->“Drawing Tools”->“Polygon”命令，或者单击“Utilities”

工具栏中的绘图工具按钮 ，在弹出的绘图工具栏中选择绘制多边形工具 。 
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鼠标指针将显示“十”字标记，表示进入绘制多边形状态。 

（2）单击键盘上的“Tab”键，打开如图 2.114所示的“Polygon”对话框。 

 

图 2.114  “Polygon”对话框 

（3）单击“Border Width”右侧的文字，在弹出的下拉列表中选择多边形边界线的宽度，

系统提供了“Small”、“Media”和“Large”三种选项。默认为“Small”项。 

（4）单击“Fill Color”色彩块，打开“Choose a color”对话框，在该对话框中设置多

边形的填充区域内的颜色。 

（5）单击“Border Color”色彩条，打开“Choose a color”对话框，在该对话框中设置

多边形的边界线的颜色。 

（6）勾选“Draw Solid”复选项，设置多边形内部有色彩填充，若未勾选该项，仅绘制

多边形的线框，多边形的内部不被色彩填充。 

（7）不勾选“Transparent”复选项，设置多边形覆盖下方的图元，如果勾选该项，多

变形处于透明状态，将显示处于多边形下方的其他图元，如图 2.115所示为“Transparent”

复选项被勾选前后的效果。 

   

未选中“Transparent”复选项           选中“Transparent”复选项 

图 2.115  选中“Transparent”复选项前后的多边形 

（8）设定好多边形的属性后，单击“Polygon”对话框中的“OK”按钮，结束对多边

形属性的设置。 

（9）移动鼠标指针至原理图中合适的位置，单击鼠标确定多边形的第一个顶点，移动

鼠标到多边形的第二个顶点，单击鼠标左键，确定第二个顶点位置。然后按照顺序，依次确

定多边形的其他顶点，在移动鼠标过程中，工作去会动态显示多边形的形状和大小。确定最

后一个顶点后，单击鼠标右键，结束顶点的确定步骤。完成一个多边形的绘制。 

（10）重复步骤（9）绘制其他的多边形，绘制结束后，单击鼠标右键，结束多边形绘

tyw藏书



第 2 章  原理图设计基础 

 ·93·   

制。 

4.椭圆弧的绘制 

绘制椭圆弧或圆弧的步骤如下。 

（1）在主菜单中选择“Place”->“Drawing Tools”->“Elliptic Arcs”命令，或者单击

“Utilities”工具栏中的绘图工具按钮 ，在弹出的的绘图工具栏中选择绘制椭圆弧工具 。  

鼠标指针将变为十字形，并悬浮一个圆弧标记，如图 2.116所示，表示进入绘制圆弧状

态。 

 

图 2.116  鼠标指针 

（2）单击键盘上的“Tab”键，打开如图 2.117所示的“Elliptic Arcs”对话框。 

 

图 2.117  “Elliptic Arcs”对话框 

（3）单击“Color”色彩块，打开“Choose a color”对话框，在该对话框中设置椭圆弧

的颜色。 

（4）单击“LineWidth”右侧的文字，在弹出的下拉列表中设定椭圆弧的线宽，系统提

供“Smallest”、“Small”、“Medium”和“Large”四种线宽供选择。 

（5）单击“X-Radius”右侧的数字，输入设定的 X 轴半径值，单击“Y-Radius”右侧

的数字，输入设定的 Y 轴半径值。 

（6）单击“Start Angle”右侧的数字，输入设定的椭圆弧起点的角度值，单击“End Angle”

右侧的数字，输入设定的椭圆弧终点的角度值。 

（7）在对话框中完成所有设定后，单击“OK”按钮，关闭“Elliptical Arc”对话框。

在工作区的适当位置单击鼠标左键确定椭圆弧的圆心位置，然后保持鼠标位置，连续单击鼠

标左键四次，按照“Elliptical Arc”对话框中设定的参数，确定椭圆弧的尺寸。 

（8）移动鼠标到其他点，绘制其他椭圆弧，所有的椭圆弧绘制完成后，单击鼠标右键，

结束椭圆弧的绘制。 
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如果需要手动设置椭圆弧的尺寸，可以按照以下的步骤进行。 

（1）在主菜单中选择“Place”->“Drawing Tools”->“Elliptic Arcs”命令，或者单击

“Utilities”工具栏中的绘图工具按钮 ，在弹出的的绘图工具栏中选择绘制椭圆弧工具 。  

（2）在工作区合适位置单击鼠标左键，确定椭圆弧的中心位置。 

（3）向左或向右移动鼠标指针调整椭圆弧所在椭圆的 x 轴半径，调整好后，单击鼠标

左键确定圆弧的 x 轴半径。 

（4）向上或向下移动鼠标，调整圆弧所在椭圆的 y 轴半径，调整好后，单击鼠标左键

确定圆弧的 y 轴半径。 

（5）移动鼠标指针，调整椭圆弧的起点位置，单击鼠标左键确定椭圆弧的起点，然后

移动鼠标，调整椭圆弧的终点位置，确定后单击鼠标左键，完成椭圆弧的绘制。 

（6）重复步骤（2）~（5）继续绘制其他的椭圆弧，所有圆弧绘制完成后单击鼠标右键

或“Esc”键退出绘制椭圆弧状态。 

5.贝赛尔曲线（Bezier）的绘制 

贝赛尔曲线是一种常用的曲线模型，利用该工具可以根据 4个相互分离的参考点绘制出

光滑的曲线。绘制贝赛尔曲线步骤如下。 

（1）在主菜单中选择“Place”->“Drawing Tools”->“Bezier”命令，或者单击“Utilities”

工具栏中的绘图工具按钮 ，在弹出的绘图工具栏中选择贝塞尔曲线工具 。 

（2）单击键盘上的“Tab”键，打开如图 2.118所示的“Bezier”对话框。 

 

图 2.118  “Bezier”对话框 

（3）单击“Color”色彩块，打开“Choose a color”对话框，在该对话框中选择一种颜

色作为绘制的贝塞尔曲线的颜色。 

（4）单击“Curve Width”右侧的文字，在弹出的下拉列表中选择贝塞尔曲线的宽度，

下拉列表中提供了四种宽度选项，分别是“Smallest”、“Small”、“Medium”和“Large”，

默认为“Small”项。 

（5）完成贝塞尔曲线的属性设置后，单击“OK”按钮，关闭“Bezier”对话框，结束

对曲线属性的设置。 

（6）工作区移动鼠标指针到合适位置，单击鼠标左键确定曲线的起点，然后移动鼠标

调整曲线的形状，单击鼠标左键，确定第二个定位点，然后采用同样方法，确定贝塞尔曲线

的第三定位点和终点，即可绘制出一段完整的曲线。如果需要，可连续绘制当前曲线的下一

段贝赛尔曲线（只需再确定三个点），否则按鼠标右键结束当前曲线的绘制。 

（7）重复步骤（6），绘制其它贝赛尔曲线，全部绘制完毕后，单击鼠标右键或单击“Esc”
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键退出绘制贝赛尔曲线状态。 

6.矩形绘制 

矩形通常是作为图文注释的边框，Altium Designer中可以绘制两种形式的矩形，一种是

直角矩形，另一种是圆角矩形。 

绘制直角矩形的步骤如下。 

（1）在主菜单中选择“Place”->“Drawing Tools”->“Rectangle”命令，或者单击“Utilities”

工具栏中的绘图工具按钮 ，在弹出的绘图工具栏中选择矩形工具 。 

（2）单击“Tab”键，打开如图 2.119所示的“Rectangle”对话框。 

 

图 2.119  “Rectangle”对话框 

（3）单击“Border Width”右侧的文字，在弹出的下拉列表中设置矩形边框线的宽度，

系统提供了“Smallest”、“Small”、“Media”和“Large”三种选项。默认为“Small”项。 

（4）单击“Fill Color”色彩块，打开“Choose a color”对话框，在该对话框中选择多

边形的填充区域内的颜色。 

（5）单击“Border Color”色彩条，打开“Choose a color”对话框，在该对话框中设置

矩形边界线的颜色。 

（6）勾选“Draw Solid”复选项，设置矩形内部有色彩填充，若未勾选该项，仅绘制矩

形线框，其内部不被色彩填充。 

（7）不勾选“Transparent”复选项，设置矩形覆盖下方的图元。 

（8）移动鼠标指针到合适位置，单击鼠标左键确定矩形的一个顶点，沿对角线移动鼠

标指针至矩形另一个顶点，单击鼠标，即完成当前矩形的绘制。 

（9）重复操作（8），绘制其他矩形，所有矩形绘制结束后，单击鼠标右键或者单击“Esc”

键，结束矩形的绘制。 

绘制圆角矩形的步骤如下 

（1）选择“Place”->“Drawing Tools”->“Round Rectangle”命令或者单击“Utilities”

工具栏中的绘图工具按钮 ，在弹出的绘图工具栏中选择绘制圆角矩形工具 。 

（2）单击键盘中的“Tab”键，打开如图 2.120所示的“Round Rectangle”对话框。 
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图 2.120  “Round Rectangle”对话框 

“Round Rectangle”对话框中的属性设置与绘制直角矩形时的“Rectangle”对话框中的

属性设置基本相同，区别在于，“Round Rectangle”对话框中增加了圆角的尺寸设置项，

“X-Radius”项用于设置圆角所在椭圆的“X”轴半径尺寸，“Y-Radius”项用于设置圆角

所在椭圆的“Y”轴半径尺寸。 

（3）在“Round Rectangle”对话框中设置圆角矩形的尺寸参数，单击“OK”按钮关闭

该对话框。 

（4）移动鼠标指针到合适位置，单击鼠标左键确定矩形的一个顶点，沿对角线移动鼠

标指针至矩形另一个顶点，单击鼠标，即完成当前矩形的绘制。 

（5）重复操作（4），绘制其他圆角矩形，所有圆角矩形绘制结束后，单击鼠标右键或

者单击“Esc”键，结束圆角矩形的绘制。 

7.椭圆绘制 

 绘制椭圆的步骤如下。 

（1）在主菜单中选择“Place”->“Drawing Tools”->“Ellipse”命令，或者单击“Utilities”

工具栏中的绘图工具按钮 ，在弹出的绘图工具栏中选择椭圆工具 。 

（2）单击键盘上的“Tab”键，打开如图 2.121所示的“Ellipse”对话框。 

 

图 2.121  “Ellipse”对话框 

（3）参照之前的绘制多边形和矩形的步骤，设置“Border Width”、“Border Color”、

“Fill Color”、“DrawSolid”和“Transparent”选项。 

（4）单击“X-Radius”右侧的文字，然后输入椭圆的 X 轴半径数值，设置欲绘制的椭
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圆的 X 轴半径尺寸。 

（5）单击“Y-Radius” 右侧的文字，然后输入椭圆的 Y 轴半径数值，设置欲绘制的椭

圆的 Y 轴半径尺寸。 

（6）单击“OK”按钮，关闭“Ellipse”对话框，结束椭圆属性的设置。 

（7）在工作区移动鼠标指针到合适位置，单击鼠标左键确定椭圆的圆心位置；然后保

持鼠标位置不动，连续单击鼠标左键两次，完成椭圆的绘制。 

如果需要使用鼠标动态调整椭圆的 X 轴和 Y 轴半径，可以在确定椭圆的圆心后，左右

移动鼠标，调整椭圆的 x 轴半径，然后单击鼠标左键，确定椭圆的 X 轴半径尺寸；接着上

下移动鼠标指针，调整椭圆的 Y 轴半径，调整好后，单击鼠标左键确定椭圆的 Y 轴半径尺

寸，完成当前椭圆的绘制。 

（8）重复步骤（7），在原理图上绘制其他的椭圆，所有椭圆绘制结束后，单击鼠标右

键或者单击“Esc”键，结束椭圆的绘制。 

8.扇形图绘制 

绘制扇形图的步骤如下。 

（1）主菜单中选择“Place”->“Drawing Tools”->“Pie Chart ”命令，或者单击“Utilities”

工具栏中的绘图工具按钮 ，在弹出的绘图工具栏中选择扇形工具 。 

（2）单击键盘的“Tab”键，打开如图 2.122所示的“Pie Chart”对话框。 

 

图 2.122  “Pie Chart”对话框 

（3）参照参照之前的绘制多边形和矩形的步骤，设置“Border Width”、“Border Color”、

“Color” 和“DrawSolid”选项。 

（4）单击“Radius”右侧的数字，输入要绘制的扇形图的圆半径数值。 

（5）单击“Start Angle”右侧的数字，输入扇形图的起始边的角度。 

（6）单击“End Angle”右侧的数字，输入扇形图的终止边的角度。 

（7）单击“OK”按钮，关闭“Pie Chart”对话框，结束扇形图属性的设置。 

（8）在工作区合适位置单击鼠标左键，确定扇形图的圆心；保持鼠标位置不动，连续

单击鼠标左键 3次，完成一个扇形图的绘制。 

如果需要动态的确定扇形图的参数，可以在确定扇形图圆心后，移动鼠标，调整扇形图

的半径，单击鼠标左键，确认扇形图的半径；然后移动鼠标指针调整扇形图的起始边的角度，

单击鼠标确认起始点；移动鼠标指针调整扇形图的终止边的角度，单击鼠标确认并完成当前

tyw藏书



第 2 章  原理图设计基础 

 ·98·   

饼图的绘制。 

（9）重复步骤（8）绘制其他扇形图，所有扇形图绘制完毕后单击鼠标右键，或“Esc”

键，结束扇形图的绘制。 

9.添加文本 

不具有电气意义的文本主要用于对电路图进行文字注解，在编译过程中将被忽略。添加

文本的步骤如下。 

（1）在主菜单中选择“Place”->“Text String”命令，或者单击“Utilities”工具栏中

的绘图工具按钮 ，在弹出的绘图工具栏中选择添加文本工具 。 

（2）单击“Tab”键，打开如图 2.123所示的“Annotation”对话框。 

 

图 2.123  “Annotation”对话框 

（3）单击“Color”右侧的色彩块，打开“Choose a color”对话框，在该对话框中选择

文字注解的颜色。 

（4）单击“Orientation”右侧的标注文字，在弹出的下拉列表中设置注释文字的旋转角

度，系统提供了“0 Degree”、“90Degree”、“180Degree”和“270Degree”四种文字方

向供选择，默认为“0 Degree”。 

（5）单击“Horizontation Justification”右侧的文字，在弹出的下拉列表中选择文字水

平对齐的方式，系统提供了“Left”、“Center”和“Right”三种对齐方式，默认为“Left”。 

（6）单击“Vertical Justification”右侧的文字，在弹出的下拉列表中设定文字的垂直对

齐方式，系统提供了“Bottom”、“Center”和“Top”三种对齐方式，默认为“Bottom”。 

（7）确定“Mirror”复选项处于未被选中状态，该复选项用于设置文字为镜像显示。 

（8）在“Properties”区域内的“Text”编辑框内输入添加的文字内容，也可以在下拉

列表中选择已有的变量名称等式。 

（9）单击“Font”右侧的“Change”按钮，打开如图 2.124 所示的“字体”对话框，

在该对话框中设置显示的文字字体，设置完成后，单击“OK”按钮，关闭“字体”对话框。 
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图 2.124  “字体”对话框 

（10）完成对文字属性的设置后，单击“Annotation”对话框中的“OK”按钮，关闭该

对话框。 

此时在“Annotation”对话框中设置好的文本将悬浮在鼠标指针上。 

（11）移动鼠标指针调整文本位置，单击鼠标添加文本。 

（12）按照以上介绍的方法，添加其他文本，当所有文本添加结束后，单击鼠标右键或

者单击“Esc”键，完成文本添加。 

10.布置文本框 

文本框与文本的区别是：文本字符串是简单的单行文本。文本框可以包含多行文本，原

理上无字数限制，常用于在图纸上放置多行注释文字。 

布置文本框的步骤如下： 

（1）在主菜单中选择“Place”->“Text Frame”命令，或者单击“Utilities”工具栏中

的绘图工具按钮 ，在弹出的绘图工具栏中选择布置文本框工具 。 

（2）单击键盘中的“Tab”键，打开如图 2.125所示的“Text Frame”对话框。 

 

图 2.125  “Text Frame”对话框 

（3）参照绘制矩形过程中的介绍，设置“Border Width”、“Border Color”、“Fill Color”
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和“Draw Solid”项。 

（4）勾选“Show Border”项，设置显示文本框的边缘线条，若为勾选该项则不会显示

文本框的边线。 

（5）单击“Text Color”右侧的色彩块，打开“Choose a color”对话框，设置文本的颜

色。 

（6）单击“Alignment”右侧的文字，在弹出的下拉列表中选择文本框中的文字对齐方

式，下拉列表中共提供了“Left”（左对齐）、“Center”（中央对齐）和“Rignt”（右对

齐）三种对齐方式供选择，默认为“Left”。 

（7）单击“Proprties”选项区域中的“Change…”按钮，打开如图 2.126所示的“TextFrame 

Text”对话框。 

 

图 2.126  “TextFrame Text”对话框 

（8）在“TextFrame Text”对话框中输入文本框中包含的文字内容，单击“OK”按钮，

关闭该对话框。 

（9）勾选“Word Wrap”复选项，设定文本框中的文字自动换行。 

（10）取消“Clip to Area”复选项的勾选状态，该选项用于设置裁剪文本内容，以适应

文本框的大小，若勾选该项，系统会根据文本框大小自动剪裁多余的文本，只显示文本框内

的文字信息。 

（11）设置好文本框的属性后，单击“OK”按钮，关闭“Text Frame”对话框。 

（12）在工作区移动鼠标指针到合适位置，单击鼠标左键确定文本框的一个顶点；移动

鼠标指针到另一位置，单击鼠标左键定出文本框大小，放置当前文本框。 

（13）重复步骤（3）~（12）放置其他文本框，所有文本框放置完毕后，单击鼠标右键

或单击“Esc”键，完成文本框的放置。 

11.插入图片 

为了更好的对原理图进行注释，用户常常需要在原理图中插入一些描述原理图性能的图

片，插入图片的步骤如下。 

（1）在主菜单中选择“Place”->“Drawing Tools”->“Graphic…”命令，或者单击“Utilities”

工具栏中的绘图工具按钮 ，在弹出的绘图工具栏中选择插入图片工具 。 

（2）单击键盘“Tab”键，打开如图 2.127所示的“Graphic”对话框。 
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图 2.127  “Graphic”对话框 

（3）参照参照绘制矩形过程中的介绍，设置“Border Width”、“Border Color”选项

内容。 

（4）在“Properties”选项区域中的“File Name”编辑框中输入需要插入的图像文件的

完整路径，或者单击“Browse…”按钮，打开如图 2.128所示的“打开”对话框，在该对话

框中选择需要插入的图像文件，单击“打开”按钮，将选中文件的完整路径输入到“FileName”

编辑框中。系统支持*.bmp、*.dib、*.rle、*.jpg、*.tif 、*.wmf、*.pcx、*.dcx、*.tga 等格式

的图像文件。 

 

图 2.128  “打开”对话框 

（5）勾选“Properties”选项区域中的“Embedded”复选项，该复选项用于设置插入图

片的方式。勾选该复选项后，图片文件的内容将被存入到原理图中；保存原理图的时候将一

起被保存，原理图文件所占用存储空间的大小将会增加。若未勾选该复选项，系统只会保存

图像文件的链接形式，这样利于减小原理图文件的存储空间，如果原图像文件发生变化，也

会导致原理图内图形框中的文件发生变化。 

（6）勾选“Properties”区域内的“Border On”复选项，设置显示插入的图片周围的边

框线。 
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（7）取消“Properties”区域内的“X：Y Ratio 1：1”复选项的勾选状态，该复选项用

于设置所插入图片的纵横比，勾选该复选项时，无论是图片的原始形状如何，插入到原理图

中的图片区域始终为正方形。 

（8）完成图片框属性的设置后，单击“OK”按钮，关闭“Graphic”对话框。 

（9）移动鼠标指针到工作区中的合适位置，单击鼠标确定图片框的一个顶点，移动鼠

标指针到另一位置，单击鼠标确定图片框的区域。系统会自动打开“打开”对话框。 

（10）在“打开”对话框中选择需要插入的图像文件，单击“打开”按钮完成图片插入，

如果在第（4）步中已经设置好了文件的路径，此时只需要直接单击“打开”按钮即可。 

（11）重复步骤（9）~（10）添加其他图片框，所有图片添加完毕后，单击鼠标右键或

者单击“Esc”键，结束图片框的添加。 

2.8  原理图实例 

为了让读者对于原理图的绘制有一个比较完整的印象，本节将通过一个完整的原理图设

计实例，使读者进一步了解电路原理图的设计过程。实例中将完成一个基于 7107芯片的三

位半 LED 显示数字电压表头的设计。最终完成的电路原理图如图 2.129所示。 

 

图 2.129  数字表头原理图 

2.8.1 新建项目文档 

在进行原理图设计之前需要新建一个 PCB项目文档，步骤如下。 

（1）单击桌面“开始”按钮，在弹出的菜单中选择“Altium Designer”图标，启动 Altium 

Designer。 

（2）单击工作区右侧的“Projects”标签，打开“Projects”工作面板。 

（3）单击“Projects”工作面板上的工作空间下拉列表，在弹出的列表中选择第一章中

新建的“ExampleWorkspace”工作空间，将其设置为当前的工作空间。 

（4）单击“Projects”工作面板上的“Workspace”按钮，在弹出的菜单中选择“Add New 

Project”->“PCB Project”命令，在当前工作空间中添加了一个默认名为“PCB_Project1.PrjPcb”
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的 PCB项目文件。 

（5）单击“Projects”工作面板中的“Project”按钮，在弹出的菜单中选择“Add New to 

Project”->“Schematic”命令，在新建的 PCB项目中添加一个默认名为“Sheet1.SchDoc”

的原理图文件。 

（6）在主菜单中选择“File”->“Save”命令，或者单击工具栏中的保存工具按钮，打

开如图 2.130所示的“Save [Sheet1.SchDoc] As…”对话框。 

 

图 2.130  “Save [Sheet1.SchDoc] As…”对话框 

（7）在 “Save [Sheet1.SchDoc] As…”对话框的“文件名”编辑框中输入“digit_meter”，

单击“保存”按钮，将原理图文件另存为“digit_meter.SchDoc”。 

（8）在“Projects”工作面板上选择“PCB_Project1.PrjPcb”名称，在主菜单中选择“File”

->“Save Project”命令，打开“Save [PCB_Project1.PrjPcb] As…”对话框。 

（9）在“Save [PCB_Project1.PrjPcb] As…”对话框的“文件名”编辑框中输入

“Digit_meter_PCB”，单击“保存”按钮，将 PCB项目文件保存为“Digit_meter_PCB .PrjPcb”。 

（ 10）在主菜单中选择“File” ->“Save Workspace As”命令，打开“Save 

[ExampleWorkspace.DsnWrk] As”对话框，单击保存按钮，保存该工作空间。创建完成后

“Projects”工作面板上显示的项目结构如图 2.131所示。 

 

图 2.131  “Projects”工作面板上显示的项目结构 

2.8.2设置图纸尺寸及版面 

完成 PCB项目及原理图文件的创建工作后，就要进行原理图的绘制工作，首先定义原

理图纸的尺寸及版面，本实例中将调用前面章节介绍的原理图模版，其具体操作步骤如下。 

（1）在“Projects”工作面板上双击新建的“digit_meter.SchDoc”文件名称，将其在工

作区打开，然后在主菜单中选择 “Design”->“Template”->“Set Template File Name”命

令，打开“打开”对话框。 

（2）在“打开”对话框中选择 2.4.1小节中创建的文档模板文件“B5_Template.SchDot”，
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单击“打开”按钮，打开如图 2.132所示的“Update Template”对话框。 

 

图 2.132  “Update Template”对话框 

（3）在“Update Template”对话框中选择“Just this document”和“Add new parameters 

that exist in the template only”项，单击“OK”按钮，更新原理图文件的模版。 

原理图模版更新完毕后，系统能够会显示如图 2.133所示的“Information”消息框，提

示已更新模版，单击“OK”按钮，关闭该消息框即可。 

 

图 2.133  “Information”消息框 

应用了模版后，原理图如图 2.134所示，其幅面大小变为“B5”，标题栏变为与模版中

一样的形式。 

 

图 2.134  应用模版后的原理图 

2.8.3加载元件库 

设置好图纸模版后，接下来就将进入真正的原理图设计内容了，通常电路由少数几个核
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心器件以及周边的附属器件组成，在绘制原理图时，应先布置核心器件。本设计实例中，核

心器件是型号为 7107的三位半集成数字表头芯片，在系统默认加载的器件库中并没有该元

件，需要查找并加载对应的元件库，具体操作步骤如下。 

（1）单击工作区右侧的“Libraries”标签，打开“Libraries”工作面板。 

（2）单击“Libraries”工作面板上的“Search…”按钮，打开如图 2.135所示的“Libraries 

Search”对话框。 

 

图 2.135  “Libraries Search”对话框 

（3）在“Libraries Search”对话框上部的编辑框内输入“7107”，在“Scope”选项区

域中选择“Librries on path”单选项，在“Path”选项区域的“Path”编辑框内输入系统的元

件库目录的默认路径，单击“Search”按钮，开始搜索。 

搜索完毕后，“Libraries”工作面板将显示所有与关键字“7107”相关的搜索结果，如

图 2.136所示。 
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图 2.136  加载元件库后的“Libraries”工作面板 

（5）从“Libraries”工作面板内显示的搜索结果列表中找出原理图中需要的，型号为

“ICL7107CJL”的器件，双击该器件的名称，打开如图 2.137所示的“Confirm”消息框，

提示用户，包含“ICL7107CJL”器件的元件库“Maxim Converter Analog to Digital.IntLib”

尚未被加载，并询问是否马上加载。 

 

图 2.137  “Confirm”对话框 

（6）单击“Confirm”对话框中的“Yes”按钮，加载该元件库，此时“ICL7107CJL”

器件已被选中，并吸附在鼠标指针上，等待被布置到原理图上，如图 2.138所示。 

 

图 2.138  鼠标指针上的“ICL7107CJL”器件 

（7）单击键盘上的“Tab”键，打开如图 2.139所示的“Component Properties”对话框。 

 

图 2.139  “Component Properties”对话框 
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（8）在“Component Properties”对话框中的“Designator”编辑框内输入“U1”，将该

元件的编号设置为“U1”，单击“OK”按钮，关闭“Component Properties”对话框 

（9）在原理图图纸中间偏左侧的空白处单击鼠标左键，布置一个编号为“U1”的

“ICL7107CJL”器件，然后单击鼠标右键，结束“ICL7107CJL”器件的布置。 

由于在原理图中使用的其它的附属电路的元件均在系统默认加载的“Miscellaneous 

Devices.IntLib”元件库中，所以无需再加载新的元件库了。 

2.8.4在原理图上布置其它元件 

加载所需的元件库后，接下来要在原理图中放置元件了，步骤如下。 

（1）单击“Libraries”标签，打开“Libraries”工作面板，在元件库列表中选择“Miscellaneous 

Devices.IntLib”。 

（2）在“Libraries”工作面板的元件列表中选择“Dpy Red-CA”器件，如图 2.140所

示。 

 

图 2.140  选择“Dpy Red-CA”器件 

（3）双击元件列表中的“Dpy Red-CA”器件名称，鼠标指针上将吸附一个“Dpy Red-CA”

器件的原理图符号。 

（4）单击键盘的“Tab”键，打开如图 2.141所示的“Component Properties”对话框。 
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图 2.141  “Component Properties”对话框 

（5）在“Component Properties”对话框的“Properties”区域内的“Designator”编辑框

中输入“DS1”，单击“OK”按钮，将器件编号为“DS1”。 

（6）在工作区原先布置“ICL7107CJL”器件的右侧连续布置四个“Dpy Red-CA”器件，

系统会对布置的四个“Dpy Red-CA”器件自动进行编号，编号分别是“DS1”、“DS2”、

“DS3”和“DS4”，如图 2.142所示。 

 

图 2.142  布置四个“Dpy Red-CA”器件后的原理图 

（7）在“Libraries”面板中的“miscellaneous Connectors.IntLib”元件库中选择名称为

“Header 8”的 8脚单排接头元件，将布置到原理图中如图 2.143所示的位置。 
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图 2.143   布置接头元件后的原理图 

以上的三种器件均是通过“Libraries”工作面板布置到原理图中的，在接下来的操作中，

将采用另外一种方法布置其余的元器件 

（7）在主菜单中选择“Place”->“Part…”命令，或者在工具栏中选择布置元器件工

具按钮 ，打开如图 2.144所示的。 

 

图 2.144  “Place Part”对话框 

（8）单击“Place Part”对话框中“Part Details”选项区域中“Physical Component”下

拉列表右侧的“...”按钮，打开如图 2.145所示的“Browse Libraries”对话框。 

 

图 2.145  “Browse Libraries”对话框 

（9）在“Browse Libraries”对话框上方的“Libraries”下拉列表中选择“Miscellaneous 

Device.IntLib”，然后，在下方的元器件列表中选择名称为“Res Semi”的贴片电阻器件，
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如图 2.146所示。 

 

图 2.146  选择“Res Semi”器件 

由于“Res Semi”器件有很多种不同的 PCB封装规格，为了方便 PCB图的设计，在原

理图设计时就要将器件的 PCB封装设置好，用户可在“Browse Libraries”对话框下方的元

件模型列表中选择合适的封装。 

（9）在元件列表下方的元件模型列表中选择“2012[0805]”封装，单击“OK”按钮，

关闭“Browse Libraries”对话框。 

（10）在“Place Part”对话框中的“Designator”编辑框内输入“R1”，将贴片电阻的

编号设置为“R1”，然后单击“OK”按钮，关闭该对话框。 

（11）在原理图中依次单击鼠标左键五次，布置五个电阻，系统会自动按照布置的次序，

给五个电阻分别编号“R1”~“R5”，然后设置编号为“R7”，接着在接头“P1”左侧布

置编号为“R7”~“R10”的四个电阻。 

（12）在电阻“R1”上双击鼠标左键，打开“Component Properties”对话框，在对话

框右侧的“Parameters for R1-Res Semi”列表中的“Value”行中设置其“Value”值为 100k，

取消“Comment”右侧的“Visible”勾选状态，单击“OK”按钮，将电阻“R1”的阻值设

置为 100kΩ。 

（13）按照步骤（12）的方法，设置“R2”的阻值为 15kΩ，“R3”的阻值为 10kΩ，

“R4”的阻值为 1MΩ，“R5”的阻值为 47kΩ，“R7”~“R10”的阻值为 100Ω，如图

2.147所示。 
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图 2.147  设置完阻值后的电阻 

（14）按照上述步骤中介绍的方法，在电路图中添加 5个封装型号为“C1206”的Cap Semi

电容元件，其编号和电容值分别为“C1”为 100pF，“C2”为 0.01uF，“C3”为 0.47uF，

“C4”为 0.22uF，“C5”为 0.1uF。添加完这些元件后的电路图如图 2.148所示。 

 

图 2.148  添加完元件后的电路图 

（15）在“Library”面板内的“Miscellaneous Devices.IntLib”元件库中双击名称为“RPot 

SM”的电位器元件，单击键盘“Tab”键，打开“Component Properties”对话框。 

（16）在“Component Properties”对话框中的“Designator”编辑框内输入“R6”，取

消“Comment”编辑框右侧的“Visible”复选项的勾选状态，然后单击“Component Properties”

对话框右侧的“Parameters for R6-RPot SM”列表下方的“Add”按钮，打开如图 2.149所示

的“Parameter Properties”对话框。 

 

图 2.149  “Parameter Properties”对话框 

（17）在“Parameter Properties”对话框中的“Name”编辑框内输入“Max Value”，

在“Value”编辑框内输入“1k”，单击“OK”按钮，关闭“Parameter Properties”对话框。 

（18）勾选“Component Properties”对话框内“Parameters for R6-RPot SM”列表中“Max 

Value”所在行的“Visible”复选项，单击“OK”按钮，关闭“Component Properties”对话

框。 

（19）在原理图中单击鼠标左键，布置一个编号为“R6”的电位器原理图符号。 

（20）在“Library”面板内的“Miscellaneous Devices.IntLib”元件库中双击名称为“D 

Zener”的稳压管元件标志，然后单击键盘上的“Tab”键，打开“Component Properties”对

话框。 

（21）在“Component Properties”对话框中的“Designator”编辑框内输入“D1”，取
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消“Comment”编辑框右侧的“Visible”复选项的勾选状态。 

（22）按照步骤（16）~（18）介绍的方法在“Component Properties” 对话框内“Parameters 

for R6-RPot SM”列表中添加名称为“Value”的参数，并将参数值设置为“1.2V”，勾选该

参数的“Visible”项。 

（23）单击“Component Properties” 对话框内“Models for D1 – DZener”列表下方 “Add”

按钮右侧的下拉列表按钮 ，在弹出的下拉列表中选择“FootPrint”项，打开如图 2.150所

示的“PCB Model”对话框。 

 

图 2.150  “PCB Model”对话框 

（24）在“PCB Model”对话框中的“Name”编辑框内输入“C1206”，单击“OK”

按钮，将稳压管的引脚封装形式改为“C1206”，单击 Component Properties” 对话框中的

“OK”按钮，然后在原理图中单击鼠标左键，布置一个稳压管，单击鼠标右键，结束稳压

管的布置，布置完稳压管后的原理图如图 2.151所示。 

 

图 2.151  布置完稳压管后的原理图 

（25）单击快捷工具栏中的添加电源工具按钮 ，分别在原理图中的元件“U1”的第

21脚和第 26脚、元件“DS1”~“DS4”的第 6脚处和接头“P1”的左侧单击鼠标左键，共

添加七个电源地标志，如图 2.152所示。 
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图 2.152  添加的七个电源地标志 

（26）单击键盘上的“Tab”键，打开“Power Port”对话框，在 Net编辑框中输入“VCC”，

单击“Style”右侧的“GND”字样，在弹出的下拉列表中选择“Bar”，单击“OK”按钮。 

（27）分别在原理图中“R2”左端，“U1”第 1 脚和接头“P1”左侧单击鼠标，布置

三个电源标志，如图 2.153所示。 

 

图 2.153  添加的三个电源标志 

（28）单击快捷工具栏中的添加总线工具按钮 ，在原理图中绘制如图 2.154所示的总

线。 

 

图 2.154  绘制的总线 

（29）单击快捷工具栏中的添加总线引入线工具按钮 ，在原理图中添加如图 2.155所

示的总线引入线。 
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图 2.155  添加总线引入线后的原理图 

添加总线引入线后，实际上并没有在元器件之间建立任何连接关系，为确定连接关系，

还需要添加网络标签。 

（30）单击快捷工具栏中的添加网络标签工具按钮 ，然后单击键盘“Tab”键，打开

“Net Label”对话框，在“Net”编辑框内输入网络标签的名称“a1”，单击“OK”按钮，

关闭“Net Label”对话框。 

（31）在元件“U1”的第 5脚处单击鼠标左键，布置一个名称为“a1”的网络标签。 

（32）按照步骤（30）~（31）介绍的方法布置其他的网络标签，本例中网络标签的名

称和位置如表 2.1所示 

表表表表 2.1  网络标签布置表网络标签布置表网络标签布置表网络标签布置表 

网络标签名称 布置的位置 

a1 元件“U1”的第 5 脚 元件“DS1”的第 10 脚 

b1 元件“U1”的第 4 脚 元件“DS1”的第 9 脚 

c1 元件“U1”的第 3 脚 元件“DS1”的第 8 脚 

d1 元件“U1”的第 2 脚 元件“DS1”的第 5 脚 

e1 元件“U1”的第 8 脚 元件“DS1”的第 4 脚 

f1 元件“U1”的第 6 脚 元件“DS1”的第 2 脚 

g1 元件“U1”的第 7 脚 元件“DS1”的第 3 脚 

dp0 元件“R7”左侧引脚 元件“DS1”的第 7 脚 

a2 元件“U1”的第 12 脚 元件“DS2”的第 10 脚 

b2 元件“U1”的第 11 脚 元件“DS2”的第 9 脚 

c2 元件“U1”的第 10 脚 元件“DS2”的第 8 脚 

d2 元件“U1”的第 9 脚 元件“DS2”的第 5 脚 

e2 元件“U1”的第 14 脚 元件“DS2”的第 4 脚 

f2 元件“U1”的第 13 脚 元件“DS2”的第 2 脚 

g2 元件“U1”的第 25 脚 元件“DS2”的第 3 脚 

dp1 元件“R8”左侧引脚 元件“DS2”的第 7 脚 

a3 元件“U1”的第 23 脚 元件“DS3”的第 10 脚 

b3 元件“U1”的第 16 脚 元件“DS3”的第 9 脚 

c3 元件“U1”的第 24 脚 元件“DS3”的第 8 脚 

d3 元件“U1”的第 15 脚 元件“DS3”的第 5 脚 

e3 元件“U1”的第 18 脚 元件“DS3”的第 4 脚 

f3 元件“U1”的第 17 脚 元件“DS3”的第 2 脚 

g3 元件“U1”的第 22 脚 元件“DS3”的第 3 脚 

dp2 元件“R9”左侧引脚 元件“DS3”的第 7 脚 
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ab4 元件“U1”的第 19 脚 元件“DS4”的第 8 脚和第 9 脚 

pol 元件“U1”的第 20 脚 元件“DS4”的第 3 脚 

dp3 元件“R10”左侧引脚 元件“DS4”的第 7 脚 

com 元件“U1”的第 35 脚 元件“U1”的第 32 脚 

input+ 元件“R4”的左侧引脚 接头“P1”的第 7 脚 

input- 元件“C2”的下端引脚 接头“P1”的第 8 脚 

（33）单击快捷工具栏中的布置导线工具按钮 ，按照图 2.156所示，将各元件用导线

连接起来。 

 

图 2.156  连接导线后的原理图 

做到这里，原理图的电气部分已经绘制完成了，为了让原理图的使用者能更清晰的了解

原理图的功能，还需要添加一些注释。 

（34）单击快捷工具栏中的绘图工具按钮 ，在弹出的绘图工具栏中选择添加注释概

工具按钮 ，单击键盘“Tab”键，打开“Annotation”对话框。 

（35）在“Annotation”对话框内的“Properties”选项区域中的“Text”编辑框中输入

“个位”，单击“OK”按钮，关闭该对话框，然后在编号为“DS1”的元件顶部单击鼠标

左键，布置注释文本，表示该数码管所显示的数据为个位数据。 

（36）重复步骤（34）在“DS2”~“DS4”上面分别布置内容为“十位”、“百位”

和“千位、符号位”的注释文本。 

（37）单击快捷工具栏中的绘图工具按钮 ，在弹出的绘图工具栏中选择添加文本框

工具按钮 ，单击键盘“Tab”键，打开“Text Frame”对话框。 

（38）单击“Text Frame”对话框内“Properties”选项区域中的“Text”文本右侧的

“Change…”按钮，打开“Text Frame Text”编辑框。 

（39）在“Text Frame Text”编辑框中输入“-2V~+2V输入”和“-1999~1999范围显示”

两行文本，单击“OK”按钮，关闭“Text Frame Text”编辑框，然后单击“Text Frame”对

话框中的“OK”按钮，在原理图左上角布置一个文本框，说明该电路的功能。 

添加注释后的原理图如图 2.157所示。 
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图 2.157  添加注释后的原理图 

2.7.6  标题栏设置 

标题栏设置步骤如下。 

（1）在工作区单击鼠标右键，在弹出的右键菜单中选择“Options”->“Document 

Parameters…”命令，打开如图 2.158所示的“Document Options”对话框，显示“Parameters”

选项卡。 

 
图 1.158  “Document Options”对话框 

（2）在“Document Options”对话框中的参数列表中的“Value”列中输入各参数的内

容，输入完成后单击“OK”按钮，关闭该对话框。 

在标题栏中，各项的内容均通过原理图参数表示，通过对原理图中的参数的“Value”

项进行设置，即可修改标题栏的内容。当设置完页面参数后，原理图中的标题栏如图 1.159

所示，其显示内容并不发生变化。 

 

图 2.159  标题栏 

在图纸打印输出时，标题栏中真正的内容才会被显示出来，如图 2.160所示。 
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图 2.160 打印预览中的标题栏 

2.7.7  图纸输出 

图纸完成后，接下来要做的就是存档和输出了，步骤如下。 

（1）在主菜单中选择“File”->“Save All”命令，将所有文件存盘。 

（2）在主菜单中选择“File”->“Page Setup”命令，打开如图 2.161所示的“Schematic 

Print Properties”对话框。 

 

图 2.161  “Schematic Print Properties”对话框 

（3）在“Schematic Print Properties”对话框的“Print Page”区域内选择“Portrait”项，

设置打印方向为竖直打印，单击“Printer Setup”按钮，打开如图 2.162 所示的“Printer 

Configuration for [Documentation Output]”对话框。 

 

图 2.162  “Printer Configuration for [Documentation Output]”对话框 
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（4）在“Printer Configuration for [Documentation Output]”对话框的“Printer”区域内

的“Name”下拉列表中选择已安装的打印机设备。 

（5）单击“Printer Configuration for [Documentation Output]”对话框中的“OK”按钮，

关闭该对话框，然后单击“Schematic Print Properties”对话框中的“Preview”按钮，打开如

图 2.163所示的“Preview Schematic Prints of [digit_meter.SchDoc]”窗口。 

 

图 2.163  “Preview Schematic Prints of [digit_meter.SchDoc]”窗口 

（50）经预览检查合格后，单击“Preview Schematic Prints of [digit_meter.SchDoc]”窗

口中的“Print”按钮，开始打印。 
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第 3章  原理图编辑 

电路原理图的设计过程实际上是一个不断修改原理图的过程，设计者的大量时间将用于

修改已有的原理图，使其更加完善或者将其部分修改后应用到新的设计中去。因此，对于电

路设计人员来说，熟练掌握原理图的编辑技巧将是非常重要的，本章将系统介绍原理图的编

辑方法。 

3.1  原理图的基本编辑操作 

对原理图的编辑过程是由诸如：选取、复制、剪切、移动、排列与对齐等基本操作组合

而成，读者熟练掌握这些基本操作方法后，原理图的编辑工作效率将大大提高，本节将具体

介绍这些基本操作的方法。 

3.1.1选取图元 

“选取”是电路编辑过程中最基本的操作，在对电路图中已存在的图元进行编辑之前，

必须选取操作对象。在默认设置下，被选取的图元对象上将显示绿色的虚线框，表示该图元

对象被选中。Schematic Editor为用户提供了多种选取图元对象的方法，具体介绍如下。 

1.使用鼠标选取 

使用鼠标选取图元是最直接的选取方式，当只需要选取单个图元对象时，可进行如下操

作： 

（1）将鼠标指针移动到需要选取的对象上，然后单击鼠标左键即可选中图元对象。 

当需要选择多个分布较分散的图元对象时，可进行如下操作： 

（1）按住“Shift”键，然后用鼠标一一单击需要选取的对象即可连续选择多个对象。 

当需要选取位置集中的多个图元对象时，可进行如下操作： 

（1）在图纸的合适的空白位置，按住鼠标左键，当鼠标指针变成十字状后，拖动鼠标

指针，显示一个动态矩形选择框，当所有待选图元完全包括在矩形选择框内后，释放鼠标左

键即可选中矩形区域内完全包含的所有对象。 

进行该操作需要注意三点，一是只有在空白位置单击才能将鼠标指针变为十字状；二是

在拖动过程中，不能松开鼠标左键，需要保持鼠标指针为十字状。三是只有被矩形框完全包

含的对象才能被选中。 

2.使用“Edit”-> “Select”菜单选取 

在主菜单“Edit”->“Select”中提供了几个选取图元对象的命令，如图 3.1所示。这些

命令的使用介绍如下。 

tyw藏书



第 3 章  原理图编辑 

 ·120·   

 

图 3.1  “Edit”->“Select”菜单 

1）“Edit”->“Select”->“Inside Area”命令 

该命令用于选取对象选择框内的对象，与标准工具栏中的区域选取工具按钮 的功能

完全一致。 

2）“Edit”->“Select”-> “Outside Area”命令 

该命令用于选取对象选择区域外的对象，即当前图纸中与选择区域完全无交集的所有图

元对象。操作步骤与使用 Edit”->“Select”->“Inside Area”命令相同，只是选择的对象不

同。 

3）“Edit”->“Select”-> “A11”命令 

该命令用于选取当前图纸上的所有图元对象，用户可以使用快捷键“Ctrl”+“A”执行

该命令。 

4）“Edit”->“Select”-> “Connection”命令 

该命令用于选取连接在同一通路上的所有图元，操作步骤如下： 

（1）选择“Edit”->“Select”-> “Connection”命令，鼠标指针将变成十字状。 

（2）在需要选取的某个连接的导线、节点、输入/输出端口或网络标签上单击鼠标，此

时与所单击图元有连接关系的所有导线、电气节点、输入/输出端口以及网络标签等（元件

引脚除外）图元将被选中。 

5）“Edit”->“Select”-> “Toggle Selection”命令 

该命令用于连续选取对象，操作步骤如下： 

（1）选择“Edit”->“Select”-> “Toggle Selection”命令，鼠标指针将变成十字状。 

（2）依次单击需要选择的图元对象，使其成为被选中状态。 

当单击已处于选中状态的图元对象时，将解除该图元对象的选中状态，如果鼠标单击点

位于多个图元对象的重合区域时，系统将弹出如图 3.2所示的下拉列表，显示附近的所有图

元对象的类型和位置坐标，用户可据此选择需要选取的图元对象，然后单击下拉列表中的对

应项，即可选中所需的图元对象。 
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图 3.2  下拉列表 

（3）单击鼠标右键结束选取。 

3使用区域选取工具按钮  

使用原理图标准工具栏中的区域选取工具按钮 可以一次选择多个图元对象，其具体

操作如下： 

（1）单击原理图标准工具栏上的框选工具按钮 ，鼠标指针变为十字形，在图纸上合

适位置单击鼠标，确定对象选取区域的一个顶点。 

（2）然后移动鼠标指针，调整对象选取区域的大小和形状，然后单击鼠标确定对象选

取区域，此时对象选取区域内完全包含的所有对象将全部被选中。 

与拖动鼠标选取方式相比，使用区域选取工具按钮 有两个区别，一是使用区域选取

工具按钮 在确定选取区域第一个顶点时，该顶点不需要在原理图的空白区域；二是使用

区域选取工具按钮 在确定选取区域大小和形状时，不需要始终按住鼠标左键。 

3.1.2  解除对象的选取状态 

当对被选取的对象执行完移动、复制、粘贴等操作后，需要解除对象的选中状态，以便

进行下一步操作。Altium Designer中有方法可实现解除对象的选中状态，具体介绍如下。 

1.使用鼠标解除图元对象的选中状态 

解除单个对象的选中状态 

如果想解除个别对象的选取状态，这时只需将鼠标指针移动到图元对象上，当鼠标指针

形状变为 形后，单击鼠标左键，即可解除该图元对象的选中状态。此操作过程不影响其他

的图元对象的状态。 

解除所有图元对象的选中状态 

当有多个对象被选中时，如果想一次解除所有对象的选取状态，这时只需在图纸上非选

中区域的任意位置单击鼠标即可。需要注意的是，这个方法只有在“Preferences”对话框的

“Graphical Editing”选项卡中的“Click Clears Selection”复选项被选中状态下才有效。 

2. 使用“Edit” ->“Deselect”菜单命令解除图元对象的选中状态 

“Edit”->“Deselect”菜单如图 3.3所示，共提供了 5个取消选取的命令，这些命令的

使用介绍如下。 
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图 3.3  “Edit” ->“Deselect”菜单 

1）“Edit” ->“Deselect”->“Inside Area”命令 

该命令用于解除所选择区域内的所有完整对象的选中状态，选择该命令后，单击鼠标左

键确定选定区域的一个顶点，然后拖动鼠标，调整选择区域的大小，最后再单击鼠标左键，

确定选定的区域，此时该区域内的所有完整的图元对象将处于非选中状态。如果图元对象有

部分处于该区域外，该图元对象的状态将不会发生变化。 

2）“Edit” ->“Deselect”->“Outside Area”命令 

该命令用于解除鼠标指针所拖出的区域以外的所有对象的选中状态，操作过程与“Edit” 

->“Deselect”-> “Inside Area”命令类似，选择该命令，并确定选择区域后，所有区域外

的完整图元将处于非选中状态，。如果图元对象有部分处于该区域内，该图元对象的状态将

不会发生变化。 

3）“Edit” ->“Deselect”->“All On Current Document”命令 

选中该命令后，当前文档内的所有图元对象的选中状态将被解除。该命令与标准工具栏

内的解除选中工具按钮 的功能完全相同。 

4）“Edit” ->“Deselect”->“All Open Documents”命令 

选中该命令后，所有被打开的原理图文档内的图元对象都将被解除选中状态。 

5）“Edit” ->“Deselect”->“Toggle Selection”命令 

该命令的使用方法与 3.1.1节中“Edit” ->“Select”->“Toggle Selection命令相同，功能也

完全相同，当单击被选中的图元对象时，将解除该对象的选中状态，相反当单击未被选中的

图元对象时，将使该对象处于选中状态。 

3.使用工具栏按钮 解除图元对象的选中状态 

单击标准工具栏上的解除选中工具按钮 ，图纸上所有处于被选中状态的图元对象都

将解除选中状态。 

3.1.3  图元对象的剪切、复制、粘贴 

Altium Designer提供了一个剪贴板，最多可存储 24块内容，该剪贴板可以与 Windows

操作系统的剪贴板共享空间，可方便用户在不同的应用程序之间“复制”、“剪切”和“粘
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贴”对象。用户可以将 Altium Designer中的原理图图元复制到 Word文档和 PowerPoint报

告中去，也可以将剪贴板中的其他的内容粘贴到 Altium Designer的原理图中。图元对象的

剪切、复制、粘贴方法具体如下。 

1.剪切图元对象 

剪切就是将选取的对象直接移入剪贴板中，同时删除电路图上的被选取对象。剪切图元

对象的步骤如下。 

（1）在工作区选取需要剪切的图元对象。 

（2）在主菜单中选择“Edit”->“Cut”命令，或者单击标准工具栏上的剪切工具按钮 ，

或按“Ctrl”+“X”快捷键，启动剪切命令。 

此时，选中的图元对象将被添加到剪贴板中，用户可单击工作区域右侧的“Clipboard”

页面标签，打开“Clipboard”页面，检查剪贴板。 

2.复制图元对象 

复制就是将选取的对象复制到剪贴板中，同时还保留原理图上选取的被复制图元对象。

复制图元对象的步骤如下： 

（1）在工作区选取需要复制的图元对象。 

（2）单击标准工具栏上的复制工具按钮 ，或者在主菜单中选择“Edit”->“Cut”命

令，或按“Ctrl”+“C”快捷键，启动复制命令。此时，选中的图元对象将被添加到剪贴板

中。 

3.粘贴图元对象 

粘贴就是将剪贴板上的内容复制后插入当前文档中。只有在剪贴板中有内容的情况下，

粘贴操作才可进行。Altium Designer提供的剪贴板能容纳 24块剪贴内容，粘贴最新复制的

图元对象的步骤如下。 

（1）在主菜单中选择“Edit”->“Paste”命令，或者单击标准工具栏上的粘贴图标 ，

或使用快捷键“Ctrl”+“V”。 

启动粘贴命令后，鼠标指针变成“十”字形，且鼠标指针上悬浮着剪贴板中最新的图元

对象。 

（2）将鼠标指针移到合适的位置，单击鼠标，即可在该处布置粘贴的图元对象。 

执行粘贴操作时，与布置新的图元方法一样，可以单击空格键旋转鼠标指针上所粘附的

对象，单击“X”键左右翻转图元对象，单击“Y”键上下翻转图元对象。 

如果用户需要粘贴剪贴板中的其它图元对象时，操作步骤如下。 

（1）单击工作界面右侧的“Clipboard”页面标签，打开如图 3.4 所示的“Clipboard”

页面。 
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图 3.4  “Clipboard”页面 

（2）在“Clipboard”页面中单击需要粘贴的内容块，将移动鼠标到工作区域，此时鼠

标指针变成“十”字形，上面悬浮着剪贴板中最新的图元对象。 

（3）将鼠标指针移到合适的位置，单击鼠标，即可在该处布置粘贴的图元对象。 

除了可以在图纸上粘贴原理图的图元对象之外，AltiumDesigner6.0能将其它 Windows

程序的图像、文字内容粘贴到原理图中，要实现该功能，需要用到“Smart Paste”的命令，

下面将通过一个将 Word文件中的图形文字粘贴到原理图文件中的例子，介绍“Smart Paste”

命令的使用方法。 

（1）启动 Word软件，打开包含需要复制的内容的文件，选择需要复制的内容，在 Word

软件的主菜单中选择“Edit”->“Paste”命令，或者单击标准工具栏上的粘贴图标 ，或使

用快捷键“Ctrl”+“V”，将该内容复制到 Windows 的通用剪贴板中。本例中将复制如图

3.5所示的图形和文字。 

 

图 3.5  复制的图片和文字 

（2）在 Altium Designer中选择“Edit”->“Smart Paste”命令，或按快捷键“Shift+Ctrl+V”

打开如图 3.6所示的“Smart Paste”对话框。 
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图 3.6  “Smart Paste”对话框 

（3）在“Smart Paste”对话框中的“Choose the objects to paste”选项区域内，取消

“Schematic Object Type”列表中的“Part”项，勾选“Windows Clipboard Contents”列表中

的“Pictures”项，单击“OK”按钮。 

此时鼠标指针变成“十”字形，上面悬浮着从 Word中复制的图形和文字。 

（4）将鼠标指针移到合适的位置，单击鼠标，即可在该处布置粘贴的图元对象。粘贴

图形后的原理图如图 3.7所示。 

 

图 3.7  粘贴图形后的原理图 

使用“Smart Paste”命令，用户还能将网页、PDF资料等其它程序中的图片文字内容粘

贴到原理图文件中。 

4.阵列复制 

使用 Schematic Editor中的阵列粘贴功能，可按一定阵列方式将被复制对象一次性重复

粘贴形成多个拷贝。在需要布置阵列元件，例如布置键盘时，该方法可节省大量时间，其具

体操作如下。 

（1）在原理图上添加开关元件“SW-PB”，并设置其标志为“S1”。 

（2）选择开关“S1”，然后单击标准工具栏上的复制工具按钮 ，或者在主菜单中选

择“Edit”->“Cut”命令，或按“Ctrl”+“C”快捷键，启动复制命令。此时，选中的图元
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对象将被添加到剪贴板中。 

（3）在主菜单中选择“Edit”->“Smart Paste”命令，或按快捷键“Shift+Ctrl+V”打

开“Smart Paste”对话框。 

（4）在“Smart Paste”对话框中的“Choose the objects to paste”选项区域内，勾选

“Schematic Object Type”列表中的“Part”项，取消“Windows Clipboard Contents”列表中

的所有项。 

“Smart Past”对话框中的“Paste Array”区域用于设置阵列元件的属性参数。具体各项

功能如下： 

1）“Enable Paste Array”复选框用来设置是否使用复制阵列。 

2）“Column”栏用来设置复制元件阵列的行参数，“Count”编辑框用于设置阵列每

行的元件数量，即阵列的列数，“Spacing”编辑框用于设置阵列元件中每行的相邻元件的

间距，即列间距，若设置为正数，则元件由左向右排列，若设置为负数，则元件由右向左排

列。 

3）“Row”栏用来设置复制元件阵列的列参数，“Count”编辑框用于设置阵列每列的

元件数量，即阵列的行数，“Spacing”编辑框用于设置阵列元件中每列的相邻元件的间距，

即行间距。若设置为正数，则元件由下向上排列，若设置为负数，则元件由上向下排列。。 

4）“Text Increment”栏用于设置阵列中元件编号递增的参数，其中“Direction”下拉

列表确定元件编号递增的方向，“None”项表示元件编号不递增，“Horizontal First”表示

元件编号递增的方向是先水平方向从左向右递增，再竖直方向由下往上递增，“Vertical First”

表示先竖直方向由下往上递增，再水平方向从左向右递增。“Primary”编辑框用于设置每

次递增时，元件主编号的递增数量，“Secondary”编辑框用于在复制引脚时，设置引脚序

号的递增量。这两个编辑框既可以设置为正数（递增），也可以设置为负数（递减）。 

6）“Vertical”编辑框用来设定两个拷贝之间在垂直方向的偏移量，若为正数，则向上

偏移，否则向下偏移。 

（5）在“Setup Paste Array”对话框中设置阵列参数，设置完毕后，单击“OK”按钮 

（5）在“Smart Paste”对话框中的“Paste Array”选项区域内勾选“Enable Paste Array”

项，在“Columns”栏中的“Count”编辑框中输入“4”，在“Spacing”编辑框中输入 80，

在“Rows”栏中的“Count” 编辑框中输入“4”，在“Spacing”编辑框中输入-60，在“Text 

Increment”栏中的“Direction”下拉列表中选择“Horizontal First”项，单击“OK”按钮。 

（6）移动鼠标指针到原理图上的合适位置，单击鼠标左键即可完成阵列复制，完成复

制后的原理图如图 3.8所示。 

 

图 3.8  完成复制后的原理图 
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复制完成后，原理图中将出现两个编号为“S1”的元件，用户可删除步骤（1）中布置

的一个“S1”开关元件。 

5.直接复制图元对象 

DXP Schematic Editor提供了一种直接复制图元对象到工作区的方式，这就是

“Duplicate”命令。该命令的使用步骤如下。 

（1）在工作区选择需要复制的对象。 

（2）在主菜单中选择“Edit”->“Duplicate”命令，或者使用快捷键“Ctrl+D”，启动

直接复制命令。在被选对象右下方创建一个所选对象的复制品。 

当创建一个拷贝以后，先前选中图元对象的选中状态将被解除，新创建的复制图元将处

于选取状态，同时将对象放到剪贴板。 

6.橡皮图章 

就是橡皮图章。与直接复制命令相似，使用该功能可以一次完成复制、粘贴的操作，还

能设定复制的图元的位置，使用该命令前要确认系统参数设置对话框“Preferences”的

“Gmphica Editing”选项卡中的“Clipboard Reference”复选项被选中了。该命令的使用方

法如下。 

（1）在工作区选择需要复制的对象，将其设置为已选中状态。 

（2）在主菜单中选择“Edit”->“Rubber Stamp”命令，或者单击标准工具栏上的橡皮

图章工具按钮 ，或使用快捷键“Ctrl+R”。 

此时，被选中的图元对象将被复制，复制后的图元将粘附到鼠标指针上。 

（3）移动鼠标指针到合适位置，单击鼠标左键，在鼠标指针单击位置放置一个复制的

图元对象。 

（4）重复步骤（3），在其他位置放置复制的图元对象，图元对象复制结束后单击鼠标

右键退出当前状态。 

一旦使用该命令，系统会自动将拷贝放到剪贴板上，所有图元对象的选中状态。不发生

改变。 

3.1.4  删除图元对象 

DXP Schematic Editor提供两种删除图元的命令，即“Clear”和“Delete”命令，分别

介绍如下。 

1.“Clear”命令 

“Clear”命令的功能是删除已选取的对象，操作步骤如下： 

（1）选取需要删除的图元对象。 

（2）在主菜单中选取“Edit”->“Clear”命令，或按键盘的“Del”键，删除选中的图

元对象。 

2.“Delete”命令 

“Delete”命令与“Clear”命令之间的区别在于，使用“Clear”只是执行一次删除动作，

删除实现选中的图元对象，而使用“Delete”命令会将系统转换到删除状态，在该状态下选

取的图元对象都将被删除。“Delete”命令的操作步骤如下： 
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（1）在主菜单中选择“Edit”->“Delete”命令。 

启动“Delete”命令后，鼠标指针变成十字状。 

（2）单击选中欲删除的图元对象，即可删除该对象。 

（3）重复步骤（2）继续删除其他欲删除的图元对象，删除完成后单击鼠标右键或者“Esc”

键，结束“Delete”操作。 

3.1.5  移动图元对象 

DXP Schematic Editor为用户提供两种移动图元对象的方式，分为“平移”和“层移”

两种情况。“平移”指图元对象在同一个平面上移动。“层移”指通过移动图元对象来调整

对象间的层次关系，若一个对象将另外一个对象遮盖住的时候，通过“层移”来调整对象间

的上下关系。 

使用“Edit”->“Move”菜单命令 

在主菜单“Edit”->“Move”下包含多个移动命令，如图 3.9所示，这些命令的使用方

法如下。 

 

图 3.9  “Edit”->“Move”下的移动命令 

1、“Edit”->“Move”->“Drag”命令 

该命令主要用来实现对图元对象的拖动，在拖动的过程中，会保持图元对象的电器连接

状态，系统会自动调节图元对象的连接导线的长度和形状。使用该命令，不要求事先选取图

元对象。使用该命令时，如果被拖动的图元对象为元件，则元件上的所有连线也会跟着移动，

不会断线。如果被拖动的对象为导线，则导线的两个端点的连接状态将保持不变。图 3.10

所示即为使用“Edit”->“Move”->“Drag”命令移动电子元件“U2”前后的电路。 
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移动电子元件“U2”前的电路    移动电子元件“U1”后的电路 

图 3.10  使用“Edit”->“Move”->“Drag”命令移动电子元件“U2” 

使用“Edit”->“Move”->“Drag”命令的步骤如下。 

（1）在主窗口中选择“Edit”->“Move”->“Drag”命令。 

启动“Drag”命令后，鼠标指针变成十字状。 

（2）移动鼠标指针到需要移动的图元对象上，单击鼠标，使该图元对象悬浮于鼠标指

针上。 

（3）移动鼠标指针至合适位置，如果有必要，使用“Ctrl + Space”键顺时针旋转图元

对象的方向，单击鼠标，将图元放置到原理图上。 

（4）重复步骤（2）和（3）继续移动其他的图元对象，完成移动后，单击鼠标右键或

者单击“Esc”键，结束“Drag”操作。 

在移动对象的过程中，使用以下快捷键可以调整图元对象的位置和方向 

“Ctrl + Space”快捷键可逆时针旋转图元对象的方向。 

“Shift+Ctrl+Space”快捷键可顺时针旋转图元对象的方向。 

“Space”键可切换导线两端的连接模式。 

“X”键可以沿 X 轴方向，即水平方向翻转图元对象。 

“Y”键可以沿 Y 轴方向，即垂直方向反转图元对象。 

需要注意的是，移动过程中应尽量避免出现如图 3.11 所示的因为导线自动调整不当，

而错误的将其他引脚短接的现象。 

   

移动前                        移动后 

图 3.11  导线自动调整不当的情况 

使用“Edit”->“Move”->“Drag”命令还可以在不变动电路连接性质的情况下调整导

线的布置位置。如图 3.12所示，即为使用“Edit”->“Move”->“Drag”命令移动导线布置

操作前后的电路图。 
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移动导线前                     移动导线后 

图 3.12  移动导线布置操作前后的电路图 

2、“Edit”->“Move”->“Move”命令 

该命令的功能是仅仅移动图元对象，不保持图元对象的电气连接状态，该命令的使用方

法与“Edit”->“Move”->“Drag”命令相同。不同的是，在移动对象过程中，部分快捷键

将发生变化，使用“Space”快捷键可逆时针旋转图元对象，使用“Shift+Space”快捷键可

顺时针旋转图元对象，使用“Tab”键可打开图元对象的属性编辑框，修改图元对象属性。 

3、“Edit”->“Move”->“Move Selection”命令 

该命令用于移动已选择的对象，使用该命令可以一次同步移动多个图元对象，该命令的

使用步骤介绍如下。 

（1）按照第 3.1.1节介绍的方法，选择所有需要移动的图元对象。 

（2）在主菜单种选择“Edit”->“Move”->“Move Selection”命令，启动该命令后，

鼠标指针变为“十”字形。 

（3）移动鼠标指针在原理图上选择一个参考点，然后单击鼠标左键，使被选对象吸附

在鼠标指针上。 

（4）移动鼠标指针到目标位置，单击鼠标左键，将图元对象重新布置到原理图上。 

4、“Edit”->“Move”->“Move Selection by X,Y”命令 

该命令用于通过设置 X、Y 轴偏移坐标，精确地移动已选择的图元对象。使用该命令前

需要选定需要移动的图元对象。其操作步骤如下。 

（1）按照第 3.1.1节介绍的方法，选择所有需要移动的图元对象。 

（2）在主菜单种选择“Edit”->“Move”->“Move Selection by X,Y”命令，打开如图

3.13所示的“Move Selection by X,Y”对话框。 

 

图 3.13  “Move Selection by X,Y”对话框 

（3）在“Move Selection by X,Y”对话框的“X”编辑框中输入 X 轴的偏移量，输入正

数则向右偏移，输入负数则向左偏移；在“Y”编辑框中输入 Y 轴的偏移量，输入正数则向
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上偏移，输入负数则向下偏移； 

（4）单击“OK”按钮，确认输入，所选择的对象将按照输入的数据，移动位置。 

使用该命令可以突破移动网格的限制，将对象移动到网格之间的位置。 

5、“Edit”->“Move”->“Drag Selection”命令 

该命令用于拖动已选中的图元对象，在拖动过程中保持选中图元对象的电气连接状态，

使用该命令可以一次拖动多个被选对象。“Edit”->“Move”->“Drag Selection”命令的使

用步骤与“Edit”->“Move”->“Move Selection”命令相同。 

6、“Edit”->“Move”->“Move To Front”命令 

该命令用于移动不具电气意义的图元对象，并将其放置到所有对象上方。当多个非电气

对象重叠在一起时，使用该命令可以重新安排图元对象的叠放顺序。如果要将图 3.13 所示

的文字对象移动到矩形对象的上方，操作步骤如下。 

（1）选择“Edit”->“Move”->“Move To Front”命令，启动该命令后，鼠标指针变

为“十”字形。 

（2）移动鼠标指针到文字对象的上方，单击鼠标左键，文字对象自动移到所有其他图

元对象的上方，并被吸附到鼠标指针上。 

（3）移动鼠标指针到合适位置，单击鼠标左键，将文字对象放置到矩形对象的上方，

如图 3.14所示。单击鼠标右键或按键盘“ESC”键，结束操作。 

  
移动文字前                   移动文字后 

图 3.14  使用“Edit”->“Move”->“Move To Front”命令移动文字 

7、“Edit”->“Move”->“Rotate Selection”命令 

该命令用于逆时针旋转选择的图元对象，可以一次旋转多个图元对象，操作步骤如下。 

（1）按照第 3.1.1节介绍的方法，选择所有需要移动的图元对象。 

（2）在主菜单种选择“Edit”->“Move”->“Rotate Selection”命令或者单击“Space”

快捷键，选择的图元对象将整体逆时针旋转 90°，如图 3.15所示就是选择整个电路后的旋

转效果。 

       

旋转前                      旋转后 

图 3.15  使用“Edit”->“Move”->“Rotate Selection”命令的效果 

8、“Edit”->“Move”->“Rotate Selection Clockwise”命令 

该命令用于顺时针旋转选择的图元对象，可以一次旋转多个图元对象，快捷键是
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“Shift+Space”，该命令的使用方法与“Edit”->“Move”->“Rotate Selection”命令相同，

区别在于旋转的方向相反。 

9、“Edit”->“Move”->“Bring To Front”命令 

该命令用于将图元对象设置为最顶层。只适用于不具有电气意义的图元对象。操作方法

与“Edit”->“Move”->“Move To Front”命令类似，启动该命令后，鼠标指针变成十字状，

单击要层移的对象，该对象将会被移动到其他对象上方。单击鼠标右键，结束该命令。 

10、“Edit”->“Move”->“Send To Back”命令 

该命令只适用于非电气对象的层移，功能与“Bring To Front”命令刚好相反，会将选择

的对象移动到其他图元对象的下方。操作方法则与“Edit”->“Move”->“Bring To Front”

命令完全相同。 

11、“Edit”->“Move”->“Bring To Front Of”命令 

该命令只适用于非电气图元对象的层移，其功能是将指定对象层移到某对象的上层。操

作方法如下。 

（1）选择“Edit”->“Move”->“Bring To Front Of”命令，启动该命令后，鼠标指针

变成十字状。 

（2）单击选择需要层移的图元对象，选择完成后该对象将暂时消失，鼠标指针还是十

字状。 

（3）单击选择层移操作的参考对象，单击鼠标，原先暂时消失的需要层移的图元对象

重新出现，并且被置于参考对象的上层。 

（4）重复操作（2）~（3）对其他对象进行层移操作，当所有操作完成后，单击鼠标右

键，结束该命令。 

12、“Edit”->“Move”->“Send To Back Of”命令 

该命令只适用于非电气对象，其功能是将指定对象层移到某对象的下层。操作方法同

“Bring To Front Of”命令。 

13、其他命令 

在“Edit”->“Move”菜单下的其他命令用于在多图纸层次设计中移动或调整图纸符号

对象的端口位置，本章暂不作详细描述。 

2.使用鼠标移动单个图元对象 

对于单个图元对象位置的调整，只需将鼠标指针指向待移动的对象（不需要选中），按

下鼠标左键不放，然后将对象拖到目标位置释放鼠标左键即可。 

移动具有电气意义的图元对象（如元件、导线、节点等）的操作中，按下鼠标左键时，

鼠标指针会自动滑到图元对象的电气热点上，图元对象的引脚端口处将显示 X 形标记。如

果与原理图中的其它图元对象有连接，该 X 形标记将显示为红色，如果该端口处于断开状

态，该 X 标记将显示为灰色。 

对于不具有电气意义的图元对象（如直线、矩形等），按下鼠标左键时，鼠标指针相对

于图元对象的位置不变。 

如果希望仅仅移动已具有电器连接的图元对象，而不破坏原有的电器连接，可以按住键

盘的“Ctrl”键，然后使用鼠标移动图元对象，此时该图元对象的所有电器连接将不会断开，

连接导线将自动调整，需要注意的是，移动过程中应尽量避免出现导线自动调整不当，错误

的将其他引脚短接的现象。 
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3.使用鼠标移动选中对象 

如果想一次移动多个对象，可执行以下操作。 

（1）使用 3.1.1节介绍的方法，选择所有需要移动的图元对象。 

（2）将鼠标指针移动到被任意一个选中的图元对象上方，当鼠标指针变为 形状后，

按住鼠标左键，将对象拖到目标位置，然后释放鼠标左键即可。 

如果在移动对象个过程中，按住键盘的“Ctrl”键，所有选中的图元对象的电器连接将

不会断开，系统会自动调整走线，在这种情况下仍然要注意，防止出现导线自动调整不当，

错误的将其他引脚短接的现象。 

4.使用标准工具栏上的移动工具按钮 移动图元对象 

移动工具按钮 的功能与“Edit”->“Move”->“Move Selection”命令功能完全相同，

操作步骤如下。 

（1）选取需要移动的图元对象。 

（2）单击标准工具栏上的移动工具按钮 。 

启动该命令后，鼠标指针变为“十”字形。 

（3）移动鼠标指针选择一个参考点，然后单击鼠标左键，使被选对象吸附在鼠标指针

上。 

（4）移动鼠标指针到目标位置，单击鼠标左键，将图元对象重新布置到原理图上。 

3.1.6  对象的排列与对齐 

为方便用户布置图元对象，DXP Schematic Editor提供了一系列排列与对齐功能。用户

可以通过如图 3.16所示的“Edit”->“Align”菜单启动排列与对齐命令，或者使用如图 3.17

所示的“Utilities”工具栏中的对齐工具栏，排列对齐所选择的对象。其具体操作介绍如下。 

 

图 3.16  “Edit”->“Align”菜单 

 

图 3.17  对齐工具栏 
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1.左对齐 

将一组图元对象的左侧边沿对齐的操作步骤如下。 

（1）按照 3.1.1节介绍的方法，选中所有需要左对齐的图元对象。 

（2）在主菜单中选择“Edit”->“Align”->“Align Left”命令，或单击“Utilities”工

具栏中的对齐工具按钮 ，在弹出的工具栏中选择左对齐工具按钮 ，或者使用“Shift”+

“Ctrl”+“L”快捷键，就可以使所选择的所有图元对象左侧边缘对齐于最靠左侧的图元对

象的左侧边缘。 

图 3.18所示即为执行左对齐前后的原理图，其中第一个选中的是“R1”。 

        

     左对齐前                左对齐后 

图 3.18  执行左对齐前后的原理图 

2.右对齐 

将一组图元对象的右侧边沿与其中的最靠右侧的对象右侧边沿对齐的操作步骤如下。 

（1）使用 3.1.1节介绍的方法，选择所有需要右对齐的图元对象。 

（2）在主菜单中选择“Edit”->“Align”->“Align Right”命令，或者单击“Utilities”

工具栏中的对齐工具按钮 ，在弹出的工具栏中选择右对齐工具按钮 ，或使用“Shift”+

“Ctrl”+“R”快捷键，就可以使所选择的所有图元对象右侧边缘对齐于所有选择的图元对

象中最靠右侧的图元对象的右侧边缘。 

图 3.19所示即为执行右对齐前后的原理图，在对齐之前，最右侧的图元对象是“R3”，

完成右对齐操作后，其它图元对象的右侧边缘都与“R3”的右侧边缘对齐了。 
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      右对齐前                    右对齐后 

图 3.19  执行右对齐前后的原理图 

3.垂直居中对齐 

将一组图元对象的垂直中心线对齐的操作步骤如下。 

（1）使用 3.1.1节介绍的方法，选中所有需要垂直居中对齐的图元对象。 

（2）在主菜单中选择“Edit”->“Align”->“Center Horizontal”命令，或者单击“Utilities”

工具栏中的对齐工具按钮 ，在弹出的工具栏中选择垂直居中对齐工具按钮 ，就可以使

所选图元对象的垂直中心线都对齐于所选图元对象整体的垂直中心线。 

图 3.20 所示即为执行水平居中对齐前后的原理图，所有选中的图元对象的垂直中心线

与所选对象整体的垂直中心线对齐，这里的所选对象整体的垂直中心线是指与选中对象的最

左侧边缘和最右侧边缘等距的线。 

      

   水平居中对齐前                   水平居中对齐后 

图 3.20  执行水平居中对齐前后的原理图 

4.水平等间距排列 

将一组对象水平方向上等间距排列的操作步骤如下。 

（1）使用 3.1.1节介绍的方法，选中所有需要水平等间距排列的图元对象。 

（2）在主菜单中选择“Edit”->“Align”->“Distribute Horizontal”命令，或者单击“Utilities”

工具栏中的对齐工具按钮 ，在弹出的工具栏中选择水平等间距排列工具按钮 ，或使用
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“Shift”+“Ctrl”+“H”快捷键，就可以使所选图元对象在水平方向上等间距排列。 

图 3.21所示即为执行水平方向等间距排列前后的原理图。 

  

执行水平方向上等间距排列前               执行水平方向上等间距排列后 

图 3.21  执行水平方向上等间距排列前后的原理图 

5.顶部对齐 

将一组图元对象的顶部边缘对齐的操作步骤如下。 

（1）选中所有需要顶部对齐的图元对象。 

（2）在主菜单中选择“Edit”->“Align”->“AlignTop”命令，或者单击“Utilities”

工具栏中的对齐工具按钮 ，在弹出的工具栏中选择顶部对齐工具按钮 ，或使用“Ctrl”

+“T”快捷键，即可使所选图元对象顶部边缘与最高的图元对象的顶部边缘对齐。 

图 3.22 所示即为执行顶部对齐前后的原理图。对齐之前，顶部边缘位置最高的图元对

象是“R3”，经过顶部对齐操作后，其它选中的图元对象的顶部边缘都与“R3”的顶部边

缘对齐。 

  

顶部对齐前                     顶部对齐后 

图 3.22  执行顶部对齐前后的原理图 

6.底部对齐 

将一组图元对象的底部边缘对齐的操作步骤如下。 

（1）选中所有需要底对齐的图元对象。 

（2）在主菜单中选择“Edit”->“Align”->“Align Bottom”命令，或者单击“Utilities”

工具栏中的对齐工具按钮 ，在弹出的工具栏中选择底部对齐工具按钮 ，或使用“Ctrl”

+“B”快捷键，即可使所选图元对象的底部边缘与处于最底端的图元对象底部边缘对齐。 

图 3.23 所示即为执行底部对齐前后的原理图。对齐之前，底部边缘位置最低的图元对

象是“R4”，经过底部对齐操作后，其它选中的图元对象的底部边缘都与“R4”的底部边

缘对齐。 
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执行底部对齐前                    执行底部对齐后 

图 3.23  执行底部对齐前后的原理图 

7.垂直居中对齐 

若需要将一系列图元对象在竖直方向按照水平中心线对齐，操作步骤如下。 

（1）选中所有需要垂直居中对齐的图元对象。 

（2）在主菜单中选择“Edit”->“Align”->“Align Vertical Center”命令，或者单击“Utilities”

工具栏中的对齐工具按钮 ，在弹出的工具栏中选择垂直居中对齐工具按钮 ，即可使所

选图元对象垂直居中对齐于所选对象整体的水平中心线。 

图 3.24所示即为执行垂直居中对齐前后的原理图。 

  

执行垂直居中对齐前                 执行垂直居中对齐后 

图 3.24  执行垂直居中对齐前后的原理图 

8.垂直等间距排列 

若要将一系列的图元对象在竖直方向等间距排列，操作步骤如下。 

（1）选中所有需要在竖直方向等间距排列的图元对象。 

（2）在主菜单中选择“Edit”->“Align”->“Distribute Vertical”命令，或者单击“Utilities”

工具栏中的对齐工具按钮 ，在弹出的工具栏中选择垂直等间距排列工具按钮 ，或使用

“Shift+Ctrl+V”快捷键，即可使所选图元对象在竖直方向等间距排列。 

图 3.25所示即为执行竖直方向等间距排列前后的原理图。 
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竖直方向等间距排列前      竖直方向等间距排列后 

图 3.25  竖直方向等间距排列前后的原理图 

9.对齐电气栅格 

为了加快原理图绘制的效率，系统提供了电气栅格，如果所有图元对象都能对齐电气栅

格，用户在连线的时候将会十分方便，同时原理图也会比较整齐美观，要将未对齐的图元对

象对齐电气栅格，可进行以下操作。 

（1）选中所有需要对齐网格的图元对象。 

（2）在主菜单中选择“Edit”->“Align”->“Align To Grid”命令，或者单击“Utilities”

工具栏中的对齐工具按钮 ，在弹出的工具栏中选择对齐电气栅格工具按钮 ，或使用

“Shift+Ctrl+D”快捷键，即可使所选图元对象对齐最近的电气栅格。 

10.复合对齐命令的使用 

使用复合对齐命令可以同时实现水平和垂直两个方向上的排列，步骤如下。 

（1）选中所有需要再排列的图元对象。 

（2）在主菜单中选择“Edit”->“Align”->“Align”命令，打开如图 3.26所示的“Align 

Objects”对话框。 
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图 3.26  “Align Objects”对话框 

“Align Object”对话框中的各个选项的含义如下： 

1、“HorizontalAlignment”选项区域用来设置对象的水平对齐选项。其中： 

●“NoChange”选项表示水平方向上保持原状。 

●“Left”选项表示左对齐。 

●“Center”选项表示水平居中对齐。 

●“Right”选项表示右对齐。 

●“Distribute equally”选项表示水平方向等间距排列。 

2、“VerticalAlignment”选项区域用来设置对象的垂直对齐选项。 

●“NoChange”选项表示垂直方向上保持原状。 

●“Top”选项表示顶部对齐。 

●“Center”选项表示竖直方向居中对齐。 

●“Bottom”选项表示底部对齐。 

●“Distribute equally”选项表示竖直方向等间距排列。 

3、“Move Primitives to Grid”复选项用于设置对齐时将所选对象对齐到电气栅格上，

便于线路的连接。 

（3）在“Align Objects”对话框中选择水平方向和垂直方向需要进行的对齐操作，单击

“OK”按钮，即可按照用户设置完成所需的对齐操作。 

3.1.7  图元对象的组合 

在对图元对象进行操作时，如果将部分图元对象当作一个整体来处理，将会给编辑操作

者带来很大的方便，本节将介绍将多个图元对象组合成为一个组合体的操作步骤。 

（1）选择需要组合的所有图元对象。 

（2）单击鼠标右键，在弹出的菜单中选择“Unions”->“Creat Union from selected object”

命令，如图 3.27所示。 

 

图 3.27  选择“Unions”->“Creat Union from selected object”命令 

系统显示如图 3.28所示的“Information”消息框，提示已经将对象添加到组合体中。 

 

图 3.28  “Information”消息框 

（3）单击“Information”消息框中的“OK”按钮，关闭该消息框。 

至此，所选择的那些图元对象就被组合起来，当直接用鼠标拖动组合中的任一个图元对

象时，组合中的所有图元对象将会一起被拖动。当选中组合中的图元对象后，仍然可以对所

选择对象进行单独的编辑，不会影响到其它图元对象。 

当需要重新选择组合中的所有图元对象时，只需要选择右键菜单中的“Unions”->“Select 

All In Union”命令，即可选中组合中的所有图元对象，选择右键菜单中的“Unions”->“Deselect 
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All In Union”命令，即可取消组合中的所有图元对象的选中状态。选择右键菜单中的“Unions”

->“Break objects from Union”命令就会解除图元对象的组合。 

3.1.8  电路连线的编辑 

原理图的编辑操作中往往要对连线进行重新调整，改变连线的长度和形状，本节将通过

一个实例介绍电路连线的编辑方法。该实例要完成的任务是将图 3.29 所示的添加一个电阻

的电路修改操作。 

      
修改前的电路    修改后的电路 

图 3.29  添加电阻“R5”的电路修改 

具体的操作步骤如下： 

（1）单击电路最上方的水平导线，将其选中，如图 3.30所示。 

 

图 3.30  选中电路上方的水平导线 

（2）移动鼠标到已选中的导线的水平段，当鼠标指针变为 形后，按住鼠标左键，并

向上拖动鼠标，将导线的水平段向上拖动到如图 3.31所示的位置，释放鼠标左键。 

 
图 3.31  拖动水平导线后的原理图 

（3）在电容“C5”的上方竖直布置电阻“R5”，并使“R5”的上端与水平导线连接，

如图 3.32所示。 
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图 3.32  布置电阻“R5”后的电路图 

（4）单击“C5”上端的导线，将其选中，移动鼠标到选中导线的上端点，当鼠标变为

形时，按住鼠标左键，向上拖动鼠标，将导线上端与电阻“R5”下端接点连接起来，如

图 3.33所示。 

 

图 3.33  调整导线后的电路图 

（5）选中电容“C1”~“C4”上方的四根导线，移动鼠标到任何一根选中导线的上端

点，当鼠标变为 形时，按住鼠标左键，向上拖动鼠标，使该导线与水平导线连接起来，释

放鼠标左键，此时其它三根选中的导线也会自动延长，与水平导线相连，如图 3.34所示。 

 

图 3.34  导线自动延长与水平导线连接 

（6）移动“VCC”电源标志，使其连接到水平导线左端，完成电路图的修改。 

3.2  图元对象的系统编辑 

在复杂的电路图中，元件成千上万，如果想要对原理图中某一种特定的元件进行调整，

使用普通的编辑方法，一一选取图元对象，需要花费相当长的时间，如果使用 Altium 

Design6.0提供的系统编辑功能，这种修改将会变得非常容易。本节将介绍在Altium Design6.0

中进行系统编辑的方法。 
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3.2.1  查找并批量修改图元对象 

如果需要查找原理图文件中，满足一定约束条件的所有图元对象，可以使用“Find Similar 

Object”命令，本小节将通过一个实例介绍“Find Similar Object”命令的使用方法，实例的

任务是查找并选中如图 3.35所示的原理图中所有容量为 1nF的电容元件，然后将其容量值

改为 10nF。 

 

图 3.35  原理图 

（1）在主菜单中选择“Edit”->“Find Similar Object”命令，或使用快捷键“Shift+F”，

然后在原理图中用鼠标单击任意一个容量为 1nF的电容元件，打开如图 3.36所示的“Find 

Similar Objects”对话框。 

  

图 3.36  “Find Similar Objects”对话框 

（2）在“Find Similar Objects”对话框中的“Object Specific”区域内，单击“Part Comment”

栏最右侧的下拉列表框，在弹出的列表中选择“Same”项，然后勾选“Find Similar Objects”

对话框下方的“Select Matching”复选项，单击“OK”按钮。 

系统自动选中原理图中所有的容量为 1nF的电容元件，并且使用蒙板将其它的图元对象
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遮住，显示效果如图 3.37所示。 

 

图 3.37  执行“Find Similar Objects”命令后的原理图 

通过设置“Find Similar Objects”对话框中的选项，用户还可以查找具有其它的共同属

性的同类图元对象，“Find Similar Objects”对话框中各栏的意义如下： 

1）“Kind”区域显示当前对象的类别（元件、导线或其他对象） 

2）“Design”区域中的“Owner Document”栏显示当前对象所处的文档的完整目录。 

3）“Graphical”区域用于设定对象的图形显示参数。 

“Xl”、“Y1”表示图元对象在原理图上的坐标。 

“Orientation” 表示图元对象的方向，即被旋转的角度。 

“Mirrored”表示图元对象是否被镜像。 

“Display Mode”表示图元对象的显示模式。 

“Show Hidden Pins” 表示图元对象是否显示被隐藏的引脚。 

“Show Designator” 表示图元对象是否显示元件编号等。 

4）“Object Specific”区域用来设定待查找的对象的详细描述。 

“Description” 表示图元对象的描述名称。 

“Lock Designator” 表示图元对象是否锁定元件编号。 

“PinsLocked” 表示图元对象是否锁定引脚。 

“FileName” 表示图元对象的文件名。 

“Configuration”表示图元对象的一些配置 

“Library” 表示图元对象元件所在库文件名。 

“Library Reference” 表示图元对象在库文件内的参考元件名。 

“Component Designator” 表示图元对象的元件编号。 

“Current Part” 表示图元对象的当前组件。 

“Part Comment” 表示图元对象的组件注释。 

“Current Footprint” 表示图元对象的封装形式 

“Component Yype” 表示图元对象的元件类型。 

“Database Table Name”表示图元对象所在数据库表单的名称 

以上的参数都可以当作搜索的条件，在对应选项右侧的下拉列表中设定，查找对象的详

细参数要求是“Same”、“Different”或“Any”。 

“Same”表示要求待查找的图元对象的属性与对应栏中设置的属性相同； 

“Different”表示要求待查找的图元对象的属性与对应栏中设置的属性必须不相同； 

“Any”表示对待查找的图元对象该项属性不作要求，可为任意值。 

5）“Zoom Matching”复选项设定是否将条件相匹配的对象，以最大显示模式，居中显

示在原理图编辑窗口内。 

6）“Mask Matching”复选项设定是否在显示条件相匹配的对象的同时，使用蒙板遮住
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其他对象。 

7）“Clear Existing”复选项设定是否清除已存在的过滤条件。系统默认选中该项。 

8）“Create Expression”复选项设定是否自动创建一个表达式，以便以后再用。系统默

认为不创建。 

9）“Run lnspector”复选项设定是否自动打开“Inspector”对话框。 

10）“Select Matching”复选项设定是否将符合匹配条件的对象选中。 

11）“Find Similar Objects”对话框右下方的下拉列表用于设置搜索的范围。共有两个

选项，其中“Current Document”项表示在当前的原理图文件中查找；“Opened Document”

项表示在所有已打开的原理图文件中查找。 

由于在“Find Similar Objects”对话框中选择了“Run lnspector”复选项，所以在选择所

有容量为“1nF”的电容元件后，系统打开如图 3.38所示的“SCH Inspector”面板。 

 

图 3.38  “SCH Inspector”页面 

（3）在“SCH Inspector”页面内单击“Part Comment”编框，将其改为“10nF”，其

他参数保持不变，最后单击回车键即可将更改应用到搜索到的所有电容，更改后的结果如图

3.39所示。 

 

图 3.39  全局修改后的电路图 
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（4）关闭“SCH Inspector”面板，单击工作区右下方的“Clear”按钮，解除图元对象

的选中状态，同时取消电路的蒙板。 

3.2.2  “Navigator”面板 

对于已经编译过的原理图文件，用户还可以使用“Navigator”面板选取其中的图元对象

进行编辑，如图 3.40所示就是一个原理图文件的“Navigator”面板。 

 

图 3.40  “Navigator”面板 

在该面板上部是该项目所包含的原理图文件的列表，本例中只有一个单独的原理图文

件。 

在该面板中部是元件表，列出了原理图文件中的所有元件信息，如果用户需要选择任何

一个元件进行修改，可以单击元件列表中的对应元件编号，即可在工作区选中放大显示该元

件，且其它元件将被自动蒙板盖住，如图 3.41 所示就是在“Navigator”面板中的元件列表

中选择了编号为“C1”的电容后，工作区的显示情况。 

 

图 3.41  在“Navigator”面板中选择编号为“C1”的电容 

采用这种方法，就能很快地在元件众多的原理图中定位某个元件。 

在元件表的下方，是网络连线表，显示所有网络连线的名称和应用的范围，单击任何一

个网络名称，在工作区都会放大显示该网络连线，并且使用自动蒙板将其它图元对象盖住。 

在“Navigator”面板的最下方是端口列表，显示当前所选对象的端口，默认为图纸上的

输入、输出端口的信息，当用户在元件列表或者网络连线列表中选择一个对象时，端口列表
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将显示该对象的引脚端口信息。单击端口列表中的杜端口时，工作区将会放大显示该端口，

并且使用自动蒙板将其它图元对象盖住。 

3.2.3  选择存储器 

在进行原理图编辑时，首先要选择元件，在元件众多的原理图中选择所需要编辑的元件

有时候并不是一件很轻松的事，当需要一次又一次重复的选取某一组图元对象时，用户可以

使用选择存储器，将一组图元对象的选择状态存储到选择存储器中，需要的时候自动调用就

好，Altium Designer为用户提供了 8个选择存储器，可以存储 8个选择状态。本小节将介绍

使用选择存储器的步骤。 

（1）在工作区域选择所需要的图元对象，本例中选择如图 3.42所示的电路图中的编号

为“U6”和“U9”的元件。 

 

图 3.42  选择的元件 

（2）单击工作区域右下方的 按钮，打开如图 3.43所示的“Selection Memory”面板。 

 

图 3.43  “Selection Memory”面板 

（3）单击“Selection Memory”面板中的“STO1”按钮，即可将工作区中的选择状态

存储到第 1 组存储空间中，此时存储空间状态列表中的第一行将显示该存储空间的内容信

息，本例中显示“2 Objects in 1 document”表示在一个文件中有 2个图元对象被选中。 

如果单击其它的“STO”按钮，将把当前工作区中的图元对象选择状态存储到对应的存

储空间中，例如单击“STO5”按钮，会把当前工作区中的图元对象选择状态存储到第 5 号

存储空间中。 

（4）在工作区任意位置单击，关闭“Selection Memory”面板。 

当需要重新恢复选择状态时，只需要执行以下步骤。 
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（1）单击工作区域右下方的 按钮，打开“Selection Memory”面板。 

（2）单击 “RCL1”按钮，则该第 1 组存储空间内存储的选择状态就应用于工作区，

此时工作区中的编号为“U6”和“U9”的元件被选中。 

如果单击第 1组存储空间对应的“Apply”按钮，工作区内的编号为“U6”和“U9”的

元件被放大显示，且其它的元件被自动蒙板挡住，如图 3.44所示。 

 

图 3.44  单击“Apply”按钮后的效果 

这是因为“Selection Memory”面板下方的“Mask”、“Zoom”和“Clear Existing”复

选项被选中，单击“Apply”按钮后才会应用蒙板，自动调节放大显示比例，清除其它的选

择状态，如果勾选了“Select”项，当单击“Apply”按钮后，还会将存储的图元对象转入选

中状态。 

单击“Selection Memory”面板中的存储空间对应的“Clear”按钮，将会晴空该存储空

间的内容，如果单击“Selection Memory”面板右下方的 按钮，将会清空所有存储空间

的内容。 

3.3  编辑元件编号 

在放置元件的过程中，由于疏忽等原因，经常会出现元件编号遗漏、重复、跳号等现象，

此时就需要对已放置的元件进行编号编辑。 

3.3.1元件编号的手动编辑 

如果在“Preferences”对话框的“Schematic”选项卡内勾选了“Enable ln-Place Editing”

复选项，也可以直接在原理图编辑窗口内修改元件编号。步骤如下： 

（1）选择需要编辑标号的元件的编号文本，使其处于选中状态，本例中选择如图 3.45

所示的编号为“JP2”的接头元件。 
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图 3.45  选中元件 

（2）单击已选中元件的编号文本，使其变为高亮状态，如图 3.46所示，然后输入新的

元件编号，修改完毕后在任意位置单击鼠标确认。 

 

图 3.46  高亮显示元件编号文本 

该方法同样适用于除文本框以外的其它所有图元对象中的文本修改，如元件编号、元件

参数值、注释、网络标签、文本字符串。 

另外，也可以在元件的属性对话框中修改元件的编号，步骤如下。 

（1）选中需要修改编号的元件，按键盘的“Tab”键，或者直接双击该元件，打开如图

3.47所示的的“Component Properties”对话框。 

 

图 3.47 “Component Properties”对话框 

（2）在“Component Properties”对话框中的“Designator”编辑框中输入新的元件编号，

然后单击“OK”按钮，完成元件编号的修改。 
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3.3.2  元件自动编号 

除了手工对元件进行编号之外，Altium Designer为用户提供了元件自动编号的功能，当

电路比较复杂、元件数目较多时，可以大大提高编号的效率，避免出现重复编号、跳号等错

误。自动编号的操作步骤如下。 

（1）在主菜单里选择“Tools”->“Annotate”命令，打开如图 3.48所示的“Annotate”

对话框。 

 

图 3.48  “Annotate”对话框 

在“Annotate”对话框中可以设置自动元件编号的规则及编号的范围等，“Annotate”

对话框左侧是“SchematicAnnotationConfiguration”区域，用于设置元件编号的顺序及其匹

配条件。右侧的“Proposed Change List”列表用于显示新旧元件编号的对照关系。具体介绍

如下。 

1、“Order of Processing”选项区域 

“Order of Processing”选项区域用于设置自动编号的顺序，该区域内包含一个下拉列表

和一个显示编号顺序的示意图，下拉列表中共有 4个选项，分别介绍如下。 

● “up then across”单选项表示根据元件在原理图上的位置，先按由下至上、再按由

左至右的顺序自动递增编号。 

●“Down then across”单选项表示根据元件在原理图上的位置，先按由上至下、再按

由左至右的顺序自动递增编号。 

●“Across then up”单选项表示根据元件在原理图上排列位置，先按由左至右、再按由

下至上的顺序自动递增编号。 

●“ Across then down” 单选项表示根据元件在原理图上排列位置，先按由左至右、

再按由上至下的顺序自动递增编号。系统默认选择此项。 

以上四种编号顺序如图 3.49所示。 
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“up then across”    “Down then across”      “Across then up”   “Across then down” 

图 3.49  四种编号顺序示意图 

2）“Match Options”选项区域用于设置查找需要自动编号的对象的范围和条件，其中

“Complete Existing Package”下拉列表用来设置需要自动编号的作用范围，该列表有三个选

项，介绍如下。 

●“None”表示无设定范围。 

●“Per sheet”表示范围是单张图纸文件 

●“Whole Project”表示范围是整个项目。 

在下拉列表下方是一个表格，用于选择自动编号对象的匹配参数。系统要求至少选择一

个参数，默认值为“Comment”。 

3）“Schematic Sheets To Annotate”区域用来选择要进行自动编号一些参数，包括执行

自动编号操作的图纸、自动编号的起始下标及后缀字符。 

“Schematic Sheet”栏列出所有待选的图纸文件，勾选“Schematic Sheet”栏中对应图

纸名称前的复选框，即可选中该图纸。单击“All On”按钮表示选中所有文档。单击“All Off”

按钮表示不选择任何文档。系统要求至少要选中一个文件。 

“Annotation Scope”栏用于设置每个文件中参与自动编号的原件范围。该栏共有三种

选项，分别是“All”、“Ignore Selected Parts”和“Only Selected Parts”，“All”表示对原

理图中的所有元件都进行自动编号，“Ignore Selected Parts”项表示对除选中的原件外的其

它元件进行自动编号，“Only Selected Parts”项表示仅仅对选中的原件进行自动编号。 

“Designator lndex Control”项用来设置使用编号索引控制。当勾选该复选项时，可以

在“Start lndex”下面的输入栏内输入编号的起始下标。 

“Add Suffix”项用于设定元件编号的后缀。在该项中输入的字符将作为编号后缀，添

加到编号后面，在对多通道电路进行设计时，可以用后缀区别各个通道的对应元件。 

4）“Reset All”按钮用来复位编号列表中的所有自动编号。单击“Reset All”按钮，系

统弹出如图 3.50所示的“DXP Information”消息框，单击“OK”按钮，即可使“Proposed Change 

List”列表中“Proposed”列中的自动元件编号都以问号“?” 结束，如图 3.51所示。 

 

图 3.50  “DXP Information”消息框 
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图 3.51  复位后的“Proposed Change List”列表 

5）“Update Change List”按钮用于按照设置的自动编号参数，更新自动编号列表。当

对自动编号的设置进行改变后，需要单击该按钮，对自动编号列表进行重新更新。 

6）“Back Annotate”按钮用于导入 PCB中已有的编号文件，使原理图的自动编号与对

应的 PCB 图同步。当单击该按钮后，会打开如图 3.52 所示的“Choose WAS-IS File for 

Back-Annotation from PCB”对话框，在对话框中选择对应的“ECO”或“WAS-IS”文件，

单击“OK”按钮，即可将该文件中的编号信息导入自动编号列表。 

 

图 3.52  “Choose WAS-IS File for Back-Annotation from PCB”对话框 

7）“Accept Changes（Create ECO）”按钮用于执行自动编号操作。 

（2）在“Annotate”对话框中设置元件自动编号规则，单击“Accept Changes（Create ECO）”

按钮，打开如图 3.53所示的“Engineering Change Order”对话框。 
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图 3.53  “Engineering Change Order”对话框 

“Engineering Change Order”对话框中列出了所有的更改操作列表，用户可以根据需要

决定哪些更改需要执行，如果不需要执行某一项更改，只用取消该项更改前的复选框即可。 

（3）单击“Validate Change”按钮检查所有的改变是否有效，当检查通过后，在每一

项更改后的“Check”栏将出现一个绿色的“√”标记，当所有的改变经过验证是正确的以

后，单击“Execute Change”按钮，执行所有改变。执行完成后，每一项更改后的“Done”

栏将出现一个绿色的“√”标记，表示该系那个更改已经完成了，如图 3.54所示。 

 

图 3.54  检查、执行完成后的“Engineering Change Order”对话框 

（4）单击“Report Change”按钮，打开如图 3.55所示的“Report Preview”窗口。 
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图 3.55  “Report Preview”窗口 

（5）单击“Export”按钮，打开“Export From Project[…]”对话框，设置报告的文件

名，在保存类型中选择“Adobe PDF”单击“保存”按钮，将更新报告保存为 PDF文件。 

（6）单击“Close”按钮，关闭“Report Preview”窗口，单击“Engineering Change Order”

对话框中的“Close”按钮关闭该对话框，并返回到“Annotate”对话框。 

（7）最后在“Annotate”对话框内单击“Close”按钮，完成元件编号自动更改。 
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第 4章  高级原理图设计 

Altium Designer 6支持多种设计复杂电路的方法，例如层次设计、多通道设计等，在增

强了设计的规范性的同时减少了设计者的劳动量，提高了设计的可靠性。本章将介绍这些高

级原理图设计的方法。 

4.1  层次设计 

对于复杂的电子项目的设计，最好的设计方式是采用层次化设计的思路，Altium 

Designer 6支持层次化的电路设计，所谓层次化设计，是指将一个复杂的设计任务分派成一

系列有层次结构的、相对简单的电路设计任务。这样可以实现多个设计小组协同设计同一个

项目，当完成顶层的模块设计，定义好个模块之间的连接关系后，可将各个模块的设计任务

分配给不同的小组单独完成，这样可以大大缩短开发周期。采用这种方式后，对单个模块设

计的修改可以不影响系统的整体设计，提高了系统的灵活性。 

Altium Designer 6支持“自顶向下”和“自底向上”这两种层次电路设计方式。所谓自

顶向下设计，就是按照系统设计的思想，首先对系统最上层进行模块划分，设计包含子图符

号的父图，标示系统最上层模块之间的电路连接关系，接下来分别对系统模块图中的各功能

模块进行详细设计，分别细化各个功能模块的电路实现。自顶向下的设计方法适用于较复杂

的电路设计。与之相反，进行自底向上设计时，则预先设计各子模块，接着创建一个空的所

谓父图，将各个子模块连接起来，成为功能更强大的上层模块，完成一个层次的设计，经过

多个层次的设计后，直至满足项目要求。 

层次电路图设计的关键在于正确地传递各层次之间的信号。层次电路图设计中，信号的

传递主要通过电路子图符号、子图入口和输入/输出端口来实现。电路子图符号、子图入口

和电路输入/输出端口之间有着密切的关系。 

层次电路图的所有子图符号都必须有与该子图符号相对应的电路图存在（该图为子图），

并且子图符号的内部也必须有子图入口。同时，在与子图符号相对应的子图中必须有输 X

／输出端口与子图符号中的子图入口相对应，且必须同名。在同一项目的所有电路图中，同

名的输 X／输出端口（包括子图入口）之间，在电气上是相互连接的。 

本节将通过层次设计实例介绍使用 Altium Designer 6进行层次设计的方法。 

4.1.1  自顶向下设计层次电路图 

本节以 PIC16F877单片机系统电路为例，介绍按照自顶向下的设计方法，设汁一个层

次电路的完整过程。 

本节实例中需要创建的电路的完整电路图如图 4.1所示，但是采用自顶向下的层次设计

后，电路图则如图 4.2所示，结构更加清晰。 
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图 4.1  电路原理图 

 

图 4.2  层次设计后的电路图 

自顶向下的层次电路设计操作步骤如下。 

（1）启动 Altium Designer 6，在主菜单中选择“File”->“New”->“Project”->“PCB 

Project”命令，在当前工作空间中添加一个默认名为“PCB_Project1.PrjPCB”的 PCB 项目

文件。 

（2）单击“Projects”工作面板中的“Project”按钮，在弹出的菜单中选择“Add New to 

Project”->“Schematic”命令，在新建的 PCB项目中添加一个默认名为“Sheet1.SchDoc”

的原理图文件。 

（3）在 “Save [Sheet1.SchDoc] As…”对话框的“文件名”编辑框中输入“PIC_top”，

单击“保存”按钮，将原理图文件另存为“PIC_top.SchDoc”，同时系统自动打开“Save 

[PCB_Project1.PrjPCB] As…”对话框。 

（4）在“Save [PCB_Project1.PrjPCB] As…”对话框的“文件名”编辑框中输入

“Level_PIC”，单击“保存”按钮，将 PCB项目文件保存为“Level_PIC.PrjPCB”。 

（5）单击工作台右侧的“Libraries”标签，打开“Libraries”工作面板。 

（6）单击“Libraries”工作面板中的“Search…”按钮，打开“Libraries Search”对话

框。 

（7）在“Libraries Search”对话框中的编辑框内输入“PIC16F877”，单击“Search”
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按钮，开始进行搜索。 

（8）双击“Libraries”工作面板中的“Query Results”列表中名称为“PIC16F877-04I/P”

的器件，单击键盘上的“Tab”键，将元件的编号修改为“U1”，然后将其布置在原理图中

央位置。 

（9）单击“Wiring”工具栏中的添加子图符号工具按钮 ，或者在主菜单中选择“Place”

->“Sheet Symbol”命令。 

（10）单击键盘上的“Tab”键，打开如图 4.3所示的“Sheet Symbol”对话框。 

 

图 4.3  “Sheet Symbol”对话框 

（11）在“Sheet Symbol”对话框的“Designator”编辑框中输入“PIC_Clock”，在“Filename”

编辑框内输入“PIC_Clock.schdoc”，单击“OK”按钮，结束子图符号的属性设置。 

（12）在原理图上合适位置单击鼠标，确定子图符号的一个顶角位置，然后拖动鼠标，

调整子图符号的大小，确定后再单击鼠标，在原理图上插入子图符号，如图 4.4所示。 

 

图 4.4  插入子图符号后的原理图 

（13）按照步骤（11）（12）的方法，再在原理图上插入二个子图符号。子图符号的

“Designator”和“Filename”分别为“PIC_RST”、“PIC_232”和“PIC_RST.schdoc”、
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“PIC_232.schdoc”，如图 4.5所示。  

 

图 4.5  插入两个子图符号后的原理图 

（14）单击“Wiring”工具栏中的添加子图入口工具按钮 ，或者在主菜单中选择“Place”

->“Add Sheet Entry”命令。 

（15）在“PIC_Clock”子图符号上单击鼠标，然后单击“Tab”键，打开如图 4.6所示

的“Sheet Entry”对话框。 

 

图 4.6  “Sheet Entry”对话框 

（16）在“Sheet Entry”对话框的“Name”编辑框中输入“XTAL1”，作为子图入口

的名称。 

（17）在“I/O”Type下拉列表中选择“Output”项，将子图入口设为输出口，单击“OK”

按钮。 

（18）在“Clk”子图符号靠近 PIC单片机元件的一侧单击鼠标，布置一个名为“OSC1”

的子图输出口，如图 4.7所示。 
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图 4.7  布置的子图端口 

（19）单击“Tab”键，在打开的“Sheet Entry”对话框的“I/O Type”下拉菜单中选择

“Intput”项，单击“OK”按钮。 

（20）在“Clk”子图符号靠右侧单击鼠标，再布置一个名为“OSC2”的子图输入口，

如图 4.8所示，然后单击鼠标右键确定。 

 

图 4.8  布置的子图端口 

（21）采用步骤（14）~（29）介绍的方法，再在“PIC_Clock”子图符号中添加一个端

口，在“PIC_Rst”子图符号中添加五个端口，在“PIC_232”子图符号中添加四个端口，原

理图中的端口名称和类型如表 4-1所示。布置完端口后的原理图如图 4.9所示。 

表 4-1  端口名称和类型表 

子图符号 端口名称 端口类型 

PIC_Clock OSC1 Output 

PIC_Clock OSC2 Input 

PIC_Clock GND Unspecified 

PIC_RST MCLR Bidirectional 

PIC_RST PGC Bidirectional 

PIC_RST PGD Bidirectional 

PIC_RST VCC Unspecified 

PIC_RST GND Unspecified 

PIC_232 TX Input 

PIC_232 RX Output 

PIC_232 VCC Unspecified 

PIC_232 GND Unspecified 
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图 4.9  布置完端口后的原理图 

（22）使用“Wiring”工具栏中的布置电源工具和连接导线工具，布置电源，并连接各

子图端口和电源，完成系统最上层的设计图，绘制的原理图如图 4.10所示。 

 

图 4.10  连接好的顶层电路 

（23）在主菜单中选择“Design”->“Creat Sheet From Symbol”命令，如图 4.11所示。 

 

图 4.11  选择“Design”->“Creat Sheet From Symbol”命令 

（24）单击“PIC_Clock”子图符号，打开如图 4.12所示的“Confirm”消息框，询问是

否颠倒子图入口的方向。 

 

图 4.12  “Confirm”消息框 

（25）单击“Confirm”消息框中的“No”按钮，系统自动在“Level_PIC.PrjPCB”项

目中新建一个名为“PIC_Clock.schdoc”的原理图文件，置于“PIC_top.SchDoc”原理图文

件下层。如图 4.14所示。在原理图文件“PIC_Clock.schdoc”中自动布置了如图 4.15所示的

三个端口。 
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图 4.13  系统自动创建的名为“PIC_Clock.schdoc”的原理图文件 

 

图 4.14  自动生成的端口 

（26）在新建的原理图中绘制如图 4.15所示的“PIC_Clock”子电路图。 

 

图 4.15  “PIC_Clock”子电路图 

（27）单击工作区上方的“PIC_top.schdoc”文件标签，将其在工作区打开。 

（28）在原理图中的“PIC_232”子图符号上单击鼠标右键，在弹出的如图 4.16所示的

右键菜单中选择“Sheet Symbol Actions”->“Creat Sheet From Symbol”命令，打开“Confirm”

消息框。 
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图 4.16  右键菜单 

（29）在 “Confirm”消息框中单击“No”按钮，在 PIC_top.SchDoc文件下层新建一

个名为“PIC_232.schdoc”的原理图，如图 4.17所示。 

 

图 4.17  新建的名为“PIC_232.schdoc”的原理图 

（30）在 PIC_232.schdoc”原理图文件中布置如图 4.18所示的“PIC_232”子图电路。 

 

图 4.18  “PIC_232”子图电路 

（31）单击“Project”面板标签，打开“Project”工作面板，在“Project”工作面板中

单击“PIC_top.SchDoc”，将其在工作区中打开。 

（32）在主菜单中选择“Design”->“Creat Sheet From Symbol”命令，然后单击“PIC_RST”

子图符号，打开“Confirm”消息框。 

（33）在“Confirm”消息框中选择“NO”按钮，新建一个名为“PIC_Rst.SchDoc”的

原理图文件。 

（34）在“PIC_Rst.SchDoc”原理图文件中绘置如图 4.19所示的“PIC_Rst”子电路图。 
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图 4.19  “PIC_RST”子电路图 

（35）在所有电路图的标题栏内填写制图信息。 

（36）在主菜单中选择“File”->“Save All”命令，将新建的三个子图文件按照其原名

保存。 

至此，采用自顶向下的设计方法设计的 PIC单片机最小系统的过程即告完成。 

4.1.2  自底向上设计层次电路图 

Altium Designer 6还支持传统的自底向上设计方法，本节将在上一节已经完成的层次电

路图的基础上，采用自底向上的设计方法，为单片机系统添加电源。 

（1）启动 Altium Designer 6，打开上一节中创建的 PCB项目“Level_PIC.PrjPCB”。 

（2）单击“Projects”工作面板中的“Project”按钮，在弹出的菜单中选择“Add New to 

Project”->“Schematic”命令，在项目中新建一个默认名称为“Sheet1.SchDoc”的空白原理

图文档。 

（3）在空白原理图文档中绘制如图 4.20所示的电源电路。 

 

图 4.20  绘制的电源电路 

（4）单击通用工具栏中的保存工具按钮 ，在弹出的“Save [Sheet1.schdoc] As”对话

框的“文件名”编辑框内输入“Power”，单击“保存”按钮，将键盘电路图文件保存为

“Power.SchDoc”。 

（5）单击“Projects”工作面板中“PIC_top.SchDoc”文件的名称，在工作区打开该文

tyw藏书



第 4 章  高级原理图设计 

 ·163·   

件。 

（6）在主菜单中选择“Design”->“Creat Sheet Symbol From Sheet”命令，打开如图

4.21所示的“Choose Document to Place”对话框。 

 

图 4.21  “Choose Document to Place”对话框 

（7）在 “Choose Document to Place”对话框中选择“Power.SchDoc”文件，单击“OK”

按钮，打开“Confirm”消息框，单击“Confirm”消息框中的“No”按钮，在新建的文件中

添加如图 4.22所示的子图符号。 

 

图 4.22  添加的子图符号 

（8）在“PIC_top.SchDoc”文件中绘制电源网络节点，将子图符号连接到电路中，完

成的电路图如图 4.23所示。 

 

图 4.23  完成的电路图 

（9）选择“File”->“Save All”命令，保存项目中的所有文件。 

至此，采用自底向上的设计方法设计单片机电源电路的过程结束。 
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4.2  多通道电路设计 

Altium Designer 6支持多通道设计，简化具有多个完全相同的子模块的电路的设计工作。

本节将通过一个多通道测量系统电路的设计实例介绍多通道电路设计方法。 

如图 4.24所示为一个八通道温度测量系统的信号转换部分，通过 NE555器件，将温度

传感器的电阻变换转变为频率信号，通过一个八路模拟开关器件 CD4051，在八个通道输出

信号之间切换，由上一节中绘制的单片机系统对频率信号进行测量，实现温度的巡回检测功

能。 

 

图 4.24  八通道温度测量系统信号转换电路 

由于八个通道的电路是完全一致的，所以可以采用多通道设计方法设计电路，具体设计

步骤如下。 

（1）启动 Altium Designer，打开 4.1节中创建的名称为“Level_PIC.PrjPCB”的项目。 

（2）单击“Projects”工作面板中的“Project”按钮，在弹出的菜单中选择“Add New to 

Project”->“Schematic”命令，在项目中新建一个空白原理图文档。 

（3）在新建的空白原理图中绘制如图 4.25所示的单通道温度测量电路图。 

 

图 4.25  绘制的单通道温度测量电路图 

（4）单击通用工具栏中的保存工具按钮 ，在弹出的“Save [Sheet1.schdoc] As”对话

框的“文件名”编辑框内输入“T_mea_cell”，单击“保存”按钮，保存原理图文件。 

tyw藏书



第 4 章  高级原理图设计 

 ·165·   

（5）单击“Projects”工作面板中的“Project”按钮，在弹出的菜单中选择“Add New to 

Project”->“Schematic”命令，在项目中再次新建一个空白原理图文档。 

（6）在主菜单中选择“Design”->“Creat Sheet Symbol From Sheet or HDL”命令，打

开如图 4.26所示的“Choose Document to Place”对话框。 

 

图 4.26  “Choose Document to Place”对话框 

（7）在“Choose Document to Place”对话框中选择“T_mea_cell.SchDoc”文件名，单

击“OK”按钮，在弹出的“Confirm”消息框中单击“No”按钮，在原理图文档中添加如图

4.27所示的子图符号。 

 

图 4.27  添加的子图符号 

（8）双击子图符号名称“U_T_mea_cell”，打开如图 4.28 所示的“Sheet Symbol 

Designator”对话框，将“Designator”编辑框内的内容修改为“Repeat（T_mea_cell，1，8）”，

单击回车键。 
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图 4.28  “Sheet Symbol Designator”对话框 

（9）双击子图符号中的端口“Pulse_out”，打开“Sheet Entry”对话框，在“Name”

编辑框内输入“Repeat（Pulse_out）”，然后单击“OK”按钮。将端口的名称改为“Repeat

（Pulse_out）”，修改完成后的子图符号如图 4.29所示。 

 

图 4.29  修改后的子图符号 

通过将子图符号名称修改为“Repeat（T_mea_cell，1，8）”，表示将如图 4.25所示的

单元电路复制了 8个。将“Pulse_out”端口名称改为“Repeat（Pulse_out）”语句，则表示

每个复制的电路中的“Pulse_out”端口都被引出来，而各通道的其他未加“Repeat”语句的

电路同名端口都将被互相连接起来。 

（10）在原理图中添加其他元件，绘制如图 4.30所示的电路图。 
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图 4.30  绘制的电路 

（11）单击通用工具栏中的保存工具按钮 ，在弹出的“Save [Sheet1.schdoc] As”对话

框的“文件名”编辑框内输入“T_mea”，单击“保存”按钮，将单个按键电路图文件保存

为“T_mea.schdoc”。 

（12）单击“Projects”工作面板中的“PIC_top.SchDoc”文件名，打开该文件。 

（13）在主菜单中选择“Design”->“Creat Sheet Symbol From Sheet or HDL”命令，打

开“Choose Document to Place”对话框。 

（14）在“Choose Document to Place”对话框中选择“T_mea.schdoc”文件，单击“OK”

按钮，在弹出的“Confirm”消息框中单击“No”，在原理图中添加如图 4.31所示的子图符

号。 

 

图 4.31  添加的子图符号 

（15）连接子图符号的端口，最后完成的电路原理图如图 4.32所示。 
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图 4.32  八通道温度测量系统顶层电路 

（16）在主菜单选择“File”->“Save All”命令，保存项目中的文件。 

至此，采用多通道技术设计八通道温度测量系统的任务即告完成。 
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第 5章  原理图库文件编辑 

尽管 Altium Design6提供了大量的原理图库文件供用户调用，在实际的设计过程中总会

出现一些当前元件库中找不到的元件，因此 Altium Design6提供了自定义元件库的功能。本

章将介绍创建自定义原理图元件库的方法。 

5.1  创建原理图元件库文件 

本节将介绍创建原理图元件库的具体步骤。 

5.1.1  新建元件库文件 

在自定义原理图元件库之前，用户需要创建一个库文件，本小节将介绍具体步骤。 

（1）启动 Altium Designer，单击工具栏中的新建按钮 ，在弹出的 Files 面板中选择

“New”->“Library”->“Schematic Library”命令，新建一个默认名称为“Schlib1.SchLib”

的原理图库文件。 

（2）单击工具栏中的保存按钮 ，打开“Save[Schlib1.SchLib] As”对话框，在文件名

编辑框中输入“custom”，单击“保存”按钮，将原理图元件库文件名称改为“custom.SchLib”，

并保存。 

完成以上步骤后，一个名为“custom”的空白元件库文件就创建完毕了。 

5.1.2  添加元件 

本小节将通过为“custom”元件库添加两个原理图元件的实例，介绍元件的自定义方法。 

（1）启动 Altium Designer，打开“custom.SchLib”文件，显示如图 5.1所示的原理图

元件编辑界面。 
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图 5.1  原理图元件编辑界面 

（2）在工作区单击鼠标右键，在弹出的右键菜单中选择“Options”->“Document Options”

命令，打开如图 5.2所示的“Library Editor Workspace”对话框。 

 

图 5.2  “Library Editor Workspace”对话框 

（3）单击“Library Editor Workspace”对话框上部的“Unit”选项卡标签，打开如图 5.3

所示的“Unit”选项卡。 

 

图 5.3  “Unit”选项卡 

（4） 在“Unit”选项卡内的“Imperial Unit System”选项区域内勾选“Use Imperial Unit 

System”选项框，将绘图单位设置为英制。 

（5）单击“Library Editor Workspace”对话框上部的“Library Editor Options”选项卡

标签，打开“Library Editor Options”选项卡。 

（6）在“Library Editor Workspace”对话框中的“Grids”选项区域内的“Snap”编辑

框中输入“1”，将对齐网格的边长设置为 1，然后单击“OK”按钮，关闭“Library Editor 

Workspace”对话框。 

（7）选择“Place”->“Polygon”命令，或者单击工具栏中的绘图工具按钮 ，在弹出

的工具栏中选择绘制多边形工具 ，单击键盘上的“Tab”键，打开如图 5.4所示的“Polygon”
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对话框。 

 

图 5.4  “Polygon”对话框 

（8）单击“Polygon”对话框中的“Fill Color”色彩块，打开如图 5.5所示的“Choose Color”

对话框。 

 

图 5.5  “Choose Color”对话框 

（9）在“Choose Color”对话框中单击第“218”号色彩，单击“OK”按钮，将填充颜

色设置为淡黄色。 

（10）采用同样方法，将“Border Color”设置为第“235”号棕色，单击“Border Width”

右侧的选项，在弹出的下拉列表中选择“Small”，单击“OK”按钮，结束多边形的设置。 

（11）分别在工作区内坐标为（60，40）、（-60，60）、（-60，-60）和（60，-40）

的四个点上单击鼠标左键，绘制如图 5.6所示的等腰梯形，然后单击鼠标右键结束多边形的

绘制。 
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图 5.6  绘制的等腰梯形 

（12）选择主菜单中的“Place”->“Pins”命令，或者单击工具栏中的绘图工具按钮 ，

在弹出的工具栏中选择添加引脚工具按钮 ，然后单击键盘上的“Tab”键，打开如图 5.7

所示的“Pin Properties”对话框。 

 

图 5.7  “Pin Properties”对话框 

（13）在“Pin Properties”对话框中的“Display Name”编辑框中输入“IR1”，设置引

脚的名称为 IR1，在“Designator”编辑框中输入“1”，设置引脚编号为 1，在“Electrical Type”

下拉列表中选择“Output”，在“Description”编辑框中输入“恒流源输出 1”单击“OK”

按钮，关闭“Pin Properties”对话框。 

（14）在工作区中坐标为（-20，53）的位置单击鼠标左键，布置的 1 号引脚如图 5.8

所示。 

 

图 5.8  布置的 1 号引脚 

由于 XTR105共有 14个功能不同的引脚，如果按照步骤（13）~（14）介绍的方法一一

进行设置，工作会比较繁琐，容易出错，用户可以先布置完所有的引脚，然后使用引脚编辑

功能，对引脚进行集中编辑。 

（15）按照图 5.9所示位置，布置其他引脚，布置过程中可使用键盘的空格键旋转引脚，

布置时只需注意引脚的编号正确，引脚名称和类型可在下一步进行编辑更正。 
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图 5.9  布置引脚位置 

（16）单击工作区域右侧的“SCH Library”选项页标签，打开如图 5.10所示的“SCH 

Library”选项页。 

 

图 5.10  “SCH Library”选项页 

（17）在“SCH Library”选项页上部的元件列表中选择当前元件“Component_1”，单

击“Edit”按钮，打开如图 5.11所示的“Library Component Properties”对话框。 
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图 5.11  “Library Component Properties”对话框 

（18）单击“Library Component Properties”对话框左下方的“Edit Pin”按钮，打开如

图 5.12所示的“Component Pin Editor”对话框。 

 

图 5.12  “Component Pin Editor”对话框 

（19）在“Component Pin Editor”对话框中有一个当前引脚的列表，用户可以直接修改

引脚的各种属性。本例中，元件 XTR105P的各引脚属性如表 5.1所示。 

表表表表 5.1  XTR105P的各引脚属性的各引脚属性的各引脚属性的各引脚属性 

引脚编号 引脚名称 引脚类型 引脚功能描述 

1 IR1 Output 恒流源输出 1 

2 Vin- Input 输入信号负端 

3 RG Passive 接增益调节电位器引

脚 

4 RG Passive 接增益调节电位器引

脚 

5 NC Passive 空脚 

6 IRET Passive 恒流源电流回路引脚 

7 Io Output 电流信号输出 

8 E Passive 接放大三极管发射极

引脚 

9 B Passive 接放大三极管基极引
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脚 

10 V+ Passive 电压正极输入 

11 VREG Output 电压基准引脚 

12 VLin Passive 接线性补偿电阻引脚 

13 Vin+ Input 输入信号正极 

14 IR2 Output 恒流源输出 2 

由于在第 5 号引脚是一个空置的引脚，在修改其属性时，取消勾选“Show”复选框，

将该引脚设置为隐藏，这样原理图中将不显示该引脚。 

（20）各引脚属性编辑完成后，单击“OK”按钮，关闭“Component Pin Editor”对话

框，此时 XTR105P的原理图如图 5.13所示。 

 

图 5.13  编辑完成的引脚 

（21）在“SCH Library”选项页上部的元件列表中选择当前元件“Component_1”，单

击“Edit”按钮，再次打开“Library Component Properties”对话框。 

（22）在“Library Component Properties”对话框中的“Properties”选项区域内的“Default 

Designator”编辑框内输入“U？”，在“Description”编辑框内输入“4-20mA 电流变送芯

片”。然后在“Library Link”选项区域内的“Physical Component”编辑框内输入“XTR105”，

然后单击“OK”按钮，关闭“Library Component Properties”对话框。 

（23）单击工作栏中的保存按钮 ，保存原理图元件库文件。 

至此，一个名为“XTR105”的器件的原理图就完成了。 

接下来，通过创建集成了两个独立比较器的 LM393 元件的原理图实例，介绍集成多个

独立模块的元件的原理图创建方法，图 5.14所示为技术资料中的 LM393的结构原理图。 
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图 5.14  LM393的结构原理图 

为了使原理图表达得更加清楚，在进行原理图库的设计时，将该元件分成两个独立的比

较器符号进行设计，以下是设计步骤。 

（1）启动 Altium Designer，打开 5.2.1小节创建的元件库文件“custom.SchLib”文件。 

（2）单击工作界面左侧的“SCH Library”选项页标签，打开“SCH Library”选项卡，

单击元件列表下方的“Add”按钮，打开如图 5.15所示的“New Component Name”对话框。 

 

图 5.15  “New Component Name”对话框 

（3）在“New Component Name”对话框对话框中的编辑框中输入新元件的名称

“LM393”，单击“OK”按钮，新建一个名称为 LM393的新元件。 

（4）选择“Place”->“Line”命令，或者单击工具栏的绘图工具按钮 ，在弹出的工

具栏中选择绘制直线工具 ，单击键盘上的“Tab”键，打开如图 5.16所示的“PolyLine”

对话框。 

 

图 5.16  “PolyLine”对话框 

（5）单击“PolyLine”对话框中的“Color”色块，打开“Choose Color”对话框。 

（6）在“Choose Color”对话框中选择“235”号棕色，单击“OK”按钮，将直线的颜

色设置为棕色。 

（7）在“PolyLine”对话框中设置“Line Width”为“Small”，设置“Line Style”为

“Solid”，然后单击“OK”按钮，结束对直线线形的设计。 

（8）依次单击工作区的位置坐标为（-20，20）、（30，0）、（-20，-20）和（-20，

20）的点，绘制如图 5.17所示的三角形。 
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图 5.17  绘制的三角形 

（9）选择主菜单中的“Place”->“Pins”命令，或者单击工具栏中的绘图工具按钮 ，

在弹出的工具栏中选择添加引脚工具按钮 ，然后单击键盘上的“Tab”键，打开“Pin 

Properties”对话框。 

（10）在“Pin Properties”对话框中的“Display Name”编辑框中输入“out”，设置引

脚的名称为 out，在“Designator”编辑框中输入“1”，设置引脚编号为 1，在“Electrical Type”

下拉列表中选择“Output”，在“Description”编辑框中输入“比较器输出”单击“OK”按

钮，关闭“Pin Properties”对话框。 

（14）在工作区中坐标为（30，0）的位置单击鼠标左键，布置第 1号引脚。 

（15）接着分别布置引脚编号为“2”和“3”的引脚，其中引脚“2”的引脚名称为“-”，

引脚类型为“Input”，引脚描述为“比较器输入-”的引脚，引脚“3”的引脚名称为“+”，

引脚类行为“Input”，引脚描述为“比较器输入+”，三个引脚布置完成后，元件原理图如

图 5.18所示。 

 

图 5.18  比较器元件原理图 

（16）选择主菜单中的“Edit”->“Select”->“All”命令，或者按键盘上的“Ctrl+A”

快捷键，将工作区的元件原理图全部选中。 

（17）选择主菜单中的“Edit”->“Copy”命令，或者按键盘上的“Ctrl+C”快捷键，

将选中的原理图复制到剪贴板中。 

（18）选择主菜单中的“Tool”->“New Part”命令，新建一个空白的元件页面，此时

在“SCH Library”选项页中的元件列表中，元件 LM393变成由“Part A”和“Part B”两个

部分构成，如图 5.19所示。 

 

图 5.19  元件 LM393 

（19）选择主菜单中的“Edit”->“Paste”命令或者按键盘上的“Ctrl+V”快捷键，将

剪贴板中的元件复制到光标上，移动鼠标，调整复制的元件位置，使其与原始的元件原理图

位置相同，然后单击鼠标，将复制的元件原理图固定到工作区。 

（20）双击工作区的元件的引脚，打开“Pin Properties”对话框，对引脚的编号进行修

改，修改完引脚编号后的元件原理图如图 5.20所示。 
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图 5.20  修改完引脚编号后的元件原理图 

现在，元件 LM393 的两个独立比较器部分的原理图就绘制完毕了，接下来为其添加电

源引脚，对于电源引脚，有两种处理方式，一种是使用“Tools”->“New Part”命令新建一

个独立的电源模块，另外一种是将电源引脚隐藏起来，并设置电源引脚与固定名称的电源相

连，无论用户调用元件中的任何一个模块，元件的电源引脚总是自动与设定的电源连接，这

样原理图就会显得更加清晰。本实例就采用将电源引脚隐藏起来的方式处理电源引脚。 

（21）在“SCH Library”选项页内的元件列表中，单击元件 LM393的“Part A”部分，

在工作区中将其打开。 

（22）选择主菜单中的“Place”->“Pins”命令，或者单击工具栏中的绘图工具按钮 ，

在弹出的工具栏中选择添加引脚工具按钮 ，然后单击键盘上的“Tab”键，打开“Pin 

Properties”对话框。 

（23）在“Pin Properties”对话框中的“Display Name”编辑框中输入“VCC”，在

“Designator”编辑框中输入“8”，在“Electrical Type”下拉列表中选择“Power”，在

“Description”编辑框中输入“比较器电源+”，勾选“Hide”复选框，在“Connect To”编

辑框中输入“VCC”，这样就表示该引脚被隐藏，且自动与名称为“VCC”的电源网络相

连接，在“Part Number”编辑框中输入“0”，表示该引脚属于 LM393 元件的公共引脚，

无论使用 LM393中的那个模块，该引脚都会被调用。单击“OK”按钮，关闭“Pin Properties”

对话框。 

（24）在工作区中任意位置单击鼠标左键，布置第 8号电源引脚。 

（25）采用同样方法，布置第 4号电源地引脚，在“Pin Properties”对话框中设置“Display 

Name”为“GND”，“Designator”属性为“4”，“Electrical Type”属性为“Power”，

“Description”属性为“比较器电源+”，勾选“Hide”复选框，在“Connect To”编辑框中

输入“GND”， “Part Number”属性设置为“0”。 

由于两个电源引脚被设置为隐藏，所以在原理图中并未显示出来。 

（26）选择主菜单中的“View”->“Show Hidden Pins”命令，显示隐藏的引脚，此时

LM393的 PARTA的原理图如图 5.21所示。 

 

图 5.21  显示电源引脚的 LM393 的 PARTA的原理图 

（27）选择主菜单中的“File”->“Save”命令，或者单击工具栏中的保存按钮 ，将
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保存元件原理图库文件。 

5.1.3  提取原理图元件 

Altium Designer为用户提供了大量的原理图库管理功能，用户除了能向原理图元件库中

添加自定义的元件原理图外，还能通过复制的方法，将其它原理图或原理图元件库中的元件

添加到自定义的原理图元件库中，这样就能充分利用已有的原理图或原理图库，使元件的管

理更为规范。本小节将通过一个实例介绍如何从原理图或其它原理图元件库中提取原理图元

件。 

本实例的操作目的是从 Altium Designer软件自带的示例原理图文件“4Port UART and 

Line Drivers.schdoc”中提取元件的原理图，复制到 5.2.1节定义的原理图元件库中。 

（1）启动 Altium Designer，选择主菜单的“File”->“Open”命令，或单击工具栏中的

打开文件按钮 ，打开“Choose Document to Open”对话框。 

（2）在“Choose Document to Open”对话框中打开 Altium Designer安装目录下的

“Examples/Reference Design/4 Port Serial Interface”子目录，选择“4Port UART and Line 

Drivers.schdoc”文件，单击“打开”按钮，将其打开，打开的文件如图 5.22所示。 

 

图 5.22  “4Port UART and Line Drivers.schdoc”原理图文件 

（3）单击原理图中的编号为“U1”的“TL16C554”元件，将其选中，然后选择主菜

单中的“Edit”->“Copy”命令或者按键盘快捷键“Ctrl+C”，将选中的元件复制到剪贴板

中。 

此时单击工作区右侧的“Clipboard”页面标签，打开的“Clipboard”页面如图 5.23 所

示，其中包含了复制的元件的原理图，表示该元件已被复制到剪贴板中了。 

 

图 5.23   “Clipboard”页面 
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（4）打开 5.1.1小节创建的元件库项目文件“custom.LibPkg”，然后双击“Projects”

选项卡中的“custom.SchLib”文件名，打开“custom.SchLib”文件。 

（5）单击工作区左侧的“SCH Libary”选项页标签，打开“SCH Libary”选项页。 

（6）在“SCH Libary”选项页中的元件列表中单击鼠标右键，在弹出的如图 5.24所示

的右键菜单中选择“Paste”命令，将剪贴板中的元件原理图粘贴到原理图库中。 

 

图 5.24  右键菜单 

此时原理图元件库的元件列表中就会增添一个名为“TL16C554”的元件，如图 5.25所

示。 

 

图 5.25  添加的原理图元件 

除了可以提取单个元件外，Altium Designer还支持同时提取多个原理图元件，用户只需

要在复制前同时选中多个元件，粘贴到元件库中时，Altium Designer会自动从剪贴板中将元

件的原理图提取出来，其它非元件原理图的图元部分则不会粘贴到元件库中。 

（7）在“SCH Libary”选项页中的元件列表中选择新添加的元件“TL16C554”，单击

“Edit”按钮，打开“Library Component Properties”对话框。 

（8）将“Library Component Properties”对话框中的“Properties”选项区域内的“Default 

Designator”编辑框中的“U1”更改为“U？”，这样当调用该元件时元件编号能自动递增。 

（9）单击“OK”按钮，关闭“Library Component Properties”对话框。 

（10）选择主菜单中的“File”->“Save”命令，或者单击工具栏中的保存按钮 ，将

保存元件原理图库文件。 

以上操作实现了从原理图中提取原理图元件，接下来的操作将实现从已有的原理图库
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“Miscellaneous Devices.IntLib”中提取原理图元件。 

（1）启动 Altium Designer，选择主菜单的“File”->“Open”命令，或单击工具栏中的

打开文件按钮 ，打开“Choose Document to Open”对话框。 

（2）在“Choose Document to Open”对话框中打开 Altium Designer安装目录下的

“Library”子目录，选择“Miscellaneous Devices.IntLib”文件，单击“打开”按钮，将其打

开。 

由于“Miscellaneous Devices.IntLib”文件是个复合元件库文件，在该库文件中，元件的

原理图和 PCB封装被复合链接起来，所以在打开“Miscellaneous Devices.IntLib”文件之前，

系统会显示如图 5.26所示的“Extract Sources or Install”消息框，询问用户是要将该复合元

件库文件分解成对应的原理图元件库还是仅仅调用该复合元件库。本例中需要使用该复合元

件库中的原理图元件库部分，所以选择“Ectract Sources”。 

 

图 5.26  “Extract Sources or Install”消息框 

（3）单击“Extract Sources or Install”消息框中的“Extract Sources”按钮，将该复合元

件库分解。 

（4）在弹出的“Project”选项卡中双击“Miscellaneous Devices.SchLib”文件名，在工

作区打开该库文件。 

（5）单击工作区左侧的“SCH Library”选项页标签，打开“SCH Library”选项页。 

（6）在“SCH Library”选项页中的元件列表中选择需要提取的元件名称，利用键盘上

的 Windows的选择快捷键“Ctrl”键或“Shift”键能一次选择多个元件，本例中选择的元件

是“2N3904”和“2N3906”。 

（7）在元件列表中单击鼠标右键，在弹出的右件菜单中选择“Copy”命令，将所选的

元件复制到剪贴板中。 

（8）打开 5.2.1小节创建的元件库文件“custom.SchLib”。 

（9）单击工作区左侧的“SCH Libary”选项页标签，打开“SCH Libary”选项页。 

（10）在“SCH Libary”选项页中的元件列表中单击鼠标右键，在弹出右键菜单中选择

“Paste”命令，将剪贴板中的元件原理图粘贴到原理图库中，复制后的元件列表如图 5.27

所示。 
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图 5.27  粘贴元件后的元件列表 

（11）选择主菜单中的“File”->“Save”命令，或者单击工具栏中的保存按钮 ，将

保存元件原理图库文件。 

采用上述实例中的方法，可以将平时使用频率较高的元件集中到一个自定义的元件库

中，方便绘制原理图时调用。 

5.2  创建复合元件库 

通过上一节的学习，读者应该会利用各种现有的资源创建自己的原理图元件库，在

Altium Designer中，为了实现由原理图设计到 PCB图设计、电路仿真，电路三维建模的无

缝连接，通常使用的元件库是复合元件库文件，即将元件的原理图符号、元件的 PCB引脚

封装图形、元件的仿真模型以及元件的 3D模型连接到一起，成为一个复合的元件库。使用

这种复合元件库，就可以在原理图的基础上，自动更新产品的 PCB图、进行电路原理仿真、

生成电路板成品的 3D外观图。本节将介绍创建复合元件库的方法。 

5.2.1  原理图元件库转换集成元件库 

本小节将通过把 5.1 节中自定义的原理图元件库转换成集成库的实例，介绍在 Altium 

Designer 6环境中生成集成库的方法。 

（1）启动 Altium Designer，在主菜单选择“File”->“New”->“Integrated Library”命

令，新建一个默认名为“Integrated_ Library1.LibPkg”的复合元件库项目。 

（2）在主菜单选择“File”->“Save As”命令，打开“Save [Integrated_ Library1.LibPkg]As”

对话框。 

（3）在“Save [Integrated_ Library1.LibPkg]As”对话框的“文件名”编辑框中输入

“Custom”，单击“保存”按钮，将新建的集成元件库项目文件更名为“Custom.LibPkg”。 

（4）在“Projects”工作面板中单击“Projects”按钮，在弹出的菜单中选择“Add Existing 

to Project”命令，打开“打开”对话框。 

（5）在“打开”对话框中选择 5.1.1节中新建的原理图元件库文件“Custom.SchLib”，

单击“打开”按钮，将该文件添加到集成元件库项目中。 

（6）在主菜单中选择“Project”->“Project Options”命令，打开如图 5.28所示的“Options 

for Script Project Custom.SchLib”对话框。 
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图 5.28  “Options for Script Project Custom.SchLib”对话框 

（7）单击如图 5.29所示的“Options for Script Project Custom.SchLib”对话框中的“Search 

Path”标签，打开如图 5.30所示的“Search Path”选项卡。 

 

图 5.30  “Search Path”选项卡 

（8）单击“Search Path”选项卡中的“Add”按钮，打开如图 5.31所示的“Edit Search 

Path”对话框。 

 

图 5.31  “Edit Search Path”对话框 
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（9）单击“Edit Search Path”对话框中的 按钮，打开“浏览文件夹”对话框。 

（10）在“浏览文件夹”对话框中选择“Altium Designer\Library\PCB”，单击“确定”

按钮。 

（11）单击“Edit Search Path”对话框中的“Refresh List”按钮，刷新文件列表，如图

5.32所示。 

 

图 5.32  刷新后的列表 

（12）单击“Edit Search Path”对话框的 “OK”按钮，关闭该对话框。然后，单击“Options 

for Script Project Custom.SchLib”对话框中的“OK”按钮。 

（13）在主菜单中选择“Project”->“Compile Integrated Library Custom.LibPkj”命令，

开始对项目进行编译。 

编译完成后，系统将生成一个名为“Custom.IntLib”的集成元件库文件，并自动加载该

集成元件库。 

（14）在“Library”工作面板的元件库选择下拉列表中选择生成的“Custom.IntLib”元

件库，打开该元件库，如图 5.33所示。 

 

图 5.33 打开的“Custom.IntLib”元件库 

至此，自定义的集成元件库就创建完毕了。 
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5.2.2  老版本元件库转换集成元件库 

Protel99SE及其以前的 Protel版本中都未使用集成元件库，而很多用户已经熟悉了老版

本元件库，若能将老版本的元件库转换成集成元件库，将给这些用户带来极大的方便。本小

节将通过一个实例介绍将老版本的元件库转换成集成元件库的方法。 

（1）启动 Protel DXP2004，在主菜单中选择“File”->“Open”命令，打开“打开”对

话框。 

（2）在“打开”对话框中选择“Protel DOS Schematic Libraries.ddb”文件，单击“打

开”按钮，打开如图 5.34所示的“Confirm”消息框，提示用户系统会自动将所选的“DDB”

数据库文件转化为项目文件。 

 

图 5.34  “Confirm”消息框 

（3）单击如图 5.35所示的“Confirm”消息框中的“Yes”按钮，系统创建如图 6.57所

示的“Protel DOS Schematic Libraries.DsnWrk” 工作台。 

 

图 5.35  “Protel DOS Schematic Libraries.DsnWrk” 工作台 

（4）在“Projects”工作面板的文件列表中双击“Protel DOS Schematic Analog digital.lib”

文件，将其打开。 

（5）在主菜单中选择“File”->“Save As…”命令，打开如图 5.36所示的“Save[Protel 

DOS Schematic Analog digital.lib]As”对话框。 
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图 5.36  “Save[Protel DOS Schematic Analog digital.lib]As”对话框 

（6）在“Save[Protel DOS Schematic Analog digital.lib]As”对话框中选择保存路径，在

“文件名”编辑框中输入“Protel DOS Schematic Analog digital”，单击“保存”按钮，将所

选的库文件保存为“Protel DOS Schematic Analog digital.SchLib”。 

（7）单击标准工具栏中的打开文件工具按钮 ，打开“打开”对话框。 

（8）在“打开”对话框中选择“General IC.DDB”文件，单击“打开”按钮，在弹出

的提示将“DDB”文件转化为项目的“Confirm”消息框中单击“Yes”，接着在弹出的如图

5.37所示的“Confirm”对话框中单击“No”，关闭“Protel DOS Schematic Libraries.DsnWrk”

工作台文件，同时打开系统创建的如图 5.38所示的“General IC. DsnWrk”工作台。 

 

图 5.37  “Confirm”消息框 

 

图 5.38  “General IC. DsnWrk”工作台 

（9）在“Projects”工作面板的文件列表上双击“General IC.lib”文件，将其打开。 

（10）在主菜单中选择“File”->“Save As…”命令，打开“Save[General IC.lib]As”

对话框。 

（11）在“Save[General IC.lib]As”对话框中选择与“Protel DOS Schematic Analog 

digital.SchLib”相同的保存路径，在“文件名”编辑框中输入“General IC”，单击“保存”

按钮，将所选的库文件保存为“General IC.PCBLib”。 

（12）在主菜单选择“File”->“New”->“Integrated Library”命令，新建一个默认名
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为“Integrated_ Library1.LibPkg”的集成元件库项目。 

（13）在主菜单选择“File”->“Save As”命令，打开“Save [Integrated_ Library1.LibPkg]As”

对话框。 

（14）在“Save [Integrated_ Library1.LibPkg]As”对话框的“文件名”编辑框中输入“AD 

Convertor”，单击“保存”按钮，将新建的集成元件库项目文件更名为“AD Convertor. LibPkg”。 

（15）在“Projects”工作面板中单击“Projects”按钮，在弹出的菜单中选择“Add Existing 

to Project”命令，打开“打开”对话框。 

（16）在“打开”对话框的“文件类型”下拉列表中选择“Any File *.*”，然后按住“Ctrl”

键，选择导出的元件库文件“General IC.PCBLib”和“Protel DOS Schematic Analog 

digital.SchLib”，单击“打开”按钮，将这两个文件添加到集成元件库项目中，如图 5.39所

示。 

 

图 5.39  添加的两个文件 

（17）在主菜单中选择“Project”->“Compile Integrated Library AD Convertor. LibPkg”

命令，开始编译集成元件库项目。 

系统编译结束后，自动在与“AD Convertor. LibPkg”文件名相同的文件夹下新建一个

名为“AD Convertor.IntLib”的集成库文件，并自动加载该集成元件库。 

（18）在“Library”工作面板的元件库选择下拉列表中选择生成的“AD Convertor.IntLib”

元件库，打开该元件库，如图 5.40所示。 

 

图 5.40  “AD Convertor.IntLib”元件库 

至此，集成元件库就转换完毕了。 
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第 6章  原理图仿真分析 

电子系统设计者在设计电路时，需要凭借自己的经验，或者通过搭建实验电路板，进行

实际测试，来验证电路原理设计的正确性，使用 Altium Designer 6之后，设计者可以在原理

图设计完成后，对原理图的功能进行软件仿真，以此验证电路的原理正确性。 

Altium Designer 6可以在原理图设计界面下进行模拟电路、数字电路或者混合电路的仿

真，Altium Designer 6的混合仿真器兼容 SPICE仿真模型，对仿真电路的复杂程度没有限制，

仅要求参与仿真的原理图中的元件都包含仿真模型。本章将通过实例介绍使用 Altium 

Designer 6进行仿真的方法。 

6.1  静态工作点分析（Operating Point Analysis） 

静态工作点分析通常用于对放大电路进行分析，当放大器处于输入信号为零的状态的时

候，电路中各点的状态就是电路的静态工作点。最典型的是放大器的直流偏置参数。进行静

态工作点分析的时候，不需要设置参数。本节将通过一个实例介绍使用静态工作点分析的方

法。 

（1）启动 Altium Designer 6，新建一个空白原理图文件，命名为“Sim1.SchDoc”。 

（2）单击“Libraries”面板标签，打开“Libraries”面板，单击“Search…”按钮，在

弹出的“Libraries Search”对话框中的编辑框内输入“AD645”，单击“Search”按钮。 

（3）在“Libraries”面板中选择搜寻到的名为“AD645KN”的器件，布置到工作区。 

（4）单击“Utility”工具栏中的数字元件工具按钮 ，打开如图 6.1 所示的数字元件

工具栏，在工具栏中单击“1K”电阻工具按钮 。 

 

图 6.1  数字元件工具栏 

（5）单击键盘的“Tab”键，打开“Component Properties”对话框。 

（6）在“Designator”编辑框内输入“R1”，在“Parameter for R？-Res2”列表中的“Value”

栏中输入“7.68k”，单击“OK”按钮，关闭“Component Properties”对话框。 

（7）按照同样的方法，在工作区布置参数为“14.7K”、“10K”的两个电阻和两个参

数分别为 0.01uF和 0.022uF的电容。 

（8）单击“Utility”工具栏中的源工具按钮 ，打开如图 6.2所示的源工具栏，在工

具栏中单击“+12V”电压源工具按钮 ，在工作区布置一个+12V的电压源。 
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图 6.2  源工具栏 

（9）采用同样方式，在工作区布置一个-12V 的电压源和一个频率为 1K 的脉冲电压信

号源。 

（10）在原理图工作区布置导线和电源标志，同时布置两个电路节点“Input”和“Output”，

绘制的电路原理图如图 6.3所示。 

 

图 6.3  绘制完成的电路原理图 

（11）在主菜单中选择“Design”->“Simulate”->“Mixed Sim”命令，打开如图 6.4

所示的“Analyses Setup”对话框。 
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图 6.4  “Analyses Setup”对话框 

（12）在“Avalable Signals”列表中选择“INPUT”和“OUTPUT”两个网络节点，单

击“>”按钮，将这两路信号添加到“Active Signals”列表中。 

（13）勾选“Analyses/Options”列表中的“OperatingPoint Analysis”项，单击“OK”

按钮，开始进行静态工作点分析。 

分析结束后，系统新建一个名为“Sim1.sdf”分析结果文件，显示如图 6.5 所示的静态

工作点分析结果。 

 

图 6.5  静态工作点分析结果 

该分析结果表明，在输入为 0的情况下，有源滤波器的输出电压为 500.2uV，该电压为

电路的静态工作点。 

（14）单击保存工具按钮 ，保存仿真结果和原理图。 

6.2  瞬态/傅立叶分析（Transient/Fourier Analysis） 

瞬态分析用于仿真电路中各点的动态信号随时间变化的状态，使用瞬态分析就像使用示

波器一样，显示系统测试点的信号波形，方便从时域分析信号。进行瞬态分析前，需要设置

瞬态分析的起始时间、终了时间和仿真的时间步长，系统首先进行静态工作点分析，确定系

统的直流偏置，接着从时间零点开始进行仿真，直到瞬态分析的起始时间，开始记录仿真结

果，到仿真的终了时间后，停止仿真，显示起始时间和终了时间之间的仿真结果。瞬态分析

的结果中的周期数据可以进行傅立叶分析，显示信号的频域波形。接下来将通过一个实例介

绍使用瞬态/傅立叶分析的方法。 

（1）启动 Altium Designer 6，打开上一节创建的原理图文件“Sim1.SchDoc”。 

（2）双击名称为“1KHz”的脉冲源，打开“Component Properties”对话框，单击“Component 

Properties”对话框右下角的“Model for 1KHz-VPULSE”列表中的“Edit”按钮，打开如图

6.6所示的“Sim Model-Voltage Source/Pulse”对话框。 

tyw藏书



第 6 章  原理图仿真分析 

 

 
 

·192·   

 

图 6.6  “Sim Model-Voltage Source/Pulse”对话框 

（3）单击“Sim Model-Voltage Source/Pulse”对话框中的“Parameters”选项页标签，

打开如图 6.7所示的“Parameters”选项页。 

 

图 6.7  “Parameters”选项页 

（4）设置“Pulse Width”参数为“0.2ms”，单击“OK”按钮，关闭“Sim Model-Voltage 

Source/Pulse”对话框。 

（5）单击“Component Properties”对话框中的“OK”按钮，关闭该对话框。 

（6）选择主菜单栏中的“Design”->“Simulate”->“Mixed Sim”命令，打开“Analyses 

Setup”对话框。 

由于在上一节的仿真过程中已经选取了仿真的电路节点“INPUT”和“OUTPUT”，所

以就不用再次确定仿真的节点了。 

（7）勾选“Analyses/Options”列表中的“Transient/Fourier Analysis ”项，在“Analyses 

Setup”对话框中打开如图 6.8所示的“Transient/Fourier Analysis ”设置界面。 
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图 6.8  “Transient/Fourier Analysis ”设置界面 

在“Transient/Fourier Analysis Setup”列表中共有 11个参数进行设置，各参数的意义如

下： 

“Transient Start Time”参数用于设置瞬态分析的起始时间，实际上进行瞬态分析时，

系统从 0时刻开始进行仿真，在到达瞬态分析起始时间之前的分析结果不被记录。 

“Transient Stop Time”参数用于设置瞬态分析的终了时间，当仿真到该时间时，系统

停止仿真。 

“Transient Step Time”参数用于设置瞬态分析的时间步长，该参数设置得越小，仿真

过程越细致，但仿真花费的时间越长。 

“Transient Max Step Time”参数用于设置瞬态分析的最大时间步长，该参数要不小于

“Transient Step Time”参数。 

“Use Initial Conditions”项用于设置电路仿真的初始状态。当勾选该项后，仿真开始时

将调用设置的电路初始参数。 

“Use Transient Default”项用于设置使用默认的瞬态分析设置，选中该项后，列表中的

前四项参数将处于不可修改状态。 

“Default Cycles Displayed”参数用于设置默认的显示周期数。 

“default Points Per Cycle”参数用于设置默认的每周期仿真点数。 

“Enable Fouries”项用于设置进行傅立叶分析，勾选该项后，系统将进行傅立叶分析，

显示频域参数。 

“Fouries Fundamental Frequency”用于设置进行傅立叶分析的基频。 

“Fouries Number of Harmonics”用于设置进行傅立叶分析的谐波次数。 

（4）取消“Analyses Setup”对话框的“Transient/Fourier Analysis Setup”列表中的“Use 

Transient Defaults”项，手动设置瞬态仿真的参数。 

（8）设置瞬态分析的起始时间为“0m”，终了时间为“10m”，仿真步长和最大仿真

步长为“50u”，勾选傅立叶分析项，设置傅立叶分析的基频为“1k”，谐波次数为“10”，

单击“OK”按钮开始进行仿真。 

瞬态仿真结果如图 6.9所示，傅立叶分析结果如图 6.10所示。 
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图 6.9  瞬态仿真结果 

 

图 6.10  傅立叶分析结果图 

同时系统还创建一个名为“Sim1.sim”的文件，显示傅立叶分析的数据列表，如图 6.11

所示。 
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图 6.11  傅立叶分析数据文件“Sim1.sim”内容 

（9）单击保存工具按钮 ，保存仿真结果和原理图。 

6.3  直流扫描分析（DC Sweep Analysis） 

直流扫描分析会执行一系列的直流工作点分析，从用户设置的直流信号源的起始值开

始，以预定义的步长修改信号源，绘制出直流传递曲线。进行直流扫描分析之前要设置进行

扫描的直流信号源，以及扫描的起始直流参数、终了直流参数和扫描步长，Altium Designer 

6支持同时对两个信号源进行直流扫描分析。本节将介绍进行直流扫描分析的方法。 

（1）启动 Altium Designer 6，打开 8.1节创建的原理图文件“Sim1.SchDoc”。 

（2）选择主菜单栏中的“Design”->“Simulate”->“Mixed Sim”命令，打开“Analyses 

Setup”对话框。 

（3）选择仿真的电路节点“INPUT”和“OUTPUT”作为仿真节点。 

（4）勾选“Analyses/Options”列表中的“DC Sweep Analysis ”项，并单击“DC Sweep 

Analysis ”项，在“Analyses Setup”对话框中打开如图 6.12所示的“DC Sweep Analysis”

设置界面。 
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图 6.12  “DC Sweep Analysis”设置界面 

“DC Sweep Analysis Setup”设置列表中的选项意义介绍如下： 

“Primary Source”项用于设置直流扫描的信号源，用户可在“Value”列中选择电路原

理图中的源。 

“Primary Start”项用于设置进行直流扫描的起始值。 

“Primary End”项用于设置进行直流扫描的终了值。 

“Primary Step”项用于设置进行直流扫描的步长。 

“Enable Secondary”项用于设置对第二个信号源进行直流扫描，勾选该项后，该项下

方的四个选项就被激活。 

“Secondary Name”项用于设置第二个信号源的名称。 

“Secondary Start”项用于设置针对第二个信号源直流扫描的起始值。 

“Secondary End”项用于设置针对第二个信号源直流扫描的终了值。 

“Secondary Step”项用于设置针对第二个信号源直流扫描的步长。 

（5）设置“Primary Source”项为 1K 的脉冲信号源“V1KHz”，设置“Primary Start”

项为“-15”，设置“Primary End”项为“15”，设置“Primary Step”项为“1”，单击“OK”

按钮进行直流扫描。 

直流扫描的结果如图 6.13所示。 
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图 6.13  直流扫描的结果 

通过直流扫描，可以发现所分析二阶滤波电路的输出幅度限制在-9V~9V 之间。 

（6）单击保存工具按钮 ，保存仿真结果和原理图。 

6.4  交流小信号分析（AC Small Signal Analysis） 

交流小信号分析用于对系统的交流特性进行分析，在频域响应方面显示系统的性能，该

分析功能对于滤波器的设计相当有用，通过设置交流信号分析的频率范围，系统将显示该频

率范围内的增益。本节将介绍进行交流小信号分析的方法。 

（1）启动 Altium Designer 6，打开 8.1节创建的原理图文件“Sim1.SchDoc”。 

（2）选择主菜单栏中的“Design”->“Simulate”->“Mixed Sim”命令，打开“Analyses 

Setup”对话框。 

（3）选择仿真的电路节点“INPUT”和“OUTPUT”作为仿真节点。 

（4）勾选“Analyses/Options”列表中的“AC Small Signal Analysis ”项，在“Analyses 

Setup”对话框中打开如图 6.14所示的“AC Small Signal Analysis”设置界面。 
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图 6.14  “AC Small Signal Analysis”设置界面 

“AC Small Signal Analysis Setup”设置列表中的选项意义介绍如下： 

“Start Frequency”参数用于设置进行交流小信号分析的起始频率。 

“Stop Frequency”参数用于设置进行交流小信号分析的终了频率。 

“Sweep”参数用于设置交流小信号分析的频率扫描的方式，系统提供了三种频率扫描

方式“Linear”项表示对频率进行线性扫描，“Decade”项表示采用 10 的指数方式进行扫

描，“Octave”项表示采用 8的指数方式进行扫描。 

“Test Points”参数表示进行测试的点数。 

“Total Test Points”参数表示中的测试点数。 

（5）设置“Start Frequency”参数为“1”，“Stop Frequency”参数为“100k”，选择

“Sweep Type”为“Decade”，设置“Test Points”为 100，单击“OK”按钮，开始交流小

信号分析。 

交流小信号分析的结果如图 6.15所示。 
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图 6.15  交流小信号分析结果 

通过观察交流小信号分析结果，二阶低通滤波器在 10K 左右的输出就接近于 0 了，在

频率为 1K 时的输出只有输入的 70%。 

（6）单击保存工具按钮 ，保存仿真结果和原理图。 

6.5  噪声分析（Noise Analysis） 

噪声分析用于模拟电路中的噪声对电路的影响，仿真器绘制出噪声的功率谱密度，使用

噪声分析之前需要设置仿真的噪声源、分析结果的输出节点，分析的起始频率、终了频率、

扫描方向和测试点的数量。本节将介绍进行噪声扫描的步骤。 

（1）启动 Altium Designer 6，打开 8.1节创建的原理图文件“Sim1.SchDoc”。 

（2）选择主菜单栏中的“Design”->“Simulate”->“Mixed Sim”命令，打开“Analyses 

Setup”对话框。 

（3）选择仿真的电路节点“INPUT”和“OUTPUT”作为仿真节点。 

（4）勾选“Analyses/Options”列表中的“AC Small Signal Analysis ”项，在“Analyses 

Setup”对话框中打开如图 6.16所示的“AC Small Signal Analysis”设置界面。 
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图 6.16  “Noise Analysis”设置界面 

“Noise Analysis Setup”设置列表中的选项意义介绍如下： 

“Noise Source”参数用于设置噪声源 

“Start Frequency”参数用于设置进行噪声分析的起始噪声频率。 

“Stop Frequency”参数用于设置进行噪声分析的终了噪声频率。 

“Sweep Type”参数用于设置交流小信号分析的频率扫描的方式，系统提供了三种频率

扫描方式“Linear”项表示对频率进行线性扫描，“Decade”项表示采用 10 的指数方式进

行扫描，“Octave”项表示采用 8的指数方式进行扫描。 

“Test Points”参数表示进行测试的点数。 

“Ourput Node”参数用于设置测试的受噪声影响的电路输出节点。 

“Reference Node”用于设置噪声测试的参考点，如果以地电压作为参考点，设置该参

数为“0”。 

（5）设置“Noise Source”参数为“V1KHz”，“Start Frequency”参数为“1”，“Stop 

Frequency”参数为“100meg”即设置从 1~108Hz的频率范围，选择“Sweep Type”为“Octave”，

设置“Test Points”为 15，选择“Output”节点为“Output Node”，单击“OK”按钮，开

始噪声分析。 

噪声分析的结果如图 6.17所示。 
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图 6.17  噪声分析结果 

噪声分析结果实采用噪声功率谱密度曲线的形式表现的，纵坐标的单位是 V2/Hz，结果

中的 NO（output）表示白噪音作用到输入端后的输出端的输出噪声强度，NI（output）表示

为获得输出端的白噪声，输入端需要的噪声功率密度。 

进行噪声分析前，系统会自动加载静态工作点分析和交流小信号分析。 

（6）单击保存工具按钮 ，保存仿真结果和原理图。 

6.6  极点、零点分析（Pole-Zero Analysis） 

极点、零点分析计算单输入单输出线性系统传递函数的极点和零点，用于分析系统的稳

定性，本节将通过一个实例介绍进行极点、零点分析的步骤。 

（1）启动 Altium Designer 6，新建一个名为“Sim2.SchDoc”的原理图文件。 

（2）绘制如图 6.18所示的电路原理图。 
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图 6.18  绘制的原理图 

（3）双击“5V”电压源，打开“Comonent Properties”对话框，设置“Value”属性为

“30”并更改电压源的名称为“30V”。 

（4）选择主菜单栏中的“Design”->“Simulate”->“Mixed Sim”命令，打开“Analyses 

Setup”对话框。 

（5）勾选“Analyses/Options”列表中的“Pole-Zero Analysis ”项，在“Analyses Setup”

对话框中打开如图 6.19所示的“Pole –Zero Analysis”设置界面。 

 

图 6.19  “Pole –Zero Analysis”设置界面 

“Pole –Zero Analysis Setup”设置列表中的选项意义介绍如下： 

“Input Node”项用于选择系统输入节点。 

“Input Reference Node”项用于选择输入信号的参考节点，默认为“0”，表示以地电

位作为参考电位。 

“Output Node”项用于选择系统的输出节点。 
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“Output Reference Node”项用于选择输出信号的参考节点，默认为“0”，表示以地电

位作为参考电位。 

“Transfer Fnction Type”项用于选择传递函数的类型，该项有两个选项，其中“V（output）

/ V（input）”表示使用电压增益传递函数，“V（output）/ I（input）”表示使用阻抗传递

函数。 

“Analysis Type”项用于选择分析的类型，该项有三个选项，其中“Poles Only”表示

仅作极点分析，“Zeros Only”表示仅进行零点分析，“Poles and Zeros”表示既进行极点又

进行零点分析。 

（6）选择“Input”节点作为输入节点，“0”作为输入参考节点，“Output”作为输出

节点，“0”作为输出参考节点，“V（output）/ V（input）”作为传递函数，进行“Poles and 

Zeros”分析，结果如图 6.20所示。 

 

图 6.20  极点、零点分析结果 

系统分析得到两个极点和一个零点。 

（7）单击保存工具按钮 ，保存仿真结果和原理图。 

6.7  传递函数分析（Transfer Function Analysis） 

传递函数分析用于计算电路的直流传递函数，即直流输入与输出阻抗和增益。本节将通

过实例介绍进行传递函数分析的方法。 

（1）启动 Altium Designer 6，新建一个名为“Sim2.SchDoc”的原理图文件。 

（2）绘制如图 6.21所示的电路原理图。 
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图 6.21  反向放大电路原理图 

（3）选择主菜单栏中的“Design”->“Simulate”->“Mixed Sim”命令，打开“Analyses 

Setup”对话框。 

（4）选择仿真的电路节点“OUTPUT”作为仿真节点。 

（5）勾选“Analyses/Options”列表中的“Transfer Function Analysis ”项，在“Analyses 

Setup”对话框中打开如图 6.22所示的“Transfer Function Analysis”设置界面。 

 

图 6.22  “Transfer Function Analysis”设置界面 

“Transfer Function Analysis Setup”设置界面中的选项介绍如下。 

“SourceName”项用于选择系统的输入源的节点。 

“Reference Node”项用于设置系统的输入源的参考节点，默认为“0”，表示以地电位

作为参考电位。 

（5）设置“V1KHz”作为“SourceName”，“0”作为“Reference Node”，单击“OK”
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按钮，进行传递函数分析。 

传递函数分析的结果如图 6.23所示。 

 

图 6.23  传递函数分析的结果 

通过传递函数分析可知，该反向放大电路的增益为“-10”，对于源“V1KHz”的输入

阻抗为“10k”欧姆，输出阻抗为“4.325m”，即 4.325×10-3欧姆。 

（6）单击保存工具按钮 ，保存仿真结果和原理图。 

6.8  温度扫描（Temperature Sweep） 

温度扫描分析用于模拟电路在不同温度下的电气特性，温度分析要与其他分析方法结合

起来使用，以确定温度对电路各方面的影响，进行温度扫描分析需要确定起始温度、终了温

度和扫描步长。本节将通过实例介绍进行温度扫描的方法。 

（1）启动 Altium Designer 6，打开 6.6节创建的名为“Sim2.SchDoc”的原理图文件。 

（2）选择主菜单栏中的“Design”->“Simulate”->“Mixed Sim”命令，打开“Analyses 

Setup”对话框。 

（4）选择仿真的电路节点“OUTPUT”作为仿真节点。 

（5）勾选“Analyses/Options”列表中的“Transient/Fourier Analysis ”项，设置瞬态分

析的起始时间为“0m”，终了时间为“10m”，仿真步长和最大仿真步长为“5u”，取消傅

立叶分析项。 

（6）勾选“Analyses/Options”列表中的“Temperature Sweep”项，在“Analyses Setup”

对话框中打开如图 6.24所示的“Temperature Sweep Analysis”设置界面。 

 

图 6.24  “Temperature Sweep Analysis”设置界面 
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“Temperature Sweep Analysis”设置界面中各参数项的意义如下。 

“Start Temparature”参数设置进行温度扫描的起始温度。 

“Stop Temparature”参数设置进行温度扫描的终了温度。 

“Step Temparature”参数设置进行温度扫描的温度步长。 

（7）设置“Start Temparature”参数为“0”，设置“Stop Temparature”参数为“100”，

设置“Step Temparature”参数为“20”，单击“OK”按钮，进行温度扫描分析。 

分析结果如图 6.25所示。 

 

图 6.25  温度扫描分析结果 

通过直接观察温度扫描分析结果曲线，温度对电路输出信号的影响无法直接分辨，需要

使用鼠标放大局部曲线。 

（8）使用鼠标在温度扫描分析结果曲线中合适位置按下左键，拖曳框出需要放大的区

域曲线，释放鼠标后鼠标框出的区域将被放大到整个曲线图区域，放大后的曲线图如图 6.26

所示。 

 

图 6.26  放大后的曲线图 

观察放大后的温度扫描分析曲线图，可以发现，随着温度的提高，输出电压有升高的趋

势，温度升高 100℃，输出电压提高 0.16V，占输出幅度的 16%，可见温度升高对系统性能

的影响不可忽略。 

（9）单击保存工具按钮 ，保存仿真结果和原理图。 
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6.9  参数扫描（Parameter Sweep） 

参数扫描分析用于确定电路中的器件参数对电路的影响，该分析方式需要与其他分析方

法结合起来使用，以确定参数变化对电路各方面的影响，根据设置，逐次改变器件参数，进

行其他的分析。Altium Designer 6支持对两个器件进行参数扫描。本节将通过对二阶滤波器

电路的电阻和电容进行参数扫描的实例介绍进行参数扫描的方法。 

（1）启动 Altium Designer 6，打开 8.1节创建的原理图文件“Sim1.SchDoc”。 

（2）选择主菜单栏中的“Design”->“Simulate”->“Mixed Sim”命令，打开“Analyses 

Setup”对话框。 

（3）选择仿真的电路节点“OUTPUT”作为仿真节点。 

（4）勾选“Analyses/Options”列表中的“AC Small Signal Analysis”项，设置交流小

信号分析的起始频率“Start Frequency”为“1”，终了频率“Stop Frequency”为“100k”，

扫描方式“Sweep Type”为“Linear”和测试点数为“100”。 

（5）勾选“Analyses/Options”列表中的“Parameter Sweep Analysis”项，在“Analyses 

Setup”对话框中打开如图 6.27所示的“Parameter Sweep Analysis”设置界面。 

 

图 6.27  “Parameter Sweep Analysis”设置界面 

“Parameter Sweep Analysis”设置界面中的选项意义如下。 

“Primary Sweep Variable”项用于设置进行第一参数扫描的器件。 

“Primary Start Valure”项用于设置第一参数扫描器件进行参数扫描的起始值。 

“Primary Stop Valure”项用于设置第一参数扫描器件进行参数扫描的终了值。 

“Primary Step Valure”项用于设置第一参数扫描器件进行参数扫描的步长值。 

“Primary Sweep Type”项用于设置第一参数扫描器件进行参数扫描的方式，共有两种

方式可供选择，其中“Absolute Values”项表示根据设置的参数的值直接进行扫描，“Relative 

Values”项表示根据设置的参数的相对关系进行扫描。 

“Enable Secondary”项用于设置同时进行第二个器件的参数扫描，勾选该项后，其下

方的其它选项将被激活用于设置第二个器件的参数扫描值。 
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第二个器件的参数扫描值的设置项意义与第一参数扫描器件的设置方式相同，在这里就

不再赘述。 

（6）“Parameter Sweep Analysis”设置界面中的“Primary Sweep Variable”项中选择器

件“C1”，设置“Primary Start Valure”为“2n”即 2nF，设置“Primary Stop Valure”为“10n”，

设置“Primary Step Valure”为“4n”，在“Primary Sweep Type”项中选择“Absolute Values”

项，（7）勾选“Enable Secondary”项，在“Secondary Sweep Variable”项中选择器件“C2”，

设置“Secondary Start Valure”为“4.4n”，设置“Secondary Stop Valure”为“22n”，设置

“Secondary Step Valure”为“4.4n”，在“Secondary Sweep Type”项中选择“Absolute Values”

项，单击“OK”按钮进行参数扫描。 

参数扫描结果如图 6.28所示， 

 

图 6.28  参数扫描结果 

通过对参数扫描结果的分析，可以发现，随着 C1的增大，滤波系统的截止频率逐步减

小，但频率衰减速度变缓，随着 C2的增大，频率衰减的速度加快，频率特性变陡，但频域

出现尖峰，通过调整 C1和 C2 的大小，可以获得频域特性最好的组合。单击参数扫描结果

右侧的对应曲线名称，例如“output_p06”，系统会自动淡化其它曲线，而突出显示该曲线，

右下方会显示该曲线的对应扫描参数，如图 6.29所示。 

 

图 6.29  突出显示“output_p06”曲线 

（8）单击保存工具按钮 ，保存仿真结果和原理图。 
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6.10  蒙特卡洛分析（Monte Carlo Analysis） 

当电子产品进行批量生产时，每个电子器件的公差会对电路的性能造成影响，蒙特卡洛

分析采用数理统计方式，分析由于器件参数的随机误差对电路的影响。该分析方式需要与其

他分析方法结合起来使用，以确定参数的随机变化对电路各方面的影响。本节将通过对二阶

滤波器电路进行蒙特卡洛分析的实例介绍进行蒙特卡洛分析的步骤。 

（1）启动 Altium Designer 6，打开 8.1节创建的原理图文件“Sim1.SchDoc”。 

（2）选择主菜单栏中的“Design”->“Simulate”->“Mixed Sim”命令，打开“Analyses 

Setup”对话框。 

（3）选择仿真的电路节点“OUTPUT”作为仿真节点。 

（4）勾选“Analyses/Options”列表中的“AC Small Signal Analysis”项，设置交流小

信号分析的起始频率“Start Frequency”为“100”，终了频率“Stop Frequency”为“10k”，

扫描方式“Sweep Type”为“Decade”，测试点数为“100”。 

（5）勾选“Analyses/Options”列表中的“Monte Carlo Analysis”项，在“Analyses Setup”

对话框中打开如图 6.30所示的“Monte Carlo Analysis”设置界面。 

 

图 6.30  “Monte Carlo Analysis”设置界面 

“Monte Carlo Analysis”设置界面中的设置选项意义如下。 

“Seed”项用于设置进行蒙特卡洛扫描时，生成器件参数随机数的种子值，默认值为

“-1”。 

“Distribution”项用于设置器件参数的公差随机分布的统计规律，系统提供了三个选项，

其中“Uniform”项表示器件的参数在公差范围内是均匀分布的，“Gaussian”项表示器件

的参数在公差范围内是满足高斯分布规律分布的，“Worst Case”项表示器件总是按照最糟

糕的状态，即公差最大的状态分布。 

“Number of Runs”项用于设置进行蒙特卡洛分析的次数。 

“Default Resistor Tolerance”项用于设置默认的电阻器件的误差范围。 

“Default Capacitor Tolerance”项用于设置默认的电容器件的误差范围。 
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“Default Inductor Tolerance”项用于设置默认的电感器件的误差范围。 

“Default Transistor Tolerance”项用于设置默认的晶体管器件的误差范围。 

“Default DC Source Tolerance”项用于设置默认的直流源器件的误差范围。 

“Default Digital Tp Tolerance”项用于设置默认的数字器件的误差范围。 

“Specific Tolerance”项用于独立设置具体的器件的误差范围。 

（6）设置“Seed”项为“1”，在“Distribution”项中选择“Worst Case”项，“Number 

of Runs”项设置为“5”，其他的公差选项全部设置为“10%”，单击“OK”按钮，进行蒙

特卡洛分析。 

蒙特卡洛分析的结果如图 6.31所示。 

 

图 6.31  蒙特卡洛分析的结果 

通过进行蒙特卡洛分析，可以发现二阶滤波器性能受器件公差的影响还是比较明显的。 

（7）单击保存工具按钮 ，保存仿真结果和原理图。 
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第 7章  PCB设计基础 

PCB（Printed Circle Board 印刷电路板）设计是电子产品由原理设计转换为产品的一个

重要过程，为实现电路原理图所描述的电路，设计者需要设计满足原理图要求的 PCB板，

本章将介绍使用 Altium Designer进行 PCB板设计的基础知识。 

7.1  PCB设计的基本概念 

在介绍 PCB设计操作之前，本节将向读者介绍一些 PCB设计的基础知识，如元件封装、

导线、飞线等基本概念以及 PCB设计的一般流程。 

7.1.1  PCB介绍 

常用的 PCB板主要由绝缘基板和敷铜面以及上面的附属部分构成，根据其敷铜面的数

量分为单面板（Signal Layer PCB）、双面板（Double Layer PCB）和多层板（MultiLayer PCB）

三种。 

单面板只在绝缘基板一面敷铜，另一面没有敷铜，用于安插电子元件。由于只可在它敷

铜的一面布线和焊接元件，所以这种板的布线相对较困难，对于设计者的要求较高，但成本

最低，用于比较简单的电路或对成本限制较严的电子产品。 

双面板在绝缘基板的两面都有敷铜，设计时将一面定义为顶层（Top Layer），另一面

定义为底层（Bottom Layer），一般情况下在顶层布置元件，在底层焊接。顶层和底层都可

以布线，可以使用过孔将两层的电路连接起来。 

多层板是包含多个工作层面的电路板，除了有顶层和底层外还有中间层，顶层和低层与

双面板一样，中间层一般构成电源层或接地层。 

通常在印制电路板上布上铜膜导线后，还要在上面涂上一层防焊膜（Solder Mask），这

层防焊膜将铜膜导线覆盖住，仅留出需要进行焊接的位置。防焊膜不粘焊锡，在进行机器焊

接时，可以防止焊锡溢出造成短路。根据防焊膜的位置，分为顶层防焊膜（Top Solder Mask）

和底层防焊膜（Bottom Solder Mask）。 

为了便于电路板的焊接，防止生产过程中的错误，印制电路板的顶层和底层安插电子元

件的位置印上一些必要的符号和文字，如元件标号、引脚标志等，印刷标志或文字的层称为

丝印层（Silkscreen Overlay），根据标志和文字印刷的位置不同，又分为顶层丝印层（Top 

Overlay）和底层丝印层（Bottom Overlay）。 

7.1.2元件封装 

所谓封装是指安装半导体集成电路芯片用的外壳，它不仅起着安放、固定、密封、保护

芯片和增强电热性能的作用，而且还是沟通芯片内部世界与外部电路的桥梁——芯片上的接

点用导线连接到封装外壳的引脚上，这些引脚又通过印制板上的导线与其他器件建立连接。

新型电子器件的出现常常伴随着新的封装形式的使用。芯片的封装技术已经历了好几代的变
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迁，从 DIP、QFP、PGA、BGA 到 CSP再到 MCM，技术指标一代比一代先进，包括芯片面

积与封装面积之比越来越接近于 1，器件体积越来越小，适用频率越来越高，耐温性能越来

越好，引脚数增多，引脚间距减小，重量减小，可靠性提高，使用更加方便等等。下面将对

具体的封装形式作详细说明。 

1.元件封装的分类 

按照元件安装方式，元件封装可以分为封装和表面安装式封装两大类。 

典型穿孔安装式元件封装外型及其 PCB板上的焊接点如图 7.1 所示。穿孔安装式元件

焊接时先要将元件引脚插入焊盘通孔中，然后再焊锡。由于焊点导孔贯穿整个电路板，所以

其焊盘中心必须有通孔，焊盘至少占用两层电路板。通常采用穿孔安装的元件体积较大，利

于散热，适用于较大功率的电路。 

   

图 7.1  穿孔安装式元件外型及其 PCB焊盘 

典型的表面粘着式封装的 PCB 图如图 7.2 所示。此类封装的焊盘只限于表面板层，即

顶层或底层，采用这种封装的元件的引脚占用板上的空间小，不影响其他层的布线，一般引

脚比较多的元件常采用这种封装形式，但是这种封装的元件手工焊接难度相对较大，多用于

大批量机器生产。 

   

图 7.2  表面粘着式封装的器件外型及其 PCB焊盘 

2.元件封装的编号 

常见元件封装的编号原则为：元件封装类型+焊盘距离（焊盘数）+元件外型尺寸。可

以根据元件的编号来判断元件封装的规格。例如有极性的电解电容，其封装为 RB.2-.4，其

中“.2”为焊盘间距，“.4”为电容圆筒的外径，“RB7.6-15”表示极性电容类元件封装，引脚

间距为 7．6mm，元件直径为 15mm。 
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7.1.3  其他概念 

1.铜膜导线 

铜膜导线是指在 PCB板上的敷铜层经过蚀刻后形成的铜膜电流通路，又简称为导线，

用于实现各个元件引脚间的电路连接，是印制电路板重要的组成部分。 

2.焊盘（Pad） 

焊盘是在电路板上为固定元件引脚，并使元件引脚和导线导通而加工的具有固定形状的

铜膜。形状一般有圆形“Round”、方形“Rectangle”和八角形“Octagonal”三种，一般用

于固定穿孔安装式元件的焊盘有孔径尺寸和焊盘尺寸两个参数，表面粘着式元件常采用方形

焊盘。 

3.过孔（Via） 

过孔存在于双层板和多层板中，过孔的作用是连接不同的板层间的导线，根据连接板层

不同，过孔分为三种，即从顶层到底层的穿透式过孔、从顶层通到内层或从内层通到底层的

盲过孔以及内层间的屏蔽过孔。过孔通常为圆形，中间有一个贯穿两层和多层板的通孔。 

4.安全间距（Clearance） 

为了避免导线、过孔、焊盘之间因为制造工艺的原因，产生连线短路的问题，或在使用

过程中由于导线距离过近，发生信号干扰，因此这些 PCB板上的对象之间的间隙必须满足

一定的要求，即大于某一个安全间距，安全间距的大小可以在布线规则中设置，具体参见有

关部分。 

7.2  PCB板设计流程图 

利用 Altium Designer设计 PCB板通常需要经过，同步 PCB文件、元件布局、PCB布

线等几个步骤，其具体的的流程图如图 7.3所示。 
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图 7.3  PCB板设计步骤 

设计过程介绍如下。 

1）绘制编译原理图 

绘制编译原理图是 PCB板设计的准备工序，设计者将其设计的电路采用原理图的形式

输入系统，通过编译过程检验原理图设计是否满足原理图设计规则的要求，同时生成连线网

络，这些工作步骤在前几章已经作了详细介绍。在特殊情况下，例如电路比较简单的情况下

可以不进行原理图设计而直接进入 PCB板的设计过程，然后在 PCB编辑器中手工布线或者

利用网络管理器人工创建网络表后进行交互布线。 

2）添加 PCB文件 

这一步是 PCB板设计中的第一步，首先必须在已有的项目中添加新的 PCB文件，这样，

该 PCB文件就与该项目中的原理图联系起来，这是非常重要的，新建的 PCB文件还需要设

置一些主要参数，例如：电路板的结构及其尺寸、PCB 板的层数、格点的大小和形状。一

般情况下大多数参数可以用系统的默认值。 

3）同步 PCB文件 

同步 PCB文件是将原理图中的内容与 PCB文件中的内容同步起来，这种同步是通过网

络列表来实现的，网络列表示描述电路连接的列表文件，是连接原理图设计和 PCB板设计

的纽带，同步过程中，系统会显示同步操作将对 PCB文件进行得的修改内容，用户可以逐

个选择是否进行修改，这个过程将在以后详细介绍。同步完成后，PCB 文件中将具有原理

图中所有元件的 PCB封装，以及元件的连接关系。 

4）PCB板元件布局规则设置 

好的元件布局是布线成功的保障，AltiumDesigner6.0中提供了自动布局的功能，可以按

照用户设置的布局规则，自动进行元件位置的布局。即使用户采用交互布局的方式进行布局，

绘制编译原理图 

使用原理图 

同步 PCB文件 

添加 PCB文件 

设置 PCB板 

元件布局规则 

交互布局 自动布局 

设置 PCB板 

布线规则 

交互布线 自动布线 

手工调整布线 

校验 

输出生产制造文件 

不合格 

合格 

不合格 

合格 

手工调整布局 

校验 
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系统也会自动检查当前布局状态，显示当前违反布局规则的错误或警告。降低由于布局失误

为后续工作带来的麻烦。为得到一个满意的元件布局，用户必须设置好 PCB板元件布局规

则。 

5）布线规则设置 

布线规则是布线时依据的各个规范，如安全间距、导线宽度等，这是对自动布线的约束。

布线规则的设置也是印制电路板设计的关键之一，需要一定的实践经验，布线规则设置不能

过高也不能过低，当约束条件设置得过高，给布线带来较大的困难，会使布线成功率降低，

约束条件设置得过低，不限质量将受到影响，会给实际产品带来隐患，甚至无法满足实际需

要。 

6）输出生产制造文件 

在绘制完成 PCB板后，系统可以生成各种生产制造文件和输出报表，例如 PCB光绘文

件“Gerber”、数控钻文件“NC drill”、元件插置文件“Pick and Place”和材料清单报表等，

使用这些文件，设计者就可以开始批量生产 PCB板以及进行元件自动焊接。 

7.2.1  Altium Designer中的 PCB设计环境简介 

通过创建或打开 PCB文件，即可启动 PCB设计界面，PCB设计界面如图 7.4所示。与

原理图设计界面类似，由主菜单、工具栏、工作区和工作面板组成，工作区面板可以通过移

动、固定或隐藏来适应设计者的工作环境。 

 

图 7.4  PCB设计界面 

1.主菜单 

PCB设计界面中的主菜单如图 7.5所示，该菜单中包括了与 PCB设计有关的所有操作

命令。 

 

图 7.5  PCB设计界面中的主菜单 

2.工具栏 

PCB编辑器中的工具栏由“Standard”工具栏、“Utilities”工具栏、“Filter”工具栏、

“Wiring”工具栏和“Navigation”工具栏组成，分别介绍如下。 
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标准工具栏如图 7.6所示，主要进行常用的文档编辑操作，其内容与原理图设计界面中

标准工具栏的内容完全相同，功能也完全一致，这里不作详细介绍。 

 

图 7.6  标准工具栏 

“Utilities”工具栏如图 7.7所示，其中的工具按钮用于在 PCB图中绘制不具有电气意

义的图元对象，具体介绍如下。 

 

图 7.7  “Utilities”工具栏 

1）绘图工具按钮 ，单击绘图工具按钮 ，弹出如图 7.8所示的工具栏，该工具栏中

的工具按钮用于绘制直线、圆弧等不具有电气性质的图元。 

 

图 7.8  绘图工具栏 

2）对齐工具按钮 ，单击对齐工具按钮 ，弹出如图 7.9 所示的工具栏，该工具栏中

的工具按钮用于对齐选择的图元对象。 

 

图 7.9  对齐工具栏 

3）查找工具按钮 ，单击查找工具按钮 ，弹出如图 7.10所示的查找工具栏，该工具

栏中的工具按钮用于查找元件或者元件组。 

 

图 7.10  查找工具栏 

4）标注工具按钮 ，单击标注工具按钮 ，弹出如图 7.11所示的标注工具栏，该工具

栏中的工具按钮用于标注 PCB图中的尺寸。 
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图 7.11  标注工具栏 

5）区域工具按钮 ，单击区域工具按钮 ，弹出如图 7.12所示的分区工具栏，该工具

栏中的工具按钮用于在 PCB图中绘制各种分区。 

 

图 7.12  分区工具栏 

6）栅格工具按钮 ，单击栅格工具按钮 ，弹出如图 7.13所示的下拉菜单，在此下拉

菜单中设置 PCB图中的对齐栅格的大小。 

 

图 7.13  下拉菜单 

7）“Wiring”工具栏如图 7.14所示，该工具栏中的工具按钮用于绘制具有电气意义的

铜膜导线、过孔、PCB元件封装等图元对象，与之前的 Protel版本不同的是，Altium Designer

新增加了两种交互式布线工具，这些工具的使用，将在接下来的章节中详细介绍。 

 

图 7.14  “Wiring”工具栏 

8）“Filter”工具栏如图 7.15所示，该工具栏用于设置屏蔽选项，在“Filter”工具栏中

的的编辑框中设置屏蔽条件后，工作区将只显示满足用户设置的图元对象，该功能为用户查

看 PCB板的布线情况提供了极大的帮助，尤其是在布线较密的情况下，使用“Filter”工具

栏能让用户更加清楚地检查某一特定的电器通路的连接情况。 
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图 7.15  “Filter”工具栏 

3.工作区 

工作区用于显示和编辑 PCB图文档，每个打开的文档都会在设计窗口顶部有自己的标

签，右击标签可以关闭、修改或平铺打开的窗口。 

4.工作面板 

PCB编辑器中的工作面板与 DXP Schematic Editor中的工作面板类似，单击工作面板标

签可以打开其相应的工作面板。 

7.3  添加 PCB文档 

当完成原理图的设计和编译后，接下来开始 PCB设计时，需要在项目中添加一个新的

PCB文档，为方便对新的 PCB文件进行设置，Altium Designer位用户提供了 PCB向导，使

用该向导，在新建 PCB文档的过程中即可完成 PCB板的各种参数的定义。本节将通过一个

使用 PCB创建向导完成 PCB空白文档创建的实例，介绍使用 PCB创建向导的具体步骤。

创建的空白 PCB板卡的外形尺寸如图 7.16所示。 

 

图 7.16  创建的空白 PCB板卡 

（1）启动 Altium Designer，单击工作区左侧的“Files”工作面板标签，打开如图 7.17

所示的“Files”工作面板。 
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图 7.17  “Files”工作面板 

（2）在“Files”工作面板中的“New from template”区域内选择“PCB Board Wizard”

命令，打开如图 7.18所示的“PCB Board Wizard”对话框，显示“Altium Designer New Board 

Wizard”页面。 

 

图 7.18  “Altium Designer New Board Wizard”页面 

（3）单击“PCB Board Wizard”对话框中的“Next”按钮，显示如图 7.19所示的“Choose 

Board Units”页面。 
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图 7.19  “Choose Board Units”页面 

“Choose Board Units”页面用于度量单位选择，系统默认的选项为“Imperial”，即使

用英制单位“mil”（1000mil=25.4mm）作为度量单位。为符合电路板外形尺寸的设计习惯，

本例中使用公制单位。 

（4）选择“Metric”单选项，将度量单位设置为公制，使用“mm”作为坐标单位，单

击“Next”按钮，显示如图 7.20所示的“Choose Board Profiles”页面。 

 

图 7.20  “Choose Board Profiles”页面 

“Choose Board Profiles”页面用于选择 PCB板的预定义轮廓，该页面左侧是预定义 PCB

板外形列表，右侧是预定义 PCB板外观显示区域，用于预览选择的预定义 PCB板的外观图

样。本例中要使用自定义的 PCB板外形轮廓。 

（5）在“Choose Board Profiles”页面左侧的预定义 PCB板外形列表中选择“[Custom]”

项，使用自定义的 PCB板的外形轮廓，然后单击“Next”按钮，显示如图 7.21所示的“Choose 

Board Details”页面。 
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图 7.21  “Choose Board Details”页面 

“Choose Board Details”页面内的选项用于设置自定义电路板的细节参数，这些选项的

功能介绍如下。 

“Outline Shape”选择区域用于设置自定义电路板的外部轮廓形状，包含三个单选项，

意义如下。 

“Rectangular”项表示矩形的电路板。选中该项后，在“Board Size”区域内设置矩形

的宽和高的尺寸。 

“Circular”项表示圆形的电路板。选中该项后，在“Board Size”区域内显示“Radius”

编辑框，用于设置圆形的半径尺寸。 

“Custom”项表示自定义电路板外部轮廓。选中该项后，在“Board Size”区域内设置

自定义的电路外部轮廓的宽和高的尺寸。 

对话框右侧的“Dimension Layer”下拉列表框用于设置显示尺寸标注的图层。 

“Boundary Track Width”编辑框用于设置边界线的宽度。 

“Dimension Line Width”编辑框用于设置尺寸标注线的宽度。 

“Keep Out Distance From Board Edge”编辑框用于设置电路板边界空白区域的宽度。 

“Title Block and Scale”复选框用于在图纸上显示标题栏和刻度栏。 

“Corner Cutoff”复选项用于切除 PCB板的边角，该选项只有在“Outline Shape”区域

内的“Rectangular”项被选中后才会被激活，选中该项后，在后续的步骤中将会要求设置切

除边角的尺寸。 

“Legend String”复选框用于在图纸上显示图例文字。 

“Inner Cutoff”复选项用于设置切除板内的区域，该选项只有在“Outline Shape”区域

内的“Rectangular”项被选中后才会被激活，选中该项后，接下来将会要求设置切除板内区

域的尺寸。 

“Dimension Line”复选框用于在图纸上显示标注线。 

（6）在“Choose Board Details”页面中选择“Rectangular”项，然后在“Board Size”

区域内设置“Width”为 120mm，“Heigh”为“80”mm，设置“Keep Out Distance From Board 

Edge”为 2mm，选中“Corner Cutoff”复选项和“Inner Cutoff”复选项，其它选项按照系统

默认设置，单击“Next”按钮，显示如图 7.22所示的“Choose Board Corner Cuts”页面。 
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图 7.22  “Choose Board Corner Cuts”页面 

“Choose Board Corner Cuts”页面用于设置切除边角的尺寸，通过单击页面内图样上的

蓝色标注尺寸的数字，即可激活参数编辑框，在编辑框内输入新的参数，就可以设置切角的

尺寸。 

（7）在“Choose Board Corner Cuts”页面内设置左右上角切角的尺寸值均为宽“10mm”

高“8mm”，下方两端无切角。单击“Next”按钮，显示如图 7.23所示的“Choose Board Inner 

Cuts”页面。 

 

图 7.23  “Choose Board Inner Cuts”页面 

“Choose Board Inner Cuts”页面用于设置 PCB板内的方孔的位置及尺寸，其设置方法

与“Choose Board Corner Cuts”页面类似，其中右上角参数表示方孔的宽度和高度，左下角

的参数表示方孔的左下角距离电路板左侧边框和底部边框的距离，用户只需要修改页面图例

中的尺寸标注数值即可，。 

（8）在“Choose Board Inner Cuts”页面内设置方孔宽度为 40mm，高度为 30mm，距

离左侧边框 40mm，距离底部边框 30mm，单击“Next”按钮，显示如图 7.24所示的“Choose 

Broad Layers”页面。 
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图 7.24  “Choose Broad Layers”页面 

“Choose Broad Layers”页面用于设置电路板的层数，其中“Signal Layer”数字编辑框

用于设置信号层的层数，信号层是指用于布线的图层。“Power Planes” 数字编辑框用于设

置电源层的层数，电源层是指用整片铜膜构成的接电源或接地的图层。本例中将新建一个双

面板，故有两层信号层，没有电源层。 

（9）在层数设置对话框的“Signal Layer”数字编辑框中输入“2”，在“Power Planes” 

数字编辑框中输入“0”，单击“Next”按钮，显示如图 7.25所示的“Choose Via Style”页

面。 

 

图 7.25  “Choose Via Style”页面 

“Choose Via Style”页面用于设置 PCB板中的过孔的类型。“Thruhole Var only”单选

项表示 PCB板中所有的过孔都是穿透式过孔。“Blind and Buried Vias only”单选项表示 PCB

板中只有盲过孔和隐藏过孔。由于本例中新建的是两层板，所以使用穿透式过孔。 

（9）在过孔类型选择对话框中选择“Thruhole Var only”单选项，单击“Next”按钮，

显示如图 7.26所示的“Choose Coponent and Routing Technologies”页面。 
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图 7.26  “Choose Coponent and Routing Technologies”页面 

“Choose Coponent and Routing Technologies”页面用于设置 PCB板中的元件封装性质

和布局、走线方式。 

“Surface-mount components”单选项表示 PCB板上大部分元件采用表面粘着式封装形

式，选择该项后，系统会询问是否在电路板的两面都布置电子元件。“Yes”单选项表示 PCB

板的两面都布置表面粘着式封装的电子元件，“No”单选项表示 PCB板仅有一面布置表面

粘着式封装的电子元件。 

“Through-hole components”单选项表示 PCB 板上大部分元件采用穿孔安装式封装形

式，选择该项后，“Choose Coponent and Routing Technologies”页面变为如图 7.27所示，

“Numbers of tracks between adjacent pads”选项要求用户设置相邻元件引脚焊盘间允许通过

的铜膜导线数量，“One Track”单选项表示相邻元件引脚焊盘间仅能通过一条铜膜导线，

“Two Track”单选项表示能通过两条铜膜导线，“Three Track”单选项表示能通过三条铜

膜导线。 

 

图 7.27  “Choose Coponent and Routing Technologies”页面 

本例中设置穿孔安装式元件，由于 PCB板空间较大，故设置相邻焊盘之间仅通过一根

导线。 

（10）在“Choose Coponent and Routing Technologies”页面中选择“Through-hole 
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components”单选项和“One Track”单选项，单击“Next”按钮，显示如图 7.28所示的“Choose 

Default Track and Via sizes”页面。 

 

图 7.28  “Choose Default Track and Via sizes”页面 

“Choose Default Track and Via sizes”页面用于设置默认的的铜膜导线极限尺寸、过孔

极限尺寸和默认的导线极限间距。“Minimum Track Size”表示最小的铜膜导线宽度。

“Minimum Via Width”表示过孔的最小外径。“Minimum Via Holesize”表示过孔中的通孔

的最小直径。“Minimum Clearance”用于设置两条铜膜导线之间的最小距离。 

（11）接受“Choose Default Track and Via sizes”页面中的默认设置，单击“Next”按

钮，打开如图 7.29所示的 PCB向导结束对话框。 

 

图 7.29  PCB向导结束对话框 

（12）单击 PCB 向导结束对话框中的“Finish”按钮，新建如图 7.30所示，默认名为

“PCB1.PcbDoc”的 PCB文件。 
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图 7.30  新建的 PCB文件 

（13）在主菜单中选择“File”->“Save”命令或者单击工具栏的保存按钮 ，在弹出

的“Save [PCB1.PcbDoc] As”对话框中设置文件路径和名称，单击“保存”按钮，保存该文

件。 

至此，空白 PCB文件就创建完毕了。 

7.4  定制 PCB编辑环境 

Altium Designer 6为用户提供了定制 PCB编辑环境的功能，用户可根据使用习惯，定制

PCB编辑的界面，以方便操作，本节将介绍有关 PCB编辑器环境的设置选项。 

7.4.1  PCB工作环境设置 

Altium Designer为用户进行 PCB编辑提供了大量的辅助功能，以方便用户的操作，同

时系统允许用户对这些功能进行设置，使其更符合自己的操作习惯，本小节将介绍这些设置

的方法。 

（1）启动 Altium Designer，在工作区打开新建的 PCB文件，启动 PCB设计界面。 

（2）在主菜单中选择“Tools”->“Preferences”命令，打开如图 7.31所示的“Preferences”

对话框。 
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图 7.31  “Preferences”对话框 

在“Preferences”对话框左侧的树形列表内，PCB Editor文件夹内有 12个子选项卡，通

过这些选项卡，用户可以对 PCB设计模块进行系统的设置，这些选项卡内的选项功能介绍

如下。 

1、“General”页面 

“General”页面如图 7.32 所示，该页面主要用于进行 PCB 设计模块的通用设置，

“General”页面包含四个选项区域，介绍如下。 

 

图 7.32  “General”页面 

“Editing Options”选项区域用于 PCB编辑过程中的功能设置，共有 12个复选项，其

中： 

“Online DRC”复选项表示进行在线规则检查，一旦操作过程中出现违反设计规则，系
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统会显示错误警告。建议选中此项。 

“Snap to Center”复选项表示在对图元对象进行操作时，指针对齐图元对象的中心 

“Smart Component Snap”复选项表示在对图元对象进行操作时，指针会自动捕获小的

图元对象 

“Double Click Runs Inspector”复选项表示在双击图元对象时，将打开“Inspector”工

作面板，用户可在里面对 PCB图元对象的属性进行修改。 

“Remove Duplicates”复选项表示系统会自动移除重复的输出对象，选中该复选项后，

数据在准备输出时将检查输出数据，并删除重复数据。 

“Confirm Global Edit” 复选项表示在进行全局编辑时，例如从原理图更新 PCB图时，

会弹出确认对话框，要求用户确认更改。 

“Protect Locked Objects” 复选项表示保护已锁定的图元对象，避免用户对其误操作。 

“Confirm Selection MemoryClear”复选项表示在清空选择存储器时，会弹出确认对话

框，要求用户确认。 

“Click Clears Selection”复选项表示当用户单击其它图元对象时，之前选择的其他图元

对象将会自动解除选中状态。 

“Shift Click To Select”复选项表示只有当用户按住键盘“Shift”键后，再单击图元对

象才能将其选中。选中该项后，用户可单击“Primitives…”按钮，打开如图 7.32所示的“Shift 

Click To Select”对话框，在该对话框中设置需要按住“Shift”键，同时单击才能选中的对

象种类。 

“Preserve Angle When Dragging” 复选项表示当拖动图元对象时，保持该图元对象的

旋转状态。 

“Smart Track Ends”复选项表示在交互布线时，系统会智能寻找铜膜导线结束端，调

整定义连接关系的虚线，图 7.33 所示就是选中该项后，表示两个焊盘连接关系的虚线在布

线的过程中自动调整。 

 

图 7.33  自动寻找导线末端 

“Auto pan Option”区域用于设置工作区的自动摇景功能，该区域中的“Style”下拉列

表用于设置自动摇景功能的模式，PCB编辑器共提供了 6种自动摇景模式，其中： 

“Disable”项表示禁止自动摇景功能，用户只有使用工作区的滚动条或鼠标滚轮才能调

整当前视图的位置。 

“Re-Center”项表示在光标接近工作区边界时，调整工作区显示的图纸位置，使光标

所在的点位于新的工作区视图的正中间。 

“Fixed Size Jump”项表示当光标超出工作区边界时，工作区显示的视图会连续移动，

且移动的速度与图纸的缩放比例成正比，即工作区视图的放大比例越大，视图移动速度越慢。 

“Shift Accelerate”项表示在光标超出工作区边界时，工作区显示的视图会按照设置的

步长移动，按住“Shift”键后，视图移动的速度增加。 

“Shift Decelerate” 项表示在光标超出工作区边界时，工作区显示的视图会按照设置的

步长移动，按住“Shift”键后，视图移动的速度减小。 

“Ballistic”项表示当光标超出工作区边界时，工作区显示的视图会连续移动，且移动

的速度正比于光标移出工作区的距离。 
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“Adaptive”项表示当光标超出工作区边界时，工作区显示的视图会按照设置的速度连

续移动。 

“Speed”编辑框用于设置当使用“Adaptive”模式时，视图的移动速度，默认值为 1200，

单位可选择为“mil/s”或者“pixel/s”。 

“PolygonRepour”区域用于设置多边形敷铜区域被修改后，重新敷铜时的各种参数，

该区域中的“Repour”下拉列表用于选择多边形敷铜区域被修改后，重新敷铜的方式。该列

表中共有三种选项，其中： 

“Never”选项表示不启动自动重新敷铜。 

“Threshold”选项表示当超过某限定值自动重新敷铜。 

“Always”选项表示只要多边形发生变化，就自动重新敷铜。 

“Threshold”编辑框用于设定重新敷铜的极限值。 

“Other”区域用于设置其他选项，该区域中的选项及其功能如下。 

“Undo/Redo”编辑框用于设置操作记录堆栈的大小，指定最多取消多少次以前的操作。

在此编辑框中输入“0”，会清空堆栈，输入数值越大，则可恢复的操作数越大，但占用系

统内存也越大，用户可自行配制合适的数据。 

“RotationStep”编辑框用于输入当能旋转的图元对象悬浮于光标上时，每次单击空格

键使图元对象逆时针旋转的角度。默认旋转角度为 90°。同时按下 Shift键和空格键则顺时

针旋转。 

“Cursor Type”下拉列表用于设置在进行图元对象编辑时光标的类型。Altium Designer

提供三种光标类型，“Small 90”表示小“十”字形，“Large90”表示大“十”字形，“Small 

45”表示“×”形。 

“Comp Drag”下拉列表用于设置对元件的拖动。若选择“None”，在拖动元件时只移

动元件，若选择“Connected Tracks”，在拖动元件时，元件上的连接线会一起移动。 

2、“Display”页面 

“Display”页面如图 7.34所示，该选项卡用于设置所有有关工作区显示的方式，具体

功能介绍如下。 

 
图 7.34  “Display”页面 
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“Display Options”区域中各复选项的具体功能如下。 

“Convert Special Strings”复选项表示转换图纸中预定义的字符串为其定义的内容。选

中该复选项后，图纸中系统预定义的特殊字符串，如 LAYER-NAME 或 PRINT-DATE等，

会在屏幕上显示解释值。若未选中该复选项，只显示字符串本身。 

“Redraw Layers”复选项表示进行层操作时，重绘图层。选中该复选项后，当在层间切

换时会自动重绘所有层，当前层最后重绘。若只要求重绘当前层可使用“Alt+End”快捷键。 

“Transparent Layers”复选项表示设置图层为透明状态，选中该复选项后，当重叠一个

图元对象在另一层的图元对象上时，可透过上层图元对象看到下层图元对象。这样能容易地

识别被当前层的图元对象覆盖的图元对象。 

“Use Alpha Blending”复选项表示使用α混合的方式显示图层。 

“Show”区域用于设置图纸中的信息显示，其中的复选项功能如下。 

“Test Points”复选项表示显示测试点标号。 

“Origin Marker”复选项表示显示原点标记。 

“Status Info”复选项表示显示状态栏信息。 

“Highlight Options”选项区域用于进行工作区高亮显示图元对象时的设置，其中的选

项介绍如下。 

“Highlight ln Full” 复选项表示选中的对象会全部高亮显示。若未选中该复选项，所

选择器件仅轮廓高亮显示。 

“Use Net Color For Highligh”复选项。选中该复选项后，使用网络色彩高亮显示被选

中的网络，该复选项与“Highlight ln Full” 复选项一起使用可得到更好的效果。 

“Use Transparent Mode When Masking”复选项表示图元对象在被蒙板遮住时，使用透

明模式。 

“Show All Primitives In Highlighted Nets”复选项表示显示高亮状态下的网络的所有的

图元对象内容。 

“ApplyMask During Interactive Editing”复选项表示在进行交互编辑操作时，使用蒙板

标记。 

“Apply Highlight During Interactive Editing”复选项表示在进行交互编辑操作时，使用

高亮标记。 

“Draft Thresholds”选项区域用于设置线及字符串显示模式转换阈值。 

“Tracks”编辑框用于设置草图模式下，工作区显示线条的模式转换宽度值，宽度低于

此设置值的线条将用单个线条显示，所有大于此宽度的线条会以轮廓线的方式显示。 

“Strings”编辑框用于文字显示模式的转换阀值，在当前视图下，所有小于此象素点的

文本将以一个轮廓框的形式表示，只有大于此阈值的文本以字符的方式显示。 

“Plane Drawing” 区域用于设置电源层的分割区域显示方式，其中的“Plane Drawing”

下拉列表共有三个选项，其意义如下。 

“Solid Net Colored”项表示以网络色实心显示电源层的分割区域。 

“Outlined Net Colored” 项表示仅以网络色显示电源层的分割区域轮廓。 

“Outlined Layer Colored”项表示仅以板层色显示电源层分割区域轮廓。 

“Layer Drawing Order”按钮用于设制层重绘的顺序，单击“Layer Drawing Order”按

钮打开如图 7.35所示的“Layer Drawing Order”对话框。在对话框列表中的层的顺序就是将

重绘的层的顺序，列表顶部的层就是屏幕上显示的最上部的层。 
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图 7.35  “Layer Drawing Order”对话框 

3、“Board Insignt Display”页面 

“Board Insignt Display”页面如图 7.36所示，该页面用于设置工作区的显示选项，具体

介绍如下。 

 
图 7.36  “Board Insignt Display”页面 

“Pad and Via Display Options”选项区域用于设置焊盘和过孔的显示选项，其中各选项

的意义如下。 

“Pad Nets”复选线表示在焊盘上显示其所在的网络名称。 

“Pad Numbers”复选项表示在焊盘上显示其对应的器件引脚编号。 

“Via Nets”复选项表示在过孔上显示其所在的网络名称。 

“Use Smart Display Color”复选项表示使用智能色彩显示文字，选中该项后，“Font 

Color”色彩选择块将处于不可用状态，系统会自动选择文字色彩。 

“Font Color”色彩选择块仅当“Use Smart Display Color”复选项未被选中时可用，单

击该色块将打开“Choose Color”对话框，用户可以选择任意颜色作为焊盘和过孔中标注文

字的色彩。 

“Transparent Background”复选项表示使用透明的文字背景色，选中该项后，

“Background Color”色彩选择块将处于不可用状态。 

“Background Color”色彩选择块仅当“Transparent Background”复选项未被选中时可

用，单击该色块将打开“Choose Color”对话框，用户可以选择任意颜色作为焊盘和过孔中
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标注文字的背景色彩。 

“Min/Max Font Size”编辑框用于输入焊盘和过孔中标注文字的最小和最大尺寸数值，

系统会根据实际图元对象的大小，在设置的范围内选择合适大小的字体。 

“Font Name”下拉列表用于选择焊盘和过孔中标注文字的字体名称。 

“Font Style”下拉列表用于选择焊盘和过孔中标注文字的样式，其中有“Bold”加粗、

“Bold Italic”加粗斜体、“Italic”斜体和“Regular”正常四种样式供选择。 

“Minimum Object Size”编辑框用于设置显示文字对象的阀值，如果在当前显示比例下，

文字对象小于设置的像素数值，将不再显示。 

“Net Name on Tracks”区域用于设置在铜膜导线上标注其所在的网络名称的方式，其

中的“Display”下拉列表有三个选项“Do not Display”项表示不在铜膜导线上显示网络名

称，“Single and Centered”项表示只在铜膜导线中间部分上只显示一个网络名称标记，

“Repeated”项表示按照一定间隔，重复的在导线上显示网络名称标记。 

“Single Layer Mode Options”选项区域用于设置单层模式选项，其中“Current”下拉

列表用于设置当前使用何种单层模式，在下拉列表下方有三种单层模式复选项供选择，其中

“Hide Other Layer”表示隐藏其他的层，“Gray Other Layer”表示用灰色显示其他层，

“monochrome Other Layer”表示用单色显示其他的层。这三个复选项中被选中的模式将被

置入“Current”下拉列表中，供用户选择。 

4、“Board Insignt Modes”页面 

“Board Insignt Modes”页面如图 7.37所示，该页面用于自定义工作区的浮动状态框显

示选项。所谓浮动状态框是 Altium Designer的 PCB编辑器新增的一项功能，改半透明的状

态框悬浮于工作区上方，如图 7.38所示。 

 

图 7.37  “Board Insignt Modes”页面 
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图 7.38  浮动状态栏 

通过该浮动状态框，用户可以方便地从浮动状态框中获取当前鼠标指针的位置坐标、相

对移动坐标等等操作信息。为了避免浮动状态栏影响用户的正常操作，Altium Designer给浮

动状态框设置了两个模式，一个是“Hover”模式，当鼠标指针处于移动状态时，浮动状态

框处于该模式，此时，为避免影响鼠标移动，此时显示较少的信息，而另一个模式是“Head 

Up”模式，当鼠标指针处于静止状态时，浮动状态栏处于“Head Up”模式，此时可以显示

较多信息。为了充分发挥浮动状态框的作用，用户可在“Board Insignt Modes”页面内对其

进行设置，满足自己的操作习惯，“Board Insignt Modes”页面内的各选项功能介绍如下。 

 “Display”选项区域用于设置浮动状态框的显示属性，其中包含七个选项，介绍如下。 

“Display Heads up Information”复选项表示显示浮动状态框，选中该项后，浮动状态

框将被显示在工作区中。在工作过程中用户也可以通过快捷键“Shift+H”来切换浮动状态

框的显示状态。 

“Use Background Color”色彩选择块用于设置浮动状态框的背景色，单击该色块将打

开“Choose Color”对话框，用户可以选择任意颜色作为浮动状态框的背景色彩。 

“Insert Key Resets Heads Up Delta Origin”复选项表示使用键盘的“Ins”键，设置移动

状态栏中显示的鼠标相对位置坐标零点。 

“Mouse Click Resets Heads Up Delta Origin” 复选项表示使用鼠标左键，设置移动状态

栏中显示的鼠标相对位置坐标零点。 

“Hover Mode Dely”编辑框用于设置浮动状态框从“Hover”模式到“Heads Up”模式

转换的时间延迟，即当鼠标指针静止的时间大于该延迟时，浮动状态框从“Hover”模式转

换到“Heads Up”模式。用户可以在编辑框中直接输入设置的时间，或者拖动右侧的滑块设

置延迟时间，时间的单位为毫秒。 

“Heads up Transparency”编辑框用于设置浮动状态框处于“Heads Up”模式下的透明

度，透明度数值越大，浮动状态框越透明，用户可以在编辑框中直接输入数值，或者拖动右

侧的滑块设置透明度数值，在调整的过程中，用户可通过页面右下方的“Heads Up Preview”

图例预览透明度显示效果。 

“Hover Transparency” 编辑框用于设置浮动状态框处于“Hover”模式下的透明度，

透明度数值越大，浮动状态框越透明，用户可以在编辑框中直接输入数值，或者拖动右侧的

滑块设置透明度数值，在调整的过程中，用户可通过页面左下方的“Hover Preview”图例预

览透明度显示效果。 

浮动状态栏显示内容列表用于设置相关操作信息在浮动状态栏中的显示属性，该列表分

两大栏，一栏是“Visible Display Modes”用于选择浮动状态框在各种模式下显示的操作信

息内容，用户只需勾选对应内容项即可，显示效果可参考下方的预览。另一栏是“Font”用
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于设置对应内容显示式的字体样式信息。Altium Designer共提供了 10种信息供用户选择在

浮动状态框中显示，分别介绍如下。 

“Cusor Location”表示当前鼠标指针的绝对坐标信息。 

“Last Click Delta”表示当前鼠标指针相对上一次单击点的相对坐标信息。 

“Current Layer”表示当前所在的 PCB图层名称。 

“Snap Grid”表示当前的对齐网格参数信息。 

“Summary”表示当前鼠标指针所在位置的图元对象信息。 

“Heads Up Shortcuts”表示鼠标静止时与浮动状态框操作的快捷键及其功能 

“Violation Details”表示鼠标指针所在位置的 PCB图中违反规则的错误的详细信息。 

“Net Details”表示鼠标指针所在位置的 PCB图中网络的详细信息。 

“Component Details” 表示鼠标指针所在位置的 PCB图中元件的详细信息。 

“Primitive Details” 表示鼠标指针所在位置的 PCB图中基本图元对象的详细信息。 

“Hover Preview”和“Heads Up Preview”视图便于用户对设置的浮动状态栏的两种模

式显示效果进行预览。 

5、“Board Insignt Lens”页面 

为了方便用户对 PCB板中较复杂的区域细节进行观察，Altium Designer在 PCB编辑器

中新增了放大镜功能，放大镜显示效果如图 7.39 所示，通过放大镜，用户能对鼠标指针所

在位置的电路板中的细节进行观察，同时又能了解电路板的整体布局情况。 

 

图 7.39  放大镜显示效果 

为了让放大镜更适合用户操作习惯，Altium Designer允许用户对放大镜的显示属性进行

自定义，“Board Insignt Lens”页面就是专用设置放大镜显示属性的页面，如图 7.40所示，

其中的选项功能介绍如下。 
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图 7.40  “Board Insignt Lens”页面 

“Configuration”选项区域用于设置放大镜视图的大小和形状，其中： 

“X Size”编辑框用于设置放大镜视图的 X 轴向尺寸，即宽度，单位是像素点，用户可

以在编辑框中直接输入设置的数值，或者拖动右侧的滑块设置尺寸数值。 

“Y Size”编辑框用于设置放大镜视图的 Y 轴向尺寸，即高度，单位是像素点，用户可

以在编辑框中直接输入设置的数值，或者拖动右侧的滑块设置尺寸数值。 

“Rectangular”单选项表示使用矩形的放大镜。 

“Eliptical”单选项表示使用椭圆型的放大镜。 

“Behaviour”选项区域用于设置放大镜的动作，其中有三个选项。 

“Zoom Main Window to Lens When Routing”复选项表示在进行布线时，使用放大镜缩

放主窗口。 

“Animate Zoom”复选项表示使用动画形式缩放。 

“On Mouse Cursor”复选项表示放大镜总是位于鼠标指针的位置。 

“Content”选项区域用于设置放大镜视图中的显示内容。其中有两个选项。 

“Zoom”编辑框用于设置放大镜的放大比例，用户可以在编辑框中直接输入放大比例

数值，或者拖动右侧的滑块设置放大比例数值。 

“Single Layer Mode”下拉列表用于设置在放大镜视图中使用单层模式，其中有三个选

项，“Not In Single Layer Mode”项表示不使用单层显示模式，显示所有 PCB图层。“Hide 

Other Layers”项表示隐藏其他 PCB图层。“Monochrome Other Layers”项表示使用单色显

示其他的图层。 

“Hot Keys”列表用于设置与放大镜视图有关的快捷键，列表左侧是动作行为描述，右

侧是设置的快捷键，系统默认的设置如下。 

快捷键“F2”用于启动如图 7.41所示的“Board Insight”菜单，设置浮动状态框和放大

镜视图。 

tyw藏书



第 7 章  PCB设计基础 

 

 ·236·   

 

图 7.41  “Board Insight”菜单 

快捷键“Shift+M”用于切换放大镜视图的显示和隐藏状态。 

快捷键“Shift+N”用于将绑定放大镜视图到鼠标指针上。 

快捷键“Ctrl+Shift+S”用于在放大镜视图内切换单层模式。 

快捷键“Ctrl+Shift+N”用于将放大镜视图设置到鼠标指针位置，并随鼠标指针移动。 

6、“Interactive Routing”页面 

“Interactive Routing”页面如图 7.42所示，该页面用于定义交互布线的属性，其中选项

的功能和意义如下。 

 

图 7.42  “Interactive Routing”页面 

“Interactive Routing Conflict Resolution”区域用于设置交互布线过程中出现布线冲突时

的解决方式，共有三个单选项供选择。 

“None”表示不进行任何操作。 

“Stop at First Conflicting Object”表示布线到第一个冲突对象为止。 

“Push Conflicting Objects”表示移动发生冲突的对象，解决布线冲突。 

“Smart Connection Routing Conflict Resolution” 区域用于设置当进行智能连接布线过

程中出现布线冲突时的解决方式，共有三个单选项和一个复选项供选择。 

“None”表示不进行任何操作。 

“Stop at First Conflicting Object”表示布线到第一个冲突对象为止。 
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“Walking around Conflicting Object”表示绕开冲突对象。 

“Plow Through Polygon”复选项表示穿越多边形填充区域，若未选中，则在布线时不

会割开多边形填充区域。 

“Interactive Routing Options”选项区域用于设置交互布线属性，其中有四个选项。 

“Restrict To 90/45”复选项表示设置布线角度为 90/45度。 

“Auto Complete” 复选项表示自动完成布线。 

“Automatically Terminate Routing”复选项表示自动判断布线终止时机。 

“Automatically Remove Loops”复选项表示自动移除布线过程中出现的导通环。 

“Smart Connection Pad Exits”选项区域用于设置智能连接时的焊盘引出线属性，其中

的“Allow Diagonal”复选项表示允许倾斜的焊盘引出线。 

“Interactive Routing Width/Via Size Sources”选项区域用于设置在交互布线中的铜膜导

线宽度和过孔尺寸的选择属性。 

“Pickup Track Width From Existing Routes”复选项表示从已布置的铜膜导线中选择铜

膜导线的宽度。 

“Track Width Mode”下拉列表用于设置交互布线时铜膜导线宽度，共有 

“Via Size Mode” 下拉列表用于设置交互布线时，过孔的尺寸 

“Favorite Interactive Routing Widths” 

7、“Show/Hide”页面 

“Show/Hide”页面如图 7.43所示，该选项卡用于设定各类图元对象显示模式。 

 

图 7.43  “Show/Hide”选项卡 

“Show/Hide”选项卡中可设置的对象有：“Arcs”（圆弧）、“Fills”（填充）、“Pads”

（焊盘）、“Polygons”（多边形）、“Dimensions”（尺寸标注）、“Strings”（字符串）、

“Tracks”（铜膜导线）、“Vias”（过孔）、“Coordinates”（坐标）、“Rooms”（块）、

“Regions”（区域）和“Component Bodies”（元件）。这些对象均可以有三种显示状态供
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选择，分别如下。 

“Final”单选项表示以终稿型模式显示对象，其中每一个图素都是实心显示。 

“Draft”单选项表示以草稿型模式显示对象，其中每一个图素都是以草图轮廓形式显

示。 

“Hide”单选项表示隐含对象。 

8、“True Type Fonts”页面 

“True Type Fonts”页面如图 7.44所示，该页面主要用于设置 PCB图中的 True Type

字体。 

 

图 7.44  “True Type Fonts”页面 

“True Type Fonts Save/Load Options”区域用于设置“True Type”字体的保存和加载选

项，其中有两个选项介绍如下。 

“Embed True Type fonts inside PCB Document”复选项表示将“True Type”字体嵌入保

存到 PCB文件中，这样能保证在其他未支持“True Type”字体的系统中也能正常显示该字

体。 

“Substitution font”下拉列表用于设置替代“True Type”字体的字体，当系统不支持

“TrueType”字体时，将用该下拉列表中设置的字体代替“True Type”字体，显示 PCB中

的文字。 

9、“Mouse Wheel Configuration”页面 

“Mouse Wheel Configuration”页面如图 7.45所示，该选项卡主要设置鼠标滚轮在 PCB
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编辑器中的功能。 

 
图 7.45  “Mouse Wheel Configuration”页面 

在“Mouse Wheel Configuration”页面左侧的“Action”栏中列出了需要鼠标滚轮参与

的操作，在“Button Configuration”栏列出执行左侧的操作所需要的组合键，用户可通过勾

选对应的复选框设置组合键，以适应自己的操作习惯。系统默认的组合键如下。 

组合键“Ctrl+滚轮”用于调整当前工作区域的显示比例。 

滚动鼠标可以竖直移动工作区的显示区域。 

组合键“Shift+滚轮”用于横向移动工作区的显示区域。 

组合键“Ctrl+鼠标中键”用于显示如图 7.46所示的“Board Insight”视图窗口，显示当

前选中的 PCB网络视图。 

 

图 7.46  “Board Insight”视图窗口 

组合键“Ctrl+Shift+滚轮”用于切换显示 PCB图层。 

组合键“Alt+滚轮”用于调整放大镜视图的缩放比例。 

组合键“Alt+鼠标中键”用于自动将放大镜视图的放的比例应用于工作区。 

10、“Default”页面 

“Default”页面如图 7.46所示，PCB编辑器中各种图元对象的缺省值都是在该选项卡

中进行配置的。 
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图 7.46  “Defaults”选项卡 

在“Primitives”列表选择需要更改的项，单击“Edit Values”按钮，打开对应的属性对

话框，在此对话框中编辑参数。 

11、“PCB 3D”页面 

“PCB 3D”页面如图 7.47所示，该页面用于设置 PCB板的三维模型显示属性。 
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图 7.44  “PCB 3D”页面 

“Highlighting”选项区域用于设置三维视图中高亮显示的三维图元对象的色彩和背景

色彩，用户单击对应的色彩块即可打开“Choose Color”对话框，选择色彩。默认高亮显示

的图元对象色彩为红色，三维视图背景为淡黄色。 

“Print Quality”选项区域用于设置三维视图的打印质量，共提供了三种质量选项，

“Draft”项打印质量最差，只显示三维视图的草图轮廓，“normal”项质量较好，“Proof”

的打印质量最好。 

“PCB3D Document”选项区域用于设置 PCB3D文件的属性，共有两个选项。 

“Always Regenerate PCB3D”复选项表示一直重建 PCB的三维模型。 

“Always Use Component Bodies”复选项表示一直显示元件形体。 

“Default PCB3D Library”选项区域用于设置 PCB3D库的选项，单击“Browse”按钮

打开“打开”对话框，选择 PCB3D库文件作为系统默认的 PCB三维元件库。 

12、“Reports”页面 

“Reports”页面如图 7.46所示，该页面用于设置 PCB输出文件类型，用户在该选项卡

中设置需要输出的文件类型，以及输出路径和文件名称。这样在完成 PCB设计后，系统会

自动显示和生成已设置好的输出文件。 

 

图 7.46  “Reports”页面 

7.4.2  网格及图纸设置 

为了方便定义图元对象的位置，PCB编辑器提供了 “Snap Grid”、“Component Grid”、

“Electrical Grid”和“Visible Grid” 4种网格，其中： 

捕捉网格“Snap Grid”定义了工作区中限制光标移动位置的一组点阵，移动鼠标时，光

标只在捕捉网格的格点之间跳动。 

元件网格“Component Grid”用于控制元件的布置位置，当移动或放置元件时，光标只

能在元件网格的各点上移动，为元件的整齐布局带来了方便。 

捕捉网格和元件网格都可以按照需要分别设置 x 轴和 Y 轴的捕捉格，使器件在不同的

方向按照不同的步长移动。恰当地设置网格很重要，一般可以将其设置为管脚距离的可整除

倍。例如，在布放一个管脚距离为 100 mil的器件时，可以将移动网格设置为50mil或者 25mil。

又如，当在元件的管脚上连线时，可以选择捕捉网格为 25 mil。设置合适的捕捉网格有助于

顺序地放置器件和提供最大的布线通道。 

电气网格“Electrical Grid”是为了方便电气对象的连接而定义的，该网格代表的是电气
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对象的连接点周围的一个空间范围，移动到该范围内的其他电气对象将直接连接到该连接

点。我们在工作区内移动一个电气对象时，如果落在另外一个电气对象的电气网格范围内，

移动的图元将跳动到一个已放置图素的电气连接点上。 

可视网格“Visible Grid”用于在工作区为用户提供视图参考，系统提供了点状“Dot”

和线状“Lines”两种类型的可视参考网格作为布放和移动的视图参考。在一张视图上可以

布置两个不同的可视网格，用户可以根据工作任务的需要独立地设置这些网格的大小，甚至

可以设置英制和公制分开的可视网格。 

可视网格是显示工作区背景上位置线的系统。这种显示受到当前电子设计图像放大水平

的限制，如果看不到可视网格，则说明视图的缩放比例过大或过小。 

PCB编辑器中绘制的 PCB板图被放置在一张图纸上，当新建了 PCB文档时，系统会自

动建立一个 10000mil×8000mil的图纸。 

以上这些网格及图纸的设置方法如下。 

（1）在主菜单中选择“Design”->“Broad Option”命令，打开如图 7.30所示的“Broad 

Options”对话框。 

 

图 7.30  “Broad Options”对话框 

“Broad Options”对话框中包含多个选项区域，各选项的功能如下。 

“Measurement Unit”区域用于设置计量的单位，其中的“Unit”下拉列表有两个选项，

“Metric”表示公制单位，“Imperial”表示英制单位。 

“Snap Grid”区域用于设置捕捉网格的尺寸，其中的“X”和“Y”的参数可以不相同。 

“Component Grid” 区域用于设置元件网格的尺寸，其中的“X”和“Y”的参数可以

不相同。 

“Electrical Grid”区域用于设置电气网格的尺寸。 

“Electrical Grid”复选项用于设置是否使用电气网格。 

“Range”编辑框用于输入电气网格的大小。 

“Snap to Board Outline”复选项用于设置是否捕获 PCB板的边框。 

“Visible Grid”区域用于设置可视网格的类型和大小。 

“Makers”下拉列表用于选择可视网格的显示方式。 

“Grid1”和“Grid2”编辑框分别用来设置显示的两个可视网格的大小。 

“Sheet Position”区域用于设置绘制 PCB板的图纸页面大小和位置。 

“X”、“Y”编辑框用于设置页面的左下角定点的绝对坐标。 

“Width”和“Heigh”编辑框分别用来设置图纸页面的宽和高。 

“Display Sheel”复选项用来设置显示页面。 
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“Lock Sheet Primitive”复选项表示锁定原始页面 

“Designator Display”区域用于设置元件编号的显示。 

（2）在“Broad Options”对话框中设置各种网格参数，单击“OK”按钮。 

7.5  PCB板设置 

7.5.1  PCB板层设置 

PCB板层在“Layer Stack Manager”对话框中设置，设置板层的步骤如下。 

（1）在主菜单中选择“Design”->“Layer Stack Manager…”命令，或者在工作区单击

鼠标右键，在弹出的菜单中选择“Options” ->“Layer Stack Manager…”命令，如图 7.31

所示，打开如图 7.32所示的“Layer Stack Manager”对话框。 

 

图 7.31  选择“Options” ->“Layer Stack Manager…”命令 

 

图 7.32  “Layer Stack Manager”对话框 

（2）在如图 7.32所示的“Layer Stack Manager”对话框中选择“Core（0.32mm）”，

单击“Properties”按钮，或直接双击“Core（0.32mm）”，打开如图 7.33所示的“Dielectric 

Properties”对话框。 
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图 7.33  “Dielectric Properties”对话框 

如图 7.33所示的“Dielectric Properties”对话框用于设置 PCB板中的绝缘层的参数，其

选项的具体功能如下。 

“Material”编辑框用于设置绝缘层的材料 

“Thickness”用于设置绝缘层的厚度 

“Dielectric constant”编辑框用于设置绝缘层的介电常数。 

（3）在“Dielectric Properties”对话框中的“Thickness”编辑框中输入“2mm”，单击

“OK”按钮，设置绝缘层厚度为“2mm”。  

（4）勾选“Top Dielectic”复选项和“Bottom Dielectic”复选项，在 PCB板的顶层和

底层添加阻焊层，如图 7.34所示。 

 

图 7.34  添加的阻焊层 

“Layer Stack Manager”对话框中的按钮功能如下： 

“Add Layer”按钮用于在 PCB板中添加信号层。 

“Add Plane”按钮用于在 PCB板中添加电源平面。 

“Delete”按钮用于删除所选中的层。 

“Move Up”按钮用于上移所选中的层。 

“Move Down”按钮用于下移所选中的层。 

7.5.2  PCB板层颜色设置 

为了区别各 PCB板层，Altium Designer 6使用不同的颜色绘制不同的 PCB层，用户可

根据喜好调整各层对象的显示颜色，具体步骤如下。 

（1）在主菜单中选择“Design”->“Board Layers and Colors…”命令，或者在工作区

单击鼠标右键，在弹出的菜单中选择“Options” ->“Board Layers and Colors…”命令，打

开如图 7.35所示的“Board Layers and Colors”对话框。 
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图 7.35  “Board Layers and Colors”对话框 

“Board Layers and Colors”对话框中共有七个列表设置工作区中显示的层及其颜色。在

每个区域中有一个“Show”复选框，勾选该复选框后，工作区下方将显示该层的标签。 

单击对应的层名称“Color”列下的色彩条，打开“Choose Color”对话框，在该对话框

中设置所选择的电路板层的颜色。 

在“SystemColors”区域中可设置包括可见栅格（VisibleGrid）、焊盘孔（Pad Holes）、

过孔（Via Holes）和 PCB工作区等系统对象项的颜色及其显示属性。 

（2）当设置完毕后单击“OK”按钮，完成 PCB板层的设置。 

7.5.3  PCB编辑器工作区设置 

PCB编辑器的工作区选项在“Preferences”对话框中设置，“Preferences”对话框可使

用以下方式打开。 

（1）在主菜单中选择“Tools”->“Preferences…”命令，或者在工作区单击鼠标右键，

在弹出的菜单中选择“Options”->“Preferences…”命令，或使用快捷键“Ctrl”+“0”，

打开如图 7.36所示的“Preferences”对话框。 

 

图 7.36  “Preferences”对话框 
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三、“Show/Hide”选项卡 

“Show/Hide”选项卡如图 7.37所示，该选项卡用于设定各类图元对象显示模式。 

 

图 7.37  “Show/Hide”选项卡 

“Final”单选项表示以终稿型模式显示对象，其中每一个图素都是实心显示。 

“Draft”单选项表示以草稿型模式显示对象，其中每一个图素都是以草图轮廓形式显

示。 

“Hide”单选项表示隐含不显示对象。 

“Show/Hide”选项卡中可设置的对象有：“Arcs”（圆弧）、“Fills”（填充）、“Pads”

（焊盘）、“Polygons”（多边形）、“Dimensions”（尺寸标注）、“Strings”（字符串）、

“Tracks”（线）、“Vias”（过孔）、“Coordinates”（标尺）、“Rooms”（区域）、

“From Tos”（连接）等。 

 四、“Defaults”选项卡 

 “Defaults”选项卡如图 7.38所示，PCB编辑器中每个图元对象的缺省值都是在该选

项卡中进行配置的。 

 

图 7.38  “Defaults”选项卡 

在“Primitives”列表选择需要更改的项，单击“Edit Values”按钮，打开对应的属性对

话框，在此对话框中编辑参数。 

 “Reset”按钮用于恢复系统默认值。 
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“Options”区域用于对选项设置文件进行操作。 

“Save As”按钮用于将在选项卡中的设置保存为文件。 

“Load…”按钮用于导入设置文件。 

“Reset All”按钮用于恢复系统默认值。 

当设置完成后，单击“OK”按钮，即可应用所有的设置。 

7.6  PCB板基本图元对象布置 

PCB 板的基本图元对象有连线、线段、焊盘、过孔、填充、圆弧线、文本字符串和特

殊字符串等几种类型。本节将介绍这些基本图元对象的布置步骤。 

7.6.1  布置连线 

连线（Tracks）是 PCB最基本的线元素。连线宽度可以在 0．001mil和 10000mil之间

调节，连线可以布置在 PCB板的任意层，例如，连线放置在信号层，用作布线连接，放在

机械层中定义板轮廓，放在丝印层绘制元件轮廓，或者在禁布层定义“禁布区”等等。放置

连线的步骤如下。 

（1）在工作区选择布置连线的电路层，使用“*”键可在信号层之间切换，使用 “+”

和“-”键在所有层之间切换。 

（2）单击“Wiring”工具栏中的布置连线按钮 ，或者从菜单中选择“Place”->“Interactive 

Routing”命令。 

此时，状态栏上会显示提示信息“Choose Start location”。 

（3）移动光标至连线起点，单击鼠标或按下“Enter”键确定连线的起始位置。 

此时，状态栏显示连线的网格，括弧里显示的是当前线段的长度和连线的总长度。 

（4）在工作区移动光标，工作区显示如图 7.39所示的两个线段，一个是实线，另一个

是轮廓线。实线表示当前即将布置的线段，轮廓线是“预测”下一步放置的线段，指明走线

的方向。 

 

图 7.39  实线和轮廓线 

PCB编辑器一共提供了 5种连线模式，其中有 4种连线模式存在两种起始或结束模式，

所以共有 9 种布线模式。这些布线模式如图 7.40所示。通过“Shift”+“空格键”可以在 5

tyw藏书



第 7 章  PCB设计基础 

 

 ·248·   

种连线模式间切换，使用空格键可以在起始或结束模式间切换。   

         

         “Line 45 Start”  “Line 45 End”   “Line 45 Start–rounded corner” “Line 45 End–rounded corner” 

                  

 “Line 90 Start”    “Line 90 End”    “Line 90 Start–rounded corner” “Line 90 End–rounded corner” 

 

“Any Angle” 

图 7.40  系统提供的布线模式 

“Line 45 Start”模式指所有连线之间的夹角都为 45°的倍数，且当起点和终点不在同

一条水平线或垂直线上时，总是以 45°或 135°的斜线连接连线的起点。 

“Line 45 End”模式指所有连线之间的夹角都为 45°的倍数，且当起点和终点不在同

一条水平线或垂直线上时，总是以 45°或 135°的斜线连接连线的终点。 

“Line 45 Start–rounded corner”模式与“Line 45 Start”模式基本相同，区别在于所有直

线之间的 135°的夹角都采用圆角过渡。 

“Line 45 End–rounded corner” 模式与“Line 45 End”模式基本相同，区别在于所有直

线之间的 135°的夹角都采用圆角过渡。 

“Line 90 Start” 模式指所有连线都采用垂直线或水平线，且当起点和终点不在同一条

水平线或垂直线上时，总是以垂直线连接连线的起点。 

“Line 90 End” 模式指所有连线都采用垂直线或水平线，且当起点和终点不在同一条

水平线或垂直线上时，总是以垂直线连接连线的终点。 

“Line 90 Start–rounded corner” 模式与“Line 90 Start”模式基本相同，区别在于所有

直线之间的夹角都采用圆角过渡。 

“Line 90 End–rounded corner” 模式与“Line 90 End”模式基本相同，区别在于所有直

线之间的夹角都采用圆角过渡。 

“Any Angle”模式指所有的连线都采用直接连接的形式，允许连线线段被放置为任何

角度。 

在-rounded corner的模式下单击“.”快捷键会增大圆角半径，单击“，”快捷键会减小

圆角半径。 

（5）单击“Tab”键，打开如图 7.41所示的“Interactive Routing”对话框。 
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图 7.41  “Interactive Routing”对话框 

如图 7.46所示的“Interactive Routing”对话框由两个区域组成。 

“Properties”区域用于设置连线和过孔的属性。该区域中的“Trace Width”编辑框用于

设置连线宽度。“Via Hole Size”编辑框用来设置与该连线相连的过孔的内径。“Via Diameter”

编辑框用来设置与该连线相连的过孔的外径。“Layer”编辑框用来设置当前布线的 PCB板

层。 

“Design Rule Constraints”区域用于显示设计规则参数。 

“Menu”按钮用于打开设置设计规则参数的下拉菜单。 

（6）单击“Menu”按钮，在弹出的下拉菜单中选择“Edit Width Rule”命令，打开如

图 7.42所示的“Edit PCB Rule – Max-Min Width Rule”对话框。 

 

图 7.42  “Edit PCB Rule – Max-Min Width Rule”对话框 

（7）在“Edit PCB Rule – Max-Min Width Rule”对话框“Constraints”区域的“Max Width”

编辑框内输入“2mm”，单击“OK”按钮，将最大连线宽度设置为“2”mm。 

（8）在“Interactive Routing”对话框的“Trace Width”编辑框内输入当前布置的连线

的宽度，该值应介于最小连线宽度和最大连线宽度之间，本例中可输入的值的范围为

“0.3mm~2mm”。，然后单击“OK”按钮，结束对直线属性的更改。 

（9）移动光标到实际连线结束处，单击鼠标，或单击回车键，布置第一个线段。 

（10）移动光标开始一个新的连线线段，这个新线段将从已经放置的连线线段处开始延

伸，移动光标并按下空格键，可以改变连线放置模式。每次定义一个连线线段时单击鼠标或
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回车键确认。如果操作错误，可以单击“Backspace”键去掉最后一个连线元素。 

（11）单击鼠标右键结束此次连续线段的布置。 

（12）重复步骤（3）~（11）布置其他的连线线段。 

（13）所有的连线线段布置完毕后，单击鼠标右键或者“Esc”键，结束连线的布置。 

7.6.2  布置线段 

线段（Line）的属性除没有网络特性外，其他都与连线相同。由于即便一根从带有网络

的焊盘上引出的 Line也不带有任何电气属性，因此，线段被用来布放没有电气性能的连线，

比如定义结构尺寸、标注等机械层信息或者是禁布层信息等。 

布置线段的方法如下。 

（1）单击“Utilities”工具栏中的绘图工具按钮 ，在弹出的工具栏中选择线段工具按

钮 ，或者在主菜单中选择“Place”->“Line”命令，即可启动布置线段命令。 

（2）按照 7.6.1节中介绍的布置连线的方法，布置线段。 

（3）布置完毕后单击鼠标右键，结束线段的布置操作。 

7.6.3  布置焊盘 

插针式器件的焊盘通常是贯通整个电路板的，其焊盘在电路板的顶层和底层都有布置，

而贴片式器件的引脚焊盘中间则没有通孔，仅布置在电路板的顶层或底层。焊盘的形状可以

是圆形、矩形、圆角矩形或者八边形，过孔的尺寸可在 0mil 到 1000mil之间变化。自由焊

盘是指没有被编进元件库的焊盘，这种焊盘能被放置在设计的任何地方。焊盘既可以单独地

被指定为自由焊盘，也可以和其他的对象元素合并成元件。放置焊盘的步骤如下。 

（1）单击“Wiring”工具栏中的布置焊盘工具按钮 ，或者在主菜单中选择“Place”

->“Pad”命令，启动放置焊盘命令。 

（2）单击“Tab”键，打开如图 7.43所示的“Pad”对话框。 

 

图 7.43  “Pad”对话框 

“Pad”对话框用于设置焊盘的属性，其中选项的功能如下。 

“Hole Size”编辑框用于设置焊盘中间的通孔的直径。 

“Rotation”编辑框用于设置焊盘的旋转角度。 

“Location”栏中的“X”、“Y”编辑框用于设置焊盘的位置坐标。 
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“Properties”区域用于设置焊盘的属性。其中各项的功能如下。 

“Designator”编辑框用于设置焊盘的编号，焊盘最多能用 20个文本字符或数字字符标

识，通常用于提供元件管脚数字。编号中间不允许出现空格，但也可根据需要在左边留有空

格。如果放置的初始焊盘有数字标号的话，随后放置的焊盘其标号会每次自动增 1。 

“Layer”下拉列表框用于设置焊盘所在的 PCB板层。 

“Net”下拉列表框用于设置焊盘所在的网络。 

“Electrical Type”用于设置焊盘的电气类型，有“Load”（负荷）、“Terminate”（终

端）和“Source”（源）三个选项。 

“Testpoint”栏中有两个复选项，分别是“Top”和“Bottom”，用于在顶部或底部布

置测试点。 

“Plated”栏中的复选框用于设置焊盘是否镀锡。 

“Lock” 栏中的复选框用于锁定焊盘。 

“Size and Sharp”区域用于设置焊盘的大小和形状，其中包括三个单选项，这些单选项

的功能如下。 

“Simple”单选项表示焊盘在 PCB 板各层中的大小和形状都完全相同，用户只需要设

置一组“X-Size”、“Y-Size”和“Shape”参数即可。 

“Top-Middle-Bottom”单选项表示焊盘在 PCB板的顶层、中间各层以及底层的尺寸和

形状不同，需要用户在如图 7.49内的列表中分别设置焊盘在 PCB板顶层、中间各层、底层

的尺寸和形状。 

“Full Stack”单选项表示焊盘在 PCB板各层中的大小和形状都需要单独设置，选中该

项后，“Size and Sharp”区域底部的“Edit Full Pad Layer Definition…”按钮被激活，单击

该按钮，打开如图 7.44所示的“Pad Layer Editor”对话框。用户可在“Pad Layer Editor”对

话框中对焊盘在每一层的大小形状进行设置。 

 

图 7.44  “Pad Layer Editor”对话框 

“Paste Mask Expansion”区域用于设置表面粘贴元件焊盘上的防止粘贴区域，其中的选

项功能如下。 

“Expansion value from rules”单选项表示按照设计规则设置焊盘的防止粘贴区。 

“Specify expansion value”单选项表示按照输入的数值设置焊盘的防止粘贴区。 

“Solder Mask Expansions”区域用于设置焊盘上的阻焊区域，其中的选项功能如下。 

“Expansion value from rules”单选项表示按照设计规则设置焊盘的阻焊区。 
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“Specify expansion value”单选项表示按照输入的数值设置焊盘的阻焊区。该项被选中

后，用户可在右侧的编辑框内输入防止粘贴区的数值。 

“Force complete tenting on top”复选项，选中该复选框后，焊盘忽略设置规则中的任何

阻焊规定，在顶层不添加阻焊。 

“Force complete tenting on bottom”复选项，选中该复选框后，焊盘忽略设置规则中的

任何阻焊规定，在底层不添加阻焊。 

（3）在“Pad”对话框中设置焊盘的参数信息，单击“OK”按钮。 

（4）移动光标到工作区合适位置，单击鼠标，即可布置一个焊盘。 

（5）继续布置其他的焊盘，当所有焊盘布置完毕后，单击鼠标右键，或单击“Esc”按

钮，结束焊盘的布置。 

7.6.4  布置过孔 

当不同层之间的连线需要连接时，就需要放置一个过孔在不同层之间传递信号。过孔的

外观类似圆形的焊盘，它被钻孔，而且制板的时候通常贯穿镀层。过孔可以是多层孔、盲孔

或埋孔。多层过孔可从顶层通到底层，并且允许连接所有的内部信号层；盲孔则从表层连到

内层；埋孔从一个内层连到另一个内层。过孔的尺寸可从 0mil 到 1000mil变化，过孔盘的

直径可从 2 mil 到 10000mil之间变化。如果在手工放置连线或者自动布线时改变了布线所在

的电气层，过孔会被自动放置。 手动布置过孔的步骤如下。 

（1）在“Wiring”工具栏中选择布置过孔工具按钮 ，或者在主菜单选择“Place”->

“Via”命令，启动放置过孔命令。 

（2）单击“Tab”键，打开如图 7.50所示的“Via”对话框。 

 

图 7.50  “Via”对话框 

如图 7.50所示的“Via”对话框用来设置过孔的属性，其中“Properties”区域中的“Start 

Layer”编辑框用于设置过孔的起始 PCB板层，“End Layer”用于设置过孔的终止 PCB板

层。对话框中的其余选项与“Pad”对话框中相应的选项功能相同，读者可参考“Pad”对话

框中的选项介绍。 

（3）在“Via”对话框中设置过孔的属性项，单击“OK”按钮。 

（4）移动光标到工作区合适位置，单击鼠标，即可布置一个过孔。 

（5）继续布置其他的过孔，当所有焊盘布置完毕后，单击鼠标右键，或单击“Esc”按
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钮，结束过孔的布置。 

7.6.5  布置圆弧线 

圆弧线是圆形的连线元素，在 PCB设计中有很多用途，例如，在丝印层用来显示元件

的形状，或者在机械层中显示板的轮廓等。圆弧线能被放在任何层，半径可在 0.001 mil~16000 

mil 范围内任意设置，宽度可在 0.001 mil~10000 mil范围内任意设置。圆弧线可以单独布置，

或者作为连线的一部分在布置连线的过程中布置。布置圆弧有三种方法，其步骤分别如下。 

一、圆心方式布置圆弧 

（1）在工作区选择需要绘制圆弧的 PCB 板层，单击“Utilities”工具栏中的绘图工具

按钮 ，在弹出的工具栏中选择圆心方式圆弧工具按钮 ，或者在主菜单中选择“Place”

->“Arc（Center）”命令。 

状态栏上会显示“Start Arc Center”，提示用户设置圆弧的圆心。 

（2）移动光标到将要放置的圆弧的圆心位置，单击鼠标，确定圆弧的圆心。 

（3）移动鼠标，调整圆弧所在的圆的半径至合适大小后，单击鼠标，确定圆弧所在的

圆。 

（4）在圆弧所在的圆上移动光标，至圆弧的起点处，单击鼠标，确定圆弧起点。 

（5）在圆弧所在的圆上移动光标，至圆弧的终点处，单击鼠标，确定圆弧终点。 

这样，一个圆弧就布置完毕，布置圆弧的过程如图 7.51所示。 

  

图 7.51  圆心方式布置圆弧的过程 

（6）重复步骤（2）~（5）绘制其他圆弧，所有圆弧布置结束后，单击鼠标右键或者单

击“Esc”键，结束圆弧的布置操作。 

如果想要定义一个完整的圆，执行到步骤（4）、（5）的时候，在不移动鼠标的情况下，

连续单击鼠标即可。 

二、确定圆弧的两个端点方式布置圆弧 

确定圆弧的两个端点布置圆弧的方式只能绘制圆心角为 90°的圆弧。操作方法如下。 

（1）单击“Wiring”工具栏中的圆弧工具按钮 ，或者在主菜单中选择“Place”->“Arc

（Edge）”命令。 

（2）移动光标到圆弧的起始点，单击鼠标，确定圆弧的起点。 

（3）移动光标到圆弧的终点，单击鼠标，确定圆弧的终点，完成一个圆弧的绘制。 

（4）重复步骤（2）、（3）布置新的圆弧。当所有圆弧布置完毕后，单击鼠标右键或

者按下“Esc”键结束布置圆弧的操作。 

三、任意角度方式布置圆弧 
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以圆弧线的一端作为起始点，放置一个任意角度的圆弧线。这种布置圆弧的方法与圆心

方式布置圆弧类似，操作方法如下。 

（1）单击“Utilities”工具栏中的绘图工具按钮 ，在弹出的工具栏中选择任意角度圆

弧工具按钮 ，或者在主菜单中选择“Place”->“Arc （Any Angle）”命令。 

（2）移动光标到圆弧的起始点，单击鼠标，确定圆弧的起点。 

（3）移动光标到圆弧的圆心处，单击鼠标，确定圆弧的圆心。 

（4）移动光标到圆弧的终点处，单击鼠标，确定圆弧的终点。 

这样，一个圆弧就布置完毕，布置圆弧的过程如图 7.52所示。 

  

图 7.52  任意角度圆弧布置过程 

（5）重复操作（2）~（4）布置其他的圆弧，所有圆弧布置结束后，单击鼠标右键或者

“Esc”键，结束布置圆弧的操作。 

7.6.6  布置填充区域 

Altium designer 6 提供的填充区域功能用于在电路板的任意层布置形状为矩形的填充

块。如果在信号层布置填充区域，填充的区域就成为实心敷铜区，可以用来进行屏蔽，或者

形成传导平面，用户可以将不同大小的填充区域重叠连接，连成不规则形状的敷铜区域。当

在非电气层填充时。例如，在“Keep Out”层布置一个填充区域，可以用来指定一个自动布

线器和自动布局器都“不能进去”的禁区。在电源层、阻焊层或者阻粘层可以用来放置一个

填充区域做空白区域。布置填充区域的步骤如下： 

（1）在工作区单击需要布置填充区域的 PCB板层标签。 

（2）在主菜单中选择“Place”->“Fill”命令或者直接单击“Wiring”工具栏中的填充

工具按钮 。启动填充命令。 

（3）单击键盘“Tab”键，打开如图 7.53所示的“Fill”对话框。 
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图 7.53  “Fill”对话框 

如图 7.53所示的“Fill”对话框用于设置填充的属性，其中选项的功能如下。 

“Corner 1”和“Corner 2”中的“X”、“Y”编辑框用于设置填充区域的两对角点的

坐标。 

“Rotation”编辑框用于设置填充的矩形区域逆时针旋转的角度。 

“Properties”区域用于设置填充区域的特性，其中的选项的功能如下。 

“Layer”下拉列表用于设置填充区域所在的 PCB板层。 

“Net”下拉列表用于设置填充区域所连的网络。 

“Locked”复选项用于设置锁定该填充区域。 

“Keepout”复选项用于设置该填充区域为布线禁区。当选中该项后，系统会在填充区

域上添加一个禁止布线边框。 

（4）在“Fill”对话框中设置填充区域的属性，单击“OK”按钮。 

（5）在工作区移动光标到合适位置，单击鼠标，确定填充区域矩形的一个顶点。 

（6）移动光标到对角处，单击鼠标，定义填充区域矩形的另一个对角的顶点。完成这

个填充区域的布置。 

（7）重复以上操作，继续布置其他的填充区域，当所有填充区域布置完毕后，单击鼠

标右键或单击“Esc”键，结束布置填充区域操作。 

7.6.7  布置字符串 

Altium Designer中的字符串能被放在任何层，宽度可从 0.001 mil到 10000mil之间变化。

系统提供 3种字体绘制文本。默认的形式是简单的矢量字体，这种字体支持笔绘和矢量光绘。 

所有的文本字符串（元件标号、元件注释和自由文本字符串）都有相同的属性，并能以

相同的方法移动和编辑。自由文本能被放在任何层。当元件被放置的时候，元件上的文本被

自动地指定在丝印层的顶部或底部即“Top Overlay”或“Bottom Overlay”，这些文本不能

被移到其他层。 

放置字符串的操作方法如下。 

（1）在工作区选择放置字符串的 PCB板层，单击“Wiring”工具栏中的字符串工具按

钮，或者选择“Place”->“String”命令。 

（2）单击“Tab”键，打开如图 7.55所示的“String”对话框。 
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图 7.55  “String”对话框 

如图 7.55所示的“String”对话框用于设置添加的字符串的属性，其中的选项功能如下。 

“Width”编辑框用于设置文字笔画线条的宽度。 

“Height”编辑框用于设置文字的高度。 

“Rotation”编辑框用于设置文字的旋转角度。 

“Location”编辑框用于设置文字左下角的位置坐标。 

“Properties”区域用于设置字符串的性质，其中的选项功能如下。 

“Text”下拉列表用于设置文字的内容。 

“Layer”下拉列表用于设置布置字符串的 PCB板层。 

“Font”下拉列表用于设置字符串的字体。 

“Locked”复选框用于锁定字符串。 

“Mirror”复选框用于镜像翻转字符串。 

（3）在“String”对话框“Properties”区域的“Text”下拉列表内输入字符串或者从列

表中选择特殊字符串。 

（4）在“String”对话框中设置字符串的其他属性，单击“OK”按钮。 

（5）在工作区单击鼠标，布置字符串到指定位置。放置字符串时，按下 X 或 Y 键可以

沿该坐标轴镜像，按下空格键可以旋转字符串。 

（6）重复以上步骤，继续布置其他字符串，所有字符串布置完成后，单击鼠标右键或

单击“Esc”键结束布置字符串的操作。 

在“String”对话框“Properties”区域的“Text”下拉列表内提供了特殊字符串“SpeciaI 

Strings”，这些特殊字符串用来放置一些特殊用途的文本，这些文本在打印、绘图或生成

Gerber文件时被替换成对应的字符串。特殊字符串的定义如表 7.1所示。 

表表表表 7.1  特殊字符串及其含义特殊字符串及其含义特殊字符串及其含义特殊字符串及其含义 

特殊字符串 表示的含义 

PRINT DATA 打印日期 

PRINT TIME 打印时间 

PRINT SCALE 打印标尺 

LAYER NAME 层名 

PCB FILE NAME PCB文件名 

PCB FILE NAME NO PCB无路径文件名 
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PATH 

PLOT FILE NAME 绘图文件名 

ARC COUNT 圆弧线计数 

COMPONENT COUNT 元件计数 

FILL COUNT 填充计数 

HOLE COUNT 孔计数 

NET COUNT 网络计数 

PAD COUNT 焊盘计数 

STRING COUNT 字符串计数 

TRACK COUNT 连线计数 

VIA COUNT 过孔计数 

DESIGNATOR 标号 

COMMENT 注释 

LEGEND 图例 

NET NAMES ON LAYER 网络层名 

7.6.8  布置 PCB元件封装 

元件封装是 PCB中用的最多的组对象，由元件的引脚焊盘，定义元件的物理形状图形

等一组对象组合而成。在由原理图生成 PCB板图的步骤中，系统会自动将原件的 PCB封装

图布置到 PCB板层上，用户只需调整元件封装的布局即可，当需要手动添加 PCB元件封装

时，可执行以下步骤。 

（1）在工作区选择需要布置 PCB 元件封装的 PCB板层，单击“Wiring”工具栏中的

布置 PCB 元件封装工具按钮 ，或者在主菜单中选择“Place”->“Component…”命令，

打开如图 7.56所示的“Place Component”对话框。 

 

图 7.56  “Place Component”对话框 

（2）单击如图 7.56所示的“Place Component”对话框“Component Details”区域内的

“Footprint”编辑框右侧的 按钮，打开如图 7.57所示的“Browse Libraries”对话框。 
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图 7.57  “Browse Libraries”对话框 

（3）单击如图 7.57所示的“Browse Libraries”对话框中“Libraries”下拉列表右侧的

按钮，打开如图 7.58所示的“Available Libraries”对话框。 

 

图 7.58  “Available Libraries”对话框 

（4）单击如图 7.58所示的“Available Libraries”对话框中的“Install…”按钮，打开“打

开”对话框。 

（5）在“打开”对话框中选择需要添加的 PCB元件封装所在的 PCB元件封装库文件，

然后单击“打开”按钮，将该库文件添加到“Available Libraries”对话框的列表中。 

（6）单击“Available Libraries”对话框的“Close”按钮，关闭该对话框。 

（7）在“Browse Libraries”对话框的“Libraries”下拉列表中选择添加的 PCB元件封

装库，然后再在“Browse Libraries”对话框的 PCB元件封装列表中选择需要添加的 PCB元

件封装模型，单击“OK”按钮。 

（8）单击“Place Component”对话框中的“OK”按钮。 

（9）移动光标到合适位置，单击空格键调整 PCB元件封装的旋转角度，单击鼠标，将

该 PCB元件封装布置到 PCB板上。 

（10）重复步骤（9），在 PCB板上布置同样的 PCB元件封装，布置完毕后，单击鼠
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标右键，或者“Esc”键，重新打开“Place Component”对话框。 

（11）重复步骤（2）~（10），布置其他的 PCB元件封装，所有的 PCB元件封装布置

结束后，单击“Place Component”对话框中的“Cancel”按钮，结束布置 PCB元件封装的

操作。 

7.6.9  布置多边形敷铜区域 

多边形敷铜可以填充板上不规则形状的区域，实现在 PCB板中的任何连线、焊盘、过

孔、填充和文本周围敷铜。当它们被敷铜的时候，可以和一个指定网络的元件焊盘、过孔连

接。多边形的边框由线段和圆弧线组成，形成一个单元。布置多边形敷铜区域的方法如下。 

（1）在工作区选择需要设置多边形敷铜的 PCB板层。 

（2）单击“Wiring”工具栏中的多边形敷铜工具按钮 ，或者在主菜单中选择“Place”

->“Polygon plane”菜单项。打开如图 7.59所示的“Polygon plane”对话框。 

 

图 7.59  “Polygon plane”对话框 

如图 7.59所示的“Polygon plane”对话框用于设置多边形敷铜区域的属性，其中的选项

功能如下。 

“Surround Pads With”选项用于设置多边形敷铜区域在焊盘周围的围绕模式。其中，

“Arcs”单选项表示采用圆弧围绕焊盘，“Octagons”单选项表示使用八角形围绕焊盘，使

用八角形围绕焊盘的方式所生成的 Gerber文件比较小，生成速度比较快。 

“Grid Size”编辑框用于设置多边形敷铜区域中网格的尺寸。为了使多边形连线的放置

最有效，建议避免使用元件管脚间距的整数倍值设置网格尺寸。 

“Track Width”编辑框用于设置多边形敷铜区域中网格连线的宽度。如果连线宽度比网

格尺寸小，多边形敷铜区域是网格状的；如果连线宽度和网格尺寸相等或者比网格尺寸大，

多边形敷铜区域是实心的。 

“Hatching Style”用于设置多边形敷铜区域中的填充网格式样，其中共有 5个单选项，

其功能如下。 

“None”单选项表示在多边形敷铜区域中没有任何填充网格。 

“90 Degree”单选项表示在多边形敷铜区域中填充水平和垂直的连线网格。 

“45 Degree”单选项表示用 45°的连线网络填充多边形。 

“Horizontal”单选项表示用水平的连线填充多边形敷铜区域。 
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“Vertical”单选项表示用垂直的连线填充多边形敷铜区域。 

以上各填充风格的多边形敷铜区域如图 7.60所示。 

            

“None”                  “90 Degree”               “45Degree” 

           

“Horizontal”                   “Vertical” 

图 7.60  各填充风格的多边形敷铜区域 

“Properties”区域用于设置多边形敷铜区域的性质，其中的各选项功能如下。 

“Layer”下拉列表用于设置多边形敷铜区域所在的层。 

“Min Prim Length”编辑框用于设置多边形敷铜区域的精度，该值设置得越小，多边形

填充区域就越光滑，但敷铜、屏幕重画和输出产生的时间会增多。 

“Lock Primitive”复选项用于设置锁定多边形敷铜区域的状态。 

“Net Options”区域用于设置多边形敷铜区域中的网络，其中的各选项功能如下 

“Connect To Net”下拉列表用于选择与多边形相连的网络，选择好该选项后会激活其

他的两个复选项。 

“Pour Over Same Net”复选项。选中该复选项后，多边形敷铜区域将会自动覆盖与该

区域相同网络的连线。 

“Remove Dead Copper”复选项。选中该复选项后，系统会自动移去死铜。所谓死铜是

指在多边形敷铜区域中没有和选定的网络相连的铜膜。当已存在的连线、焊盘和过孔不能和

敷铜构成一个连续区域的时候，死铜就生成了。死铜会给电路带来不必要的干扰，因此建议

用户选中该选项，自动消除死铜。 

（3）在“Place Polygon plane”对话框中设置多边形敷铜区域的属性。 

（4）移动光标，在多边形的起始点单击，定义多边形开始的顶点。 

（5）移动光标，持续在多边形的每个折点单击，确定多边形的边界，直到多边形敷铜

的边界定义完成。按下 Shift+空格键或者空格键，可改变多边形边界连线的放置模式（比如

圆弧、任意角度等）。 

当多边形敷铜区域被编辑后，系统会弹出如图 7.61所示的“Confirm”消息框，提示用

户重新绘制多边形敷铜区域，单击“Confirm”消息框中的“Yes”按钮，即可重绘多边形敷

铜区域，若单击“No”按钮，即取消多边形敷铜区域的重绘操作。 
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图 7.61  “Confirm”消息框 

在主菜单中选择“Tools”->“Convert”->“Explode”->“Polygon to Free Primitives”

命令，可以把一个多边形敷铜区域转变成一组单独的连线和圆弧。 

7.6.10  尺寸标注 

尺寸标注是由文本和连线元素组成的特殊实体。在实际设计任务中，由于生产、加工的

需要，往往需要提供尺寸的标注。Altium Designer提供了智能尺寸标注功能。一般来说，尺

寸标注通常是放置在某个机械层，用户可以从 16个机械层中指定一个层来做尺寸标注层。

根据标注对象的不同，尺寸标注共有以下几种。 

一、直线尺寸标注 

对直线距离尺寸进行标注，可进行以下操作。 

（1）单击“Utilities”工具栏中的尺寸工具按钮 ，在弹出的工具栏中选择直线尺寸工

具按钮 ，或者选择“Place”->“Dimension”->“Linear”命令。 

（2）单击“Tab”键，打开如图 7.62所示的“Linear Dimension”对话框。 

 

图 7.62  “Linear Dimension”对话框 

如图 7.62所示的“Linear Dimension”对话框用于设置直线标注的属性，其中的选项功

能如下。 

“Pick Gap”编辑框用来设置尺寸线与标注对象间的距离。 

“Extension Width”编辑框用来设置尺寸延长线的线宽。 

“Arrow Length”编辑框用来设置箭头线长度。 

“Arrow Size”编辑框用来设置箭头长度（斜线）。 

“Line Width”编辑框用来设置箭头线宽。 

“Offset”编辑框用来设置箭头与尺寸延长线端点的偏移量。 
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“Height”编辑框用来设置尺寸字体高度。 

“Rotation”编辑框用来设置尺寸标注线拉出的旋转角度。 

“Text Width”编辑框用来设置尺寸字体线宽。 

“Gap”编辑框用来设置尺寸字体与尺寸线左右的间距。 

“Properties”区域用来设置直线标注的性质，其中的选项功能如下。 

“Layer”下拉列表用来设置当前尺寸文本所放置的 PCB板层。 

“Font”当前尺寸文本所使用的字体。可以在下拉列表中选择尺寸放置的字体。 

“Format”下拉列表用来设置当前尺寸文本的放置风格。在下拉列表中选择尺寸放置的

风格共有 4个选项：“None”选项表示不显示尺寸文本。“0.00”选项表示只显示尺寸，不

显示单位。“0.00mil”选项表示同时显示尺寸和单位。“0.00（mil）”选项表示显示尺寸

和单位，并将单位用括号括起来。 

“Text Position” 下拉列表用来设置当前尺寸文本的放置位置。 

“Unit”下拉列表用来设置当前尺寸采用的单位。可以在下拉列表中选择放置尺寸的单

位，系统提供了 “mils”、“millimeters”、“Inches”、“Centimeters”和“Automatic”

共五个选项，其中“Automatic”项表示使用系统定义的单位。 

“Precision”下拉列表用来设置当前尺寸标注精度。下拉列表中的数值表示小数点后面

的位数。默认标注精度是 2，一般标注最大是 6，角度标注最大为 5。 

“Prefix”编辑框用来设置尺寸标注时添加的前缀。 

“Suffix”编辑框用来设置尺寸标注时添加的后缀。 

“Sample”编辑框用来显示用户设置的尺寸标注风格示例。 

“Locked”复选项用来锁定标注尺寸。 

（3）在“Linear Dimension”对话框中设置标注的属性，单击“OK”按钮。 

（4）移动光标至工作区单击需要标注的距离的一端，确定一个标注箭头位置。 

（5）移动光标至工作区单击需要标注的距离的另一端，确定另一个标注箭头位置，如

果需要垂直标注，可单击空格键旋转标注的方向。 

（6）重复步骤（2）、（3）继续标注其他的水平和垂直距离尺寸。 

（5）标注结束后，单击鼠标右键，或者单击“Esc”键，结束直线尺寸标注操作。 

二、角度标注 

对 PCB图中的角度进行标注，可进行以下操作。 

（1）单击“Utilities”工具栏中的尺寸工具按钮 ，在弹出的工具栏中选择角度标注工

具按钮 ，或者选择“Place”->“Dimension”->“Angular”命令。 

（2）单击“Tab”键，打开如图 7.63所示的“Angular Dimension”对话框。 
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图 7.63  “Angular Dimension”对话框 

如图 7.63所示的“Angular Dimension”对话框用于设置角度标注的属性，其中的选项

功能与“Linear Dimension”对话框中的对应选项功能相同。可参考对“Linear Dimension”

对话框中选项的描述。 

（3）在“Angular Dimension”对话框中设置角度标注的属性，单击“OK”按钮。 

（4）移动光标，在工作区选择欲标注的角度的顶点，单击鼠标，确定该顶点。 

（5）在工作区单击欲标注的角度的一条射线上的一点，确定该射线。 

（6）在工作区再次单击欲标注的角度的顶点，然后单击另外一条射线上的点，确定另

一条射线。 

（7）移动光标，调整标注文本的位置，单击鼠标，完成角度的标注。过程如图 7.64所

示。 

      

图 7.64  角度标注过程 

（8）重复步骤（4）~（7），对其他需要标注的角度进行标注，角度标注结束后，单击

鼠标右键或者单击“Esc”键，结束角度标注操作。 

三、半径尺寸标注 

步骤（4）和（6）
中单击的角度

顶点 

步骤（5）中单

击的角度射线

上的一点 

步骤（6）中单

击的角度射线

上的一点 
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对 PCB图中的圆弧半径进行标注，可进行以下操作。 

（1）单击“Utilities”工具栏中的尺寸工具按钮 ，在弹出的工具栏中选择半径尺寸工

具按钮 ，或者在主菜单中选择“Place”->“Dimension”->“Radial”命令。 

（2）单击“Tab”键，打开如图 7.65所示的“Radial Dimension”对话框。 

 

图 7.65  “Radial Dimension”对话框 

如图 7.65所示的“Radial Dimension”对话框用于设置半径标注的属性，其中的选项功

能与“Linear Dimension”对话框中的对应选项功能相同，可参考对“Linear Dimension”对

话框中选项的描述。 

（3）在工作区单击需要标注的圆弧或者圆。 

（4）移动光标调整半径标注中的箭头所在的位置，单击鼠标确定半径标注中的箭头位

置和方向。 

（5）移动光标调整箭头后的引线长度，单击鼠标确定该引线，然后再调整箭头后部折

线的方向，单击鼠标确定。 

（6）重复步骤（3）~（5）标注其他的圆弧，当标注完成后，单击鼠标右键或者“Esc”

键结束半径标注操作。 

四、引线标注 

引线标注用于标明电路中的某点，对其进行某些文字注释。布置引线标注可进行以下操

作。 

（1）单击“Utilities”工具栏中的尺寸工具按钮 ，在弹出的工具栏中选择引线标注工

具按钮 ，或者选择“Place”->“Dimension”->“Leader”命令。 

（2）单击“Tab”键，打开如图 7.66所示的“Leader Dimension”对话框。 
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图 7.66  “Leader Dimension”对话框 

如图 7.66所示的“Leader Dimension”对话框用于设置引线标注的属性，其中大部分选

项的功能与 “Linear Dimension”对话框中的对应选项功能相同。可参考对“Linear Dimension”

对话框中选项的描述。与“Linear Dimension”对话框中不相同的选项介绍如下。 

“Text”编辑框用于填写要标注的文本信息。 

“Dot”复选项。选中该复选项后，指向标注对象的引线端点位置显示实心圆点。不选

时，以箭头指向该点。 

“Size”编辑框用于设置在引线端点位置显示实心圆点的大小，仅当“Dot”复选项被

选中时，该项有效。 

“Shape”下拉列表用于设置标注文字的显示形式。“None”选项表示只显示文字。

“Round”选项表示将文字压缩显示在一个圆中，其圆的尺寸由对话框的图形表示，圆直径

由“Size”编辑框中的数值确定。“Square”选项表示将文字压缩显示在一个正方形中，其

正方形的大小由“Size”编辑框中的数值确定。系统默认设置为“None”。 

（3）在属性对话框的“Text”编辑框内输入要标注的文字。 

（4）在工作区单击要标注的位置。 

（5）移动鼠标调整引线的长度，单击鼠标，确定标注线的折点。 

（6）单击鼠标确定标注线其他折点的位置，所有折点确定后，在标注线的终点单击鼠

标右键，确定标注线的终点位置，完成这次标注。标注过程如图 7.67所示。 

  

图 7.67  引线标注的过程 

五、标尺标注 

标尺标注用于在 PCB板上设置尺寸标尺，布置尺寸标尺可进行以下操作。 

（1）单击“Utilities”工具栏中的尺寸工具按钮 ，在弹出的工具栏中选择标尺工具按

钮 ，或者选择“Place”->“Dimension”->“Datum”命令。 
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（2）单击“Tab”键，打开如图 7.68所示的“Datum Dimension”对话框。 

 

图 7.68  “Datum Dimension”对话框 

如图 7.68所示的“Datum Dimension”对话框用于设置标尺的属性，其中的选项功能与

“Linear Dimension”对话框中的对应选项功能相同。可参考对“Linear Dimension”对话框

中选项的描述。 

（3）在“Datum Dimension”对话框中设置标尺的属性，单击“OK”按钮。 

（4）在工作区移动光标至基准处，单击鼠标，确定标尺基准“0”的位置。 

（5）移动光标至第一个标尺处，单击鼠标，确定标尺刻度，若需要标注垂直距离尺寸，

可单击空格键，旋转标注的方向。 

（6）移动光标至工作区的下一个标尺刻度处，单击鼠标，确定下一个标尺刻度。 

（7）重复步骤（6）确定所有的标尺刻度，单击鼠标右键或者单击“Esc”键，完成标

尺刻度的确定。 

（8）移动鼠标调整标尺数值的位置，单击鼠标，确定标尺数值位置。结束该标尺布置

操作。布置过程如图 7.69所示。 

   

图 7.69  标尺布置过程 

六、基准标注 

对连续的点相对于同一个基准的直线距离进行标注，可进行以下操作。 

（1）单击“Utilities”工具栏中的尺寸工具按钮 ，在弹出的工具栏中选择基准标注工
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具按钮 ，或者选择“Place”->“Dimension”->“Baseline”命令。 

（2）单击“Tab”键，打开如图 7.70所示的“Baseline Dimension”对话框。 

 

图 7.70  “Baseline Dimension”对话框 

如图 7.70所示的“Baseline Dimension”对话框用于设置基准标注的属性，其中的选项

功能与“Linear Dimension”对话框中的对应选项功能相同。可参考对“Linear Dimension”

对话框中选项的描述。 

（3）在“Baseline Dimension”对话框中设置基准标注的属性，单击“OK”按钮。 

（4）在工作区移动光标至基准处，单击鼠标，确定尺寸基准的位置。 

（5）移动光标至工作区需要标注的第一个尺寸处，单击鼠标确定基准标注的另一个端

点，移动光标，调整标注文字的位置，单击鼠标确定标注文字位置。若需要标注垂直距离尺

寸，可单击空格键，旋转标注的方向。 

（6）重复步骤（5）继续标注其他的点与尺寸基准的距离。 

（7）所有尺寸标注完毕后，单击鼠标右键或者单击“Esc”键，完成基准标注操作。布

置基准标注过程如图 7.71所示。 

   

图 7.71  布置基准标注过程 

七、中心标注 

中心标注用于定位圆心或其他中心，布置中心标注，可进行如下操作。 
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（1）单击“Utilities”工具栏中的尺寸工具按钮 ，在弹出的工具栏中选择中心标注工

具按钮 ，或者选择“Place”->“Dimension”->“Center”命令。 

（2）单击“Tab”键，打开如图 7.72所示的“Center Dimension”对话框。 

 

图 7.72  “Center Dimension”对话框 

如图 7.72所示的“Center Dimension”对话框用于设置中心标注的属性，其中“Rotation”

编辑框用于设置中心标注的旋转角度。“Size”编辑框用于设置中心标注的大小。“Layer”

编辑框用于设置中心标注所在的 PCB板层。“Locked”复选框用于设置锁定中心标注。 

（3）在“Center Dimension”对话框中设置中心标注的属性，单击“OK”按钮。 

（4）在工作区单击需要布置中心标注的圆弧或圆，确定中心标注的位置。 

（5）移动光标，调整中心标注的大小，单击鼠标确定中心标注大小。 

（6）重复步骤（4）、（5）布置其他的中心标注，所有中心标注布置完毕后，单击鼠

标右键或者单击“Esc”键，结束布置中心标注的操作。 

八、线性直径标注 

线性直径尺寸标注就是采用标注直线的方式标注圆的直径，布置这种标注可进行以下操

作。 

（1）单击“Utilities”工具栏中的尺寸工具按钮 ，在弹出的工具栏中选择线性直径标

注工具按钮 ，或者选择“Place”->“Dimension”->“Linear Diameter”命令。 

（2）单击“Tab”键，打开如图 7.73所示的“Linear Diameter Dimension”对话框。 
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图 7.73  “Linear Diameter Dimension”对话框 

如图 7.73所示的“Linear Diameter Dimension”对话框用于设置线性直径标注的属性，

其中的选项功能与“Linear Dimension”对话框中的对应选项功能相同。可参考对“Linear 

Dimension”对话框中选项的描述。 

（3）在“Linear Diameter Dimension”对话框中设置线性直径标注的属性，单击“OK”

按钮。 

（4）在工作区单击需要进行线性直径标注的圆弧或圆，移动光标调整直径标注文本的

位置，单击鼠标确定标注文本的位置。 

（5）重复步骤（4），对其他的圆弧进行标注，标注结束后，单击鼠标右键或者单击“Esc”

键，结束线性直径标注操作。布置的线性直径标注如图 7.74所示。 

 

图 7.74  布置的线性直径标注 

九、射线式直径标注 

射线式直径标注是圆或圆弧直径尺寸标注的常用方式，可进行以下操作，布置射线式直

径标注。 

（1）单击“Utilities”工具栏中的尺寸工具按钮 ，在弹出的工具栏中选择射线式直径

标注工具按钮 ，或者选择“Place”->“Dimension”->“Radial Diameter”命令。 

（2）单击“Tab”键，打开如图 7.75所示的“Radial Diameter Dimension”对话框。 
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图 7.75  “Radial Diameter Dimension”对话框 

如图 7.75所示的“Linear Diameter Dimension”对话框用于设置射线式直径标注的属性，

其中的选项功能与“Linear Dimension”对话框中的对应选项功能相同。可参考对“Linear 

Dimension”对话框中选项的描述。 

（3）在“Radial Diameter Dimension”对话框中设置线性直径标注的属性，单击“OK”

按钮。 

（4）在工作区单击需要进行线性直径标注的圆弧或圆，移动光标调整直径标注箭头的

位置，单击鼠标确定箭头位置。 

（5）移动光标调整直径标注引线的终点位置，单击鼠标确定引线终点，结束该直径标

注。 

（6）重复步骤（4）、（5），对其他的圆弧进行标注，标注结束后，单击鼠标右键或

者单击“Esc”键，结束射线式直径标注操作。布置过程如图 7.76所示。 

   

图 7.76 布置射线式直径标注 

十、标准标注 

标准标注用于任意倾斜角度的直线距离标注，可进行以下操作设置标准标注。 

（1）单击“Utilities”工具栏中的尺寸工具按钮 ，在弹出的工具栏中选择标准直线尺

寸工具按钮 ，或者选择“Place”->“Dimension”->“Dimension”命令。 

（2）单击“Tab”键，打开如图 7.77所示的“Dimension”对话框。 
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图 7.77  “Dimension”对话框 

如图 7.77所示的“Dimension”对话框用于设置标准标注的属性，其中“Sart”、“End”

项中的“X”、“Y”编辑框用于设置标注起始点和终点的坐标。对话框中其他的选项功能

与“Linear Dimension”对话框中的对应选项功能相同。可参考对“Linear Dimension”对话

框中选项的描述。 

（3）在“Dimension”对话框中设置标准标注的属性，单击“OK”按钮。 

（4）移动光标至工作区到需要标注的距离的一端，单击鼠标，确定一个标注箭头位置。 

（5）移动光标至工作区到需要标注的距离的另一端，单击鼠标，确定标注另一端箭头

的位置，系统会自动调整标注的箭头方向。 

（6）重复步骤（4）、（5）继续标注其他的直线距离尺寸。 

（7）标注结束后，单击鼠标右键，或者单击“Esc”键，结束尺寸标注操作。 

十一、坐标标注 

坐标标注用于显示工作区里指定点的坐标。坐标标记可以放置在任意层，坐标标注包括

一个“十”字标记和位置的（X，Y）坐标，可进行如下操作布置坐标标注。 

（1）单击“Utilities”工具栏中的绘图工具按钮 ，在弹出的工具栏中选择坐标标注工

具按钮 ，或者在主菜单中选择“Place”->“Coordinate”命令。 

（2）单击“Tab”键，打开如图 7.78所示的“Coordinate”对话框。 
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图 7.78  “Coordinate”对话框 

如图 7.78 所示的“Coordinate”对话框用于设置坐标标注的属性，其中的选项功能与

“Linear Dimension”对话框中的对应选项功能相同。可参考对“Linear Dimension”对话框

中选项的描述。 

（3）在工作区单击需要布置坐标标注的点，即可在该点布置坐标标注。 

（4）重复步骤（3），在其他的点上布置坐标标注，所有标注布置结束后，单击鼠标右

键或者单击“Esc”键，结束坐标标注的布置。布置的坐标标注如图 7.79所示。 

 

图 7.79  布置的坐标标注 

7.7  由原理图生成 PCB板实例 

本节将通过实例介绍由原理图生成 PCB板的过程，在实例中将第二章 2.8 节中创建的

数显表头原理图绘制完成 PCB板图。 

7.7.1  在项目中新建 PCB文档 

（1）启动 Altium Designer，在“Projects”工作面板的“Workspace”下拉列表中选择

“ExampleWorkspace”工作空间。 

（ 2）在“ ExampleWorkspace”工作空间下方的“Projects”下拉列表中选择

“Digit_meter_PCB .PrjPcb”项目，选择主菜单中的“File”->“New”->“PCB”命令，在

“Digit_meter_PCB .PrjPcb”项目中新建一个名称为“PCB1.PcbDoc”的 PCB文件。 

（3）在新建的 PCB文件上单击鼠标右键，在弹出的下拉菜单中选择“Save”命令，打

开“Save[PCB1.PcbDoc]As”对话框。 

（4）在“Save[PCB1.PcbDoc]As”对话框的“文件名”编辑框中输入“digit_meter”，

单击“保存”按钮，将新建的 PCB文档保存为“digit_meter.PCBDOC”文件。 

7.7.2  设置 PCB板 

（1）在主菜单中选择“Design”->“Board Options…”命令，打开如图 7.80所示的“Board 

Options”对话框。 
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图 7.80  “Board Options”对话框 

（2）在如图 7.80所示的“Board Options”对话框的“Measurement Unit”区域中设置“Unit”

为“Metric”，勾选“Sheet Position”区域中的“Display Sheet”复选项，单击“OK”按钮。 

（3）在主菜单中选择“Design”->“Board Sharp”->“Redefine Board Sharp”命令，工

作区 PCB图纸中的 PCB板变为绿色。 

（4）移动光标按顺序分别在工作区内坐标为（100，30）、（160，30）、（160，70）

和（100，70）的点上单击，最后单击鼠标右键，绘制一个矩形区域。 

（5）单击鼠标右键，重新定义如图 7.81所示的 PCB板区域。 

 

图 7.81  重新定义的 PCB板区域 

（6）单击工作区下部的“Keep-Out Layer”层标签，选择“Keep Out”层。 

（7）单击“Utilities”工具栏中的网格工具按钮 ，在弹出的菜单中选择“1.000mm”

设置绘图的对齐网格 1mm。 

（8）单击“Utilities”工具栏中的绘图工具按钮 ，在弹出的工具栏中选择线段工具按

钮 ，移动光标按顺序连接工作区内坐标为（102，32）、（158，32）、（158，68）和（102，

68）的四个点，绘制“Keep Out”矩形区域。 

（9）在主菜单中选择“Design”->“Layer Stack Manager”命令，打开如图 7.82所示

的“Layer Stack Manager”对话框。 
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图 7.82  “Layer Stack Manager”对话框 

（10）在“Layer Stack Manager”对话框中勾选“Top Dielectric”复选项和“Bottom 

Dielectric”复选项，设置电路板为有阻焊层的双层板，单击“Ok”按钮。 

至此，PCB板的形状、大小，布线区域和层数就设置完毕了。 

7.7.3  导入元件 

（1）在主菜单中选择“Design”->“Import Changes From Digit_meter_PCB .PrjPcb”命

令，打开如图 7.83所示的“Engineering Change Order”对话框。 

 

图 7.83  “Engineering Change Order”对话框 

（3）单击“Execute Changes”按钮，应用所有已选择的更新，“Engineering Change Order”

对话框内列表中的“Status”下的“Check”和“Done”列将显示检查更新和执行更新后的

结果，如果执行过程中出现问题将会显示 符号，若执行成功则会显示 符号。应用更新后

的“Engineering Change Order”对话框如图 7.84所示。 
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图 7.84  应用更新后的“Engineering Change Order”对话框 

PCB 板图文件的工作区如图 7.85 所示，此时 PCB 板图文件的内容与原理图文件

“digit_meter.SchDoc”就完全一致了。 

 

图 7.85  PCB工作区内容 

（5）单击“Engineering Change Order”对话框中的“Close”按钮，关闭该对话框，  

至此，原理图中的元件和连接关系就导入到 PCB板中了。 

7.7.4  元件布局 

（1）单击工作区中的名称为“digital meter”room框，按键盘的“del”键，将其删除。 

room框用于限制单元电路的位置，即某一个单元电路中的所有元件将被限制在由 room

框所限定的 PCB范围内，便于 PCB电路板的布局规范，减少干扰，通常用于层次化的模块

设计和多通道设计中。由于本项目未使用层次设计，中不需要使用到 room边框的功能，为

了方便元件布局，可以先将该 room框删除。 

（2）单击 PCB图中的元件，将其一一拖放到 PCB板中的“Keep-Out”区域内。 

为了节约 PCB板的空间，需要将元件双面布置，在导入元件的过程中，系统自动将元
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件布置到 PCB板的正面，需要手工将元件调整到背面。 

（3）双击元件“D1”，打开如图 7.86所示的“Component D1”对话框。 

 

图 7.86  “Component D1”对话框 

（4）在“Component D1”对话框中“Component Properties”区域内的“Layer”下拉列

表中选择“Bottom Layer”项，单击“OK”按钮，关闭该对话框。 

此时，元件“D1”连同其标志文字都被调整到背面。 

（5）采用步骤（3）~（4）的方法，将其他贴片元件布置到 PCB板背面，然后调整元

件的位置，布置完成后的 PCB板如图 7.87所示。 

 

图 7.87  布置完成后的 PCB板 

至此，元件布局完毕。 
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7.7.5  自动布线 

（1）在主菜单中选择“Auto Route”->“All”命令，打开如图 7.88所示的“Situs Routing 

Strategies”对话框。 

 

图 7.88  “Situs Routing Strategies”对话框 

（2）在 “Situs Routing Strategies”对话框内的“Availale Routing Strategies”列表中选

择“Default 2 Layer Board”项，单击“Route All”按钮，启动 Situs自动布线器。 

自动布线结束后，系统弹出“Message”工作面板，显示自动布线过程中的信息，如图

7.89所示。 

 

图 7.89  “Messages”工作面板 

自动布线后的 PCB板图如图 7.90所示。 
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图 7.90  自动布线生成的 PCB板图 

观察自动布线的结果可知，对于比较简单的电路，当元件布局合理，布线规则设置完善

时，Altium Designer中的 Situs布线器的布线效果相当令人满意。 

（3）单击保存工具按钮 ，保存 PCB文件。 

至此，PCB自动布线就结束了，通过整个 PCB板生成的过程的学习，可以体会得到，

使用 Altium Designer 进行 PCB板的设计过程非常简单，可靠。 

7.7.6  验证 PCB设计 

（1）在主菜单中选择“Tools”->“Design Rule Check…”命令，打开如图 7.91所示的

“Design Rule Checker”对话框。 

 

图 7.90  “Design Rule Checker”对话框 

（2）单击“Run Design Rule Check…”按钮，启动设计规则测试。 

设计规则测试结束后，系统自动生成如图 7.91所示的检查报告网页文件。 
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图 7.91  检查报告网页 

查看检查报告，系统设计中不存在违反设计规则的问题，系统布线成功。 
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第 8章  PCB板设计规则设置 

为了保证电路系统能够可靠的工作，PCB 板的设计水平至关重要，具有同样互连关系

的，不同走线设计的 PCB板可能有的能够稳定可靠的工作，有的就会出现莫名其妙的问题，

这是因为 PCB设计工作不仅仅是按照原理图的要求将元件引脚连到一起，还需要考虑到类

似于串扰、网络长度等问题。为提高 PCB设计的质量，Altium Designer提供了 PCB设计规

则管理功能，用户自己根据不同产品的需要定义设计规则，系统在自动布线过程中将参考用

户的设计规则，在交互式布线过程中，系统会实时检查设计中是否有违反设计规则的问题，

及时提醒设计者。这样就能保证设计结果符合之前设定的要求。本章将系统的介绍在 Altium 

Designer中提供的 PCB板设计规则，以及如何对设计规则进行管理和设置的方法。 

8.1  设计规则编辑器 

为了方便地设置和管理设计规则，AltiumDesigner6.0提供设计规则编辑器，所有设计规

则的管理操作均可在设计规则编辑器中完成，本节将简要介绍设计规则编辑器。 

8.1.1  设计规则编辑器界面介绍 

在 PCB编辑器环境下，在主菜单中选择“Design”->“Rules…”命令，即可打开如图

8.1所示的“PCB Rules and Constraints Editor”对话框，该对话框就是设计规则编辑器的界

面。 

 

图 8.1  “PCB Rules and Constraints Editor”对话框 

设计规则编辑器界面由两个列表组成。左边的树形列表显示已设定的设计规则的结构

图，AltiumDesigner6.0采用多层方式管理设计规则，将设计规则划分为几个规则类，单击树

形列表中规则类名称之前的“+”可以展开该规则类，显示该规则类下属的所有子类，单击

规则类前的“-”即可隐藏该规则类中的子类。 

对话框右侧的视图用于显示左侧树形列表中选中的设计规则对象的内容，若在树形列表

中选中规则类的名称，则右边的视图中将显示该规则类下的规则列表，如果在树形列表中选
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中某项具体定义的规则，则在右边的视图中将显示所选规则定义的选项，便于用户修改规则。

所有的设计规则的建立、修改和删除等操作均可在设计规则编辑器中完成。 

8.1.2  规则的基本操作 

在一个 PCB项目设计中，用户可能需要设置多个同类型的规则，例如在同一个 PCB设

计中，不同的网络由于流过电流大小不同，铜膜导线的宽度、间距也会不同，这样就需要新

建多个有关导线宽度的设计规则，应用于不同的对象。本节将介绍新建、删除、导入和导出

设计规则的步骤。 

1、新建设计规则 

新建设计规则的步骤如下。 

（1）在规则编辑器左侧的树形列表中选择需要编辑的规则，本例中选择“Electrical”

设计规则类下的“Clearance”设计规则。 

（2）在“Clearance”设计规则上单击右键，弹出如图 8.2所示的右键菜单。 

 

图 8.2  右键菜单 

（3）在弹出的菜单中选择“New Rule”命令，系统在“Clearance”规则下新建一个默

认名称为“Clearance_1”的规则，如图 8.3所示。 

 

图 8.3  新建的默认名称为“Clearance_1”的规则 

此时的设计规则使用加粗字体显示，还需要用户进行修改，经过检查没有出现规则冲突，

然后被应用后才算新建完毕。 

（4）单击“PCB Rules and Constraints Editor”对话框中的“Apply”按钮，检查并应用

新建的规则。 

2、删除规则 

（1）在规则编辑器左侧的树形列表中选择欲删除的规则，本例中选择刚才新建的设计

规则“Clearance_1”。 

（2）在该规则上单击鼠标右键，在弹出的菜单中选择“Delete Rule…”命令，系统就

会在将要删除的规则名称上显示一条删除线，如图 8.4所示，表示该规则已经设置为被删除。 

 

图 8.4  规则名称上显示删除线 

（3）单击“PCB Rules and Constraints Editor”对话框中的“Apply”按钮，删除有删除

线标记的规则。 

3、导出设计规则 

为了将设计规则能应用于其他的 PCB设计，用户可以选择将设计规则导出到后缀名为

“.rul”的文件中，供其他的设计引用，导出设计规则的方法如下。 
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（1）在规则编辑器左侧的树形列表中选择需要导出的规则，本例中选择设计规则

“Clearance”。 

（2）在该规则上单击鼠标右键，在弹出的菜单中选择“Export Rules…”命令，打开如

图 8.5所示的“Choose Design Rule Type”对话框。 

 

图 8.5  “Choose Design Rule Type”对话框 

（3）在“Choose Design Rule Type”对话框中选择“Electrical”规则类下的“Clearance 

Constraint”栏，单击“OK”按钮，打开如图 8.6所示的“Export Rules to File”对话框。 

 
图 8.6  “Export Rules to File”对话框 

（4）在“Export Rules to File”对话框中设置导出的文件的名称和路径，单击“保存”

按钮，保存导出的文件。 

4、导入规则 

如果需要在当前的 PCB设计中应用以前设置的设计规则，可以导入已有的设计规则文

件，具体操作步骤如下。 

（1）在规则编辑器左侧的树形列表中单击鼠标右键，在弹出的菜单中选择“Import 

Rules…”命令，打开“Choose Design Rule Type”对话框。 

（2）在“Choose Design Rule Type”对话框中选择“Clearance Constraint”规则，单击

“OK”按钮，打开如图 8.7所示的“Import File”对话框。 
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图 8.7  “Import File”对话框 

（3）在“Import File”对话框中选择需要导入的“.rul”文件，单击“打开”按钮即可。 

5、设置规则优先级 

在“Altium Designer”中，每一个具体的设计规则都有一个优先级参数，该参数用于设

置设计规则在检查时的先后次序，当同一个设计规则类中存在多个设计规则时，系统根据设

计规则的优先级参数逐个检查设计规则。用户可通过以下步骤设置设计规则的优先级参数。 

（1）单击规则编辑器左下方的“Priorities”按钮，打开如图 8.8所示的“Edit Rule Priorities”

对话框。 

 

图 8.8  “Edit Rule Priorities”对话框 

（2）在 “Edit Rule Priorities”对话框上方的“Rule Type”下拉列表中选择需要改变优

先级的规则所在的规则类。 

（3）在“Edit Rule Priorities”对话框下方的列表中选择需要改变优先级的具体设计规

则，单击“Increase Priorities”按钮即可将所选规则的优先级提高一级，或者单击“Decrease 

Priorities”按钮即可将所选规则的优先级降低一级。另外，按住鼠标左键，将选中的规则行

拖动到合适的优先级位置，也可调整规则的优先级。 

（4）所有的规则优先级都调整完毕后，单击“Close”按钮，关闭“Edit Rule Priorities”

对话框。 
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8.1.3  设计规则设置页面 

在 Altium Designer的设计规则管理器中，选中具体的设计规则项后，在设计规则管理

器的右部，将会显示对应的设计规则设置页面，通常，所有的设计规则设置页面由三大块构

成，分别是基本属性、适用对象和约束参数，下面，以“Width”设计规则的设置页面为例，

介绍这三部分属性，“Width”规则的设置页面如图 8.9所示。 

 

图 8.9  “Width”设计规则设置页面 

一、基本属性 

设计规则的基本属性包括“Name”、“Comment”和“Unigue ID”三项，其中： 

“Name”属性表示设计规则的名称。 

“Comment”属性表示设计规则的注释描述。 

“Unique ID”表示设置规则的 ID 号。 

用户可以在对应的文本编辑框内设置这些基本属性，通常情况下，“Unique ID”由系

统指定。 

二、适用对象 

设计规则的适用对象用于指定在进行设计规则检查时的图元对象范围，根据设计规则所

描述的对象个数，设计规则可以分为一元设计规则和二元设计规则，所谓一元规则指该设计

规则及应用于独立的图元对象，例如“Width”设计规则即属于一元规则，该规则规定导线

的宽度范围，适用于单个铜膜导线对象，而“Clearance”设计规则属于二元规则，需要有两

个不同的导线对象才能测量间距，这样才能使用该规则。在二元规则选项视图中有“Where 

the first object matches”选项栏和“Where the Second object matches”选项栏用于分别设置二

元设计规则适用的两个对象的范围。 

在对应的设计规则适用对象选项区域右侧有“Full Query”区域，显示用户选择的适用

对象的“Query”表达式。 

在每个“Where the first object matches”选项栏或者“Where the Second object matches”

选项栏中有 6个单选项，意义如下。 

“All”单选项表示规则适用于 PCB板中的所有对象，但会默认设置该规则的优先级为
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最低。 

“Net”单选项表示规则适用于所选网络上的对象，包括线、圆弧、填充、焊盘和过孔。

用户可在选项栏右侧的下拉列表中选择当前的 PCB项目中已定义的网络名称。 

“Net Class” 单选项表示规则适用于所有属于所选网络类的网络上的对象，包括线、

圆弧、填充、焊盘和过孔以及用户自定义的网络类。用户可在选项右侧上方的下拉列表种选

择网络类的名称。关于自定义网络类的方法，将在接下来的小节中通过实例介绍。 

“Layer” 单选项表示规则适用于所有指定层上的对象。用户可在选项栏右侧上方的下

拉列表中选择需要设置的 PCB板层的名称。 

“Net and Layer” 单选项表示规则适用于在指定层上的指定网络对象。用户可在选项

栏的第一个下拉列表种选择 PCB板层的名称，在第二个下拉列表种选择网络的名称。 

“Advanced（Query）” 单选项表示使用“QueryBuilder”，建立应用对象表达式，表

明规则应用范围。单击“QueryBuilder”按钮，将打开 “QueryBuilder”对话框，用户可在

“QueryBuilder”对话框中用输入描述语句。 

三、规则约束设置 

规则约束设置区域内的选项用于设置规则的具体参数，由于每种设计规则的参数都不相

同，所以规则约束设置区域的内容会各不相同，关于规则约束设置的具体内容将在 8.2节中

具体介绍。 

8.2  设计规则介绍 

AltiumDesigner6.0提供了内容丰富、具体的设计规则， 根据设计规则的适用范围共分

为如下 10个类别，下面分别进行介绍。 

“Electrical”——电气规则类。 

“Routing”——布线规则类。 

“SMT”——SMT元件规则类。 

“Mask”——阻焊膜规则类。 

“Plane”——内部电源层规则类。 

“Testpoint”——测试点规则类。 

“Manufacturing”——制造规则类。 

“High Speed”——高速电路规则类。 

“Placement”——布局规则类。 

“Signal Integrity”——信号完整性规则类。 

8.2.1  “Electrical”规则类 

“Electrical”规则设置在电路板布线过程中所遵循的电气方面的规则，主要包括以下四

个具体的规则： 

1、“Clearance”设计规则 

“Clearance”设计规则的“Constraints”区域如图 8.10所示，该设计规则属于二元规则，

用于确定在 PCB的设计中，导线、导孔、焊盘、矩形敷铜填充等对象相互之间的最小距离。

如果布线中出现小于该距离，系统会报错。自动布线时，系统会根据设置的最佳间距指标进

行布线。 
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图 8.10  “Clearance”设计规则视图中的“Constraints”区域 

“Constraints”区域中的下拉列表用于设置应用规则的对象关系，该下拉列表共有三个

选项。 

“Different Net Only”项表示该规则应用于不同网络中的对象之间，即不同网络中的对

象之间的距离必须大于设置的安全距离。 

“Same Net Only” 项表示该规则应用于属于同一网络的图元对象之间，即相同网络中

的图元对象间的距离必须大于设置的安全距离。 

“Any Net”项表示该规则应用于所有网络，即 PCB板上的所有网络中的对象之间的距

离必须大于设置的安全距离。 

“Minimum Clearance”编辑框用于设置安全距离的长度。默认的情况下整个电路板上

的安全距离为 10mil。 

2、“Short-Circuit”设计规则 

“Short-Circuit”设计规则的“Constraints”区域如图 8.11所示，该设计规则属于一元规

则，该规则限制电路板上的导线之间是否允许信号线路短路。 

 

图 8.11  “Short-Circuit”设计规则视图中的“Constraints”区域 

“Allow Short-Circuit”复选项表示允许断路。选中该复选项，则规则允许短路，默认设

置为不允许短路。 

 3、“Un-Routed Net” 设计规则 

“Un-Routed Net”设计规则属于一元规则，用于检查指定范围内的网络是否完全布线，

如果网络尚未完全连通，该网络上已经布的导线将保留，没有成功布线的网络将保持飞线。

该规则的设计规则视图中的“Constraints”区域如图 8.12所示。该规则不需设置约束参数，

只要创建规则，设置基本属性和适用对象即可。 

 

图 8.12  “Un-Routed Net”设计规则视图中的“Constraints”区域 

4、“Un-Conneted Pin”设计规则 

“Un-Conneted Pin”设计规则无约束项，该规则属于一元规则，用于检查指定范围内的

元件封装的引脚是否连接成功。该规则也不需设置其它约束，只须要创建规则，设置基本属
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性和适用对象即可。 

8.2.2  “Routing”规则类 

“Routing”规则类包含所有与布线有相关的规则，总共有七个具体规则，介绍如下。 

1、“Width”设计规则 

“Width”设计规则用于限定布线时的铜膜导线的宽度范围。“Width”设计规则视图中

的“Constraints”区域如图 8.8所示。 

 

图 8.8  “Width”设计规则视图中的“Constraints”区域 

“Constraints”区域中的列表用于设置各布线层的铜膜导线的宽度约束参数。 

“Max Width”表示铜膜导线的最大宽度。 

“Preferred Width” 表示铜膜导线的推荐宽度。 

“Min Width” 表示铜膜导线的最小宽度。 

“Characteristic Impedance Driven Width”复选项表示通过设置电阻率的数据来设置铜膜

导线的宽度，选中该复选项后，用户只需要设置铜膜导线的最大、最小和推荐电阻率即可确

定铜膜导线的宽度规则。 

“Layers in layerstack Only”复选项表示仅仅列出当前 PCB文档中设置的层，选中该复

选项后，规则列表将仅显示现有的 PCB板层，如未选中该项，该列表将显示 PCB编辑器支

持的所有层。 

2、“Routing Topology” 设计规则 

“Routing Topology”设计规则用于选择布线过程中的拓扑规则。“Routing Topology”

设计规则视图中的“Constraints”区域如图 8.9所示。 
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图 8.9  “Routing Topology”设计规则视图中的“Constraints”区域 

“Topology”下拉列表用于设置拓扑规则。系统提供七种拓扑规则，具体意义如下。 

“Shortest”拓扑规则表示布线结果要求能够连通网络上的所有节点，并且使用的铜膜

导线的总长度最短。 

“Horizontal”拓扑规则表示布线结果能够连通网络上的所有节点，并且使用的铜膜导

线尽量处于水平方向。 

“Vertical”拓扑规则表示布线结果能够连通网络上的所有节点，并且使用的铜膜导线

尽量处于竖直方向。 

“Daisy Simple”拓扑规则表示在用户指定的起点和终点之间连通网络上的各个节点，

并且使连线最短。如果设计者没有指定起点和终点，此规则和“Shortest”拓扑规则的结果

是相同的。 

“Daisy Mid-Driven”拓扑规则表示以指定的起点为中心向两边的终点连通网络上的各

个节点，起点两边的中间节点数目要相同，并且使连线最短。如果设计者没有指定起点和两

个终点，系统将采用“DaisySimple”拓扑规则。 

“Daisy Balanced”拓扑规则表示将中间节点数平均分配成组，组的数目和终点数目相

同，一个中间节点组和一个终点相连接，所有的组都连接在同一个起点上，起点间用串联的

方法连接，并且使连线最短。如果设计者没有指定起点和终点，系统将采用“DaisySimple”

拓扑规则。 

“Star Burst”拓扑规则表示网络中的每个节点都直接和起点相连接，如果设计者指定了

终点，那么终点不直接和起点连接。如果没有指定起点，那么系统将试着轮流以每个节点作

为起点去连接其它各个节点，找出连线最短的一组连接作为网络的拓扑。 

以上各选项的示意图如图 8.10所示。 

 

图 8.10  各拓扑规则示意图 

三、“Routing Priority”设计规则 

“Routing Priority”规则用于设置布线的优先次序。布线优先级从“0”到“100”，“100”

是最高级，“0”是最低级。在“Routing Priority”栏里指定其布线的优先次序，即可。 

四、“Routing Layers” 设计规则 

“Routing Layers”规则用于设置布线板层走线的方式。“Routing Layers”设计规则视

图中的“Constraints”区域如图 8.11所示。 
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图 8.11  “Routing Layers”设计规则视图中的“Constraints”区域 

规则约束特性单元主要设置各个信号板层的走线方法，共有 32个布线板层设置项，其

中“Mid-Layerl”至“Mid-Layer30”是否高亮显示取决于电路板是否使用这些中间板层，系

统默认状态是使用顶层（Top Layer）和低层（Bottom Layer）。在设置项右侧的下拉列表中

设置走线方法，系统提供了 11种走线方法可选择，这些选项意义如下。 

“Not Used”项表示该层不走线。 

“Horizontal”项表示水平方向走线。 

“Vertical”项表示垂直方向走线。 

“Any”项表示任意方向走线。 

“1 O’Clock”项表示一点钟方向走线。 

“2 O’Clock”项表示两点钟方向走线。 

“4 O’Clock”项表示四点钟方向走线。 

“5 O’Clock”项表示五点钟方向走线。 

“45Up”项表示向上 45°方向走线。 

“45Down”项表示向下 45°方向走线。 

“FanOut”项表示以扇出方法走线。 

一般情况下，“Horizontal”项表示水平方向走线和“Vertical”项表示垂直方向走线用

于双面或多面板布线，其它走线方法用于单面板布线。 

五、“Routing Corners” 设计规则 

“RoutingComers” 设计规则用于设置导线的转角方法。“Routing Corners”设计规则

视图中的“Constraints”区域如图 8.12所示。 

 

图 8.12  “Routing Corners”设计规则视图中的“Constraints”区域 

“Style”下拉列表用于设置导线转角的形式，系统提供三种转角形式，“90 Degree”

项表示 90°转角方式。“45 Degree”项表示 45°转角方式。“Rounded”项表示圆弧转角

方式，这三种方式如图 8.13所示。 
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“90 Degree”        “45 Degree”           “Rounded” 

图 8.13  三种转角方式 

“Setback”编辑框用于设置导线的最小转角的大小，其设置随转角形式的不同而具有

不同的含义。如果是 90’转角，则没有此项；如果是 45’转角，则表示转角的高度；如果

是圆弧转角，则表示圆弧的半径。 

“To”编辑框用于设置导线转角的最大大小。 

六、“Routing Via Style” 设计规则 

“Routing Via Style”设计规则用于设置过孔的尺寸。“Routing Via Style”设计规则视

图中的“Constraints”区域如图 8.14所示。 

 

图 8.14  “Routing Via Style”设计规则视图中的“Constraints”区域 

“ViaDiameter”设置项用于设置过孔外径。其中“Minimum”编辑框用于设置最小的

过孔外径，“Maximum”编辑框用于设置最大的过孔外径，“Preferred” 编辑框用于设置

推荐的过孔外径。 

“ViaHoleSize”设置项用于设置过孔中心孔的直径。其中“Minimum”编辑框用于设

置最小的过孔中心孔的直径，“Maximum”编辑框用于设置最大的过孔中心孔的直径，

“Preferred” 编辑框用于设置推荐的过孔中心孔的直径。 

7、“Fanout Control” 设计规则 

“Fallout Control”规则用于设置 SMD扇出式布线控制。“Fanout Control” 设计规则

视图中的“Constraints”区域如图 8.15所示。 

 

图 8.15  “Fanout Control” 设计规则视图中的“Constraints”区域 
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系统默认设置了六种扇出式布线控制规则，大多情况下用户可以采用默认设置。 

8、“Differential Pairs Routing”设计规则 

“Differential Pairs Routing”设计规则用于设置压差信号通路的铜膜导线布线的要求，

为减少外部干扰，通常这种信号通路的铜膜导线要求成对平行布置。Altium Designer新增了

交互式差分对布线器，用户可使用交互式差分对布线器从差分对中选取一个导线连接，然后

对其进行布线。该差分对中的另一个导线将沿着第一根导线平行布线。交互式布线器将保持

指定布线宽度和间距，并提供巧妙利用过孔改变导线所在的层。“Differential Pairs Routing”

设计规则视图中的“Constraints”区域如图 8.16所示。 

 

图 8.16  “Differential Pairs Routing” 设计规则视图中的“Constraints”区域 

“Max Uncoupled Length”表示两条压差信号通路不相邻平行布置的最大长度。 

“Min Gap” 表示两条压差信号通路之间的最小间距。 

“Prefered Gap”表示两条压差信号通路之间的最佳间距。 

“Max Gap”表示两条压差信号通路之间的最大间距。 

8.2.3  “SMT”设计规则类 

“SMT”类规则主要设置 SMD元件引脚与布线之间的规则，共分为三个规则。 

一、“SMD TO Corner”设计规则 

“SMD TO Corner”设计规则用于设置 SMD 元件焊盘与导线拐角之间的最小距离。

“SMD TO Corner”设计规则视图中的“Constraints”区域如图 8.16所示。 

 

图 8.16  “SMD TO Corner”设计规则视图中的“Constraints”区域 

“Distance”编辑框用于设置“SMD”与导线拐角处的距离。 
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二、“SMD TO Plane” 设计规则 

“SMDToPlane” 设计规则用于设置 SMD 与电源层的焊盘或导孔之间的距离。其

“Constraints”区域仅有一个“Distance”选项，在该项中设置距离参数即可。 

三、“SMD Neck-Down” 设计规则 

“SMD Neck-Down” 设计规则用于设置 SMD 引出导线宽度与 SMD 元件焊盘宽度之

间的比值关系。“SMD Neck-Down”设计规则视图中的“Constraints”区域如图 8.17所示。 

 

图 8.17  “Constraints”设计规则视图中的“Constraints”区域 

“Neck-Down”编辑框用于设置 SMD元件焊盘宽度与导线宽度的比例。 

8.2.4  “Mask”规则类 

“Mask”规则类用于设置焊盘周围的阻焊层的尺寸，包括两个规则。 

一、“Solder Mask Expansion”设计规则 

“Solder Mask Expansion” 设计规则用于设置阻焊层中为焊盘留出的焊接空间与焊盘外

边沿之间的间隙，即阻焊层上面留出的用于焊接引脚的焊盘预留孔半径与焊盘的半径之差。

“Solder Mask Expansion”设计规则视图中的“Constraints”区域如图 8.18所示。 

 

图 8.18  “Solder Mask Expansion”设计规则视图中的“Constraints”区域 

 “Expansion”编辑框用于设置阻焊膜中为焊盘留出的焊接空间与焊盘之间的间隙。 

二、“Paste Mask Expansion”设计规则 

“Paste Mask Expansion”规则的“Constraints”区域如图 8.19所示，该规则用于设置表

面安装器件焊盘的延伸量，该延伸量是表面安装器件焊盘的边缘与镀锡区域边缘之间的距

离。“Paste Mask Expansion”设计规则视图中的“Constraints”区域如图 8.19所示。 
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图 8.19  “Paste Mask Expansion”设计规则视图中的“Constraints”区域 

“Expansion”编辑框表示表面安装器件的焊盘边缘与镀锡区域边缘之间的距离。 

8.2.5  “Plane”规则类 

 “Plane”规则类用于设置电源层和敷铜层的布线规则，共包含为三个规则。 

一、“Power Plane Connect Style” 设计规则 

 “PowerPlaneConnectStyle”设计规则用于设置过孔或焊盘与电源层连接的方法。

“PowerPlaneConnectStyle”设计规则视图中的“Constraints”区域如图 8.20所示。 

 

图 8.20  “PowerPlaneConnectStyle”设计规则视图中的“Constraints”区域 

“Connect Style”下拉列表用于设置电源层与过孔或焊盘的连接方法。系统提供三种方

法选择，“Relief Connect”项表示放射状连接，“Direct Connect”项表示直接连接，“No Connect”

项表示不连接。 

“Connectors”栏用于设置焊盘或过孔与铜膜之间的连接点的数量，有“2”和“4”两

种设置。如图 8.21所示分别为为 2点和 4点连接时的电源层连接方式。 

     

2 点连接                         4点连接 

图 8.21  2点和 4 点连接时的电源层连接方式 

“Conductor Width”编辑框用于设置连接铜膜的宽度。 

“Air-Gap”编辑框用于设置空隙大小。 

“Expansion”编辑框用于设置焊盘或过孔的内外半径之差。 

二、“Power Plane Clearance”设计规则 
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“Power Plane Clearance”设计规则用于设置电源板层与穿过它的焊盘或过孔间的安全

距离。“Power Plane Clearance”设计规则视图中的“Constraints”区域如图 8.21所示。 

 

图 8.21  “Power Plane Clearance”设计规则视图中的“Constraints”区域 

“Clearance”表示穿过电源层的过孔与电源层上的预留空间之间的最小距离。 

三、“Polygon Connect Style”设计规则 

“Polygon Connect Style”设计规则用于设置多边形敷铜与焊盘之间的连接方法。

“Polygon Connect Style”设计规则视图中的“Constraints”区域如图 8.22所示。 

 

图 8.22  “Polygon Connect Style”设计规则视图中的“Constraints”区域 

“Connect Style”下拉列表用于设置敷铜层与焊盘的连接方法。“Relief Connect”项表

示放射状连接。“Direct Connect”项表示直接连接。“No Connect”项表示不连接。 

“Connectors”栏用于设置敷铜与焊盘之间的连接点的数量，有“2”和“4”两种设置。 

“Conductor Width”编辑框用于设置连接铜膜的宽度。 

连接角度下拉列表用于设置在放射状连接时敷铜与焊盘的连接角度，有“90Angle”连

接和“45Angle”连接两种连接形式。 

8.2.6  “Testpoint”规则类 

“Testpoint”规则类中的规则用于设置测试点的形状大小及其使用方法，其下有两个规

则。 

  一、“Testpoint Style”设计规则 

“Testpoint Style”规则用于设置测试点的形状和大小。“Testpoint Style”设计规则视

图中的“Constraints”区域如图 8.23所示。 
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图 8.23  “Testpoint Style”设计规则视图中的“Constraints”区域 

“Style”列表用于设置测试点的大小。其中“Size”设置测试点的外径尺寸，“Hole Size”

设置测试点的孔径尺寸。 

“GridSize”栏用于设置格点的大小。“Testpoint grid size”编辑框内键入尺寸。 

“Allowed SideandOrder”列表设置允许作为测试点的板层和组件。 

“Allow testpoint under component”复选框用于设置允许在元件封装的下面出现测试点。 

二、“Test Point Usage”设计规则 

“Test Point Usage”规则用于设置测试点的用法。“Test Point Usage”设计规则视图中

的“Constraints”区域如图 8.24所示。 

 

图 8.24  “Test Point Usage”设计规则视图中的“Constraints”区域 

“Allow multiple testpoints on same net”复选框用于设置在同一条网络上是否允许多个 

测试点存在。 

“Testpoint”栏设置测试点有效、无效和忽略。 

8.2.7  “Manufacturing”规则类 

“Manufacturing”规则类主要设置与电路板制造有关的项，共有四个规则。 

一、“Minimum Annular Ring”设计规则 

“Minimum AnnularRing” 设计规则用于设置最小环宽，即焊盘或导孔与其通孔之间的

直径之差。“Minimum Annular Ring”设计规则视图中的“Constraints”区域如图 8.25所示。 
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图 8.25  “Minimum Annular Ring”设计规则视图中的“Constraints”区域 

“Minimum Annular Ring （X-Y）”编辑框设置最小环宽，该参数的设置应参考数控钻

孔设备的加工误差，以避免电路中的环状焊盘或过孔在加工时出现缺口。 

二、“Acute Angle”设计规则 

“Acute Angle” 设计规则视图中的“Constraints”区域如图 8.26所示。该设计规则用

于设置具有电气特性的导线与导线之间的最小夹角。建议该设计规则中的最小夹角设置应该

大于 90°，避免在蚀刻加工后，导线夹角处残留药物，导致过度蚀刻。 

 

图 8.26  “Acute Angle”设计规则视图中的“Constraints”区域 

在“Minimum Angle”编辑框设置最小夹角。 

三、“Hole Size”设计规则 

“Hole Size”设计规则用于孔径尺寸设置。“Hole Size”设计规则视图中的“Constraints”

区域如图 8.27所示。 

 

图 8.27  “Hole Size”设计规则视图中的“Constraints”区域 

“Measurement Method”编辑框用于设置尺寸表示的形式。共有两种方式可供选择，其

中“Absolute”项表示以绝对尺寸设置约束尺寸，“Percent”项表示使用百分比的方式设置

约束尺寸。 

“Minimum”编辑框用于设置最小孔尺寸。 

“Maximum”编辑框用于设置最大孔尺寸。 

四、“Layer Pairs”设计规则 

“Layer Pairs”规则用于设置是否允许在多层板设计中使用板层对。当前使用的板层对
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由板子上使用过的过孔和焊盘来确定层与层的组合。 

通过“Layer Pairs”设计规则视图中的“Constraints”区域中的“Enforce layer pairs settings”

复选项设置是否使用板层对。 

8.2.8  “High Speed”规则类 

“High Speed”规则类中的规则用于设置与高频电路设计有关的规则。共包含六项规则。 

一、“Parallel Segment”设计规则 

“Parallel Segment”设计规则视图中的“Constraints”区域如图 8.28所示，该设计规则

用于设置并行导线的长度最大值和距离最小值。 

 

图 8.28  “Parallel Segment”设计规则视图中的“Constraints”区域 

“Layer Checking”下拉列表用于设置该规则在多层板 PCB的情况下的适用范围。其中

“Same Layer”项表示仅检查同一层 PCB 板中是否出现违反设计规则的情况，“Adjacent 

Layers”项表示还要检查相邻 PCB板层之间是否有并行走线过长的现象。 

“For a parallel gap of”编辑框用于设置并行走线的最小距离。 

“The parallel Limit is”编辑框用于设置并行导线允许的并行长度。 

二、“Length”设计规则 

“Length”设计规则用于设置网络的最大和最小长度。“Length”设计规则视图中的

“Constraints”区域如图 8.29所示。 

 

图 8.29  “Length”设计规则视图中的“Constraints”区域 

“Minimum”栏用于设置铜膜导线的最小长度。 

“Maximum”栏用于设置铜膜导线的最大长度。 

三、“Matched Net Lengths” 设计规则 

“Matched Net Lengths” 设计规则视图中的“Constraints”区域如图 8.30所示。该设计

规则用于设置网络等长匹配布线。为了保证高速电路中的信号传输同步，在布线时要求信号

传输线之间的长度要尽量相同，为此设置了“Matched Net Lengths”设计规则，该规则以用
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户设置的设计规则范围中的最长铜膜导线为基准，在其它布线网络中增加折线，使这些导线

的长度在设定的公差范围内相等。 

    

图 8.30  “Matched Net Lengths” 设计规则视图中的“Constraints”区域 

“Amplitude”编辑框用于设置匹配折线的振幅。 

“Style”下拉列表用于设置匹配折线的形式。单击右边的下拉式按钮，系统提供了三种

选项。“90Degree”项表示折线的拐角都是 90°的。“45Degree”项表示折线的夹角都是

45°的。“Rounded”项表示折线采取圆弧波形走线方式。这三种模式如图 8.31所示。 

 

“90Degree”          “45Degree”                  “Rounded”   

图 8.31  三种匹配折线形式 

“Tolerance”编辑框用于设置匹配折线的长度误差。 

“Gap”编辑框用于设置折线间的间距。 

四、“Daisy Chain Stub Length” 设计规则 

为了防止信号在导线分支处损失过大，制定了“Daisy Chain Stub Length” 设计规则，

“Daisy Chain Stub Length”设计规则视图中的“Constraints”区域如图 8.32所示，该设计规

则设置布线过程中出现菊花链走线时，支线的最大长度。 

 

图 8.32  “Daisy Chain Stub Length”设计规则视图中的“Constraints”区域 

“MaximumStubLength” 编辑框用于设置支线的长度。 
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五、“Vias Under SMD” 设计规则 

“Vias Under SMD”设计规则用于设置是否允许在 SMD焊盘下放置过孔。“Vias Under 

SMD”设计规则视图中的“Constraints”区域如图 8.33所示。 

 

图 8.33  “Vias Under SMD”设计规则视图中的“Constraints”区域 

“Allow Vias under SMD Pads”复选框设置允许在 SMD焊盘下放置过孔。 

六、“MaximumViaCount”设计规则 

在高速电路板上，过多的过孔会导致信号干扰，影响电路中的信号质量。“Maximum Via 

Count”设计规则用于设置一块电路板上允许的最大过孔数量。在设计规则视图中的

“Constraints”区域仅包含一个“Maximum Via Count”编辑框，用于设置过孔数目的最大

值。 

8.2.9  “Placement”规则类 

“Placement”规则类用于约束元件的布置，共有 6个规则。 

一、“Room Definition” 设计规则 

“Room Definition”设计规则视图中的“Constraints”区域如图 8.34所示，该设计规则

用于定义元件区域的尺寸及其所在的板层。 

 

图 8.34  “Room Definition”设计规则视图中的“Constraints”区域 

“Room Locked”复选项用于设置锁定元件区域。 

“Define”按钮用于设置元件区域的大小。单击按钮后，光标变成十字状并激活 PCB

编辑区，用鼠标确定元件区域的大小。 

“X1”、“Y1”、“X2”和“Y2”编辑框用于设置元件区域的对角顶点的坐标，元件

区域的大小也可以通过该栏的坐标设置。 

元件区域可以布置到顶层或底层，通过在倒数第二个下拉菜单中选择“Top Layer”项

或者“Bottom Layer”项，设置元件合所在的板层。 
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“Constraints”区域的最下部的下拉菜单用于设置元件相对于元件区域的位置。“Keep 

Objects lnside”项表示元件放在元件区域以内。“Keep Objects Outside”项表示元件放在元

件区域以外。元件一旦被放置在元件合中，这些元件将随元件合一起移动。 

二、“Component Clearance”设计规则 

“Component Clearance”设计规则视图中的“Constraints”区域如图 8.35所示，该设计

规则用于设置元件之间的最小距离。 

 

图 8.35  “Component Clearance”设计规则视图中的“Constraints”区域 

“CheckMode”下拉列表用于设置设计规则的检查模式。系统提供了四种模式供选择。 

“Quick Check”项表示快速检查模式。“MultiLayer Check”项表示多层检查模式。“FullCheck”

项表示全面检查模式。“Use Component Bodies”项表示使用电路元件的三维外形来检查元

件之间的距离，选择该项可以保证在不影响破坏实际元件间距值的情况下，使电路的布局更

加紧凑。 

三、“Component Orientation”设计规则 

“Component Orientation”设计规则视图中的“Constraints”区域如图 8.36所示，该设

计规则用于设置 PCB板中元件自动布局时，元件 PCB封装的放置方向。 

 

图 8.36  “Component Orientation”设计规则视图中的“Constraints”区域 

“Allowed Orientations”设置元件封装的允许放置方向。其中有五个角度复选项，允许

选择多个布置方向。 

四、“Permifled Layer”设计规则 

“Permitted Layer”设计规则视图中的“Constraints”区域如图 8.37所示，该设计规则

用于限置 PCB板中元件自动布局时元件封装的放置板层。 
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图 8.37  “PermittedLayer”设计规则视图中的“Constraints”区域 

“Permitted Layer”项用于设置元件封装的放置板层。“Top Layer”和“Bottom Layer”

复选框分别表示允许在顶层和底层布置元件封装。 

五、“Nets to Ignore”设计规则 

“Nets to Ignore”设计规则用于设置自动布局时忽略的网络。组群式自动布局时，忽略

电源网络可以使得布局速度和质量有所提高。该设计规则只需要设置适用的网络范围即可。 

六、“Height”设计规则 

“Height”设计规则用于设置在电路板上放置组件的高度。“Height”设计规则视图中

的“Constraints”区域如图 8.38所示。 

 

图 8.38  “Height”设计规则视图中的“Constraints”区域 

“Minimum”编辑框用于设置允许组件放置的最小高度。 

“Preferred” 编辑框用于设置允许组件放置的推荐高度。 

“Maximum”编辑框用于设置允许组件放置的最大高度。 

8.2.10  “Signal Integrity”规则类 

“Signal Integrity”规则类用于约束信号完整性分析，共有 13项： 

一、“Signal Stimulus” 

“Signal Stimulus”规则用于设置电路分析的激励信号。“Signal Stimulus”设计规则视

图中的“Constraints”区域如图 8.39所示。 
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图 8.39  “Signal Stimulus”设计规则视图中的“Constraints”区域 

“Stimulus Kind”下拉列表用于设置信号的种类。系统提供了三种选择，“Constant Level”

项表示直流电信号，“Signal Pulse”项表示单脉冲信号，“Periodic Pulse”项表示周期脉冲

信号。 

“Start Level”下拉列表用于设置信号的初始状态。系统提供两种选择，“Low Level”

项表示低电平，“High Level”项表示高电平。 

“Start Time（s）”编辑框用于设置信号开始时间。 

“StopTime（s）” 编辑框用于设置信号停止时间。 

“Period Tune（s）” 编辑框用于设置信号的周期。 

二、“Over shoot-Falling Edge”设计规则 

“Overshoot-Falling Edge” 设计规则视图中的“Constraints”区域如图 8.40所示，该设

计规则用于设置信号下降沿的震荡超调幅度。 

 

图 8.40  “Overshoot-Falling Edge” 设计规则视图中的“Constraints”区域 

“Maximum（Volts）”编辑框用于设置最大超调电压幅度。 

三、“Over shoot-Rising Edge”设计规则 

“Overshoot-Rising Edge”设计规则视图中的“Constraints”区域如图 8.41所示，该设

计规则用于设置信号上升沿的震荡超调幅度。 

 

图 8.41  “Overshoot-Rising Edge”设计规则视图中的“Constraints”区域 

“Maximum（Volts）”编辑框用于设置最大超调电压幅度。 

四、“Undershoot-Falling Edge”设计规则 

“Undershoot-Falling Edge”设计规则视图中的“Constraints”区域如图 8.42所示，该设

计规则用于设置信号下降沿欠调电压的最大值。 
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图 8.42  “Undershoot-Falling Edge”设计规则视图中的“Constraints”区域 

“Maximum（Volts）” 编辑框用于设置最大欠调电压。 

五、“Undershoot-Rising Edge”设计规则 

“Undershoot-Rising Edge”  设计规则用于设置信号上升沿欠调电压的最大值。

“Undershoot-Rising Edge”设计规则视图中的“Constraints”区域如图 8.43所示。 

 

图 8.43  “Undershoot-Rising Edge”设计规则视图中的“Constraints”区域 

“Maximum（Volts）”编辑框用于设置最大欠调电压。 

六、“Impedance”设计规则 

“Impedance”设计规则视图中的“Constraints”区域如图 8.44 所示，该设计规则用于

设置电路的最大和最小阻抗。 

 

图 8.44  “Impedance”设计规则视图中的“Constraints”区域 

“Minimum（Ohms）”编辑框用于设置最小阻抗。 

“Maximum（Ohms）”编辑框用于设置最大阻抗。 

七、“Signal Top Value”设计规则 

“Signal Top Value”设计规则视图中的“Constraints”区域如图 8.45所示，该设计规则

用于设置高电平信号最小电压。 

tyw藏书



第 8 章  PCB板设计规则 

 ·304·   

 

图 8.45  “Signal Top Value”设计规则视图中的“Constraints”区域 

“Minimum（Volts）”编辑框用于设置高电平信号的最小电压。 

八、“Signal Base Value”设计规则 

“Signal Base Value”设计规则视图中的“Constraints”区域如图 8.46所示，该设计规

则用于设置信号电压基值。 

 

图 8.46  “Signal Base Value”设计规则视图中的“Constraints”区域 

“Maximum（Volts）” 编辑框用于设置最大基值电压幅度。 

九、“Flight Time-Rising Edge”设计规则 

“Hight Time-Rising Edge”设计规则视图中的“Constraints”区域如图 8.47所示，该设

计规则用于设置信号上升沿的上升时间。 

 

图 8.47  “Hight Time-Rising Edge”设计规则视图中的“Constraints”区域 

“Maximum（Seconds）”编辑框用于设置最大上升时间。 

十、“Flight Time-Falling Edge”设计规则 

“Flight Time-Falling Edge”设计规则视图中的“Constraints”区域如图 8.48所示，该设

计规则用于设置信号下降沿的下降时间。 
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图 8.48  “Flight Time-Falling Edge”设计规则视图中的“Constraints”区域 

“Maximum（Seconds）”编辑框设置最大延迟时间。 

十一、“Slope-Rising Edge”设计规则 

“Slope-Rising Edge”设计规则视图中的“Constraints”区域如图 8.49所示，该设计规

则用于设置信号从阈值电压上升到高电平电压的上升时间。 

 

图 8.49  “Slope-Rising Edge”设计规则视图中的“Constraints”区域 

“Maximum（Seconds）”编辑框设置最大延迟时间。 

十二、“Slope-Falling Edge”设计规则 

“Slope-Falling Edge”设计规则视图中的“Constraints”区域如图 8.50所示。该设计规

则用于设置信号下降沿从阈值电压下降到低电平电压的最大延迟时间。 

 

图 8.50  “Slope-Falling Edge”设计规则视图中的“Constraints”区域 

“Maximum（Seconds）”编辑框用于设置最大延迟时间值，数字后面的“n”表示单位

为纳秒。 

十三、“Supply Nets”设计规则 

“SupplyNets”设计规则用于设置电路板中电源网络的电压值。“SupplyNets”设计规

则视图中的“Constraints”区域内的“Voltage”编辑框用于设置电源电压值。 
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8.3  设计规则向导 

Protel DXP 2004提供了设计规则向导，帮助用户完成设计规则的设置，本节将通过一

个设计规则设置的实例，介绍使用设计规则向导设置设计规则的步骤。 

（1）在主菜单中选择“Design”->“RuleWizard…”命令，启动设计规则向导，打开如

图 8.50所示的“New Rule Wizard”对话框，显示“Design Rule Wizard”视图。 

 

图 8.51  “New Rule Wizard”对话框 

（2）单击“Next”按钮，显示如图 8.52所示的“Choose the Rule Type”视图。 

 

图 8.52  “Choose the Rule Type”视图 

（3）在“Choose the Rule Type”视图内的“Name”栏中输入规则的名称，“Comment”

栏中输入规则的特性描述。选择需要设置的规则类型后，单击“Next”按钮，显示如图 8.53

所示的“Choose the Rule Scope”视图。 
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图 8.53   “Choose the Rule Scope”视图 

（4）在如图 8.53所示的规则适用范围设置对话框中选择规则使用的范围，如果选中的

不是“Whole Board”项，单击“Next”按钮将显示如图 8.54所示的“Advanced Rule Scope”

视图。 

 

图 8.54  “Advanced Rule Scope”视图 

（5）在“ConditionType／Operator”和“ConditionValue”列中设置规则的范围和条件。

完成适用范围高级设置后，单击“Next”按钮，显示如图 8.55所示的“Choose the Rule Priority”

视图。 
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图 8.55  “Choose the Rule Priority”视图 

（6）通过单击“Decrease Priority”按钮可将所选的规则优先级下降一级，通过单击

“Increase Priority”按钮可将所选的规则优先级升高一级。单击“Next”按钮，显示如图 8.56

所示的“The New Rule is Complete”视图。 

 

图 8.56  “The New Rule is Complete”视图 

（7）设置完毕后，单击“Finish”按钮，系统弹出 8.57所示的“PCB Rules and Constraints 

Editor”对话框，单击“Close”按钮关闭该对话框即可将规则设置保存。 
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图 8.57  “PCB Rules and Constraints Editor”对话框 

至此，使用设计规则向导设置设计规则的任务完成。 
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第 9章  PCB项目输出 

在完成了 PCB板的设计后，接下来的工作就是将加工设计好的 PCB板，通常 PCB板

的加工制作要求使用专用的设备，这些设备要求输入各种类型的加工文件，例如 PCB组合

底片文件“Gerber”、数控钻文件“NC drill”、元件插放文件“Pick and Place”等。有的

PCB加工企业会要求客户提供这些 CAM 文件，本章将介绍使用 Altium Designer输出以上

项目资料的方法。 

9.1  生成 Gerber文件 

Gerber是一种光绘机专用的计算机语言，包括一系列的绘图指令以及坐标信息。Gerber

文件中用—系列绘图码（或命令）和坐标来描述绘图。绘图码控制光绘机的镜头光圈、开关

光源等。坐标定义网上各种点和线的位置，这些信息以 ASCII 码文本文件保存。用户在完

成 PCB的设计后，在加工 PCB板之前，需要生成 Gerber文件，然后将 Gerber文件输入到

光绘机中，生成制造 PCB板所需要的电路胶片。Altium Designer提供了自动生成 Gerber文

件的功能，当 PCB设计工作完成后，Altium Designer就可以根据 PCB文件产生对应的 Gerber

文件，PCB板的每一个层都需要产生一个 Gerber文件。 

本节将通过一个实例介绍生成 Gerber文件的方法，生成 Gerber文件的步骤如下。 

（1）启动 Altium Designer，打开已完成的 PCB板文件。 

（2）在主菜单中选择“File”->“Fabrication Output”->“Gerber Files”命令，打开如

图 9.1所示的“Gerber Setup”对话框。 

 

图 9.1  “Gerber Setup”对话框 

“Gerber Setup”对话框包括五个选项卡，在第一次输出“Gerber”文件时，需要对这些

选项进行一一设置。 

（3）单击“General”选项卡标签，打开如图 9.1所示的“General”选项卡，该选项卡
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用于设置产生 Gerber文件的单位和数据格式。 

（4）在“Units”区域中选择“Inches”项。将 Gerber文件的单位设置为英制，如果选

择“millimeters”，则表示使用公制单位。 

（5）在“Format”区域中选择“2：4”设置坐标数据的精度为 0.1mil。 

如果选择“2：3”项，则表示坐标数据精确到 1mil，选择“2：5”项表示坐标数据精确

到“0.01mil”。精度的选择必须与 PCB工作区内实体的放置精度匹配，精度越高对光绘和

制造设备的要求就越高。 

（6）单击“Layers”选项卡标签，打开如图 9.2所示的“Layers”选项卡，该选项卡用

于设置需要产生 Gerber文件的层。 

 

图 9.2  “Layers”选项卡 

（7）在“Plot/Mirror Layers”列表中选择需要生成 Gerber文件的层，勾选这些层对应

的“Plot”项，如果需要对某一层图形进行镜像，勾选该层对应的“Mirror”项。 

（8）在右侧的“Mechanical Layer to Add to All Plots”列表中勾选需要在各层的 Gerber

中出现的机械层。 

（9）勾选“Include unconnected mid-layer pads”复选项，设置在 Gerber中绘出未连接

的中间层焊盘。 

（10）单击“Drill Drawing”选项卡标签，打开如图 9.3所示的“Drill Drawing”选项卡，

该选项卡主要用于设置钻孔层。 
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图 9.3  “Drill Drawing”选项卡 

（11）在“Drill Drawing Plots”区域勾选“Plot all used layer pairs”复选项，设置绘制

所用到的所有层对的钻孔信息。在“Drill Drawing Symbol”栏中选择“Graphic symbols”单

选项，设置采用图形标注的方式显示钻孔图中的孔符号。 

在“Drill Drawing Symbol”栏中“Size of hole string”单选项表示采用字符串标注，

“Characters” 单选项表示采用字符标注。“Symbol size”编辑框用于设置标注符号的大小。 

（12）在“Drill Guide Plots”区域中勾选“Plot all used layer pairs”复选项，设置绘制

所用到的所有层对的导孔图。 

（13）单击“Apertures”选项卡标签，打开如图 9.4所示的“Apertures”选项卡，该选

项卡用于设置产生 Gerber文件时建立光圈表的选项。 

 

图 9.4  “Apertures”选项卡 

（14）选择“Embedded Apertures”选项，设置自动建立光圈表，然后按照“RS274X”

标准将光圈表嵌入到 Gerber文件中。 

（15）单击“Advanced”选项卡标签，打开如图 9.5所示的“Advanced”选项卡，该选

项卡用于设置与光绘胶片相关的选项。 

tyw藏书



第 9 章  PCB项目输出 

 ·313·   

 

图 9.5  “Advanced”选项卡 

（16）在“FilmSize”区域中的“X（horizontal）” 编辑框内输入胶片的横向尺寸，在

“Y（vertical）”编辑框内输入胶片的纵向尺寸，在“Border size”编辑框内输入边框的尺

寸。 

（17）在“Leading/Trailing Zeroes”区域中选择“Supress leading zeroes”单选项，设置

处理数字数据文件时压缩多余的前导零字符。 

（18）在“Aperture Matching Tolerances”区域设置绘图与 D 码表匹配的公差范围，在

“Plus”编辑框内输入公差上限，在“Mirus”编辑框内输入公差下限。 

（19）在“Position on Film”区域内选择“Reference to relative origin”项，设置图形在

胶片上按照图形之间的相对位置布置。 

（20）在“Batch Mode”区域选择“Separatefile per layer”项，设置每层 PCB板生成一

个 Gerber文件。 

对于不同的 PCB层，Gerber绘图文件会自动附加一个特殊的扩展名，Altium Designer

输出的 Gerber文件的扩展名如下。 

“TopOverlay”层生成的 Gerber文件的扩展名称为“.GTO”。 

“Bottom Overlay”层生成的 Gerber文件的扩展名称为“.GBO”。 

“TopLayer”层生成的 Gerber文件的扩展名称为“.GTL”。 

“Bottom Layer”层生成的 Gerber文件的扩展名称为“.GBL”。 

“MidLayer 1”、“MidLayer 2”等中间层生成的 Gerber文件的扩展名称为“.G1”、

“G2”等。 

“PowerPlane 1”、“PowerPlane 2”等电源层生成的 Gerber文件的扩展名称为“.GPl”、

“GP2”等。 

“MechanicalLayer l”、“MechanicalLayer 2”等机械层生成的 Gerber文件的扩展名称

为“.GMl”“GM2”等。 

“Top SolderMask”顶层镀锡层生成的 Gerber文件的扩展名称为“.GTS”。 

“Bottom SolderMask”底层镀锡层生成的 Gerber文件的扩展名称为“.GBS”。 

“Top PasteMask”顶层粘贴层生成的 Gerber文件的扩展名称为“.GTP”。 

“BottomPasteMask”底层粘贴层生成的 Gerber文件的扩展名称为“.GBP”。 
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“DrillDrawing”钻通孔层生成的 Gerber文件的扩展名称为“·GDD”。 

“DrillDrawing ToptoMid 1”，“DrillDrawing Mid2toMid3”等中间钻孔层生成的 Gerber

文件的扩展名称为“.GDl”、“.GD2”等。 

“DrillGuide”层生成的 Gerber文件的扩展名称为“.GDG”。 

“DrillGuide ToptoMid l”、“Mid2toMid3”等层生成的 Gerber文件的扩展名称为“.GGl”、

“.GG2”、“.GG3”等。 

“PadMaster Top”顶层焊盘层生成的 Gerber文件的扩展名称为“.GPT”。 

“PadMaster Bottom”底层焊盘层生成的 Gerber文件的扩展名称为“.GPB”。 

“KeepOutLayer”层生成的 Gerber文件的扩展名称为“.GKO”。 

（21）在“Plotter Type”区域选择光绘的形式，“Unsorted（raster）”表示光栅式方式

进行光绘，“sorted（vector）”表示矢量式光绘。该选项要根据光绘机的类型来进行选择，

不同的光绘方式，生成的 Gerber文件各不相同。 

（22）在“Other”区域用于设置 G54语句和软件光绘圆弧等选项。 

（23）在“Gerber Setup”对话框中完成 Gerber的参数的设置后，单击“OK”按钮，执

行产生 Gerber文件命令。 

所有按照设置生成的 Gerber文件，保存在项目路径下的“Generated Documents”文件

夹中，并自动调入 CAMtastic!界面，生成 CAMtasticl．CAM 文件，进行制造板图的检查、

校验、图形编辑等工作，如图 9.6所示。 

 

图 9.6  打开的 CAMtasticl．CAM 文件 

（24）单击标准工具栏中的保存工具按钮 ，保存生成的文件。 

 

9.2  输出数控钻孔 NC Drill 文件 

钻孔是 PCB板加工过程的一道重要工序，生产商需要设计者提供数控钻孔文件，以控

制数控钻床完成 PCB板的钻孔工作。钻孔设备需要读取 NC Drill 类型的钻孔文件，文件中

包含每个孔的坐标和使用的钻孔刀具等信息。通常有 3 种类型钻孔文件。分别是“.DRR”

文件，“.TXT”文件和“.DRL”文件。对于多层带有盲孔和埋孔的 PCB，每个层对产生单

独的带有惟一扩展名的钻孔文件。 
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AltiumDesigner6.0提供了由 PCB文档自动生成钻孔文件的功能，输出 NC Drill 文件的

具体步骤如下。 

（1）启动 Altium Designer，打开需要生成钻孔文件的 PCB项目文档，打开对应的 PCB

图文件。 

（2）在主菜单中选择“File”->“Fabrication Output”->“NC Drill Files”命令，打开

如图 9.7所示的“NC Drill Setup”对话框。 

 

图 9.7  “NC Drill Setup”对话框 

（3）在“NC Drill Format”区域内设置输出数控钻孔文件的格式。其中的选项意义与

Gerber文件相同，系统要求生成的 NC Drill 文件应和 Gerber文件具有相同的格式和精度。 

（4）在“Leading/Trailing Zeroes”区域内选择“Suppress leading zeroes”项，设置压缩

数据文件中多余的零字符。 

（5）在“Coordinate Positions”区域中选择“Reference to absolute origin”单选项，设

置使用绝对原点，“Reference to relative origin”单选项表示使用用户设置的相对原点。 

（6）在“Others”选项区域中勾选“Generate separate NC Drill files for plated & non-plated 

holes”项，设置单独生成镀金孔和非镀金孔的钻孔文件。 

（7）“NC Drill Setup”对话框中完成 NC Drill 文件参数设置后，单击 OK 按钮，打开

如图 9.8所示的“Import Drill Data”对话框。 
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图 9.8  “Import Drill Data”对话框 

（8）在“Import Drill Data”对话框中设置长度单位和默认孔的尺寸，单击“OK”按钮。

生成钻孔 NC Drill 文件。 

生成的钻孔文件保存在与项目文件同路径的“Generated TextFiles”文件夹下。系统自

动进入 CAMtastic!界面，并加载输出文件。在 CAM 中，用户可进一步检查钻孔数据，生成

的钻孔文件如图 9.9所示。 

 

图 9.9  生成的钻孔文件 

（9）单击标准工具栏中的保存工具按钮 ，保存生成的文件。 

9.3  输出 ODB++文件 

ODB++（Open Data Base）开放式数据库由 Valor公司推出，其出现是现代计算机、数

据库发展的结果，适应当今设计制造一体化的要求，可以真正实现将 DFM 规则嵌入设计过

程，逐渐形成 PCB设计与制造之间的通用沟通。 

ODB++是一种可扩展的 ASCII 格式，它可在单个数据库中保存 PCB制造和装配所必需

的全部工程数据。单个数据库即可包含图形、钻孔信息、布线、元件、网表、规格、绘图、

工程处理定义、报表功能、ECO和 DFM 结果等。 

输出 ODB++文件的步骤如下。 

（1）启动 Altium Designer，打开需要生成钻孔文件的 PCB项目文档，打开对应的 PCB
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图文件。 

（2）在主菜单中选择“File”->“Fabrication Output”->“ODB++Files”命令，打开如

图 9.10所示的“ODB++Setup”对话框。 

 

图 9.10  “ODB++Setup”对话框 

（3）在“Select Layers to Plot”列表中选择 ODB++文件的输出层。 

（4）在“Mechanical Layer（s） to Add to All Plots”编辑框中勾选“Merchanical 1”，

将机械层加到 ODB++输出文件中。 

（5）在“Miscellaneous Options”区域取消“Unconnected Pads”选项的勾选状态，设

置生成的 ODB++文件中不包括未连接的焊盘，勾选“Generate DRC Rules”项，设置建立

DRC规则输出文件。 

（6）在“ODB++Setup”对话框右下部的轮廓选择下拉列表中选择“Board Outline”设

置生成的 ODB++文件预览层的轮廓。 

（7）在“ODB++Setup”对话框中完成 ODB++文件的参数设置后，单击“OK”按钮，

打开如图 9.11所示的“Steps Table”对话框。 

 

图 9.11  “Steps Table”对话框 

系统自动打开 CAMtastic界面，并加载所设置的输出到 CAM 编辑器。 

（8）单击标准工具栏中的保存工具按钮 ，保存生成的文件。 
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9.4  输出 PCB板报表 

PCB 板报表提供用户电路板的完整信息，包括电路板尺寸、电路板上的焊盘、导孔的

数量以及电路板上的元件标号等。输出 PCB板报表的步骤如下。 

（1）启动 Altium Designer，打开需要生成钻孔文件的 PCB项目文档，打开对应的 PCB

图文件。 

（2）在主菜单中选择“Reports”->“Board Information …”命令，打开如图 9.12所示

的“PCB Information”对话框。 

 

图 9.12  “PCB Information”对话框 

（3）单击“General”选项卡标签，显示如图 9.12所示的“General”选项卡，该选项卡

主要显示电路板的常规信息，包括电路板的大小、导线数、焊盘和焊孔数等。 

（4）单击“Components”选项卡标签，显示如图 9.13所示的“Components”选项卡，

该选项卡用于显示当前电路板上使用的元件信息，包括元件封装序号及其所在的板层信息。 

 

图 9.13  “Components”选项卡 

（5）单击“Nets”选项卡标签，显示如图 9.14所示的“Nets”选项卡，该选项卡用于

显示当前电路板中的网络信息。 
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图 9.14  “Nets”选项卡 

（6）单击“Nets”选项卡中的“Pw/Gnd”按钮，打开如图 9.15所示的“Internal Plane 

Information”对话框。 

 

图 9.15  “Internal Plane Information”对话框 

该对话框列出了各个内层所连接的网络、导孔、焊盘等之间的连接关系。每一个内层用

一个页面显示。 

（4）检查完 PCB板的内层信息后，单击“Close”按钮，关闭“Internal Plane Information”

对话框，然后单击“PCB Information”对话框中的“Report”按钮，打开如图 9.16所示的“Board 

Report”对话框。 
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图 9.16  “Board Report”对话框 

（5）在如图 9.16所示的“Board Report”对话框中勾选在报表文件中包含的内容或信

息。单击“Report”按钮，生成如图 9.17所示的“.REP”文件。 

 

图 9.17  生成的“.REP”文件 

（6）单击标准工具栏中的保存工具按钮 ，保存生成的文件。 

至此，PCB板报表就输出完毕了。 
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第 10章  PCB元件封装库的编辑 

为方便用户处理设计中的 PCB元件封装，Altium Designer提供了 PCB元件封装编辑器，

用户可以在该编辑器中对 PCB 元件封装库进行编辑操作，包括复制 PCB 元件封装，删除

PCB元件封装、新建自定义的 PCB元件封装以及修改 PCB元件封装等等操作。本章将简单

介绍 PCB元件封装编辑器，然后通过两个具体实例介绍使用元件封装编辑器自定义 PCB元

件封装的具体步骤。 

10.1  PCB元件封装编辑器 

PCB元件封装编辑器在用户新建或打开一个 PCB元件封装库文件后，将会自动启动，

其工作界面如图 10.1所示。 

 

图 10.1  PCB元件封装编辑器工作界面 

与 PCB图编辑器界面相比，PCB元件封装编辑器界面少了一些布线的工具栏，多了一

个名为“PCB Library”的工作面板，该工作面板用于管理 PCB元件封装库中的元件封装。 

10.2  PCB元件封装管理 

在 PCB元件封装编辑器的“PCB Library”工作面板中，用户可对 PCB元件封装库中的

PCB元件封装进行管理，进行复制、粘贴、导入、删除 PCB元件封装操作，本节将通过实

例介绍这些常用 PCB元件封装管理操作的具体步骤 

10.2.1  复制 PCB元件封装 

当需要从 PCB原件封装的复制过程比较简单，通过复制名为“BNC_RA CON”的 PCB
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元件封装到用户自定义的 PCB元件封装库中的实例，介绍复制 PCB元件封装的方法。 

（1）打开包含有需要复制的 PCB元件封装的 PCB元件封装库文件，启动 PCB元件封

装编辑器，本例中选择通用 PCB元件封装。 

（2）单击工作区左侧的“PCB Library”工作面板标签，打开如图 10.2 所示的“PCB 

Library”工作面板。 

 

图 10.2  “PCB Library”工作面板 

（3）在“PCB Library”工作面板上方的“Mask”编辑框中输入“BNC*”，将所有名

称前三个字母为“BNC”的 PCB元件封装筛选出来。筛选结果将在“Components”列表中

显示。 

（4）在“PCB Library”工作面板中的“Components”列表中的选择名为“BNC_RA CON”

的 PCB元件封装，单击鼠标右键，弹出如图 10.3的右键菜单。 

 

图 10.3  右键菜单 

（5）在右键菜单中选择“Copy”命令，复制已选中的名为“BNC_RA CON”的 PCB
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元件封装。 

（6）在主菜单中选择“File”->“New”->“Library”->“PBC Library”命令，新建一

个默认名称为“PcbLib1.PcbLib”的新 PCB元件封装库。 

（7）在新 PCB元件封装库的“PCB Library”工作面板中的“Components”列表中单击

鼠标右键，在弹出的菜单中选择“Paste 1 component”命令，将名为“BNC_RA CON”的

PCB元件封装复制到新的 PCB元件封装库中。 

（8）单击工具栏中的保存按钮 ，在弹出的“Save[PcbLib1.PcbLib]As”对话框中设置

文件名称为“Custom_Pcb.PcbLib”，单击“保存”按钮，保存该 PCB元件封装库文件。 

10.2.2  导入旧版本 PCB封装 

在许多工作中，用户常需要导入以前版本的 Protel元件封装库，已便能使用以前的工作

成果，减小重复劳动，本节将通过一个导入 Protel99版本的 PCB元件库的实例介绍使用旧

版本 PCB封装文件的方法。 

（1）单击工具栏中的打开按钮 ，打开“Choose Document to Open”对话框。 

（2）在“Choose Document to Open”对话框中选择 Protel 99版本的后缀为“.DDB”的

PCB元件封装库文件，然后单击“打开”按钮，系统显示如图 10.4所示的“Confirm”提示

框。 

 

图 10.4  “Confirm”提示框 

该“Confirm”提示框提示用户，导入 DDB 文件前，要关闭所有当前文档和项目，如果

用户同意关闭当前的文档和项目，可以单击“Yes”按钮，否则单击“No”按钮，终止文件

的导入。 

（3）单击“Confirm”提示框中的“Yes”按钮，系统自动关闭当前所有文档和项目，

打开如图 10.5所示的“99 SE Import Wizard”对话框。 
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图 10.5  “99 SE Import Wizard”对话框 

（4）单击“Next”按钮，“99 SE Import Wizard”导入向导显示如图 10.6所示的“Choose 

files or folders to import”页面 

 

图 10.6  “Choose files or folders to import”页面 

“Choose files or folders to import”页面用于设置需要导入的文件，如果用户需要批量导

入文件，可以单击左侧的“Folders To Process”列表下方的“Add”按钮，打开“浏览文件

夹”对话框，选择需要批量导入的文件所在的目录，这样可以一次将所选目录下的所有

“.DDB”文件全部导入。如果需要一次导入多个“.DDB”文件，可以单击右侧的“Files To 

Process”列表下方的“Add”按钮，打开“浏览文件夹”对话框，选择需要批量导入的文件。 

（5）单击“Next”按钮，打开如图 10.7所示的“Set file extraction options”页面。 
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图 10.7  “Set file extraction options”页面 

“Set file extraction options”页面中的“Output Folder”编辑框用于设置导入后的文件保

存的路径。 

（6）在“Set file extraction options”页面中单击“Output Folder”编辑框右侧的浏览按

钮 ，打开“浏览文件夹”对话框，在“浏览文件夹”对话框内选择导入文件的保存路径，

单击“确定”按钮，然后单击“Set file extraction options”页面中的“Next”按钮，打开如

图 10.8所示的“Set Schematic conversion option”页面。 

 

图 10.8  “Set Schematic conversion option”页面 

“Set Schematic conversion option”页面用于设置原理图导入选项，本例中没有原理图，

所以不需要设置该页面。 

（7）单击“Next”按钮，打开如图 10.9所示的“Set Import options”页面。 
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图 10.9  “Set Import options”页面 

“Set Import options”页面用于设置导入过程选项，其中“Project Mapping Option”选

项区域中的选项意义如下。 

“Creat one Altium Designer project for each DDB”单选项表示针对每个“.DDB”文件都

创建一个 Altium Designer项目。 

“Creat one Altium Designer project for each DDB Folder” 单选项表示对每个“.DDB”

文件的文件夹，将其中的“.DDB”文件内容都包含在同一个 Altium Designer项目中。 

“Include non-Protel files（such as PDF or Word）in created Projects”复选项表示将原”

“.DDB”文件中包含的非 Protel格式的其他文件，例如“.PDF”或“.Word”文件也包含在

转换后的 Altium Designer项目中。 

（8）勾选“Creat one Altium Designer project for each DDB”单选项和“Include non-Protel 

files（such as PDF or Word）in created Projects”复选项，单击“Next”按钮，打开如图 10.10

所示的“Analyzing DDBs”页面。 
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图 10.10  “Analyzing DDBs”页面 

“Analyzing DDBs”页面显示系统调用所有选中的 DDB 文件，分析其中的内容的过程

进度，通常该过程会很快，当分析结束后，系统自动打开如图 10.11所示的“Select Design files 

to import”页面。 

 

图 10.11  “Select Design files to import”页面 

“Select Design files to import”页面中的列表中显示“Choose files or folders to import”

页面中所有的 DDB 文件，勾选需要导入的“.DDB”文件。 

（9）勾选“.DDB”文件，单击“Next”按钮，打开如图 10.12所示的“Review project 

creation”页面。 

 

图 10.12 “Review project creation”页面 

“Review project creation”页面中的列表中显示即将进行的每个 DDB 文件的导入设置，

用户可以在“Mapping”栏中修改每个“.DDB”文件的设置，在“Documents to Add”栏中
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修改导入文件的设置。 

（10）单击“Review project creation”页面中的“Next”按钮，打开如图 10.13所示的

“Import summary”页面。 

 

图 10.13  “Import summary”页面 

（11）确认“Import summary”页面中显示的之前设置的导入过程选项信息，单击“Next”

按钮，开始导入过程，导入完成后，显示如图 10.14所示的“Importing is done.Choose workspace 

to open”页面。 

 

图 10.14  “Importing is done.Choose workspace to open”页面 

（12）选择“Importing is done.Choose workspace to open”页面中列表内新建的工作空

间，单击“Next”按钮，打开如图 10.15所示的“Protel 99 SE DDB Import Wizard is complete”

页面。 
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图 10.15  “Protel 99 SE DDB Import Wizard is complete”页面 

（13）单击“Protel 99 SE DDB Import Wizard is complete”页面中的“Finish”按钮，完

成导入过程。系统会自动打开导入后生成的 Altium Designer项目。 

10.3自定义 PCB元件封装 

在 PCB元件封装编辑器环境中，用户可手工定义 PCB元件封装，本节将通过一个手工

定义 PCB元件封装的实例，介绍手工定义 PCB元件封装的方法，该实例定义了一个固定到

电路板边缘的 DB25接头的 PCB封装，完成后的 PCB元件封装图如图 10.16所示。 

 

图 10.16  完成后的 PCB元件封装图 

（1）启动 Altium Designer，在主菜单中选择“File”->“Open”命令，打开“Choose Document 

to Open”对话框，在该对话框中选择 10.2.1节中新建的“Custom.PcbLib”库文件，启动 PCB

元件封装编辑器。 

（2）单击工作区左侧的“PCB Library”工作面板标签，打开“PCB Library”工作面板。 

（3）在“PCB Library”工作面板的“Component”列表中选中的“PCBCOMPONENT_1”

栏，在主菜单中选择“Tools”->“Component Properties”命令，打开如图 10.17所示的“PCB 
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Library Component”对话框。 

 

图 10.17  “PCB Library Component”对话框 

（4）在“PCB Library Component”对话框的“Name”编辑框内输入“D-Connector Edge”，

将新建的文件名称改为“D-Connector Edge”，单击“OK”按钮，关闭“PCB Library Component”

对话框。 

（5）在工作区单击鼠标右键，在弹出的如图 10.18所示的菜单中选择“Library Options…”

命令，打开如图 10.19所示的“Broad Options”对话框。 

 

图 10.18  右键菜单 

 

图 10.19  “Broad Options”对话框 

（6）将“Broad Options”对话框的“Unit”设置为“Imperial”，设置“Snap Grid”选
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项区域的 X、Y 值都为 5mil，设置“Visible Grid”选项区域的“Grid1”的值为“5mil”，

“Grid2”的值为“100mil”，然后单击“OK”按钮，完成设置。 

（7）单击工作区下部的“Top Layer”层标签，选择顶层“Top Layer”为当前编辑层。 

（8）单击工具栏中的布置焊盘工具按钮 ，单击键盘的“Tab”键，打开如图 10.20所

示的“Pad”对话框。 

 

图 10.20  “Pad”对话框 

（9）在“Pad”对话框中单击“Hole Size”项，输入新的数据“0mil”，在“Designator”

选项区域中设置“Designator”项为“1”，设置“Layer”项为“Top Overlay”；在“Size and 

Shape”选项区域设置焊盘的形式为“Simple”，设置“X-size”为“60mil”，“Y-size”为

“150mil”，“Shape”项为“Rectangle”，单击“OK”按钮，结束设置。 

（10）在工作区坐标为（660，-300）的位置单击鼠标，布置如图 10.21所示的编号为 1

的焊盘。 

 

图 10.21  布置的编号为 1 的焊盘 

（11）再次单击键盘的“Tab”键，打开“Pad”对话框。 

（12）在“Pad”对话框中的“Size and Shape”选项区域中选择“Shape”为“Round”，

保持其他选项，单击“OK”按钮，关闭“Pad”对话框。 

（13）依次在工作区坐标为（550，-300）、（440，-300）、（330，-300）、（220，

-300）、（110，-300）、（0,-300）、（-110，-300）、（-220，-300）、（-330，-300）、
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（-440，-300）、（-550，-300）和（-660，-300）共 12个点上单击鼠标左键，布置如图 10.22

所示的编号为“2”~“13”的 12个焊盘，布置完成后，单击鼠标右键，结束“Top Layer”

上的焊盘布置操作。 

 

图 10.22  “Top”层布置的焊盘 

（14）单击工作区下方的“Botton Layer” 层标签，选择底层“Botton Layer”为当前

编辑层。 

（15）单击工具栏中的布置焊盘工具按钮 ，依次在工作区坐标为（-605，-300）、（-495，

-300）、（-385，-300）、（-275，-300）、（-165，-300）、（-55,-300）、（55，-300）、

（165，-300）、（275，-300）、（385，-300）、（495，-300）和（605，-300）共 12 个

点上单击鼠标左键，布置如图 10.23所示的编号为“14”~“25”的 12个焊盘，布置完成后，

单击鼠标右键，结束“Botton Layer”上的焊盘布置操作。 

 

图 10.23  “Botton”层布置的焊盘 

（16）单击工作区下方的“Top Overlay”层标签，选择顶层丝印层“Top Overlay”为

当前编辑层。 

（17）单击工具栏中的布置直线工具按钮 ，或者在主菜单中选择“Place”->“Line”

命令，启动绘制直线命令。 

（18）依次在工作区坐标分别为（-1000，0）、（1000，0）、（1000，20）、（-1000，

20）和（-1000 mil，0）的点上单击鼠标，绘制如图 10.24所示的线框，然后单击鼠标右键，

结束直线的绘制。 

 

图 10.24  绘制的线框 
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（19）按照第（18）布介绍的绘制线框的方法，绘制如图 10.25所示的其他图线框。 

 

图 10.25  绘制的图线 

（20）在工作区的空白部分绘制如图 10.26所示的 U 型线段，U 型线段的高为“120”，

宽为“100”。 

 

图 10.26  绘制的 U 型线段 

（21）使用鼠标选中绘制好的 U 型线段，选择菜单命令“Edit”->“Copy”，或者使用

快捷键“Ctrl+C”复制 U 型线段到剪贴板中。 

（22）单击工具栏中的阵列复制工具按钮 ，打开如图 10.27所示的“Setup Paste Array”

对话框。 

 

图 10.27  “Setup Paste Array”对话框 

（23）在“Setup Paste Array”对话框中的“Placement Varaible”选项区域内设置“Item 

Count”项为“8”，即一次粘贴 8个对象。在“Array Type”选项区域内选择“Linear”项，
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设置阵列粘贴的方式为线性阵列，最后在“Linear Array”选项区域内的“X-Spacing”编辑

框内输入“150mil”，在“Y-Spacing”编辑框内输入“0mil”，设置阵列粘贴后，每个对象

之间的水平间距为“150mil”，垂直间距为 0，单击“OK”按钮，对剪贴板中的 U 形线框

进行阵列粘贴。粘贴后的结果如图 10.28所示。 

 

图 10.28  阵列粘贴后的效果 

（24）选择步骤（20）中绘制的 U 形线段，单击键盘“Del”键，将其删除。 

（25）选择主菜单“File”->“Save”命令，或直接单击工具栏的保存按钮 ，保存新

建的元件。 

10.4  利用向导生成 PCB元件封装 

对于符合标准的 PCB元件封装，如果采用手工方式定义，定义的过程比较繁琐，容易

出现错误，针对这种情况，Altium Designer为用户提供了 PCB元件封装向导，帮助用户完

成焊盘较多的 PCB元件封装的制作，本节将通过一个实例，介绍使用 PCB元件封装向导生

成 PCB元件封装的步骤。 

（1）启动 Altium Designer，在主菜单中选择“File”->“Open”命令，打开“Choose Document 

to Open”对话框，在该对话框中选择 10.2.1节中新建的“Custom.PcbLib”库文件，启动 PCB

元件封装编辑器。 

（2）在主菜单中选择“Tools”->“Component Wizard”命令，或者直接在“PCB Library”

工作面板的“Component”列表中单击右键，在弹出的菜单中选择“Component Wizard…”

命令，打开如图 10.29所示的“Component Wizard”对话框，显示“PCB Component Wizard”

页面。 
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图 10.29  “Component Wizard”对话框 

（3）单击“Component Wizard”对话框中的“Next”按钮，显示如图 10.30 所示的

“Component patterns”页面。 

 

图 10.30  “Component patterns”页面 

（4）在“Component patterns”页面中选择“Dual In-Line Package（DIP）”项，在“Select 

a unit”下拉列表中选择“Imperial（mil）”，单击“Next”按钮，打开如图 10.31所示的“Dual 

In-Line Package（DIP）”页面，显示“Define the pads dimensions”视图。 
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图 10.31  “Define the pads dimensions”视图 

“Define the pads dimensions”视图用于设置焊盘的尺寸。 

（5）“Define the pads dimensions”视图中的示意图左侧的焊盘尺寸编辑框中设置焊盘

的纵向尺寸为“60mil”，设置焊盘中孔的直径为“25mil”，设置焊盘横向外径为“60mil”

单击“Next”按钮，显示如图 10.32所示的显示“Define the pads layout”视图。 

 

图 10.32  “Define the pads layout”视图 

“Define the pads layout”视图用于设置焊盘之间的间距。 

（6）接受默认间距，单击“Next”按钮，显示如图 10.33所示的“Define the outline width”

视图。 
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图 10.33  “Define the outline width”视图 

“Define the outline width”视图用于设置丝印线框中的线的宽度。 

（7）单击“Define the outline width”视图中的线框的导线宽度尺寸标注，将其文字改

为“8mil”，设置轮廓线的宽度为 8mil，然后单击“Next”按钮，显示如图 10.34所示的“Set 

number of the pads”视图。 

 

图 10.34  “Set number of the pads”视图 

“Set number of the pads”视图用于设置元件封装中引脚焊盘的数量。 

（8）“Set number of the pads”视图中的编辑框中输入“14”，设置焊盘总数为“14”，

单击“Next”按钮，显示如图 10.35所示的“Set the component name”页面。 
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图 10.35  “Set the component name”页面 

“Set the component name”页面用于设置元件封装的名称。 

（9）在“Set the component name”页面中的编辑框中输入“DIP14-100”，作为 PCB

元件封装的名称，单击“Next”按钮，显示如图 10.36所示的结束视图。 

 

图 10.36  PCB元件封装向导结束视图 

（10）单击 PCB元件封装向导结束视图中的“Finish”按钮，创建的 PCB元件封装如

图 10.37所示。 
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图 10.37  生成的 PCB元件封装 

（11）选择主菜单中的“File”->“Save”命令，或单击标准工具栏中的保存工具按钮 ，

保存该 PCB元件封装库。 
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