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1.  Altium 历史，以及产品介绍 (20 minutes) 

1.1 Altium 历史介绍 

Altium(前身为 Protel 国际有限公司)由 Nick Martin 于 1985 年始创于塔斯马尼亚州霍巴

特，致力于开发基于 PC 的软件，为印刷电路板提供辅助的设计。 初的 DOS 环境下的 PCB 

设计工具在澳大利亚得到了电子业界的广泛接受，在 1986 年中期，Altium 通过经销商将设计

软件包出口到美国和欧洲。随着 PCB 设计软件包的成功，Altium 公司开始扩大其产品范围，

包括原理图输入、PCB 自动布线和自动 PCB 器件布局软件。 

80 年代晚期，Altium 公司意识到在开发利用 Microsoft Windows 作为平台的电子设计自动

化 EDA 软件方面存在商机。虽然 Windows 平台在处理性能和可靠性上取得了进步，但当时很

少有用于 Windows 平台的 EDA 软件,而当时越来越多的设计工程师使用基于 Windows 的操作

系统。于是，在 1991 年 Altium 公司发布了世界上第一个基于 Windows 的 PCB 设计系统，

Advanced PCB。在后来几年里，凭借各种产品附加功能和增强功能所带来的好处，Altium 建

立了具有创新意识的 EDA 软件开发商的地位。 

1997 年，Altium 公司认识到越来越需要把所有核心 EDA 软件工具集中到一个集成软件包

中，从而可以实现从设计概念直到生产的无缝集成。因此 Altium 发布了专为 Windows NT 平台

构建的 Protel98，这是首次将所有 5 种核心 EDA 工具集成于一体的产品，这 5 种核心 EDA 工

具包括原理图输入、可编程逻辑器件(PLD)设计、仿真、板卡设计和自动布线。随后在 1999 年

又发布了 Protel 99 和第二个版本 Protel 99 SE，这些版本提供了更高的设计流程自动化程度，

进一步集成了各种设计工具，并引进了“设计浏览器”平台。设计浏览器平台允许对电子设计的

各方面——设计工具、文档管理、器件库等——进行无缝集成，它是 Altium 建立涵盖所有电子

设计技术的完全集成化设计系统理念的起点。藉此，Altium 公司成功进行首次公开募股

（IPO），于 1999 年 8 月在澳大利亚股票市场上市。所筹集的资金用于在 2000 年 1 月收购适

当的公司和技术，包括收购 ACCELTechnologies 公司、Metamor 公司、Innovative CAD 

Software 公司和 TASKING BV 公司等。拥有了这些技术，Altium 公司终于在 2000 年进入 

FPGA 设计和综合市场，并于 2001 年进入嵌入式软件开发市场。 

为了更好的反映公司是在嵌入式领域、FPGA 设计领域以及 EDA 市场拥有多个品牌的新

的市场地位，Protel International 公司在 2001 年 8 月 6 日正式更名为 Altium 有限公司。新公

司的名称可以代表所有产品品牌，并为未来发展提供一个统一的平台。 

Altium 公司致力于产品开发，并为工程师提供帮助他们实现目标的 佳设计工具，这是公

司成功的关键。2002 年，Altium 公司重新设计了设计浏览器（DXP）平台，并发布第一个在新

DXP 平台上使用的产品（Protel DXP）。Protel DXP 是 EDA 行业内第一个可以在单个应用程

序中完成整个板设计处理的工具。如今，公司总部位于澳大利亚悉尼的 Frenchs Forest 区，在
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悉尼和欧洲进行研发。公司在澳大利亚、美国、日本、中国和欧洲设有多个销售与支持办事

处，在其他许多主要市场，包括中国、印度、英国等地拥有代理销售网络。Altium 公司的客户

包括 IBM、NASA、Motorola、Hewlett-Packard、Canon、Fujitsu、Bosch、Siemens、

Delphi、NEC、Sony、BMW、Alcatel、Daimler-Benz、Philips、CSIRO、Nokia 以及 Telstra 

等公司。Altium 公司的行业合作伙伴包括 Mitsubishi、Infineon、Intel, STMicroElectronics、

Atmel、 Analog Devices 和 Philips 等。 

Altium 公司目前的生产线包括：Altium Designer、P-CAD、TASKING 和一系列用于交互式

FPGA 设计的硬件产品，如 NanoBoard2。 
1.2   Altium Designer 产品介绍 

Altium Designer 基于一个软件集成平台，把为电子产品开发提供完整环境所需的工具全部整合

在一个应用软件中。  

Altium Designer 包含所有设计任务所需的工具：原理图和 HDL 设计输入、电路仿真、信号完整

性分析、PCB 设计、基于 FPGA 的嵌入式系统设计和开发。另外可对 Altium Designer 工作环境加以

定制，以满足用户的各种不同需求。  

1.2.1 Altium Designer 集成平台 

当您执行菜单命令[开始]-[所有程序]-[Altium Designer]启动 Altium Designer 时，您实际在启动 

DXP.EXE 文件。Altium Designer 基于 DXP 平台，支持创建设计时使用的各种编辑器。  

应用界面通过自动配置来适应正在处理的文件。例如，打开原理图时，将激活相应的工具栏、

菜单和快捷键。此性能意味着您可以随意在 PCB 布线、物料清单编制、瞬态电路分析和其它操作之

间进行切换，当前菜单、工具栏和快捷键始终保持可用。  

另外还可根据您的偏好对所有工具栏、菜单和快捷键进行配置。 
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图  1. Altium Designer 软的 件集成构架’ 

1.2.2 用于 FPGA 及嵌入式智能设计的硬件平台 

     

 
图 2 可重构的硬件验证平台 NanoBoard2 
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图 2 所示，为配合 Altium Designer 软件进行 FPGA 以及嵌入式智能设计的可重构的硬件验证

平台。该验证平台与 Altium Designer 一起组成了可进行实时设计 Live Design 的创新平台

Innovation station。在这个创新平台下，设计者可进行 FPGA 以及嵌入式软件的设计，调试以及验

证。可重构的硬件验证平台 NanoBoard2 可以通过可插拔的 FPGA 子板支持独立于各 FPGA 源厂商

的设计，设计成果可选择下载到不同的 FPGA 厂商的不同芯片中去。NanoBoard2 周围的可插拔的

外设板可以按照设计者的需要进行配置，实现可重构的硬件验证平台的功能。 

1.3 公司理念 
"Historically, the most advanced, state of the art design tools have been prohibitively priced, 

with access being limited to engineers based in the few companies that could afford them. The 

Altium vision – unchanged since the company’s inception – is to break down these barriers to 

innovation and technological advancement and provide every engineer and system designer with 

easy access to the best possible design tools.“——Nick Martin, Founder & Joint CEO 

“长久以来，大多数高端的设计工具以其昂贵的价格，限制了工程师只能在少数公司中使用。

而 Altium 公司一贯的理念就是打破传统的价格束缚，以先进的技术为广大工程师及系统设计人员提

供 适合的设计工具。” 

Innovation 的概念。Altium 的 Altium Designer 设计软件致力于革新的电子产品设计平台，为广

大的工程师提供统一的一体化的电子设计环境，让工程师们集中精力于推出不断创新的下一代电子

产品。 
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2. DXP 系统平台介绍                       (5 minutes) 

当你从开始菜单选择 Programs » Altium » Altium Designer 运行软件时实际是运行

DXP.EXE。Altium Designer 下的 DXP 平台可以使各位工程师完成你们的设计，应用接口自动地配

置成适合您工作的文本。例如，当你打开一张原理图文件，工具栏、菜单和快捷键都被激活。这个

功能意味着当你设计 PCB、生成 BOM 表、电路仿真等工作的时候与之相关的工具栏菜单和快捷键

都将被激活。 

所有的工具栏、菜单和快捷键也可以被用户自定义为自己熟悉的排列方式。 

 
图 3 Altium Design 的软件集成结构 

 

      
图 4 项目结构图 

一个项目 

设计文件 

库文件 

输出文件 
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图 4 所示为一个完整的项目结构图，一个项目可以包含多个设计文件，包括原理图设计文件，

PCB 设计文件等等。同时还包含有项目输出文件，以及设计中所用到的库文件。  

2.1 项目以及工作区介绍 

 项目是每项电子产品设计的基础。  

 项目将设计元素链接起来，包括源原理图、PCB、网表和欲预保留在项目中的所有库或

模型。  

 项目还能存储项目级选项设置，例如错误检查设置、多层连接模式和多通道标注方案。  

 项目共有 6 种类型 – PCB 项目、FPGA 项目、内核项目、嵌入式项目、脚本项目和库封

装项目（集成库的源）。  

 Altium Designer 允许您通过 Projects 面板访问与项目相关的所有文档。 

 还可在通用的 Workspace（工作空间）中链接相关项目，轻松访问与您公司目前正在开

发的某种产品相关的所有文档。  

 在将如原理图图纸之类的文档添加到项目时，项目文件中将会加入每个文档的链接。这

些文档可以存储在网络的任何位置，无需与项目文件放置于同一文件夹。若这些文档的

确存在于项目文件所在目录或子目录之外，则在 Projects 面板中，这些文档图标上会显

示小箭头标记。 

2.2 DXP 系统菜单 

DXP 的系统菜章提供了配置软件环境的命令，你可以用选中左上角主菜单旁边的 DXP 图标使

用这些命令，DXP 按钮在任何工作界面都可以找到。 
 

 
图 5 在 DXP 菜单下配置设计环境 

接下来一节将描述 DXP 系统菜单的定义。 

2.2.1 定制 

菜单对当前工作界面相关联的资源进行管理。 
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2.2.2  Preferences 参数选项 

不同的全局系统参数可以在 DXP 环境下被定义，包括资料备份和自动保存，系统字体的使用，

工程面板的显示，环境查看参数包括弹出和隐藏面板，使能版本控制接口。在 Altium Designer 下，

也可以为每一工作界面设置不同的参数设计，例如原理图设计和 PCB 设计，设定 Altium Designer

环境参数，选择 DXP 菜单下的 Preferences 选项，这将会弹出图 6 的参数设置对话框。 

 
图 6 参数设置对话框，用于配置 Altium Designer 和所有工作界面的参数 

 

Altium Designer 支持两种文件自动备份模式： 

 Backup-on-save—保存一个备份，无论初始用户是否执行保存的动作（默认），这些

文件将保存在历史文件夹中。默认值是建立一个历史文件夹在当前激活的项目文件夹

下，去配置一个可选的中央文件夹，来打开参数对话框中版本控制的本地历史页。历史

文件显示在 Storage Manager 面板上的历史部分中。 

 Timed backup—在所有打开的文档里，在固定的时间间隔下自动保存文件，自动保存

的设定，例如文件的数量和保存的频率，可以在 DXP 系统下的参数选项对话框中的

Backup 页中被配置。 

两种备份模式都支持多重拷贝，命名使用的惯例：原始文件名.~(保存的数量).文档扩展名.Zip 备

份的文件会被自动压缩以减少文件的体积。 
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2.2.3 运行进程 

从 DXP 系统下选择 Run Process 命令按钮，可在 Run Process 对话框里，允话你运行任何的

进程。 

2.2.4 注册 

从 DXP 系统下选择 Licensing 命令可以显示 Licensing View，在这里你可以选择或是配置许可

的类型—网络版或者单机版。 

2.2.5 脚本运行和脚本运行调试器 

在 Altium Designer 中包含了一个强大的脚本系统，支持类似 Windows 平台下的 VB 脚本语言

和 Java 脚本语言的内嵌 DelphiScript 语言。 

内嵌的 DelphiScrip 脚本语言像一个 Pascal 语言一样。它是一个完整的设计接口组织，允许快

速创建对话框。 

选择 Run Script 选项会弹出 Select Item to Run 对话框，选中脚本的名字可执行在当前文档上

的脚本。 

选择 Run Script Debugger 将打开脚本调制器，你可以在这里设置断点、脚本单步执行等等。 

在 Knowledge Center 面板里的 Configuring the System 文件下有更多关于 Scripting 的脚

本设置文件介绍。 

2.2.6 练习—配置 Altium Designer 系统的参数选项 

1. 打开 DXP 参数选项对话框，选中对话框中的不同选项，去了解什么选项可被设置，修改后

的原理图和 PCB 工作界面选项在以后的课程中将会被重新覆盖。 

2. 在 Preferences 对话框中的 View 页面取消 Use animation 功能，减少 Hide delay 选项。 

3. 关闭参数项页面 

4. 把鼠标放在工作区的右手边上的 Libraries 标签上，将看到弹出的面板如何受到影响，然

后鼠标移开 Libraries 面板验证 hide delay。 
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3.  Altium Designer 设计环境       (30minutes) 

Altium Designer 操作环境由两个主要部分组成：  

 Altium Designer 主要文档编辑区域，如图 7 右边所示。 

 Workspace 面板。Altium Designer 有很多操作面板，默认设置为一些面板放置在应用程

序的左边，一些面板可以弹出的方式在右边打开，一些面板呈浮动状态，另外一些面板

则为隐藏状态。  

打开 Altium Designer 时， 常见的初始任务显示在特殊视图 Home Page 中，以方便选用。 

 

Figure7. Altium Designer， DXP Home Page 已打开. 

注意：要移动单个面板，请单击并按住面板名称。要移动一套面板，请单击并按住面板标题

栏，将其拖离面板名称。要避免面板重叠，请按住 CTRL 键。要将面板悬停模式更改为弹出模式，

请单击面板顶部的管脚小图标；要恢复悬停模式，请再次单击管脚图标。 
 

3.1      文档编辑器总览 

不同种类的文档在相应的文档编辑器中进行编辑，例如 PCB 文档使用 PCB Editor 编辑、原理图

文档使用 Schematic Editor 编辑、VHDL 文档使用 VHDL 编辑器编辑。图 8 为在 Schematic Editor 中

打开原理图文档进行编辑。 

DXP System Menu 
Use this menu to set 
up system preferences 
and customize the 
environment. All other 
menus and toolbars 
automatically change 
to suit the document 
being edited. 

Workspace panels 
These include Files 
and Projects panels. 
These panels can be 
moved, docked or 
clipped by clicking on 
the panel title and 
dragging it to a new 
location. 
Click on the tab at the 
bottom of the panel to 
display its contents.  Panel Control 

Editor specific and 
shared panels can be 
displayed using these 
Panel buttons.  

View Navigation 
Click on the arrows 
to go back and forth 
between views. 

Workspace panels 
More pop out panels 
are displayed by 
clicking on these tabs. 
These panels can also 
be moved, docked or 
clipped. 

Home Page Design View
Common tasks are listed 
to get started quickly. 

Document bar 
A tab appears for 
each open document.
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图 8. 打开准备在 Schematic Editor 视图中编辑的原理图文档. 

3.1.1 文档栏中的文档标签 

打开的文档在应用程序顶部都分配有一个标签。单击相关标签可显示该文档并使其处于活动状

态以便于编辑

 

图 9. 标签显示了打开的各种文档，注意 PCB 标签高亮显示表示当前正在编辑该文档. 

文档栏的右键菜单 

 右键单击文档栏的任何文档标签。  

 从出现的浮动菜单中选择 Tile All。所有打开的文档将平铺在多项窗口区域中。 

注意：区域的数量取决于打开文档的数量。 

 右键单击文档标签。 

 选择 Close。 

 将鼠标指针置于两个分割窗口的交汇处，将显示双箭头图标。单击并拖动可调整尺寸。 

 右键单击平铺窗口中的任一标签，并选择 Merge All。请注意您已将分割窗口还原为单

一视图。 

注意：Altium Designer 支持多个显示器。若您的 PC 具有多个显示器，您可右键单击文档，使

用 Open in New Window 命令打开另一个 Altium Designer 应用程序，然后在第二个显示器上操作。 
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3.2       练习－Altium Designe 导航系统 

3.2.1 使用 Projects 面板 

1. 打开 4 Port Serial Interface.PRJPCB，文件目录为 \Altium Designer 6\Examples\Reference 

Designs\4 Port Serial Interface 文件夹。 

2. 导航树内容。 

3. 双击打开 Projects 面板中的单个文档。 

4. 双击打开 Projects 面板中更多一些文件。 

3.2.2  Design Window navigation 
1. 右键单击文档栏上的文档标签，选择 Tile All。 

2. 单击并拖动任一文档标签，将其拖放到另一文档标签的旁边。 

3. 右键单击多个窗口中的任一标签，并选择 Merge All。 

4. 逐项关闭打开的文档。 

注意：文档栏中标签的行为都由 Preferences 对话框中 System – View 页面上的选项控制。 
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4.  Altium 免费资源，支持及帮助中心                               
(15 Minutes)  

4.1 免费网络培训 

每周我们有定期的免费网络培训，针对 Altium Designer 中每一个功能有一个主题。在网络培训

时可以针对这个主题进行详细的演示以及问题解答。               

4.2 中文论坛  

 通过用户名和密码安全登陆 

 用户有权使用唯一的资源进行研发。 

 用户或 Altium 的全体员工（包括研发，即使是 CEO）可发贴回复 

 全球用户每天 24 小时不停解答疑难。 

 为中文用户专门开通有中文论坛，用户可在论坛中通过下载资料，提出问题等方法寻求

技术支持。 

 

图 10 Altium 交流论坛首页 
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4.3 网络培训中心及知识中心 

4.3.1 演示中心 

演示中心通过http://www.altium.com/Evaluate/DemoCenter/进入。当有新功能添加的时候我们

会对视频进行更新。 

 
图 11  演示中心可用的短片 
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4.3.2 训中心 

 
图 12  当前培训中心可用的材料清单 

4.3.3 知识中心 

Altium Designer 中有一个专门帮助用户使用软件 Knowledge Center 的面板(图 13)，上半部分

显示当前帮助的主题，工具栏按钮，选择的对像，面板等等，下半部分是文件库导航区域。在这里

用户查看到关于软件的应用笔记，导航和其它相关的 PDF 文章。 

如果 Autoupdate 按钮使能后，帮助文档可自加载到 Knowledge Center 面板的上半区域如果

不是使能的话，你可以按 F1 键加载帮助菜单。 
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图 13 Knowledge Center 面板用于查看文档库 

键入相关字符后按下 Search 按钮，可以查找到你所需要的所有相关 PDF 文档库。注意该查的

范围是由你当前所在的库控制。打下指定的下级文件夹限制所查找主题的区域，返回库的顶端查找

整个库。图 13 显示查找 interactive routing，和 Whats new in the Altium designer 部分导航。 

Altium Designer 中包含很多按 F1 键的帮助支持。实际上，每一个方面都有 F1 键的帮助支持接

口，例如： 

 在菜单入口，工具栏按钮或对话框上按 F1 键，可以直接进入该命令/对话框的帮助主

题。 

 在面板上按 F1 键，可以获得该面板的帮助细节。 

 在编辑环境下按 F1 键，如果鼠标指向某一设计对象，会出现该对象的帮助信息。 
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4.4     支持中心  

Altium 的网站(www.altium.com)包括很多关于软件的产品和服务的信息，同时还包括技术信

息和服务模块。经常查看网站也是一个好的练习。 

 点击 Home Page 上方的 Community 按钮，进入多样的客户资源 

 在 Support 下一页中 SUPPORTcenter 和 Learning Guides 是两个可用的部分，学习

向导，例如教程，文章和白皮书都是使用 PDF 格式的。 

 Altium 的技术论坛可以在 Home Page 页面上方的 Communityj 选项里的 Forums 进

入。技术论坛都受用户和 Altium 全体员工所欢迎，就像一个可以交流建议和信息的会

议室。 

 在 home page 的左侧的 DEMOcenter 是一个用来观看软件新功能和怎样使用软件的短

小视频，无论何新出一些新特性的版本，新的视频都会被创建，给用户去认识产品的新

功能。 

 在 Community 部分里 TRAININGcenter 是另一个有用的可用资源。这些视步比

DEMOcenter 里讲解的更为深入。目前的培训材料包含项目管理，布局，布线和填充

等视。 

支持中心 http://www.altium.com/supportcenter/ 是用户获得高质量的产品支持和使用到 新产

品更新包的一种方法。 

 使用用户名（Email 地址）和密码安全登陆 

 

图 14 登陆页面 

 一旦进入，允许记录、跟踪和搜索数据库中的解决方案 

 “Find Solution” 按钮用来搜索可能存在的解决方案 
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图 15 查找解决方案的搜索引擎 

 如果找到的解决方案无效，点击 Log a Case 按钮输入存在的问题和支持请求  

 

图 16 记录事件 
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 一旦支持请求添加好了，点击提交（Submit） 按钮保存。View Cases 按钮允许对原

始的请求进行编辑和添加附件。 

 

图 17 下载主页 

 当您登陆以后，下载和更新信息显示在支持中心的主页上。 
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5.  从 PROTEL 到 Altium Designer(30minutes) 

5.1 Protel 99SE 与 Altium Designer  

 Altium Designer 相对于 Protel 增强了非常多的功能。其功能的增加主要体现在以下几个大的

方面： 

首先在软件架构方面，Altium Designer 不是象 Protel 一样，仅仅用于设计 PCB 电路板的功

能。Altium Designer 在传统的设计 PCB 电路板的基础上新增加了 FPGA 以及嵌入式智能设计这一

功能模块。因此，现在的 Altium Designer 不但可以做硬件电路板的设计，也可以做嵌入式软件设

计。是一款统一的电子产品设计平台。 

其次在 EDA 设计软件兼容性方面，Altium Designer 提供了其他 EDA 设计软件的设计文档的导

入向导。通过 import wizard 来进行其他电子设计软件的设计文档以及库文件的导入。 

第三，在辅助功能模块接口方面，Altium Designer 提供了与机械设计软件 ECAD 之间的接口，

通过 3D 来进行数据的传输。在与制造部门之间，提供了 CAM 功能，使得设计部门与制造部门进行

良好沟通。在与采购部门以及装配部门，提供了 DBLIB 以及 SVNDBLIB 等功能使得采购部门与设

计部门等人员可以共享元件信息，提供与公司 PDM 系统或者 ERP 系统的集成。 

第四，对于项目管理方面，Altium Designer 采用的是以项目为基础的管理方式，而不是以

DDB 的形式管理的。这样使得项目中的设计文档的复用性更强，文件损坏的风险降低。另外提供了

版本控制，装配变量，灵活的设计输出 output jobs 等功能，使得项目管理者可以轻松方便的对整个

设计的过程进行监控。 

后，在设计功能方面，Altium Designer 无论是在原理图、库、PCB、FPGA 以及嵌入式智能

设计等各方面都增加了很多新的功能。这将大大增强对处理复杂板卡设计和高速数字信号的支

持，以及嵌入式软件和其他辅助功能模块的支持。 

Altium Designer 对于之前的版本 Protel99se 是向下兼容的，因此，原来 Protel99se 的用户若

要转向 Altium Designer 来进行设计，可以将 Protel99se 的设计文件以及库文件导入到 Altium 

Designer 中来。 

5.2 Protel 99SE 导入向导 

Altium Designer 包含了特定的 Protel99se 自动转换器。直接将*.DDB 文件转换成 Altium 

Designer 下项目管理的文件格式。 

1. Altium Designer 全面兼容 99se 的各种文档。Altium Designer 中设计的文档也可以保存成 

99se 格式，方便在 99se 软件中打开，编辑。 

2. 在 Altium Designer 中导入 99se 文档 

1.）使用菜单 “file\import wizard...”打开导入向导，进入导入界面，如图 18 所示。 
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图 18 protel 99 导入向导 

2.）选择 99se DDB files，再依次添加 99se 格式文档，系统自动转换成 AD project 项目文

档。 

3. 在 PCB 界面下，使用“save as…”功能，把文件保存成 version 4.0 格式，该格式文档 

能在 99se 软件中打开。如图 19。 

 
图 19 设计保存为 protel 可以打开的格式 

4. AD 软件可以直接打开 99se 原理图文档。 在 AD 软件中同样可以把原理图保存成 version4.0 

的格式，方便在 99se 中打开。 

5.3         练习－导入 99SE 的 DDB 文件 
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6.  原理图编辑基础                        (30 minutes) 

当你打开一个已有的原理图或是创建一个新的时候，原理图编辑器就会打开。在 Altium 

Designer 环境下该编辑器可以使用工作区所有的功能。这包括多重工具栏，资源编辑，右键菜单，

快捷键和工具提示。 

 
图 20 原理图编辑器工作区 

在这一节，我们将要探索原理图编辑器上的工作基础。 

请打开以下项目：4 Port Serial Interface.PrjPcb，位于\Altium 

Designer\Examples\Reference Designs\4 Port Serial 文件界面（如上图 20 所示），然双击项目

面板上的文件名为 ISA Bus 和 Address Decoding.SchDoc，打开原理图。 

6.1 视图命令 

视图命令能从 View 菜单被访问到，显示如下。 
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表 1 视图菜章摘要 

执行命令时，当接解到任何设计窗口的边沿时，自动平移会被激活（光标变成十字光标并附于

其下）。当自动平移时，按信 SHIFT 键会加快 2 倍的平移速度。自动平移的速度是通过 Graphical 

Editing 标签的 Auto Pan Options 控制 (Tools » Schematic Preferences)。 

在这里，自动平移功能也可以被关闭。 

以下的快捷键对熟悉工作区的视图提供了一个非常有用的选择。当执行命令时，这些快捷键也

可以同时被使用。 

 
表 2 视图操作的快捷键 
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6.1.1 使用鼠标滚轮平移和缩放 

在设计文档中，鼠标滚轮也可以被用作平移和缩放。 

 平移 

向上滚动鼠标滚轮则向上平移，向下滚动则向下平移。 

按住 SHIFT 键同时向下滚动鼠标滚轮会向右平移。 

按住 SHIFT 键同时向上滚动鼠标滚轮会向左平移。 

 放大 

按住 CTRL 键同时向上滚动鼠标滚轮会放大。 

 缩小 

按住 CTRL 键同时向下滚动鼠标滚轮会缩小。 

6.1.2 使用鼠标右键平移 

点鼠标右键保持不放，在设计文档里移动光标进行平移，鼠标变成手形表明你正在平移模式

下，释放右键则停止。 

6.2 选择 

原理图编辑器提供了一个类似其它 Windows 应用程序的选择功能，虽然不是完全一致的。 

以下是该选择功能的一些要点： 

  选择主要用于剪贴操作的对象提取，如：当剪切或拷贝命令执行时，这些对象将被移

动或是拷贝到剪贴板中。 

  一旦对象在剪贴板里，它们将可以粘贴在当前原理图的任意一个地方或另一个原理图

里，又或是其它支持 Windows 剪贴板的 Windows 应用程序中。 

  选择是不会累积的，当你选中另一对象时，前面被选的对象则会取消选择。 

  按住 SHIFT 键，可选择多个对象。 

  按 DELETE 键，所选对象全部删除。 

选择一个对象你可以使用： 

 
表 3 选择命令摘要 

所选对象可以： 
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表 4  所选对像操作命令摘要 

注意：取消所选对象，使用菜单命令 Edit » DeSelect（‘X’弹出菜单）或使用主工具栏上的

DeSelect All 按钮。 

6.2.1 选择建议 

  开始进行选择前，先取消选择所有对象是一个好习惯。 

  只有完全在选择区中的对象才会被选中。 

  选择的颜色设置在 Preferences 对话框里的 Graphical Editing 标签里（Tools 

»Schematic Preferences）。 

  可以使 Move 菜单移动所选对象。 

-不保持连通性（移动） 

-保持连通性（拖曳）。 

 S’键弹出选择菜单 

 X’键弹出取消选择菜单 

6.2.2 选择存储器 

在原理图和 PCB 编辑器里，可用的选择存储器

容量为八次，对象的选择状态都可以存储或召回。使

用表 3 上所描述的任何方法，选择一个你想记住的

对象，然后存储它们，以便快速的召回。  

以下选择存储的选项是可以用的： 

  存储到存储器(CTRL + 数字 1 to 8) 

  添加到存储器(SHIFT + 数字 1 to 8) 

  从存储器中召回(ALT + 数字 1 to 8)                       

  从存储器中召回并添加(SHIFT + ALT+

数字 1 to 8)                                                                   图 21 选择存储器控制面板 

  类似工作区过滤器一样申请存储器(SHIFT+ CTRL + 数字 1 to 8).  

你也可以使用下拉菜单 Edit » Selection 访问选择存储器功能。当然，点击 按钮可以打

开选择存储器控制面板。按住 CTRL+Q.再点击 STO 按钮保存或是点击 RCL 召回选择。在控制面

板上的过滤选项决所选对象的显示方式。 
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为了防止意外操作将当前选择存储覆盖，在参数选项中(Tools » Schematic Preferences)选择

Schematic 部分在 Graphical Editing 页中使能 Confirm Selection Memory Clear 选项，选择容量

体能够从检查 Lock 检验栏的覆盖处里被锁定。  

6.3 他鼠标动作 

鼠标操作显示如下，它被广泛使用在原理图编辑器上和菜单命令之中。 

 
表 5 普通鼠标快捷方式摘要 

当把鼠标放在对象上时，可以使用以下快捷方式： 

  空格键——旋转 

  X 键——垂直翻转 

  Y 键——水平翻转 

6.4 练习－原理图编辑器基础 

缩放与平移 
1. 打开原理图：ISA Bus and Address Decoding.SchDoc，在\Altium 

Designer\Examples\Reference Designs\4 Port Serial Interface folder.中找到 ISA Bus 和 Address 

Decoding.SchDoc 

2. 尝试使用视图菜单的快捷键和工具栏来实现表 1 各种显示命令。 

3. 使用鼠标平移和缩放 

4. 选择 Place » Text String (PT)功能，再用表 2 的快捷键菜单，重复刚才的动作。按 ESC

建或者单击右键退出。 

5. 现在试一下自动平移。选择 Place » Text String 移动光标到窗口的边缘，显示画面开始移

动，当移动时按住 SHIFT 键。注意当 Place » Text String 命令被激活时十字光标的显示。 

本地标记 
1. 通过选择 Edit » Jump » Set Location Marks » 2 (JK2) 设置本地标记，然后进入原理图

设定好本地标记的位置。 

2. 缩小原理图到另外一部分 

3. 选择 Edit » Jump » Location Marks » 2 (JM2)，屏幕将以本地标记 2 为中心。 

选择与鼠标动作 
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1. 选中一个器件，例如 P1，观察他被选中时的虚线框。 

2. 选中另一个器件，例如一个电容，它现在是一个被选中的对象。 

3. 点击原理图上没有器件的某一处，没有东西被选中。 

4. 选中一条导线，注意手柄的显示。 

5. 随着这条导线被选中，尝试移动端点和移动一部分（两端点之间的一段）。在你要想新端

点的导线增加一个端点，使用单击并保持不放，然后按下 INSERT键，再把它移到一个新的位

置上。选中一个新的端点，然后按下 DELETE，删除。 

6. 确认原理图上的所有对象都不被选中，使用 Edit » DeSelect » All (X, A)或者工具栏上的

。 

7. 使用单击和拖曳选择功能，选中电路的一个部分。使用菜单命令 Using the Edit »Copy，

将内容拷贝到剪贴板。 

8. 打开一个新的原理图，粘贴剪贴板上的内容。取消选择粘贴的对象。 

9. 将该新原理图关闭（不用保存）。 

10. 使用菜单命令 Edit » Move 尝试移动原始原理图上的所有对象，然后取消选择。 

11. 当按下 CTRL 键时，选中 U10 器件。现在你可以向四边拖曳，它仍然保持导线连通。 

12. 单击 C12 并保持不放，然后开始移动它。当移动它时按下 ALT 键，注意，现在的移支只能

是水平或是垂直方向，只要靠近鼠标靠近的对象就会被选中——尝试移动对象到想要的方位

查看效果。 

13. 双击其中一个电容。器件属性对话框会显示，你可以编辑器件的任何属性。 

14. 不保存任何改变，关闭原理图。 
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7.  原理图绘图工具以及电气连接工具(20 
minutes)  

7.1     原理图绘图工具 

7.1.1   概要 

 在 Utilities 工具列中可使用绘图工具的对象，如要开启或关闭 Utilities 工具列可在 View 

» Toolbars » Utilities 

 绘图工具按钮在 Place » Drawing Tools 除了  Paste Array 之外(Edit » Paste Array)绘

图工具列的功能可以透过选单内 Place » Drawing Tools menu, 除了 Paste Array (Edit 

» Paste Array)之外. 

 当在摆放对象时按下 tab 键可以编辑对象属性。左键双击也可编辑所放置对象的属性  

 当对象被选中时名称会显示出来                                     

 当在这指令操作中,在还没有放弃当前指令时你可以选择其它指令,只要你会用快捷键.这

是一个强大的功能, 称为重入编辑, 将可以大大的增加生产力. 

图 22 绘图工具 

7.1.2  绘制原理图绘图对象 

文件 Objiects.SchDoc 中的所有图形对象都可以在 Altium 

Designer\Examples\Training\Practice Documents folder.文件夹下面找到  
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图 23. 原理图绘图对象 

这些摆放对象的描述如下: 

1.    Lines 

画线: 

1. 选择画线工具按钮  或 Place » Drawing Tools » Line. 

2. 点击左键开始执行画线 

3. 在画的过程中点击左键增加拐点,可利用 backspace 键删除 后一个拐点 

4. 点击右键可结束此条线 

5. 再点一下右键可结束此指令 

2.    Polygons 
画多边形: 

1. 选择放置多边型工具按钮  或执行 Place » Drawing Tools » Polygon. 

2. 点击左键放置多边形的各端点 

3. 点击右键结束多边形. 

4. 再次点右键结束指令. 

5. 将 Draw Solid 选项取消后多边形不会填充. 
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3.  Arcs 
画圆型: 

1. 选择 Place » Drawing Tools » Arc 选单指令. 

2. 点击左键确定圆心位置. 

3. 点击左键确定圆半径. 

4. 点击确定圆弧开始点及第二次点击确定圆弧结束点. 

5. 点击右键结束指令. 

4.     Elliptical arcs 
画椭圆形弧线: 

1. 选择放置椭圆形弧线工具按钮  或者执行 Place » Drawing Tools » Elliptical Arc. 

2. 点击左键确定弧线中心位置. 

3. 点击左键确定 X-半径. 

4. 点击左键确定 Y-半径. 

5. 点击左键确定弧线起始点,再点击左键确定弧线结束点. 

6. 点击右键结束指令. 

5.    Bezier curves 
适合画贝赛尔曲线的是这条曲线利用鼠标来确定曲线各点的位置.  

画贝赛尔曲线: 

1. 选择放置贝赛尔曲线工具按钮  或执行 Place » Drawing Tools » Bezier.  

2. 点击左键确定第一曲线控制点. 

3. 点击左键确定第二控制点. 

4. 点击左键确定第三和第四控制点. 

5. 继续点击左键确定更多的控制点. 

6. 点击右键结束指令. 

7. 重新修改曲线形状,点击曲线的一个端点移动、增加（按 INSERT 键）或删除新控制点. 

6.    Annotation (Text) 
放置单行文字: 

1. 选择放置文本工具按钮  或执行 Place »Text String. 

2. 按下 Tab 设定文字字体.你可以从文字下拉选项中增加特殊字符串, 如日期和文档信息.。 
这个主题包含的一些详细内容在原理图培训章节中 

3. 点击左键放置文字. 

4. 右键结束指令. 

字符串可以通过选择并再一次点击高亮后进行编辑。 
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7.       Text frames 
文本框用来放置文字段落在原理页面上。 

放置文本框： 

1. 选择放置文本框工具按钮  或执行 Place » Text Frame. 

2. 按下 Tab 键设定 Text Frame.相关属性 

3. 点击左键确定左上角位置，再点击左键决定右下角位置. 

4. 右键停止摆放文本框. 

下面的指令可用在编辑文本框的时候使用: 

Action Keystroke 

插入 tab CTRL+TAB 

剪下 SHIFT+DELETE or 
CTRL+X 

复制 CTRL+INS or CTRL+C 

贴上 SHIFT+INS or CTRL+V 

表 6. 文本框指令摘要 

剪切,复制和粘贴指令都可一应用在 Windows 剪贴板中， 剪贴板也可以从其它应用软件中载入

文字信息。 

8.     Rectangles 

放置矩形方块: 

1. 选择放置矩形方块工具按钮  或执行 Place » Drawing Tools » Rectangle. 

2. 点击左键确定左上角. 

3. 点击左键确定右下角. 

4. 右键结束指令. 

9.      Rounded rectangles 

圆角矩形方块是一个带有圆弧角的矩形。 圆角矩形方块对话栏中可设定圆弧的 X-半径和 Y-半

径. 

放置圆角矩形方块： 

1. 选择放置圆角矩形方块工具按钮  或执行 Place » Drawing Tools » Rounded 
Rectangle. 

2. 按下 Tab 设定圆角矩形方块 相关属性. 

3. 点击左键确定左上角再次点击左键确定右下角. 

4. 右键结束指令. 

10.      Ellipses 
使用这指令来画圆较适合。放置椭圆： 

1. 选择放置椭圆工具按钮  或执行 Place » Drawing Tools » Ellipse. 
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2. 点击左键摆放椭圆中心点. 

3. 点击左键确定 X 半径大小. 

4. 点击左键确定 Y 半径大小. 

5. 右键结束指令. 

11.     Pie charts 
放置椭圆分格图表: 

1. 选择放置椭圆分格图表工具按钮  or Place » Drawing Tools » Pie Chart. 

2. 点击左键确定分格图表中心点. 

3. 点击左键确定分格图表半径. 

4. 点击左键确定第一个边再点击左键确定第二个边. 

5. 右键结束指令. 

12.      Graphic images 

以下格式的图形可以添加到原理图中： 

• .bmp, .rle, .dib 

• .jpg, .tif (uncompressed) 

• .wmf, .pcx, .dcx, .tga. 

包含图形的文件可以嵌入或链接到原理图中，当原理图文件的位置移动后图形文件的链接也需

随着原理图文件转移。 

放置图片: 

1. 选择放置图片工具按钮  or Place » Drawing Tools » Graphic. 

2. 点击左键确定图的左上角，再点击左键确定图的右下角. 

3. 找出图文件的路径并按下 OK. 

4. 左键连点两下打开对话框崁入图片. 

13.     Notes 

批注可以在原理图页面上用来放置文字段落，而且文字段落可随时折叠或展开. 

放置批注: 

1. 选择执行 Place » Notes » Note 或按 PEO 快捷键. 

2. 按下 Tab 编辑 NOTES 相关设定属性完成后按下 OK. 

3. 点击左键确定左上角位置在点击左键确定右下角位置. 

4. 右键结束指令. 

当正在放置文本框时可利用下面的快捷键: 

Action Keystroke 

插入 tab CTRL+TAB 

剪下 SHIFT+DELETE or 
CTRL+X 
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复制 CTRL+INS or CTRL+C 

贴上 SHIFT+INS or CTRL+V 

表 7. 文本框指令摘要 

剪切,复制和贴贴指令都可以应用在 Windows 剪贴板中. 剪贴板板也可以从其它应用软件中载入

文字信息。 

5.        通过点击左上角的小三角形可以让批注折叠和展开。 

7.1.3    Exercise –Schematic graphical objects 

1. 打开 Altium Designer6\Examples\Training\ Practice Documents 文件夹下的

Objects.SchDoc 文件，并在文件中的空白处放置每个绘图对象 

2. 选择每个对象并观察操作方法. 

3. 注意移动效果. 

4. 在多线对象中输入一个新的顶点, 并移除它. 

5. 在对象上双击显示并且更改其属性. 

6. 关掉这张图纸并且不要存档. 

7.2      电气连接工具 

7.2.1    General 

原理图设计对象定义捕获的实际电路.电气对象包含零件跟连接要素，例如导线.总线.连接端口.

原理图中这些对象用来产生网络表，网表在不同的设计工具中能够传递电路和连接信息。 

 使用配线工具按钮来放置电器对象.  

  

图 24.原理图电气对象 

 所有配线工具按钮的功能可以从 Place 菜单下访问. 

 文字在电气对象中可以加顶线, 典型的是在所需要定义的字符后面加入‘\’ 表示有效低信

号,例如 R\ESET 会显示 ‘R’ 有上顶线的状态。 要让整个词语上显示单一的上顶线，必

须激活 Schematic – Graphical Editing 设置下的 Single ‘\’ Negation 选项。 

下列章节将会解释每一个电气对象. 

7.2.2    电器对象概要 

电器对象的例子如图 25 所示。 
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图 25 原理图电气连接工具 

14.   电气连接线 Wires 

• 选择放置电气连接线工具按钮  或执行 Place » Wire. 

• 电气连接线 主要用来连接两个电气点之间的关系. 

请注意要使用 Place » Wire 指令且不要错误使用 Line 指令. 

• 按下空格键来改变摆放的角度. 下面有 6 种摆放模式可设定: 

- 90 度 开始 

- 90 度 结束 

- 45 度 开始 

- 45 度 结束 

- 任意角度 

- 自动连线. 

• 退格键可以删除上一段所放置的导线. 

• 导线结束点必须在电器对象的连接点上.例如导线的结束点必须落在接脚的连接点上. 

• 导线有自动节点的功能,假如导线在开始或结束在其它导线落跨过接脚的连接点上会自动产

生节点 

• 要增加多个拐点必须按住鼠标左键并且按下 INSERT 键. 

• 移除节点请选到拐点后点击右键选择 Edit Wire Vertex NO. 或到导线属性对话框切换到

vertices 页面点选 Remove 可移除节点. 

15. Buses 

 总线可以图形化地表现一组连接在原理图页面上的相关信号的关系，例如数据线。它们

用来集中属于同一页面上的总线信号并把这些信号连接到页面的输入输出端口。在这中

情况下,它们必须含有这种格式的网络标号: D[0..7]。 
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 选择放置总线工具按钮  或执行 Place » Bus. 摆放总线用跟 wire 方法相同, 按下空格

键可改变摆放模式，按退格键可删除 后一个拐点。 

 总线只表示连接端口和页面接入端点之间的连接  

 总线摆放模式的快捷键指令和导线相同. 

 
图 26 总线以及总线分支 

16. Bus Entries 

总线分支用来连接总线和导线. 

放置总线分支： 

 保证连接线可以画在适当的工作格点上. 

 选择放置总线分支工具按钮  或执行 Place » Bus Entry. 

 按下空格键改变总线分支的角度. 

 按下左键确定总线分支的位置. 

 右键结束指令. 

总线分支是可以自由选择的. 许多使用者比较喜欢使用 45 度的导线. 

17. Signal Harness 

Signal Harnesses 允许逻辑群组有多种信号,包含导线,总线以及其它的 signal harnesses.这个群

组可以作为单一实体使用到整个项目中。  

有 4 个关键元素给 Signal Harness 系统:  

 Signal Harness  

 Harness Connector  

 Harness Entry  

 Harness Definition File  
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图 27. 一个 Signal Harness 可以携带导线,总线和其它的 signal harnesses 混合体. 

Note: 移动鼠标到 harness 上方可以实时显示相关网络,总线和 sub-harnesses. 

18. Harness Connector  

Harness 连接器可以将不同的信号集合在一起。 Harness 连接器包含捆绑到 Signal Harness 中的

每个网络、总线和 Sub-harness 的 harness entry 。 

 

图 28. Harness Connector 聚合信号到 Signal Harness 内.它通过 Harness 类型来定义,例如这个

范例类型是 I2S 

Note: 开始用智能贴图指令去将网络转换为 Harness Connectors. 

19. Harness Entry  

要将网络,总线,Sub-harness 包含在一个 Signal Harness 内, 需要连接到 Harness Connector 内

的 Harness Entry.  
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图 29. Harness Entries 提供连接点供网络连接.在上图,Harness Entries 包含 WCLK, BCLK, 

DOUT, DIN 和 MCLK 

20. Harness Definition  

针对设计内的每一个 Signal Harness, 会有一个 Harness 定义文档，每一个 Harness 定义组合

由 Harness 类型(如下图的 I2S),和相关的 Harness Entries (例如下图: BCLK, DIN, DOUT, MCLK, 

WCLK)组成.  

Harness 定义档案 (*.Harness) 可以通过 Altium Designer 自动建立与管理. Harness 定义文档

可以在项目面板下 Settings\Harness Definition Files sub-folder 找到.  

 

图 30. The Harness 定义文档是个文本文件并放在项目的 Settings 下. 他包含所有关于 Signal 

Harnesses 的定义与关连信息. 它们有一个易于辨识的扩展名 *.Harness 

Note: 你可以在没有 Harness connector 情况下建立 Signal Harness. 但是你需要手动建立与管

理 Harness 定义文件. 
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21. Net Labels 

 网络标号让网络易于识别，并为没有通过电气导线连接的相同网络管脚提供一种简单的

连接方法。 

 在同张图纸中有相同网络称号的导线之间是互相连接的，在某些情况下,同一个项目中

所有相同的网络标号的电气导线要连接在一起. 层次项目设计将在原理图培训章节作详

细描述. 

 所有网络标号在网络上必须相同. 

 网表生成器会将所有的网络称号转换成大写字母. 

 结合网络标号到导线上,只要放置时基准点(左下角)在导线上即可. 

 当放置网络标号时电器格点处于激活状态 

 假如 后一个字符在网络称号中是数字的话，在摆放下一个网络标号时它将会自动增加. 

放置网络标号： 

1. 在工作格点上摆放网络标号. 

2. 选择放置网络标号工具按钮  或执行 Place » Net Label. 

3. 按下 Tab 设定网络标号的字体. 

 

图 31. 网络标号对话框 

4. 点击下拉选单可显示已经存在在图纸上的网络名称,或输入新的网络名称再点击 OK. 

5. 按下空格键可选转网络标号. 

6. 点击左键确定网络标号位置. 

7. 右键结束指令. 
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Note : 再放置网络称号的时候可将鼠标移动到已经存在的文字上按下 Insert 快捷键便可复制文

字到网络称号内. 

22. Power Ports 

 项目中具有相同网络特新的所有的电源连接端口都会被连接起来 

 要连接到电源连接端请确定导线已连接到电源连接端口的连接脚. 

 电源连接端口的型态只能改变外型.它不会影响连接特性. 

 电源连接端口将连接到相同网络名称的隐藏管脚,和使用的网络标识范围无关 

 配线工具工具按钮中的电源连接端口工具按钮只可以放置单个电源连接端口，要改变这

特性并放上多种连接端口可以编辑此按键增加一个参数 Repeat=True. 

放置电源连接端口: 

1. 选择工具工具按钮中 GND  或 VCC  Power Port,或执行 Place » Power Port. 

2. 按下 TAB 设定 power port 不同于 GND 或 VCC 的网络名称 

 

图 32. 电源连接端口对话框 

3. 按下左键确定 power port 的位置. 右键结束摆放 power ports. 

23.   Ports 

 连接端口提供一个信号的联接方法,从一张图指向另一张图纸.  

 点击网络名称的向下按键可列出在图纸上所有的网络名称. 

 连接端口的 I/O 类型可以利用 ERC 来检查连接错误. 

 连接端口的型态只改变外观. 

放置连接端口: 

1. 选择放置端口工具按钮  或执行 Place » Port. 

2. 按下 Tab 设定 port 相关属性. 
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图 33. 连接端口属性对话框 

3. 按下空格键旋转或按下 X 或 Y 键做翻转. 

4. 左键确定 port 一端的位置 拖移鼠标设定 Port 的长度在按下左键完成 Port. 

5. 右键停止放置 ports. 

Note : 连接端口的方向将会自动定义,主要基于连接的网络特性.请将 Preference 中 General 下的

Port Direction 选项使能。.  

24.    Parts 

 当选择 Place » Part (PP) 或点击放置器件工具按钮 , 会显示摆放零件对话框. 你可

以在零件库参照名字段中输入零件名称或点击 Browse 按键(…) 来增加必要的零件库。 

 

图 34. 放置元器件对话框 
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 零件也可以利用在线路图零件库中 Place 按键来放置 

 当摆放零件时是依据工作格点，也可以利用 G 来变更工作格点的设定，如可以把格点

设为 1，5，10。 

25.          Sheet Symbols 
• 使用页面符号可以把原来的设计分割成多个图纸页面. 

• 每一个页面符号代表项目中其它的一张原理图. 

• 页面符号的名称是所代表图纸的描述名称. 

• 页面符号的文件名称必须和它代表原理图文件相同.一个项目中所有的图纸应该在同一个路

径下。. 

• 当改变页面符号的大小要确定它的边是否落在工作格点上，以确保导线可以连接到页面符

号上。. 

摆放页面符号： 

1. 选择页面符号图标工具按钮  或执行 Place » Sheet Symbol (PS). 

2. 按下 Tab 设定叶面符号的名称以及文件名. 

3. 点击左键确定左上角的位置 

4. 点击左键确定右下角的位置. 

5. 右键结束指令. 

Note : 页面符号连同输入输出端口可以通过指令来创建,指令为 Design » Create Sheet 

Symbol From Sheet or HDL. Synchronize Sheet Entries and Ports， 指令 (可在设计菜单或是

右键选择菜单找到此指令) 可以同步页面符号输入输出端口与底层图纸的连接端口。  

26.             Sheet Entries 
• 页面输入输出端口使用在页面符号中，如果你需要使用层次电路设计可以以使用此对象连

接底层电路连接端口. 

• 每一个页面输入输出端口需要与底层连接端口匹配. 

• 当建立网络表或是电气规则检查时利用 Sheet Symbols / Port Connections 来定义网络名

称. 

放置页面符号输入输出端口: 

1. 选择放置页面输入输符号工具按钮  或执行 Place » Add Sheet Entry (PA). 

2. 在页面符号上点击左键确定 Sheet Entry 的位置. 

3. 按下 Tab 设定 sheet entry 相关属性 

4. 在名称上点击下拉选项可显示在图纸上已有的网络名称. 

5. sheet entry 的位置可以是页面符号任何一条边上 

6. 右键结束指令. 

Note: 在 DXP » Preferences » Schematic » Graphical Editing 对话框中包含一个选项 Place 

Sheet Entries Automatically. 其默认值是关闭的。 这是一个有用的功能，它可以在页面符号之间

相互连接时自动放上 sheet entries。 . 
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27.          Off Sheet Connectors 
Off Sheet 连接器使用在网络跨接多个图纸对象，而且这些图纸都是通过同一个页面符号的输

入输出端口连接起来的.成功连接的特殊网络跨过两张或以上的图纸，每张图纸上的 Off Sheet 
连必须指定相同的网络名称. Off Sheet 连接器主要是从 ORCAD 导入到 Altium 的。 

1. 选择 Place » Off Sheet Connector (PC).  

2. 按下 Tab 设定 Off Sheet 连接器属性. 

3. 点击左键放置 Off Sheet，右键结束指令.  

Note :Off Sheet 连接器的主要功能是针对 Orcad 原理图转换的. 如果你用 Altium Designer 设计

原理图也需要将原理图转换为 Orcad 格式, 那你就可以使用 Off Sheet 连接器。 

28.             Junctions   
• 这软件会自动产生节点在有效的连接点上，包括‘T’型 连接状况及导线跨过引脚端点。十字

交叉不会自动添加连接点。 

• 十字交叉可以通过添加手动交叉点强制连接，手动节点可以从选择 Place » Manual 
Junction (PJ)，当十字基准线上出现一个连接标记（红点）时，点击左键摆放节点。 

• 自动节点显示设定是在属性设置 (Tools » Schematic Preferences) 的 Compiler 栏下。.  

29.             Parameter Sets 
一些对象不支持直接定义参数，如导线,总线。增加参数到这些对象需要放置一个参数设定对

象。 PCB 设计规则也可以使用参数设定对象增加到导线(网络)或总线，这些规则定义通过同步

操作传递到 PCB 里。 

1. 选择 Place » Directives » Parameter Set.光标上出现一个 directive symbol . 

2. 按下 TAB 在参数对话框 设定参数.按下 Add 按钮在参数属性对话框增加参数. 
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图 36. 参数对话框 

3. 确定指示符号位置，指示端要碰触到导线或总线.，点击左键放置。 

4. 右键结束指令. 

Note: PCB 布线规则也是一个参数设置对象.，放置 PCB 布线规则作为独立菜单选项保留在一

些早期的版本中。 

30.           Compile Mask 
• 它的放置方式与批注相似，可以折叠或展开。这个功能并不只提供给你要将某区域不做

ERC 检查显示而已，只要的是它可以将原理图工作领域中的仿真源掩盖起来。 

• 放置 compile mask： 

1. 选择选单 Place » Directives » Compile Mask.  

2. 按下 Tab 设定 compile mask. 

3. 点击左键确定左上角位置. 

4. 点击左键确定右下角位置. 

5. 右键结束指令. 

 

图 35.这个参数设定对象是一个包含 PCB 规则定义

的参数添加器. 
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31.          No ERC Marker 
• 摆放一个 No ERC 符号在电路节点上将对摆放的点禁止警告和错误报告. 这个标记不会打印

出来。 

• 选择 Place No ERC 工具图标按钮  或是 Place » Directives » No ERC. 点击摆放 No 
ERC 在零件管脚上或是已存在的 ERC 标记上，按鼠标右键结束此指令。 

7.2.3 练习 –原理图电气对象 
1. 开启 Electrical Objects.SchDoc 文件，此文件在此路径 Altium Designer 

Summer 08\Examples\Training\ Practice Documents 下，然后练习摆放任意的电

气对象到原理图上. 

2. 选择到这些对象并试着移动它们. 

3. 双击某些对象并显示或修改对象属性. 

4. 关闭此档案并且不要存盘. 
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8.  创建第一张原理图                       (1hour) 

原理图课程介绍了包括怎么从 初的设置到元器件的放置，连线，设计检查和打印来创建单张

原理图和多张层次式原理图。我们将进一步研究原理图编辑器的功能，进行一系列的练习来展示怎

样将一个设计画成原理图，并为 PCB 设计做准备。 

图 37 描绘了在 Altium Designer 中建立一个原理图时需要依照的工作流程 

 

图 37 Altium Designer 原理图设计流程 

转移设计到

PCB 布局 
从 PCB 返回标

注 

设计概念& 技
术要求 

建立 PCB 工程 

添加电路图 & 电路

图符号来创建设计

从库里找到和放置

元器件 

电路设计 

设计批注 

编译和修改设计

添加元件参数 

添加 PCB 设计要求
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8.1 原理图编辑器工作区设置 

本节介绍如何通过设置文档选项和参数选项来设置和浏览原理图编辑界面。页面选项，如栅格

和模板，以及可通过这些对话框设置参数选项和默认值。打开原理图编辑器，在 Altium Designer 中

简单的创建一个新的原理图文档(File » New » Schematic)或者打开一个现有的原理图文件

(.SchDoc 文件)。 

8.1.1 文档选项 

 文档选项对话框允许您： 

设置参数关联到单独的原理图文件。 

此对话框的设置是与被设置的原理图文件一起保存。 

双击版边或者使用菜单命令 Design » Options 来调出文档选项对话框。 

以下各节介绍文档选项对话框的选项卡。 

32.   页面选项卡 

图 38 显示的是文档选项对话框的页面选项卡。下面将解释选项的每一部分。 

 

图 38 文档选项对话框的页面选项卡 

模板部分 

如果有，则显示关联的模板的文件名。 在设计菜单中使用模板选项应用、 更新或删除关联的模

板。 在参数选项对话框的 System – New Document Defaults 页面设置系统默认模板。 
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选项部分 

方向 

将工作表方向设置为横向或纵向。 

标题栏 

在选中后，标准标题栏附加到工作表。 标题栏的格式设置使用此选项旁边的下拉列表。 注意这

通常只是在没有使用模板的时候使用。 

显示参照区域 

在选中后，工作表有了一个在边上的参考栅格。 一个新的选项还添加了可以按 ASME Y14.1 标

准分区。 

显示边框  

选中后可以看到页面的边框。 

显示模板图形 

选中后,在已定义模板中的任意物件都将显示. 这通常用以显示一个非标准标题栏，在这种情况

下您会取消选中标题栏选项。 

边框颜色 

允许您在选择颜色对话框中设置边框颜色。 

页面颜色 

允许您设置页面背景颜色。 

标准类型区域  
允许您从标准尺寸中选择标准类型的页面尺寸，如 A4,A3 

自定义类型区域 
允许您自定义页面的尺寸和边框。如果标准类型部分没有您所需的页面尺寸可使用此选项。 

改变系统字体 
此按钮允许您更改用于显示端口号，引脚名称，端口文字，电源端口文字和页面边框字体。 

栅格部分 

栅格选项允许您设置对齐栅格和可见栅格的大小和开关。 

捕捉开 

网格捕捉强制鼠标点击到 靠近的网格位置。栅格捕捉可以在文档选项对话框中设置，打开或

者关闭。您也可以在任何时候按 G 快捷键在三个预定义网格中循环. 

可见 

可见栅格打开时将显示栅格。它与捕捉栅格并无关系。栅格捕捉也可以在视图菜单中打开或者

关闭（快捷键 VV）。 
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电气栅格部分 

在文档选项对话框中可以打开关闭电气栅格和设置电气栅格的范围，也可以在视图菜单中打开

或者关闭（快捷键 VE）。 

当电气栅格打开，你在执行一个支持电气栅格的命令时，鼠标会跳到对象的关键点而忽略栅格

捕捉。 

比如，如果你在运行 Place » Wire 命令，移动鼠标到一个引脚的电气栅格内，鼠标会跳转到那

个引脚上。 

33.   参数选项卡 

参数选项卡用于方便的编辑页面层面的文本。 每个参数自动链接到在页面上除了前面的等号与

参数一样名字的字符串。 

例如，参数 Address1 自动链接到文本字符串 = Address1。 在等号是原理图编辑器自动用一个

名为 Address1 参数的值替代文本字符串在页面的指令。 可以将任意数值的参数添加到一个原理图

模板或一个原理图页面。 使用这些特殊的字符串允许定义诸如字体，尺寸和颜色，而当一个原理图

应用于该模板，实际的文本字符串的值就被指定了, 

在打印时会自动替换，它也可以通过在首选项对话框中的图形编辑选项卡页面中打开转换特殊

字符串选项(Tools » Schematic Preferences）。 

 

图 39 文档选项对话框的参数选项卡 

默认的特殊字符串在下表中列出，如果设计需要的话您可以自己创建合适的参数。 

Special String Description Special String Description 

=Address1 一行地址 =Engineer 工程师名字 

=Address2 一行地址 =ImagePath 图片路径 
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Special String Description Special String Description 

=Address3 一行地址 =Modified Date 后修改时间 (数值自动输

入) 

=Address4 一行地址 =Organization 组织名称 

=ApprovedBy 验证者 =Revision 版本号 

=Author 作者 =Rule 规则描述 

=Checked By 审核人 =SheetNumber 原理图页面数 

=CompanyName 公司名称 =SheetTotal 工程中原理图页面统计数 

=CurrentDate 系统日期(数值自动输入) =Time 时间 (非自动更新) 

=CurrentTime 系统时间 (数值自动输入) =Title 页面标题 

=Date 日期 (不是自动更新的) =Engineer 工程师名字 

=DocumentFullPath 
AndName 

档案名称和档案的完整路径 
(数值自动输入) 

=ImagePath 图片路径 

=DocumentName 档案名称不包括路径（数值

自动输入) 
=Modified Date 后修改时间 (数值自动输

入) 

=DocumentNumber 文档数   

=DrawnBy 绘制者   

表格 8 建立一个新原理图时的默认参数列表 

图 40 显示特殊字符串怎样输入到标题栏中。放置的特殊字符串将显示参数选项卡中参数的值。

特殊字符串的属性（如字体颜色）决定显示文字的样子。 

通过选择 Place » Text String 时放置特殊字符串，然后按 Tab 键，显示注释对话框。在名称

字段中点击下拉箭头将列出每一个特殊的字符串。 点击所需要的字符串并将其放置。 当示意图打印

或绘制时，或者在参数选项对话框中的图形编辑选项卡页面中打开转换特殊字符串选项 （Tools » 

Schematic Preferences），特别字符串显示其内容。 

 

 

图 40 当转换特殊字符串打开或者关闭特殊字符串在标题栏的显示 

34.   单位选项卡 

单位选项卡允许您定义用于原理图编辑器中的各个单位。栅格将使用这些单位的倍数如，DXP 

默认单位是每个单位等于 10 mils ，当打印实际尺寸或 1:1 时，捕捉网格值为 5 （或 5 单位） 会相

当于 50 mils ，10 个单位 = 100 mils 等。 
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图 41 文档选项对话框的单位选项卡 

英制单位系统部分 

使用英制单位 

选中此选项原理图就使用英制单位。 您可以指定使用 （DXP defaults - 10 mil, mils, inches 

and auto imperial units）下拉列表中的哪个英制单位。 

使用的英制单位 

此选项用于从提供的英制单位之一选择 ；mils，inch，DXP 默认单位 (10 mils） 和自动英制单

位。 如果选择自动英制单位，当值大于 500mils 系统将从 mils 切换到 inch. 

公制单位系统部分 

使用公制单位 

选中此选项来原理图就使用公制单位。您可以指定使用 （millimeters, centimeters, meters, and 

Auto-Metric units）下拉列表中的哪个公制单位。 

使用的公制单位 

此选项用于从提供的公制单位之一选择 ； 毫米，厘米,米和自动公制单位。 如果选择自动公制

单位，当值大于 100 厘米系统将从厘米切换到米. 

35.   使用模板 

Altium Designer 提供标准模板（*,SchDot）在路径\Altium Designer\Templates\文件

夹，您也可以创建自己的模板保存在任何地方。 
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选择 Design » Template » Set Template File Name.这个选项将删除现有的模板而使用您选

择的模板。 

选择 Design » Template » Update，当一个模板被修改了而你需要更新它的时候你可以使用这

个命令。 

选择 Design » Template » Remove Current Template.这个选项将移除模板但是保留以前的

文档尺寸。 

每个命令都将会提示您此更改是否应用于当前的工作页面，所有打开或所有项目。 

8.1.2    参数选项 

参数选项对话框的原理图部分允许您设置原理图编辑器工作区的参数。 使用菜单命令 Tools » 

Schematic Preferences 显示此对话框。 此对话框中的设置保存在 Altium Designer 环境中，因此

当您更改当前的原理图文件时，参数保持相同。附录中有这些选项全部说明。 

8.2 集成库概念介绍 

在 Altium Designer 中，元件库能作为独立的文档存在，如原理图库包含原理图符号、PCB 库包

含 PCB 封装模型以及一些其他的库文件包含各自的 PCD3D 模型，仿真模型和信号完整性分析模型

等等。 

另外，AltiumDesigner 支持集成库的创建及使用。集成库(.IntLib 文件)包含了原理图库文件

(.SchLib)，PCB 库文件(.PcbLib)，SPICE 模型库文件(.ckt 和.mdl 文件)，信号完整性模型模型文件

以及 PCB3D 模型文件。如图 42 所示。 

 
图 42 将元件的各个模型添加到原理图符号中 
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创建好的集成库会在库面板中如图 43 所示的方式来显示。其中包括集成库的名称，库中元件，

元件的原理图符号图，联接的各种模型以及各种模型的显示。 

 
图 43 集成库面板示意图 

Altium Designer 提供的大部分库都是集成库，储存在 \Program Files\Altium Designer \Library 文

件夹中。集成库也能转换回原先的分立库，只需在 Altium Designer 中打开就可做到。 

8.3 库与元件的装载及浏览 

这部分主要介绍的是 Altium Designer 库和如何在库里面找元件 

8.3.1   查找以及加载库 

Altium Designer 提供的元件都存在一组集成库里面。在集成库中的元件不仅有原理图元件符

号，还集成了其他文件所需的相应的模型文件，如封装、电路仿真模型、信号完整性分析模型、3D

模型等。大多数集成库都是符合厂商规定的。 

集成库是通过分离的原理图库、PCB 封装库等编译生成的。在集成库中的元件不能够被修改，

如要修改元件可以在分离的库中编辑然后再进行编译产生更新过的集成库即可。 

还有一部分特殊性质的集成库，如特殊函数仿真元件。 

元件也可以通过原理图库直接放置，当然也可以通过 99SE 格式的原理图库来放置。 

可用的元件库列在器件库面板上，这些放在面板上的库包括： 

 项目工程中的库。如果库在项目工程中，库是被自动罗列出来的。 

 加载的库。加载的库文件可以使元件在设计环境中被使用；选择的库可以使用在不同的

工程中。 
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 库文件可以在指定的工程路径中查找。这个选项在查找仿真模型特别有用。查找路径在

项目选项对话框中定义。 

36.  加载一个库使其元件可用 

1. 加载库，在 Libraries 面板上点击

Libraries 按钮或者选择菜单 Design » 

Add/Remove Library，这样可使用的库就

显示在对话框中了。 

2. 在加载库对话框中点击 Install 按钮 

3. 在对话框中选择所需的库后，这样它将

显示在对话框的 Installed Libraries 列表

中。 

4. 选择好后就可以点击关闭对话框了。 

注意: 提供的集成库位于: \Program Files\Altium Designer\Library\ 文件夹.  

8.3.2    查找元器件 

当你不知道元件位于哪个库中，可以在库面板上点击 Search 按钮，或者菜单 Tools » Find 

Component，将弹出元器件库查找对话框。 

 

图 45.库查找对话框 

 
图 44.可用库对话框，使用安装按钮来安装或者删除库
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8.3.3 浏览库 

器件库面板给出的元件都是可以用来放置

使用的。 

 选择菜单 View » Workspace 

Panels » Libraries, 或者在工作区

底部点击 Libraries 按钮来显示

Libraries 面板。 

 Libraries 按钮显示可用器件库对话

框。此对话框显示当前可放置在该

项目的所有元件。选择安装选项，

然后单击安装按钮将库添加到库列

表中。 

 选定库所包含的元件在中筛选字段

下面的框中列出，筛选器允许您控

制哪些元件名称列出，例如 RES * 

将显示只开头 RES 的元件名称。 

 您也可以在元件列表中直接输入, 

当您输入时类型提前功能将自动跳

通过列表。按 Esc 可提前停止执行

类型提前操作。                                           图 46 从原理图编辑面板中浏览元器件库 

 单击元件的名称将:在面板的正中间显示元件符号，下面的列表显示关联的模型，而且

在列表下面还显示被选中的封装模型 

 放置按钮放当前选定的元件。双击该元件也能达到此目的。 

 搜索按钮是一个强有力的搜索工具，允许您搜索库中的器件。单击此按钮弹出库搜索对

话框。 

 如果一个元件有几个部分，sub-parts 将显示在符号库的迷你浏览器中。 

 您可以控制元件或模型列表中显示哪些列，右击选择要显示的选择列。 

8.3.4 练习–库和元件 

37. 当所需库已知时查找和加载库 

培训设计是一个微控制器驱动温度感应器。安装所提供的库并查看它是否包括 PIC 微控制器

库，完成下列步骤： 

 打开原理图文档来激活原理图编辑器。 

 在库面板上点击库按钮来显示可用器件库对话框。 



Module 3: Schematic Editor Basics 0 - 57 

 选择加载选项，然后点击安装按钮定位到目录\Program Files\Altium 

Designer\Library\。此目录包含的子目录附带支持 Altium Designer 的原理图编辑

器的集成库。 

 滚动库目录，打开文件名为“Microchip”的文件，选择并加载 Microchip 

Microcontroller 8-Bit PIC16 2.IntLib  

 点击“CLOSE“关闭可用库对话框 

 在顶端的库面板列表里选择“Microchip”库，库内容将在筛选字段部分下面框中显

示，确认库包括一个 PIC16C72-04 / SO。 

38. 当库未知的情况下查找器件 

经常有这样一种情况，你想加载一个器件，但不知道那个库中有，或者你可能想查看库中有哪

些类似可用器件。查找器件我们可以使用“Search”按钮或者菜单 Tools» Find Component 来查

找。 

1. 点击“Search”按钮，然后库查找对话框弹出。 

2. 在库路径上设定范围，设置路径 C:\Program Files\Altium Designer\Library

（包含子目录选项在内） 

3. 在培训提供的设计中电源使用 LM317MSTT3 调整器。若要在提供的库中搜索一个适当的

器件，在搜索字段对话框中键入字符串 LM317 并单击搜索按钮。 

4. 注意当前搜索的库列在库面板中，它取决于 PC 机的速度，需要花几分钟来搜索八万个元

件。 

5. 搜索结果在集成库 ON Semi Power Mgt Voltage Regulator.IntLib 中包含器

件，确认器件 LM317MSTT3 在列表中 

6. 加载此库并使元件可用，你可以在结果列表中右键单击并选择 Add or Remove Libraries

（这只是打开可用的库对话框），或者在列表中双击元件名来放置（如果是错误的工作表，

则可以轻松地删除它），你确认后对话框将出现，让你有机会安装库。 

39. 在打开的元件库中查找元件 

1. 在库面板中选择集成库 Miscellaneous Devices.IntLib，此库是安装该软件时，默

认安装的两个 PCB 库之一。它包括多种离散器件，如：电阻、电容、二极管等等。 

2. 在筛选字段里键入 cap，注意只有电容类型的器件罗列出来 

3. 尝试筛选字段中输入 diode，现在列出的只是器件开头字符串为 diode 的二极管的器件。 

4. 现在尝试键入“*diode”，这次列出来的就是字符串中含有“*diode”的器件。 

40. 当库未知的情况下查找封装 

1. 封装查找与器件符号查找是同样的；唯一区别是你需要在按 Search 按钮前在库查找面板

中设置查找类型。 
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2. 设置查找路径为 C:\Program Files\Altium Designer \Library\Pcb\IPC-SM-782. 

3. 键入字符串“0805”，然后点击查找。查找结果包含一些库，其中一个是 IPC-SM-782 

Section 8.1 Chip Resistor.PcbLib 库。 

4. 在查询结果中双击 2012[0805]的封装，会出现一个对话框，让您知道库当前未安装，点

击“YES”来安装 IPC-SM-782 Section 8.1 Chip Resistor.PcbLib 库。 

 

41. 设置库搜索顺序 

当你键入一个器件名，例如在放置器件对话框中，或者在封装模型对话框中键入一个封装名，

则将以一个默认的顺序查找可用的库。这个查找顺序就是罗列在可用库对话框中的顺序。配置查找

顺序： 

1. 在库面板上点击库按钮来显示可用库对话框。 

2. 点击安装选项，然后在安装列表中点击选择 IPC-SM-782 Section 8.1 Chip 

Resistor.PcbLib 库来突出显示它，再然后点击“Move Up”按钮来它到列表顶端。 

3. 关闭可用库对话框。 

您现在拥有完成培训设计所需的所有器件和封装 

注意：请在联机文档中查阅器件，模型和库概念的文章，获得进一步关于定义，库搜索顺序和

器件模型链接的信息。 
 

8.4    元件放置及原理图连线 

   本节主要是讲如何放置元件然后用导线把它们连接在一起。这项练习需要你创建一个完整的

原理图表。 

图 47.查找器件封装 



Module 3: Schematic Editor Basics 0 - 59 

8.4.1   放置元件 

   放置一个元器件，双击库面板里的元件名称。 

放置元件前要编辑其属性，按“TAB”键，元件属性对话框就会出现。通过按 TAB（下）或

SHIFT+TAB（上）来切换对话框中不同字段。 

新的文本将覆盖被选中的内容。 

如果你在放置元件前设置好元件的标号，那么随后所放置的元件标号就会自动递增。 

如果知道元件的名字也可以通过“Place » Part”命令放置元件。当选中这个命令时，提示你输

入元件名称，一旦输入元件名称，，就会在打开的库里寻找，如果找器件一旦找到，它就会附在光

标上。 

42. 自动递增元件标号 

当放置一个元件，如果你放置前设置好元件的 初标号，其标号就会递增直到放置好 后一个

元件。这只发生在放置元件时按下“TAB”键，并设置 初的标号。一旦你停止放置这种类型的元

件，下次放置元件时标号不再被记忆。 

通常标注元件标号很容易的，你可以让他们空缺器件标号直到设计完成，允许在原理图中控制

元件的合理分配和标注。 

8.4.2    引脚连线 

导线被用来创建点之间的电气连接。 

注意用“Place » Wire”而不是错误地放置“lines”。 

按“SHIFT+SPACEBAR”键改变导线放置模式，按“SPACEBAR”键切换导线角度。 

按“BACKSPACE”键删除 后所放置的点。 

导线必须连接到具有电气对象上的连接点上，例如，导线连接时必须接触管脚的末端。 

总线是代表一组相关信号的关系，比如数据总线是连接到一张图表上，用总线连接相关信号到

端口和原理图入口。 

总线必须用总线名字或总线参考系统的要素正如图 48 所示，必须包含单独的网络标号和总线网

络标号。 

 

图 48：用参考系统定义的总线 
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总线范围[0..7],或[7..0]。 

在原理图中移动元件并保持元件上导线的连接（尤指拖动），当点击时按住 “CTRL” 键保持

并移动鼠标（一旦开始拖动，就释放“CTRL”键）。当拖动时按“SPACEBAR”或者

“SHIFT+SPACEBAR”键切换导线的模式。按快捷键“M”拖动一个选择。 

8.4.3    练习——绘制原理图 

 

图 49：微型控制器原理图实例 
1. 如果没有打开，在基本编辑环境下重新打开项目，\Program Files\Altium 
Designer\Examples\Training\Temperature Sensor\Temperature 
Sensor.PrjPcb. 

2. 2．在“Projects”面板下点击右键选择“Add New to Project » Schematic”为项目添加新的

原理图文件。 

3. 在“Projects”面板下右键点击新的原理图文件，然后从弹出的菜单里选择“Save As”。在

“\Program Files\Altium Designer\Examples\Training\ Temperature Sensor“文

件夹下把原理图保存为“MCU.SchDoc”。 

4. 在“\Program Files\Altium Designer\Templates “的文件夹下选择” A4 “大小的

模板，通过菜单“Design » Template » Set Template File Name “设置。 

5. 在放置任何对象之前确保电气栅格使能，并设置电气栅格范围是 4，确保捕捉栅格使能并设置

大小是 10（双击原理图边框打开文档选项对话框）。 

6. 绘制原理图如图 49。当放置元件时，按“TAB “键定义元件标号和注释（元件的值）。 

Component Library Reference 

Microcontroller PIC16C72-04/SO 

Resistors Res1 

Capacitor Cap 

7. 按“SPACEBAR “键旋转元件，按” Y “键垂直翻转，按” X “键水平旋转。 

8. 设置端口 I/O 类型与其显示相匹配，设置电源和地端口的网络属性。 

9. 设置总线名字和端口名字“RB[0..7]”，目的是连接网络从 RB0 到 RB7 到总线上。 
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10. 10．为了在总线上建立网络，首先在右面创建端口，复制端口然后运行“Edit » Smart 

Paste”。从左面选择“Ports”，在右面选择“net labels and wires”。在对话框的下面部分选

择信号名字“expand buses”，你也可以设置合适的线长。注意间距以及导线是以目前的栅格设

置 10，以便导线和网络标号连接到元件的管脚。 

 
图 50：智能粘贴对话框把总线信号粘贴为网络标号和导线 

11. 在放置电阻和电容时可以用器件切断导线特性快速的切入到线里,而不需要在其周围连线。 

12. 当放置一些端口和电源端口时按住“ctrl”键然后拖动延伸对象上的线。这样在连线阶段将节

省大量的时间。 

13. 在文档选项对话框的参数标签里输入必要的文档信息，比如输入标题”PIC 微控制器”。 

这次不必设置原理图表数这个特性，系统在整个项目中会自动的设置。 

8.4.4  练习—完成原理图 

在这一阶段的练习，你的“Temperature Sensor project “项目如图 51 所示 
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图 51：MCU 原理图完成后的项目结构图 

然而，“Sensor.SchDoc”没有完成，到现在仅仅完成温度器件的放置。完成原理图绘制： 

14. 如果你还没有完成，新建一个名为“Sensor.SchDoc”原理图文档。 

15. 添加端口、电源端口并用导线完成连接，如图 52 

 
图 52：连接好的传感器原理图 

16. 保存并关闭“Sensor.SchDoc”。 

完成“sensor”原理图设计的 后一步是添加顶层原理图。 

8.5   智能粘贴 

原理图编辑中的智能粘贴特性允许你复制选择对象并在粘贴时一次性可以转换为其他对象。例

如，你可以复制一个网络标号，用智能粘贴可以粘贴成端口，或者你选择原理图输入端口口，可以

粘贴为“端口+导线+网络标号”。 
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 以平常的方式创建一个选定的对象，比如网络标号，然后复制到剪切板上（Ctrl+C）。 

 从菜单中选择“Edit » Smart Paste”或快捷键（Ctrl+Shift+V），将弹出智能粘贴对话

框，如图 53 所示 

 
图 53：智能粘贴对话框 

8.5.1    选择粘贴的对象  

本节在对话框里会显示一个按类型分类的所有对象的列表。复选框里允许你选择想粘贴的对

象。在粘贴前必须选择”Paste Action “，这确定所选择对象以什么方式放置在你的原理图中。 

8.5.2   选择粘贴行为 

在粘贴前要选择”Paste Action “。这确定把所选择的对象在原理图中转换成什么样的对象。粘贴

“本身”叫做一次标准的粘贴操作。其他选项在粘贴时允许把源对象转换成其他不同的对象，或集

合对象。 

可能的转换包括： 

 端口，原理图页面输入端口或网络标号可以同等的转化成端口，原理图页面输入端口，

网络标号，或者一个文本框/注释或一个端口和网络标号（带连线）。 

 标签，文本框或注释可以转化成标签，文本框或注释。 

 Windows 的剪切文本可以转化成网络标签，端口，原理图页面输入端口，标签，文本

框，注释，或端口和网络标号（带连线）。 

 Windows 剪切板里的图形可以转化成图像。 
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8.5.3   阵列粘贴  

启用此选项把你选择的对象复制成一个二维阵列。你将创建拷贝的行数和列数。点击 OK，将

会在文档上提示你选择插入阵列的起始位置。只需光标移动到想要的位置然后点击即可。 

列 

在阵列粘贴中具体设置复制元件阵列的列数。“Spacing”编辑框用于设置阵列元件中的每列相

邻元件的间距。若设置为正数，则元件由左下到上排列，若设置为负数，则元件由上到下排列。 

行 

“Rows”栏用来设置复制元件阵列的行数，“Spacing”编辑框用于设置阵列元件中每行相邻

元件的间距，即行间距。若设置为正数，则元件由左向右排列，若设置为负数，则元件由右向左排

列。 

文字增加栏 

“Text Increment“栏用于设置阵列中元件编号递增的参数。你可以从下面几项中选择： 

•  方向 

“Direction”下拉列表确定元件编号递增的方向。 

“None “项表示元件编号不递增。 

“Horizontal First”表示元件编号递增的方向是先水平方向从左向右递增，再竖直方向由下往

上递增。“Secondary”编辑框用于在复制引脚时，设置引脚序号的递增量。 

“Vertical First”表示先竖直方向由下往上递增，再水平方向从左向右递增。“Primary”编辑

框用于设置每次递增时，元件主编号的递增数量，“Secondary”编辑框用于在复制引脚时，设置

引脚序号的递增量。 

• 主要的 

“Primary”编辑框用于设置每次递增时，元件主编号的递增数量。 
• 次要的 

“Secondary“编辑框用于在复制引脚时，设置引脚序号的递增量。这两个编辑框既可以设置

为正数（递增），也可以设置为负数（递减）。 

8.6 设计复用 

8.6.1    片断设计面板 

片断设计面板提供了一种方法存储部分的设计以供日后复用。该面板将存储分为原理图，PCB

布局以及源代码。 

 在底端的 右边点击 System » Snippets 将会打开片断设计面板。 
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图 54：片断设计面板 

 片断的内容分成不同文件夹。这些都是通常的 Windows 文件夹，它们的位置从

“Snippets Folders” 按钮下配置。可以定义多个文件夹；使用网络共享资源在整个团

队设计中将分享摘录库。 

 要创建一个片断，在原理图，PCB 或源代码中选择对象，然后点击右键选择“Snippets 

»  Create Snippet from selection “。 

 在面板顶部点击“Place button “，可以放置选择的片断。 

 如果你在创建片断前重新选择元件标号，你就可能避免在放置片断时元件重复标号。 

8.6.2    剪切板面板 

 
图 55：剪切板面板 
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剪切板面板提供了一个可以召回以前的复制行为。该面板存储复制的部分包括原理图，PCB 布

局和源代码。 

 从面板控制的右下角点击“System » Clipboard “打开” Clipboard”面板。 

 剪切板增加了能够读取 Windows 剪切板的优势，允许从其他粘贴过来的数据转化到

Altium Designer 里。要启用此项，在参数设置对话框中的“Systems – General”下关

闭“Monitor clipboard content within this application only”选项。 

 剪切板面板数据仅适用于当前的编辑，和片断设计面板不同可以把数据存储在硬盘上。 
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9.  全局编辑                               （45 Minutes） 

9.1 DXP 数据编辑系统  

作为一个设计者面临的 大挑战是管理在设计中所创建的大量的设计数据，为此，Altium 

Designer 提供了图 56 所示对象过滤/高亮显示系统。 

 
图 56 过滤/高亮系统图表 

一个强大的数据编辑系统允许你用多种方法来管理，查找，编辑你的设计数据。 

为了灵活实用的编辑数据的方法，提供了三种可交替的数据查看方式访问和编辑设计设计对

象： 

• 传统的图标查看 

• Inspector 面板 (按 F11 打开或关闭) 

• List 面板 (按 Shift+F12 打开或关闭) 

Inspector 显示当前被选中的工程的属性，底部显示在列表中实际被选中的总数。注意

Inspector 能同时编辑不同类型的工程。 

List 面板提供了一个类似的电子数据表格，列出在原理或 PCB 工作区中的对象列表，在 List

中单个或多个单元都可以被编辑。 

强大的对象过滤功能用来控制当前在三个视图中编辑的大量数据，数据可通过 PCB 编辑面板中

查找相似对话框进行过滤，或者通过在 Filter 面板中写入查询来实现。 

Filter 面板常被用来设置一个查询来过滤整体的数据设置，减少在图形显示并在列表面板中仅

显示满足查询的对象。在图表中将灰色显示那些已经被过滤的对象（并不能被再编辑）。 

数据编辑系统 强的特征是能够同时编辑多个对象。访问数据编辑系统 基本的方法是：  

 选择需要编辑的对象 

Display dataFiltering Engine

Filter
panel

Navigator
panel

FSO
dialog

Highlighting Engine
(Mask, Select, Zoom)

Query Engine

Design data
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 检查对象 

 编辑对象属性 

9.1.1    使用查找相似对象对话框查找和选择对象 

当元器件和网络等分类对象进行操作时这个面板非常实用。你对一个基本对象要素操作时，一

个高效的方法就是使用 Find Similar Objects 对

话框。  

 在 Find Similar Objects 对话框中, 

右键点击一个对象，然后从弹出菜

单中选择 Find Similar。  

 对话框出现后，列出该对象的属

性。. 几乎每一个属性都有一个下拉

框，设置你想要的匹配标准。 

 单击 Apply 对话框不关闭，开始查

找匹配对象。单击 OK 关闭对话框

开始查找。 

 选择所有匹配标准的对象。图 57 显

示通过 Find Similar Objects 对话框

来设置选择和查找所有 PCB 元器件

标注字符串。  

 通过 Inspector 复选框自动启动

Inspetor，在 Inspector 上可以编辑

查找和选择到的对象的任何属性。 

9.1.2  检查和编辑被选择对象 

Inspector 面板常用来检查和编辑当前被选择的对象，

对所有被选择对象做整体编辑。 

 按 F11 打开关闭 Inspector 面板  

 Inspector 能用来检查一个或多个对象 

 被选择对象的设置有多种方法，包括手动，写

一个查询，或者使用查找相似对象对话框。 

 不同的对象只有当它们共有的属性可被编辑时

才能被选择和编辑。 

 在 Inspector 里改变属性后，按 ENTER完成 

 在 Inspector 中可以使用字符串的替代功能。. 
 
 

 
图 57. 使用查找相似对象高亮所有器件注释 

图 58. Inspector 显示所选位号和注释

字符串的属性 
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9.2 全局编辑实例（练习 – 编辑对象 ） 

这个例子演示通过不同方法来调整元件走线的宽度，弧和元件文本框的高度 

9.2.1   元器件注释字符串明显度的改变 

1. 在 4 Port UART and Line Drivers.SchDoc 中找到元件 S1 

2. 在元件符号上点击右键然后在弹出菜单中选择 Find Similar  

3. 出现 Find Similar 对话框，显示被选择对象的属性。注意 Parameter name 属性下有一个

批注值。 通过设置 Same 来查找相同的属性。 

4. 勾选 Run Inspector 复选框，清除 Create Expression 复选框，然后点击 OK。 

5. Inspector 出现 24 个被选对象，点击 Hide 属性，然后按 ENTER完成改变。所有元器件注

释字符串将在原理图中被隐藏。 

9.2.2 练习 –List 面板 

我们将用 List 面板在原理图库编辑器中创建一个原理图符号。 

1. 打开工程例 4 port serial interface，然后打开该工程中包含的原理图库  

2. 点击右下角的控制面板 SCH » SCH Library 打开库面板  

3. 打开 Tools » New Component 给元器件取个名字 EP2C5 

4. 设置当前栅格为 10，你将在屏幕左下方看到当前栅格，在工作时可使用快捷键 G 来快速改

变栅格 

5. 在 Windows 中从 C:\Program Files\Altium Designer \Examples\Training\Practice 

Documents\ directory 目录下打开 TestBook.xls Excel 文件 

6. 在表格的右边你可以查看到一组以 Object Kind 开始，以 Designator 结束的列表，这组

列表是通过在 Altera Cyclone II 数据手册中复制并粘贴过来的部分资料来创建的，并通过

Excels 表格增强了其函数调用功能，你需要使用 ctrl-c 复制这这组列表包括名字到剪贴板 

7. 一旦被复制，返回 Altium Designer ，在右下角的控制面板中点击 SCH » SCHLIB List 打

开库列表面板 

8. 如果是 View 模式，设置 List 面板到 Edit 模式，确定 current component 已设置 

9. 在 List 面板中点击右键，然后选择 Smart Grid Insert. 
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图 59.随粘贴出现的智能网格插入对话框 

10. 图 59 对话框显示你现在能从电子表格中设置到 Altium Designer 的列表。在这个过程中，

如果没有复制列的名称，可以手动来完成，在上面部分选择一列并在下面部分选择匹配的

列，，然后按 Paste Column to Attribute 按钮来链接。 如果正确复制了列表名称，通过点

击 Automatically Determine Paste 按钮完成自动粘贴  

11. 当所有的栏对应正确，你可以点击 OK，然后原理图符号的管脚将被立即创建 

注意: 如果你发现所有的管脚彼此堆积到一起，请确定你的栅格设置是否为 10 
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10.完成设计项目              （45 minutes） 

10.1 多层次设计介绍 

10.1.1 结构化多层次设计 

几乎 小的设计也需要多张图纸来完成。实质上有两种途径来构造一个多表设计，要么单层次

的，要么分层次的。单层次的设计就是从一张原理图到另一张原理图网络间的连接是直接的，也可

能是连接到其它许多张原理图。 

虽然单层次的设计对于小数量的原理图和网络标号是适用的，也许 6 张原理图，但是对于大的

设计就不适用了。因为一个网络可以转到其他原理图的任何位置，为了指导阅读者找到在另一个原

理图上的网络，一个较大的单层次设计就需要导航指示。单层次设计的优点在于通常情况下只有较

少的原理图和绘制较少的连线。 

层次设计在结构中表现为页与页的关系。它通过符号来完成，称为图纸符号，在层次设计中代

表底层图纸。图纸符号代表下层的图纸，并用图纸入口代表与下层图纸端口的连接。层次设计的优

势是为读者显示设计的结构，其连通性是完全可预测的和容易查看的。因为它总是从子图到母图上

的图纸符号。 

下图显示的是温度传感器项目的顶层原理图。在设计中每个图纸符号代表一个子原理图。 

图 60.温度传感器的顶层原理图 
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10.1.2 多层次设计的连接 

多图纸设计的电气连接性是通过原理图中提供的网络标示连接的。 

43.           网络标识 

在同一网络的点对点之间由网络标识建立逻辑连接。它可以在一张原理图中，或在多张原理图

中。物理连接存在一个对象直接由导线连接到另一个对象。逻辑连接时，创建两个相同类型的网络

标识（如，两个网络标号），并有相同的网络属性。注意，逻辑连接不是创建两个不同的网络标

识，例如一个端口和一个网络标号。唯一的例外是当一个端口连接到相同名称的图纸入口，在图纸

符号里它代表图纸上的端口（更多稍后介绍）。 

网络标识包括： 

网络标号—使用网络标号唯一标识一个网络。这个网络连接到同一原理图中具有相同名称的网

络，也可以连接到不同原理图中具有相同名称的网络，依据设计模式定义连接方式（参考网络标识

范围）。网络标号隶属于单独的导线，元件器件管脚和总线。 

端口—依据连接方式，一个端口可以横向连接具有相同名字的其它端口，或纵向的连接到具有

相同名字的图纸入口。 

图纸入口—当连接是纵向的，你可以用图纸入口连接到下层原理图中有相同名字的端口。添加

一个图纸入口执行“Place » Add Sheet Entry”命令。 

-
ENABLE

RESET
VCC

RESET

ENABLE

sheet
entries

power
port net label

port

 

 

图 61. 网络标识 

电源端口—整个设计中所有相同名称的电源端口是相互连接的。 

隐藏管脚—隐藏管脚类似电源端口，在整个设计中，连接所有具有相同名称的网络。 

44.             网络标识范围 

当你为设计建立一个连接方式时，你必须定义你如何识别彼此之间网络标识的连接—这称为网

络标识范围。网络标示的范围在“Project Options”对话框里的“Options”标签里有具体说明。在

设计的开始时应设置网络标示的范围。 

在多层次设计中基本上有两种方式连接原理图：要么横向，直接从一个原理图到另一个原理

图，或其他原理图等等；要么是纵向，由图纸符号从一个子图连接到母图上。在横向连接中，连接

是从端口到端口（网络标号到网络标号也可以）。在纵向连接中，连接是从图纸入口到端口。网络

标识范围明确说明你如何连接想要连接的网络标识。 

单层的—整个设计中端口连接所有的原理图。选择这一项，网络标号对每张原理图来说是本地

的，他们不会跨原理图连接。在所有的原理图中具有相同名字的所有端口将会连接。此选项可以用

于单层的多图纸设计。由于它很难在原理图中查看网络，所以它不适用于大型的设计。 
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全局的—在整个设计中通过端口和网络标号连接所有的原理图。选择此项，在原理图中所有相

同网络标号的网络将连接在一起。此外，在所有原理图中具有相同名字的所有端口将连接。如果一

个网络连接一个具有一个网络标号的端口，那么它的网络的名称将是其网络标号的名字。此选项也

可以用在单层的多图纸设计，然而它很难查看从一个原理图到另外一个原理图，因为在原理图上查

看网络名称总是不太容易。 

层次的（图纸入口/端口连接）—在端口和匹配的图纸入口之间纵向连接。此选项使得底层原理

图仅仅通过图纸符号的接口匹配到子图的端口上。它在原理图中使用端口把网络或总线连接到顶层

相应的图纸符号入口。无匹配图纸符号接口的端口在原理图中不会连接，即使在另一张原理图中具

有相同名字的端口。每张原理图中的网络标号都是本地的，它们不会跨原理图连接。此选项可用于

创建任何深度或层次的设计，并允许在整个原理图设计中查看网络。 

在自动模式下，自动选择使用三个网络标识的哪一个是基于以下标准：如果在顶层有图纸入

口，那么采用分层；如果没有图纸入口，但是有端口，那么采用单层的；如果即没有图纸入口也没

有端口，那采用全局的。 

注意：两个特殊的网络标示对象总是认为是全局的：电源端口和隐藏管脚。 

概要 

如果你使用带有图纸入口的图纸符号，网络标识范围将设置图纸入口/端口连接的范围。如果选

择此模式，顶层原理图必须有连线。 

如果你不使用，通过端口或网络标号可以建立起连接，因此你会使用其他两个网络标识范围中

的一个。 

网络标号不会连接到相同名字的端口上。 

10.2 构建完整的项目 

10.2.1      创顶层图纸 

手动创建一个顶层图纸，放置图纸符号，设置每一个图纸符号的名称属性均指向正确的子图，

并且根据子图相应端口把图纸接入添加到图纸符号上。 

我们也有创建多图纸的快捷命令方式 

Create Sheet from Symbol 命令是自上而下的设计。一旦顶层图确定好，这个命令就可以为图

纸符号创建子图和放置端口。 

Create Symbol from Sheet 命令是自下而上的设计，基于选定的子图创建一个包含图纸接入点

的图纸符号。这我们现在使用的模式。 

10.2.2  练习 — 创建一个温度传感器顶层图纸工程 

参考图 60 完成这个练习 
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1. 创建顶层图,在温度传感器工程中添加新的原理图文件，设置图纸规格为 A4 并保存在

Program Files\Altium Designer 6Altium Designer\Training\Temperature 

Sensor\Temperature Sensor.SchDoc. 

2. 我们不用手动方式为底层图纸放置和编辑图纸符号，而选用 Design » Create Sheet 

Symbol from Sheet or HDL 命令。从菜单中选择这项。 

3. 在 Choose Document to Place 对话框中，选择 Sensor.SchDoc. 

4. 图纸符号将以浮动光标形式出现，像图 60 所示，在图的合理位置放置图纸符号 

5. 注意到两个图图纸接入点在方框图左侧，这是因为依据它们的 I/O 类型放置的，输入及双

向点在左边，输出点在右边。拖动左边的两个点到右边。 

6. 关于图纸接入的另外一个重点就是，除非你在 Preferences（参数设置）中的 Schematic 

tab 对话框中把 auto sheet entry direction (自动图纸入口指向)选项激活，否则他们的 i/o 类型

就是他们模式（他们的指向）的独立标志。当在左侧的时候 SCL sheet entry 是指向内部的，

当他在右侧的时候，并且 sheet entry direction 选项没有被选中的情况下，它是指向外部的。

打开 Preferences（参数设置）对话框确定这个选项是激活的。 

7. 重复上述步骤分别为 MCU, LCD and Power sub-sheets 创建图纸符号 

8. 放置连接器 J1，他是一个 Header 3X2A，你可以在 Miscellaneous 

Connectors.IntLib（默认状态下安装的两个集成库之一）中找到 

9. 按图 60 给层次图放线 

10. 保存顶层图.这就完成了设计进程中的捕获阶段。为了确保这个设计的层次是正确的我们现

在来编译一下这个设计。目前我们将简单的编译一下，在 Projects 面板上展示一下这个设计

的正确结构。 

11. 编译这个工程，选择 Projects » Compile PCB Project Temperature Sensor.PrjPcb。确保

你所运行的编译是正确的，因为在工程菜单中有两个编译文件。一个编译的焦点是现行的原

理图文件,另外一个编译的是整个工程。我们需要的是编译整个工程。 
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                图 62.一旦编译完成，工程的层次表将展现出来。 

12. 保存工程（在 project 面板上右击这个工程） 

   设计现在已经完成了，但是在被转到 PCB 板上之前还有几个工作要做，包括 

  --在层次表上为每一个图表指定一个图纸编号 

  --分配位号 

  --检查设计错误 

10.2.3    分配图纸编号和图纸总数 

图纸编号通过设定文件参数实现，链接放置在原理图上的特殊字符串，图纸自

动编号通过 Tools » Number Sheets命令实现 

 图纸编号对话框可以用来实现： 

-为图纸编号（参数 SheetNumber） 

-为文件编号（参数 DocumentNumber） 

-统计图纸总数（参数 SheetTotal） 

 点击需要被编辑的列进入对这些列的编辑状态 

 可以通过各种方式为图纸和文件编号，选中 SheetNumber，然后再点击 Auto 

Sheet Number按钮 

 每一个单元都可以手动编辑，选择目标单元，右击选择编辑（或者用空

格键）。选择 Move Up and Move down（向上和向下）按钮，或者按照

display order（显示的顺序）编号 
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图 63 通过图纸编号功能来查看或更新图纸编号 

注意：原理图在工程面板上是按照你所添加的先后顺序显示的。你可以按照你的要求来改变这

个顺序。只需要简单的点击，然后拖放到一个新的位置即可 

10.3     元件标注 

原理图编辑工具包含一个对器件基于位置的重新标注工具，通过这个工具可以给期间从新分配

位号。 

10.3.1    通过标注来分配元件标号 

标注选项包括： 

 更新更改列表—此按钮将重新分配当前未分配的所有位号 （它们的位号应该以一个?结

尾） 

 重置所有—使用重置所有按钮重置所有位号为?结尾，您还可以限定只重置重复的位

号。 

 处理顺序 — 有四个方向选项可用。在顶部左侧的对话框选择 佳的一个，它使用页面

网格来定义水平/ 垂直递增。 

 匹配选项—启用这个参数选项用来封装多部分元件。 通常，这基于元件注释。 如果有

特殊器件，必须一起封装，提供一个通用的参数，然后在元件参数列表中启用此参数

（例如 filter-stage1）。注意右下的对话框底部的 Annotation Summary 提供了匹配行

为的信息。 

 原理图页面标注—对话框的此部分提供每一个页面的标注控制，能从进程中排除某些页

面，还可以为每个页面的的标号设置起始编号。 



Module 3: Schematic Editor Basics 0 - 77 

 反向标注—单击此加载一个 Was／Is 文件。它仅仅是在不用 Altium Designer 设计板子

的情况下用到。如果您是在使用 Altium Designer 设计，您可以直接从 PCB 反向标注原

理图，只需要使用菜单命令 Design » Update 

 每当更新或重置命令执行时会出现一个信息对话框。 此对话框详细统计与上一个状态

（自上次更新或重置）有多少改变，信息对话框还列出了从原始状态更改的详细统计

（自打开注释对话框起）。 

 一旦满意标注分配，单击 Accept Changes 按钮产生一个 ECO。 在 ECO 对话框中您

可以更新原理图。 

注意：若要防止元器件在标注过程更改其标号，启用元器件属性对话框中标号旁边的锁定复选

框。 

10.3.2      多部分元器件的标号 

多部分元器件的后 可以是希腊字母或数字，取决于在参数设定对话框中的希腊字母和数字后

选项。 这是一个环境设置，将适用于所有打开的原理图页面。 

您可以使用 Edit » Increment Part Number 命令更改在一个元器件内的零部件，选择此命令，

然后单击要更改的器件部分。 

注意：若要防止多部分元器件在标注过程更换其标号，启用元器件属性对话框中零部件旁边的

锁定复选框。 

10.3.3    练习 – 标注设计 

1. 在主菜单选择 Tools » Annotate 

2. 在标注对话框中，点击 Reset All 按钮，然后点击出现的信息对话框的 OK 按钮。请注意

对话框中的建议标号列现在显示所有位号符上有一个？ 的作为其批注索引。 

3. 点击 Update Changes List 按钮来给每一个元器件分配一个唯一的位号，元器件根据顶部

设置对话框选择的方向位置顺序标注。 出现的信息对话框统计有多少表示已从其原始状态更

改。如果不是所有的元器件都获得了新的标号请不要奇怪，可能是因为他们在页面上的位置

导致它们被标注成同样的标示。 

4. 重复重置和分配、 更改方向选项的过程，用您喜欢的方向选项完成。 

5. 提交更改并更新元器件，点击 Accept Changes 按钮生成 ECO。在 ECO 对话框点击

Execute Changes，然后关闭 ECO 和标注对话框。 

6. 请注意，曾接受过更改的的每个文档在其窗口顶部的文档选项卡上的名称旁边有一个 *，

保存项目中的所有文件。 

10.3.4      多部分元器件的标号 

多部分元器件的后 可以是希腊字母或数字，取决于在参数设定对话框中的希腊字母和数字后

选项。 这是一个环境设置，将适用于所有打开的原理图页面。 
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您可以使用 Edit » Increment Part Number 命令更改在一个元器件内的零部件，选择此命令，

然后单击要更改的零部件。 

注意：若要防止多部分元器件在标注过程更换其标号，启用元器件属性对话框中零部件旁边的

锁定复选框。 

10.3.5    练习 – 标注设计 

1. 在主菜单选择 Tools » Annotate 

2. 在标注对话框中，点击 Reset All 按钮，然后点击出现的信息对话框的 OK。请注意对话框

中的建议标号列现在显示所有指示符，有一个？ 的作为其批注索引。 

3. 点击 Update Changes List 按钮来给每一个元器件分配一个唯一的标示，元器件根据顶部

设置对话框选择的方向标注位置顺序。 出现的信息对话框统计有多少表示已从其原始状态更

改。如果不是所有的元器件都获得了新的标号请不要奇怪，他可能是因为他们在页面上的位

置导致它们被标注成同样的标示。 

4. 每次重复重置和分配、 更改方向选项的过程，用您喜欢一个方向选项完成。 

5. 提交更改并更新元器件，点击 Accept Changes 按钮生成 ECO。在 ECO 对话框重点击

Execute Changes，然后关闭 ECO 和标注对话框。 

6. 请注意，曾接受过更改的的每个文档在其窗口顶部的文档选项卡上的名称旁边有一个 *，

保存项目中的所有文件。 
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11. 项目编译及验证                   （45 minutes） 

这一节将讲述如何验证一个设计，这是切换到 PCB 布线前

一个必不可少的步骤。在 Altium Designer 下，检测设计是否完

成，通过编译设计实现，它可以检查出逻辑性、电气性和画图的

错误。 

 进行设计的编译，选择 Project » Compile PCB Design。 

一旦设计进行了编译，它可以在 Navigator 面板上找到。

编译的结果会显示在 Messages 的面板上；在这，你可以双击

信息跳到相应的错误或警告上。Messages 面板只会在有错误

的时候自动打开，如果该面板没有显示出来，可以单击工作区的

System 按钮打开该面板。 

注意，默认的错误检查选项是在连接矩阵中设定，因此检查

相应设置和调整它们，以合适你的项目和设计的要求。 

11.1 设置设计编译选项 

当你编译设计的时候，DXP 会建立一个项目可连接的模

式，你可以把它想像成是一个内部的网络表。内部网络的存在允

许你去查找或查看项目的组织结构。 

11.1.1 编译选项 

 在项目能被编译之前，必须先配置项目选项。它通

过项目选项对话框中的选项标签完成(Project » Project Options)。 

 Net Identifier Scope 必须适合设计的结构。这点已在 10.1.2 .2 的多图纸设计中的网络

标识范围一节中描述过。 

 当设计被编译时，它可以在 Navigator 面板上查找到。选择 Navigator 面板顶部的

Flattened Hierarchy 功能，当你选中一个元件或网络时，该元件或网络将会显示在工

作区上。 

 使用“+”展开元件或网络时，可以访问元件的所有引脚或是所有引脚/网络的标识符。 

 点击 Interactive Navigation 按钮右边的 按钮，可以配置工作区如何显示的相关选

项。 

 Zoom: 跳到电路图层和放大所选对象。 

 Select: 选中所选的对象。 

 Mask: 除所选对象外其它全部对像祛色。控制遮盖祛色度使用屏幕右下方的 Mask 

Level 按钮。清除祛色使用快捷键：Shift+C 。 

图 66. 使用导航器来查看设计连

通性 
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 Connective Graph: 显示红色（网络对象）或绿色（元件）图线的连接关系。  

 在面板中的导航按钮充许你进行全局的查找，点击它得到一个十字光标，然后选中一个

工作区的电气对象，例如一个条连线，网络标号，端口等，会高亮显示所有电气连接对

象。 

        该 上/下 层次按钮也可以用于设计的查找。 

11.1.2 错误报告选项 

 

图 67 错误报告的设置 

错误报告选项包括 Error Reporting 标签和 Connection Matrix 标签。 

错误报告选项是一个大的阵列，其相关的一边拥有默认设置。一般来说， 好编译设计，如果

你的设计上出现的警告信息不是关键问题的话，可以更改报告的等级。 
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11.1.3 连接矩阵 

 

图 68 ERC 规则矩阵表 

 项目选项对话框中的 Connection Matrix 表如图 68 所示。该矩阵提供了一个从元件引

脚和网络标识之间建立规则连通性的机制。它定义了所报告警告或是错误的逻辑和电气

条件。 

 例如：一个输入引脚连接到另一个输入引脚通常将不会被认为是错误的，但是连接到输

出引脚则肯定不是错误的。这些都反应在表格里。 

 当点击矩阵上相应的小方块时，规则可以改变。多次的点击可以在选项范围内循环选

择。 

11.2 系统消息框及错误查找 

 当编译项目时，任何产生警告和错误的信息都会显示在 Messages 面板上。注意，

Messages 面板只会在有错误的情况下自动打开。 

 双击其中一个警告/错误，可以打开 Compile Errors 面板，然后双击该面板上所显示的

一个对象，可以跳到相应的原理图上。 

 Messages 面板上单击右键可以清除信息。单击列的标题。双击其中一个信息，可以打

开 Compile Errors 面板，在此面板上双击可以交叉探测原理图上的对象的。 

 一旦错误的条件被修正后，之后的编译会除去相应的警告/错误信息。 

 仔细审查每一个警告/错误和解决它们是很重要的，可以改变错误检查报告的模式，或

是给它加上 NO ERC 标记。在切换到设计的 PCB 布线前，这些经常都需要做。 

11.2.1  练习——配置项目选项 

1. 选择 Project » Project Options 打开项目选项的对话框，选中 Options 标栏。 
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2. 对于这个项目，Net Identifier Scope 一项保留默认。仅开启 Allow Ports to Name 

Nets 中的 Netlist Options 一项。 

11.2.2 练习 — 设计校验 

1. 使用编译功能检查你的设计，检查所有的错误或警告。 

2. 解决所有错误。注意，‘Nets with no driving source’ 报告任何一条不包含至少一个管脚有

电气类型为：输入、输出、开极、高阻、发射极或电源的网络。 

3. 如果你有一些余留的警告，那不会影响你的设计，你可以直接忽略它们或是考虑在

Options for Project 对话框里的 Error Reporting 标签上，把警告类型转成 No Report。  

一些技巧 

 检查每一个带有错误的对像。 

 开启 Graph 选项，检查网络的连通性。一旦在 Navigator 面板上选中一条网线，在

设计上就会高亮显示出来。你也可以使用 ALT+左键单击其中一个网线，让其高亮

显示在当前电路图纸上。 

 输入引脚的错误通常是由于输入源有问题。如果输入看起来是正常的，追踪信号的

来源（输出引脚/端口）。 

注意：打开下底层原理图时，按住 CTRL 键双击图纸上的页面符号。 
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12. 集成库概念介绍                  （45 minutes） 

12.1 集成库模型介绍 

Altium Designer 引入了集成库的概念，也就是它将原理图符号、PCB 封装、仿真模型、信号完

整性分析、3D 模型都集成在了一起。如图 42 所示，需要将每一个元件的 PCB 封装、仿真模型、信

号完整性分析、3D 模型都添加到原理图符号上，进行关联，然后编译，使之生成集成库。这样，用

户采用集成库中的元件做好原理图设计之后，就不需要再为每一个元件添加各自的模型了，大大的

减少了设计者的重复劳动，提高了设计效率。 

12.2 dblib, svnlib 库类型介绍 

在以往的产品设计中我们经常被如下问题困扰： 

 元器件的采购周期太长，造成研发延期； 

 元器件采购错误，造成研发延期； 

 研发出来的产品成本超过预算； 

 大量长期不用的元器件占据我们库存管理的资源； 

 … … 

诸多问题的 终根源是，由于传统的 EDA 工具没有提供与数据库的接口能力，所以不能提供设

计人员与采购人员之间良好沟通的桥梁。另外，由于传统的 EDA 工具都是单点解决方案，所以各个

设计人员之间不能够做到设计库的共享，不仅浪费了工程师的宝贵时间，而且还为整个公司库的管

理和统一带来极大的不便。 

基于 新网络技术和计算机技术开发的新的统一的电子产品开发平台——Altium Designer，不

仅能够实现统一管理设计元件库，而且它能够连接公司的数据库，在设计中实时查看数据库中各种

元器件的采购信息和库存信息，搭起了设计人员与采购人员之间双向沟通的桥梁。 

 创造发明了集成库，把原理图符号、PCB 封装、信号仿真模型、信号完整性分析模型

和 3D 模型等元器件相关的各种模型信息关联起来，方便设计库的统一管理； 

 通过 DBLink 文件方式，为每个集成库元件添加了与数据库的接口链接，可以实现远程

调用数据库信息； 

 完整数据库驱动的器件信息系统——DBLIB，它即实现了 Altium Designer 与数据库的

链接，也方便统一管理设计元件库，它更方便把 Altium Designer 的电子设计平台集成

到 PDM/ERP 系统中； 

 SVNDBLIB 在 DBLIB 的基础上，把元器件各种模型信息，如原理图符号、PCB 封装、

信号仿真模型、信号完整性分析模型和 3D 模型等，添加进 PDM/ERP 系统的版本控制

流程，更加保障了设计元件库的安全性和统一管理； 



Module 3: Schematic Editor Basics 0 - 84 

12.2.1 DBLIB 

完整数据库驱动的器件信息系统——DBLIB，它的系统模型如下图所示。我们需要为原有的数

据库中添加列表，这些列表代表着元器件的各种模型信息，从而组成了新的中心数据库。 

工程师在使用 DBLIB 放置一个器件时，Altium Designer 软件通过数据库接口链接到中心数据

库并读取与这个元器件相关的所有列表。它读取到元器件的各种模型信息，然后到模型信息指定的

文件中找到模型信息，并加载到设计中。同时，它把这个元器件相关的其他信息，如采购信息和库

存信息等加载到这个元器件的属性中。 

Altium Designer 软件，就是通过这样的方式从远方数据库获取采购和库存等信息。由于通过数

据库形式固定了元器件各种模型之间的对应关系，所以做到了设计元件库的统一管理。如果我们的

数据库是来源于公司的 PDM/ERP 系统，那么 DBLIB 也可以实现 Altium Designer 电子开发平台与

PDM/ERP 系统在器件库方便的集成。 
 

 
图 69   DBLIB 系统模型 

采用 Dblib 的实例步骤如下： 

1．建立数据库格式的库文件 

采用 Altium Designer 的 DatabaseLib Editor ，如图 70 所示，建立并管理一个数据库格式的库

文件。建立一个新的数据库格式的库文件，可以在菜单上选择 File » New » Library » Database 

Library  命令。 
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图70 Altium Designer的DatabaseLib Editor 

例子请参考 VishayCapacitor.DBLib，可在\Program Files\Altium Designer 

\Examples\Cis\Example DBLib 文件夹中找到。  

2． 连接到外部的数据库 

Altium Designer 可以连接任何提供 OLE DB 支持的数据库。一些数据库可能不提供 OLE DB 支

持，但是目前使用的所有的数据库管理系统都可以通过开放式数据连接接口（ODBC）来访问。 

建立与外部的数据库的连接，可以使用 Altium Designer 的 DatabaseLib Editor 窗口中

Source of Connection ，如图 71 中提供的方式。 

 
图 71  建立与外部数据库的连接 

 快速连接到 Access 或 Excel 形式的数据库 

如果外部数据库是通过 Microsoft Access 或者 Excel 建立的，你可以选择 Select Database 

Type 建立连接。在下拉菜单下选择数据库类型，然后点击 Browse 选择目标数据库文件。 

 建立一个连接线程 

如果外部数据库不是通过 Microsoft Access 或者 Excel 建立的，你可以选择 Use Connection 

String 选项来建立连接线程。点击右边的 Build 按键 ，Data Link Properties 对话框会弹出来,

如图 76。  
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Altium Designer 缺省的 OLE DB Provider 是 Microsoft Jet 4.0 ，你可以点击 Provider 菜

单来选择你需要的 OLE DB Provider 或者 ODBC。在 Connection 菜单下，你可以选择或者输入外部

数据库的文件名（包含路径）。如果外部数据库需要登陆访问，你可以在这里输入登陆信息。其他

高级的设置请选择 Advanced 菜单。在 All 菜单下，是所有连接选项定义的汇总。你可以在这里更改

它们的设置。 

所有设置完成后，你可以点击 Connection 菜单下的 Test Connection 按钮。如果设置正确，

则会有连接成功的对话框弹出。 

 
图 72  Data Link Properties 对话框 

 指定一个数据连接文件 

如果你要连接的数据源是由 Microsoft 公司的数据连接文件（*.udl）来描述的，你可以选择

Use Data Link File 选项来指定数据连接关系。点击右边的 Browse 来指定你需要的数据连接文

件。 

3．建立连接 

如果你正确的定义了外部数据库的连接关系，Connect 按钮上的字会变成黑体。点击这个按

钮，如果正确连接按钮上的字会变成灰色的 Connected，同时外部数据库的表格和关联信息会出现

在这个 DBLib 文件中。如果连接有问题，怎会有提示跳出。检查数据库设置后，在重新连接。 

 

图 73  连接不正确 

4． 数据库列表 
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当正确连接到外部数据库，窗口的左边会出现数据库中所有的专栏列表名称（如图 74 所示）。

当这个数据库格式的库文件被在 Libraries 面板中选为可用的库文件时，这些列表都将以独立的库

文件实体出现。 

右侧的 Enable 选项如果选中，则该列表会以独立的库文件实体出现；如果未选中，则不会以独

立的库文件实体出现。 

 
图 74   数据库专栏列表 

当我们选择列表中的一个条目，它的图标会由 变成 。同时数据库的详细信息会出现在

Table Browses 中。如图 75 所示。这个列表是不可更改的。 
 

 
图 75   Table Browses 列表 
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5．数据库中的域和设计参数的对应 

我们点击 Field Mappings 图 76 将出现。第一列 Database Field Name 列出了数据库中所包含

的所有域的名称。第二列 Design Parameter 列出了设计中与器件相关的参数。Update Values   

设置数据库那边更新，设计图纸尚更新与否；Add To Design  设置这个参数是否加到设计中； 

Visible On Add  设置这个参数是否显示； Remove From Design 设置这个参数是否从设计中删

除。 

 
图 76  设置器件参数映射和更新选项 

DBlib 创建好之后，在设计中可以使用数据库格式的库文件。 

使用之前先加载数据库格式的库文件。数据库格式的库文件同样是在 Library 面板上加载的。和

其他库文件不同的是加载数据库格式的库文件在库文件列表中会出现很多的文件列表。我们点击打

开一个库文件，和其他集成库文件的操作结果一样，库中的所有元件出现在列表中。所选择元件的

图形符号、PCB 封装等信息出现在窗口的下边。如图 77 所示。 

点击放置，就可以把所选择的器件放置在我们的设计文件中。用法同集成库文件的用法完全相

同。不同的是我们双击放置在设计图纸中的元件，包含元件属性信息的窗口会弹出来。我们会发现

在窗口中多了一项叫做“Library Link – Database Component”的选项。见图 78 红颜色方框中。 
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图 77   数据库格式的库文件元件列表 

 

 
图 78   数据库格式的库文件元件属性 

如果您在设计库列表中加载了 DBLIB，那么 Altium Designer 在每次开启的时候都会自动同步

数据库。对于已经放置在设计中的元器件，在原理图编辑环境下执行 Tools >>Update Parameter 

From Database 命令就可以完成所有元器件数据库参数的更新。 

另外，Altium Designer 软件的 BOM 表可以包含采购和库存等信息，同时 Excel 格式的 BOM

表可以实现定制化输出，为 BOM 表回送公司的 PDM/ERP 系统提供了便利。具体操作如图 79 所

示。在窗口的底部，选择“Include Parameter Form Database”，则在窗口的左下侧会出现一个信

息窗口。在信息窗口下选择相应的数据库信息，则这个信息就会出现在元件属性列表中。 
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图 79   包含数据库信息的 BOM 表 

12.2.2  SVNDBLIB 

SVNDBLIB 是一种新型的 DBLIB，它与 DBLIB 的区别是它把期间的模型文件纳入版本控制管

理，更加严格地控制了设计元件库的来源。 

完整数据库驱动的器件信息系统——DBLIB，它在实现时元器件模型信息指定的元器件模型文

件可以存放在任何地方。虽然严格的数据库管理能够保障元器件模型信息的正确，但是由于模型文

件没有被很好地保护，会带来很大的设计风险。同时这样的方案无法避免工程师使用 DBLIB 以外的

设计元件库。 

SVNDBLIB 把元器件的模型文件纳入版本控制管理，有效地保障了设计元件库的安全性，大大

降低了设计风险。这个方案还可以方便把器件管理纳入到 PDM 系统中。不仅完整地保护了设计元

件库，同时也有效去除了设计工程师使用外部设计元件库的可能。 

为了实现 SVNDBLIB，把所有元器件的模型文件纳入版本控制管理，首先，我们需要把现有的

器件库分裂，每个元器件的每个模型生成一个单独的库文件。这样版本控制就可以有效地追溯每个

元器件的每个模型的任意修改。目前 PTC 的 Windchill 系统对每个元器件每个模型都是以单独文件

的方式进行管理。这种库管理方式更容易实现与 Windchill 系统集成。Altium Designer 软件自带的

库分裂器可以很方便的生成每个器件一个文件的形式。 

另外，为了更好地实现与 PDM 系统的集成和有效管理设计元件库，我们需要进行相关的二次

开发，提供库管理员接口界面和使用工程师接口界面。库管理员接口界面，主要是帮助库管理员管

理每个元器件的每个模型；使用工程师接口界面，帮助工程师查找元器件、并从 PDM 系统中检出

该元器件模型，放置在设计中。 

Altium 公司提供软件 SDK 开发包，可以有效地支持二次开发工作。 

 


