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提问提问11：：

什么是印刷电路板 (printed circuit 
board简写为：PCB)？
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印刷电路板 (PCB)

在塑料板上印制导电铜箔，用铜箔取代导线，只要将各种元件安装在印
制电路板上，铜箔就可以将它们连接起来组成一个电路。 如下图所示
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AltiumDesignerAltiumDesigner的发展的发展
Altium Designer是Altium 公司（澳大利亚）继Protel
系列产品（Tango（1988）、Protel for DOS、Protel
forWindows 、Protel 98、Protel 99、Protel 99 SE、
Protel DXP、Protel DXP 2004）之后推出的高端设计
软件。
2001 年，Protel Technology公司改名为Altium公司，
整合了多家EDA软件公司，成为业内的巨无霸。
2006 年，Altium 公司推出新品Altium Designer 
6.0，经过Altium Designer 6.3、AltiumDesigner 6.6、
Altium Designer 6.7、Altium Designer 6.8、Altium
Designer 6.9、Altium DesignerSummer 08、Altium
Designer Winter 09、 Altium Designer Summer09等
版本升级，体现了Altium 公司全新的产品开发理念，
更加贴近电子设计师的应用需求，更加符合未来电子设
计发展趋势要求。
该软件的使用是自学，由于比较时间仓促，水平有限，
书中的错误和不妥之处在所难免，敬请同学提出宝贵的
意见并批评指正，以让教材更加完善。
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学习目标：学习目标：
希望你能希望你能————

了解本课程的教学目标

了解本课程的教学方法

了解本课程的教学内容

了解本课程的考评方法

1

2

3

4
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一、教学目标一、教学目标
1、知识方面的要求：

要求学生掌握在了解了数字、模拟电路的基础上，熟
练掌握电路原理图、PCB板的设计方法，了解相关的
概念、了解电路的仿真功能，熟悉Altium Designer软
件的使用，为今后的工作打下坚实的基础。
2、技能和能力方面的要求：
通过本课程的学习，要求学生能够熟练地掌握Altium
Designer 软件的设计环境、原理图设计、层次原理图
设计、多通道设计、印制电路板（PCB）设计、三维
PCB 设计、PCB 规则约束及校验、交互式布线、原理
图库、PCB 库、集成库的创建、电路设计与仿真，
Protel 99 SE 与Altium Designer的转换等相关技术
内容。学会用该软件解决在电路设计中的各种问题，
多掌握一种技能，为以后的毕业设计、工作打下坚实
的基础。
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二、本课程的教学方法二、本课程的教学方法
对于理论知识

以“学生自学，教师辅导”的方式进行教学

对于技能训练
采用“任务驱动”的方式进行教学
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三、教学内容三、教学内容
教材内容：教材第1-14章
学时安排：见教学计划
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四、本课程的考评方法四、本课程的考评方法

：随堂考核+过程考核
从三个方面考核：知识、技能、态度。

知识：课堂提问
技能：本堂课的内容、作业
平时成绩30分
期末考试60分。

考查
学习态度（基础分为10分）：出勤情况、课堂活动的参与、
课堂纪律等

本课程希望全班同学都学会，不要有人补考。
学分：4分
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五、学习方法建议五、学习方法建议
新课部分应自学（课前学习），培训自
学能力

课堂上进行技能实训（随堂到教师机上
给同学们演示）
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第一章第一章 Altium Designer 
Winter 09 软件认识

1.1 Altium Designer 
Winter 09软件特点

1.2 Altium Designer 
Winter 09软件安装

1.3 Altium Designer 
Winter 09 软件界面设置

一

二

三
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1.1 1.1 AltiumAltium Designer Winter Designer Winter 
0909软件特点软件特点

Altium Designer Winter 09与之前
Altium Designer 6.X相比，新增的技术
特征如下：
1．即插即用的软件平台搭建器
2．应用控制面板
3．新的交互式布线功能
4．设计发布管理功能
5．方便的供应商数据链接服务
6．实时制造规则检查
7．三维PCB可视引擎性能提高
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1.2.1 硬件环境需求
达到最佳性能的推荐系统配置：
•Windows XP SP2专业版或以后的版本。
•英特尔R酷睿™ 2双核/四核2.66 GHz或更快的处理器或
同等速度的处理器。
• 2GB内存。
•10G 硬盘空间（系统安装+用户文件）。
•双显示器，至少1680×1050（宽屏）或1600×1200
（4:3）分辨率。
•NVIDIA公司的GeForce R 80003 系列，使用256 MB 
（或更高）的显卡或同等级别的显卡。
•Internet 连接，以接收更新和在线技术支持。要使用
包括三维可视化技术在内的加速图像引擎，显卡必须支
持DirectX 9.0c 和Shader model 3，因此建议系统配
置独立显卡。

1.2 Altium Designer Winter 09软件安装
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系统最低配置：
Windows XP SP2 Professional1。
英特尔R 奔腾™ 1.8 GHz 处理器或同等处
理器。
1GB内存。
3.5 GB 硬盘空间（系统安装+ 用户文件）。
主显示器的屏幕分辨率至少是1280×1024
（强烈推荐）；次显示器的屏幕分辨率不
得低于1024×768。
独立的显卡或者同等显卡。
USB2.0端口。
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1.2.2 安装 Altium Designer 
Winter 09
（1）进入

12.04.08.AltiumDesignerWinter09.l
cz文件夹，执行autorun.exe文件，只
执行第1个选项，在显示器上出现如图
1-1所示的安装界面
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图1-1 软件安装界面
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（（22）点击）点击““Install Install AltiumAltium DesignerDesigner””，显示如图，显示如图11--22所示所示
的安装向导欢迎窗口。的安装向导欢迎窗口。

图1-2 安装向导欢迎窗口
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（（33）单击安装向导欢迎窗口的）单击安装向导欢迎窗口的““NextNext””按钮，显示如图按钮，显示如图11--
33所示的所示的““License AgreementLicense Agreement””视图。视图。

图1-3 “License Agreement”视图
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（（44）选择）选择““License AgreementLicense Agreement””视图中的视图中的““I accept the I accept the 
license agreementlicense agreement””单选项，同意该协议，单击单选项，同意该协议，单击““NextNext””按按

钮，显示如图钮，显示如图11--44所示的所示的““User InformationUser Information””视图。视图。

图1-4 “User Information”视图
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（5）在“User Information”视图中的“Full 
Name”编辑框内输入用户名称，在
“Organization”编辑框内输入单位名称，
在使用权限选项中选择使用权限的范围：
“Anyone who uses this computer”单选
项，表示这台计算机上的所有用户都能使
用Altium Designer Winter 09，“Only 
for me”单选项则表示只有在当前安装
Altium Designer Winter 09的用户帐号
下才能使用Altium Designer软件。单击
“Next”按钮，显示如图1-5所示的
“Destination Folder”视图。
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图1-5 “Destination Folder”视图
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（（66）在）在““Destination FolderDestination Folder””视图视图““Destination FolderDestination Folder””区域显示了区域显示了
即将安装即将安装AltiumAltium Designer Winter 09Designer Winter 09的安装路径，若想更改安装路的安装路径，若想更改安装路

径，单击径，单击““BrowseBrowse””按钮，打开如图按钮，打开如图11--66所示的安装路径选择对话框。所示的安装路径选择对话框。

图1-6 安装路径对话框
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（（77）选择软件安装的路径后，点击）选择软件安装的路径后，点击““okok””按钮，显示如图按钮，显示如图

11--77所示所示““BoardBoard--level Librarieslevel Libraries””。。

图1-7  “Board-level Libraries”视图
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（（88）如果需要安装板级的库文件，就勾选上图的）如果需要安装板级的库文件，就勾选上图的““Install Install 
BoardBoard--level Librarieslevel Libraries””对话框，点击对话框，点击““NextNext””按钮，出现按钮，出现
如图如图11--88的的““Ready to Install the ApplicationReady to Install the Application””视图。视图。

图1-8 “Ready to Install the Application”视图



第
一
讲

第
一
讲

A
l
t
i
u
m

A
l
t
i
u
m

概
述
概
述

（（99）确定以上安装信息设定无误后，单击）确定以上安装信息设定无误后，单击““Ready to Ready to 
Install the ApplicationInstall the Application””视图中的视图中的““NextNext””按钮开始安装，按钮开始安装，

过程中，文件复制窗口内将显示操作过程和文件复制进过程中，文件复制窗口内将显示操作过程和文件复制进
度，以及安装剩余时间等信息，如图度，以及安装剩余时间等信息，如图11--99所示。所示。

图1-9 安装进度视图
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（（1010）文件复制完毕后，系统弹出安装完毕窗口，单击）文件复制完毕后，系统弹出安装完毕窗口，单击
““FinishFinish””按钮，结束安装如图按钮，结束安装如图11--1010所示。所示。

图1-10  安装结束视图
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1.2.3 1.2.3 AltiumAltium Designer Designer 
Winter 09Winter 09软件激活软件激活

进入
AltiumDesignerWinter09破
解文件夹，将ad80.alf、
dxp.exe文件拷贝到安装目录
下（如：D:\program 
Fiels\Altium Designer 
Winter 09\）即可。
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1.3 1.3 AltiumAltium Designer Winter Designer Winter 
09 09 软件界面设置软件界面设置

启动Altium Designer Winter 09的同时
可以看到它的启动画面,如图1-16所示。

图图11--16 16 AltiumAltium Designer Winter 09Designer Winter 09的启动画面的启动画面
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Altium Designer Winter 09启动后，进
入主页面如图1-17所示，用户可以使用

该页面进行项目文件的操作，如创建新
项目、打开文件、配置等。该系统界面
由系统主菜单、浏览器工具栏、系统工
具栏、工作区和工作区面板五大部分组
成。
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图1-17  Altium Designer Winter 09软件界面

系统主菜单

系统工具栏

浏览器工具栏

工作区面板

工作区

工作区面板切
换按钮
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小结小结

1.1 Altium Designer Winter 09软件特

点

1.2 Altium Designer Winter 09软件安

装

1.2.1 硬件环境需求

1.2.2 安装 Altium Designer Winter 
09
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教师演示教师演示

1. Altium Designer Winter 09软件的安

装。

2. Altium Designer Winter 09软件的启

动，注意观察启动过程。

3. 打开安装盘下：\ Altium Designer 
Winter 09\Examples\Reference 
Designer\4 Port Serial Interface例
子，初步了解电路原理图、PCB板。

1. Altium Designer Winter 09软件的安

装。

2. Altium Designer Winter 09软件的启

动，注意观察启动过程。

3. 打开安装盘下：\ Altium Designer 
Winter 09\Examples\Reference 
Designer\4 Port Serial Interface例
子，初步了解电路原理图、PCB板。
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动手操作动手操作：：

1. Altium Designer Winter 09软件的安

装。

2. Altium Designer Winter 09软件的

启动，注意观察启动过程。

3. 打开安装盘下：\ Altium Designer 
Winter 09\Examples\Reference 
Designer\4 Port Serial Interface例
子，初步了解电路原理图、PCB板。

1. Altium Designer Winter 09软件的安

装。

2. Altium Designer Winter 09软件的

启动，注意观察启动过程。

3. 打开安装盘下：\ Altium Designer 
Winter 09\Examples\Reference 
Designer\4 Port Serial Interface例
子，初步了解电路原理图、PCB板。
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第二讲 《Altium Designer概述》第二讲第二讲 《《AltiumAltium DesignerDesigner概述概述》》

主讲主讲::王静王静

中心
下划线
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复习：复习：
1.1 Altium Designer Winter 09软件特点

1.2 Altium Designer Winter 09软件安装

1.2.1 硬件环境需求

1.2.2 安装 Altium Designer Winter 09
Altium Designer Winter 09软件的启动
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学习目标：学习目标：
希望你能希望你能————

了解 1.3 Altium Designer 
Winter 09 软件界面设置

熟悉 工作区面板
（Workspace Panel）

了解 1.4 Altium Designer 
Winter 09 软件参数设置

熟悉 切换英文编辑环境到中文
编辑环境

1

2

3

4
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Altium Designer Winter 09启动后，进
入主页面如图1-17所示，用户可以使用

该页面进行项目文件的操作，如创建新
项目、打开文件、配置等。该系统界面
由系统主菜单、浏览器工具栏、系统工
具栏、工作区和工作区面板五大部分组
成。

1.3 1.3 AltiumAltium Designer Winter Designer Winter 
09 09 软件界面设置软件界面设置
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图1-17  Altium Designer Winter 09软件界面

系统主菜单

系统工具栏

浏览器工具栏

工作区面板

工作区

工作区面板切
换按钮
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1.3.11.3.1系统主菜单（系统主菜单（System System 
menumenu））
1.3.21.3.2系统工具栏系统工具栏 (menus)(menus)
1.3.31.3.3浏览器工作栏浏览器工作栏(Navigation)(Navigation)
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1.3.41.3.4工作区面板工作区面板 （（Workspace Workspace 
panelpanel））

1．面板的访问

软件初次启动后，一些面板已经打开，比如File和
Project控制面板以面板组合的形式出现在应用窗口的
左边，Library控制面板以弹出方式和按钮的方式出现
在应用窗口的右侧边缘处。另外在应用窗口的右下端
有4个按钮System、DesignComplier、Help、
Instrument，分别代表四大类型，点击每个按钮，弹
出的菜单中显示各种面板的名称，从而选择访问各种
面板，除了直接在应用窗口上选择相应的面板，也可
以通过主菜单“View”→ “workspace panels”→ “sub 
menus”选择相应的面板。
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22．面板的管理．面板的管理

面板显示模式有三种，分别是Docked Mode
（停靠模式） 、Pop-out Mode（弹出模式 ）、
Floating Mode（浮动模式 )。Docked Mode
指的是面板以纵向或横向的方式停靠在设计窗
口的一侧，如图1-23所示。Pop-out Mode指
的是面板以弹出隐藏的方式出现于设计窗口，
当鼠标点击位于设计窗口边缘的按钮时，隐藏
的面板弹出，当鼠标光标移开后，弹出的面板
窗口又隐藏回去，如图1-24所示。这两种不同

的面板显示模式可以通过面板上的两个按钮互
相切换。
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面板停靠模式面板停靠模式 面板弹出模式面板弹出模式

面板纵向停靠模式

面板横向停靠模式

图图11--2323面板停靠模式面板停靠模式
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图1-24 面板弹出模式

面板处于弹出模式,以按钮的形式显示在

主设计窗口的边框上

已弹出的面板
已弹出的面板
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图 1-25 面板浮动模式
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1.4 1.4 AltiumAltium Designer Winter Designer Winter 
09 09 软件参数设置软件参数设置

使用软件前，对系统参数进行设置是重要的环节。用
户点击“DXP”→“Preferences”命令，系统将弹出如图
1-27所示的系统参数设置对话框。对话框具有树状导
航结构，可对12个选项内容进行设置，现在主要介绍
系统相关参数的设置方法。
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1.4.1 1.4.1 切换英文编辑环境到中文编辑环境切换英文编辑环境到中文编辑环境

点击“Preferences”设置窗口中的“System”→“General”命令，该窗
口包含了5个设置区域，分别是“Startup”、“Default Location”、
“System Font”、 “General”、和“Localization”区域。
在“Localization”区域中，选中“Use Localized resources”复选框，
统会弹出提示框，点击“OK”按钮，然后在“System-General”设置界
面中单击“Apply”按钮，使设置生效，再单击“OK”按钮，退出设置界
面，关闭软件，重新进入Altium Designer系统，即可进入中文编
辑环境。
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1.4.2 System1.4.2 System--GeneralGeneral选项卡选项卡

“Startup”区域用来设置启动时状态

“ Reopen Last Workspace”： 从新启动时打开上一次关机时的屏幕

“Open Home Page if no Documets open”： 如果没有文档打开就打开

主页

“Show Startup screen”： 显示开始屏幕

“Default Locations”区域用来设置系统默认的文件路径

“Document Path”：编辑框用于设置系统打开或保存文档、项目和项目组

时的默认路径。用户直接在编辑框中输入需要设置的目录的路径，或者
单击右侧的按钮，打开“浏览文件夹”对话框，在该对话框内指定一个已
存在的文件夹，然后单击“确定”按钮即完成默认路径设置。

“Library Path”: 编辑框用于设置系统的元件库目录的路径。

“System font”：用于设置系统字体、字形和字体大小

“General”
“Monitor Clipboard Content within this application only”：本应用程

序中查看剪切板的内容。
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1.4.3 1.4.3 系统备份设置系统备份设置

点击“Preferences”设置窗口中的“System”→“Backup”命令，弹

出如图1-30所示的对话框。

图图11--3030文件备份参数设置文件备份参数设置

Auto Save 设置框主要用来设置自动保存的一些参数，选中“Auto 
save every”复选框，可以在时间编辑框中设置自动保存文件的
时间间隔，最长时间间隔为120min。“Number of versions to 
keep”设置框用来设置自动保存文档的版本数，最多可保存10个
版本。
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1.4.41.4.4调整面板弹出、隐藏速度，调整浮动面板的透明程度调整面板弹出、隐藏速度，调整浮动面板的透明程度

点击“Preferences”设置窗口中的“System”→“View”命令，在“Popup 
Panels”区域中拉动滑条来调整面板弹出延时，隐藏延时，如图1-
31所示。

图图11--31 31 面板弹出速度调整对话框面板弹出速度调整对话框

快快
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调整浮动面板的透明程度设置调整浮动面板的透明程度设置

点击“Preferences”设置窗口中的
“System”→“Transparency”命令，勾选
“Transparency”下的复选框，即选择使用面板
在操作的过程中，使浮动面板透明化。勾选
“Dynamic transparency”(自动调整透明化程
度)复选框，即在操作的过程中，光标根据窗
口间的距离自动计算出浮动面板的透明化程
度，也可以通过下面的滑条来调整浮动面板的
透明程度，其效果如图1-25所示。
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小结小结
1.3 Altium Designer Winter 09 软件界面设置

1.3.1 系统主菜单（System Menu）
1.3.2 系统工具栏（Menus）
1.3.3 浏览器工具栏（Navigation）
1.3.4 工作区面板（Workspace Panel）
1.3.5 工作区（Main Design Window）

1.4 Altium Designer Winter 09 软件参数设置
1.4.1 切换英文编辑环境到中文编辑环境
1.4.2 System-General选项卡 启动、文件路径、系

统字体
1.4.3 系统备份设置
1.4.4 调整面板弹出、隐藏速度，调整浮动面板的透

明程度
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上机练习上机练习

学生在计算机上练习上述内

容，并完成以下的作业。

学生在计算机上练习上述内

容，并完成以下的作业。
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作业作业

预习：第2章 下次课提问

P17  2-4 
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第2章 绘制多谐振荡器电路原理
图

教学目的及要求：

熟悉项目及工作空间的概念

熟练掌握创建一个新的原理图图纸

熟练掌握绘制电路原理图

教学重点、难点：

绘制电路原理图



复习

1.1 Altium Designer Winter 09软件特点

1.2 Altium Designer Winter 09软件安装

1.3 认识Altium Designer Winter 09 软件界面

1.3.1 系统主菜单（System Menu）
1.3.2 系统工具栏（Menus）
1.3.3 浏览器工具栏（Navigation）
1.3.4 工作区面板（Workspace Panel）
1.3.5 工作区（Main Design Window）

1.4 Altium Designer Winter 09 软件参数设置

1.4.1 切换英文编辑环境到中文编辑环境

1.4.2 系统备份设置

1.4.3 调整面板弹出、隐藏速度，调整浮动面板的透明程度



讲评P17 习题 4在Preferences对话框中
设置面板在操作的过程中，使浮动面板透
明化。

首先将工作面板拖为浮动。

点击“Preferences”设置窗口中的“System”→“Transparency”命令，
勾选“Transparency”下的复选框，勾选“Dynamic transparency”(自
动调整透明化程度)复选框，即在操作的过程中，光标根据窗

口间的距离自动计算出浮动面板的透明化程度，也可以通过
Highest transparency的滑条来调整浮动面板的透明程度，越往

右透明化程度越高。

在原理图交互式模式下（放置元件或移动元件）即可看到浮
动面板的透明化程度。



提问：

解释项目的含义？

解释工作空间的含义？



2.1项目及工作空间介绍

项目是每项电子产品设计的基础，在一个项目文件中包括设
计中生成的一切文件，比如原理图文件、PCB图文件、各种

报表文件及保留在项目中的所有库或模型。一个项目文件类
似Windows系统中的“文件夹”，在项目文件中可以执行对文件

的各种操作，如新建、打开、关闭、复制与删除等。但需注
意的是，项目文件只是起到管理的作用，在保存文件时，项
目中的各个文件是以单个文件的形式保存的。

项目大约有6种类型–PCB 项目、FPGA 项目、内核项目、嵌

入式项目、脚本项目和库封装项目（集成库的源）。

Workspace（工作空间）比项目高一层次，可以通过Workspace
（工作空间）连接相关项目，设计者通过Workspace（工作空

间）可以轻松访问目前正在开发的某种产品相关的所有项目。



2.2创建一个新项目
1．在菜单栏选择File → New → Project → PCB Project。
2．Projects面板出现。

3．重新命名项目文件。

在E:盘上建立“多谐振荡器”文件夹

工作空间

项目文件

项目文件

通过选择File →Save Project As来将新
项目重命名（扩展名为.PrjPCB）。指

定把这个项目保存在设计者硬盘上的
“多谐振荡器”文件夹的位置，在文件名
栏里键入文件名:Multivibrator.PrjPCB
并单击保存按钮。



2.3创建一个新的原理图图纸
2.3.1创建一个新的原理图图纸的
步骤

1．单击File → New → Schematic，或者在Files
面板的New单元选择:Schematic Sheet。
2．通过选择File → Save As来将新原理图文件
重命名（扩展名为*.SchDoc）。



2.3.2将原理图图纸添加到项目

如果设计者想添加到一个项目文件中的原理
图图纸是作为自由文件夹被打开如图2-6，那
么在Projects面板的Free Documents单元
Source document文件夹下用鼠标拖拽要移
动的文件sheet1.sch到目标项目文件夹下的
Source document上即可。

图2-6 自由文件夹下的原理图



2.3.3设置原理图选项

1．从菜单选择Design → Document Options，在
此唯一需要修改的是将图纸大小（sheet size）
设置为标准A4格式。



2.3.4进行一般的原理图参数设置

1．从菜单选择Tools → Schematic  Preferences（热键T，P）打

开原理图参数对话框。这个对话框允许设计者设置全部参
数，这些设置将应用到设计者继续工作的所有原理图图纸(具
体设置我们将在后面的第6章中详细介绍)。
2．在对话框左边的目录中单击Schematic → Default Primitives目
录，勾选Permanent使其为当前，单击OK按钮关闭对话框。

3．在开始绘制原理图之前，保存这个原理图图纸，因此选
择File → Save（热键F，S）或按工具栏上的“ ”图标。



2.4绘制原理图
2.4.1在原理图中放置元件

1.下面将介绍从默认的安装库中首先放置两个三极管Q1和Q2。
（1）从菜单选择View → Fit Document（热键V、D）确认设计

者的原理图纸显示在整个窗口中。

（2）单击Libraries标签以显示Libraries面板。

（3）Q1和Q2是型号为2N3904的三极管，该三极管放在
Miscellaneous Devices.IntLib集成库内，所以从Libraries面板“安装
的库名”栏内，从库下拉列表中选择Miscellaneous Devices.IntLib
来激活这个库。

（4）使用过滤器快速定位设计者需要的元件。默认通配符
（*）可以列出所有能在库中找到的元件。在库名下的过滤
器栏内键入*3904*设置过滤器，将会列出所有包含“3904”的元

件。



（5）在列表中单击2N3904以选择它，然后单击Place按钮。

另外，还可以双击元件名。

光标将变成十字状，并且在光标上“悬浮”着一个三极管的轮

廓。现在设计者处于元件放置状态，如果设计者移动光标，
三极管轮廓也会随之移动。

（6）在原理图上放置元件之前，首先要编辑其属性。在三
极管悬浮在光标上时，按下TAB键，这将打开Component 
Properties（元件属性）对话框，现在要设置对话框选项如图
2-9所示。

（7）在对话框Properties单元，在Designator栏中键入Q1以将其

值作为第一个元件序号。

（8）下面将检查在PCB中用于表示元件的封装。在本教程

中，我们已经使用了集成库，这些库已经包括了封装和电路
仿真的模型。确认在模型列表中（Models for Q?-2N3904）含
有模型名TO-92A的封装，保留其余栏为默认值，并单击OK按
钮关闭对话框。



2.下面放置四个电阻
（resistors）。

（1）在Libraries面板中，确认Miscellaneous Devices.IntLib库为当
前。在库名下的过滤器栏里键入res1来设置过滤器。

（2）在元件列表中单击RES1以选择它，然后单击Place按
钮，现在设计者会有一个“悬浮”在光标上的电阻符号。

（3）按TAB键编辑电阻的属性。在对话框的Properties单元，
在Designator栏中键入R1以将其值作为第一个元件序号。

（4）在对话框的Properties单元，单击Comment栏并从下拉列
表中选择=Value（如图2-11所示），将Visible关闭。



图2-11 选择Comment=Value



使用Comment栏可以输入元件的描述，例如74LS04或者10K。
当原理图与PCB图同步时，这一栏的值将更新到PCB文件中。

也可以把这一栏的值当成字符串，也可以从这一栏的下拉列
表中选择一种参数，下拉列表显示了当前有效的所有参数。
当“=Value”这个参数被使用时，这个参数将被用于电路仿真，
也将被传到PCB文件中。

（5）PCB元件的内容由原理图映射过去，所以在Parameters
栏将R1的值(Value)改为100K
（6）在模型列表中确定封装“AXIAL-0.3”已经被包含如图2-10
所示，单击OK按钮返回放置模式。

（7）按SPACEBAR（空格键）将电阻旋转90°



3.现在放置两个电容
（capacitors）。

(1)在Libraries面板的元件过滤器栏键入cap。
方法同上。



4.最后要放置的元件是连接器
（connector）。

连接器在Miscellaneous Connectors.IntLib库里。从Libraries面板
“安装的库名”栏内，从库下拉列表中选择Miscellaneous 
Connectors.IntLib来激活这个库。

（1）我们想要的连接器是两个引脚的插座，所以设置过滤
器为H*2*。
（2）在元件列表中选择HEADER2并单击Place按钮。按TAB编
辑其属性并设置Designator为Y1，检查PCB封装模型为HDR1X2。
由于在仿真电路时我将把这个元件换为电压源，所以不需要
作规则设置，单击OK关闭对话框。

（3）以放置连接器之前，按X作水平翻转，在原理图中放下
连接器。右击或按ESC退出放置模式。

（4）从菜单选择File → Save（热键F，S）保存设计者的原理

图。



现在已经放完了所有的元件。元件的摆放如
图2-12所示，从中可以看出元件之间留有间

隔，这样就有大量的空间用来将导线连接到
每个元件引脚上。



图2-12 元件摆放完后的电路图

如果设计者需要移动元件，鼠标左击并拖动元件
体，拖到需要的位置放开鼠标左键即可。



小结：

第2章绘制多谐振荡器电路原理图

2.1 项目及工作空间介绍

2.2 创建一个新项目·
2.3 创建一个新的原理图图纸

2.3.1 创建一个新的原理图图纸的步骤

2.3.2 将原理图图纸添加到项目

2.3.3 设置原理图选项

2.3.4 进行一般的原理图参数设置

2.4 绘制原理图

2.4.1 在原理图中放置元件



作业：

上机题:



第2章 绘制多谐振荡器电路原理
图

教学目的及要求：

1.熟悉电路中的各种元器件之间建立连接

2.熟悉网络标记的含义，会正确放置网络标

记

3.熟练掌握检查设计电路图中的错误

教学重点： 检查设计电路图中的错误

教学难点： 检查设计电路图中的错误



复习
第2章绘制多谐振荡器电路原理图

2.1 项目及工作空间介绍

2.2 创建一个新项目·
2.3 创建一个新的原理图图纸

2.3.1 创建一个新的原理图图纸的步骤

2.3.2 将原理图图纸添加到项目

2.3.3 设置原理图选项

2.3.4 进行一般的原理图参数设置

2.4 绘制原理图

2.4.1 在原理图中放置元件



2.4.2连接电路

连线起着在设计者的电路中的各种元器件之间建立连接的作
用。要在原理图中连线，参照图2-1所示并完成以下步骤：

1．为了使电路图清晰，可以使用Page Up键来放大，或Page 
Down键来缩小；保持Ctrl键按下，使用鼠标的滑轮也可以放
大或缩小；如果要查看全部视图，从菜单选择View → Fit All 
Objects（热键V，F）。

2．首先用以下方法将电阻R1与三极管Q1的基极连接起来。
从菜单选择Place → Wire（热键P，W）或从连线工具栏单击
‘ ’工具进入连线模式，光标将变为十字形状。

3．将光标放在R1的下端，当设计者放对位置时，一个红色

的连接标记会出现在光标处，这表示光标在元件的一个电气
连接点上。



4．左击或按ENTER固定第一个导线点，
移动光标设计者会看见一根导线从光标处
延伸到固定点。

5．将光标移到R1的下边Q1的基极的水平
位置上，设计者会看见光标变为一个红色
连接标记如图2-13所示，左击或按ENTER
在该点固定导线。在第一个和第二个固定
点之间的导线就放好了。

6．完成了这根导线的放置，注意光标仍
然为十字形状，表示设计者准备放置其它
导线。要完全退出放置模式恢复箭头光
标，设计者应该再一次右击或按ESC键。
---但现在还不能这样做。

图2-13 连线时的红色标记



7．现在我们要将C1连接到Q1和R1的连线上。将光
标放在C1左边的连接点上，左击或按ENTER开始新

的连线。

8．水平移动光标一直到Q1的基极与R1的连线上，
左击或按ENTER放置导线段，然后右击或按ESC表示

设计者已经完成该导线的放置。注意两条导线是怎
样自动连接上的。

9．参照图2-1连接电路中的剩余部分。

10．在完成所有的导线之后，右击或按ESC退出放
置模式，光标恢复为箭头形状。

11．如果想移动元件，让连接该元件的连线一起移
动，当移动元件的时候按下并保持按下Ctrl键，或者
从菜单上选择Edit → Move → Drag。



2.4.3网络与网络标记

彼此连接在一起的一组元件引脚的连线称为网络
（net）。例如，一个网络包括Q1的基极、R1的一个
引脚和C1的一个引脚。

在设计中识别重要的网络是很容易的，设计者可以
添加网络标记（net labels）。

在两个电源网络上放置网络标记：

1．从菜单选择Place → Net Label或者在工具栏上按

‘ ’ 。一个带点的Netlabel1框将悬浮在光标上。

2．在放置网络标记之前应先编辑，按TAB键显示Net 
Label （网络标记）对话框。



3．在Net栏键入+12V，然后单击OK关闭对话框。

4．在电路图上，把网络标记放置在连线的上面，当

网络标记跟连线接触时，光标会变成红色十字准
线，左击或按ENTER键即可（注意：网络标记一定
要放在连线上）。

5．放完第一个网络标记后，设计者仍然处于网络标
记放置模式，在放第二个网络标记之前再按TAB键
进行编辑。

6．在Net栏键入GND，单击OK关闭对话框并放置网
络标记，右击或按ESC键退出放置网络标记模式。

7．选择File → Save（热键F，S）保存电路。



如果电路图有某处画错了，需要
删除，方法如下：

方法1：从菜单栏选择Edit → Delete（热键E，
D）,然后选择需要删除的元件、连线或网络

标记等即可。

右击或按ESC键退出删除状态。

方法2：可以先选择要删除的元件、连线或网

络标记等，选中的元件有绿色的小方块包围
住如图2-14，然后按Delete键即可。



2.5编译项目

编译项目可以检查设计文件中的设计草图和
电气规则的错误，并提供给设计者一个排除
错误的环境。

1．要编译Multivibrator项目，选择Project →
Compile PCB Project Multivibrator.PrjPcb。
2．当项目被编译后，任何错误都将显示在
Messages面板上，如果电路图有严重的错
误，Messages面板将自动弹出，否则Messages
面板不出现。



项目编译完后，在Navigator面板中将列出所有对象的
连接关系。（如图2-15所示）

图2-15 Navigator面板



现在故意在电路中引入一个错误，并重新编译

一次项目：
1．在设计窗口的顶部单
击Multivibrator.SchDoc标
签，以使原理图为当前文
档。

2．在电路图中将R1与Q1
基极的连线断开。从菜单
选择Edit → Break Wire。
3. 从菜单选择Protect →
Protect Options,弹出Options 
for PCB Protect 
Multivibrator.PrjPCB对话
框，选择Connectoin Matrix
标签，如图2-18所示。 图2-18 设置错误检查条件



4．点击鼠标箭头所示的地方（即Unconnected与Passive Pin相
交处的方块），在方块变为图例中的Fatal Errors表示的颜色
(红色)时停止点击，表示元件管脚如果未连线，报告错误(默
认是一个绿色方块，表示运行时不给出错误报告)。
5．重新编译项目（Project → Compile PCB Project 
Multivibrator.PrjPcb）来检查错误，自动弹出“Messages”窗口如
图2-19所示，指出错误信息：Q1-2脚没有连接。

图2-19 给出错误信息



6．双击Messages面板中的错误或者警告，弹
出Compile Error 窗口，将显示错误的详细信息。

从这个窗口，设计者可单击一个错误或者警
告直接跳转到原理图相应位置去检查或修改
错误。

7．将删除的线段连通以后，重新编译项目
（Project → Compile PCB Project 
Multivibrator.PrjPcb）来检查。Messages面板没

有信息显示。



小结：

2.4 绘制原理图

2.4.1 在原理图中放置元件

2.4.2 连接电路

2.4.3 网络与网络标记

2.5 编译项目

在电路中引入一个错误，并重新编译一次项

目：
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第3章 多谐振荡器PCB图的设计



教学目的及要求：

1.熟悉印刷电路板的基础知识

2.熟悉掌握用PCB向导来创建PCB板
3.熟练掌握用封装管理器检查所有元件的封装

4.熟练掌握用Update PCB命令原理图信息导入到目标PCB文件



复习并导入新课
第2章绘制多谐振荡器电路原理图

2.1 项目及工作空间介绍

2.2 创建一个新项目·
2.3 创建一个新的原理图图纸

2.3.1 创建一个新的原理图图纸的步骤

2.3.2 将原理图图纸添加到项目

2.3.3 设置原理图选项

2.3.4 进行一般的原理图参数设置

2.4 绘制原理图

2.4.1 在原理图中放置元件

2.4.2 连接电路

2.4.3 网络与网络标记

2.5 编译项目



3.1 印制电路板的基础知识
印制电路板英文简称为PCB
（Printed Circle Board）如图3-2所
示。印制电路板的结构原理为：
在塑料板上印制导电铜箔，用铜
箔取代导线，只要将各种元件安
装在印制电路板上，铜箔就可以
将它们连接起来组成一个电路。

图3-2 PCB板



1．印制电路板的种类

根据层数分类，印制电路板可分为单面板、双面板和多层板。

（l）单面板

单面印制电路板只有一面有导电铜箔，另一面没有。在使用
单面板时，通常在没有导电铜箔的一面安装元件，将元件引
脚通过插孔穿到有导山铜箔的一面，导电铜箔将元件引脚连
接起来就可以构成电路或电子设备。单面板成本低，但因为
只有一面有导电铜箔，不适用于复杂的电子设备。



（2）双面板
双面板包括两层：顶层（Top Layer）和底层（Bottom Layer）。与单面板
不同，双面板的两层都有导电铜箔，其结构示意图如图3-3所示。双面板

的每层都可以直接焊接元件，两层之间可以通过穿过的元件引脚连接，
也可以通过过孔实现连接。过孔是一种穿透印制电路板并将两层的铜箔
连接起来的金属化导电圆孔。

图3-3 双面板



（3）多层板
多层板是具有多个导电层的电路板。多层板的结构示意图如
图3-4所示。它除了具有双面板一样的顶层和底层外，在内

部还有导电层，内部层一般为电源或接地层，顶层和底层通
过过孔与内部的导电层相连接。多层板一般是将多个双面板
采用压合工艺制作而成的，适用于复杂的电路系统。

图3-4 多层板



2．元件的封装

印制电路板是用来安装元件的，而同类型的元件，
如电阻，即使阻值一样，也有大小之分。因而在设
计印制电路板时，就要求印制电路板上大体积元件
焊接孔的孔径要大、距离要远。为了使印制电路板
生产厂家生产出来的印制电路板可以安装大小和形
状符合要求的各种元件，要求在设计印制电路板
时，用铜箔表示导线，而用与实际元件形状和大小
相关的符号表示元件。这里的形状与大小是指实际
元件在印制电路板上的投影。这种与实际元件形状
和大小相同的投影符号称为元件封装。例如，电解
电容的投影是一个圆形，那么其元件封装就是一个
圆形符号。



（l）元件封装的分类
按照元件安装方式，元件封装可以分为直插式和表面粘贴式
两大类。

典型直插式元件封装外型及其PCB板上的焊接点如图3-5所示。

直插式元件焊接时先要将元件引脚插入焊盘通孔中，然后再
焊锡。由于焊点过孔贯穿整个电路板，所以其焊盘中心必须
有通孔，焊盘至少占用两层电路板。

图3-5  穿孔安装式元件外型及其PCB焊盘



典型的表面粘贴式封装的PCB图如图3-6所示。此类

封装的焊盘只限于表面板层，即顶层或底层，采用
这种封装的元件的引脚占用板上的空间小，不影响
其他层的布线，一般引脚比较多的元件常采用这种
封装形式，但是这种封装的元件手工焊接难度相对
较大，多用于大批量机器生产。

图3-6  表面粘贴式封装的器件外型及其PCB焊盘



（2）元件封装的编号

常见元件封装的编号原则为：元件封装
类型+焊盘距离（焊盘数）+元件外型尺

寸。可以根据元件的编号来判断元件封
装的规格。例如有极性的电解电容，其
封装为RB.2-.4，其中“.2”为焊盘间距，“.4”
为电容圆筒的外径，“RB7.6-15”表示极性
电容类元件封装，引脚间距为7.6mm，
元件直径为15mm。



3．铜箔导线

印制电路板以铜箔作为导线将安装在电路板上的元
件连接起来，所以铜箔导线简称为导线（Track）。

印制电路板的设计主要是布置铜箔导线。

与铜箔导线类似的还有一种线，称为飞线，又称预
拉线。飞线主要用于表示各个焊盘的连接关系，指
引铜箔导线的布置，它不是实际的导线。



4．焊盘
焊盘的作用是在焊接元件时放置焊锡，将元件引脚与铜箔导
线连接起来。焊盘的形式有圆形、方形和八角形，常见的焊
盘如图3-7所示。焊盘有针脚式和表面粘贴式两种，表面粘

贴式焊盘无须钻孔；而针脚式焊盘要求钻孔，它有过孔直径
和焊盘直径两个参数。

在设计焊盘时，要考虑到元件形状、引脚大小、安装形式、
受力及振动大小等情况。例如，如果某个焊盘通过电流大、
受力大并且易发热，可设计成泪滴状（后面章节会介绍）。

图3-7 常见焊盘



5．助焊膜和阻焊膜

为了使印制电路板的焊盘更容易粘
上焊锡，通常在焊盘上涂一层助焊
膜。另外，为了防止印制电路板不
应粘上焊锡的铜箔不小心粘上焊
锡，在这些铜箔上一般要涂一层绝
缘层（通常是绿色透明的膜），这
层膜称为阻焊膜。



6．过孔
双面板和多层板有两个以上的导电层，导电层之间相互绝
缘，如果需要将某一层和另一层进行电气连接，可以通过过
孔实现。过孔的制作方法为：在多层需要连接处钻一个孔，
然后在孔的孔壁上沉积导电金属（又称电镀），这样就可以
将不同的导电层连接起来。过孔主要有穿透式和盲过式街中
问剑　缤3-8所示。穿透式过孔从顶层一直通到底层，而盲

过孔可以从顶层通到内层，也可以从底层通到内层。

过孔有内径和外径两个参数，过孔的内径和外径一般要比焊
盘的内径和外径小。

图3-8 过孔的两种形式



7．丝印层

除了导电层外，印制电路板还
有丝印层。丝印层主要采用丝
印印刷的方法在印制电路板的
顶层和底层印制元件的标号、
外形和一些厂家的信息。



3.2创建一个新的PCB文件

在将原理图设计转换为PCB设计之前，需要
创建一个有最基本的板子轮廓的空白PCB。
在Altium Designer中创建一个新的PCB设计的
最简单方法是使用PCB向导，它可让设计者
根据行业标准选择自己创建的PCB板的大小。
在向导的任何阶段，设计者都可以使用Back
按钮来检查或修改以前页的内容。



要使用PCB向导来创建PCB，完成
以下步骤：

1．在Files面板的底部的New from template单元单击PCB Board 
Wizard创建新的PCB。如果这个选项没有显示在屏幕上，单
击向上的箭头图标关闭上面的一些单元。

2．PCB Board Wizard打开,设计者首先看见的是介绍页,点Next
按钮继续。

3．设置度量单位为英制（Imperial）。注意：1000 mils = 1 
inch(英寸)、 1 inch=2.54cm（厘米）。

4．向导的第三页允许设计者选择要使用的板轮廓。在本例

中设计者使用自定义的板子尺寸，从板轮廓列表中选择
Custom，单击Next。



5．在下一页，进入了自定义板选项。在本例电路中，一个2 
x 2 inch的板便足够了。选择Rectangular并在Width和Height栏
键入2000。取消Title Block & Scale、Legend String 和
Dimension Lines 以及 Corner Cutoff 和 Inner Cutoff复选框如图3-
9。单击Next继续。

图3-9 PCB板形状设置



6．在这一页允许选择板子的层数。例子中需要两
个Signal Layers，不需要Power Planes，所以将Power 
Planes下面的选择框改为0。单击Next继续。

7．在设计中使用过孔（via）样式选择Thruhole Vias
only，单击Next。
8．在下一页允许设计者设置元件/导线的技术（布
线）选项。选择Through-hole components选项，将相
邻焊盘（pad)间的导线数设为One Track。单击Next
继续。

9．下一页用于设置一些设计规则，如线的宽度、

焊盘的大小，焊盘孔的直径，导线之间的最小距离
如图3-10，在这里设为默认值。点Next按钮继续。



10．单击Finish按钮。 PCB Board Wizard已经设置完所有创建新
PCB板所需的信息。PCB编辑器现在将显示一个新的PCB文
件，名为PCB1.PcbDoc，如图3-11所示。

图3-10 设置线的宽度、焊盘的大小，

焊盘孔的直径，导线之间的最小距离

图3-11 定义好的一个空白的
PCB板形状



11．PCB向导现在收集了它需要的所有的信息来创建设计者
的新板子。PCB编辑器将显示一个名为PCB1.PcbDoc的新的
PCB文件。

12．PCB文档显示的是一个空白的板子形状（带栅格的黑色
区域）。

13．选择View  → Fit Board（热键V，F）将只显示板子形状。

14．选择File → Save As来将新PCB文件重命名（用*.PcbDoc
扩展名）。指定设计者要把这个PCB保存在设计者的硬盘上
的位置，在文件名栏里键入文件名Multivibrator.PcbDoc并单

击保存按钮。



15．如果添加到项目的PCB是
以自由文件打开的，在
Projects面板的Free Documents
单元右击PCB文件，选择Add 
to Project。这个PCB文件已经
被列在Projects下的Source 
Documents中，并与其他项目

文件相连接。设计者也可以
直接将自由文件夹下的
Multivibrator.PcbDoc文件拖到

项目文件夹下。保存项目文
件如图3-12所示。 图3-12 Multivibrator.PcbDoc

文件在项目文件夹下



3.3用封装管理器检查所有元件的封装

在将原理图信息导入到新的PCB之前，请确保所有与原理图
和PCB相关的库都是可用的。由于在本例中只用到默认安装

的集成元件库，所有元件的封装也已经包括在内了。但是为
了掌握用封装管理器检查所有元件的封装的方法，所以设计
者还是执行以下操作：

在原理图编辑器内，执行Tools→Footprint Manager命令，显
示如图3-13所示封装管理器检查对话框。在该对话框的元件
列表（Componene List）区域，显示原理图内的所有元件。

用鼠标左键选择每一个元件，当选中一个元件时，在对话框
的右边的封装管理编辑框内设计者可以添加、删除、编辑当
前选中元件的封装。如果对话框右下角的元件封装区域没有
出现，可以将鼠标放在Add按钮的下方，把这一栏的边框往

上拉，就会显示封装图的区域。如果所有元件的封装检查完
都正确，按Close按钮关闭对话框。



图3-13 封装管理器对话框



3.4导入设计

如果项目已经编辑并且在原理图中
没有任何错误，则可以使用Update 
PCB命令来产生ECO（Engineering 
Change Orders工程变更命令），它
将把原理图信息导入到目标PCB文件。



更新PCB 
将项目中的原理图信息发送
到目标PCB：
1．打开原理图文件
Multivibrator.SchDoc。
2．在原理图编辑器选择
Design → Update PCB 
Document  
Multivibrator.PcbDoc命令。
工程变更命令(Engineering 
Change Order)对话框出现。
如图3-14所示。

图3-14  工程变更命令对话框



3．单击Validate Changes按钮，验证一下有无不妥之处，如
果执行成功则在状态列表(Status)Check中将会显示 符
号；若执行过程中出现问题将会显示 符号，关闭对话框。
检查Messages面板查看错误原因，并清除所有错误。

4．如果单击Validate Changes按钮，没有错误，则单击
Execute Changes按钮，将信息发送到PCB。当完成后，
Done那一列将被标记。如图3-15所示。

图3-15 执行了Validate Changes、Execute Changes后的对话框



5．单击Close按钮，目标PCB文件打开，并且元件也放在PCB
板边框的外面以准备放置。如果设计者在当前视图不能看见
元件，使用热键V、D（菜单View  → Fit Document）查看文档。
如图3-16所示。

图3-16 信息导入到PCB



6．PCB文档显示了一个默认尺寸的白色图纸，要关闭图
纸，选择Design  → Board Options，在Board Options对话框取
消选择Design Sheet。



小结：
3.1印制电路板的基础知识

3.2创建一个新的PCB文件

使用PCB向导来创建PCB。
在Files面板的底部的New from template单元单击PCB Board 

Wizard创建新的PCB。
3.3用封装管理器检查所有元件的封装

在原理图编辑器内，执行Tools→Footprint Manager命令

3.4导入设计

在原理图编辑器选择Design → Update PCB Document  
Multivibrator.PcbDoc命令。



3.5  印刷电路板（PCB）设计



教学目的及要求：

3.5 熟悉印刷电路板的PCB设计

3.5.1 了解PCB设计的规则

3.5.2 熟练掌握在PCB中放置元件、修改封装，

手动布线、自动布线

3.6 熟练掌握验证用户的PCB板设计

教学重点：印刷电路板的PCB设计

教学难点：验证用户的PCB板设计



复习并导入新课

3.1印制电路板的基础知识

3.2创建一个新的PCB文件

使用PCB向导来创建PCB。
在Files面板的底部的New from template单元单击

PCB Board Wizard创建新的PCB。
3.3用封装管理器检查所有元件的封装

在原理图编辑器内，执行Tools→Footprint
Manager命令

3.4导入设计

在原理图编辑器选择Design → Update PCB 
Document  Multivibrator.PcbDoc命令。



现在设计者可以开始在PCB上放置元件并在板上
布线。在开始设计PCB板之前有一些设置需要
做，本章只介绍设计PCB板的必要设置，其它的
设置使用缺省值，详细的介绍将在第8章完成。



3.5.1设置新的设计规则

Altium Designer的PCB编辑器是一个规则驱动环境。

这意味着，在设计者改变设计的过程中，如放置
导线、移动元件或者自动布线，Altium Designer都
会监测每个动作，并检查设计是否仍然完全符合
设计规则。如果不符合，则会立即警告，强调出
现错误。在设计之前先设置设计规则以让设计者
集中精力设计，因为一旦出现错误，软件就会提
示。

设计规则总共有10个类，包括电气、布线、制造、

放置、信号完整性等的约束。



现在来设置必要的新的设计规则，指明电源线、地
线的宽度。具体步骤如下：

1．激活PCB文件，从菜单选择Design → Rules。
2．PCB Rules and Constraints Editor 对话框出现。每一类规
则都显示在对话框的设计规则面板的左边Design Rules文
件夹的下面，如图3-17所示。双击Routing展开显示相关的
布线规则，然后双击Width显示宽度规则。

图3-17 设计规则对话框



3．单击选择每条规则。当设计者单击每条规则时，右边
的对话框的上方将显示规则的范围（设计者想要的这个规
则的目标）如图3-18所示，下方将显示规则的限制。这些
规则都是默认值，或在新的PCB文件创建时在PCB Board 
Wizard(PCB板向导)中设置的信息。

图3-18 设置Width规则



4．单击Width规则，显示它的范围和约束，如图
3-18所示，本规则适用于整个板。



Altium Designer的设计规则系统的一个强大功能是：

同种类型可以定义多种规则，每个规则有不同的
对象，每个规则目标的确切设置是由规则的范围
决定的，规则系统使用预定义优先级，来确定规
则适用的对象。

例如，设计者可以有对接地网络（GND）的宽度
约束规则，也可以有一个对电源线(+12V)的宽度约

束规则（这个规则忽略前一个规则），可能有一
个对整个板的宽度约束规则（这个规则忽略前两
个规则，即所有的导线除电源线和地线以外都必
须是这个宽度），规则依优先级顺序显示。



现在设计者要为+12V和GND网络各添加一个新的宽度约束规
则，要添加新的宽度约束规则，完成以下步骤：

（1）在Design Rules规则面板的Width类被选择时，右击并选择New 
Rule，一个新的名为Width_1的规则出现；然后鼠标再右击并选择New 
Rule，一个新的名为Width_2的规则出现，如图3-19所示。

图3-19 添加Width_1、Width_2线宽规则

（2）在Design Rules面板单击新的名为Width_1的规则以修改其范围和
约束，如图3-20所示。

（3）在名称（Name）栏键入+12V，名称会在Design Rules栏里自动更

新。



（4）在Where The First Object Matches栏选择单选按钮Net，在选择
框内单击向下的箭头，选择+12V，如图3-20所示。

图3-20 选择+12V网络



（5）在Constraints栏，单击旧约束文本（10mil）并键
入新值，将最小线宽（Min Width）、首选线宽
（Preferred Width）和最大线宽(Max Width)均改为
18mil。注意必须在修改Min Width 值之前先设置Max 
Width宽度栏，如图3-21所示。

图3-21 修改线的宽度



（6）用以上的方法,在Design Rules面板单击名为Width_2的规则以修改
其范围和约束。在名称栏键入GND；在Where The First Object Matches
栏选择单选按钮Net，在选择框内单击向下的箭头，选择GND；将Min 
Width、Preferred Width和 Max Width宽度改为25mil。
注意导线的宽带由设计者自己决定，主要取决于设计者PCB板的大小

与元器件的疏密。

（7）最后，单击最初的板子范围宽度规则名Width，将Min Width、
Preferred Width和 Max Width宽度栏均设为12mil。
（8）单击图3-18的 按钮,弹出图3-22所示的优先级对话框，优
先级(Priority)列的数字越小，优先级越高。可以按“Decrease Priority”按
钮减少选中对象的优先级，按“Increase Priority”按钮增加选中对象的
优先级，图3-18所示的GND的优先级最高，Width的优先级最低，单击
Close按钮，关闭Edit Rule Priorities对话框，单击OK按钮，关闭PCB 
Rules and Constraints Editor 对话框。

当设计者用手工布线或使用自
动布线器时，GND导线为
25mil，+12V导线为18mil，其
余的导线均为12mil。

图3-22 线宽的优先级



3.5.2在PCB中放置元件

现在设计者可以放置元件了。

1．按快捷键V、D将显示整个板子和所有元件。

2．现在放置连接器Y1，将光标放在连接器轮廓的

中部上方，按下鼠标左键不放。光标会变成一个
十字形状并跳到元件的参考点。

3．不要松开鼠标左键，移动鼠标拖动元件。

4．拖动连接时，按下Space键将其旋转90°，然
后将其定位在板子的左边，如图3-23所示。



5．元件定位好后，松开鼠标

左键将其放下，注意元件的
飞线将随着元件被拖动。

6．参照图3-23所示放置其余

的元件。当设计者拖动元件
时，如有必要，使用Space键
来旋转元件，让该元件与其
它元件之间的飞线距离最
短，这样飞线就如图3-23所示。

元器件文字可以用同样的方
式来重新定位——按下鼠标左
键不放来拖动文字，按Space
键旋转。

图3-23 放置元件



Altium Designer具有强大的而灵活的放置工具，让设计者

使用这些工具来保证四个电阻正确地对齐和间隔。

（1）按住Shift键，分别单击4个电阻进行选择，或者拖拉选择框包围4个电阻。

（2）光标放在被选择的任一个电阻上，变成带箭头的黑色十字光标，单击右
键并选择Align → Align Bottom （如图3-24所示），那么四个电阻就会沿着它
们的下边对齐；单击右键并选择Align → Distribute Horizontally （如图3-24所
示），那么四个电阻就会水平等距离摆放好。

图3-24 排列对齐元件



（3）如果设计者认为这4个电阻偏左，也可以整

体向右移动

（4）在设计窗口的其它任何地方左击鼠标取消选

择所有的电阻，这四个电阻现在就对齐了并且等
间距。

（5）把PCB板边框以外的“Multivibrator”Room块删
除，如图3-23所示，选中要删除的块，按Delete键
即可。



3.5.3修改封装

现在已经将封装都定位好了，但电容的封装尺寸太大，需
要改作更小尺寸的封装。

1．首先设计者要找到一个新的封装。单击Libraries面板，
从库列表中选择Miscellaneous Deivices.IntLib[Footprint
View]，设计者要的是一个小一些的radial类型的封装，因
此在过滤器栏键入rad，单击封装名就会看见与这名字相
联系的封装，其中封装RAD-0.1就是设计者需要的，如图3-
25所示。

2．在PCB板上双击电容C1，弹出Component C1对话框,在
Footprint 栏将Name处改为RAD-0.1或者单击Name处的如图
3-26所示，弹出Browse Libraries对话框如图3-27所示，选择
RAD-0.1,按OK按钮即可。



图3-25 显示元件的封装 图3-26 Component C1对话框



图3-27 Browse Libraries对话框 图3-28  布好元件的PCB板

每个对象都定位放置好后，就可以开始布线了！



3.5.4手动布线

布线是在板上通过走线和过孔以连接元件的过程。Altium
Designer通过提供先进的交互式布线工具以及Situs拓扑自

动布线器来简化这项工作，只需轻触一个按钮就能对整个
板或其中的部分进行最优化布线。

自动布线器提供了一种简单而有效的布线方式。但在有的
情况下，设计者将需要精确地控制排布的线，或者设计者
可能想享受一下手动布线的乐趣！在这些情况下可以手动
为部分或整块板布线。在这一节的例子中，将手动对单面
板进行布线，将所有线都放在板的底部。

在PCB上的线是由一系列的直线段组成的。每一次改变方
向即是一条新线段的开始。此外，默认情况下，Altium
Designer会限制走线为纵向、横向或45°角的方向，让设

计者的设计更专业。这种限制可以进行设定，以满足设计
者的需要，但对于本例，将使用默认值。



1．用快捷键 L以显示View Configurations对话框。在Signal 
Layers区域中选择在 Bottom Layer旁边的Show选项，单击
OK按钮，底层标签就显示在设计窗口的底部了。在设计
窗口的底部单击Bottom Layer标签，使PCB板的底部处于激

活状态。

2．在菜单中单击Place → Interactive Routing（快捷键：P，
T）或者单击放置（Placement）工具栏的按钮，光标变成

十字形状，表示设计者处于导线放置模式。

3．检查文档工作区底部的层标签。如果Top Layer标签是
激活的，按数字键盘上的“*”键，在不退出走线模式的情况
下切换到底层。“*”键可用在信号层之间切换。

4．将光标定位在排针Y1较低的焊盘（选中焊盘后，焊盘
周围有一个小框围住）。左击鼠标或按Enter按钮，以确定

线的起点。



5．将光标移向电阻R1底下的焊盘。注意：线段是如何跟随光
标路径来在检查模式中显示的。状态栏显示的检查模式表明它
们还没被放置。如果设计者沿光标路径拉回，未连接线路也会
随之缩回。在这里，设计者有两种走线的选择。

①Ctrl十左击鼠标，使用Auto－Complete功能，并立即完成布线
（此技术可以直接使用在焊盘或连接线上）。起始和终止焊盘
必须在相同的层内布线才有效，同时还要求板上的任何的障碍
不会妨碍Auto－Complete的工作。对较大的板，Auto－Complete
路径可能并不总是有效的，这是因为走线路径是一段接一段地
绘制的，而从起始焊盘到终止焊盘的完整绘制有可能根本无法
完成。

②使用Enter键或左击鼠标来接线，设计者可以直接对目标R1的
引脚接线。在完成了一条网络的布线，右击或按ESC键表示设
计者已完成了该条导线的放置。光标仍然是一个十字形状，表
示设计者仍然处于导线放置模式，准备放置下一条导线。用上
述方法就可以布其它导线。要退出连线模式（十字形状）再按
鼠标右键或按ESC键。按End键重画屏幕，这样设计者能清楚地

看见已经布线的网络。



6．未被放置的线用虚线表示，被放置的

线用实线表示。

7．使用上述任何一种方法，在板上的其

他元器件之间布线。在布线过程中按
Space键将线段起点模式切换到水平/450/
垂直。

8．如果认为某条导线连接得不合理，可

以删除这条线：方法选中该条线，按
Delete键来清除所选的线段，该线变成飞

线。然后重新布这条线。

9．完成PCB上的所有连线后，如图3-29
所示，右击或者按ESC键以退出放置模

式。

10．保存设计（快捷键为F,S 或者Ctrl＋
S）。

图3-29 完成手动
布线的PCB板



布线的时候请记住以下几点。

①单击或按Enter键，来放置线到当前光标的位置。状态栏显示的检查模式代

表未被布置的线，已布置的线将以当前层的颜色显示为实体。

②在任何时候使用Ctrl键十单击来自动完成连线。起始和终止引脚必须在同一

层上，并且连线上没有障碍物。

③使用Shift＋Space来选择各种线的角度模式。角度模式包括：任意角度，
450，弧度450，900和弧度900。按Space键切换角度。

④在任何时间按End键来刷新屏幕。

⑤在任何时间使用V，F键重新调整屏幕以适应所有的对象。

⑥在任何时候按Page UP或 Page Down键，以光标位置为核心，来缩放视图。
使用鼠标滚轮向上边和下边平移。按住Ctrl键，用鼠标滚轮来进行放大和缩小。

⑦当设计者完成布线并希望开始一个新的布线时，右击或按ESC键。

⑧为了防止连接了不应该连接的引脚。Altium Designer将不断地监察板的连通

性，并防止设计者在连接方面的失误。

⑨重布线是非常简便的，当设计者布置完一条线并右击完成时，冗余的线段
会被自动清除。

祝贺！设计者已经手工布线完成了PCB板设计。



3.5.5自动布线

请完成以下步骤，设计者会发现使用Altium
Designer软件是如此方便。

1．首先，从菜单选择Tools → Un-Route → All（快
捷键U，A）取消板的布线。

2．从菜单选择Auto Route → All（快捷键A，A），
弹出 Situs Routing Strategies对话框，单击Route All
按钮。Messages显示自动布线的过程。

Situs autorouter提供的布线结果可以与一名经验丰
富的设计师相比，如图3-30所示。这是因为Altium
Designer在PCB窗口中对设计者的板进行直接布

线，而不需要导出和导入布线文件。



图3-30 自动布线结果

（3）单击File＋Save命令（快捷键：F，S）来储

存设计者设计的板。



注：线的放置由Autorouter通过两种颜色来呈现。红色，

表明该线在顶端的信号层；蓝色，表明该线在底部的信号
层。要用于自动布线的层在PCB Board Wizard中的 Routing 
Layer 设计规则中指定。设计者也会注意到连接到连接器

的两条电源网络导线要粗一些，这是由设计者所设置的两
条新的Width设计规则所指明的。

如果设计中的布线与图3-29不完全一样，也是正确的，因

为手动布线时，布的是单面板，而自动布线时，布的是双
面板，再加上元器件摆放位置不完全相同，布线也会不完
全相同。图3-30为自动布线的结果。

因为最初在PCB Board Wizard中确定的板是双面印刷电路

板，所以设计者可以使用顶层和底层来手工将设计者的板
布线为双面板。要这样做，从菜单选择Tools → Un-Route 
→ All（快捷键U，A）取消板的布线。象以前那样开始布
线，但要在放置导线时用“*”键在层间切换。Altium
Designer软件在切换层的时候会自动地插入必要的过孔。



3.6验证设计者的板设计
Altium Designer提供一个规则驱动环境来设计PCB，并允许
设计者定义各种设计规则来保证PCB板设计的完整性。比

较典型的做法是，在设计过程的开始设计者就设置好设计
规则，然后在设计进程的最后用这些规则来验证设计。

在本例中设计者已经添加了二个新的宽度约束规则。设计
者也注意到已经由PCB板向导创建了许多规则。

为了验证所布线的电路板是符合设计规则的，现在设计者
要运行设计规则检查Design Rule Check(DRC)。
选择Design→ Board Layers &Colors（快捷键L），确认
System Colors 单元的DRC Error Markers 选项旁的Show复选
框被勾选，这样DRC错误标记（DRC error markers）才会显

示出来。



从图3-30可以看出，三极管Q1、Q2和4个电阻R1~R4的焊盘呈
现绿色高亮，表示它们违反了设计规则，因为规则是实时检
查的。下面检查违反设计规则的原因：

1．从菜单选择Tools → Design Rule Check（快捷键
T，D）,弹出Design Rule Checker对话框如图3-31所
示，保证Design Rule Checker 对话框的实时和批处

理设计规则检测都被配置好。点一个类查看其所
有原规则，如单击Electrical,可以看到属于那个种

类的所有规则。



图3-31 设计规则检查对话框

2．保留所有选项为默认值，单击Run Design Rule Check按钮。DRC就
开始运行，Design Rule Verification Report将自动显示，如图3-32所示，
并在该文件夹Project Outputs for Multivibrator下，产生了Design Rule 
Check–Multivibrator.drc文件。



图3-32 设计规则检查报告



从Multivibrator.drc文件看出有三个地方出错，
错误如下：

1．Processing Rule:Clearance Constraint (Gap=13mil) (All),(All) 
2．Processing Rule :Silkscreen Over Component Pads 
(Clearance=10mil) (All),(All)
3．Processing Rule:Minimum Solder Mask Sliver (Gap=10mil) 
(All),(All)
错误结果也将显示在Messages面板。打开Messages面板，
鼠标双击Messages面板中的一个错误，可以跳转到对应的
PCB中的位置。

下面依次解决3个违反设计规则的地方，现在检查第1个违

反设计规则的地方：

Clearance Constraint (Gap=13mil) (All),(All)。指出三极管Q1和
Q2的焊盘违反了13mil安全间距规则。



一、找出三极管焊盘间的实际间距：
1．在PCB文档激活的情况下，将光标放在一个三极管的中间按
PageUp键来放大视图。

2．选择Reports → Measure Primitives（快捷键R，P），光标变成十字
形状。

3．将光标放在Q1三极管中间的一个焊盘的中心，左击或按ENTER。
因为光标是在焊盘和与其连接的导线上，所以会有一个选择框弹出来
让设计者选择需要的对象（如图3-33），从选择框中选择三极管的焊

盘。

图3-33 选择框选择需要的对象

4．将光标放在Q1三极管右边焊盘的中心，左击或按ENTER,再一次从

弹出选择框中选择焊盘，一个信息框将打开显示两个焊盘的边缘之间
的最小距离是10.63mil，如图3-34所示。



图3-34 显示焊盘边缘的距离

5．单击OK按钮关闭信息框，然后右击或按ESC退出测量
模式，在且V、F快捷键重新缩放文档。



二、设计者看看当前安全间距设计规则。

1．从菜单选择Design →
Rules（快捷键D，R）打开
PCB Rules and Constraints 
Editor 对话框。双击Electrical
类在对话框的右边显示所有
电气规则。双击Clearance类
型展开该行，然后单击展开
Clearance打开它。对话框底

部区将包括一个单一的规
则，指明整个板的最小安全
间距（Minimum Clearance）
是13mil，如图3-35所示。而
三极管焊盘之间的间距小于
这个值，这就是为什么当运
行DRC规则检查的时候，它

们弹出了违反规则的信息。

图3-35 Electrical类设计规则



现在知道两个三极管焊盘之间
的最小距离是10.63mil，建立

一个针对三极管焊盘之间的设
计规则，大小为10mil。
2．在PCB Rules and 
Constraints Editor 对话框中选
择Clearance类型（左列），右
击并选择New Rule添加一个新

的安全间距约束规则
Clearance_1。
3．双击新的安全间距规则
Clearance_1，在Constraints单
元设置Minimum Clearance为
10mil，如图3-36所示。

图3-36 设置最小间距
10mil



4．由于该规则是一个二元规则（既有2个对象：
导线、焊盘）。选择第一个对象（where The First 
Object Matches），单击Advanced (Query)选项，然
后单击Query Helper按钮(如图3-35所示)，弹出
Query Helper的对话框(如图3-37所示)，在Categories
栏选择Membership Checks,然后在Name栏双击
HasFootprintPad，“HasFootprint( ,)”就出现在query
栏，在“( ,)”内输入三极管封装的名字：TO-92A并
在逗号后输入：‘*’，如图3-37所示，设置好后，单
击OK关闭对话框；或在图3-35的Full Query栏直接
键入：HasFootprintPad(‘TO-92A’,‘*’)。“*”表示名为
TO-92A的“任何焊盘”。



图3-37 Query Helper的对话框

5．在步骤4设置好规则Clearance_1的约束范围后，单击OK按钮关闭对

话框。

6．设计者现在可以从Design Rules Checker 对话框（Tools → Design 
Rule Check）单击Run Design Rule Check按钮重新运行DRC。就不会有
“1. Clearance Constraint (Gap=13mil) (All),(All)”的提示信息了。



现在来检查第二第三个错误提示：

Silkscreen Over Component Pads 
(Clearance=10mil) (All),(All)

Minimum Solder Mask Sliver (Gap=10mil) 
(All),(All)



1．从菜单选择Design → Rules（快捷键D，R）打
开PCB Rules and Constraints Editor 对话框。双击
Manufacturing类在对话框的右边显示所有制造规
则（如图3-38所示），现在看出第2、3个错误提示

信息都属于制造规则类，现在的主要任务是设计
PCB板，与制造的关系不大，所以可以关闭这2个
规则。

方法：在图3-38对话框的右边，找到Silkscreen 
Over Component Pads和Minimum Solder Mask Sliver
两行，把Enabled栏的复选框的“√”去掉即可,表示
不进行该2项的规则检查。



图3-38 PCB 设计规则编辑对话框

2．单击图3-38的OK按钮，PCB板上就没有绿色的高亮显示
了，如图3-1所示。保存已经完成的PCB和项目文件。



3.7 在3D模式下查看电路板设计

如果设计者能够在设计过程中使用设计工具直观地看到自己
设计板子的实际情况，将能够有效的帮助他们的工作。Altium
Designer软件提供了这方面的功能，下面研究一下它的3D模式。
在3D模式下可以让设计者从任何角度观察自己设计的板。

Altium Designer软件的3D环境的要求支持DirectX9.0C及相关技

术，并使用一块独立的显卡。对于如何测试系统，以及让
Altium Designer可以使用DirectX，单击菜单Tools → Preferences
打开 Preferences对话框中如图3-39所示，选择PCB Editor的
Display选项，按“Test DirectX”按钮，测试显卡是否支持
DirectX，以下按提示做，如果显卡支持DirectX，就可进行如

下操作。

注意：DirectX9.0C软件可以从网上下载，然后进行安装。



图3-39 参数设置对话框



3.7.1 设计时的3D显示状态

要在PCB编辑器中切换到3D，只需单击View→Switch To 3D
命令（快捷键：3）或者从列表中PCB标准工具栏中选择
一个3D视图配置，如图3-40所示。

图3-40 选择3D显示



进入3D模式时，一定要使用下面的操作来显示
3D，否则就要出错，提示：“Action not available in 
3d view”。
1.缩放——按Ctrl键十鼠标右拖，或者Ctrl十鼠标滚
轮，或者Page Up／Page Down键。

2.平移——按鼠标滚轮：向上／向下移动，Shift十
鼠标滚轮：向左／右移动，向右拖动鼠标来向任
何方向移动。

3.旋转——按住Shift键不放，再按鼠标右键，进人
3D旋转模式。光标处以一个定向圆盘的方式来表
示如图3-41。该模型的旋转运动是基于圆心的，

使用以下方式控制。



图3-41 PCB板的3D显示
①用鼠标右键拖拽圆盘中心点Center Dot，任意方向旋转视图。
②用鼠标右键拖拽圆盘水平方向箭头（Horizontal Arrow），关于Y轴旋
转视图。
③用鼠标右键拖拽圆盘垂直方向箭头（Vertical Arrow），关于X轴旋转
视图。



3.7.2 3D显示设置

使用上述的操作命令，设计者可以非常方便的在
3D显示状态实时查看正在设计板子的每一个细节。

使用板层和颜色设置对话框可以修改这些设置，
通过菜单Design→Board Layers &Colors或者快捷键
‘L’来访问此对话框如图3-42所示。用该对话框，

设计者根据板子的实际情况设置相应的板层颜
色，或者调用已经存储的板层颜色设置。这样，
3D显示的效果会更加逼真。



图3-42  板层和颜色设置对话框



3.7.3 3D模型介绍

如果需要把板子紧密的放在特殊形状的壳体中，
通常要把板子的文件转换到M-CAD系统的格式。

您也可以在PCB元件库的封装中导入STEP模型，
从而产生了一个完整的从E-CAD 到M-CAD的3D解
决方案。

元件形状的建模可以使用Altium Designer的3D body
对象（后面章节进行介绍）或通过导入STEP格式

的元件模型来实现，这两种模式都可以输出到板
子的STEP文件。



3.7.4 为元器件封装导入3D实体

Altium Designer软件的3D环境提供了一个逼真的检
查PCB组装的环境。

元器件封装本身存储有3D模型，用于在3D环境下
渲染该元件。这里设计的板已经包含了器件的3D
模型，板和元器件的3D模型可以在Altium Designer
软件安装中的Examples／Tutorials／
multivibrator_step文件夹中找到。方法：单击菜单
File→Open选择 Examples／Tutorials／
multivibrator_step/multivibrator_step.PcbDoc文件，
导入3D实体的PCB如图3-43所示：



图3-43 导入3D实体PCB图
1.按快捷键：3，显示如图3-44的3D实体PCB图。



图3-44 PCB板3D实体图



2．按住Shift键不放，再按鼠标右键，进人3D旋转
模式，用鼠标右键拖拽圆盘中心点，任意方向旋
转视图（如图3-45）。

图3-45 任意旋转的PCB板3D实体图



3.设计者可以将3DSTEP格式模型导入到元器件的
封装和PCB设计中并创建自己的3D物体，也可以
以STEP和DWG／DXF格式来输出PCB文件，以便用
于其他程序中。The legacy 3D viewer(方法：Tools 
→Legacy Tools → Legacy 3D View)可以导人VRML1.0
／IGES／STEP格式的3D物体（如图3-46所示），
也可以导出IGES和STEP格式的3D物体。



图3-46 VRML1.0／IGES／STEP格式的3D物体

注：任何时候在3D模式下，设计者都可以以各种分辨率创建实时“快
照”，使用Ctrl＋C快捷键复制，这样就可以将图像（Bitmap格式）存
储在Windows剪贴板中，用于其他应用程序。



小结：

3.1印制电路板的基础知识

3.2创建一个新的PCB文件

3.3用封装管理器检查所有元件的封装

3.4导入设计

3.5印刷电路板（PCB）设计

3.5.1设置新的设计规则

3.5.2在PCB中放置元件

3.5.3修改封装

3.5.4手动布线

3.5.5自动布线

3.6验证设计者的板设计

3.7 在3D模式下查看电路板设计
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第4章 创建原理图元器件库



任务描述：

图7-1  数码管显示器电路原理图



教学目的及要求：

熟悉原理图库、模型和集成库的概念

熟练掌握创建库文件包及原理图库的方法

熟练掌握创建原理图元件的方法

熟练掌握为原理图元件添加模型的方法

熟练掌握从其他库中复制元件然后修改为自
己需要的元件的方法

教学重点：创建原理图元件

教学难点：原理图库、模型和集成库的概念



复习并导入新课：
3.1印制电路板的基础知识

3.2创建一个新的PCB文件

使用PCB向导来创建PCB。

3.3用封装管理器检查所有元件的封装

在原理图编辑器内，执行Tools→Footprint Manager命令

3.4导入设计

在原理图编辑器选择Design → Update PCB Document  
Multivibrator.PcbDoc命令。

3.5印刷电路板（PCB）设计

3.5.1设置新的设计规则

3.5.2在PCB中放置元件

3.5.3修改封装

3.5.4手动布线

3.5.5自动布线

3.6验证设计者的板设计

3.7 在3D模式下查看电路板设计



4.1 原理图库、模型和集成库
在Altium Designer中，原理图元器件符号是在原理图库
编辑环境中创建的(.SchLib文件)。之后原理图库中的元
器件会分别使用封装库中的封装和模型库中的模型。设计
者可从各元器件库放置元件，也可以将这些元器件符号库
、封装库和模型文件编译成集成库(.IntLib文件)。在集
成库中的元器件不仅具有原理图中代表元件的符号，还集
成了相应的功能模块，如Foot Print封装、电路仿真模块
、信号完整性分析模块等。
集成库是通过分离的原理图库、PCB封装库等编译生成的
。在集成库中的元器件不能够被修改，如要修改元器件可
以在分离的库中编辑然后再进行编译产生新的集成库即可
。
Altium Designer的集成库文件位于软件安装路径下的
Library文件夹中，它提供了大量的元器件模型（大约
80000个符合ISO规范的元器件）。设计者可以打开一个集
成库文件，执行Extract Sources命令从集成库中提取出
库的源文件，在库的源文件中可以对元器件进行编辑。



库文件包（.LibPkg文件）是集成库文件的基础，它将生成

集成库所需的那些分立的原理图库、封装库和模型文件有机
地结合在一起。

库文件包（.LibPkg文件）编译生成集成库(.IntLib文件）



4.3 创建新的库文件包和原理图库

设计者创建元件之前，需要创建一个新的原理
图库来保存设计内容。这个新创建的原理图库
可以是分立的库，与之关联的模型文件也是分
立的。另一种方法是创建一个可被用来结合相
关的库文件编译生成集成库的原理图库。使用
该方法需要先建立一个库文件包，库文件包
（.LibPkg文件）是集成库文件的基础，它将
生成集成库所需的那些分立的原理图库、封装
库和模型文件有机地结合在一起。



新建一个集成库文件包和空白原理图库步骤如下：

l．执行 File → New → Project → Integrated 
Library命令，Projects面板将显示新建的库文件包，默
认名为Integrated_Libraryl.LibPkg。

2．在Projects面板上右击库文件包名，在弹出菜单上单
击Save Project As命令，在弹出的对话框中使用浏览功
能选定适当的路径，然后输人名称New Integrated_ 
Library1.LibPkg，单击Save按钮。注意如果不输人后缀
名的话，系统会自动添加默认名。

3．添加空白原理图库文件。执行File → New →
Library → Schematic Library命令，Projects面板将显
示新建的原理图库文件，默认名为Schlibl.SchLib。自动
进入电路图新元件的编辑界面，如图4-1所示。



图4-1 原理图库新元件的编辑界面

4．单击File→Save As命令，将库文件保存为New 
Schlibl.SchLib。

5．单击SCH Library标签打开SCH Library面板如图4-2所示。如
果SCH Library标签未出现，单击主设计窗口右下角的SCH按钮并
从弹出的菜单中选择SCH Library即可（√表示选中）。

6．原理图库元器件编辑器（SCH Library）面板介绍。

原理图库元器件编辑器管理面板如图4-2所示，其各组成部分介绍
如下：



图4-2 元件库管理面板

过滤区

元件区

别名区

引脚区

模型区



（l）Components区域。

Components区域用于对当前元器件库中的元件进行管理。可以在
Components区域对元件进行放置、添加、删除和编辑等工作。在
图4-2中，由于是新建的一个原理图元件库，其中只包含一个新的
名称为Component_l的元件。Components区域上方的空白区域用于
设置元器件过滤项，在其中输人需要查找的元器件起始字母或者
数字，在Components区域便显示相应的元器件。

Place按钮将Componens区域中所选择的元器件放置到一个处于激
活状态的原理图中。如果当前工作区没有任何原理图打开，则建
立一个新的原理图文件，然后将选择的元器件放置到这个新的原
理图文件中。

Add按钮可以在当前库文件中添加一个新的元件。

Delete按钮可以删除当前元器件库中所选择的元件。

Edit按钮可以编辑当前元器件库中所选择的元件。单击此按钮，
屏幕将弹出如图4-9所示的元件属性设置窗口，可以对该元件的各
种参数进行设置。关于元件属性设置窗口各参数的具体设置，将
在后面的4.5节中介绍。



（2）Aliases区域。

该区域显示在Components区域中所选择的元件的别名。单
击Add按钮，可为Components区域中所选中的元件添加一
个新的别名。

单击Delete按钮，可以删除在Aliases区域中所选择的别
名。单击Edit按钮，可以编辑Aliases区域中所选择的别
名。

（3）Pins信息框。

Pins信息框显示在Component区域中所选择元件的引脚信
息，包括引脚的序号、引脚名称和引脚类型等相关信息。

单击Add按钮，可以为元件添加引脚。单击Delete按钮，
可以删除在Pins区域中所选择的引脚。

（4）Model信息框。

设计者可以在Model信息框中为Components区域中所选择
元件添加PCB封装(PCB Footprint)模型、仿真模型和信号
完整性分析模型等。具体设置方法将在4.6节介绍。



4.4 创建新的原理图元件
设计者可在一个已打开的库中执行Tools→New Component命令新建一
个原理图元件。由于新建的库文件中通常已包含一个空的元件，因此
一般只需要将Component_1重命名就可开始对第一个元件进行设计，
这里以AT89C2051单片机（如图4-7所示）为例介绍新元件的创建步骤。

在原理图新元件的编辑界面内：

1．在SCH Library面板上的Components列表中选中Component_1选
项，执行Tools→ Rename Component命令，弹出重命名元件对话框输
入一个新的、可唯一标识该元件的名称，如AT89C2051，并单击“确
定”按钮。同时显示一张中心位置有一个巨大十字准线的空元件图纸
以供编辑。

2．如有必要，执行Edit→Jump→Origin命令（快捷键J，O），将设
计图纸的原点定位到设计窗口的中心位置。检查窗口左下角的状态
栏，确认光标已移动到原点位置。新的元件将在原点周围上生成，此
时可看到在图纸中心有一个十字准线。设计者应该在原点附近创建新
的元件，因为在以后放置该元件时，系统会根据原点附近的电气热点
定位该元件。　



3．可在“Library Editor 
Workspace”对话框设置单位、捕获
网格(Snap)和可视网格(Visible)等
参数，执行Tools→Document
Options命令（快捷键T，D），弹出
Library Editor Workspace对话框
如图4-3所示。针对当前使用的例
子，此处需要图4-3所示对话框中各
项参数。选择Always Show 
Comment/Designator复选框，以便
在当前文档中显示元器件的注释和
标识符。单击Units标签，选中Use 
Imperial Unit System复选框，其
它使用默认值，单击OK按钮关闭对
话框。注意缩小和放大均围绕光标
所在位置进行，所以在缩放时需保
持光标在原点位置。

图4-3 在对话框设置单位

和其他图纸属性



4．为了创建AT89C2051单片机，首先需定义元
件主体。在第4象限画矩形框：
1000*1400mil；执行Place→Rectangle命令或
单击“ ”图标，此时鼠标箭头变为十字光
标，并带有一个矩形的形状。在图纸中移动十
字光标到坐标原点（0，0），单击鼠标左键确
定矩形的一个顶点，然后继续移动十字光标到
另一位置(100,-140)，单击鼠标左键，确定矩
形的另一个顶点，这时矩形放置完毕。十字光
标仍然带有矩形的形状，可以继续绘制其他矩
形。



5．元件引脚代表了元件的
电气属性，为元件添加引
脚的步骤如下。

（1）单击Place→Pin命令
（快捷键P，P）或单击工
具栏按钮“ ”，光标处
浮现引脚，带电气属性。

（2）放置之前，按Tab键
打开Pin ProPerties对话
框，如图4-6所示。如果设
计者在放置引脚之前先设
置好各项参数，则放置引
脚时，这些参数成为默认
参数，连续放置引脚时，
引脚的编号和引脚名称中
的数字会自动增加。

图4-6 放置引脚前设置其属性



（3）在Pin Properties对话框中,Display Name
文本框输人引脚的名字：P3.0(RXD)，在
Designator文本框中输人唯一（不重复）的引脚
编号：2，此外，如果设计者想在放置元件时，引
脚名和标识符可见，则需选中Visible复选框。

（4）在Electrical Type栏，从下拉列表中设置
引脚的电气类型。该参数可用于在原理图设计图
纸中编译项目或分析原理图文档时检查电气连接
是否错误。在本例AT89C2051单片机中，大部分引
脚的Electrical Type设置成Passive，如果是VCC
或GND引脚的Electrical Type设置成Power。



注意：Electrical Type——设置引脚的电

气性质，包括八项。

①Input   输入引脚

②I/O     双向引脚

③Output  输出引脚

④Open Collector   集电极开路引脚

⑤Passive          无源引脚(如电阻、电容
引脚)

⑥HiZ 高阻引脚

⑦Emitter          射击输出

⑧Power            电源（VCC或GND）



（5）Symbols —— 引脚符号设置域

Inside        元器件轮廓的内部

Inside Edge   元器件轮廓边沿的内侧

Outside Edge  元器件轮廓边沿的外侧

Outside       元器件轮廓的外部

每一项里面的设置根据需要选定。

（6）Graphical —— 引脚图形（形状）设置

Location X   Y    引脚位置坐标X、Y

Length            引脚长度

Orientation       引脚的方向

Color             引脚的颜色



（7）本例设置引脚长度（所有引脚长度设置为30mil），
并单击OK按钮。

（8）当引脚‘悬浮’在光标上时，设计者可按Space以
900间隔逐级增加来旋转引脚。记住，引脚只有其末端具
有电气属性也称热点（Hot End）如图 所示，也就是在
绘制原理图时，只有通过热点与其它元件的引脚连接。不
具有电气属性的另一末端毗邻该引脚的名字字符。

在图纸中移动十字光标，在适当的位置单击鼠标左键，就
可放置元器件的第一个引脚。此时鼠标箭头仍保持为十字
光标，可以在适当位置继续放置元件引脚。

（9）继续添加元件剩余引脚，确保引脚名、编号、符号
和电气属性是正确的。注意：引脚6（P3.2）、引脚
7(P3.3)的Outside Edge (元器件轮廓边沿的外侧)处：选
择“Dot”。放置了所有需要的引脚之后，单击鼠标右
键，退出放置引脚的工作状态。放置完所有引脚的元件如
图4-7所示。



4-7 新建元件AT89C2051

（10）完成绘制后，单击File→Save命令保存建好的
元件。



添加引脚注意事项如下所示：
①放置元件引脚后，若想改变或设置其属性，可双击该引脚或在SCH 
Library面板Pins列表中双击引脚，打开Pin Properties对话框。如
果想一次多改几个引脚的属性，按住Shift键，依次选定每个引脚，
再按F11键显示Inspector面板,就可在该面板中编辑多个引脚。
Inspector面板的使用在后面章节（7.3中）详细介绍。

②在字母后使用\（反斜线符号）表示引脚名中该字母带有上划线，
如I\N\T\0\将显示为“INT0”。

③若希望隐藏电源和接地引脚，可选中Hide复选框。当这些引脚被隐
藏时，系统将按Connect To区的设置将它们连接到电源和接地网络，
比如VCC引脚被放置时将连接到VCC网络。

④选择View → Show Hidden Pins命令，可查看隐藏引脚；不选择该
命令，隐藏引脚的名称和编号。

⑤设计者可在Component Pin Editor对话框中直接编辑若干引脚属性
如图4-8所示，而无须通过Pin Properties对话框逐个编辑引脚属性。
在Library Component Properties对话框中（如图4-9所示）单击左
下角的Edit Pins按钮打开Component Pin Editor对话框如图4-8所示。



图4-8  在Component Pin Editor对话框中查看和编辑所有引脚

⑥对于多部件的元件，被选中部件的引脚在Component  Pin 
Editor 对话框中将以白色背景方式加以突出，而其他部件的引脚
为灰色。但设计者仍可以直接选中那些当前未被选中的部件的引
脚，单击Edit按钮打开Pin ProPerties对话框进行编辑（该⑥的
内容4.9节详细介绍）。



4.5 设置原理图元件属性

每个元件的参数都跟默认
的标识符、PCB封装、模
型以及其他所定义的元件
参数相关联。

设置元件参数步骤如下所
示。

1．在SCH  Library面板
的Components列表中选择
元件，单击Edit按钮或双
击元件名，打开Library 
Component Properties
对话框，如图4-9所示。

图4-9  元件基本参数设置



2．在Default Designator处设置为“U？”。以方便
在原理图设计中放置元件时，自动放置元件的标识
符。如果放置元件之前已经定义好了其标识符（按
Tab键进行编辑），则标识符中的“？”将使标识符
数字在连续放置元件时自动递增，如U1，U2…。要
显示标识符，需选中Default Designator区的
Visible复选框。
3．在Comment处为元件输人注释内容，如
AT89C2051，该注释会在元件放置到原理图设计图
纸上时显示。该功能需要选中Comment区的Visible
复选框。如果Comment栏是空白的话，放置时系统
使用默认的Library Reference。
4．在Description区输人描述字符串。如对于单片
机可输入：单片机AT89C2051，该字符会在库搜索
时会显示在Libraries面板上。
5．根据需要设置其他参数。



4.7 从其它库复制元件

有时设计者需要的元件在Altium Designer提供

的库文件中可以找到，但他提供的元件图形不
满足设计者的需要，这时可以把该元件复制到
自己建的库里面，然后对该元件进行修改，以
满足需要。本节介绍该方法，并为后面章节的
数码管显示电路准备数码管元件DPY Blue-CA。



4.7.1在原理图中查找元件

首先在原理图中查找数码管DPY Blue-CA，在
Libraries库面板中，单击Search按钮，弹出
Libraries Search对话框如图4-13所示。

选择Field选项区域。在Field处，选择Name；在
Operator处选择contains；在Value处输入数码管
的名字：*DPY* (‘*’匹配所有的字符)。
选择Scope选项区域，在Search in处：选择
Components，选中单选按钮Libraries on Path，
并设置Path为Altium Designer安装目录下的
Library文件夹，同时确认选中了 Include 
Subdirectories复选框，单击 Search按钮。

查找的结果如图4-19所示。



图4-19 找到的数码管



4.7.2 从其它库中复制元件

设计者可从其它已打开的原理图库中复制元件到当前原理
图库，然后根据需要对元件属性进行修改。如果该元件在
集成库中，则需要先打开集成库文件。方法：

（1）单击File →Open命令，弹出选择打开文档对话框如
图4-20所示，找到Altium Designer的库安装的文件夹，选择
数码管所在集成库文件：Miscellaneous Devices.IntLib，单
击“打开”按钮。

（2）弹出图4-21 Extract Sources or Install（抽取源库文件
或安装）的对话框，选择Extract Sources按钮，释放的库
文件如图4-22所示。

（3）在Projects面板打开该源库文件（Miscellaneous 
Devices.Schlib），鼠标双击该文件名。



图4-20 打开Miscellaneous Devices.IntLib集成库



图4-21 释放集成库或安装集成库 图4-22 释放的集成库



（4）在SCH Library面板Components列表中选择想复制的元件，该元
件将显示在设计窗口中(如果SCH Library面板没有显示，可按窗口底部
SCH按钮，弹出上拉菜单选择SCH Library)。
（5）执行Tools → Copy Components命令将弹出Destination Library目标
库对话框如图4-23所示。

（6）选择想复制元件到目标库的库文件，如图4-23所示，单击OK按
钮，元件将被复制到目标库文档中（元件可从当前库中复制到任一个
已打开的库中）。

图4-23 复制元件到目标库的库文件

设计者可以通过SCH Library面板一次复制一个或多个元件到目标库，
按住Ctrl键单击元件名可以离散地选中多个元件或按住Shift键单击元

件名可以连续地选中多个元件，保持选中状态并右击在弹出的菜单中
选择Copy选项；打开目标文件库，选择SCH Library面板，右击
Components列表，在弹出的菜单中选择Paste即可将选中的多个元件

复制到目标库。



4.7.3修改元件

把数码管改成需要的形状。

（1）选择黄色的矩形框，把他改成左上角坐标（0，0），右下角坐
标（90，-70）的矩形框。

（2）移动引脚a-g、dp到顶部，选中引脚时，按TAB键，可编辑引脚
的属性，按Space键可按以900间隔逐级增加来旋转引脚，把引脚移到
‘图4-26所示’的位置。

（3）改动中间的‘8’字。Altium Designer状态显示条（底端左边位置）
会显示当前网格信息，按G键可以在定义好的3种网格（1、5、10）设
置中轮流切换，本例中设置网格值（Grid）为1。选中要移动的线段，
按鼠标右键弹出下拉菜单选择剪切(Cut)，把它粘贴到需要的地方即可。

（4）也可以重新画‘8’字，执行Place→Line命令，按‘TAB’键，可编辑
线段的属性如图4-24，选Line Width为Medium，Line Style为Solid，Color
选需要的颜色，设置好后，按OK键，即可画出需要的8字。



（5）小数点的画法：执行Place→Ellipse命令，按‘TAB’键，可编辑椭
圆的属性如图4-25，选Border Width：Medium，Border Color与Fill Color
的颜色一致（与线段的颜色相同），设置好后，按OK键，光标处‘悬
浮’椭圆轮廓，首先用鼠标在需要的位置定圆心，再定X方向的半径，
最后定Y方向的半径，即可画好小数点。

图4-24  设置Line的属性 图4-25设置Ellipse的属

性
图4-26  修改好的数码

管



小结：
4.1 原理图库、模型和集成库
4.3 创建新的库文件包和原理图库
4.4 创建新的原理图元件
4.5 设置原理图元件属性
4.6 为原理图元件添加模型

4.6.1 模型文件搜索路径设置
4.6.2 为原理图元件添加封装模型
4.6.3 用模型管理器为元件添加封装模型

4.7 从其他库复制元件
4.7.1 在原理图中查找元件
4.7.2 从其他库中复制元件
4.7.3 修改元件



作业：

P75  1∽5



4.8 创建多部件原理图元件

教学目的及要求：

1.熟练掌握创建多部件原理图元件的方法

2.熟悉检查元件并生成报表的方法

教学重点：

创建多部件原理图元件

教学难点：

多部件原理图元件的含义



复习 ：

4.1 原理图库、模型和集成库

4.3 创建新的库文件包和原理图库

4.4 创建新的原理图元件

4.5 设置原理图元件属性

4.6 为原理图元件添加模型

4.7 从其他库复制元件

4.7.1 在原理图中查找元件

4.7.2 从其他库中复制元件

4.7.3 修改元件



4.8 创建多部件原理图元件
前面示例中所创建的两个元件的模型代表了整个元件，即单一模型
代表了元器件制造商所提供的全部物理意义上的信息（如封装）。
但有时候，一个物理意义上的元件只代表某一部件会更好。比如一
个由8只分立电阻构成，每一只电阻可以被独立使用的电阻网络。再
比如2输入四与门芯片74LS08如图4-27所示，该芯片包括四个2输人
与门，这些2输人与门可以独立地被随意放置在原理图上的任意位置
，此时将该芯片描述成4个独立的2输人与门部件，比将其描述成单
一模型更方便实用。4个独立的2输人与门部件共享一个元件封装，
如果在一张原理图中只用了一个与门，在设计PCB板时还是要用一个
元件封装，只是闲置了3个与门；如果在一张原理图中用了四个与门
，在设计PCB板时还是只用一个元件封装，没有闲置与门。多部件元
件就是将元件按照独立的功能块进行描绘的一种方法。

图4-27 2输入四与门芯片
74LS08的引脚图及实物图



作为示例，创建74LS08 2输入四与门电路的步骤如下：

（1）在Schematic Library编辑器中执行Tools→New 
Component命令（快捷键为T，C），弹出New Component 
Name对话框。另一种方法：在SCH Library库面板，用鼠
标单击Components列表处的Add按钮，弹出New Component 
Name对话框。

（2）在New Component Name对话框内，输人新元件名称
：74LS08，单击OK按钮，在SCH Library面板Components
列表中将显示新元件名，同时显示一张中心位置有一个巨
大十字准线的空元件图纸以供编辑。

（3）下面将详细介绍如何建立第一个部件及其引脚，其
他部件将以第一个部件为基础来建立，只需要更改引脚序
号即可。



4.8.l 建立元件轮廓
元件体由若干线段和圆角组成，执行Edit →Jump Origin（快捷键
为J,O）使元件原点在编辑页的中心位置，同时要确保网格清晰可见
（快捷键为Page UP）。

1.放置线段

（1）为了画出的符号清晰、美观，Altium Designer状态显示条会
显示当前网格信息，本例中设置网格值为5。

（2）执行Place → line命令（快捷键为 P，L)或单击工具栏 按
钮，光标变为十字准线，进入折线放置模式。

（3）按Tab键设置线段属性，在Polyline对话框中设置线段宽度为
Small。

（4）参考状态显示条左侧X，Y坐标值，将光标移动到（25，-5）位
置，按Enter键选定线段起始点，之后用鼠标单击各分点位置从而分
别画出折线的各段（单击位置分别为（0，-5），（0，-35）,（25
，-35）），如图4-28所示。

（5）完成折线绘制后，右击或按Esc键退出放置折线模式，注意要
保存元件。



2.绘制圆弧

放置一个圆弧需要设置4个参数：中心点、半径、圆弧的起始角度、
圆弧的终止角度。注意：可以按Enter键代替单击方式放置圆弧。

（1）执行Place→Arc（Center）命令(快捷键为P，A），光标处显示
最近所绘制的圆弧，进人圆弧绘制模式。

（2）按Tab键弹出Arc对话框，设置圆弧的属性，这里将半径设置为
15，起始角度设置为270，终止角度为90，线条宽度为Small，如图4-
29所示，按OK按钮。

图4-29  在Arc对话框中设置圆弧属性

（可使用鼠标或直接输入数值）



（3）移动光标到（25，-20）位置，按Enter键或单击选
定圆弧的中心点位置，无须移动鼠标，光标会根据Arc对
话框中所设置的半径自动跳到正确的位置，按Enter确认
半径设置。

（4）光标跳到对话框中所设置的圆弧起始位置，不移动
鼠标按Enter键确定圆弧起始角度，此时光标跳到圆弧终
止位置，按Enter键确定圆弧终止角度。

（5）右击鼠标或按ESC键退出圆弧放置模式。

（6）绘制圆弧的另一种方法：执行Place → Arc命令，
鼠标单击圆弧的中心（25，-20），鼠标单击圆弧的半径
（40，-20），鼠标单击圆弧的起始点（25，-35），鼠标
单击圆弧的终点（25，-5），即绘制好圆弧，右击鼠标或
按ESC键退出圆弧放置模式。



4.8.2 添加信号引脚

设计者可使用“创建AT89C51单片机”所介绍的方法为元件

第一部件添加引脚，如图4-30所示，引脚1和引脚2在
Electrical Type上设置为输人引脚(Input)，引脚3设置
为输出引脚(Output)，所有引脚长度均为20mil。

图4-30 元件74LS08的部件A
如图4-30所示，图中引脚方向可由在放置引脚时按Space以900间隔

逐级增加来旋转引脚时决定。



4.8.3 建立元件其余部件
（1）执行Edit → Select → All命令（快捷键为Ctrl＋A）选择目
标元件。

（2）执行Edit→Copy命令（快捷键为Ctrl＋C）将前面所建立的第一
部件复制到剪贴板。

（3）执行Tools→New Part命令显示空白元件页面，此时若在SCH 
Library面板Components列表中单击元件名左侧“＋”标识，将看到SCH 

Library面板元件部件计数被更新，包括Part A和 Part B两个部件，
如图4-31示。

图4-31 部件B被添加到元件 图4-32  74LS08部件B

图4-33  74LS08的部件C和部件D



（4）选择部件Part B,执行Edit→ Paste命令（快
捷键为Ctrl＋V），光标处将显示元件部件轮廓，
以原点（黑色十字准线为原点）为参考点，将其作
为部件B放置在页面的对应位置，如果位置没对应
好可以移动部件调整位置。

（5）对部件B的引脚编号逐个进行修改，双击引脚
在弹出的Pin Properties对话框中修改引脚编号和
名称，修改后的部件B如图4-32所示。

（6）重复步骤（3）-（5）生成余下的两个部件：
部件C和部件D，如图4-33所示，并保存库文件。



4.8.4 添加电源引脚
为元件定义电源引脚有两种方法。第一种是建立元件的第五个部件，
在该部件上添加VCC引脚和GND引脚，这种方法需要选中Component 
Properties对话框的Locked复选框（），以确保在对元件部件进行重
新注释的时候电源部分不会跟其他部件交换。第二种方法是将电源引
脚设置成隐藏引脚，元件被使用时系统自动将其连接到特定网络。在
多部件元件中，隐藏引脚不属于某一特定部件而是属于所有部件（不
管原理图是否放置了某一部件，它们都会存在），只需要将引脚分配
给一种特殊的部件——zero部件，该部件存有其他部件都会用到的公

共引脚。

图4-34 部件A显示出隐藏的电源引脚

（1）为元件添加VCC（Pin14）和GND（Pin7）引脚，将其Part 
Number属性设置为0，Electrical Type设置为Power，Hide状态设置
为hidden，Connect to分别设置为VCC和GND。

（2）从菜单栏中执行View→Show Hidden Pins命令以显示隐藏目标
，则能看到完整的元件部件如图4-34所示，注意检查电源引脚是否在
每一个部件中都有。



4.8.5 设置元件属性
（1）在SCH Library面板Components列表中选中
目标元件后，单击Edit按钮进入 Library 
Component Properties对话框，设置Default 
Designator为“U？”，Description为2输入四与门

，并在Models列表中添加名为DIP14的封装，下
一章使用PCB ComponentWizard建立DIP14封装模
型。

（2）执行File → Save命令保存该元件。

本章在原理图库内创建了3个元件，掌握了原理
图库创建的基本方法，设计者可以根据需要在该
库内创建多个元件。



4.9 检查元件并生成报表

对建立一个新元件是否成功进行检查，会
生成3个报表，生成报表之前需确认已经对
库文件进行了保存，关闭报表文件会自动
返回Schematic Library Editor界面。



4.9.1 元件规则检查器
元件规则检查器会检查出引脚重复定义或者丢失
等错误，步骤如下所示。

（1）执行Reports→ Component Rule Check命
令（快捷键：R，R），显示Library Component 
Rule Check对话框。

（2）设置想要检查的各项属性，单击OK按钮，
将在Text Editor中生成Libraryname．err文件
，里面列出了所有违反了规则的元件。

（3）如果需要，对原理图库进行修改，重复上
述步骤。

（4）保存原理图库。



4.9.2 元件报表

生成包含当前元件可用信息的元件报表的
步骤如下所示。

（1）执行Reports→Component命令（快捷
键：R，C）。

（2）系统显示Libraryname．cmp报表文件
，里面包含了元件各个部分及引脚细节信
息。



4.9.3 库报表

为库里面所有元件生成完整报表的步骤如
下所示。

（1）执行Reports→Library Report命令
（快捷键：R，T）。

（2）在弹出的Library Report Settings
对话框中配置报表各设置选项，报表文件
可用Microsoft Word软件或网页浏览器打
开，并取决于选择的格式。该报告列出了
库内所有元件的信息。
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第5章 元器件封装库的创建

任务描述：
前一章介绍了原理图元器件库的建立，本章进行
封装库的介绍，针对前一章介绍的3个元器件，在
这里为这3个元器件建立封装，并为这3个封装建
立3D模型。包含以下内容：
建立一个新的PCB库
使用PCB Component Wizard为一个原理图元件建
立PCB封装
手动建立封装
一些特殊的封装要求，如添加外形不规则的焊盘
创建元器件三维模型
创建集成库



教学目的及要求：

掌握PCB库的概念

熟练掌握使用PCB Component Wizard创建封装

的方法

熟悉掌握手工创建元件封装的方法

了解添加元器件的三维模型信息的方法

熟练掌握手工放置元件三维模型

教学重点：手工创建元件封装

教学难点： 手工放置元件三维模型



复习并导入新课：
4.1 原理图库、模型和集成库
4.3 创建新的库文件包和原理图库
4.4 创建新的原理图元件
4.5 设置原理图元件属性
4.6 为原理图元件添加模型

4.6.1 模型文件搜索路径设置
4.6.2 为原理图元件添加封装模型
4.6.3 用模型管理器为元件添加封装模型

4.7 从其他库复制元件
4.7.1 在原理图中查找元件
4.7.2 从其他库中复制元件
4.7.3 修改元件

4.8 创建多部件原理图元件
4.8.l 建立元件轮廓
4.8.2 添加信号引脚
4.8.3 建立元件其余部件
4.8.4 添加电源引脚
4.8.5 设置元件属性

4.9 检查元件并生成报表
4.9.1 元件规则检查器
4.9.2 元件报表
4.9.3 库报表



5.1 建立PCB元器件封装
Altium Designer为PCB设计提供了比较齐全的各类直插元
器件和SMD元器件的封装库，这些封装库位于Altium 
Designer安装盘符下 \Program Files\Altium Designer 
Winter 09\Library\Pcb文件夹中。
封装可以从PCB Editor复制到PCB库，从一个PCB库复制到
另一个PCB库，也可以是通过PCB Library Editor的PCB 
Component Wizard或绘图工具画出来的。在一个PCB设计
中，如果所有的封装已经放置好，设计者可以在PCB 
Editor中执行Design → Make  PCB Library命令生成一
个只包含所有当前封装的PCB库。
本章介绍的示例采用手动方式创建PCB封装，只是为了介
绍PCB封装建立的一般过程，这种方式所建立的封装其尺
寸大小也许并不准确，实际应用时需要设计者根据器件制
造商提供的元器件数据手册进行检查。



5.1.l 建立一个新的PCB库
1．建立新的PCB库包括以下步骤。
（1）执行File → New →
Library →PCB Library命令，建
立一个名为PcbLibl.PcbLib的PCB
库文档，同时显示名为
PCBComponent＿l的空白元件页，
并显示PCB Library库面板（如果
PCB Library库面板未出现，单击
设计窗口右下方的PCB按钮，弹出
上拉菜单选择PCB Library即可）
。
（2）重新命名该PCB库文档为PCB 
FootPrints.PcbLib（可以执行
File → Save As命令），新PCB封
装库是库文件包的一部分，如图5-
1所示。

图5-1添加了封装库后的库文件包



（3）单击PCB Library标
签进入PCB Library面板。
（4）单击一次PCB 
Library Editor工作区的
灰色区域并按Page UP键进
行放大直到能够看清网格
，如图5-2所示。
现在就可以使用PCB 
Library Editor提供的命
令在新建的PCB库中添加、
删除或编辑封装了。
PCB Library Editor 用于
创建和修改PCB元器件封装
，管理PCB器件库。PCB 
Library Editor 还提供
Component Wizard，它将
引导你创建标准类的PCB封
装。

图5-2  PCB Library Editor工作区



2．PCB Library编辑器面板

PCB Library Editor的PCB Library面板
（如图5-3所示）提供操作PCB元器件的各
种功能，包括：
PCB Library面板的Components区域列出
了当前选中库的所有元器件。
（1）在Components区域中单击右键将显
示菜单选项，设计者可以新建器件、编辑
器件属性、复制或粘贴选定器件，或更新
开放PCB的器件封装。
请注意右键菜单的copy/paste 命令可用
于选中的多个封装，并支持：
在库内部执行复制和粘贴操作；
从PCB板复制粘贴到库；
在PCB库之间执行复制粘贴操作。

图 5-3  PCB Library 面板

启用Mask

选 择 框 选
中 的 部 分
在 设 计 窗
口显示



（2）Components Primitives区域列出了属于当前选
中元器件的图元。单击列表中的图元，在设计窗口中
加亮显示。
选中图元的加亮显示方式取决于PCB Library面板顶
部的选项：
启用 Mask 后，只有点中的图元正常显示，其他图元
将灰色显示。单击工作空间右下角的 按钮或PCB 
Library面板顶部 按钮将删除过滤器并恢复显
示。
启用 Select 后，设计者单击的图元将被选中，然后
便可以对他们进行编辑。
在 Component Primitives 区右键单击可控制其中列
出的图元类型。
（3）在 Component Primitives 区域下是元器件封
装模型显示区，该区有一个选择框，选择框选择那一
部分，设计窗口就显示那部分，可以调节选择框的大
小。



5.1.2 使用PCB Component 
Wizard创建封装

对于标准的PCB元器件封装，Altium Designer为用户提供
了PCB元器件封装向导，帮助用户完成PCB元器件封装的制
作。PCB Component Wizard使设计者在输入一系列设置后
就可以建立一个器件封装，接下来将演示如何利用向导为
单片机AT89C2051建立DIP20的封装。
使用Component Wizard建立DIP20封装步骤如下所示。
（1）执行Tools→Component Wizard命令，或者直接在
“PCB Library”工作面板的“Component”列表中单击右键，
在弹出的菜单中选择“Component Wizard…”命令，弹出

Component Wizard对话框，单击Next按钮，进入向导。
（2）对所用到的选项进行设置，建立DIP20封装需要如下
设置：在模型样式栏内选择Dual In-line Package（DIP
）选项（封装的模型是双列直插），单位选择
Imperial(mil)选项（英制）如图5-4所示，按Next按钮。



图5-4封装模型与单位选择

图5-5 焊盘大小选择图 5-6  选择焊盘间距



（3）进入焊盘大小选择对话框如图5-5所示，圆
形焊盘选择外径60mil、内径30mil（直接输入数
值修改尺度大小），按Next按钮，进入焊盘间距
选择对话框如图5-6所示，为水平方向设为
300mil、垂直方向100mil，按Next按钮，进入元
器件轮廓线宽的选择对话框，选默认设置（
10mil），按Next按钮，进入焊盘数选择对话框
，设置焊盘（引脚）数目为20，按Next按钮，进
入元器件名选择对话框，默认的元器件名为
DIP20，如果不修改它，按Next按钮。
（4）进入最后一个对话框，单击Finish按钮结
束向导，在PCB  Library面板Components列表中
会显示新建的DIP20封装名，同时设计窗口会显
示新建的封装，如有需要可以对封装进行修改，
如图5-7所示。
（5）执行File → Save命令（快捷键为Ctrl＋S
）保存库文件。

图5-7 使用
PCB 
Component 
Wizard建立
DIP20封装



5.1.3 使用IPC Footprint Wizard创
建封装

PC Footprint Wizard 用于创建IPC器件封装。IPC Footprint 
Wizard 不参考封装尺寸，而是根据IPC发布的算法直接使用器件本身
的尺寸信息。IPC Footprint Wizard使用元器件的真实尺寸作为输入
参数，该向导基于IPC－7351规则使用标准的Altium  Designer对象
（如焊盘、线路）来生成封装。可以从PCB Library Editor菜单栏
Tools菜单中启动IPC Footprint Wizard向导，出现IPC Footprint 
Wizard对话框，按Next按钮，进入下一个IPC Footprint Wizard对话
框如图5-8所示。
输入实际元器件的参数，根据提示，按Next按钮，即可建立元器件的
封装。

图5-8 IPC Footprint Wizard利用元器件尺寸参数建立封装



该向导支持BGA、BQFP、CFP、CHIP、CQFP、DPAK、LCC、MELF
、MOLDED、PLCC、PQFP、QFN、QFN-2ROW、SOIC、SOJ、SOP、
SOT143/343、SOT223、SOT23、SOT89 和 WIRE WOUND 封装。
IPC Footprint Wizard 的功能还包括：
整体封装尺寸、管脚信息、空间、阻焊层和公差在输入后都
能立即看到。
还可输入机械尺寸如Courtyard、Assembly 和 Component 
Body 信息。
向导可以重新进入，以便进行浏览和调整。每个阶段都有封
装预览。
在任何阶段都可以按下 Finish 按钮，生成当前预览封装。



5.1.4 手工创建封装
对于形状特殊的元器件，用PCB Component Wizard不能完
成该器件的封装建立，这个时候就要手工方法创建该器件
的封装。
创建一个元器件封装，需要为该封装添加用于连接元器件
引脚的焊盘和定义元器件轮廓的线段和圆弧。设计者可将
所设计的对象放置在任何一层，但一般的做法是将元器件
外部轮廓放置在Top Overlay层（即丝印层），焊盘放置
在Multilayer层（对于直插元器件）或顶层信号层（对于
贴片元器件）。当设计者放置一个封装时，该封装包含的
各对象会被放到其本身所定义的层中。
虽然数码管的封装可以用PCB Component Wizard来完成，
为了掌握手动创建封装的方法，用他来作为示例。



一、下面手动创建数码管Dpy Blue-CA的封装步骤如下

1. 先检查当前使用的单位和网格显示是否合适，执行Tools →
Library  Options命令（快捷键为T，O）打开Board Options对话框
，设置Units为 Imperial(英制)，X，Y方向的Snap Grid为10mil，需
要设置Grid以匹配封装焊盘之间的间距，设置Visible Grid 1为
10mil，Visible Grid 2为100mil，如图5-9所示。

图5-9  在Board Options对话框中设置单位和网格



2. 执行Tools →New Blank Component命令
（快捷键为T，W），建立了一个默认名为
‘PCBCOMPONENT_l’的新的空白元件，如图5-2

所示。在PCB Library面板双击该空的封装
名（PCBCOMPONENT_l），弹出PCB Library 
Component[mil]对话框，为该元件重新命名
，在PCB Library Component对话框中的
Name处，输入新名称LED-10。
推荐在工作区（0，0）参考点位置（有原点
定义）附近创建封装，在设计的任何阶段，
使用快捷键J，R就可使光标跳到原点位置。



3.为新封装添加焊盘
Pad  Properties对话框为设计者在所定
义的层中检查焊盘形状提供了预览功能，
设计者可以将焊盘设置为标准圆形、椭圆
形、方形等，还可以决定焊盘是否需要镀
金，同时其他一些基于散热、间隙计算，
Gerber输出，NC Drill等设置可以由系统
自动添加。无论是否采用了某种孔型，NC 
Drill Output（NC Drill Excellon  
format 2）将为 3种不同孔型输出6种不
同的NC钻孔文件。
放置焊盘是创建元器件封装中最重要的一
步，焊盘放置是否正确，关系到元器件是
否能够被正确焊接到PCB板，因此焊盘位
置需要严格对应于器件引脚的位置。放置
焊盘的步骤如下所示：
（1）执行Place → Pad命令（快捷键为
P,P）或单击工具栏按钮，光标处将出现
焊盘，放置焊盘之前，先按Tab键，弹出
Pad[mil]对话框，如图5-10所示。

图5-10 放置焊盘之前设置焊盘参数



(2)在图5-10所示对话框中编辑焊盘各项属性。在Hole 
Information选择框，设置Hole Size(焊盘孔径)：30mil，
孔的形状：Round(圆形)；在Properties选择框，在
Designator处，输入焊盘的序号1，在Layer处，选择Multi-
Layer(多层)；在Size and Shape(大小和形状)选择框，X-
Size：60mil，Y-Size：60mil，Shape：Rectangular(方形)
，其它选缺省值，按OK按钮，建立第一个方形焊盘。
（3）利用状态栏显示坐标，将第一个焊盘拖到（X：0，Y：
0）位置，单击或者按Enter确认放置。
（4）放置完第一个焊盘后，光标处自动出现第二个焊盘，
按Tab键，弹出Pad[mil]对话框，将焊盘Shape(形状)改为：
Round（圆形），其他用上一步的缺省值，将第二个焊盘放
到（X：100，Y：0）位置。注意：焊盘标识会自动增加。
（5）在（X：200，Y：0）处放置第三个焊盘（该焊盘用上
一步的缺省值），X方向每隔100mil，Y方向不变，依次放好
第4、5焊盘。
（6）然后在（X：400，Y：600）处放置第6个焊盘（Y的距
离由实际数码管的尺寸而定），X方向每次减少100mil，Y方
向不变，依次放好7-10焊盘。
（7）右击或者按Esc键退出放置模式，所放置焊盘如图5-11
所示。

图5-11  放置好

焊盘的数码管



4.为新封装绘制轮廓

PCB丝印层的元器件外形轮廓在Top Overlay（顶层）中定义，如果元
器件放置在电路板底面，则该丝印层自动转为Bottom Overlay（底层
）。
（1）在绘制元器件轮廓之前，先确定它们所属的层，单击编辑窗口
底部的Top Overlay标签。
（2）执行Place → Line命令（快捷键为P,L）或单击按钮，放置线
段前可按Tab键编辑线段属性，这里选默认值。光标移到（-60，-60
）mil处按鼠标左键，绘出线段的起始点，移动光标到（460，-60）
处按鼠标左键绘出第一段线，移动光标到（460，660）处按鼠标左键
绘出第二段线，移动光标到（-60，660）处按鼠标左键绘出第三段线
，然后移动光标到起始点（-60，-60）处按鼠标左键绘出第四段线，
数码管的外框绘制完成，如图5-12所示。
(3）接下来绘制数码管的‘8’字，执行Place → Line命令（快捷键为

P,L），光标左击以下坐标（100，100），（300，100），（300，
500），（100，500），（100，100）绘制‘0’字，按鼠标右键，鼠标
再左击（100，300），（300，300）这2个坐标，绘制出‘8’字，右击

或按ESC键退出线段放置模式。建好的数码管封装符号如图5-12所示
。



注意：①画线时，按Shift＋Space快捷键可以切换线段转角（转弯处
）形状。
②画线时如果出错，可以按Backspace删除最后一次所画线段。
③按Q键可以将坐标显示单位从mil改为mm。
④在手工创建元器件封装时，一定要与元器件实物相吻合。否则PCB
板做好后，元件安装不上。

图5-12  建好的数码管封装



5.2 添加元器件的三维模型信息

鉴于现在所使用的元器件的密度和复杂度
，现在的PCB设计入员必须考虑元器件水
平间隙之外的其他设计需求，必须考虑元
器件高度的限制、多个元器件空间叠放情
况。此外将最终的PCB转换为一种机械CAD
工具，以便用虚拟的产品装配技术全面验
证元器件封装是否合格，这已逐渐成为一
种趋势。Altium Designer拥有许多功能
，其中的三维模型可视化功能就是为这些
不同的需求而研发的。



5.2.1 为PCB封装添加高度属性
设计者可以用一种最简单的方式为封装添加高度属性，双
击PCB Library面板Component列表中的封装(如图5-19所
示)，例如双击DIP20，打开PCB Library Components对话
框(如图5-20所示)，在Height文本框中输入适当的高度数
值。

图5-19 双击PCB Library面板的DIP20 图5-20为DIP20封装输入高度值

可在电路板设计时定义设计规则，在PCB Editor中执行Design →
Rules命令，弹出 “PCB Rules and Constraints Editor”对话框，在
Placement选项卡的“Component Clearance”处对某一类元器件的高

度或空间参数进行设置。



5.2.2 为PCB封装添加三维模型

为封装添加三维模型对象可使元器件在PCB Library Editor的三维视
图模式下显得更为真实（对应PCB Library Editor中的快捷键：2—
—二维，3——三维），设计者只能在有效的机械层中为封装添加三

维模型。在3D应用中，一个简单条形三维模型是由一个包含表面颜色
和高度属性的2D多边形对象扩展而来的。三维模型可以是球体或圆柱
体。
多个三维模型组合起来可以定义元器件任意方向的物理尺寸和形状，
这些尺寸和形状应用于限定Component Clearance设计规则。使用高
精度的三维模型可以提高元器件间隙检查的精度，有助于提升最终
PCB产品的视觉效果，有利于产品装配。
Altium Designer还支持直接导入3D STEP模型（*.step或*.stp文件
）到PCB封装中生成3D模型，该功能十分有利于在Altium Designer 
PCB文档中嵌入或引用STEP模型，但在PCB Library Editor中不能引
用STEP模型。



注意：三维模型在元器件被翻转后必须翻转到板
子的另一面。如果设计者想将三维模型数据（存
放在一个机械层中）也翻转到另一个机械层中，
需要在PCB文档中定义一个层对。
层对就是将两个机械层定义为一对，当设计者将
元器件从电路板的一面翻转到另一面时，层对中
位于其中一个机械层的所有与该元器件相关的对
象会自动翻转到与之配对的另一个机械层中。
注意：不能在PCB Library Editor中定义层对，
只能在PCB Editor中定义，按鼠标右键弹出菜单
，选Options又弹出下一级菜单，选“Mechanical 
Layers…”，弹出View Configurations对话框，
在对话框的左下角，单击Layer Pairs…按钮，

弹出Mechanical Layer Pairs对话框如图5-21所
示，即可内定义层对。

图5-21  在PCB Editor中
定义层对



5.2.3手工放置三维模型

在PCB Library Editor执行中Place→3D 
Body命令可以手工放置三维模型，也可以在
3D Body Manager对话框（执行Tools →
Manage 3D Bodies for Library/Current 
Component命令）中设置成自动为封装添加
三维模型。
注意：既可以用2D模型方式放置三维模型，
也可以用3D模型方式放置三维模型。



1.下面将演示如何为前面所创建的DIP20封装添加三维
模型，在PCB Library Editor中手工添加三维模型的步骤

如下：

（1）在PCB Library面板双击DIP20打开PCB 
Library Component对话框（图5-20），该
对话框详细列出了元器件名称、高度、描述
信息。这里元器件的高度设置最重要，因为
需要三维模型能够体现元器件的真实高度。
注意：如果器件制造商能够提供元器件尺寸
信息，则尽量使用器件制造商提供的信息。
（2）执行Place →3D Body命令，显示3D 
Body对话框（如图5-22所示），在3D Model 
Type选项区域选中Extruded单选按钮。
（3）设置Properties选项区域各选项，为
三维模型对象定义一个名称（Identifer）
以标识该三维模型，设置Body Side下拉列
表为Top Side，该选项将决定三维模型垂直
投影到电路板的哪一个面。

图5-22在3D Body对话框中定义三维模型参数



注意：设计者可以为那些穿透电路板的部分如引脚设置负的支架高度值，
Design Rules Checker不会检查支架高度。

（4）设置Overall Height为180mil (三维模型顶面到电路板的距离) 
，Standoff  Height(三维模型底面到电路板的距离)为0mil，3D Color
为适当的颜色。
（5）单击OK按钮关闭3D Body对话框，进入放置模式，在2D模式下，光
标变为十字准线，在3D模式下，光标为蓝色锥形。
（6）移动光标到适当位置，单击选定三维模型的起始点，接下来连续
单击选定若干个顶点，组成一个代表三维模型形状的多边形。
（7）选定好最后一个点，右击或按ESC键退出放置模式，系统会自动连
接起始点和最后一个点，形成闭环多边形如图5-23所示。
定义形状时，按Shift+Space快捷键可以轮流切换线路转角模式，可用
的模式有：任意角、450、450圆弧、900和900圆弧。按Shift+句号按键和
Shift+逗号按键可以增大或减少圆弧半径，按Space可以选定转角方向
。
当设计者选定一个扩展三维模型时，在该三维模型的每一个顶点会显示
成可编辑点，当光标变为 时，可单击并拖动光标到顶点位置。当光
标在某个边沿的中点位置时，可通过单击并拖动的方式为该边沿添加一
个顶点，并按需要进行位置调整。
将光标移动到目标边沿，光标变为 时，可以单击拖动该边沿。
将光标移动到目标三维模，光标变为 时，可以单击拖动该三维模型
。拖动三维模型时，可以旋转或翻动三维模型，编辑三维模型形状。

图5-23 带
三维模型
的DIP20
封装



2.下面为DIP20的管脚创建三维模

型。
仿照上面的步骤（2）——（3）

（4）设置Overall Height为100mil，Standoff 
Height(三维模型底面到电路板的距离)为-35mil，3D 
Color为很淡的黄色。
（5）单击OK按钮关闭3D Body对话框，进入放置模式，在
2D模式下，光标变为十字准线。按Page Up键，将第一个
引脚放大到足够大，在第一个引脚的孔内放一个小的封闭
的正方形。
（6）选中小的正方形，按Ctrl+C键将它复制到粘贴板，
然后按Ctrl+V键，将它粘贴到其它引脚的孔内。



3.用上面的方法为DIP20封装创建引脚标识1的小圆。

增加了三维模型的DIP20封装如图5-23所示。
注意：放置模型时，可按BackSpace键删除最后放置的一个顶点
，重复使用该键可以“还原”轮廓所对应的多边形，回到起点。

形状必须遵循Component Clearance设计规则，但在3D显示时并
不足够精确，设计者可为元器件更详细的信息建立三维模型。
完成三维模型设计后，会显示3D Body对话框中，设计者可以继
续创建新的三维模型，也可以单击Cancel按钮或按Esc键关闭对
话框。图5-24显示了在Altium Designer中建立的一个DIP20三
维模型。

图5-24 DIP20三维模型实例



设计者可以随时按3键进入3D显示模式（也可以在工具栏如图
5-25处选择Altium 3D *，‘*’代表各种颜色）以查看三维模型

。如果不能看到三维模型，可以按L键打开View 
Configurations对话框，找到3D Bodies，在Show Slimple 
3D Bodies处，选择Use System Setting如图5-26所示，即可
显示三维模型。按2键可以切换到2D模式（也可以在工具栏如
图5-25处选择Altium Stanfard 2D以查看二维模型）。
最后要记得保存PCB库。

图5-25 二维、三维模型显示的选择 图5-26不能显示三维模型，选择Use Syatem 
Setting即可
DIP20的三维模型如图5-24所示，包括22个三维模型对象：轮廓主体、20个引脚和
一个标识引脚1的圆点。
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复习：

5.1 建立PCB元器件封装

5.1.l 建立一个新的PCB库
5.1.2 使用PCB Component Wizard创建封装·
5.1.3 手工创建封装

5.2 添加元器件的三维模型信息

5.2.1 手工放置三维模型



教学目的及要求：

1.了解从其他来源添加封装的方法

2.熟练掌握用交互式创建三维模型

3.了解从其他方式形成三维模型

4.了解3D PCB模型库

5.熟练掌握创建集成库的方法

6.熟练掌握集成库的维护

教学重点：交互式创建三维模型、创建集成库

教学难点：从其他方式形成三维模型、3D PCB模型库



5.2.4 从其他来源添加封装
为了介绍交互式创建三维模型的方法，需要一个三极管TO-39的封装。该封装在
Miscellaneous Devices.Pcblib库内。设计者可以将已有的封装复制到自己建的PCB
库，并对封装进行重命名和修改以满足特定的需求，复制已有封装到PCB库可以

参考以下方法。如果该元器件在集成库中，则需要先打开集成库文件。方法已在
‘4.8.2 从其他库中复制元器件’一节中介绍。

（1）在Projects面板打开该源库文件（Miscellaneous Devices.Pcblib），鼠标双击该

文件名。

（2）在PCB Library面板中查找TO-39封装，找到后，在Components的Name列表中选
择想复制的元器件TO-39，该器件将显示在设计窗口中。

（3）按鼠标右键，从弹出的下拉菜内单选择Copy命令如图5-27所示。

图5-27 选择想复制的封装元件TO-39          图5-28 粘贴想复制的封装元件到目标库



（4）选择目标库的库文档（如PCB FootPrints.PcbLib文档），
再单击PCB Library面板，在Compoents区域，按鼠标右键，弹
出下拉菜单（如图5-28）选择Paste 1 Compoents，器件将被复

制到目标库文档中（器件可从当前库中复制到任一个已打开
的库中）。如有必要，可以对器件进行修改。

（5）在PCB Library面板中按住Shift键+单击或按住Ctrl键+单击
选中一个或多个封装，然后右击选择Copy选项，切换到目标
库，在封装列表栏中右击选择Paste选项，即可一次复制多个

元器件。

下面介绍用交互式方式创建TO-39的三维模型



5.2.5 交互式创建三维模型

使用交互式方式创建封装三维模型对象的方法与手动方式类
似，最大的区别是该方法中，Altium Designer会检测那些闭环

形状，这些闭环形状包含了封装细节信息，可被扩展成三维
模型，该方法通过设置3D Body Manager对话框实现。

注意：只有闭环多边形才能够创建三维模型对象。

接下来将介绍如何使用3D Body Manager对话框为三极管封装
TO-39创建三维模型，该方法比手工定义形状更简单。

使用3D Body Manager对话框方法如下：

（1）在封装库中激活TO-39封装。

（2）单击Tools→Manage 3D Bodies for Current Component命令，
显示3D Body Manager对话框如图5-29所示。



（3）依据器件外形在三维模型中定义对应的形状，需要用
到列表中的第二个选项Polygonal shape created from primitives on 
TopOverlay，在对话框中该选项所在行位置单击Action列的Add 
to按钮，将Registration Layer设置为三维模型对象所在的机械
层（本例中为Mechanicall），设置 Overall Height为合适的值，
如180mil，设置Body 3D Color为合适的颜色，如图5-29所示。

图5-29 通过 3D Bodg Manager对话框在现有基元的基础上快速建立三维模型



（4）单击Close按钮，会在元器件上面显示三维模型形状，如图5-30所示，
保存库文件。

图5-30 添加了三维模型后的TO-39 2D封装 图5-31 TO-39 3D模型

图5-31给出了TO-39封装的一个完整的三维模型图，该模型包含5个三维模型对象。
（1）一个基础性的三维模型对象，根据封装轮廓建立（overall height 50mil，
standoff height 0mil，Body 3D color gray）。
（2）一个代表三维模型的外围，通过放置一个圆，再以圆为蓝本生成闭环多边形，
设计者可在3D Body Manager对话框检测该闭环多边形。闭环多边形参数设置为：
overall height 180mil，standoff height 0mil，color gray。
（3）其他3个对象对应于3个引脚，通过放置圆柱体的方法实现。执行Place→3D 
Body命令，弹出3D Body对话框如图5-32所示，在3D ModelType栏选择单选按钮
Cylinder（圆柱体），选择圆参数Radius(半径):15mil，Height:450mil，standoff  
height:-450mil，co1or gold，设置好后，按ok按钮，光标处出现一个小方框，把它放
在焊盘处，按鼠标左键即可，按鼠标右键或Esc键退出放置状态。
（4）设计者可以先只为其中一个引脚创建三维模型对象，再复制、粘贴两次分别建

立剩余两个引脚的三维模型对象。



图5-32在3D Body对话框中定义三维模型参数



设计者在掌握了以上三维模型的创建方法后，就可以建立数
码管LED-10的三维模型，建好的三维模型如图5-33所示。

图5-33 数码管LED-10的三维模型

管脚：

Place→ 3D Body   选Cylinder     半径：15mil  

Height:200mil 

Standoff Height:-200mil 

“8”字：

Place→ 3D Body   选Extruded 

Standoff Height:0mil    Overall Height:180mil

主体：

Tools →Manager 3D …

Standoff Height:0mil    Overall Height:180mil
小数点：
Place→ 3D Body   选Cylinder     半径：15mil  
Height:180mil      Standoff Height:0mil 



5.2.6其它方式形成三维模型
1.导入STEP Model形成三维模型

为了方便设计者使用元器件，许多元器
件供应商以发布通用机械CAD文件包的方
式提供了详细的器件3D模型，Altium
Designer允许设计者直接将这些3D STEP模
型（*.step或*.stp文件）导入到元器件封装

中，避免了设计者自己设计三维模型所
造成的时间开销，同时也保证了三维模
型的准确可靠性。

2. 导入STEP Model
导入STEP Model步骤如下：

（1）执行Place→3D Body命令（快捷键为
P,B）进入3D Body对话框如图5-32所示。

（2）在3D Model Type区选择Generic STEP 
Model选项。

（3）单击Embed STEP Model按钮，显示
Choose Model对话框，可在其中查找*.step
和*.stp文件（如图5-34所示）。

“multivibrator_base.STEP”文件
在“D:\Program Files\Altium
Designer Winter 
09\Examples\Tutorials\multivibr
ator_step”文件夹找到。

图5-34 打开*.Step文件



（4）找到并选中所需STEP文件，单击打开按钮关闭Choose Model对话框。

（5）返回3D Body对话框，单击OK按钮关闭对话框，光标处浮现三维模

型。

（6）单击工作区放置三维模型，此时该三维模型已加载了所选的模型如
图5-35所示。

4.移动和定位STEP模型

导入STEP模型时，模型内各三维模型对象会依大小重新排列，由于原点
的不一致，会导致STEP模型不能正确定位到PCB文档的轴线。系统通过

在模型上放置参考点（也称捕获点），为设计者提供了几种图形化配置
STEP模型的方法，非图形化配置方法可以通过设置3DBody对话框的
Generic STEP Model选项来实现。

图5-35 加载的STEP Model



5.2.7 检查元器件封装

Schematic Library Editor提供了一系列输出报表供设计者检查所创建的元器
件封装是否正确以及当前PCB库中有哪些可用的封装。设计者可以通过
Component Rule Check输出报表以检查当前PCB库中所有元器件的封装，
Component Rule Checker可以检验是否存在重叠部分、焊盘标识符是否丢失、

是否存在浮铜、元器件参数是否恰当。

（1）使用这些报表之前，先保存库文件。

（2）执行Reports→ Component Rule Check命令（快捷键为 R,R）打开
Component Rule Check对话框，如图5-36所示。

（3）检查所有项是否可用，单击OK按钮生成PCB FootPrints.err文件并自动
在Text Editor打开，系统会自动标识出所有错误项。

（4）关闭报表文件返回PCB Library Editor。

图5-36 在封装应用于设计之

前对封装进行查错



5.3 简介3D PCB模型库

5.2节介绍的内容仅仅是为元器件封装添加三维模型信息，而不是3D PCB
模型库。真正的3D PCB模型库从第4章的习题第4、5题可以看出，它代表
了元器件的真实外形，一般是用结构软件（如AutoCAD）设计好的，然后
导入到Altium Designer软件中。下面简介3D PCB模型库的建立。

1.创建一个3D PCB模型库。可以执行File→New→Library→PCB3D Library命
令，就在当前项目中添加了一个PCB3D Library Files（三维的库文件），默
认的文件名为：PCB3DViewLib1.PCB3DLib。
2.先要用结构软件（如AutoCAD）设计好元器件的3D模型，然后以stp的格
式导出文件。启动Altium Designer软件,执行Tools→Import 3D Model命令把建
好的3D模型导入到建好的3D库中并进行保存，如图5-37所示。

图5-37 导入3D模型



5.4 创建集成库
1.建立集成库文件包——集成库的原始项目文件。

2.为库文件包添加原理图库和在原理图库中建立原理图元器件。

3.为元器件指定可用于板级设计和电路仿真的多种模型（本教材只介绍

封装模型）。

为第4章新建的电路图库文件内的器件：单片机AT89C2051、与非门
74LS08、数码管Dpy Blue-CA三个器件重新指定设计者在本章新建的封装
库PCB FootPrints.PcbLib内的封装。

图5-38  Library Component Properties对话框



为AT89C2051单片机更新封装的步骤如下：

在SCH Library面板的Components列表中选择AT89C2051元器
件，单击Edit按钮或双击元件名，打开Library Component 
Properties对话框，如图5-38所示。

在Models for AT89C2051栏删除原来添加的DIP20封装，选中该
DIP20按Remove按钮。然后添加设计者新建的DIP20封装，按
Add按钮，弹出‘Add New Model’对话框，选FootPrint，按OK按
钮，弹出‘PCB Model’对话框，按Browse按钮，弹出‘Browse 
Libraries’对话框，查找新建的PCB库文件（PCB 
FootPints.PcbLib），选择DIP20封装，按OK按钮即可。

用同样的方法为与非门74LS08添加新建的封装DIP14。
用同样的方法为数码管Dpy Blue-CA添加新建的封装LED-10。



4.检查库文件包New Integrated_ Library1.LibPkg是否包
含原理图库文件和PCB图库文件如图5-39所示。

在本章的最后，将编译整个库文件包以建立一个集成库，该
集成库是一个包含了第4章建立的原理图库（New 
Schlib1.SchLib）及本章建立的PCB封装库（PCB FootPints.PcbLib）
的文件。即便设计者可能不需要使用集成库而是使用源库文
件和各类模型文件，也很有必要了解如何去编译集成库文
件，这一步工作将对元器件和跟元器件有关的各类模型进行
全面的检查。

图5-39 库文件包包含的文件



5.编译库文件包步骤如下：

（1）执行Project → Compile Integrated Library命令将库文件包中的

源库文件和模型文件编译成一个集成库文件。系统将在
Messages面板显示编译过程中的所有错误信息（执行View →
Workspace Panels → System → Messages命令），在Messages面板

双击错误信息可以查看更详细的描述，直接跳转到对应的元器
件，设计者可在修正错误后进行重新编译。

（2）系统会生成名为‘New Integrated_Library1.IntLib’的集成库文件
（该文件名：‘New Integrated_Library1’是在4.3节创建新的库文件
包时建立），并将其保存于Project Outputs for New 
Integrated_Library1文件夹下，同时新生成的集成库会自动添加到

当前安装库列表中，以供使用。

需要注意的是，设计者也可以通过执行Design → Make Integrated 
Library命令从一个已完成的项目中生成集成库文件，使用该方

法时系统会先生成源库文件，再生成集成库。

现在已经学会了建立电路原理图库文件，PCB库文件和集成库

文件。



5.5集成库的维护

用户自己建立集成库后，可以给设计工作带来极大的方便。
但是，随着新元器件的不断出现和设计工作范围的不断扩
大，用户的元器件库也需要不断地进行更新和维护以满足设
计的需要。



5.5.1 将集成零件库文件拆包

系统通过编译打包处理，将所有的关于某个特定元器件的所
有信息封装在一起，存储在一个文件扩展名为“.IntLib”独立文

件中构成集成元件库。对于该种类型的元件库，用户无法直
接对库中内容进行编辑修改。对于是用户自己建立的集成库
文件，如果在创建时保留了完整的集成库库文件包，就可以
通过再次打开库文件包的方式，对库中的内容进行编辑修改。
修改完成后只要重新编译库文件包，就可以重新生成集成库
文件。如果用户只有集成库文件,这时，如果要对集成库中的

内容进行修改，则需要先将集成库文件拆包，方法：打开一
个集成库文件，弹出“Extract Sources or Install”对话框,按Extract 
Sources按钮，从集成库中提取出库的源文件，在库的源文件

中可以对元件进行编辑、修改、编译，才能最终生成新的集
成库文件。



5.5.2 集成库维护的注意事项

集成库的维护是一项长期的工作。随着用户开始使用Altium
Designer进行自己的设计，就应该随时注意收集整理，形成自

己的集成元件库。在建立并维护自己的集成库的过程中，用
户应注意以下问题：



1．对集成库中的元器件进行验证

为保证元器件在印制电路板上的正确安装，用户应随时对集成零件库中
的元器件封装模型进行验证。验证时，应注意以下几个方面的问题：元
器件的外形尺寸，元器件焊盘的具体位置，每个焊盘的尺寸，包括焊盘
的内径与外径。穿孔式焊盘应尤其需要注意内径，太大有可能导致焊接
问题，太小则可能导致元器件根本无法插入进行安装。在决定具体选用
焊盘的内径尺寸时，还应考虑尽量减少孔径尺寸种类的数量。因为在印
制电路板的加工制作时，对于每一种尺寸的钻孔，都需要选用一种不同
尺寸的钻头，减少孔径种类，也就减少了更换钻头的次数，相应的也就
减少了加工的复杂程度。贴片式焊盘则应注意为元器件的焊接留有足够
的余量，以免造成虚焊盘或焊接不牢。另外，还应仔细检查封装模型中
焊盘的序号与原理图元器件符号中管脚的对应关系。如果对应关系出现
问题，无论是在对原理图进行编译检查，还是在对印制电路板文件进行
设计规则检查，都不可能发现此类错误，只能是在制作成型后的硬件调
试时才有可能发现，这时想要修改错误，通常只能重新另做板，给产品
的生产带来浪费。



2．不要轻易对系统安装的元器件库进行改动
Altium Designer系统在安装时，会将自身提供的一系列集成库
安装到系统的Library文件夹下。对于这个文件夹中库文件，

建议用户轻易不要对其进行改动，以免破坏系统的完整性。
另外，为方便用户的使用，Altium Designer的开发商会不定时

地对系统发布服务更新包。当这些更新包被安装到系统中
时，有可能会用新的库文件将系统中原有的库覆盖。如果用
户修改了原有的库文件，则系统更新时会将用户的修改结果
覆盖，如果系统更新时不覆盖用户修改结果，则无法反映系
统对库其他部分的更新。因此，正确的做法是将需要改动的
部分复制到用户自己的集成库中，再进行修改，以后使用时

从用户自己的集成库中调用。

熟悉并掌握Altium Designer的集成库，不仅可以大量减少设计

时的重复操作，而且减少了出错的机率。对一个专业电子设
计人员而言，对系统提供的集成库进行有效的维护和管理，
以及具有一套属于自己的经过验证的集成库，将会极大地提
高设计效率。



小结：
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第6章 原理图绘制的环境参数及设

置方法
任务描述

在掌握了前几章的内容后，要绘制一个简单的原理图、设计
印制电路板应该没有问题，但为了设计复杂的电路图，提高
设计者的工作效率，把该软件的功能充分发掘出来，需要进
行后续章节的学习。本章主要介绍原理图编辑环境下的相关
参数设置，它将涵盖以下主题：

原理图编辑的操作界面设置

原理图图纸设置



教学目的及要求：

1. 熟练掌握原理图编辑的操作界面设置

2. 熟练掌握原理图图纸设置

3. 熟练掌握栅格（Grids）设置

教学重点：原理图图纸设置

教学难点： 栅格（Grids）设置

复习：
5.2 添加元器件的三维模型信息

5.2.4 从其他来源添加封装
5.2.5 交互式创建三维模型
5.2.6 其他方式形成三维模型
5.2.7 检查元器件封装

5.3 简介3D PCB模型库
5.4 创建集成库
5.5 集成库的维护

5.5.1 将集成零件库文件拆包
5.5.2 集成库维护的注意事项



6.1原理图编辑的操作界面设置

启动Altium Designer后
，系统并不会进入原理
图编辑的操作界面，只
有当用户新建或打开一
个PCB项目中的原理图文
件后，系统才会进入原
理图编辑的操作界面（
如图6-1所示）。本章介
绍的所有操作，都是在
原理图编辑的操作界面
内完成。所以用户一定
要用前面介绍的方法，
打开原理图编辑器。 图6-1 原理图编辑操作界面



原理图绘制的环境，就是原理图编辑器以及它提供的设计界面。若要更
好地利用强大的电子线路辅助设计软件Altium Designer进行电路原理图
设计，首先要根据设计的需要对软件的设计环境进行正确的配置。
Altium Designer的原理图编辑的操作界面，顶部为主菜单和主工具栏，
左部为工作区面板，右边大部分区域为编辑区，底部为状态栏及命令栏
，还有电路绘图工具栏、常用工具栏等。除主菜单外，上述各部件均可
根据需要打开或关闭。工作区面板与编辑区之间的界线可根据需要左右
拖动。几个常用工具栏除可将它们分别置于屏幕的上下左右任意一个边
上外，还可以以活动窗口的形式出现。下面分别介绍各个环境组件的打
开和关闭。

Altium Designer的原理图编辑的操作界面中多项环境组件的切换可通过
选择主菜单“View”中相应项目实现如图6-2所示。“Toolbars”为常用工具
栏切换命令；“Workspace Panels”为工作区面板切换命令；“Desktop 
Layouts”为桌面布局切换命令；“Command Status”为命令栏切换命令。菜

单上的环境组件切换具有开关特性，例如，如果屏幕上有状态栏，当单
击一次“status Bar”时，状态栏从屏幕上消失，当再单击一次“Status 
Bar”时，状态栏又会显示在屏幕上。



1．状态栏的切换

要打开或关闭状态栏，可以执行菜单命令
“View → Status Bar”。状态栏中包括光

标当前的坐标位置、当前的Grid值。

2．命令栏的切换

要打开或关闭命令栏，可以执行菜单命令
“View →Command  Status”。命令栏用来

显示当前操作下的可用命令。

3．工具栏的切换

Altium Designer的工具栏中常用的有主
工具栏（Schematic Standard）、连线工
具栏（Wiring）、常用工具栏（
Utilities）等。这些工具栏的打开与关
闭可通过菜单“Wiew → toolbars”中子菜

单的相关命令的执行来实现。工具栏菜单
及子菜单如图6-2所示。 图6-2  工具栏的切换



6.2 图纸设置
6.2.1 图纸尺寸

在电路原理图绘制过程中，对图纸的设置是原理图设计的第一步。虽然
在进入原理图设计环境时，Altium Designer系统会自动给出默认的图
纸相关参数。但是对于大多数电路图的设计，这些默认的参数不一定适
合设计者的要求。

图6-3 用Sheet Options选项卡进行原理图

图纸的设置

尤其是图纸幅面的大小， 一般

都要根据设计对象的复杂程度
和需要对图纸的大小重新定义
。在图纸设置的参数中除了要
对图幅进行设置外，还包括图
纸选项、图纸格式以及栅格的
设置等。
设置图纸尺寸时可执行
“Design→Document Options”
菜单命令，执行后，系统将弹
出“Document Options”对话框
，选择其中的“Sheet Options”
标签进行设置，如图6-3所示。



在Standard Style栏的
Standard Styles处，按右
边的‘ ’符号，可选择各种

规格的图纸。Altium 
Designer系统提供了18种规
格的标准图纸，各种规格的
图纸尺寸如表6.1 所示。

在Altium Designer给出的
标准图纸格式中主要有公制
图纸格式(A4~A0)、英制图
纸格式(A~E)、OrCAD格式
(OrCADA~ OrCADE)以及其他
格式(Letter、Legal)等。
选择后，通过单击图6-3示
的对话框右下角的按钮就更
新当前的图纸的尺寸。

表6.1                         各种规格的图纸尺寸

代号 尺寸（英寸） 代号 尺寸（英寸）

A4 11.5×7.6 E 42×32

A3 15.5×11.1 Letter 11×8.5

A2 22.3×15.7 Legal 14×8.5

A1 31.5×22.3 Tabloid 17×11

A0 44.6×31.5 OrCADA 9.9×7.9

A 9.5×7.5 OrCADB 15.4×9.9

B 15×9.5 OrCADC 20.6×15.6

C 20×15 OrCADD 32.6×20.6

D 32×20 OrCADE 42.8×32.8



2．自定义图纸
如果需要自定义图纸尺寸，必须设置图6-3所示“Custom 
Style”栏中的各个选项。首先，应选中“Use Custom Style”
复选框，以激活自定义图纸功能。

“Custom Style”栏中其他各项设置的含义如下：

（1）Custom Width：设置图纸的宽度。

（2）Custom Heigh：设置图纸的高度。

（3）X  Region  Count：设置x轴框参考坐标的刻度数。如
图6-3中设置为6，就是将x轴6等分。

（4）Y Region  Count：设置y轴框参考坐标的刻度数。如
图6-3中设置为4，就是将y轴4等分。

（5）Margin  Wdth：设置图纸边框宽度。如图6-3中设置为
200，就是将图纸的边框宽度设置为200mil。



6.2.2 图纸方向
1．设置图纸方向

在图6-3中，使用“Orientaion”（方位）下拉列表框可以选择
图纸的布置方向。按右边的‘ ’符号可以选择为横向（

Landscape）或纵向（Portrait）格式。

2．设置图纸标题栏

图纸标题栏是对图纸的附加说明。在Altium Designer提供
了两种预先定义好的标题栏，分别是标准格式（Standard）
和美国国家标准协会支持的格式（ANSI），如图6-4和6-5所
示。设置应首先选中“Title Block”（标题块）左边的复选框
，然后按右边的‘ ’符号即可以选择。若未选中该复选框，

则不显示标题栏。

图6-4 标准格式（Standard）标题栏 图6-5美国国家标准模式（ANSI）标题栏



Show Reference Zones”复选项用来设置图纸上索引区的显

示。选中该复选项后，图纸上将显示索引区。所谓索引区是
指为方便描述一个对象在原理图文档中所处的位置，在图纸
的四个边上分配索引栅格，用不同的字母或数字来表示这些
栅格，用字母和数字的组合来代表由对应的垂直和水平栅格
所确定的图纸中的区域。

“Show Border”复选项用来设置图纸边框线的显示。选中该复

选项后，图纸中将显示边框线。若未选中该项，将不会显示
边框线，同时索引栅格也将无法显示。

“Show Template Graphics”复选项用来设置模板图形的显示

。选中该复选项后，将显示模板图形；若未选中，则不会显
示模板图形。

3．“Template”区域

“Template”区域用于设定文档模板，在该区域的“File Name”
编辑框内输入模板文件的路径即可。



6.2.3 图纸颜色

图纸颜色设置，包括图纸边框（Border）和图纸底色（Sheet）的设置。

在图6-3中，“Border Color”选择项用来设置边框的颜色，默认值为黑色
。单击右边的颜色框，系统将弹出“Choose Color”对话框，如图6-6所示

，我们可通过它来选取新的边框颜色。

“Sheet Color”栏负责设置图纸的底色，默认的设置为浅黄色。要改变底
色时，双击右边的颜色框，打开“Choose Color”对话框如图6-6所示，然

后选取出新的图纸底色。

“Choose Color”对话框的“Basic”标签中列出了当前可用的239种颜色，并

定位于当前所使用的颜色。如果用户希望改变当前使用的颜色，可直接
在“Basic Colors”栏或“Custom colors”栏中用鼠标单击选取。

如果设计者希望自己定义颜色，单击“Standard”标签，如图6-7所示，选
择好颜色后单击“Add  to  Custom  Colors”按钮，即可把颜色添加到

Custom Colors中。



图6-6 选择颜色对话框 图6-7 设计者自己定义颜色



6.3 栅格（Grids）设置
在设计原理图时，图纸上的栅格为放置元器件、连接线路等设计工作带来了极大的方便。
在进行图纸的显示操作时，可以设置网格的种类以及是否显示网格。在图6-3所示的
Document Options对话框中栅格设置条目可以对电路原理图的图纸栅格（Grids）和电气
栅格（Electrical Grid)进行设置。

具体设置内容介绍如下:

1.捕获栅格（Snap）：表示设计者在放置或者移动“对象”时，光标移动的距离。捕获功能

的使用，可以在绘图中能快速地对准坐标位置，若要使用捕获栅格功能，先选中（Snap）
选项左边的复选框，然后在右边的输入框中输入设定值。

2.可视栅格（Visible〕：表示图纸上可视的栅格，要使栅格可见，选中（Visible）选项
左边的复选框，然后在右边的输入框中输入设定值。建议在该编辑框中设置与“Snap”编辑

框中相同的值，使显示的栅格与捕捉栅格一致。若未选中该复选项则不显示栅格。

3.电气栅格（Electrical Grid）：用来设置在绘制图纸上的连线时捕获电气节点的半径
。该选项的设置值决定系统在绘制导线〔wire〕时，以鼠标当前坐标位置为中心，以设定
值为半径向周围搜索电气节点，然后自动将光标移动到搜索到的节点表示电气连接有效。
实际设计时，为能准确快速地捕获电气节点，电气栅格应该设置得比当前捕获栅格稍微小
点，否则电气对象的定位会变得相当的困难。

格点的使用和正确设置可以使设计者在原理图的设计中准确地捕捉元器件。使用可视格点
，可以使设计者大致把握图纸上各个元素的放置位置和几何尺寸，电气栅格的使用大大地
方便了电气连线的操作。在原理图设计过程中恰当地使用栅格设置，可方便电路原理图的
设计，提高电路原理图绘制的速度和准确性。



6.4 其他设置

6.4.1“Document Options”中的系统字体设置

在图6-3所示的“Document Options”对话框中，单击“Change 
System Font”（更改系统字体）按钮，屏幕上会出现系统字

体对话框，可以对字体、大小、颜色等进行设置。选择好字
体后，单击“确定”按钮即可完成字体的重新设置。



6.4.2 图纸设计信息
图纸的设计信息记录了电路原理图的设计信息和更新记录。
Altium Designer的这项功能使原理图的设计者可以更方便
、有效地对图纸的设计进行管理。若要打开图纸设计信息设
置对话框，可以在图6-3所示的Document Options对话框中
用鼠标单击Parameters标签，如图6-8所示。“Parameters”标
签为原理图文档提供20多个文档参数，供用户在图纸模板和
图纸中放置。当用户为参数赋了值，并选中转换特殊字符串
选项后（方法：鼠标单击主菜单
DXP→Preferences→Schematic→Graphical Editing，在该
选项卡内选择复选框：Convert Special Strings），图纸
上显示所赋参数值。



在图6-8所示对话框中可以设置的选项很多，其中常用的有以下几个：
Address：设计者所在的公司以及个人的地址信息。
Approved By：原理图审核者的名字。
Author：原理图设计者的名字
Checked By：原理图校对者的名字
Company Name：原理图设计公司的名字
Current Date：系统日期
Current Time：系统时间
Document Name：该文件的名称
Sheet Number：原理图页面数
Sheet Total：整个设计项目拥有的图纸数目
Title：原理图的名称
在上述选项中的填写信息包括：设置参数的值（Value）和数值的类型
(Type)。设计者可以根据需要添加新的参数值。填写的方法有以下几种
：
单击欲填写参数名称的（Value）文本框，把*去掉，可以直接在文本框
中输入参数。
单击要填写参数名称所在的行，使该行变为选中状态，然后单击对话框
下方的‘Edit’按钮，进入参数编辑对话框如图6-9，这时设计者可以根据
需要在对话框中填写参数。

图6-8  图纸设计信息对话框



双击要编辑参数所在行的任意位置
，系统也将弹出参数编辑对话框如
图6-9所示。

在图纸设计信息对话框中按下按钮
Add，系统自动弹出参数属性编辑对
话框，此时可以添加新的参数。

在图6-9所示的“Parameter 
Properties”对话框，在该对话框的
“Value”文本框内输入参数值。如果

是系统提供的参数，其参数名是不
可更改的（灰色）。确定后单击“OK”
按钮，即完成参数赋值的操作。

图6-9  参数设置对话框



可以在图6-3所示的Document Options对话框中用鼠标单击Units标签,可以设置
图纸是用英制（Imperial）或公制(Metric)单位。

如果完成了参数赋值后，标题栏内没有显示
任何信息。如在图6-8中的“Title”栏处，赋了“
数码管显示电路”的值，而标题栏无显示。则

需要作如下操作：
单击工具栏中的绘图工具按钮‘ ’，在弹出
的工具面板中选择添加放置文本按钮‘ ’，
按键盘上的“Tab”键，打开“Annotation”对话
框如图6-10，可在“Properties”选项区域中的
“Text”下拉列表框中选择“=Title”，在“Font”
处，按Change按钮，设置字体颜色、大小
等属性，然后在按OK按钮，关闭
“Annotation”对话框，鼠标在标题栏中“Title”
处的适当位置，按鼠标左键即可。

图6-10  让设置的参数在标题栏内可见



小结：

6.1 原理图编辑的操作界面设置

6.2 图纸设置

6.2.1 图纸尺寸

6.2.2 图纸方向

6.2.3 图纸颜色

6.3 栅格（Grids）设置



习题
1．Altium Designer 原理图编辑器中的常用工具栏有哪些？各种工具栏的主要
用途是什么？

2．新建一个原理图图纸，图纸大小为：Letter、标题栏为：ANSI，图纸底色为
：浅黄色214，

3．在Altium Designer中提供了哪几种类型的标准图纸？能否根据用户需要定义
图纸？

5．窗口设置。反复尝试各项窗口设置命令及操作，如“View”菜单中的环境组件

切换命令、工作区面板的切换、状态栏的切换、命令栏的切换、工具栏的切换等
。

6．如何将原理图可视网格设置成Dot Grid或Line Grid?

7．如何设置光标形状为:Larger Cursor 90或Small Cursor45？

8．在原理图中如何设置撤销或重复操作的次数。

9．如何设置元器件自动切割导线。即当一个元器件放置中，若元器件的两个管
脚同时落在一根导线上，该导线将被元器件的两个管脚切割成两段，并将切割的
两个端点分别与元器件的管脚相连接。



第7章 数码管显示电路原理图的绘制
教学目的及要求：

1. 掌握原理图图纸的设置

2. 了解导线放置模式

3. 熟练掌握放置总线和总线引入线

教学重点：熟练掌握放置总线和总线引入线

教学难点：导线放置模式

复习并导入新课：

6.1 原理图编辑的操作界面设置

6.2 图纸设置

6.2.1 图纸尺寸

6.2.2 图纸方向

6.2.3 图纸颜色

6.3 栅格（Grids）设置



7.1数码管原理图的绘制
7.1.1 绘制原理图首先要做的工作

首先在硬盘上建立一个“数码管显示电路”的文件夹，然后建立一个
“数码管显示电路.PrjPCB”项目文件并把它保存在“数码管显示电
路”的文件夹下，新建一个原理图，自定义原理图的图纸。

（1）在原理图上任意位置单击鼠标右键，在弹出的菜单中选择
“Options”→“Document Options”命令，打开如图6-3所示的
“Document Options”对话框。

（2）在“Unit”标签中的“Metric Unit System”选择区域中勾选
“Use Metric Unit System”选项，在激活的“Metric unit used”
下拉列表中选择“Millimeters”，将原理图图纸中使用的长度单位
设置为毫米单位。

（3）单击“Sheet Options”标签，打开该标签，勾选“Custom 
Style”选项区域中的“Use Custom Style”选项，然后在激活的
“Custom Width”编辑框中输入257，在“Custom Height”编辑框中
输入182，在“X Region Count”编辑框中输入4，在“Y Region 
Count”编辑框中输入3，单击“OK”按钮。



7.1.2 加载库文件
Altium Designer为了管理数量巨大的电路标识，电路原理图编辑器
提供强大的库搜索功能。首先在库面板查找：MAX1487E和74LS49两个
元件，并加载相应的库文件。然后加载设计者在第5章建立的集成库
文件：New Integrated_ Library1.IntLib。

1．首先来查找型号为74LS49元件。

（1）单击Libraries标签，显示Libraries面板。

（2）在Libraries面板中按下Search按钮，或选择Tools → Find 
Component，将打开Libraries Search对话框如图7-4所示。

（3）对于本例必须确认Scope设置中，Search in选择为Components
（对于库搜索存在不同的情况，使用不同的选项）。必须确保Scope
设置中，选择Libraries on Path单选按钮，并且Path包含了正确的
连接到库的路径。如果用户接受安装过程中的默认目录，路径中会显
示C:\Program Files\Altium Designer Winter 09\Library\。可以
通过单击文件浏览按钮来改变库文件夹的路径。还需要确保已经选中
Include Subdirectories复选框。



（4）我们想查找所有与74LS49有关的元件，所以在Filters的Field
列的第1行选Name,Operator列选Contains,Value列输入74LS49，如图
7-4所示。

图7-4 库搜索对话框



（5）单击Search按钮开始查找。搜
索启动后，搜索结果如图7-5所示

图7-5 搜素结果



（6） 鼠标左击“Place SN74LS49D”按钮，弹出Confirm对话框如图
7-6，确认是否安装元件SN74LS49D所在的库文件“TI Interface 
Display Driver.IntLib”,按Yes按钮，即安装该库文件。

（7）用以上方法查找“MAX1487E”元件。

图7-6 确认是否安装库文件



2. 安装第5章建立的集成库文件：New 
Integrated_Library1.IntLib

（1）如果用户需要添加新的库文件，单击图7-3中库面板的
“Libraries”按钮，弹出“Available Libraries”对话框如图7-7
所示。

（2）在“Available Libraries”对话框中，单击“Install”按钮
，弹出打开路径的对话框如图7-8所示，选择正确的路径，双击需要
安装的库名即可。

图7-7 安装库文件对话框 图7-8 安装库文件



7.1.3 放置元件
用第2章介绍的方法放置元件。表7-1给出了该电路中每个元件样本、元件标
号、元件名称（型号规格）、所在元器件库等数据。注意在放置元件的时候
，一定要注意该元件的封装要与实物相符。

表7-1                   数码管显示电路元器件数据
元件样本 元件标号 元件名称 所属元器件库

AT89C2051 U1 New Integrated_ Library1.IntLib(新建元件库)

MAX1487EPA U2 Maxim Communication Transceiver.IntLib

74LS49 U3 TI Interface Display Driver.IntLib

Dpy Blue-CA DS1-DS3 New Integrated_ Library1.IntLib(新建元件库)

NPN Q1-Q3 9013 Miscellaneous Devices.IntLib

XTAL Y1 12MHz Miscellaneous Devices.IntLib

Cap C1-C2 30P Miscellaneous Devices.IntLib

Cap Pol2 C3 10U/10V Miscellaneous Devices.IntLib

Cap Pol2 C4 220U/10V Miscellaneous Devices.IntLib

Res2 R1-R3 10K Miscellaneous Devices.IntLib

Res2 R4-R6 5K Miscellaneous Devices.IntLib

Res2 R7-R9 1K Miscellaneous Devices.IntLib

Res2 R10-R16 300 Miscellaneous Devices.IntLib

Header2 P1 Miscellaneous Connectors.IntLib

Header6 P2 Miscellaneous Connectors.IntLib



1. 在放置电容C1、C2的过程中，将封
装改为：RAD-0.1方法如下：

（1）在用户放置C1的时候，当光标上“悬浮”着一个电容符号时，
按TAB键编辑电容的属性。在Component Properties对话框的Models 
For C1-Cap单元，电容的封装模型为RAD-0.3如图7-9所示，现在要把
它改为RAD-0.1。

（3）用同样的方法将C2封装改为：RAD-0.1；将C3封装改为：CAPR5-
5×5; 将C4封装改为：RB5-10.5。

在原理图内也可以不修改元器件的封装，用缺省的值。然后在PCB板
内，根据实际元器件的尺寸修改封装。

图7-9  为选中元件选择相应的模型



2．放置好元器件位置的数码管电路原
理图如图7-12所示。

图7-12 放好元件的数码管电路原理图



7.1.4放置导线

7.1.5 放置总线和总线引入线

7.1.6 放置网络标签

图7-23  放置好的总线、总线引入线及网络标签



7.1.7 检查原理图

编辑项目可以检查设计文件中的设计原理图和电气规则的错误，并提
供给用户一个排除错误的环境。

1．要编辑数码管显示电路，选择Project → Compile PCB Project 
数码管显示电路.PrjPCB

2．当项目被编辑后，任何错误都将显示在Messages面板上。如果电
路图有严重的错误，Messages面板将自动弹出，否则Messages面板

不出现。如果报告给出错误，则检查用户的电路并纠正错误。



小结：
6.1 原理图编辑的操作界面设置

6.2 图纸设置

6.2.1 图纸尺寸

6.2.2 图纸方向

6.2.3 图纸颜色

6.3 栅格（Grids）设置

7.1 数码管原理图的绘制

7.1.1 绘制原理图首先要做的工作

7.1.2 加载库文件

7.1.3 放置元件

7.1.4 导线放置模式

7.1.5 放置总线和总线引入线

7.1.6 放置网络标签

7.1.7 检查原理图



作业：

1. 简述Altium Designer在电路原理图中使用Wire与Line工具画线的
区别？原理图中连线（Wire）与总线（Bus）的区别？

2. 在原理图的绘制过程中，怎样加载和删除库文件？怎样加载Atmel
公司的Atmel Microcontroller 16-Bit ARM.IntLib库文件

4. “”和“”按钮的作用分别是什么？

5. “”和“”按钮都可以用来放置文字，它们的作用是否相同？

6. 在元器件属性中，“Footprint”、“Designator”、“Part 
Type”分别代表什么含义？



第9章 数码管显示电路的PCB设计

任务描述

在第7章完成了数码管显示电路的原理图绘制后，本章完
成数码管显示电路的PCB板设计。在该PCB板中，调用第5
章建立的封装库内的两个器件：DIP20(AT89C2051单片机
的封装)、LED-10(数码管的封装)。通过该PCB图验证建立
的封装库内的两个器件的正确性，并进行新知识的介绍。
他将涵盖以下主题：

设置PCB板

设计规则介绍

自动布线的多种方法

数码管显示电路的PCB板设计



教学目的及要求：

1.掌握在项目中新建PCB文档

2.熟练掌握设置PCB板
3.熟练掌握导入元件、元件布局

4.了解PCB的设计规则

5.熟练掌握检查绿色高亮显示

6.熟练掌握自动布线、验证PCB的设计

教学重点：导入元件、元件布局

教学难点：检查绿色高亮显示



9.1 创建PCB板

9.1.1  在项目中新建PCB文档

在第3章的3.2中介绍了用PCB向导产生空白PCB板子轮廓的方法
。本节将介绍另一种方法产生空白的PCB板。

（1）启动Altium Designer，打开“数码管显示电路.PrjPCB”的
项目文件，再打开“数码管显示电路.SchDoc”的原理图。

（2）产生一个新的PCB文件。方法如下：选择主菜单中的
“File”→“New”→“PCB”命令，在“数码管显示电路.PrjPcb”项目中
新建一个名称为“PCB1.PcbDoc”的PCB文件。

（3）在新建的PCB文件上单击鼠标右键，在弹出的下拉菜单中
选择“Save”命令，打开“Save[PCB1.PcbDoc]As”对话框。

（4）在“Save[PCB1.PcbDoc]As”对话框的“文件名”编辑框中输入
“数码管显示电路”，单击“保存”按钮，将新建的PCB文档保存为“
数码管显示电路.PcbDoc”文件。



9.1.2  设置PCB板

（1）在主菜单中选择“Design”→“Board Options…”命令，打开如图9-
1所示的“Board Options”对话框。

图9-1  “Board Options”对话框
（2）在如图9-1所示的“Board Options”对话框的“Measurement Unit”区域中设置
“Unit”为“Metric”；勾选“Sheet Position”区域中的“Display Sheet”复选项，表示在
PCB图中显示白色的图纸；设置Snap Grid X、Y：1mm，单击“OK”按钮。



（3）在主菜单中选择“Design”→“Board Sharp”→“Redefine Board 
Sharp”命令，重新定义PCB板的形状。

（4）移动光标按顺序分别在工作区内坐标为（100 mm，30 mm）、（
190 mm，30 mm）、（190 mm，106 mm）和（100 mm，106 mm）的点
上单击，最后单击鼠标右键，绘制一个矩形区域。重新定义的PCB板
区域如图9-2所示。

图9-2  重新定义的PCB板区域



（5）单击工作区下部的“Keep-Out Layer”层标签，选择“Keep Out Layer”
层，重新定义PCB板的边框。

（6）单击“Utilities”工具栏中的绘图工具按钮“”，在弹出的工具栏中选择
线段工具按钮“”，移动光标按顺序连接工作区内坐标为（103，33）、
（187，33）、（187，103）和（103，103）的四个点，然后光标
回到（103，33）处，光标处出现一个小方框，按鼠标左键，即绘制
“Keep Out”布线的矩形区域（如图9-3所示），按鼠标右键，退出布线
状态。(单位：mm)。

图9-3 绘制布线区域的PCB板

（7）在主菜单中选择
“Design”→“Layer Stack Manager”命
令，打开“Layer Stack Manager”对话

框。
（8）在“Layer Stack Manager”对话框
中勾选“Top Dielectric”复选项和
“Bottom Dielectric”复选项，设置电路
板为有阻焊层的双层板，单击“Ok”按
钮。
至此，PCB板的形状、大小，布线区

域和层数就设置完毕了。



9.2 PCB板布局

9.2.1  导入元件

（1）在原理图编辑器下，用封装管理器检查每个元件的封装是否正
确（3.3节中已介绍），打开封装管理器Tools → Footprint 
Manager。

（2）在主菜单中选择“Design”→“Import Changes From 数码管显示
电路.PrjPcb”命令，打开如图9-4所示的“Engineering Change Order”
对话框。

图9-4  “Engineering Change Order”对话框



（3）单击“Execute Changes”按钮，应用所有已选择的更
新，“Engineering Change Order”对话框内列表中的
“Status”下的“Check”和“Done”列将显示检查更新和执行更
新后的结果，如果执行过程中出现问题将会显示“ ”符号
，若执行成功则会显示“ ”符号。如有错误检查错误，然

后从（2）开始重新执行，没有错误后，应用更新后的
“Engineering Change Order”对话框如图9-5所示。

图9-5  应用更新后的“Engineering Change Order”对话框



（4）单击“Engineering Change Order”对话框中的“Close”
按钮，关闭该对话框，至此，原理图中的元件和连接关系
就导入到PCB板中了。

图9-6  PCB工作区内容

导入原理图信息的PCB板文件的工作区如图9-6所示，此时
PCB板文件的内容与原理图文件“数码管显示电路.SchDoc”就
完全一致了。



9.2.2  元件布局

Altium Designer提供了自动布局功能。方法：选择主菜单Tools →
Component Placement → Auto Placer弹出Auto Place对话框。在该
对话框内可以选择Cluster Placer和Statistical Placer两种布局方
式，目前这两种布局方式布局的效果不尽人意，所以用户最好还是采
用手动布局。方法如下：

（1）单击PCB图中的元件，将其一一拖放到PCB板中的“Keep-Out”布线

区域内。单击元件U1,将它拖动到PCB板中靠左边靠上的区域；在拖动
元件到PCB板中的“Keep-Out”布线区域时，可以一次拖动多个元件，如

选择3个元件DS1-DS3（鼠标单击DS1元件的左下角，然后单击DS3元件
的右上角），按住鼠标左键将它拖动到PCB板中部用户需要的位置时
放开鼠标左键；如图9-7所示。在导入元件的过程中，系统自动将元
件布置到PCB板的顶层（Top Layer），如果需要将元件放置到PCB板
的底层（Bottom Layer）按（2）步骤进行操作。



图9-7 移动元器件

（2）双击元件“U3”，按Tab键，打开如图9-8所示的“Component U3”对话
框。在“Component U3”对话框中“Component Properties”区域内的
“Layer”下拉列表中选择“Bottom Layer”项，单击“OK”按钮，关闭该对
话框。此时，元件“U3”连同其标志文字都被调整到PCB板的底层，把
“U3”放在DS1元件位置的底层（DS1的元件放在顶层）。

图9-8  “Component U3”对话框



（3）放置其它元件布置到PCB板顶层，然后调整元件的位
置。调整元件位置时，最好将光标设置成大光标，方法：
单击鼠标右键，弹出菜单，选择Options → Preferences
，弹出Preferences对话框，光标类型（Cursor Type）处
：选择Large 90即可。

（4）放置元件时，选择于其它元件连线最短，交叉最少
的原则，可以按Space键，让元件旋转到最佳位置，才放
开鼠标左键。

（5）如果电阻R2、R3、R10-R16排列不整齐，可以选中这
些元件，在工具栏上按“ ”图标，弹出下拉工具，选“”图
标，再选“ ”图标后，即可把电阻布置整齐。

(6)在放置元件的过程中，可以按G键，设置元件的Snap 
Grid以及Component Grid，以方便元件摆放整齐。也可以
设置PCB板是采用公制（Metric）或英制(Imperial)单位
，最好采用英制单位。布置完成后的PCB板如图9-9所示。



图9-9  手动布局完成后的PCB板

至此，元件布局完毕。

（7）单击工作区中的名称为“数码管显示电路”的room框，按键盘的“del”键，将其

删除。

room框用于限制单元电路的位置，即某一个单元电路中的所有元件将被限制在由
room框所限定的PCB范围内，便于PCB电路板的布局规范，减少干扰，通常用于层
次化的模块设计和多通道设计中。由于本项目未使用层次设计，不需要使用到
room边框的功能，为了方便元件布局，可以先将该room框删除。



9.2.3  检查绿色高亮显示

运行设计规则检查：Tools→Design Rule Check给出错误报告如图9-
10所示。

图9-10  设计规则检查后的错误报告

从错误报告看出有2个地方出错：Silkscreen Over Component Pads与Minimum 
Solder Mask Sliver。
可以用第3章介绍的方法，从菜单选择Design → Rules（快捷键D，R）打开PCB  
Rules and Constraints Editor 对话框。双击Manufacturing类在对话框的右边显示
所有制造规则，找到Silkscreen Over Component Pads和Minimum Solder Mask 
Sliver两行，把Enabled栏的复选框的“√”去掉即可,表示关闭这2个规则，不进行该
2项的规则检查。



现在PCB板上就没有绿色的高亮显示了，如图9-15所示。

图9-15 清除了绿色高亮的PCB板



9.2.4  更改元件封装

由于图9-15所示PCB板上元器件的封装用的是绘制原理图时放元器件
的缺省值，C1-C4的元件封装与实际元件有差异，所以需要修改这4个
元件的封装。用第3章介绍的方法将C1、C2元件的封装修改为：RAD-
0.1，C3元件的封装修改为：CAPPR5-5X5，C4元件的封装修改为：
RB5-10.5。修改封装后的PCB板如图9-16所示。

图9-16 修改封装后的PCB板



9.3 设计规则介绍

AltiumDesigner提供了内容丰富、具体的设计规则，根据
设计规则的适用范围共分为如下10个类别，下面把要经常
要使用的规则作简单介绍。

“Electrical”——电气规则类。

“Routing”——布线规则类。

“SMT”——SMT元件规则类。

“Mask”——阻焊膜规则类。

“Plane”——内部电源层规则类。

“Testpoint”——测试点规则类。

“Manufacturing”——制造规则类。

“High Speed”——高速电路规则类。

“Placement”——布局规则类。

“Signal Integrity”——信号完整性规则类。



9.3.2 “Routing”规则类

1．“Width”设计规则

“Width”设计规则用于限定布线时的铜箔导线的宽度范围。

已在第3章介绍，在此将接地线（GND）的宽度设为：
30mil，电源线（VCC）的宽度设为：20mil，其它线的宽
度：最小值（Min Width）10mil、首选宽度（Preferred 
Width）15 mil、最大值（Max Width）20mil。如图9-19
所示。

注意：铜箔导线宽度的设定要依据PCB板的大小、元器件
的多少、导线的疏密、印制板制造厂家的生产工艺等多种
因素决定。



9.4 PCB板布线

9.4.1 自动布线

1．网络自动布线

在主菜单中执行“Auto Route”→“Net”命令，光标变成十字准线，选中
需要布线的网络即完成所选网络的布线，继续选择需要布线的其他网
络，即完成相应网络的布线按鼠标右键或“Esc”键退出该模式。

可以先布电源线，然后布其它线。先布电源线“VCC”的电路如图9-38所
示。

图9-38布电源线“VCC”的PCB板



2．单根布线

在主菜单中执行“Auto Route”→“Connection”命令，光标变成十字准线，选中

某根线，即对选中的连线进行布线，继续选择下一根线，则对选中的线自动
布线，要退出该模式，按鼠标右键或“Esc”键。他与“Net”的区别是一个是单根

线，一个是多跟线。

3．面积布线

执行“Auto Route”→“Area”命令，则对选中的面积进行自动布线。

4．元件布线

执行“Auto Route”→“Component”命令，光标变成十字准线，选中某个元件，

即对该元件管脚上所有连线自动布线；继续选择下一个元件，即对选中的元
件布线，要退出该模式，按鼠标右键或“Esc”键。

5．选中元件布线

先选中一个或多个元件，执行“Auto Route”→“Connections On Selected 
Component”命令，则对选中的元件进行布线。

6．选中元件之间布线

先选中一个或多个元件，执行“Auto Route”→“Connections Between 
Selected Component”命令，则在选中的元件之间进行布线，布线不会延伸到

选中元件的外面。



7．自动布线

在主菜单中选择“Auto 
Route”→“All”命令，打

开如图9-39所示的
“Situs Routing 
Strategies”对话框。

在“Situs Routing 
Strategies”对话框内的
“Available Routing 
Strategies”列表中选择
“Default 2 Layer 
Board”项，单击“Route 
All”按钮，启动Situs自

动布线器。

图9-39 “Situs Routing Strategies”对话框



自动布线结束后，系统弹出“Message”工作面板，显示自动

布线过程中的信息，如图9-40所示。

图9-40  “Messages”工作面板



本例，先布电源线“VCC”，然后再自动布线后的PCB板图
如图9-41所示。

图9-41  自动布线生成的PCB板图

如果PCB显示如上图，有的导线显示是断的，把屏幕重新刷新一下就好
了。方法：View → Refresh(快捷键V，R或End键)。



9.4.2 调整布线
如果用户觉得自动布线的效果不令人满意，可以重新调整
元件的布局。如：仔细看数码管DS1的元件封装的底层（
Bottom Layer）上放了一个元件U3，在DS1元件内有4个过
孔，U1元件内的布线太多了，需要调整。

如果想重新布线，方法：选择主菜单Tools →Un-Route 
→ All ，就把所有已布的线路全部撤销，变成了飞线；
如果选择Tools →Un-Route →Net，就可用鼠标点击需要
撤销的网络，这样就可以撤销选中的网络；如果选择
Tools →Connection，就可以撤销选中的连线；如果选择
Tools →Un-Route →Component，用鼠标点击元件，相应
元件上的线就全部变为非线。

现在执行Tools →Un-Route → All命令，撤销所有已布
的线。然后移动元件，调整元件布局后的电路如图9-42所
示。



图9-42 重新调整布局后的PCB板 图9-43 重新自动布线后的PCB板

执行“Auto Route”→“All”命令，布线结果如图9-43所示。

从操作过程可以看出，PCB板的布局对自动布线的影响很大，所以用户在设
计PCB板时一定要把元件的布局设置合理，这样自动布线的效果才理想。



调整布线是在自动布线的基础上完成的，如C2和Y1之间的
连线不是很好如图9-44a所示。用Place →Interactive 
Routing命令重新绘线如图9-44b所示。

a.改动前的布线 b.手动改动后的布线
图9-44 手动布线前后的布线

观察自动布线的结果可知，对于比较简单的电路，当元件布局合理，布线规则
设置完善时，Altium Designer中的Situs布线器的布线效果相当令人满意。
单击保存工具按钮“ ”，保存PCB文件。



9.4.3 验证PCB设计

（1）在主菜单中选择Tools → Design Rule Check…命
令，打开如图9-45所示的“Design Rule Checker”对话框。

图9-45 “Design Rule Checker”对话框

（2）单击“Run Design Rule Check…”按钮，启动设计规则测试。



设计规则测试结束后，系统自动生成如图9-46所示的检查
报告网页文件。

图9-46 检查报告网页

查看检查报告，系统设计中不存在违反设计规则的问题，系统布线成功
。在下一章将介绍介绍PCB板设计的一些技巧。



小结：

9.1 创建PCB板
9.1.1 在项目中新建PCB文档

9.1.2 设置PCB板
9.2 PCB 板布局

9.2.1 导入元件

9.2.2 元件布局

9.2.3  检查绿色高亮显示

9.3 设计规则介绍

9.4 PCB板布线

9.4.1 自动布线

9.4.2 调整布线

9.4.3 验证PCB设计



习题
1.设计规则检查Design Rule Check(DRC)检查的作用是什
么？

2.在PCB板的设计过程中，是否随时在进行DRC检查？

3.设计规则总共有多少个类？具体有哪些？

4.在设计PCB板时，自动布线前，是否必须把设计规则设
置好？

5.自动布线的方式有几种？

6.请完成第7章绘制的“高输入阻抗仪器放大器电路的电路
原理图”的PCB设计。PCB板的尺寸根据所选元器件的封装

自己决定，要求用双面板完成，电源线的宽度设置为
18mil,GND线的宽度设置为28mil，其他线宽设置为13mil
，元器件布局要合理，设计的PCB板要适用。

7.请完成第7章绘制的“铂电阻测温电路的电路原理图”的
PCB设计，具体要求同第6题。



第10章 交互式布线及PCB板设计技巧

教学目的及要求：
1. 熟练掌握交互式布线的各种方法
2. 熟练掌握放置走线、连接飞线自动完成布线
3. 了解处理布线冲突
4. 熟练掌握布线中添加过孔和切换板层

教学重点: 放置走线、连接飞线自动完成布

教学难点：处理布线冲突

复习：
9.1 创建PCB板

9.1.1 在项目中新建PCB文档
9.1.2 设置PCB板

9.2 PCB 板布局
9.2.1 导入元件
9.2.2 元件布局
9.2.3  检查绿色高亮显示

9.3 设计规则介绍
9.4 PCB板布线

9.4.1 自动布线
9.4.3 验证PCB设计



10.1 交互式布线

交互式布线并不是简单地放置线路使得焊盘连接起来。
Altium Designer支持全功能的交互式布线，交互式布线工具可以
通过以下3种方式调出：单击菜单 Place →Interactive Routing命
令、在PCB标准工具栏中单击“”按钮或在右键菜单中单击
Interactive Routing命令（快捷键P，T）。交互式布线工具能直
观地帮助用户在遵循布线规则的前提下取得更好的布线效果，包
括跟踪光标确定布线路径、单击实现布线、推开布线障碍或绕行、
自动跟踪现有连接等。

当开始进行交互式布线时，PCB编辑器不单是给用户放置线
路，它还能实现以下功能：

①应用所有适当的设计规则检测光标位置和鼠标单击动作；

②跟踪光标路径，放置线路时尽量减小用户操作的次数；

③每完成一条布线后检测连接的连贯性和更新连接线；

④支持布线过程中使用快捷键，如布线时按下“*”键切换到下
一个布线层，并根据设定的布线规则插入过孔。



10.1.1 放置走线

当进入交互式布线模式后，光标便会变成十字准线，单击某个焊

盘开始布线。当单击线路的起点时，当前的模式就在状态栏或在悬浮
显示（如果开启此功能）。此时向所需放置线路的位置单击或按
Enter键放置线路。把光标的移动轨迹作为线路的引导，布线器能在

最少的操作动作下完成所需的线路。

光标引导线路使得需要手工绕开阻隔的操作更加快捷、容易和直

观。也就是说只要用户用鼠标创建一条线路路径，布线器就会试图根
据该路径完成布线，这个过程是在遵循设定的设计规则和不同的约束
以及走线拐角类型下完成的。

在布线的过程中，在需要放置线路的地方单击然后继续布线，这

使得软件能精确根据用户所选择的路径放置线路。如果在离起始点较
远的地方单击放置线路，部分线路路径将和用户期望的有所差别。

注意：在没有障碍的位置布线，布线器一般会使用最短长度的布

线方式，如果在这些位置用户要求精确控制线路，只得在需要放置线
路的位置单击。



如图10-2所示，左边的图为最短长度的布线，中间的图指

示了光标路径，五角星所示的位置为需要单击的位置，右边的图
是布线后的图。该例说明了很少的操作便可完成大部分较复杂的
布线。

图10-2 使用光

标引导布线路径
的图例

若需要对已放置的线路进行撤销操作，可以

依照原线路的路径逆序再放置线路，这样原已放
置的线路就会撤销。必须确保逆序放置的线路与
原线路的路径重合，使得软件可以识别出要进行
线路撤销操作而不是放置新的线路。撤销刚放置
的线路同样可以使用退格键BackSpace（退格）

完成。当已放置线路并右击退出本条线路的布线
操作后将不能再进行撤销操作。

以下的快捷键可以在布线时使用。
①Enter（回车）及单击——在光标当前位置放置线路。
②Esc键——退出当前布线，在此之前放置的线路仍然保留。
③BackSpace（退格）——撤销上一步放置的线路。若在上一步

布线操作中其他对象被推开到别的位置以避让新的线路，它们将
会恢复原来的位置。本功能在使用Auto－Complete时则无效。



1．控制拐角的类型

在交互式布线过程中，有不同拐角类型如图10-3所示，当
在Preferences对话框里的PCB Editor中，Interactive  Routing
下的 Restrict to 90／45模式的复选框不被选择，圆形拐角和任
意角度拐角就可用。

可使用的拐角模式有：

①任意角度（A）；

② 450（B）；

③ 450圆角（C）；

④ 900（D）；

⑤ 900圆角（E）。 图10-3 不同的拐角类形

弧形的拐角的弧度可以通过快捷键“，”（逗号）或“。”（句号）
进行增加或减小。使用Shift+“。”快捷键或Shift＋“，”快捷键则以10
倍速度增加或减小控制。

使用Space键可以对拐角的方向进行控制切换。



10.1.2 连接飞线自动完成布线

在交互式布线中可以通过Ctrl十单击操作对指定连接

飞线自动完成布线。这比单独手工放置每条线路效率要高
得多，但本功能有以下几方面的限制。

①超始点和结束点必须在同一个板层内；

②布线以遵循设计规则为基础。

Ctrl+单击操作可直接单击要布线的焊盘，无须预先对

对象在选中的情况下完成自动布线。对部分已布线的网
络，只要用Ctrl十单击操作单击焊盘或已放置的线路，便

可以自动完成剩下的布线。

如果使用自动完成功能无法完成布线，软件将保留原

有的线路。



10.1.3 处理布线冲突

布线工作是一个复杂的过程——在已有的元器

件焊盘、走线、过孔之间放置新的统一线路。
在交互式布线过程中，Altium Designer具有

处理布线冲突问题的多种方法。从而使得布
线更加快捷，同时使线路疏密均匀、美观得
体。

这些处理布线冲突的方法（有以下介绍的4
种），这4种可以在布线过程中随时调用，
通过快捷键Shift＋R对所需的模式进行切换。

在交互式布线过程中，如果使用推挤或紧贴、
推开障碍模式试图在一个无法布线的位置布
线，线路端将会给出提示，告知用户该线路
无法布通。如图10-4所示。

图10-4 无法布

通线路的提示



1．围绕障碍物走线(Walk around Conflicting Object)

该模式下软件试图跟踪光标寻找路径绕过存在的障
碍，它根据存在的障碍来寻找一条绕过障碍的布
线的方法。如图10-5所示。

围绕障碍物的走线模式依据障碍实施绕开的方式进
行布线，该方法有以下两种紧贴障碍模式。

①最短长度——试图以最短的线路绕过障碍；

②最大紧贴——绕过障碍布线时保持线路紧贴现存

的对象。

这两种紧贴模式在线路拐弯处遵循之前设置拐角类
型的原则。

紧贴模式可通过快捷键Shift＋H切换。

如果放置新的线路时冲突对象不能被绕行，布线器
将在最近障碍处停止布线。

图10-5 围
绕障碍物
的走线模

式



2．推挤障碍物(Push Conflicting Object)

该模式下软件将根据光标的走向推挤其他对象（走线和过
孔），使得这些障碍与新放置的线路不发生冲突，如图10-6所示。

如果冲突对象不能移动或经移动后仍无法适应新放置的线路，线
路将贴近最近的冲突对象且显示阻碍标志。

图10-6推挤障碍物



4．忽略障碍物（None）

该模式下软件将直接根据光标走向布线，
不对任何冲突阻止布线。用户可以自由布线，
冲突以高亮显示，如图10-7所示。

图10-7 忽略障碍物

3．紧贴并推挤障碍物(Hug And Push Conflicting 
Object)

该模式是围绕障碍物走线和推挤障碍物两种模式的结合。软

件会根据光标的走向绕开障碍物，并且在仍旧发生冲突时推开障
碍物。它将推开一些焊盘甚至是一些已锁定的走线和过孔，以适
应新的走线。

如果无法绕行和推开障碍来解决新的走线冲突，布线器将自
动紧贴最近的障碍并显示阻塞标志，如图10-4所示。



5．冲突解决方案的设置

在首次布线时应对冲突解决方案进行设置，在Preferences
对话框中，单击PCB Editor中的Interactive Routing项，如图
10-8所示。本对话框中设置的内容将取决于最后一次交互式布

线时使用的设置。

推挤障碍物

忽略障碍物

围绕障碍物走
线

紧贴并推挤障碍物

图10-8 交互式布线设置



与之相同的设置可以在交互式布线时按Tab键弹出的
“Interactive Routing for Net”对话框中进行访问（如图10-9所
示）。无论在图10-8所示对话框还是在通过Tab键调出的对话

框中对冲突解决方案进行设置，都会变成下次进行交互式布线
时的初始设置值。

图10-9 按Tab键弹出的交互式布线设置

状态栏和悬浮显示(快
捷键Shift + H)上显示了当

前的布线模式。用户可以
通过“Preferences”下PCB  
Editor → Board Insight 
Modes页面中的Summary
复选框对悬浮显示进行设
置。

在Preferences对话框

中对交互式布线选项进行
设置，或使用SHIFT＋R
快捷键对当前模式进行切
换（见状态栏）。



10.1.4 布线中添加过孔和切换板层

在Altium Designer交互布线过程中可以添加过孔。过孔只

能在允许的位置添加，软件会阻止在产生冲突的位置添加过孔
（冲突解决模式选为忽略冲突的除外）。

过孔的属性的设计规则位于 PCB Rules and Constraints 
Editor对话框里的Routing Via Style（Design → Rules），如图
10-10所示。

图10-10 过孔的设置



1．添加过孔并切换板层
在布线过程中按数字键盘的“*”或“+”键添加一个过孔并切换到下一个信号

层。按“-”键添加一个过孔并切换到上一个信号层。该命令遵循布线层
的设计规则，也就是只能在允许布线层中切换。单击以确定过孔位置
后可继续布线。

2．添加过孔而不切换板层
按“2”键添加一个过孔，但仍保持在当前布线层，单击以确定过孔位置。
3．添加扇出过孔
按数字键盘的“/”键为当前走线添加过孔，单击确定过孔位置。用这种方

法添加过孔后将返回原交互式布线模式，可以马上进行下一处网络布
线。本功能在需要放置大量过孔（如在一些需要扇出端口的器件布线
中）时能节省大量的时间。

4．布线中的板层切换
当在多层板上的焊盘或过孔布线时，可以通过快捷键L把当前线路切换

到另一个信号层中。本功能在布线时当前板层无法布通而需要进行布
线层切换时可以起到很好的作用。

5.PCB板的单层显示
在PCB设计中，如果显示所有的层，有时显得比较零乱，需要单层显

示，仔细查看每一层的布线情况，按快捷键Shift + S就可单层显示，
选择那一层的标签，就显示那一层；在单层显示模式下，按快捷键
Shift + S又可回到多层显示模式。



小结：

第10章 交互式布线及PCB板设计技巧

10.1 交互式布线

10.1.1 放置走线

10.1.2 连接飞线自动完成布线

10.1.3 处理布线冲突

10.1.4 布线中添加过孔和切换板层



10.5 PCB板的设计技巧

教学目的及要求：
1. 熟练掌握PCB板的设计技巧

2. 熟练掌握放置泪滴、放置过孔作为安装孔

3. 熟练掌握布置多边形敷铜区域

4. 熟练掌握放置尺寸标注、设置坐标原点等

教学重点: PCB板的各种设计技巧

教学难点：PCB板的各种设计技巧

复习：
第10章交互式布线及PCB板设计技巧

10.1 交互式布线

10.1.1 放置走线

10.1.2 连接飞线自动完成布线

10.1.3 处理布线冲突

10.1.4 布线中添加过孔和切换板层



10.5 PCB板的设计技巧

在掌握了以上的布线方式后，可以对上一章设计的PCB板
进行优化，重新布局、布线后的PCB板如图10-25所示。

图10-25 重新布局、布线后的PCB板

由于新的PCB板元器件的排
列比原来紧凑，所以PCB板的

布线区域及板边框的尺寸可缩小。
选择“Keep-Out Layer”层，将布
线区域的左边框向右移动，x的
坐标从103mm→112mm；执行
“Design” → “Board Shape” →
“Redefine Board Shape”命令，
鼠标点击（109mm，30mm）、
（190mm，30mm）、
（190mm，106mm）、
（109mm，106mm）这4个坐
标，将PCB板的边框缩小。



在进行下面的学习之前，一定要先检查设计
的PCB板有无违反设计规则的地方，在主菜单中
执行择“Tools”→“Design Rule Check…”命令，弹
出“Design Rule Checker” 对话框，单击“Run 
Design Rule Check…”按钮，启动设计规则测试。

如设计合理，没有违反设计规则，则进行下面的
操作。



10.5.1 放置泪滴

如图10-26所示，在导线与焊盘或过孔的连接处有一段

过渡，过渡的地方成泪滴状，所以称它为泪滴。泪滴的作
用是：在焊接或钻孔时，避免应力集中在导线和焊点的接
触点，而使接触处断裂，让焊盘和过孔与导线的连接更牢
固。

Arc                             Arc Track
图10-26 泪滴的Arc和Track两种形状



放置泪滴的步骤如下：

（1）打开需要放置泪滴的PCB板，执行“tools”→“Teardrops”命
令，弹出如图10-27所示泪滴设置对话框。

图10-27 泪滴设置对话框

（2）在“General”设置栏中，如果选择
“All Pads”，将对所有的焊盘放置泪
滴；如果选择“All Vias”，将对所有的过
孔放置泪滴；如果选择“Selected 
Objects Only”，将只对所选择的元素所

连接的焊盘和过孔放置泪滴。

（3）在“Action”设置栏，Add单选按钮表示此操作将添加泪滴；
“Remove”单选按钮表示此操作将删除泪滴。
（4）在“Teardrop Style”设置栏，设置泪滴的形状，其中“Arc”
和“Track”两种形状分别如图10-26所示。
（5）单击OK按钮，系统将自动按所设置的方式放置泪滴。



10.5.2 放置过孔作为安装孔

在低频电路中，可以放置过孔或焊盘作为安装孔。执行命令
“Place” →“Via”，进入放置过孔的状态，按Tab键弹出Via对话框
如图10-28所示。

图10-28 Via对话框

将过孔直径(Diameter )改为：
6mm
将过孔的孔的直径(Diameter )
改为：3mm
然后放在PCB板的4个角上
（116mm，37mm）、
（183mm，37mm）、
（183mm，99mm）、（116 
mm，99mm）。
把4个过孔放在PCB板后，成
绿色高亮，如图10-29所示。



图10-29 放置安装孔的PCB板

检查过孔为什么绿色高亮。
（1）在主菜单中选择
“Tools”→“Design Rule 
Check…”命令，打开“Design 
Rule Checker”对话框。
（2）单击“Run Design Rule 
Check…”按钮，启动设计规

则测试。
设计规则测试结束后，系统
自动生成如图10-30所示的检

查报告网页文件。



错误原因：“Hole Size 
Constraint(Min=0.0254mm)(Max=2.54mm)(All)”。PCB板上孔
的直径最小0.0254mm,最大2.54mm 。而用户放置的过孔的孔
的直径为3mm大于最大值,所以出现绿色的高亮显示。

修改设计规则：执行Design → Rule命令，出现“PCB Rules and 
Constraints Editor”对话框，选择Design Rules —
Manufacturing — Hole Size，按鼠标右键，从下拉菜单中选择
New Rule,出现Hole Size的新规则如图10-31所示，将孔直径的
最大值改为：4mm。

图10-30  检查报告网页 图10-31将孔直径的最大值改为4mm



选择Design Rules — Routing — Routing
Via Style，将Via Diameter(过孔直径)的最大值
（Maximum）改为：7mm，Via Hole Size(过孔
的孔的尺寸)的最大值（Maximum）改为：
4mm，按OK按钮即可。

修改了这两个参数后的PCB板无绿色高亮显
示。



10.5.3 布置多边形铺铜区域

在设计电路板时，有时为了提高系统的抗干扰性，需要设

置较大面积的接地线区域（大面积接地）。多边形铺铜就可以
完成这个功能，布置多边形铺铜区域的方法如下。

（1）在工作区选择需要设置多边形铺铜的PCB板层。

（2）单击“Wiring”工具栏中的多边形铺铜工具按钮“ ”，
或者在主菜单中选择Place→Polygon plane菜单项。打开如图
10-33所示的“Polygon Pour”对话框。

图10-33  “Polygon Pour ”对话框



如图10-33所示的“Polygon Pour”对话框用于设置多边形铺铜区域的

属性，其中的选项功能如下。

①“Fill Mode”用来设置多边形铺铜区域内的形状

Solid(Copper Regions)：表示铺铜区域是实心的。

Hatched(Tracks/Arcs)：表示铺铜区域是网状的。

None(Outlines Only)：表示铺铜区域无填充，仅有轮廓、外围。

②“Track Width”编辑框用于设置多边形铺铜区域中网格连线的宽度。

如果连线宽度比网格尺寸小，多边形铺铜区域是网格状的；如果
连线宽度和网格尺寸相等或者比网格尺寸大，多边形铺铜区域是
实心的。

③“Grid Size”编辑框用于设置多边形铺铜区域中网格的尺寸。为了

使多边形连线的放置最有效，建议避免使用元件管脚间距的整数
倍值设置网格尺寸。

④“Surround Pads With”选项用于设置多边形铺铜区域在焊盘周围
的围绕模式。其中，“Arcs”单选项表示采用圆弧围绕焊盘，
“Octagons”单选项表示使用八角形围绕焊盘，使用八角形围绕焊
盘的方式所生成的Gerber文件比较小，生成速度比较快。



⑤“Hatch Mode”用于设置多边形铺铜区域中的填充网格式样，其
中共有4个单选项，其功能如下。

“90 Degree”单选项表示在多边形铺铜区域中填充水平和垂直的连
线网格。

“45 Degree”单选项表示用45°的连线网络填充多边形。

“Horizontal”单选项表示用水平的连线填充多边形铺铜区域。

“Vertical”单选项表示用垂直的连线填充多边形铺铜区域。

以上各填充风格的多边形铺铜区域如图10-34所示。

“None” “90 Degree” “45Degree”

“Horizontal” “Vertical”
图10-34  各填充风格的多边形铺铜区域



⑥“Properties”区域用于设置多边形铺铜区域的性质，其中的各选
项功能如下。

Name：铺铜区域的名字，一般不用更改。
Layer：下拉列表用于设置多边形铺铜区域所在的层。
Min Prim Length：编辑框用于设置多边形铺铜区域的精度，该值

设置得越小，多边形填充区域就越光滑，但铺铜、屏幕重画和
输出产生的时间会增多。

Lock Primitive：用于设置是否锁定多边形铺铜区域。如果选择该
复选框，多边形铺铜区域就成为一个整体，不能对里面的任何
对象进行编辑，否则可以编辑里面的对象。

Locked：用于设置是否移动多边形铺铜区域在板上的位置。如果
选择该复选框，移动时给出一个提示信息：This Primitive is 
locked. Contiune？如果选择“Yes”，就可移动多边形铺铜区
域，否则不能移动。

Ignore On-Line Violations：设置多边形铺铜区域是否进行在线设
计规则检查。

⑦“Net Options”区域用于设置多边形铺铜区域中的网络，其中的
各选项功能如下：

“Connect To Net”下拉列表用于选择与多边形铺铜区域相连的网
络，一般选择GND。



10.5.4 放置尺寸标注

1．直线尺寸标注

对直线距离尺寸进行标注，可进行以下操作。

（1）单击“Utilities”工具栏中的尺寸工具按钮“”，在弹出的工具栏
中选择直线尺寸工具按钮“”，或者选择
“Place”→“Dimension”→“Linear”命令。

（2）单击“Tab”键，打开如图10-39所示的“Linear Dimension”对
话框。

图10-39  “Linear Dimension”对话框



如图10-39所示的“Linear Dimension”对话框用于设置直线标注的
属性，其中的选项功能如下。

“Pick Gap”编辑框用来设置尺寸线与标注对象间的距离。

“Extension Width”编辑框用来设置尺寸延长线的线宽。

“Arrow Length”编辑框用来设置箭头线长度。

“Arrow Size”编辑框用来设置箭头长度（斜线）。

“Line Width”编辑框用来设置箭头线宽。

“Offset”编辑框用来设置箭头与尺寸延长线端点的偏移量。

“Height”编辑框用来设置尺寸字体高度。

“Rotation”编辑框用来设置尺寸标注线拉出的旋转角度。

“Text Width”编辑框用来设置尺寸字体线宽。

“Text Gap”编辑框用来设置尺寸字体与尺寸线左右的间距。

“Properties”区域用来设置直线标注的性质，其中的选项功能如下：

“Layer”下拉列表用来设置当前尺寸文本所放置的PCB板层。



“Format”下拉列表用来设置当前尺寸文本的放置风
格。在下拉列表中选择尺寸放置的风格共有4个选
项：“None”选项表示不显示尺寸文本。“0.00”选
项表示只显示尺寸，不显示单位。“0.00mil”选项
表示同时显示尺寸和单位。“0.00（mil）”选项表

示显示尺寸和单位，并将单位用括号括起来。

“Text Position”下拉列表用来设置当前尺寸文本的放

置位置。

“Unit”下拉列表用来设置当前尺寸采用的单位。可以
在下拉列表中选择放置尺寸的单位，系统提供了
“mils”、“millimeters”、“Inches”、“Centimeters”和
“Automatic”共五个选项，其中“Automatic”项表示

使用系统定义的单位。



2．标准标注

标准标注用于任意倾斜角度的直线距离标注，可进行以下操
作设置标准标注。

（1）单击“Utilities”工具栏中的尺寸工具按钮“ ”，在弹出
的工具栏中选择标准直线尺寸工具按钮“ ”，或者选择
“Place”→ “Dimension”→“Dimension”命令。

3．坐标标注

坐标标注用于显示工作区里指定点的坐标。坐标标记可以放
置在任意层，坐标标注包括一个“十”字标记和位置的
（X，Y）坐标，可进行如下操作布置坐标标注。

（1）单击“Utilities”工具栏中的绘图工具按钮“ ”，在弹出
的工具栏中选择坐标标注工具按钮“ ”，或者在主菜单
中选择“Place”→“Coordinate”命令。



10.5.5 设置坐标原点

在PCB编辑器中，系统提供了一套坐标系，其坐标原点称为绝对原
点，位于图纸的最左下角。但在编辑PCB板时，往往根据需要
在方便的地方设计PCB板，所以PCB板的左下角往往不是绝对
坐标原点。

Altium Designer提供了设置原点的工具，用户可以利用它设定自己
的坐标系，方法如下：

（1）单击“Utilities”工具栏中的绘图工具按钮“ ”，在弹出的工具
栏中选择坐标原点标注工具按钮“ ”，或者在主菜单中选择
“Edit”→“Origin”→“Set”命令。

（2）此时鼠标箭头变为十字光标，在图纸中移动十字光标到适当
的位置，单击鼠标左键，即可将该点设置为用户坐标系的原点
（如图10-42所示），此时再移动鼠标就可以从状态栏中了解到
新的坐标值。

（3）如果需要恢复原来的坐标系，只要选择
“Edit”→“Origin”→“Reset”命令即可。



图10-42 标注的尺寸、坐标，重置坐标原点及铺铜的PCB板



小结：

10.5 PCB 板的设计技巧

10.5.1 放置泪滴

10.5.2 放置过孔作为安装孔

10.5.3 布置多边形敷铜区域

10.5.4 放置尺寸标注

10.5.5 设置坐标原点
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10.6  PCB板的3D显示

教学目的及要求：
1. 熟练掌握PCB板的3D显示设计方法

2.熟练掌握检查原理图与PCB板之间的信息是否一致的方法

教学重点: PCB板的3D显示设计

教学难点：PCB板的3D显示设计

复习：
10.5 PCB 板的设计技巧

10.5.1 放置泪滴

10.5.2 放置过孔作为安装孔

10.5.3 布置多边形敷铜区域

10.5.4 放置尺寸标注

10.5.5 设置坐标原点



10.6 PCB板的3D显示

在PCB编辑器中，按快捷键3就可进行PCB板的3D显示，
如图10-46所示。从图中可以看出只有3个数码管和单片机有3D
模型，其他元器件都没有3D模型，这是因为在第5章建立数码

管和单片机的封装时，建立了这两个器件的三维模型。而其他
元器件的封装没有三维模型。

图10-46 PCB板的3D显示



为了查看PCB板焊接元器件后的效果，提前预知PCB板与
机箱的结合，也就是ECAD与MCAD的结合，需要为其他元器

件建立与实际器件相吻合三维模型。方法如下：

执行“Tools”→“Manage 3D Bodies for Components on 
Board”命令，弹出如图10-47所示的“Component Body 
Manager”3D模型管理对话框，可以在该对话框内对PCB板上
所有的元器件建立3D模型。

图10-47 元器件3D模型管理对话框



1.建立晶振Y1的3D模型

（1）在图10-47所示的“Components”区域选择需要建3D模型的元件Y1。
（2）在“Description”列选择“Shape Created from bounding rectangle on All Layers”。
（3）在“Action”列，用鼠标左键单击“Add to Y1”,表示把3D模型加到Y1上，点击后显示变

为：“Remove From Y1”，如果再单击“Remove From Y1”，表示把刚加的3D模型从Y1
上移除掉，在此不进行此操作。

（4）在“Standoff Height”列，该列表示三维模型底面到电路板的距离，在此设为0.5mm。
（5）在“Overall Height”列，该列表示三维模型顶面到电路板的距离，在此设为12.5mm。
（6）“Body Projection”列，用于设置三维模型投影的层面，在此选“Top Side”
（7）“Registration Layer”，用于设置三维模型放置的层面，在此选缺省值“Mechanical1”。
（8）“Body 3-D Color”,用于选择三维模型的颜色，在此选择与实物相似的颜色。进行了以

上设置的3D模型管理对话框如图10-48所示。

图10-48 为晶振Y1添加了三维模型



2.建立三极管Q1-Q3的3D模型

（1）在图10-47所示的“Components”区域选择需要建3D模型的器
件Q1。

（2）在“Description”列选择“Polygonal Shape Created from  
primitives on TopOverlay”。

（3）在“Action”列，用鼠标左键单击“Add to Q1”。
（4）在“Standoff Height”列，设为3.5mm。

（5）在“Overall Height”列，设为8.5mm。

（6）“Body Projection”列，用于设置三维模型投影的层面，在此
选“Top Side”

（7）“Registration Layer”，用于设置三维模型放置的层面，在此
选缺省值“Mechanical1”。

（8）“Body 3-D Color”,用于选择三维模型的颜色，在此选择与实

物相似的颜色。

Q2与Q3的设置与Q1相同。



3.建立电阻R1-R16的三维模型

方法同“2”，仅仅以下3处不同：

（1）在“Standoff Height”列，设为1mm。

（2）在“Overall Height”列，设为3.2mm。

（3）“Body 3-D Color”,用于选择三维模型的颜色，在此选择与实物相似
的颜色。

4.建立U2的三维模型

方法同“2”，仅仅以下3处不同：

（1）在“Standoff Height”列，设为0mm。

（2）在“Overall Height”列，设为4.58mm。

（3）“Body 3-D Color”,用于选择三维模型的颜色，在此选择与实物相似
的颜色。

5. 建立C1-C2的三维模型

方法同“2”，仅仅以下3处不同：

（1）在“Standoff Height”列，设为1mm。

（2）在“Overall Height”列，设为4mm。

（3）“Body 3-D Color”,用于选择三维模型的颜色，在此选择与实物相似
的颜色。



6. 建立C3、C4的三维模型
方法同“2”，仅仅以下3处不同：
（1）在“Standoff Height”列，设为0.5mm。
（2）在“Overall Height”列，设为12.7mm。
（3）“Body 3-D Color”,用于选择三维模型的颜色，在此选择与实物相似的颜色。
7.建立J1、J2的三维模型
方法同“2”，仅仅以下3处不同：
（1）在“Standoff Height”列，设为0mm。
（2）在“Overall Height”列，设为8mm。
（3）“Body 3-D Color”,用于选择三维模型的颜色，在此选择与实物相似的颜色。
为数码管显示电路PCB板的所有元器件添加三维模型后的PCB板如图10-49所示。

图10-49 为数码管显示电路的所有元件添加三维模型后的PCB板



在主菜单执行View → Flip Board命令，可以把PCB板从一
面翻转到另一面，也就是翻转1800，如图10-50所示。

图10-50 数码管显示电路PCB板翻转1800



10.7 原理图信息与PCB板信息的一致性

如果数码管显示电路PCB板上元器件的三维模型比较接近真
实的元器件的尺寸，就可观察用户设计的PCB板是否合理适用。如
果不合理，可以修改PCB板，直到满足设计要求为止，否则等生产
厂家把PCB板制作好以后才发现错误，就会造成浪费。

如果在PCB板上发现某个元件的封装不对，可以在PCB板上修

改该元件的封装，或把该元件的封装换成另一个合适的封装，这就
造成原理图信息与PCB板上的信息不一致。为了把PCB板上更改的
信息反馈回原理图，在PCB编辑器执行“Design”→“Update
Schematics in 数码管显示电路.PrjPCB”命令，就可把PCB的信息

更新到原理图内。

如果在原理图上发生了改变，要把原理图的信息更新到PCB
内，在原理图编辑环境下执行“Design”→“UpdateDocument 数码管
显示电路.PcbDoc”命令，就可把原理图的信息更新到PCB图内。

这样就可保证原理图信息与PCB板上的信息一致，原理图与
PCB图之间是可以双向同步更新的。



要检查原理图与PCB板之间的信息是否一致，可以执行以下

操作：

（1）打开原理图与PCB图，执行“Project”→ “Show Differences”命
令，弹出“Choose Documents to Compare”对话框如图10-51所
示，选择一个要比较的PCB板，按OK按钮。

图10-51 Choose Documents to Compare对话框



（2）弹出原理图与PCB图之间差异的对话框如图10-52所
示，从图中看出除了Room以外，原理图与PCB图之间没有差
异。

可以按“Report Differences”按钮查看报告，也可以按
“Explore Differences”按钮探究报告，在该报告上选择目标，就
可以找到原理图与PCB板之间的差异。

图10-52 原理图与PCB图之间差异的对话框

如果PCB板设计合理，就可产生输出文件（第12章介绍）供生产厂家使用。



小结：

10.6 PCB 板的3D显示

10.7 原理图信息与PCB板信息的一致性
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4．将第9章完成的“高输入阻抗仪器放大器电路的

PCB板”做优化处理，标注尺寸，设置坐标原
点，并为PCB板上所有的元器件建立3D模型，
查看PCB板的3D显示，检查设计的PCB板是否

适用。



第12章 输出文件

教学目的及要求：
1. 了解各种输出文件的用途

2. 熟练掌握输出PDF文件、生成Gerber文件、NC Drill文件的

方法

3. 熟练掌握创建材料清单（BOM）的方法

教学重点: 输出Gerber文件、NC Drill文件

教学难点：输出Gerber文件、NC Drill文件

复习：
10.6 PCB 板的3D显示

10.7 原理图信息与PCB板信息的一致性



12.1 输出PDF文件

现在已经完成了基本的PCB的设计和布线，

还需要把各种文件整理分发出来，从而来进行设
计审查、制造验证和生产组装PCB板。这些需要
输出的文件很多，有些文件是用于提供给PCB制
造商，生产PCB板用，比如PCB文件，或者
Gerber文件，PCB规格书等等，而有的则是提供
给工厂生产使用，比如Gerber文件用来开钢网，
Pick坐标文件做自动贴片插件机用，单层的测试
点文件做ICT，元件丝印图做生产作业文件，等
等，而对于这些要求，Altium Designer完全可以

输出各种用途的文件。



这些用途区分下来就包括有以下几个方面：
1．装配文件输出
（1）元件位置图：显示电路板每一面上元器件XY坐标位置和原点信息。
（2）抓取和放置文件：用于元件放置机械手在电路板上摆放元器件。
（3）3D结构图：将3D图给结构工程师，沟通是否有高度，装配，尺寸干涉等

等。
2．文件输出
（1）文件产出复合图纸：成品板组装，包括元件和线路。
（2）PCB的三维打印：采用三维视图观察电路板
（3）原理图打印：绘制设计的原理图。
3．制作输出
（1）绘制复合钻孔图：绘制电路板上钻孔位置和尺寸的复合图纸。
（2）钻孔绘制／导向：在多张图纸上分别绘制钻孔位置和尺寸。
（3）最终的绘制图纸,把所有的制作文件合成单个绘制输出。
（4）Gerber文件：制作 Gerber格式的制作信息。
（5）NC Drill Files:创建能被数控钻控机使用的制造信息
（6）ODB++：创建ODB++数据库格式的制造信息。
（7）Power－Plane Prints：创建内电层和电层分割图纸。
（8）Solder／Paste Mask Prints：创建阻焊层和锡膏层图纸。
（9）Test Point Report：创建在不同模式下设计的测试点的输出结果。



4．网表输出

网表描述在设计上逻辑之间的元器件连接，对于移植到其他电子
产品设计中是非常有帮助的，比如与PADS2007等其他CAD软

件连接。

5．报告输出

（l）Bill of Materials：为了制作板的需求而创建的一个在不同格

式下部件和零件的清单。

（2）Component Cross Reference Report：在设计好的原理图

的基础上，创建一个组件的列表。

（3）RePort Project Hierarchy：在该项目上创建一个原文件的清

单。

（4）RePort Single Pin Nets：创建一个报告，列出任何只有一个

连接的网络。

（5）Simple BOM：创建文本和该 BOM的 CSV（逗号隔开的变

量）文件。



对于大部分的输出文件是用做配置的，在需要的时候设置

输出就可以。在完成更多的设计后，用户会发现他经常为每个
设计采用相同或相似的输出文件，这样一来就做了许多重复性
的工作，严重影响工作效率，针对这种情况，Altium Designer
提供了一个解决办法：Altium Designer现在提供一个叫做
Output Job Files的方式，该方式使用一种接口，为 Output Job 
Editor，可用于将各种需要输出文件捆绑在一起，将它们发送
给各种输出方式（可以直接打印，生成PDF和生成文件）。

下面用户简单介绍一下Altium Designer的Output Job Files
相关的操作和内容。

首先，打开上一章设计好的数码管显示电路的原理图、
PCB图等，启动Output Job Files，用户可以单击File菜单下的
Smart PDF...选项，然后将出现对话框，在这个对话框里面，
仅仅是提示一下启动智能PDF向导，直接点击Next进入下一步

骤。



现在此处的对话框（图12-2）主要是选择需要输出的目标
文件范围，如果是仅仅要输出当前显示的文档，就选择Current  
Document，如果是要输出整个项目的所有相关文件，就如图所
示选择Current  Project。

图12-1 智能PDF设置向导 图12-2 选择输出的目标文件(包)



现在此处的对话框（图12-3）是详细的文件输出表，用户可以
通过Ctrl+单击和Shift+单击来进行组合选择需要输出的文件。而对

于非项目输出，则无此步骤。

图12-3 选择详细的文件输出表



现在此处的对话框（图12-4）选择输出BOM的类型以及选择
BOM模板，Altium Designer提供了很多的各种各样的模板，比如
其中的BOM Purchase.XLT一般是用于物料采购使用较多，其中的
BOM Manufacturer.XLT一般是用于生产使用较多，当然它还有缺
省的通用BOM格式：BOM Default Template.XLT等等，用户可以
根据自己的需要选择相应的模板 。当然也可以自己做一个适合自
己的模板，在后续章节的的BOM输出里面看到相关的内容。

图12-4 选择输出BOM的类型



现在此处的对话框（图12-5）主要是选择PCB打印的层和区

域打印，在上面的打印层设置，可以设置元件的打印面，是否镜
象（常常是对于底层视图的时候需要勾选此选项，更贴近人类的
视觉习惯），是否显示孔等等，下半部主要是设置打印的图纸范
围，是选择整张输出呢？还是仅仅输出一个特地的XY区域，比如

对于模块化，和局部放大就很有用处的。

图12-5 打印输出的层和区域设置



现在此处的对话框（图12-6）主要是设置PDF的详细参
数，比如输出的PDF文件是否带网络信息，元件，元件引脚等
书签，以及PDF的颜色模式（彩色打印，单色打印，灰度打印

等）。

图12-6 输出PDF的详细设置



现在此处的对话框（图12-7）就已经完成了PDF输出的设
置，其附带的选项是提示是否在输出PDF后自动查看文件，是
否保存此次的设置配置信息，方便后续的PDF输出可以继续使

用此类的配置。

图12-7 完成PDF设置



用户可以根据提示和教材内容完成。

在用户完成上述输出PDF设置向导后，单击完成按钮，示
例文件所输出的PDF文件包如图12-8所示。

图12-8 输出的PDF的例子



用户可以清晰的看见它包括原理图，PCB各
单层图等相关的所有的信息。

虽然上述输出的文件也比较全面，但是还是

不完整，在许多的特定特殊的场合需要的文件好
多都没有，在 PCB设计完成的最后阶段，为了更

好地满足设计验证，生产效率，生产要求和质量
控制，下面就主要介绍如何产生各种PCB厂家生

产以及工厂工艺生产，以及质量控制的等等所需
的相关文件。



12.2 生成Gerber文件
12.2.1 Gerber文件简单介绍

电子CAD文档一般指原始PCB设计文件，文
件后缀一般为.PcbDoc、 .SchDoc， 而对用户或

企业设计部门，往往出于各方面的考虑，提供给
生产制造部门电路板的都是Gerber文件。

Gerber文件是所有电路设计软件都可以产生

的一种文件格式，在电子组装行业又称为模版文
件（stencil.data）,在PCB制造业又称为光绘文件。
可以说Gerber文件是电子组装业中最通用最广泛

的文件格式。



由Altium Designer产生的Gerber文件各层扩展名与PCB原来
各层对应关系表:

顶层Top (copper) Layer : .GTL
底层Bottom (copper) Layer : .GBL
中间信号层Mid Layer 1, 2, ... , 30 : .G1, .G2, ... , .G30
内电层Internal Plane Layer 1, 2, ... , 6 : .GP1, .GP2, ... , .GP16
顶丝印层Top Overlay : .GTO
底丝印层Bottom Overlay : .GBO
顶掩膜层Top Paste Mask : .GTP
底掩膜层Bottom Paste Mask : .GBP
Top Solder Mask : .GTS
Bottom Solder Mask : .GBS
Keep-Out Layer : .GKO
Mechanical Layer 1, 2, ... , 16 : .GM1, .GM2, ... , .GM16
Top Pad Master : .GPT
Bottom Pad Master : .GPB
Drill Drawing, Top Layer - Bottom Layer (Through Hole) : .GD1
Drill Drawing, other Drill (Layer) Pairs : .GD2, .GD3, ...
Drill Guide, Top Layer - Bottom Layer (Through Hole) : .GG1
Drill Guide, other Drill (Layer) Pairs : .GG2, .GG3, ...



12.2.2 用Altium Designer输出Gerber文件

1. 单击 File → Fabrication Outputs → Gerber Fils，打开设置对话框

2. 在普通General标签下面（图12-10），用户可以选择输出的单位是英
寸还是米制，而在格式就有2：3，2：4，2：5三种，这三种选择同
样对应了不同的PCB生产精度，一般普通的用户可以选择2：4，当然
有的设计对尺寸要求高些，用户也可以选2：5。

图12-10 Gerber普通项设置



3. 单击 Layers标签，用户进行Gerber绘制输出层设置，
然后单击 Plot Layers按钮，并选择Used On。然后单击 Mirror 
Layers按钮，并选择All Off。然后在Mechanical Layer标签项
选择PCB绘图所用外形的机械层（图12-11）。当然在这里用
户也可以根据需要或者PCB板的要求来决定一些特殊层是否需

要输出，比如单面板和双面板，多层板等等。

图12-11 Gerber绘制输出层设置



4.在Drill Drawing标签项目钩上Plot all used layer pairs
（图12-12）。

图12-12 Gerber钻孔输出层设置



5.而对于其他选择项目用户采取默认值，不用去设置了，
直接点OK按纽退出设置对话框，Altium Designer则开始自动
生成Gerber文件，并且同时进入CAM 编辑环境（图12-13），
显示出用户刚才所生成的Gerber文件。

图12-13 CAM编辑环境



6.此时，用户可以进行检查，如果没有问题就可以导出
Gerber文件了，先单击File下面的Export选项，选择Gerber，
然后在弹出的对话框里面钩上格式为RS-274-X，单击OK按纽
就导出Gerber文件了，（如图12-14所示）。

图12-14 Gerber导出



7.此时用户可以查看刚才生成的Gerber文件，用“我的电脑”
在PCB同位置的文件夹可以看见新生成的Gerber文件（图12-
15）。

图12-15 Gerber输出文件清单



8.现在我们还需要导出钻孔文件,用户重新回到PCB编辑界
面，File →Fabrication Outputs → NC Drill Files。

9.弹出“NC Drill Setup”对话框，用户可以选择输出的单位是英
寸还是米制，而在格式就有2：3，2：4，2：5三种，这三种选择
同样对应了不同的PCB生产精度，一般普通的用户可以选择2：4，
当然有的设计对尺寸要求高些，用户也可以选2：5。但是还有一个
很关键的就是：对于此处的单位和格式的选择必须和在产生Gerber
的选择一致，否则厂家生产的时候叠层会出问题。而其他默认设置
点OK，然后在弹出的对话框点击OK按钮，确认后就出现了CAM的
输出界面(图12-17所示)。

图12-17 输出界面

此时产生好了钻空文件，如图12-17所示。



12.3 创建BOM

BOM为Bill of Materials的简称 , 也叫材料清单，它是一个

很重要的文件，在物料采购，设计验证样品制作，批量生产等
等都需要这个东东，它可以用SCH文件产生出BOM，也可以
PCB产生BOM，这里简单介绍用PCB产生BOM的方法。

1.单击 Reports → Bill of Materials命令，出现Bill of 
Materials for PCB Document对话框（图12-20）：

图12-20 BOM输出设置



2.使用此对话框，以建立起自己的BOM。在用户想要输出到报告
的每一栏中都选中Show复选框。从All Columns清单选择并拖
动标题到Grouped Columns清单，以便在BOM中按该数据类型
来分组元件。例如，若要以封装来分组，在All Columns中选择
Footprint选项，并拖拽到Grouped Columns清单。该报告将据
此进行分类。

3.在Export Options项可以选择文件的格式，是用XLS的电子表格
还是TXT的文本样式。在Excel Options项里面可以选择相应的
BOM模板，软件自己附带包括很多种输出，比如设计开发前期
的简单BOM样式（BOM Simple.XLT），样品的物料采购BOM
样式（BOM Purchase.XLT），生产用BOM样式（BOM 
Manufacturer.XLT），普通的缺省BOM样式（BOM Default 
Template.XLT）等等，当然用户也可以自己做一个适合自己的
BOM模板，做BOM模板的时候注意变量名称即可，这个东西很
简单，在这里就不多介绍了。在Supplier Options可以选择数量
从而自动计算BOM里面物料的需求用量。



4.单击Export按钮，弹出保存文件对话框，选择正确路径保存即可。
打开该文件如图12-21所示。

图12-21 输出的BOM例子



小结：

第12章 输出文件

12.1 输出PDF文件

12.2 生成Gerber文件

12.2.1 Gerber 文件简单介绍

12.2.2输出Gerber文件

输出NC Drill 文件

12.3 创建材料清单（BOM）



作业：

P267 
1. 将此处的PCB项目文件：X:\Program Files\Altium

Designer Winter 09\Examples\Reference Designs\4 
Port Serial Interface\4 Port Serial Interface.PRJPCB
（X为软件安装盘盘符） 输出一个Smart PDF。

2.将此处的PCBDOC文件：X:\Program Files\Altium
Designer Winter 09\Examples\Reference Designs\4 
Port Serial Interface\4 Port Serial Interface.pcbdoc （X
为软件安装盘盘符） 输出一个gerber文件包

3. 将此处的PCB项目文件：X:\Program Files\Altium
Designer Winter 09\Examples\Reference Designs\4 
Port Serial Interface\4 Port Serial Interface.PRJPCB
（X为软件安装盘盘符） 输出一个Altium Designer缺省
的XLS格式的BOM表。



第11章 层次原理图及其PCB设计

任务描述

本教材前面介绍的常规电路图设计方法，是将整个原理图绘制在一张
原理图纸上，这种设计方法对于规模较小，简单的电路图的设计提供
了方便的工具支持。但当设计大型、复杂系统的电路原理图时，若将
整个图纸设计在一张图纸上，就会使图纸变得过分复杂不利于分析和
检错，同时也难于多人参与系统设计。

Altium Designer支持多种设计复杂电路的方法，例如层次设计、多通道

设计等，在增强了设计的规范性的同时减少了设计者的劳动量，提高
了设计的可靠性。本章将以电机驱动电路为例介绍层次原理图设计的
方法，以多路滤波器的设计为例介绍多通道电路设计方法。它将涵盖
以下主题：

自上而下层次原理图设计

自下而上层次原理图设计

多通道电路设计

电机驱动电路的PCB设计

多路滤波器的PCB设计



教学目的及要求：
了解层次原理图、模块，设计包含子图符号的父图（方块图）、子
图的含义

了解“自上而下”和“自下而上”这两种层次电路设计方法

熟练掌握自上而下的层次原理图设计

教学重点：自上而下的层次原理图设计

教学难点：自上而下的层次原理图设计

复习旧课：
第12章 输出文件

12.1 输出PDF文件

12.2 生成Gerber文件

12.2.1 Gerber 文件简单介绍

12.2.2 输出Gerber文件

输出NC Drill 文件

12.3 创建材料清单（BOM）



11.1 层次设计

对于一个庞大和复杂的电子项目的设计系统，最好的设计方式是在设
计时应尽量将其按功能分解成相对独立的模块进行设计，这样的设计
方法会使电路描述的各个部分功能更加清晰。同时还可以将各独立部
分分配给多个工程人员，让他们独立完成，这样可以大大缩短开发周
期，提高模块电路的复用性和加快设计速度。采用这种方式后，对单
个模块设计的修改可以不影响系统的整体设计，提高了系统的灵活性。

为了适应电路原理图的模块化设计，Altium Designer提供了层次原理图

设计方法。所谓层次化设计，是指将一个复杂的设计任务分派成一系
列有层次结构的、相对简单的电路设计任务。把相对简单的电路设计
任务定义成一个模块（或方块），顶层图纸内放置各模块（或方
块），下一层图纸放置各模块（或方块）相对应的子图，子图内还可
以放置模块（或方块），模块（或方块）的下一层再放置相应的子
图，这样一层套一层，可以定义多层图纸设计。这样做还有一个好
处，就是每张图纸不是很大，可以方便用小规格的打印机来打印图纸
（如A4图纸）。



Altium Designer支持“自上而下”和“自下而上”这两种层次电路设计
方式。所谓自上而下设计，就是按照系统设计的思想，首先对
系统最上层进行模块划分，设计包含子图符号的父图（方块
图），标示系统最上层模块（方块图）之间的电路连接关系，
接下来分别对系统模块图中的各功能模块进行详细设计，分别
细化各个功能模块的电路实现（子图）。自顶向下的设计方法
适用于较复杂的电路设计。与之相反，进行自下而上设计时，
则预先设计各子模块（子图），接着创建一个父图（模块或方
块图），将各个子模块连接起来，成为功能更强大的上层模
块，完成一个层次的设计，经过多个层次的设计后，直至满足
项目要求。

层次电路图设计的关键在于正确地传递各层次之间的信号。在
层次原理图的设计中，信号的传递主要通过电路方块图、方块
图输入／输出端口、电路输入/输出端口来实现,他们之间有着密
切的联系。



层次电路图的所有方块图符号都必须有与该方块图符号相
对应的电路图存在（该图称为子图），并且子图符号的内
部也必须有子图输入输出端口。同时，在与子图符号相对
应的方块图中也必须有输入／输出端口,该端口与子图符号
中的输入/输出端口相对应，且必须同名。在同一项目的所

有电路图中，同名的输入／输出端口（方块图与子图）之
间，在电气上是相互连接的。

本节将以电机驱动电路为实例，介绍使用Altium Designer 进
行层次设计的方法。

图11-1是电机驱动电路的原理图（图纸的图幅是A3），虽

然该电路不是很复杂，不用层次原理图设计都可以完成
PCB板的设计任务。但还是以它为例，介绍层次原理图的

设计方法。



图11-2  电机驱动电路原理图（图纸幅面A3）
从图11-1可以看出，可以把整个图纸分成上、中、下三个部分，其中：中部分和下部分是相同的。
我们先用子图1，子图2，练习自上而下的层次原理图设计。

子图1
子图2

子图5子图3 子图4

子图6



11.1.1 自上而下层次电路图设计

自上而下的层次电路设计操作步骤如下。

1．建立一个项目文件

（1）启动Altium Designer，在主菜单中选择
“File”→“New”→“Project”→“PCB Project”命令，在当前工作空间中添加一个
默认名为“PCB_Project1.PrjPCB”的PCB项目文件，将它另存为“层次原理
图设计.PrjPCB”的PCB项目文件。

2．画一张主电路图（如：Main.SchDoc）来放置方块图（Sheet Symbol）
符号

（1）选择“Projects”工作面板中的“层次原理图设计.PrjPCB”按鼠标右
键，在弹出的菜单中选择“Add New to Project”→“Schematic”命令，在新建
的.PrjPCB项目中添加一个默认名为“Sheet1.SchDoc”的原理图文件。

（2）将原理图文件另存为“Main_top.SchDoc”，用缺省的设计图纸尺寸：
A4。其它设置用默认值。

（3）单击“Wiring”工具栏中的添加方块图符号工具按钮“ ”，或者在
主菜单中选择“Place”→“Sheet Symbol”命令。

（4）单击键盘上的“Tab”键，打开如图11-3所示的“Sheet Symbol”对话框。



在“Sheet Symbol”对话框的的属性（Properties）
栏:
designator(图纸的标号)：用于设置方块图所代

表的图纸的名称。

Filename(图纸的文件名)：用于设置方块图所代

表的图纸的文件全名（包括文件的后缀），以
便建立起方块图与原理图（子图）文件的直接
对应关系。

Unique ID(唯一的ID号): 为了在整个项目中正确

地识别电路原理图符号，每一个电路原理图符
号在项目中都有一个唯一的标识，如果需要可
以对这个标识进行重新设置。

图11-3  “Sheet 
Symbol”对话框

（5）在“Sheet Symbol”对话框的“Designator”编辑框中输入“隔离部分”，在
“Filename”编辑框内输入“隔离部分.SchDoc”，单击“OK”按钮，结束方块图符

号的属性设置。
（6）在原理图上合适位置单击鼠标左键，确定方块图符号的一个顶角位置，

然后拖动鼠标，调整方块图符号的大小，确定后再单击鼠标左键，在原理图上
插入方块图符号。



（7）目前还处于放置方块图状态，按Tab键，弹出“Sheet 
Symbol”对话框的，在“Designator”处输入“电机驱动”，在
“Filename”编辑框内输入“电机驱动.SchDoc”，重复步骤（6）
在原理图上插入第二个方块图(方框图)符号,如图11-4所示。

图11-4 放入两个方块图符号后的上层原理图



3．在方块图内放置端口

（1）单击工具栏中的添加方块图输入/输出端口工具按钮
“ ”，或者在主菜单中选择“Place”→“Add Sheet Entry”命令。

（2）光标上“悬浮”着一个端口，把光标移入“隔离部分”的
方块图内，按“Tab”键，打开如图11-5所示的“Sheet Entry”对
话框。



图11-5  “Sheet Entry”对话框

在该对话框内，几个英文的含义如下：

端口位置（Side）：用于设置端口在方块图中的位置。

端口类型（Style）:用来表示信号的传输方向。

端口的名称（Name）:是识别端口的标识。应将其设置为

与对应的子电路图上对应端口的名称相一致。

端口的输入/出类型（I/O Type）:是表示信号流向的确定参
数。它们分别是：未指定的(Unspecified)、输出端口(Output)、
输入端口(Input)和双向端口(Bidirectional)。



（5）在“隔离部分”方块图符号右边一侧单击鼠标，布置一
个名为“A_OUT”的方块图输出端口，如图11-7所示。

（3）在“Sheet Entry”对话框的“Name”编辑框中输入“A_OUT”，作为方块图端口

的名称。
（4）在“I/O”Type下拉列表中选择“Output”项，将方块图端口设为输出口（如图
11-6所示），单击“OK”按钮。

图11-7  布置的方块图端口
图11-6 在“Sheet Entry”对话框内设置
端口A_OUT为输出端口



（6）此时光标仍处于放置端口
状态，单击“Tab”键，再打开的
“Sheet Entry”对话框，在“Name”编
辑框中输入“B_OUT”，“I/O Type”
下拉菜单中选择“Output”项，单
击“OK”按钮。

（7）在“隔离部分”方块图符号

靠右侧单击鼠标，再布置一个
名为“B_OUT”的方块图输出端口。

（8）重复步骤（6）~（7），完
成C_OUT、D_OUT、VO4、VO5、
S5、+5V、GND输入/输出端口的
放置（如图11-8所示）,各端口
的类型如表11-1所示。

图11-8  布置完端口的方

块图





（9）采用步骤（1）~（4）介绍的方法，再在“电机驱动”
方块图符号中添加6个输入、电源和地的端口，在电机驱
动的方块图中各端口名称、端口类型（如表11-1所示）。
布置完端口后的上层原理图如图11-9所示。

图11-9  布置完端口后的上层原理图



4．方块图之间的连线（Wire）

在工具栏上按“ ”按钮，或者在主菜单中选择
“Place”→“Wire”命令，绘制连线，完成的子图1、子图2相对
应的方块图隔离部分、电机驱动的上层原理图如图11-10所
示。

图11-10  连接好的上层方块图



5.由方块图生成电路原理子图
（1）在主菜单中选择“Design”→“Create Sheet From Sheet Symbol”命令。

（2）单击“隔离部分”方块图符号，系统自动在“层次原理图设计.PrjPCB”
项目中新建一个名为“隔离部分.SchDoc”的原理图文件，置于
“Main_top.SchDoc”原理图文件下层。如图11-12所示。在原理图文件“隔
离部分.SchDoc ”中自动布置了如图11-13所示的9个端口，该端口中的名
字与方块图中的一致。

图11-12  系统自动创建的名为“隔
离部分.SchDoc”的原理图文件 图11-13  在“隔离部分.SchDoc”的原理图自

动生成的端口



（3）在新建的“隔离部分.SchDoc”原理图中绘制如图11-14所
示的原理图。该原理图即是图11-2椭圆所框的子图1。

图11-14  “隔离部分”方块图所对应的下一层“隔离部分.SchDoc”原理图



至此，完成了上层方块图“隔离部分”与下一层“隔离部
分.SchDoc”原理图之间的一一对应的联系。父层（上层）

与子层（下一层）之间的联系，靠上层方块图中的输入、
输出端口，与下一层的电路图中的输入、输出端口进行联
系。如上层方块图中有：A_OUT等6个端口，在下层的原理
图中也有A_OUT等6个端口，名字相同的端口就是一个点。



现在用另一种方法来完成上层方块图“电机驱动”与下一层“电机
驱动.SchDoc”的原理图之间的一一对应关系。

（4）单击工作窗口上方的“Main_top.SchDoc”文件标签，将其在工

作窗口中打开。

（5）在原理图中的“电机驱动”方块图符号上单击鼠标右键，在
弹出的如图11-15所示的右键菜单中选择“Sheet Symbol 
Actions”→“Create Sheet From Sheet Symbol”命令。

（6）在“Main_top.SchDoc”文件下层新建一个名为“电机驱
动.SchDoc”的原理图，如图11-16所示。

（7）在“电机驱动.SchDoc”原理图文件中，自动产生了如图11-17所示的9个端

口。

图11-16  新建的名为“电机驱
动.SchDoc”的原理图

图11-17  在“电机驱动.SchDoc”的原理图内自动建立的9个端口



（8）在“电机驱动.SchDoc”原理图文件中，完成如图11-
18所示的电路原理图。

图11-18  “电机驱动.SchDoc”原理图（子图2）



至此，完成了上层原理图中的方块图“电机驱动”与下层原
理图“电机驱动.SchDoc”之间一一对应的联系。“电机驱
动.SchDoc”原理图，就是图11-2所示的原理图中的子图2。
这样我们就用图11-2所示的子图1、子图2，完成了自上而

下的层次原理图设计。

在主菜单中选择“File”→“Save All”命令，将新建的3个原理图

文件和按照其原名保存。

注意：在用层次原理图方法绘制电路原理图中，系统总图
中每个模块的方块图中都给出了一个或多个表示连接关系
的电路端口，这些端口在下一层电路原理图中也有相对应
的同名端口，它们表示信号的传输方向也一致。Altium
Designer使用这种表示连接关系的方式构建了层次原理图的

总体结构，层次原理图可以进行多层嵌套。



6．层次原理图的切换

（1）上层（方块图）→下层（子原理图），在工具栏按
层次切换工具按钮“ ”或在主菜单中选择“Tools”→“Up/Down 
Hierarchy”，光标变成“十”字形，选中某一方块图，单击鼠

标左键即可进入下一层原理图。

（2）下层（子原理图）→上层（方块图），在工具栏按
层次切换工具按钮“ ”或在主菜单中选择“Tools”→
“Up/Down Hierarchy”，光标变成“十”字形，将光标移动到子电

路图中的某一个连接端口并单击鼠标左键即可回到上层方
块图。

注意：一定要用鼠标左键单击原理图中的连接端口，否则
回不到上一层图。



小结：

11.1.1 自上而下层次电路图设计

自上而下的层次电路设计操作步骤如下。

1．建立一个项目文件

2．画一张主电路图（如：Main.SchDoc）来放置方块图（Sheet 
Symbol）符号

3．在方块图内放置端口

4．方块图之间的连线（Wire）
5. 由方块图生成电路原理子图

（1）在主菜单中选择“Design”→“Create Sheet From Sheet Symbol”
命令

（2）在原理图中的“电机驱动”方块图符号上单击鼠标右键，在弹出的
菜单中选择“Sheet Symbol Actions”→“Create Sheet From Sheet 
Symbol”命令。

6．层次原理图的切换



11.1.2 自下而上的层次电路图设计

教学目的及要求：
1. 了解层次原理图、模块，设计包含子图符号的父图（方块图）、子图的含义
2. 了解“自上而下”和“自下而上”这两种层次电路设计方法
3. 熟练掌握自下而上的层次原理图设计
教学重点、难点：自下而上的层次原理图设计

复习：
自上而下的层次电路设计操作步骤如下。
1．建立一个项目文件
2．画一张主电路图（如：Main.SchDoc）来放置方块图（Sheet Symbol）符号
3．在方块图内放置端口
4．方块图之间的连线（Wire）
5. 由方块图生成电路原理子图
（1）在主菜单中选择“Design”→“Create Sheet From Sheet Symbol”命令
用另一种方法来完成上层方块图“电机驱动”与下一层“电机驱动.SchDoc”的原理图

之间的一一对应关系。
（4）单击工作窗口上方的“Main_top.SchDoc”文件标签，将其在工作窗口中打开。
（5）在原理图中的“电机驱动”方块图符号上单击鼠标右键，在弹出的右键菜单

中选择“Sheet Symbol Actions”→“Create Sheet From Sheet Symbol”命令。
6．层次原理图的切换



11.1.2 自下而上的层次电路图设计

Altium Designer还支持传统的自下而上的层次电路
图设计方法，本节将采用图11-2所示的子图3、子图4、子
图5，练习自下而上的设计方法，为电机驱动电路添加电
源。

1．完成各个子电路图（如：sub3.schdoc、sub4.schdoc、
sub5.schdoc），并在各子电路图中放置连接电路的输入/
输出端口，

（1）启动Altium Designer，打开上一

节中创建的上层原理图文件
“Main_top.SchDoc”。
（2）单击主菜单
“File”→“New”→“Schematic”命令新建
一个默认名称为“Sheet1.SchDoc”的空

白原理图文档。将它另存为
“Sub3.SchDoc”（ 如图11-19所示）。

图11-19 新建Sub3.SchDoc



（3）在“Sub3.SchDoc”原理图文档中绘制如图11-20所示的电

路。

图11-20 子图3（Sub3.SchDoc）



（4）在“Sub3.SchDoc”电路图中放置与其它电路图连接的输入/输
出端口，鼠标单击工具栏中按钮“ ”（或在主菜单栏选
“Place”→“Port”），鼠标上“悬浮”着一个端口，按TAB键弹出
“Port Properties”对话框，如图11-21所示，在“Name”编辑框输
入端口的名字：“IN_5”,“I/O Type”编辑框选择“Unspecified”，
按OK按钮，在需要的位置放置端口即可。

图11-21 Port Properties对话框



（5）按步骤（4）放置端口:+5V、SGND、S5，这3个端口的
I/O Type都选择“Unspecified”。放置完端口的电路图如图

11-22所示。

图11-22  放置端口的电路图



2．从下层原理图产生上层方块图

（1）如果没有上层电路图文档，就要产生一张电路图文档。方法：单击主
菜单“File”→“New”→“Schematic”命令新电路图文档。在本例中，已有主电
路图文档“Main_top.SchDoc”，所以用步骤(2)，打开它即可。

（2）单击“Projects”工作面板中“Main_top.SchDoc”文件的名称，在工作区打

开该文件。注意：一定要打开该文件，并在打开该文件的窗口下，执行步
骤（3）。

（3）在主菜单中选择“Design”→“Creat Sheet Symbol From Sheet or HDL”
命令，打开如图11-23所示的“Choose Document to Place”对话框。

图11-23  “Choose Document to Place”对话框



（4）在 “Choose Document to Place”对话框中选择
“sub3.SchDoc”文件，单击“OK”按钮，回到
“Main_top.SchDoc”窗口中，鼠标处“悬浮”着一个方块图，

如图11-24所示，在适当的位置，按鼠标左键，把方块图
放置好（如图11-25所示）。

图11-24鼠标处“悬浮”的方块图符号 图11-25  放置好的方块图符号



3．重复以上步骤完成子图
4(Sub4.SchDoc)及子图4的
方块图，完成子图
5(Sub5.SchDoc)及子图5的
方块图。

4．完成后的子图
4(Sub4.SchDoc)，子图
5(Sub5.SchDoc)的电路图
如图11-26，11-27所示。 图11-26子图4(Sub4.SchDoc)

图11-27子图5(Sub5.SchDoc)



5．完成子图3、子图4、子图5的方块图，如图11-28所示。

图11-28 上层方块库



6．再看图11-2，还有子图6的没有完成，子图6即可用自上
而下的方法完成，也可以用自下而上的方法完成。

（1）如果用自下而上的方法，放置完电路输入输出的端口
的电路如图11-29所示。

（2）单击“Projects”工作面板中“Main_top.SchDoc”文件的名

称，在工作区打开该文件，在主菜单中选择
“Design”→“Creat Sheet Symbol From Sheet or HDL”命
令，打开“Choose Document to Place”对话框。选择
“Sub6.SchDoc”文件，然后按OK按钮，即鼠标处“悬浮”着一
个子图6的方块图。在“Main_top.SchDoc”中的合适位置，

按鼠标左键，放置好方块图。放置好6个方块图的
“Main_top.SchDoc”电路如图11-30所示。



图11-29子图6（Sub6.SchDoc）



图11-30放置完6个方块图的Main_top.SchDoc上层原理图



7．在主电路图(Main_top.SchDoc)内连线，在连线过程中，可以用鼠标
移动方块图内的端口（端口可以在方块图的上下左右四个边上移动）
，也可改变方块图的大小，完成后的主电路图(Main_top.SchDoc)如
图11-31所示。

图11-31 绘制完成的上层方块图



8．检查是否同步，也就是方块图入口与端口之间是否匹配，选择菜单
“Design”→“Synchronize Sheet Entries and Ports”命令，如果方块
图入口与端口之间匹配，则显示对话框“Synchronize Ports to 
Sheet Entries In 层次原理图设计.PrjPCB”，告知“All Sheet 
symbols are matched”，如图10-32所示。

图10-32 显示方块图入口与端口之间匹配



9．选择“File”→“Save All”命令，保存项目中的所有文件。

至此，采用自上而下、自下而上的层次设计方法设计电机驱
动电路过程结束。图11-2所示的电路原理图，可以用图
11-31所示的层次原理图代替，6个方块图分别代表6个子
图，它们的数据要转移到一块电路板里，设计PCB板的过
程与单张原理图差不多，唯一的区别是，编译原理图的时
候，必须在顶层。

注意在设计层次原理图的每张子电路图时，必须把每
个元件的封装选择好，这样便于设计PCB板。



小结：
11.1.2 自下而上层次原理图设计

1．完成各个子电路图（如：sub3.schdoc、sub4.schdoc、
sub5.schdoc），并在各子电路图中放置连接电路的输入/输出端口，

2．从下层原理图产生上层方块图
（1）如果没有上层电路图文档，就要产生一张电路图文档。方法：单击

主菜单“File”→“New”→“Schematic”命令新电路图文档。在本例中，已
有主电路图文档“Main_top.SchDoc”，所以打开它即可。

（2）单击“Projects”工作面板中“Main_top.SchDoc”文件的名称，在工作
区打开该文件。

（3）在主菜单中选择“Design”→“Creat Sheet Symbol From Sheet or 
HDL”命令。

（4）在 “Choose Document to Place”对话框中选择“sub3.SchDoc”文
件，单击“OK”按钮，回到“Main_top.SchDoc”窗口中，鼠标处“悬浮”着
一个方块图，在适当的位置，按鼠标左键，把方块图放置好。

3．方块图之间的连线
4．层次原理图的切换



11.1.3 层次电路图的PCB设计
教学目的及要求：
1. 熟练掌握把层次原理图的数据转移到PCB内
2. 进一步熟悉排PCB板的方法

教学重点、难点：层次原理图的数据转移到PCB内
复习：
1．完成各个子电路图（如：sub3.schdoc、sub4.schdoc、sub5.schdoc），并

在各子电路图中放置连接电路的输入/输出端口，
2．从下层原理图产生上层方块图
（1）如果没有上层电路图文档，就要产生一张电路图文档。方法：单击主菜单

“File”→“New”→“Schematic”命令新电路图文档。在本例中，已有主电路图
文档“Main_top.SchDoc”，所以打开它即可。

（2）单击“Projects”工作面板中“Main_top.SchDoc”文件的名称，在工作区打开
该文件。

（3）在主菜单中选择“Design”→“Creat Sheet Symbol From Sheet or HDL”命令。
（4）在 “Choose Document to Place”对话框中选择“sub3.SchDoc”文件，单击

“OK”按钮，回到“Main_top.SchDoc”窗口中，鼠标处“悬浮”着一个方块图，
在适当的位置，按鼠标左键，把方块图放置好。

3．方块图之间的连线
4．层次原理图的切换



11.1.3 层次电路图的PCB设计

在一个项目里，不管是单张电路图，还是
层次电路图，有时都会把所有电路图的数据转移
到一块PCB板里，所以没用的电路图子图必须
删除。

（1）用前面介绍的方法在Projects面板里产生一个
新的PCB板，默认名为：“PCB1.PcbDoc”，把
它另存为“电机驱动电路.PcbDoc”。

（2）重新定义PCB板的形状。选择菜单
“Design”→“Board Shape”→“Redefine Board 
Shape”，鼠标单击（25mm，25mm）、
（115mm，25 mm）、（115mm，145mm）、
（25mm，145mm）点。

（3）绘制一个PCB板的板框，选择“Keep-Out 
Layer”层，画出长80mm,高110mm的边框。鼠
标单击（30mm，30mm）、（110mm，
30mm）、（110mm，140mm）、（30mm，
140mm）、（30mm，30mm）点绘出PCB板布
线区域。在一个角上绘制一个半径2mm的圆
弧，然后把该圆弧复制3个放在每个角上，把每
个角上多余的线删除，让PCB边框的4个角变成
圆角，如图11-33所示。

图11-33 PCB板边框



(4)检查每个元件的封装是否正确，可以打开封装管理器。选择菜单
“Tools”→“Footprint Manager”,弹出“Footprint Manager”对话框，在该

对话框内，检查所有元件的封装是否正确。

(5)打开原理图（Main_top.SchDoc），检查原理图（Main_top.SchDoc）
有无错误，执行“Project”→“Compile PCB Project 层次原理图设
计.PrjPCB”命令。

如果有错，则在messages面板有提示，按提示改正错误后，重新编

译，没有错误后进行以下操作。

(6)执行“Design”菜单下的“Update PCB Document 电机驱动电
路.PcbDoc”命令。出现如图11-34所示的“Engineering Change Order”
对话框。

图11-34 数据转移对话框



（7） 按“”按钮验证一下有无不妥之处，程序将验证结果反
应在对话框中，如图11-35所示。

图11-35验证更新



（8）在图11-35中，如果所有数据转移都顺利，没有错误产
生，则按“”按钮执行真正的操作，然后按“Close”按钮关闭
此对话框，原理图的信息转移到“电机驱动电
路.PcbDoc”PCB板上，如图11-36所示。

图11-36 数据转移到“电机驱动电路.PcbDoc”的PCB板上



（9）在图11-36中包括
6个零件摆置区域
（上述设计的6个模

块电路），分别将这
6个区域的元件移动
到PCB板的边框内，

用前面介绍的方法完
成布局、布线的操
作，在此不赘述。

设计好的“电机驱
动电路.PcbDoc”的
PCB板如图11-37所
示。

图11-37 设计好的电机驱动电路PCB板



制作的机器人“电机驱动电路”PCB板的实物如图11-38所示。

图11-38机器人电机驱动电路PCB板实物



小结：

11.1.3 层次电路图的PCB设计

（1）在Projects面板里产生一个新的PCB板。

（2）重新定义PCB板的形状。

（3）绘制一个PCB板的板框。

（4）检查每个元件的封装是否正确。

（5）执行“Project”→“Compile PCB Project 层次原理图设计.PrjPCB”命
令。

（6）执行“Design”菜单下的“Update PCB Document 电机驱动电
路.PcbDoc”命令。

（7） 按“ ”按钮验证一下有无不妥之处。

（8）如果所有数据转移都顺利，没有错误产生，则按

“ ”按钮。

（9）设计PCB板。



11.2 多通道电路设计

教学目的及要求：
1. 了解多通道设计方法的含义
2. 熟练掌握多通道电路设计方法

教学重点、难点：多通道电路设计方法

复习：
11.1.3 层次电路图的PCB设计
（1）在Projects面板里产生一个新的PCB板。
（2）重新定义PCB板的形状。
（3）绘制一个PCB板的板框。
（4）检查每个元件的封装是否正确。
（5）执行“Project”→“Compile PCB Project 层次原理图设计.PrjPCB”命

令。
（6）执行“Design”菜单下的“Update PCB Document 电机驱动电

路.PcbDoc”命令。
（7） 按“ ”按钮验证一下有无不妥之处。
（8）如果所有数据转移都顺利，没有错误产生，则按“ ”按钮。
（9）设计PCB板。



11.2.1多路滤波器的原理图设计

Altium Designer支持多通道设计，简化具有多个完全

相同的子模块的电路的设计工作。本节将通过多路滤波器
的设计，介绍多通道电路设计方法。

下图所示为一个六通道多路滤波器的设计电路原理图。



由于六个通道的电路是完全一致的，所以可以采用多

通道设计方法设计电路，具体设计步骤如下。

（1）启动Altium Designer，创建名称为“多路滤波
器.PrjPCB”的项目。

（2）在“多路滤波器.PrjPCB”的项目中新建一个空白原理图
文档，把它另存为：单路滤波器.SchDoc。

（3）在新建的空白原理图中绘制如图11-40所示的单路滤波
器.SchDoc。

图11-40  绘制的单路滤波器电路原理图

（4）单击通用工具栏中的保存工具按钮“”，保存原理图文

件。



（5）选择“Projects”工作面板，在项目中再次新建一个空白
原理图文档。

（6）在空白原理图文档窗口内，在主菜单中选择
“Design”→“Create Sheet Symbol From Sheet or HDL”命
令，打开如图11-41所示的“Choose Document to Place”
对话框。

图11-41 “Choose Document to Place”对话框

（7）在“Choose Document to Place”对话框中选择“单路滤
波器.SchDoc”文件名，单击“OK”按钮，在原理图文档中添
加如图11-42所示的方块图符号。



（8）双击方块图符号名称“U_单路滤波器”，打开如图11-43
所示的“Sheet Symbol Designator”对话框，将“Designator”
编辑框内的内容修改为“Repeat（单路滤波器，1，6）”，
单击回车键。

图11-42  添加的方块图符号

图11-43  “Sheet Symbol Designator”对话框



（9）双击方块图符号中的端口“Vin”，打开“Sheet Entry”对
话框，在“Name”编辑框内输入“Repeat（Vin）”，然后单
击“OK”按钮。将端口的名称改为“Repeat（Vin ）”。

(10) 双击方块图符号中的端口“Vout”，打开“Sheet Entry”对
话框，在“Name”编辑框内输入“Repeat（Vout）”，然后
单击“OK”按钮。将端口的名称改为“Repeat（Vout ）”，
修改完成后的子图符号如图11-44所示。

图11-44 修改后的子图符号

通过将方块图符号名称修改为
“Repeat（单路滤波器，1，6）”，表
示将如图11-42所示的单元电路复制了
6个。将“Vin”端口名称改为“Repeat
（Vin）”语句，则表示每个复制的电路
中的“Vin”端口都被引出来，将“Vout”端
口名称改为“Repeat（Vout）”语句，
则表示每个复制的电路中的“Vout”端口

都被引出来，而各通道的其他未加
“Repeat”语句的电路同名端口都将被

互相连接起来。



（11）在原理图中添加其他元件，绘制如图11-45所示的电
路图。

图11-45 绘制的六通道多路滤波器电路原理图

（12）单击通用工具栏中的保存工具按钮“”，在弹出的“Save 
[Sheet1.schdoc] As”对话框的“文件名”编辑框内输入“多路滤波
器”，单击“保存”按钮，即将电路图文件保存为“多路滤波
器.SchDoc”。

至此，采用多通道技术设计的六通道多路滤波器电路原理
图任务完成。从图11-45与图11-39比较，图11-45完全可以取
代图11-39，图11-45的原理图清晰、明了、简单。可以看出在
一个电路系统中，如果原理图比较复杂，对于具有多个重复的
电路部分时，用多通道设计方法设计很简单。



11.2.2多路滤波器的PCB设计

1.检查电路正确否，执行
“Project”→“Compile PCB Project 多
通道设计.PrjPcb”命令。

如果有错，则在messages面板

有提示，按提示改正错误后，重新
编译，如果没有信息（messages）
窗口弹出，表示没有错误。

2.执行“Design” →“Update PCB 
Document 多路滤波器.PcbDoc”命
令。出现“Engineering Change 
Order”对话框。

按“ ”按钮验证一下有无不妥之处，如果没有错误，所有
数据转移都顺利，则按“ ”按钮执行真正的操作，然后按
“Close”按钮关闭此对话框，原理图的信息转移到“电机驱动电
路.PcbDoc”PCB板上，如图11-46所示。

图11-46 数据转移到“多路滤波器.PcbDoc”的PCB板上



3.从图11-46看出，元件的标号是乱的，所以重新标注PCB
板上元件的标号。执行菜单“Tools”→“Re-Annotate”命
令，弹出图11-47对话框，选择“4By Descending Y Then 
AscendingX”，按OK按钮。重新标注的PCB板如图11-48
所示，注意元件的标号发生了改变，按重上到下的顺序排
列。

图11-47 重新标注对话框

图11-48 重新标注后的PCB板



4.手动布局、自动布线的PCB如图11-49所示。

图11-49 多路滤波器PCB图

从图11-49看出，元件标号的位置不好，可

以统一调整如下：
（1）打开“PCB Filter”面板，在“Find items 
matching these criteria:”栏，输入
“IsComponent”语句，选择“Objects passing 
the filter”栏内的复选框：“Select”，按
“Apply”按钮，选中PCB板上的所有元件。
（2）鼠标放在任一选中元件上，按鼠标右

键，弹出下拉菜单。
（3）在下拉菜单上选择“Align”→“Position
Component Text”,弹出“Component Text 
Position”对话框，如图11-50所示。
（4）在图11-50的“Designator”区域，可选
择元件标号在元件上的位置，有9个选择（9
个单选按钮），在这里选择元件中上方的位
置，如箭头光标所示。
（5）按“OK”按钮，每个元件的标号就自动
在每个元件的中上方的位置上，如图11-51
所示。

图11-50 Component Text 
Position对话框



（7）打开“PCB Inspector”面板,在“Ratation”处：输入360，如图
11-52所示，按回车键,所有选中的标号就变成水平方向了，如
图11-52所示。

图11-51 重新对齐元件的标号

（6）把图11-51的元件标号统一旋转成水平方向的。打开“PCB 
Filter”面板，在“Find items matching these criteria:”栏，输入
“IsDesignator”语句，按“Apply”按钮，选中PCB板上所有元件的

标号。

图11-52 PCB Inspector面板 标号旋转3600



5.由于PCB板上元件的标号是从新标注过的，
与原理图上的标号不一致，所以需要把PCB板上重

新标注的元件的标号信息更新到原理图上。

图11-45所示的六通道多路滤波器电路原理图编译没有错
误后，编译后单路滤波器电路图自动变成了6张，每张原理图
的标签如图11-53所示。

图11-53 编译后单路滤波器电路图的标签



（1）选择“单路滤波器2”标签，该张电路图如图11-54所示：

图11-54单路滤波器2的原理图

（2）注意元件的标号信息有一个“单路滤波器2”。
（3）打开“多路滤波器.PcbDoc”的PCB图，执行菜单
“Design”→ “Update Schematics in 多通道设计.PrjPcb”命令。
弹出“Engineering Change Order”对话框，如图11-55所示。



图11-55 原理图元件的标号将变成与PCB
元件的标号一致

（4）按“”按钮验证一下

有无不妥之处，如果没
有错误，则按“”按钮执

行真正的操作，然后按
“Close”按钮关闭此对话
框，PCB的信息更新到

原理图上。
（5）现在选择“单路滤
波器2”标签，该张电路
图如图11-56所示：

图11-56 原理图的标号被更新



小结：
11.2.1多路滤波器的原理图设计
（1）启动Altium Designer，创建名称为“多路滤波器.PrjPCB”的项目。
（2）在“多路滤波器.PrjPCB”的项目中新建一个空白原理图文档。
（3）在新建的空白原理图中绘制单路滤波器.SchDoc。
（4）保存原理图文件。
（5）选择“Projects”工作面板，在项目中再次新建一个空白原理图文档。
（6）在空白原理图文档窗口内，在主菜单中选择“Design”→“Create Sheet 

Symbol From Sheet or HDL”命令。
（7）在“Choose Document to Place”对话框中选择“单路滤波器.SchDoc”文件

名，单击“OK”按钮。
（8）将“Designator”编辑框内的内容修改为“Repeat（单路滤波器，1，6）”。
（9）将端口的名称改为“Repeat（Vin ）”。
（10）将端口的名称改为“Repeat（Vout ）”。
（11）在原理图中添加其他元件，绘制如图11-45所示的电路图。

11.2.2多路滤波器的PCB设计
1.检查电路正确否，执行“Project”→“Compile PCB Project 多通道设计.PrjPcb”命

令。
2.执行“Design” →“Update PCB Document 多路滤波器.PcbDoc”命令。
3.从图11-46看出，元件的标号是乱的，所以重新标注PCB板上元件的标号。
4.设计 PCB板
5.把PCB板上重新标注的元件的标号信息更新到原理图上。



作业：

P248 
5. 多通道设计的基本思想是什么？

6. 简述层次电路原理图设计与多通道设计的异同？



11.2 多通道电路设计

教学目的及要求：
1. 了解电路仿真的基本知识介绍

2. 熟悉电路仿真的步骤

3. 熟练掌握多谐振荡器电路的仿真

教学重点、难点：多谐振荡器电路的仿真

复习：
11.2.1多路滤波器的原理图设计

11.2.2多路滤波器的PCB设计

1.检查电路正确否，执行“Project”→“Compile PCB Project 多通道设
计.PrjPcb”命令。

2.执行“Design” →“Update PCB Document 多路滤波器.PcbDoc”命令。

3.从图11-46看出，元件的标号是乱的，所以重新标注PCB板上元件的
标号。

4.设计 PCB板
5.把PCB板上重新标注的元件的标号信息更新到原理图上。



13.1仿真元件库

Altium Designer为用户提供了大部分常用的仿真元
件，这些仿真元件库在安装目录下的：/Altium Designer 
Winter 09/Library/Simulation中，其中包含了仿真信号源
库Simulation Sources.IntLib、仿真特殊功能元件库
Simulation Special Function.IntLib、仿真数学功能元件库
Simulation Math Function.IntLib、信号仿真传输线元件库
Simulation Transmission Line.IntLib，仿真Pspice功能元
件库Simulation Pspice Function.IntLib,其元件库图标如图
13-1所示。

图13-1 仿真元件库图标



13.1.1仿真信号源元件库（Simulation Sources.IntLib）

仿真信号源元件库中共有23个仿真元件，这些仿真源

为仿真电路提供激励源和初始条件设置等功能。

1.  在原理图中添加如图13-4所示的两个元件符号，即可实

现整个仿真电路的节点电压和初始条件设置。

⑴ .NS。NODE SET （节点设置）

⑵ .IC。Initial Condition （初始条件）

图13-4 节点设置和初始条件状态定义符



13.1.2仿真数学函数元件库（Simulation Math Function. IntLib）
仿真数学函数元件库中的元件主要是一些仿真数学函数元件，比

如求正弦、余弦、绝对值、反正弦、反余弦、开方等数学计算的函
数，通过使用这些函数可以对仿真信号进行相关的数学计算，从而得
到自己需要的信号。

13.1.3仿真特殊功能元件库（Simulation Special Function. IntLib）
仿真特殊功能元件库的元件主要是常用的运算函数，比如增益、

加、减、乘、除、求和和压控振荡源等专用的元件。

13.1.4信号仿真传输线元件库（Simulation Transmission Line. IntLib）
信号

仿真传输线元件库包括三个信号仿真传输线元件，分别是URC均
匀分布传输线、LTRA有损耗传输线和LLTRA无损耗传输线，如图13-
14所示。

图13-14传输线元件



13.1.5仿真Pspice功能元件库（Simulation Pspice Function.IntLib）
仿真Pspice功能元件库主要为设计者提供Pspice功能元件。

13.2仿真器的设置
完成电路的编辑后，在仿真之前，要选择对电路进行

那种分析，设置收集的变量数据，以及设置显示哪些变量
的波形。常见的仿真分析有静态工作点分析（Operating 
Point Analysis）、瞬态分析（Transient Analysis）、直
流扫描分析（DC Sweep Analysis）、交流小信号分析
（AC Small Signal Analysis）、噪声分析（Noise 
Analysis）、极点、零点分析（Pole-Zero Analysis）、传
递函数分析（Transfer Function Analysis）、温度扫描分
析（Temperature Sweep）、参数扫描（Parameter 
Sweep）、蒙特卡洛分析（Monte Carlo Analysis）等分
析。本章主要讲解后面例子中用到的静态工作点分析、瞬
态分析和交流小信号分析的设置方法。



执行Design→Simulate→Mixed
Sim命令,弹出如图13-15所示的电路
仿真分析设置对话框。

13.2.1一般设置（General 
Setup）

在仿真分析设置对话框的左
侧分析选项列表中，列写出了所
有的分析选项，选中每个分析选
项，右侧即显示出相应的设置项。
选中General Setup，即可在右侧
的选项中进行一般设置。在
Available Signals 列表中显示的
是可以进行仿真分析的信号，
Active Signals列表框中显示的是
激活的信号，将需要进行仿真的
信号，单击 “ ”和 “ ” 可完成
添加或删除激活信号，如图13-
15所示。

图13-15 仿真分析设置对话框

可 进 行 仿
真的信号

激 活 的 信
号

添 加 或 删
除按钮



13.2.2静态工作点分析（Operating Point Analysis）
静态工作点分析通常用于对放大电路进行分

析，当放大器处于输入信号为零的状态的时候，电
路中各点的状态就是电路的静态工作点。最典型的
是放大器的直流偏置参数。进行静态工作点分析的
时候，不需要设置参数。

13.2.3瞬态分析（Transient Analysis）
瞬态分析用于分析仿真电路中工作点信号随时

间变化的情况。进行瞬态分析之前，设计者要设置
瞬态分析的起始和终止时间、仿真时间的步长等参
数。在电路仿真分析设置对话框中，激活Transient
选项，在如图13-17所示的瞬态分析参数设置对话框

中进行设置。



图13-17 瞬态分析参数设置对话框



在Transient Analysis Setup列表中共用11个参数设置选项，这些参数的
含义分别是：

Transient Start Time参数用于设置瞬态分析的起始时间。瞬态分析通常
从时间零开始，在时间零和开始时间，瞬态分析照样进行，但并不保存结果。
而开始时间和终止时间的间隔将保存，并用于显示。

Transient Stop Time参数用于设置瞬态分析的终止时间。

Transient Step Time参数用于设置瞬态分析的时间步长，该步长不是固
定不变的。

Transient Max Step Time参数用于设置瞬态分析的最大时间步长。

Use Initial Conditions项用于设置电路仿真的初始状态。当勾选该项后，
仿真开始时将调用设置的电路初始参数。

Use Transient Default项用于设置使用默认的瞬态分析设置，选中该项
后，列表中的前四项参数将处于不可修改状态。

Default Cycles Displayed参数用于设置默认的显示周期数。

default Points Per Cycle参数用于设置默认的每周期仿真点数。

Enable Fouries项用于设置进行傅立叶分析，勾选该项后，系统将进行傅
立叶分析，显示频域参数。

Fouries Fundamental Frequency用于设置进行傅立叶分析的基频。

Fouries Number of Harmonics用于设置进行傅立叶分析的谐波次数。



13.2.4交流小信号分析（AC Small Signal Analysis）

交流小信号分析用于对系统

的交流特性进行分析，在频域响
应方面显示系统的性能，该分析
功能对于滤波器的设计相当有
用，通过设置交流信号分析的频
率范围，系统将显示该频率范围
内的增益。在电路仿真分析设置
对话框中，激活AC Small Signal 
Analysis选项，在如图13-18所示

的交流小信号分析参数设置对话
框中进行设置。

图13-18 交流小信号分析参数设置对话框

其中Start Frequency参数用于设置进行交流小信号分析的起始频率。
Stop Frequency参数用于设置进行交流小信号分析的终止频率。
Sweep参数用于设置交流小信号分析的频率扫描的方式，系统提供了三种频率扫描

方式“Linear”项表示对频率进行线性扫描，“Decade”项表示采用10的指数方式进行扫
描，“Octave”项表示采用8的指数方式进行扫描。

Test Points参数表示进行测试的点数。
Total Test Points参数表示中的测试点数。



13.3多谐振荡器电路仿真实例

在学习前面关于电路仿真的基本知识后，将对第二章

的多谐振荡器电路进行仿真。电路仿真的一般步骤如下：

1. 找到仿真原理图中所有需要的仿真元件，如果仿真元件
库中没有所用的元件，必须事先建立其仿真库文件，并
添加仿真模型。本章后面的模拟放大电路仿真和BCD-7 
段译码电路仿真实例中将讲解这部分内容，但元件的仿
真库文件的建立方法在本教材中不做要求。

2. 仿真元件的放置和电路的连接，并且添加激励源。

3. 在需要绘制仿真数据的节点处添加网络标号。

4. 仿真器参数设置。

5. 电路仿真并分析仿真结果。



13.3.1绘制仿真原理图

在第二章中已经绘制了多谐振荡器电路，如图2-1所
示。其中每个元件都具有其仿真属性，因此不用更改。只
需将接口Y1删除，添加一个+12V的电压源V1，方法：单
击“Utility”工具栏中的工具按钮，打开如图13-20所示的仿
真电源工具栏，在工具栏中单击“+12V”电压源工具按钮，
在工作区放置一个+12V的电压源。

图13-20 放置激励源+12v的电压源



放置完毕后，点击元件，弹出元件属性对话框，如图13-
21所示，修改其参数，设置Designator为“V1”、Comment为
“=Value”、Value为“+12”。

图13-21 仿真电压源属性设置对话框

图13-22 多谐振荡器仿真原理图

连接电路，并放置网络
标号：Q1B、Q1C、Q2B、
Q2C，如图13-22所示。



13.3.2仿真器参数设置

1.单击 “ ” 按钮，弹出13-23所示的对话框，分别双击Q1B、Q1C、
Q2B、Q2C，把他们添加到Active Signals内，见图13-23。

2.在Collect Data For栏，从列表中选择“Node Voltage，Supply 
Current，Device Current and Power”。

3.为这个分析勾选“Operating Point Analysis”和“Transient Analysis”。

图13-23 仿真器一般参数设置



4.激活Transient Analysis选项,设置Transient Stop Time
为10ms，指定一个10ms的仿真窗口；设置Transient Step 
Time为10us，表示仿真可以每10us显示一个点；设置
Transient Max Step Time:10us；如图13-24所示。

图13-24 瞬态特性参数设置



13.3.3信号仿真分析

单击 “ ” 按钮运行仿真，仿真波形如图13-25所示。

图13-25 瞬态分析仿真波形

读者可以改变一些原理图中元件参数，再运行仿真看看
其变化。试着将C1的值改为47n，然后再运行瞬态特性分析。

输出波形将显示一个不均匀的占空比波形。



小结：

13.1仿真元件库

13.2仿真器的设置

13.3多谐振荡器电路仿真实例
13.3.1绘制仿真原理图

13.3.2仿真器参数设置

13.3.3信号仿真分析



第14章 Altium Designer与Protel 99SE的转换

任务描述

由于Protel 99SE软件用得非常广泛，所以在他基础上
有很多资源，比如建立的元器件库、设计的电路原理图、
PCB板等，为了使用以前的工作成果，减少重复劳动，所
以需要把Protel99SE上建的元器件库、设计的PCB板等导
入Altium Designer中。

由于有的PCB板制造厂家制造PCB板时，用的是
Protel 99SE的软件，而用户设计PCB板是用Altium
Designer软件，为了生产，有时又需要把用Altium
Designer软件设计的PCB板转换成Protel 99SE的格式。
所以本章介绍以下内容：

将Protel 99SE元器件库导入Altium Designer中；

将Protel 99SE设计的文件导入Altium Designer中；

将Altium Designer中设计的文件导入Protel 99SE中。



第14章 AD9与protel99se转换

教学目的及要求：
1. 熟悉将Protel 99SE元器件库导入Altium Designer中
2. 熟悉将Altium Designer的元件库转换成99SE的格式

3. 将Altium Designer设计的文件转换为99SE格式

教学重点、难点：将Protel 99SE元器件库导入Altium Designer中

复习：

13.1仿真元件库

13.2仿真器的设置

13.3多谐振荡器电路仿真实例
13.3.1绘制仿真原理图

13.3.2仿真器参数设置

13.3.3信号仿真分析



14.1 将Protel 99SE器件库导入Altium Designer中

在许多工作中，用户常需要导入以前版本的Protel元
器件库。为了介绍该方法请用户从Altium.com网站上下载

元器件库。

（1）在
http://www2.altium.com/forms/libraries/p99se/library_list.
asp下载Atmel_003112000.zip元件库并保存在用户自己
建立的“F:\ad9\99SE库文件下载”文件夹下。

（2）下载完成后将其解压，解压后为Atmel.ddb。
在硬盘上建立“F:\Altium Designer9\Protel99se库文

件转AD9”文件夹，用于存放导入的库文件。

（3）启动Altium Designer软件，执行File → Import 
Wizard命令，打开如图14-1对话框。



按照提示，点击Next，在出现的对话框中选择99SE 
DDB Files。如图14-2所示。

点击Next，出现如图14-3所示的“Choose files or 
folders to import”对话框。

图14-1 Import Wizard对话框 图14-2 选择导入文件的类型



该对话框用于设置需要导入
的文件，如果用户需要批量导入
文件，可以单击左侧的“Folders 
To Process”列表下方的“Add”按
钮，打开“浏览文件夹”对话框，
选择需要批量导入的文件所在的
目录，这样可以一次将所选目录
下的所有“.DDB”文件全部导入。
如果需要一次导入多个“.DDB”
文件，可以单击右侧的“Files To 
Process”列表下方的“Add”按
钮，打开“浏览文件夹”对话框，
选择需要批量导入的文件。

本例选择右边的“Add”按
钮，选择“F:\ad9\99SE库文件下
载
\Atmel_003112000\Atmel.ddb”
文件，如图14-3所示。

图14-3 选择导入的文件



点击Next，出现选择输出文件夹对话框，“Set file extraction options”
对话框中的“Output Folder”编辑框用于设置导入后的文件保存的路径，如
图14-4所示，最好记住该路径。

图14-4 Set File extraction options对话框

在“Set file extraction options”对话框中单击“Output Folder”编辑框右侧
的浏览按钮，打开“浏览文件夹”对话框，在“浏览文件夹”对话框内选择导入
文件的保存路径，单击“确定”按钮，然后单击“Set file extraction options”对
话框中的“Next”按钮，出现“Set Schematic conversion options”对话框，该

对话框用于设置原理图导入选项，本例中没有原理图，所以不需要设置该对
话框，如图14-5所示。



点击“Next”出现“Set import options"对话框，可以选择为
每个DDB文件创建一个Altium Designer项目,还是为每个DDB
文件夹创建一个Altium Designer项目。以及是否在项目中创
建PDF或者Word说明文档，如图14-6所示。

图14-5  Set Schematic conversion options选项 图14-6 Project Mapping Options对话框



用户可以根据自己使用DDB的需要选择合适的选项，
点击“Next”，出现选择导入设计文件的对话框，如图14-7所
示，确认没有问题。则点击“Next”进入下一步。然后会出现
Review project creation对话框，如图14-8所示。

图14-7 选择导入文件对话框 图14-8 Review project creation对话框

在图14-8所示对话框内，显示了Protel 99SE的具体哪些
文件将转换成对应的Altium Designer内的文件。



点击“Next”，出现Import summary对话框，如图14-9所示，该对话框
告知源文件发现了一个DDB文件，目标文件将产生一个工作空间、一个集
成库包。检查无误后便可进人下一步。若有错误，则退回相应步骤重新修
改。

单击“Next”按钮，开始导入过程，导入完成后，显示如图14-10所示的
“Importing is done.Choose workspace to open”对话框。选择该对话中列
表内的新建的工作空间，单击“Next”按钮，出现“Protel 99 SE DDB Import 
Wizard is complete”对话框，点击“Finish”按钮，完成导入过程。系统会自
动打开导入后生成的Altium Designer项目，如图14-11所示。

图14-10选择工作空间打开对话框图14-9 Import summary对话框



图14-11导入99SE库文件以

后的项目面板

导入过程完成，下面的步骤是将
导入的99SE库文件生成Altium
Designer的集成库文件。
（4）关闭所有打开的文件。使用
File→New→Project→Integrated
Library创建一个集成元件库项目，并
把他另存在“F:\Altium
Designer9\Protel99se库文件转AD9”
文件夹下文件名：Atmel.LibPkg。
（5）执行Project→Add Existing to 
Project命令，打开“Choose 
Documents to Add to Project”对话
框，找到并选择刚才转换的.SCHLIB文
件（F:\Altium
Designer9\Protel99se库文件转
AD9\Atmel\Sch文件夹），单击打开按
钮如图14-12所示，被选择的文件添加
到项目中了。

图14-12 添加SCHLIB文件



（6）重复（5）步，把4个.SCHLIB的文件添加完。

（7）重复（5）步，选择刚转换的.PCBLIB文件，将其添加
到项目中，如图14-13所示。

图14-13 添加了SCHLIB、PCBLIB文件



（8）执行Project→Project Options命令，打开如图14-14所
示的对话框，并打开其中的Search Paths选项卡。

图14-14 打开Search Paths选项卡

（9）单击Add按钮，打开“Edit Search Path”的对话框。点击
“ ”按钮，弹出对话框，选择.PCBLIB所在的文件夹(如图14-
15所示)，按“OK”按钮，返回上一对话框，单击 “ ”按
钮，确认所选择文件夹是否正确，然后点击OK按钮关闭对话框
(如图14-14所示)。

图14-15选择.PCBLIB所在的文件夹



（10）在图14-14所示的对话框中，选中Error Reporting标
签，设置所需要的内容，单击OK按钮关闭对话框，本例

选择缺省值。

（11）保存这4个原理图库文件。在Projects面板上选择一个
原理图库文件.SCHLIB，按保存按钮，弹出“File Format”
对话框，如图14-16所示，选择SCH Library Version 5.0
单选按钮，按OK按钮。

保存Atmel Pcb.PCBLIB图库文件，选择PCB Library 
Version 5.0（Altium Designer），按OK按钮。

图14-16 Altium Designer认识的原理图格式



（12）选择Project → Compile Integrated 
Library Atmel.LibPkg，编译完成后自动打开
库元器件编辑界面。这样Altium Designer就
在“F:\Altium Designer9\Protel99se库文件转
AD9\Project Outputs for Atmel”文件夹下生成
了一个集成元件库：Atmel.IntLib。打开
Libraries面板，就会发现在库列表中所生成

的库即为当前库，在该列表下面，会看到每
个器件名称都对应一个原理图符号和一个
PCB封装，如图14-17所示。

Protel99SE的库文件就转换为Altium
Designer的集成库文件了。

同理，如果要用自己做的元器件库时，
也必须在第5步骤之前完成.SCHLIB
和.PCBLIB，然后再从第5步骤开始。如果要
修改元件库，可以在.SCHLIB或.PCBLIB中修
改后，再从第5步骤开始。

图14-17 Protel99SE
的库文件就转换为

Atmel.IntLib



14.2 将Altium Designer的元件库转换成99SE的格式

Altium Designer的库文件是以集成库的形式提供的，
而Protel 99SE的库文件是DDB的形式。它们之间转换需要
对Altium Designer的库文件作一个分包操作。

具体步骤如下：

（l）打开一个要转换的Altium Designer 的库文件。以
\Altlum Designer winter 09\Library\Miscellaneous 
Devices.IntLib为例，将该文件拷贝到“F:\Altium
Designer9\AD9库文件转99SE”文件夹下，双击
“Miscellaneous  Devices.IntLib”文件会弹出“Extract 
Sources or Install”的对话框。

（2）选择“Extract Sources”选项。生成了
Miscellaneous Devices.LibPkg，软件自动跳转到项目编
辑界面，如图14-18所示。



（3）将项目中的PCB库文件保存为99SE格式

选择Miscellaneous Devices.PCBLIB库文件，执行File→ Save As命令，
弹出Save对话框，选择要保存的文件夹，在保存类型中选择“PCB 4.0 
Library File(*.lib）”，这是 99SE可以导入的格式，如图14-19所示。

重复上述步骤，选择Miscellaneous Devices.SCHLIB库文件，在保存
类型中选择“Schematic binary 4.0 library(*.Lib)”，这是99SE可以导入的格
式。

完成了将Altium Designer的库文件转换成99SE的格式。

图14-18跳转到项目编辑界面

图14-19选择PCB保存的类型为99SE可以导入的类型



14.3 将99SE设计的文件导入Altium Designer中
Protel 99SE将所有设计文件（原理图和PCB文件等）

保存在一个单独的DDB文件中，本节主要介绍Protel
99SE的DDB文件如何导入到Altium Designer环境中。将
Protel 99 SE的例子“4 Port Serial Interface.ddb”拷贝到
“G:\Altium Designer9\99SE文件转AD9”文件夹下，以他

为例进行介绍。

（1）直接双击“4 Port Serial Interface.ddb”文件，自
动执行Altium Designer软件，显示“Protel 99 SE DDB 
Import Wizard”对话框。

（2）点击Next按钮，弹出要导入文件或文件夹的对话
框，如图14-20所示，用户可以使用向导将一个DDB或者
含有多个DDB的文件夹进行导入。选择File to Process选
项下方的Add按钮，弹出“Open protel 99 SE design file”
对话框，选择需要导入的“4 Port Serial Interface.ddb”文
件，如图14-20所示。



图14-20 选择导入文件或文件夹对话框

（3）点击Next按钮，系统弹出文件输出设置对话框，选
择一个输出文件夹，如图14-21所示。

图14-21 文件输出设置对话框



（4）点击Next按钮，系统弹出原理图转换设置对话框，如
图14-22所示。使用该设置对话框可以控制原理图怎样转换成新
的格式，选择Convert Schematic documents to current file 
format（转换原理图文件至目前文件格式）选项的复选框，有
以下连接点导入方式的三种选择方法：Lock All Auto-Junctions
（锁定所有自动连接点）；Lock X-Cross Junctions Only（锁
定X方向的连接点）；Convert X-Cross Junctions（转换X方向
的连接点）；选择Lock All Auto-Junctions单选按钮。

图14-22 原理图转换设置对话框



（5）点击Next按钮，系统弹出导入设置对话框，如图14-23所示。使
用该设置对话框可以选择DDB文件转换为Altium Designer项目的方式。

Create one Altium Designer project for each DDB（为每个DDB文件
创建一个Altium Designer项目）。

Create one Altium Designer project for each DDB Folder（为每个
DDB文件夹创建一个Altium Designer项目）。

Include non-Protel file(such as PDF or Word)in created Projects(以
及是否在项目中创建PDF或者Word说明文档)。

图14-23 选择DDB文件转换为Altium Designer项目的方式

用户可以根据自己使
用DDB的需要选择合适的
选项，如图14-23所示。



（6）点击“Next”，出现选择导入设计文件的对话框，如
图14-24所示。

（7）确认无误后，按Import All按钮，再点击“Next”按
钮，弹出图14-25对话框。

图14-24 导入文件及导入文件所

在文件夹对话框
图14-25 预览项目创建对话框



（8）在图14-25中显示了Protel 99SE的“4 Port Serial 
Interface.ddb”文件将转换成Altium Designer的具体项目，点
击Next按钮，弹出图14-26导入总结对话框。

（9）在图14-26中显示源文件导入一个DDB文件，输出
文件产生一个工作区、PCB项目文件。点击“Next”按钮，系
统进入导入过程，导入完成后，显示图14-27对话框。

图14-26导入总结对话框 图14-27 导入完成显示打开工作空间对话框



（10）在图14-27对话框中，选择该对话中列表内的新建的工作空间，单
击“Next”按钮，出现“Protel 99 SE DDB Import Wizard is complete”对
话框，点击“Finish”按钮，完成导入过程，系统自动打开导入后的“4 
Port Serial Interface_1.PrjPCB”，如图14-28所示。

图14-28  Protel 99SE的DDB文件成功导入Altium Designer

（11）在Altium
DesignerWinter 09编
辑窗口内，即可对导
入的“4 Port Serial 
Interface_1.PrjPCB”
的原理图文件、PCB
文件、库文件等进行
编辑。完成了Protel
99SE到Altium
Designer Winter 09的
转换。



14.4 将Altium Designer设计的文件转换为99SE格式

下面以用户在第9章设计的数码管显示电路为例，进行“Altium Designer
软件设计的文件转换成Protel 99SE的格式”介绍。

(1)启动Altium Designer软件，打开“数码管显示电路.PcbDoc”文件，执
行File→ Save As命令，弹出保存文件对话框，选择将要存放99SE格式的
文件夹，在保存类型中选择“PCB 4.0 Binary File(*.pcb）”，这是 99SE可以
导入的格式，如图14-29所示。

(2)打开“数码管显示电路.SchDoc”文件，执行File→ Save As命令，弹
出保存文件对话框，选择将要存放99SE格式的文件夹，在保存类型中选择
“Schematic binary 4.0(*.sch）”，这是 99SE可以导入的格式，如图14-30所
示。

即完成了Altium Designer环境下设计的原理图及PCB文件转换为Protel
99 SE的格式。

图14-29 保存为99SE可以认识的PCB格式 图14-30 保存为99SE可以认识的sch格式



（3）启动Protel 99 SE软件，执行File→Open命令，弹
出打开文件对话框，选择需要打开的文件，如图14-31所示。

（4）按“打开”按钮，即可显示转换到Protel 99 SE的文
件，如图14-32所示。

图14-31 选项打开的文件

图14-32 Altium Designer设计的PCB板转换为Protel 99SE的格式



小结：

14.1 将Protel 99SE器件库导入Altium Designer中
14.2 将Altium Designer的元件库转换成99SE的格式

14.3 将99SE设计的文件导入Altium Designer中
14.4 将Altium Designer设计的文件转换为99SE格式
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